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NOTICES 

COPYRIGHT AND TRADEMARKS 

Copyright ©2015 Christie Digital Systems USA Inc. All rights reserved.

All brand names and product names are trademarks, registered trademarks or trade names of their respective holders.

GENERAL

Every effort has been made to ensure accuracy, however in some cases changes in the products or availability could occur which may not be 
reflected in this document. Christie reserves the right to make changes to specifications at any time without notice. Performance specifications 
are typical, but may vary depending on conditions beyond Christie's control such as maintenance of the product in proper working conditions. 
Performance specifications are based on information available at the time of printing. Christie makes no warranty of any kind with regard to this 
material, including, but not limited to, implied warranties of fitness for a particular purpose. Christie will not be liable for errors contained herein 
or for incidental or consequential damages in connection with the performance or use of this material. Canadian manufacturing facility is ISO 9001 
and 14001 certified.

WARRANTY

Products are warranted under Christie’s standard limited warranty, the complete details of which are available by contacting your Christie dealer 
or Christie. In addition to the other limitations that may be specified in Christie’s standard limited warranty and, to the extent relevant or 
applicable to your product, the warranty does not cover:

a. Problems or damage occurring during shipment, in either direction.

b. Projector lamps (See Christie’s separate lamp program policy).

c. Problems or damage caused by use of a projector lamp beyond the recommended lamp life, or use of a lamp other than a Christie lamp 
supplied by Christie or an authorized distributor of Christie lamps.

d. Problems or damage caused by combination of a product with non-Christie equipment, such as distribution systems, cameras, DVD players, 
etc., or use of a product with any non-Christie interface device.

e. Problems or damage caused by the use of any lamp, replacement part or component purchased or obtained from an unauthorized 
distributor of Christie lamps, replacement parts or components including, without limitation, any distributor offering Christie lamps, 
replacement parts or components through the internet (confirmation of authorized distributors may be obtained from Christie).

f. Problems or damage caused by misuse, improper power source, accident, fire, flood, lightening, earthquake or other natural disaster.

g. Problems or damage caused by improper installation/alignment, or by equipment modification, if by other than Christie service personnel or 
a Christie authorized repair service provider.

h. Problems or damage caused by use of a product on a motion platform or other movable device where such product has not been designed, 
modified or approved by Christie for such use.

i. Problems or damage caused by use of a projector in the presence of an oil-based fog machine or laser-based lighting that is unrelated to the 
projector.

j. For LCD projectors, the warranty period specified in the warranty applies only where the LCD projector is in “normal use” which means the 
LCD projector is not used more than 8 hours a day, 5 days a week.

k. Except where the product is designed for outdoor use, problems or damage caused by use of the product outdoors unless such product is 
protected from precipitation or other adverse weather or environmental conditions and the ambient temperature is within the 
recommended ambient temperature set forth in the specifications for such product.

l. Image retention on LCD flat panels.

m.Defects caused by normal wear and tear or otherwise due to normal aging of a product.

The warranty does not apply to any product where the serial number has been removed or obliterated. The warranty also does not apply to any 
product sold by a reseller to an end user outside of the country where the reseller is located unless (i) Christie has an office in the country where 
the end user is located or (ii) the required international warranty fee has been paid.

The warranty does not obligate Christie to provide any on site warranty service at the product site location.

PREVENTATIVE MAINTENANCE

Preventative maintenance is an important part of the continued and proper operation of your product. Please see the Maintenance section for 
specific maintenance items as they relate to your product. Failure to perform maintenance as required, and in accordance with the maintenance 
schedule specified by Christie, will void the warranty.

REGULATORY

The product has been tested and found to comply with the limits for a Class A digital device, pursuant to Part 15 of the FCC Rules. These limits 
are designed to provide reasonable protection against harmful interference when the product is operated in a commercial environment. The 
product generates, uses, and can radiate radio frequency energy and, if not installed and used in accordance with the instruction manual, may 
cause harmful interference to radio communications. Operation of the product in a residential area is likely to cause harmful interference in which 
case the user will be required to correct the interference at the user’s own expense.
CAN ICES-3 (A) / NMB-3 (A)
이 기기는 업무용 (A급 )으로 전자파적합등록을 한 기기이오니 판매자 또는 사용자는 이점을 주의하시기 바라며 , 가정 외의 지역에서 사용하는 것을 
목적으로 합니다 .

Environmental

The product is designed and manufactured with high-quality materials and components that can be recycled and reused. This symbol  means that electrical 
and electronic equipment, at their end-of-life, should be disposed of separately from regular waste. Please dispose of the product appropriately and according to 
local regulations. In the European Union, there are separate collection systems for used electrical and electronic products. Please help us to conserve the 
environment we live in!



Software Licensing Agreement

Agreement

a. This Software License Agreement (the “Agreement”) is a legal agreement between the end user, either an individual or 
business entity, (“Licensee”) and Christie Digital Systems USA, Inc. (“Christie”) for the software known commercially as 
Christie® AutoStack™ that accompanies this Agreement and/or is installed in the server that Licensee has purchased 
along with related software components, which may include associated media, printed materials and online or 
electronic documentation (all such software and materials are referred to herein, collectively, as “Software”). If 
Licensee does not accept the terms of this Agreement, Licensee will return the Software to Christie in accordance with 
Christie's standard return policy in place from time to time. BY DOWNLOADING, INSTALLING, ACTIVATING OR 
USING THE SOFTWARE, THE LICENSEE IS AGREEING TO BE BOUND BY THE TERMS OF THIS AGREEMENT.

b. The Software contains third party software programs which require notices and/or additional terms and conditions. 
Such required third party notices and/or additional terms and conditions are located in the Software install location 
(C:\ProgramFiles\Christie Digital Systems\AutoStack\Licenses). By accepting this Agreement and using the Software, 
you are also accepting any such additional terms and conditions applicable to the third party software programs. To the 
extent any license for third party software programs requires an offer to provide source code for those third party 
software programs, this Agreement constitutes such an offer. You may request more information or a copy of such 
source code by contacting Christie at open.source@christiedigital.com. In conjunction with such request, provide the 
Christie Product Number, the Software version and the Product Serial Number (if applicable). If applicable, a nominal 
cost to cover shipping and media charges will be charged.

License and Restrictions

c. Ownership of Software: Christie retains title and ownership of all rights, including copyright and all other intellectual 
property rights, in and to the Software and all copies thereof, regardless of form or media. This license is not a sale of 
any rights in or to the Software or any copy thereof. Licensee acquires no right whatsoever to the Software except the 
right to use the Software in accordance with the terms of this License. 

d. Grant of License: Christie grants to Licensee a single license providing a nonexclusive and non-transferable right to use, 
for personal or internal business purposes, the executable version of the Software, as long as Licensee complies with 
the terms and conditions of this License. Christie reserves all rights not expressly granted to Licensee. 

e. Copy Restrictions: Where the Software is provided for download onto a personal computer or similar device, Licensee 
may make as many copies of the Software as is reasonably required for Licensee's own use with the Device. Licensee 
may also make a backup copy of the Software which may be used only for reinstallation of the Software. Where the 
software is pre-installed on a server, Licensee may keep one copy of the Software solely for backup or archival 
purposes. Unauthorized copying or distribution of the Software is expressly prohibited unless agreed to in writing by 
Christie. Licensee must reproduce and include the copyright notice on any backup copy of the Software. Licensee may 
not remove or alter any proprietary rights or copyright notice or identification which indicates the ownership of the 
Software. 

f. Use Restrictions: Licensee will not (a) modify, adapt, decompile, disassemble, reverse engineer, or otherwise attempt 
to derive the source code for the Software, or create derivative works based on the Software; (b) assign this 
Agreement or redistribute, encumber, sell, transfer, lease, or grant a sublicense of the Software or the license granted 
herein or otherwise transfer rights to the Software to any person or entity except as and when expressly permitted by 
this Agreement; (c) directly or indirectly, export or transmit the Software, either alone or bundled with other software, 
to any country to which such export or transmission is restricted by any applicable laws without the appropriate prior 
written consent of the applicable government entity or department; and (d) publish or otherwise disclose the Software 
for others to copy. Licensee will make reasonable efforts to prevent any unauthorized use of the Software by third 
parties and will advise Licensee's employees of the restrictions upon use restrictions herein.

g. Upgrades and Updates: While Christie is not required to do so, Christie may provide Licensee with upgrades or 
updates to the Software, including but not limited to files that are delivered to Licensee via online transmission or 
otherwise to “patch” or otherwise modify or enhance the software program. This Agreement covers any upgrades or 
updates to the Software that Licensee may obtain from Christie or one of its authorized vendors, unless the upgrade or 
update comes with its own license agreement. If Licensee decides not to download or install an upgrade or update 
provided by Christie, Licensee understands that this could put the Software at risk to serious security threats or cause 
the Software to become unstable. Christie may, at its option, cause an upgrade or update to apply automatically.

Maintenance and Support

h. Christie may, in its sole discretion and without any obligation, provide maintenance and support services related to the 
Software (“Support Services”). Support Services are governed by Christie’s policies and programs described in 
materials available from Christie. Any supplemental software code provided to Licensee as part of the Support Services 
will be considered part of the Software and subject to the terms and conditions of this Agreement. 

Warranty and Limitation of Liability

i. No Warranties: The Software is provided “as is” and Christie makes no warranty of any kind with regard to the 
Software. Christie will not be liable for errors contained in the Software or in connection with the performance or use 
of the Software. Christie does not warrant that the Software is free from any defects or that it will operate 
uninterrupted. Christie warrants that the media on which the Software is distributed will be free from defects in 



materials and workmanship under normal use for a period of ninety (90) days from the date of delivery. Christie will 
replace any defective media returned to Christie within the ninety (90) day period. The foregoing is Licensee’s sole and 
exclusive remedy for breach of the warranty given pursuant to this Section. Christie does not make any other 
warranties, either express or implied, including, but not limited to, implied warranties of merchantability, fitness for a 
particular purpose, title and non-infringement with regard to the Software.

j. Limitations of Liability: IN NO EVENT WILL CHRISTIE BE LIABLE TO ANY PARTY FOR DIRECT, INDIRECT, SPECIAL, 
INCIDENTAL, OR CONSEQUENTIAL DAMAGES, INCLUDING LOST PROFITS, LOST REVENUES AND LOST DATA 
ARISING OUT OF THE USE OF THIS SOFTWARE AND ITS DOCUMENTATION, EVEN IF CHRISTIE HAS BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGE.
CHRISTIE SPECIFICALLY DISCLAIMS ANY WARRANTIES OR CONDITIONS, INCLUDING, BUT NOT LIMITED TO, THE 
IMPLIED WARRANTIES OR CONDITIONS OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE 
SOFTWARE AND ACCOMPANYING DOCUMENTATION, IF ANY, PROVIDED HEREUNDER IS PROVIDED “AS IS”. 
CHRISTIE HAS NO OBLIGATION TO PROVIDE MAINTENANCE, SUPPORT, UPDATES, ENHANCEMENTS, OR 
MODIFICATIONS.
CHRISTIE FURTHER DISCLAIMS ANY AND ALL REPRESENTATIONS RELATING TO THIRD PARTY SOFTWARE WHICH 
IS EMBEDDED IN THE SOFTWARE. Some jurisdictions do not allow exclusions or limitations of certain conditions or 
warranties. Only those exclusions or limitations that are lawful in Licensee’s jurisdiction will apply to Licensee and, in 
such instances, Christie’s liability will be limited only to the maximum extent permitted by law.

Termination

k. Christie may terminate this Agreement at any time and for any reason. Christie may also terminate this Agreement if 
the Licensee breaches or is in default of any obligation of Licensee under this Agreement. Upon termination of this 
Agreement, the Licensee will immediately (i) cease using the Software and (ii) uninstall the Software from any personal 
computers, servers or other devices (to the extent it is installed thereon). The Licensee’s obligation under this provision 
will survive the termination of this Agreement. 

General

l. Notices: Unless otherwise set forth in this Agreement, all notices, or other communications hereunder will be deemed 
to have been duly given when made in writing and delivered in person, by courier or deposited in the mail, postage 
prepaid, and registered mail, return receipt requested, and addressed to Licensee at the billing address supplied to 
Christie by Licensee, and addressed to Christie at Christie Digital Systems USA, Inc., c/o Christie Digital Systems 
Canada, Inc. at 809 Wellington Street North, Kitchener, Ontario, Canada N2G 4Y7, with a copy (which will not 
constitute notice) to Christie’s Legal Department at the same address.

m.Severability and Waiver: Any provision of this Agreement which is held by any court to be unenforceable or invalid will 
be deemed severed from this Agreement, without affecting any other provision of this Agreement. No waiver by 
Christie of any particular default or omission committed by Licensee will affect or impair the right of Christie in respect 
of any subsequent default or omission of the same or a different kind. No delay or failure by Christie to exercise any 
rights in connection with any default or omission committed by Licensee will affect or impair Christie’s rights in respect 
of that particular default or omission or any subsequent default or omission of the same or different kind. In any event, 
time will continue to be of the essence without the necessity of specific reinstatement. 

n. Governing Law: This Agreement is governed by the laws of the State of California, without regard to its conflict of law 
principles. Any suit or action arising out of or in connection with this Agreement will be brought in the federal or state 
courts located in Orange County, State of California. Each of Licensor and Licensee hereby irrevocably submit to the 
jurisdiction of such courts for the purpose of such suit or action and expressly and irrevocably waive, to the fullest 
extent permitted by law, any objection it may now or hereafter have to the venue of any such suit or action in any such 
court and any such claim that any suit or action has been brought in an inconvenient forum.
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Install and Set up 
Christie AutoStack

This section provides information and procedures for installing and setting up Christie AutoStack.

Hardware recommendations
• Computer:

• Intel or compatible processor (Intel Core i7-4700 or better recommended)

• 200 MB of free disk space

• 4 GB of RAM

• A true color (32 bit) display with a minimum resolution of 1024 x 768

• 1Gbps Ethernet port and network

• Network:

• 1 unmanaged Gigabit Ethernet switch

• 1 Ethernet cable to connect the computer to the network switch

• 1 Ethernet cable for each projector

• 1 Power over Ethernet (PoE) injector (if using a PoE camera)

Software recommendations
• Computer operating system: 

• Microsoft Windows 7 SP 1

• Microsoft Windows 8

• Supported projectors and software:

• Christie M series projectors must have Main Software version 2.3.0 or later installed

• Christie StIM WU projectors must have Main Software version 1.4.5 or later installed

• Christie StIM WQ projectors must have Main Software version 1.2 or later installed

• Christie J Series projectors must have Main Software version 1.1.0 or later installed

• Christie D4K series projectors must have Main Software version 1.3 or later installed

• Christie Boxer projectors must have Main Software version 1.0.0 or later installed

• Adobe Reader 11 or later

• Christie Twist 2.0 Pro or later
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   Install and Set up Christie AutoStack
Camera recommendations
Christie AutoCal must be used with one of the following calibrated cameras provided by Christie 
Digital:

• 3.2MP USB3 Point Grey Flea 3 USB FL3-U3-32S2M-C (recommended)

• 5.0MP GigE Point Grey Flea 3 FL3-GE-50S5M-C

• 1.2MP USB2 Point Grey Chameleon CMLN-13S2M

• 2.0MP GigE Point Grey Flea 3 FL3-GE-20S4M-C

• 5.0MP Mono GigE PoE Point Grey Blackfly BFLY-PGE-50H5M-C

To use the Power over Ethernet (PoE) functionality of this camera, a PoE injector or PoE enabled 
hub or router is required. If the camera cannot be located on the network, use a PoE injector to 
connect the camera to the control computer, or connect the camera to a PoE enabled hub or 
router.

Connect projectors to the control computer
To use Christie AutoStack, a minimum of one camera and one Christie AutoStack-enabled projector 
must be connected to the control computer. 

1. Connect a computer to a network switch with an Ethernet cable or use a wireless connection.

A wireless connection is not recommend with network (GigE) cameras.

2. Connect an Ethernet cable from each projector to the network switch.

3. If you are using network (GigE) cameras, connect each camera to the network switch.

For optimum performance, connect each network (GigE) camera to an unmanaged switch. 
Do not connect network (GigE) cameras to a managed switch.

Assign a projector ID
This procedure is optional, but can help identify projectors when troubleshooting.

1. Press Menu on the keypad or the remote.

2. Select 4 Configuration.

3. Select 7 Communication.

4. Select 4 Projector Address.

5. Specify a unique identification number.

6. Press Menu.
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   Install and Set up Christie AutoStack
Add the projector to the network
Alternative network routing options can cause time-outs and interfere with software functionality.

1. Press Menu on the keypad or the remote.

2. Select 4 Configuration.

3. Select 7 Communication.

4. Select 5 Network Routing.

5. Select 1 Separate. 

6. Press the Menu.

Assign a projector port number
When you add projectors to a configuration, you can search all available ports or specify a specific 
port. To associate a projector with a specific port, you must know the port number.

1. Press Menu on the keypad or the remote.

2. Select 4 Configuration.

3. Select 7 Communication.

4. Select 5 Ethernet Settings.

5. Make sure the correct port number is displayed.

6. Press the Menu.

Connect cameras
Cameras are connected to a network hub with an Ethernet or a USB connection. The network hub is 
connected to the control computer.
To use Christie AutoStack, a minimum of one camera and one Christie AutoStack-enabled projector 
must be connected to the control computer. Every camera connected to the control computer must 
have a valid IP address and be accessible on the local network. 
Tools provided by the camera manufacturer are installed in the Christie AutoStack folder in the 
Windows Start menu. Typically, cameras work correctly with Christie AutoStack without modifying 
their settings. If you need to modify camera settings, see the documentation provided by the 
camera manufacturer or visit their website. If a camera is not working correctly, see Unable to 
connect a camera on page 27.
When using a USB connection to connect cameras, use the cable supplied with the camera or a high 
quality equivalent. To determine what extenders or hubs are supported, see the supplier web site.
Cameras that use a USB 3.0 connection must be connected to a USB 3.0 port with a USB 3.0 cable. 
Typically, USB 3.0 ports are blue and are identified with USB 3.0 SS symbol.
Cameras without power supplies can receive power through the USB cable.
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Install camera drivers
Use the Christie AutoStack installation wizard to install Christie AutoStack and the camera drivers. 
Christie recommends that you only install the drivers for the cameras connected to the control 
computer. Installing multiple drivers from different manufacturers can cause software conflicts and 
prevent the cameras from working correctly. 
See Install Christie AutoStack on page 10.

Uninstall previous software versions
If you are using older projectors, you can install Christie AutoStack 4.1 without removing an 
existing Christie AutoStack 2.0 installation.

1. Click Start > Control Panel. 

2. Click Programs and Features.

3. Right-click Christie AutoStack and click Uninstall. 

4. Click Yes.

Install Christie AutoStack
If a restart prompt appears during the installation, select No and restart the computer when the full 
Christie AutoStack installation is complete.

1. Insert the installation media or download the application from the Christie website. 

2. If the installation does not start automatically, click Start > Computer. Browse to the CD-ROM 
drive and double-click the setup.msi file that matches your Windows version.

3. Click Next when the Setup Wizard appears.

4. Select the I accept the terms in the License Agreement. Click Next.

5. Click Install.

Start Christie AutoStack 
Click Start > All Programs > Christie > AutoStack 4.1 > AutoStack 4.1. 
To create a new configuration, click New. 
To open an existing configuration, click Open, browse to the location of the configuration file 
(*.stack), select it, and click Open.

Licensing
A license is required to activate Christie AutoStack features. To view the features that are currently 
active, click the Help tab and then click View.
To activate Christie AutoStack Standard or Premium, insert the dongle into the USB port of the 
computer on which you will manage Christie AutoStack settings before opening Christie AutoStack. 
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Guided setup
Select Guided Setup on the File tab to be guided through a quick configuration setup. To manually 
add a configuration, click New.

Uninstall Christie AutoStack
1. Click Start > Control Panel. 

2. Click Programs and Features.

3. Right-click Christie AutoStack 4.1 and select Uninstall.

4. Click Yes.

Technical support
North and South America: +1-800-221-8025 or tech-support@christiedigital.com
Europe, Middle East, and Africa: +44 (0) 1189 778111 or techsupport-emea@christiedigital.com
Asia Pacific: tech-asia@christiedigital.com

Bonjour, Microsoft Visual C++ 2010 and 2012 Redistributables, and 
Microsoft .NET Framework 4 may be used by other programs and are not 
uninstalled by the wizard. To uninstall these programs, see Uninstall 
previous software versions on page 10. 
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Manage Projectors

When you add projectors to your configuration, they appear in the Projector panel. Use the 
Projector panel to view information about connected projectors.   
To view the details about a projector expand the Details list.
To add a projector, you need the IP address, and the port number. To identify the IP address and 
port number, press MENU > 4 CONFIGURATION > 7 COMMUNICATIONS > 5 ETHERNET 
SETTINGS.
To reorder the projectors, select a projector and click Move Up or Move Down. 
To remove a projector from the list, select it and click Remove. 
To rename a channel, double-click the Name and enter a new one. 

Add a projector to a configuration by searching
1. Start Christie AutoStack. See Start Christie AutoStack on page 10.

2. Click New on the File tab.

3. Click Projector in the left pane.

4. Click Add in the lower left pane.

5. Click the Broadcast tab.

6. Select Default in the Port Number area to search for a projector with a default port setting.

7. or

8. Select Custom and enter the custom port number for the projector.

9. Click Search.

10. Select projectors in the Search Results list.

11. Click OK.

Manually add a projector to a configuration
Use this procedure if your projectors cannot be detected automatically, or are not on the same 
subnet. To manually add a projector to a configuration, you must provide the projector IP address 
and port.

1. Start Christie AutoStack. See Start Christie AutoStack on page 10.

2. Click New on the File tab.
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3. Click Projector in the left pane.

4. Click Add in the lower left pane.

5. Click the Manual tab.

6. Complete the IP Address field.

7. Click Search.

8. Select the projector in the Search Results list.

9. Click OK.
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Manage Cameras

This section provides information and procedures for managing cameras. 

Add a camera
Use the Camera panel to locate cameras, add them to your configuration, and change exposure 
and binarization settings.

1. Click Add.

2. Select a camera. 

If you have recently connected a new camera, click Refresh to see it. 

3. Click OK.

When a camera is added, a preview of the camera image appears in the image preview. 

Remove a camera
Select a camera and click Remove. 

View camera details
Expand the Details list in the Camera panel. 

The Details area displays information about the camera and network information including the IP 
address, the subnet mask, and the MAC address. It also shows the name of the camera Profile. 

Manage camera profiles
Camera profiles are stored on the camera. A camera profile defines the technical characteristics of a 
camera and its lens. The camera calibration process defines the position and orientation parameters 
of a camera.

If you attempt to add a camera without a profile, it is unavailable in the Camera panel or the Select 
Camera dialog.

1. On the File tab, click Manage. 
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   Manage Cameras
2. To add a camera profile, click Add.

3. In the Open File dialog, browse to the file (.xml) containing the camera profile, select it, and 
click Open.

4. Click OK.

Set camera exposure and binarization 
You use the Camera panel to set the exposure and binarization of your camera(s). 

Binarization defines the threshold of the black (dark) and white (bright) pixels of the captured 
image. The ideal binarization is when the image’s background noise is minimized and all grid points 
are fully captured. 

When a binarized image is taken, the projector(s) in the system display a black background with a 
white grid. (If Camera Markers are selected, the camera visible markers are turned on to select a 
correct binarization and exposure value to detecting these markers). 

When a single camera and projector are activated, you can adjust the binarization threshold and 
camera exposure of the selected camera. 

By default, Christie AutoStack determines exposure and binarization settings automatically. Before 
making changes to these settings, make sure that: 

• the screen is defined

• the required cameras are imported and activated

• the required channels are imported and activated

• channel extents are defined

• all points are mapped

Adjust camera exposure and binarization
The settings described in this procedure are applied to the selected camera and not all cameras.

1. Make sure at least one camera is connected and one channel is selected.

2. Expand the Camera panel. 
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3. Select one of these options:

• Automatic - Automatically adjusts exposure and binarization.

• High Contrast - Automatically adjusts exposure and binarization by using a slower test 
pattern to improve image processing and contrast. This setting is recommended when 
the camera view of the projector dots has poor contrast or some areas are brighter than 
others.

• Manual - Manually adjusts binarization.

• In the Marker Type list, select Projector Dots to change the projector grid 
settings or Screen Markers to change the camera calibration marker settings.

• Drag the Exposure slider back and forth or click the - and + buttons to adjust the 
amount of time the camera shutter remains open while capturing images.

• Click Thresholding Mode. 

Manually adjust camera settings
If camera alignment, brightness, or focus are not correct, use the zoom in, zoom out, or fit buttons 
at the top of the camera view screen. Image scale can also be adjusted using the mouse wheel.

Calibrate cameras
Before you calibrate your configuration, you must identify points on the screen so that your 
camera(s) are calibrated. 

The camera view is 2-dimensional. To calibrate a camera, you map the 3D points to the 2D points of 
the camera. 

The Calibration panel displays a real-time picture of the camera view. To display or hide windows, 
select one of the buttons in the upper-right corner.     

Locate corners
Christie AutoStack can automatically locate the corners of your screen. This feature works best for 
planar rectangular screens. 

To locate the corners, follow these recommendations:

• The screen has a well-defined border with a high degree of contrast between the screen area 
and the border.

• There are no objects between the camera and the screen that would obscure the camera’s view.

When using multiple cameras, adjust binarization and exposure settings 
individually for each one.
When making adjustments, make sure that you find a balance between 
the correct exposure and binarization threshold until all ambient light is 
filtered out and the image displayed shows only the grid points in their 
sharpest context. It is essential to avoid losing points when making 
adjustments.
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• The camera aperture is set so the image is visible, but not over exposed.

• The camera focus has been adjusted to provide a clear, sharp image.

• The center of the camera view is in the center of the screen. 

• The entire screen must be visible to the first camera. 

To find corners, on the Home tab, click Find Corners.

After Christie AutoStack has searched for corners, it displays blue dots at the corners of your screen 
in the Camera view window. It also shows blue lines along the edge of the screen. If you selected 
one of the Cylindrical options, then blue circles appear on the top and bottom of your screen area to 
show the curved edges of your screen.

In some cases, Christie AutoStack might not be able to find the corners of your screen. If the 
corners are not where you want them:

1. Move the corners to match your screen by clicking and dragging the blue circles. When you click 
a dot to select it, it turns yellow. While you are dragging a dot, it appears as a hollow blue 
circle. Drag all 4 red circles to the desired locations, and then observe the blue box to see if it is 
where you want it.

2. For fine adjustments to corner locations, press and hold the CTRL key. A zoom window 
appears, allowing you to drag a circle by small increments. 

Press CTRL + the arrow keys to move a selected circle by 10 pixels. To move a circle by 1 pixel, 
Press CTRL + SHIFT + the arrow keys. Release the CRTL key to close the zoom window.

Confirm layout
After adding and adjusting points, verify that the calibration is set up correctly.

On the Home tab, Christie AutoStack superimposes the boundary of the screen section and 
channels that the camera sees.

1. On the Home tab, click Confirm Layout. Christie AutoStack switches to Camera view. 
Warping/blending is turned off, a white test pattern is displayed on all screens and a red 
bounding box is superimposed for each channel in the image. A blue bounding box represents 
the defined screen.

2. Confirm that the blue lines trace the outline of your screen and the red lines outline where you 
want your channels to be. 
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• If the red bounding box is not within the white test pattern, then image will not be 
displayed within the target position. 

• If the blue outline does not match the layout of the physical screen, then you should re-
calibrate the camera, adjust the horizontal and vertical overlaps.

Analyze layout
Analyze your configuration to create a mapping between the camera and projector coordinate 
systems. 

Click the Home tab and click Analyze.

The display area for the projectors (green), the screen area (blue), and the channel extents (red) is 
displayed. 

Run calibration
Before beginning a calibration, make sure that these conditions are true:

• The screen is defined.

• The required cameras are imported and activated.

• The required projectors are imported and activated.

• All points are mapped.

• Camera images are focused

• Manual exposure and threshold values are correct.

• Images are not over exposed.
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To begin a calibration: 

1. On the File tab, click Save to save the current configuration. 

2. Click Run to begin a full calibration. 

To access other run options, select one of these options:

Option Description

Run using 
analyze 
results

If you have already analyzed your setup (by 
clicking Analyze on the Home tab) or performed 
a full calibration (by clicking Run on the Home 
tab), then the mappings between the camera and 
projector coordinate systems may already exist. 
Select this option to use these mappings instead 
of generating them again. Only use this option if 
you have not moved any cameras or projectors 
since the last analysis was done.

Run without 
iterations

Select this option to run a faster calibration by 
disabling iterations for camera-to-projector 
coordinate mapping. If you disable iterations, 
Christie AutoStack will only perform the 
calibration calculation once, which could lead to 
poor results. To configure iteration options, see 
the Options panel.
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Manage the Image 
Position and Layout

This section provides information and procedures for manipulating the displayed image.

Set up screen definitions 
This section outlines procedures for setting up the geometry definitions that define the 
characteristics of the physical projection screen. 
Use the Screen panel to change these settings. 
To zoom in or out, use the mouse wheel. 

Define the layout
A layout defines the location of each channel. A layout must match the parameters of the content or 
image generator. Warps are automatically generated so the projected image matches the specified 
layout. 
Channel layouts are defined by the overlaps between adjacent channels. The projected area of all 
channels will fill the entire screen.

1. Expand the Layout list in the left pane.

2. Select Planar in the Type list.

3. Select a projector orientation in the Orientation list.

The projector orientation must match the projector setting. This feature is only available with 
AutoStack premium.

4. On the Setup list, select a grid layout. 

The number of projectors installed determines what options are available. For example, 
when 2 projectors are active, the drop-down contains the selections 1x2 and 2x1, and 1x1 
(stacked). When four projectors are selected, the list includes 1x1 (stacked), 1x2 
(stacked), 2x1 (stacked), and 2x2. 

5. Enter the horizontal or vertical overlap percentages.

6. To further inset the projected image inward, specify insert percentage values (percentage in 
screen space). A positive inset value will create a black border around the final full image.



Use Christie AutoStack

Read this chapter to learn about Christie AutoStack features, how to use controls, and more. 

View ribbon
Use the View ribbon to customize what the projectors display on screen and what is visible in the 
Christie AutoStack application window.

Camera view

The Camera view shows what is currently visible in your cameras. Use the buttons beside the View 
list and your mouse to adjust the camera view:

• To change the position of the image, click the left mouse button and drag. 

• To zoom in or out, use the wheel button on your mouse or click the zoom in and zoom out 
buttons. 

• Click the capture button to capture an image from the camera. 

• Click the fit button to fit the current image to the camera view window. 
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• Click the pause button to pause the real-time view from the camera.

 The Camera Views area includes these buttons:  

Some of the buttons are only available after completing an analysis.

Projector control ribbon
Use the Projector Control ribbon to send commands to the projector.

Button Description

Calibration Points Shows or hides calibration points around the edge of the 
screen.

Channels Shows or hides the projector display area on the screen 
with the current configuration.

Screen Shows or hides the screen outline.

Screen Grid Shows or hides a grid displayed across the screen that 
shows the screen’s interior shape (red grid).

Projectors Shows or hides the areas that the projectors can display.

Button Description

Power Turns the projector power on or off.

Shutter Opens or closes the projector shutter.

Input Selects the input source for the projector.

Test Pattern Displays or removes a test pattern.

Warp Applies or removes a standard or user-defined warp.

Blend Applies or removes a standard or user-defined blend.

Show/Hide 
Markers

Displays or hides markers.

Virtual Remote Displays the virtual remote application.
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Test pattern ribbon

Use the Test Pattern ribbon to display test patterns and troubleshoot calibration issues.

View network details
Click the  icon in the lower-left corner of the Select Projectors dialog.

Set Christie AutoStack Options
The Options panel allows you to specify warp and blend settings, grid resolution, and projector 
orientation. The information for both warps and blends is stored under one name. You specify 
whether or not you want to include blend calculations.

Warping and blending
1. In the Warping & Blending area, in the Name field, enter the warp/blend name to be sent and 

saved to the projector. 

2. In the Mem Location list, select the memory location of the warp/blend. 

Access a saved warp
To apply a saved warp to the projector, select the projector in the Projector panel, and then select 
the warp in the Warp list on the Projector Control tab. 

1. Press the Menu button on the projector keypad or the remote. Use the up and down arrow 
keys on the project keypad to make selections.

2. Select 4 Configuration. 

3. Select 8 Geometry and Color. 

4. Select 2 Keystone and Warping. 

Button Description

Draw Displays a test pattern on the screen.

Clear Removes a test pattern from the screen.

Grid Density Changes the grid density. 

Line Color Changes the line color.

Fill Color Applies a fill color to the grid test pattern.
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5. Select 1 Warp Select to access a list containing all saved warp locations. Each projector can 
store up to 10 custom warp definitions. Users can select any number from 1 to 10. 

6. Press Menu.

Access a saved blend
To apply a saved blend to the projector, select the projector in the Projector panel, and then select 
the blend in the Blend list on the Projector Control tab. 

1. Press the Menu button on the projector keypad or the remote. Use the up and down arrow 
keys on the project keypad to make selections.

2. Select 4 Configuration. 

3. Select 8 Geometry and Color. 

4. Select 4 Edge Blending. 

5. Select 1 Blending Select to access a drop-down menu containing all saved blend locations. 
Each projector can store up to 5 custom blend definitions. Users can select any number from 1 
to 5. 

6. Press Menu.

Set calibration options
Use these settings to specify calibration options: 

• Do Iterations: Performs calibration calculations repeatedly to refine the calibration. Clear this 
option to have Christie AutoStack use initial calculations only. Iterations improve accuracy, but 
reduce smoothness.

• # of Iterations: Specify the maximum number of iterations Christie AutoStack will perform. 
The default value is 50. Specify a value between 10 and 50. Calibration automatically stops 
when convergence is detected. Lower the iteration number to stop calibration sooner.

• Do Tiling: Select to have the projectors tile the image so that each one shows only its portion 
of a shared input. This option is not supported on all projectors.

Christie Twist
Use these settings to specify Christie Twist-related options. To show these settings, expand 
Options in the left pane, and then expand Twist.

• Twist Filename: Specify the name of the Christie Twist (.twistx) file that you want to use. 

Click the browse button  to select a folder. By default, the folder where you save calibration 
(.stack) files is selected. Also, by default, Christie AutoStack updates the name of the Christie 
Twist file to match the name of the Christie AutoStack file. 

• Grid Size: Specify the number of grid points to be drawn by the projector during calibration 
(the warp resolution sent down to the projector). If you specify a grid size greater than 9, your 
Christie Twist file will only be able to be opened by Christie Twist Pro. 

• Smart Undershoot Handling: When selected, ignores projector undershoot around the 
border when performing blend calculations.
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Projector
Use these settings to specify projector-related options. To show these settings, expand Options in 
the left pane and then click the expand button beside Projector. To manually adjust the settings, 
clear the Automatic checkbox.

• Grid Box Size: Sets the size (in pixels) of grid points that Christie AutoStack draws during 
calibration. 

• Mapper Spacing: Sets the spacing of the grid points used by Christie AutoStack during 
calibration. The value specified is a multiplier of the grid box size.
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Troubleshooting

This section provides information and procedures for resolving common Christie AutoStack issues. 
If you cannot resolve a projector issue, contact Christie Technical Support. For contact information 
see Technical support on page 11. 

View and export diagnostics
When you are troubleshooting Christie AutoStack issues, Christie Technical Support may ask you to 
view diagnostics files, such as log files or images, or send those files to Christie for further analysis. 
Christie AutoStack creates a new folder for diagnostics files each time you run the software. 

View diagnostic files 
Click Help > Diagnostics > View and select one of these files: 

• Crash

• Data 

• Images

• Logs

Export diagnostic files
1. On the Help tab, click the Export button. 

2. Select an Christie AutoStack session and click Export. 

3. Browse to the location where you want to save the zip archive file, and click Save. 

4. Locate the file on your computer. 

The file name begins with “Diags_” and includes the calibration file name (if you have saved 
your calibration) and the session folder name, which includes the date and time when Christie 
AutoStack was launched. 

5. Send the archive zip file to Christie Technical Support. 
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Unable to locate cameras or projectors
• Ensure computer network connectivity.

• Check cable connections (computer, camera, projectors, etc.).

• Make sure that the computer is on the same subnet as the camera/projector.

• Attempt to access the projector’s Web interface. If you can reach it, then enter the IP address 
of the projector on the Manual tab of the Select Projectors dialog. 

• Check the Ethernet firmware version on the projector.

• Make sure that no other Christie software application is running.

• Make sure the Bonjour application is installed and operating correctly. 

Unable to connect a camera
• Make sure the camera is connected to a dedicated router with DHCP enabled. The camera 

should be assigned an IP address automatically.

• If the camera is connected to a network hub or router with Power over Ethernet (PoE), make 
sure PoE is enabled on the on the hub or router port. To enable PoE on the hub or router port, 
see the documentation included with the hub or router.

• If you are using a PoE camera, connect it to a PoE injector.

If the Point Grey Flea3 or Black Fly PoE cameras cannot be detected on the network, use this 
procedure.

1. Disable all wireless network connections.

2. Connect one end of an Ethernet cable to the camera.

3. Connect the other end of the Ethernet cable into the network port of the computer running the 
Christie AutoStack application.

4. Click Start > Programs > Christie > AutoStack 4.1 > Point Grey Utilities > GigE 
Configurator.

5. Select your camera in the left pane.

6. Click Automatically Force IP.

7. If your cameras use static IP addresses:

• Enter the network settings for the camera.

• Select LLA & Persistent IP.

• Click Set IP Address/Subnet.

If your cameras use dynamic IP addresses:

• Select LLA & Persistent IP.

• Select DHCP.

• Click Set IP Address/Subnet

8. Click Test Camera Connection.
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9. Reconnect the camera to the network.

10. Click Test Camera Connection.

11. If the camera is not recognized, see the documentation provided by the camera manufacturer 
for diagnostic information. 

Intermittent camera connection
The primary symptom of this issue is the live camera preview being intermittently replaced by a 
checkerboard pattern and Christie AutoCal calibration failing. The Christie AutoCal application 
automatically attempts to recapture the image. The appearance of the checkerboard pattern during 
setup or when adjusting cables, is not always indicative of a problem.

Resolving this issue with network (GigE) cameras installed
1. Complete the Unable to connect to a camera procedure. See Unable to connect a camera on 

page 27.

2. Make sure the Point Grey filter driver is installed:

a. Click Start > All Programs > AutoStack 4.1 > Point Grey Utilities > GigEConfigu-
rator.

b. Click Firewall and Filter Driver Settings in the left pane.

c. Make sure the Install Filter Driver and Enable Filter Driver checkboxes are selected.

If the checkboxes are not selected, install the filter driver. the correct location for the 
installation is: C:\Program Files\Christie Digital Systems\AutoStack 
4.1\PointGrey. When the installation is complete, the Filter Driver Status area will 
display Point Grey Filter Driver: Installed.

3. If you cannot install the filter driver:

a. Click Start.

b. Type regedit in the Search programs and files field and press Enter.

c. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network.

d. Double-click MaxNumFilters in the right pane.

e. Type 14 in the Value data field.

f. Click OK.

g. Repeat step 2.

Resolving this issue with USB cameras installed
Christie recommends that you restart the computer after each troubleshooting attempt.

• Move the USB cable side to side and up and down. If this movement causes dropped frames, 
make sure the USB cable is attached correctly or replace the USB cable.

• Connect the USB cable to a different USB port on the control computer.
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• Replace the USB cable.

• Install a shorter USB cable.

• Install a USB hub between the control computer and the camera.

Projector unresponsive
• Check power.

• Check cable connections.

• Check ability to search for projectors.

Invalid calibration file loaded
A .stack file is valid when all of the following conditions have been met:

• The selected camera is currently on the network.

• The screen has been defined.

• Each projector within the configuration is currently on the network.

Poor calibration results
Make sure that you have adequate camera coverage on the screen. 

Make sure you have calibrated your camera successfully. 

Review your exposure and binarization settings. If you used automatic exposure and binarization, 
select manual and adjust the values yourself.

Make sure all cameras are in focus.

Click the Projector Control tab and click Show in Markers. Make sure the camera images are not 
over exposed and adjust the camera aperture.

Expand Camera in the left pane, expand Exposure & Binarization, select Automatic.

Point Grey Flea3 status
This table shows the statuses that correspond to each LED state for the Point Grey Flea3 camera.

Camera Status

Off Not receiving power

Steady green, high intensity 
(~5 seconds)

Camera powers up

Green flashing quickly, low 
intensity 

Camera is attempting to establish an IP 
connection. 
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Location of generated images and log files
Christie AutoStack generates images and log files which may be useful when troubleshooting. 

View
To view the log and image files, on the Help tab, click Diagnostics > View. 

Export
To export log and image files, on the Help tab, click Export.

Problems with device communication 
• Check that Network Routing is set to Separate. See Add the projector to the network on page 

9.

• Click Start > All Programs > Christie > AutoStack 4.1 > Point Grey Utilities > 
GigEConfigurator.

• Confirm that the camera and computer are connected properly. Click Start > All Programs 
> Christie > AutoStack 4.1 > Point Grey Utilities > FlyCap2.

Slow camera performance 
For optimal results, you should have a minimum of a 1.0 Gigabits per second (Gbps) network 
connection. To confirm the speed of your network connection, click Start > Control Panel > 
Network and Sharing Center. Click your network connection and view its settings.

Failed to determine a channel ordering error 
message

• Make sure the layout settings are correct. The channel layout must match the projector output.

• Make sure every projector is calibrated by a minimum of one camera.

One green blink 
Two green blinks 
Three green blinks 
Three red blinks 

1) An IP address, if enabled and available;
2) a DHCP address, if enabled and available;
3) a link-local address (LLA).
4) Failure to establish connection

Steady green, high intensity Camera is streaming images 

Red/Green flashing quickly Firmware update in progress 

Red flashing slowly General error. 

Camera Status
Christie AutoStack 4.1 User Manual 30
020-100168-08 Rev. 1 (10-2015)



   Troubleshooting
Mapper generated no data error message
• Make sure every projector is calibrated by a minimum of one camera.

• Make sure that the lens cap has been removed from all the cameras.

• Adjust the camera aperture to increase or decrease light levels. In dark rooms a low aperture 
setting may result in a completely black image.

• Make sure the camera is pointing at an illuminated surface.

• Try viewing the camera image with the software provided by the camera vendor. For example, 
use FlyCapture with Point Grey cameras. The FlyCapture application is included with Christie 
AutoStack 4.1.

If you can see a clear image with the camera software but not with Christie AutoStack, confirm 
that the camera and firmware are supported and then contact Christie support.

If the image is visible but unclear, manually focus the camera.

• Make sure the network hardware, including the cabling and switches, can support 1Gbps 
throughput. If the camera drivers do not have a fast and reliable connection they may return 
blank images or no images may appear.

Warps have failed validation error message
• Make sure the layout settings are correct and the orientation setting matches the projector 

orientation settings.

• Adjust the projector orientation so the on-screen display appears correct from the planned end-
user viewing angle.

Projector undershooting causing distorted blends
With projector undershooting, one projector undershoots the screen or content boundary. This 
creates a region on which only a single projector can project an image. To resolve this issue:

• Expand Options in the left pane, expand Twist, and select the Smart Undershoot Handling 
checkbox. Projector undershoot around the border is now ignored when performing blend 
calculations. Typically, selecting this option improves blend quality.

• Expand Options in the left pane, expand Twist, and clear the Smart Undershoot Handling 
checkbox. The other projector is allowed to fill the undershoot area and the blend is modified so 
it transitions smoothly into the undershoot region. Select this option if you have an irregular 
projector or content arrangement.
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For the most current technical documentation, please visit  www.christiedigital.com 
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