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1  Welcome to the DVB-T2 Option
The R&S SMCVB-K164 is a firmware application that adds functionality to generate
signals in accordance with the DVB-T2 digital standard.

Key features

The R&S SMCVB-K164 option features:

● DVB-T2 signal generation

This user manual contains a description of the functionality that the application pro-
vides, including remote control operation.

All functions not discussed in this manual are the same as in the base unit and are
described in the R&S SMCV100B user manual. The latest version is available at:

www.rohde-schwarz.com/manual/SMCV100B

Installation

You can find detailed installation instructions in the delivery of the option or in the
R&S SMCV100B service manual.

1.1  Accessing the DVB-T2 Dialog

To open the dialog with DVB-T2 settings

► In the block diagram of the R&S SMCV100B, select "Baseband > DVB-T2".

A dialog box opens that displays the provided general settings.

The signal generation is not started immediately. To start signal generation with the
default settings, select "State > On".

1.2  Documentation Overview

This section provides an overview of the R&S SMCV100B user documentation. Unless
specified otherwise, you find the documents on the R&S SMCV100B product page at:

www.rohde-schwarz.com/manual/smcv100b

1.2.1  Getting Started Manual

Introduces the R&S SMCV100B and describes how to set up and start working with the
product. Includes basic operations, typical measurement examples, and general infor-
mation, e.g. safety instructions, etc. A printed version is delivered with the instrument.

Documentation Overview

https://www.rohde-schwarz.com/manual/smcv100b
http://www.rohde-schwarz.com/manual/smcv100b
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1.2.2  User Manuals and Help

Separate manuals for the base unit and the software options are provided for down-
load:
● Base unit manual

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control com-
mands with programming examples, and information on maintenance, instrument
interfaces and error messages. Includes the contents of the getting started manual.

● Software option manual
Contains the description of the specific functions of an option. Basic information on
operating the R&S SMCV100B is not included.

The contents of the user manuals are available as help in the R&S SMCV100B. The
help offers quick, context-sensitive access to the complete information for the base unit
and the software options.

All user manuals are also available for download or for immediate display on the Inter-
net.

1.2.3  Service Manual

Describes the performance test for checking compliance with rated specifications, firm-
ware update, troubleshooting, adjustments, installing options and maintenance.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS):

https://gloris.rohde-schwarz.com

1.2.4  Instrument Security Procedures

Deals with security issues when working with the R&S SMCV100B in secure areas. It
is available for download on the Internet.

1.2.5  Printed Safety Instructions

Provides safety information in many languages. The printed document is delivered with
the product.

1.2.6  Data Sheets and Brochures

The data sheet contains the technical specifications of the R&S SMCV100B. It also
lists the options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

Documentation Overview

https://gloris.rohde-schwarz.com
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See www.rohde-schwarz.com/brochure-datasheet/smcv100b

1.2.7  Release Notes and Open Source Acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open-source acknowledgment document provides verbatim license texts of the
used open source software.

See www.rohde-schwarz.com/firmware/smcv100b

1.2.8  Application Notes, Application Cards, White Papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/smcv100b

1.3  Scope

Tasks (in manual or remote operation) that are also performed in the base unit in the
same way are not described here.
In particular, it includes:
● Managing settings and data lists, like saving and loading settings, creating and

accessing data lists, or accessing files in a particular directory.
● Information on regular trigger, marker and clock signals and filter settings, if appro-

priate.
● General instrument configuration, such as checking the system configuration, con-

figuring networks and remote operation
● Using the common status registers

For a description of such tasks, see the R&S SMCV100B user manual.

1.4  Notes on Screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

Notes on Screenshots

http://www.rohde-schwarz.com/brochure-datasheet/smcv100b
http://www.rohde-schwarz.com/firmware/smcv100b
http://www.rohde-schwarz.com/application/smcv100b
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The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on Screenshots
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2  About the DVB-T2 Option
The transmission standard complies with the specification ETSI EN 302 755 and ETSI
TS 102 773. A subset of all possible parameters found in the specification can be set
on the R&S SMCV100B.

2.1  Required Options

The equipment layout for generating DVB-T2 signals includes:
● Base unit
● Option Enable Broadcast Standard (R&S SMCVB-K519)
● Option DVB-T2 (R&S SMCVB-K164)

Required Options
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3  DVB-T2 Configuration and Settings
Access:

► Select "Baseband > DVB-T2".

This section provides an overview on the DVB-T2 settings.

The remote commands required to define these settings are described in Chapter 5,
"Remote-Control Commands", on page 78.

Settings:

● General Settings..................................................................................................... 12
● Input Signal Settings............................................................................................... 15
● Mode & Stream Settings......................................................................................... 29
● BICM Settings......................................................................................................... 34
● OFDM Settings........................................................................................................38
● System Settings...................................................................................................... 41
● SFN Settings...........................................................................................................49
● Frame Info...............................................................................................................53
● Data Generation Settings........................................................................................57
● Global Connector Settings...................................................................................... 58
● TS Player................................................................................................................ 58
● Local IP Data Network Settings.............................................................................. 68

3.1  General Settings

Access:

► Select "Baseband > DVB-T2".

General Settings
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The tab provides default settings, save and recall settings and settings necessary
to configure T2-MI interface parameters.

The remote commands required to define these settings are described in Chapter 5.1,
"General Commands", on page 79.

Settings:

State..............................................................................................................................13
Set To Default................................................................................................................13
Save/Recall................................................................................................................... 13
T2-MI Interface..............................................................................................................14
T2-MI PID (Hex)............................................................................................................ 14
T2-MI SID (Hex)............................................................................................................ 14
Data Generation............................................................................................................14
Test Cases.................................................................................................................... 14

└ Test Cases...................................................................................................... 14
Reset Log File............................................................................................................... 14
Status Info..................................................................................................................... 15

State
Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:STATe on page 79

Set To Default
Calls the default settings. The values of the main parameters are listed in the following
table.

Parameter Value

State Not affected by the "Set to Default"

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PRESet on page 79

Save/Recall
Accesses the "Save/Recall" dialog, that is the standard instrument function for saving
and recalling the complete dialog-related settings in a file. The provided navigation
possibilities in the dialog are self-explanatory.

The settings are saved in a file with predefined extension. You can define the filename
and the directory, in that you want to save the file.

See also, chapter "File and Data Management" in the R&S SMCV100B user manual.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:SETTing:CATalog? on page 80
[:SOURce<hw>]:BB:T2DVb:SETTing:DELete on page 80
[:SOURce<hw>]:BB:T2DVb:SETTing:LOAD on page 80
[:SOURce<hw>]:BB:T2DVb:SETTing:STORe on page 80

General Settings



DVB-T2 Configuration and SettingsR&S®SMCVB-K164

14User Manual 1179.0974.02 ─ 03

T2-MI Interface
Activates the T2-MI modulator interface.

"On" Uses the incoming T2-MI stream to configure the modulator.

"Off" Uses the incoming MPEG transport stream directly as payload for
single PLP transmission.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:INTerface on page 83

T2-MI PID (Hex)
Requires "T2-MI Interface > On".

Sets the PID.

The PID belongs to MPEG transport stream packets, that contain T2-MI data.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:PID on page 83

T2-MI SID (Hex)
Requires "T2-MI Interface > On".

Sets the T2-MI transport SID.

Use the SID, when transmitting a composite signal, in accordance with annex I of the
specification ETSI EN 302 755.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:PID on page 83

Data Generation
Accesses the "DVB-T2 Data Generation" dialog.

See Chapter 3.9, "Data Generation Settings", on page 57.

Test Cases
Accesses a standard file-select dialog to select DVB-T2 test cases.

For available test cases, see Chapter A, "DVB-T2 Test Cases", on page 141.

Test Cases ← Test Cases
Filters the list of available test cases.

Reset Log File
Requires "T2-MI Interface > On".

Resets the log file.

Status information of the T2-MI analyzer as displayed in "Status Info" is saved to a log
file. The log file DVBT2_T2MI_Status_Info_TX.txt is saved to the directory var/
user/log.

See also, chapter "File and Data Management" in the R&S SMCV100B user manual.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:RESetlog on page 84

General Settings
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Status Info
Displays the status of the T2-MI analyzer by an error message. "No Error" implies cor-
rect behavior of the analyzer. Status information of the T2-MI analyzer is saved to a log
file, see "Reset Log File" on page 14.

To ensure correct behavior, fix occurring errors successively.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:ANALyzer? on page 83

3.2  Input Signal Settings

Access:

► Select "Baseband > DVB-T2 > Input Signal".

The dialog provides settings necessary to configure the input signal.

Input signal tasks

The settings allow you to perform the following tasks:
● Selecting an MPEG TS or T2-MI source
● Displaying information about the selected stream (e.g. data rate)
● Configuring the internal MPEG TS test packets

How to: Chapter 4.1, "Configuring the Input Signal", on page 71

Settings:

● General Settings..................................................................................................... 16
● PLP Info.................................................................................................................. 19
● T2-MI Data Packet Timing Settings........................................................................ 21
● Test Signal Settings.................................................................................................24
● IP Channnel x Settings............................................................................................26

Input Signal Settings
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3.2.1  General Settings

Access:

► Select "Input Signal > General".

The tab provides general settings necessary to configure the input signal.

Settings:

T2-MI Interface..............................................................................................................16
Source ..........................................................................................................................16
Number of PLPs............................................................................................................17
Input ............................................................................................................................. 17
Input Format .................................................................................................................17
IP TS Channel...............................................................................................................18
T2-MI PID (Hex)............................................................................................................ 18
T2-MI SID (Hex)............................................................................................................ 18
Stuffing.......................................................................................................................... 18
Test Signal.....................................................................................................................18

T2-MI Interface
Activates the T2-MI modulator interface.

"On" Uses the incoming T2-MI stream to configure the modulator.

"Off" Uses the incoming MPEG transport stream directly as payload for
single PLP transmission.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:INTerface on page 83

Source
Sets the modulation source for the input signal.

Input Signal Settings
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"External" Uses a transport stream, that is input at the "TS IN"/"IP Data" inter-
face.

For more information about connecting to the interfaces, see also:
● "TS IN" interface: Section "Configuring the Global Connectors" in

the R&S SMCV100B user manual.
● "IP Data" interface: Chapter 3.12, "Local IP Data Network Set-

tings", on page 68.

"TS Player" Uses an internal transport stream with TS packet data played from a
file. The player requires no option.
Playing encrypted files with extension _c requires a stream library
option R&S SMCVB-KSx.

See also:
● Chapter 3.11, "TS Player", on page 58
● Supported TS player file types

"Test Signal" Requires "T2-MI Interface > Off".
Uses an internal test signal as specified in Chapter 3.2.4, "Test Signal
Settings", on page 24.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:SOURce on page 82

Number of PLPs
Displays the number of PLPs.

The available number of PLPs depends on the setting of "T2-MI Interface":
● If "T2-MI Interface > Off", the number of PLPs is "1" (single PLP).
● If "T2-MI Interface > On", maximum "1 to 20" PLPs are supported.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:NPLP? on page 86

Input
Requires "Source > External".

Sets the external input interface.

"TS IN" Input for serial transport stream data. The signal is input at the "User
1" connector.

"IP" Input for IP-based transport stream data (TSoverIP). The signal is
input at the "IP Data" connector.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut on page 82

Input Format
Requires "Source > External" and "Input > TS IN".

Sets the format of the input signal.

"ASI" ASI format

"SMPTE 310" SMPTE 310 format

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:FORMat on page 83

Input Signal Settings
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IP TS Channel
Requires "Source > External" and "Input > IP".

Selects the IP-based transport stream (TS) channel. You can select 1 out of 4 IP TS
channels as input at the "IP Data" interface.

To configure a particular channel, see Chapter 3.2.5, "IP Channnel x Settings",
on page 26.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:TSCHannel on page 84

T2-MI PID (Hex)
Requires "T2-MI Interface > On".

Sets the PID.

The PID belongs to MPEG transport stream packets, that contain T2-MI data.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:PID on page 83

T2-MI SID (Hex)
Requires "T2-MI Interface > On".

Sets the T2-MI transport SID.

Use the SID, when transmitting a composite signal, in accordance with annex I of the
specification ETSI EN 302 755.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:PID on page 83

Stuffing
Requires "External/TS Player".

Activates stuffing.

"On" Inserts null packets and corrects the PCR values.

"Off" The data rate of the transport stream source must match the data
rate required for the current modulation parameters.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:STUFfing on page 87

Test Signal
Requires "T2-MI Interface > Off" and "Source > Test Signal".

Defines the test signal data.

"Test TS Packet"
Standardized packet data used as modulation data in the transport
stream. To configure the packet structure, select the side tab "Test
Signal > Test TS Packet".
Uses a null packet as the test signal. To configure the null packet, see
Chapter 3.2.4, "Test Signal Settings", on page 24.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:TESTsignal on page 91

Input Signal Settings
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3.2.2  PLP Info

Access:

► Select "Input Signal > PLP Info".

The tab displays the "PLP <num>" table, that contains individual PLP information of
up to 20 PLPs.
The information comprises input parameters for each PLP.

Settings:

PLP <num> table.......................................................................................................... 19
└ PLP Input Format............................................................................................19
└ Packet Length ................................................................................................19
└ Stuffing............................................................................................................20
└ Max. Useful Data Rate / Mbit/s....................................................................... 20
└ Measured Data Rate / Mbit/s.......................................................................... 20
└ Useful Data Rate / Mbit/s................................................................................20

PLP <num> table
Displays individual parameters for each PLP <num>. The table displays information of
up to 20 PLPs with <num> ranging from 0 to 19.

PLP Input Format ← PLP <num> table
Displays the input format of each PLP <num> for all input sources.

"GFPS/GCS/GSE" require "T2-MI Interface > On".

To edit the input format, select "Input Signal > General > Input Format".

"TS" Transport stream

"GFPS" Generic fixed-length packetized stream

"GCS" Generic continuous stream

"GSE" Generic stream encapsulation

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:FORMat on page 86

Packet Length ← PLP <num> table
Requires "T2-MI Interface > Off" and "Source > External".

Displays the packet length of the external transport stream in bytes.

If the packet length does not match the specified length, the output signal is erroneous.
"Packet Length > Invalid" is displayed.

Input Signal Settings
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"188" 188 bytes specified packet length for serial input ("TS IN") and paral-
lel input("IP").

"Invalid" Packet length ≠ 188 bytes, i.e. the length is not a specified length.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:PACKetlength? on page 87

Stuffing ← PLP <num> table
Requires "External/TS Player".

Activates stuffing.

"On" Inserts null packets and corrects the PCR values.

"Off" The data rate of the transport stream source must match the data
rate required for the current modulation parameters.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:STUFfing on page 87

Max. Useful Data Rate / Mbit/s ← PLP <num> table
Requires "T2-MI Interface > Off" and "Source > External/TS Player".

Displays the maximum data rate, that is derived from the current modulation parameter
settings.

The value is the optimal value at the TS input interface, that is necessary for the modu-
lator.

If "Stuffing > On", the value indicates the maximum useful data rate, that is allowed in
the transport stream.

If "Stuffing > Off", the value indicates the transport stream input data rate that is
required for the transport stream.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:USEFul[:RATE]:MAX? on page 88

Measured Data Rate / Mbit/s ← PLP <num> table
Requires "T2-MI Interface > Off" and "Source > External".

Displays the measured value of the data rate rmeas of one of the following:
● External transport stream including null packets input at "User 1" connector
● External transport stream including null packets input at "IP Data/LAN" connector

(TSoverIP)
The value rmeas equals the sum of useful data rate ruseful and the rate of null packets r0:

If "Stuffing > Off", ensure that the measured data rate equals the maximum useful data
rate (rmeas = rmax. useful).

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>[:INPut]:DATarate? on page 88

Useful Data Rate / Mbit/s ← PLP <num> table
Requires "Source > External/TS Player".

Displays the data rate of useful data ruseful of the external transport stream. The data
rate is measured at the input of the installed input interface.

Input Signal Settings
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The value is measured or computed depending on the setting of "T2-MI Interface":
● If "T2-MI Interface > Off" and "Source > External/TS Player", the value is mea-

sured.
● If "T2-MI Interface > On", the value is computed.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:USEFul[:RATE]? on page 87

3.2.3  T2-MI Data Packet Timing Settings

Access:

1. Select "Input Signal > T2-MI Interface > On".

The "T2-MI Data Packet Timing" side-tab appears.

2. Select "Input Signal > T2-MI Data Packet Timing"

The tab provides packet timing settings for data input at the T2-MI interface.

All operations on frame_idx are modulo NT2.

Individual addressing functions (packet_type 2116) can be sent at any time.

The T2 timestamp refers to the transmission time of the super frame, although it is sent
at any time.
The figure below shows a single PLP. If using multiple PLPs, the interleaving frame
duration TIF and hence the timing requirements for the type 0016 packets can be differ-
ent for different PLPs.

Input Signal Settings
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Settings:

All following settings require "T2-MI Interface > On".

Measurement Mode...................................................................................................... 22
T2-MI Tmin1.................................................................................................................... 22
T2-MI Tmin2.................................................................................................................... 23
T2-MI Tmin3.................................................................................................................... 23
T2-MI Tmax1....................................................................................................................23
T2-MI Tmax2....................................................................................................................23
T2-MI Tmax3....................................................................................................................24
T2-MI Tmax4....................................................................................................................24

Measurement Mode
Specifies the measurement mode to configure the evaluation of T2-MI timing parame-
ters.

"Absolute" Displays the absolute values of the measured T2-MI timing parame-
ters.

"Delta" Displays the measured delta values of two consecutive T2-MI pack-
ets for each T2-MI timing parameter.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MEASuremode on page 89

T2-MI Tmin1

Displays the current value of Tmin1.
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T2-MI packets arrive at the modulator not later than Tmin1 before starting transmission
of the corresponding T2 frame, if:
● T2-MI packets are of type: 0016, 0116, 0216, 1016, 1216, 2016

● frame_idx is given

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T1? on page 89

T2-MI Tmin2

Displays the current value of Tmin2.

T2-MI packets arrive at the modulator not later than Tmin2 before starting transmission
of the corresponding T2 frame, if:
● T2-MI packets are of type: 1116

● frame_idx is given

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T2? on page 89

T2-MI Tmin3

Displays the current value of Tmin3.

T2-MI packets arrive at the modulator not later than Tmin3 before starting transmission
of the corresponding FEF part, if:
● T2-MI packets are of type: 3016, 3116, 3216, 3316

● fef_idx is given

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T3? on page 89

T2-MI Tmax1

Displays the current value of Tmax1.

T2-MI packets arrive at the modulator not earlier than TIF + Tmax1 before starting trans-
mission of the corresponding T2 frame, if:
● T2-MI packets are of type: 0016 type
● frame_idx is given

TIF is the duration of one interleaving frame for the corresponding PLP.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T1? on page 90

T2-MI Tmax2

Displays the current value of Tmax2.

T2-MI packets arrive at the modulator not earlier than Tmax2 before starting transmis-
sion of the corresponding T2 frame, if:
● T2-MI packets are of type: 0116, 0216

● frame_idx is given

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T2? on page 90
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T2-MI Tmax3

Displays the current value of Tmax3.

T2-MI packets arrive at the modulator not earlier than Tmax3 before starting transmis-
sion of the corresponding T2 frame, if:
● T2-MI packets are of type: 1016, 1116, 1216, 2016

● frame_idx is given

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T3? on page 90

T2-MI Tmax4

Displays the current value of Tmax4.

T2-MI packets arrive at the modulator not earlier than Tmax4 before starting transmis-
sion of the corresponding FEF part, if:
● One of the following types: 3016, 3116, 3216, 3316

● Given fef_idx

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T4? on page 90

3.2.4  Test Signal Settings

Access:

► Select "Input Signal > Test Signal".

The tab provides settings necessary to configure the test signal.

Input Signal Settings
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Settings:

Test TS Packet.............................................................................................................. 25
PID Test Packet.............................................................................................................25
PID (Hex)...................................................................................................................... 25
Payload Test/Stuff......................................................................................................... 25
PRBS............................................................................................................................ 25

Test TS Packet
Specifies the structure of the test transport stream packet that is fed to the modulator.

"Head/184 Payload"
A sync byte (0x47) followed by three header bytes and 184 payload
bytes.

"Sync/187 Payload"
A sync byte (0x47) followed by 187 payload bytes.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:TSPacket on page 92

PID Test Packet
If a header is present in the test packet ("Test TS Packet > Head/184 Payload"), you
can specify a fixed or variable packet identifier (PID).

"Null" The header of the test transport stream packets has a fixed setting of
null packet header 1FFF (hex).

"Variable" Uses the header value defined with "PID (Hex)" on page 25.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PIDTestpack on page 91

PID (Hex)
Sets the PID.

If "PID Test Packet > Null", "PID (Hex) = 1FFF" is fixed.

If "PID Test Packet > Variable", you can edit the value.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PID on page 91

Payload Test/Stuff
Defines the payload area content of the TS packet.

You can select PRBS or exclusively data in hexadecimal format as payload.

For "Source > Test Signal", the packet is a test packet.

For "Stuffing > On", the packet is a null packet. Null packets are inserted into the exter-
nal transport stream to adapt the stream data rate. See also "Measured Data Rate /
Mbit/s" on page 20

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PAYLoad on page 91

PRBS
Sets the length of the PRBS sequence.
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You can select a PRBS 15 or a PRBS 23 sequence as specified by ITU-T O.151.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PRBS[:SEQuence] on page 92

3.2.5  IP Channnel x Settings

Access:

1. Select "Input Signal > General".

2. Select "Source > External"

3. Select "Input > IP"

4. Select "Input Signal > IP Channel x"

The tab provides settings necessary to configure IP channel x.

You can configure settings for 4 IP channels x = 1 to 4 individually, see also "Input
Signal > General > IP TS Channel".

IP channel settings affect input IP data of the local IP data network. The settings are
independent from the used broadcast standard configuration.
Saving/recalling a certain IP channel or local IP data network configuration is not possi-
ble via the broadcast standard-specific functionality.
Use the global save/recall functionality instead, see section "Saving and Recalling
Instrument Settings" in the R&S SMCV100B user manual.

The table below shows the availability of the tab in the broadcast standard configura-
tion.

Input Signal Settings
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Table 3-1: IP channel configuration support in broadcast standards

Baseband standard "IP Channel x" Baseband standard "IP Channel x"

"ATSC/ATSC-M/H" Yes "T-DMB/DAB" Yes

"ATSC 3.0" No "DVB-S" Yes

"DTMB" Yes "DVB-S2" Yes

"DVB-T" Yes "DRM" No

"DVB-T2" Yes "Audio AM" No

"ISDB-T" Yes "Audio FM" No

See also:
● Chapter 4.1.1, "How to Apply an External IP Input Signal", on page 71
● Chapter 3.12, "Local IP Data Network Settings", on page 68

Requirements

At your IP source, set the "transport stream packets per internet protocol packet" (TP
per IP) parameter as follows:
● If TP packet length = 188 bytes: Set TP per IP to 7 or 6.
● If TP packet length = 204/208 bytes: Set TP per IP to 6.

We recommend that youFurthermore, we recommend that you use a separate LAN
infrastructure to stream the transport streams via IP to the IP connector of the base-
band board. We recommend that you avoid TS packet losses during IP transmission.

Settings:

Input IP..........................................................................................................................27
Alias.............................................................................................................................. 27
Type.............................................................................................................................. 28
Multicast Address..........................................................................................................28
Port................................................................................................................................28
IGMPv3 Source Address...............................................................................................28
Ping Source Address.................................................................................................... 28
Ping Result....................................................................................................................28
Local IP Data Network.................................................................................................. 29

Input IP
Activates/deactivates the IP input.

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>[:STATe] on page 93

Alias
Sets a unique name for the IP connection.

The definition of a name is optional but facilitates identification in the measurement
views. The name input fits maximum 16 characters in ASCII format.
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Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:ALIas on page 93

Type
Sets the input signal type.

"Unicast" Analyzes all unicast IP packets that arrive at the specified "Port".

"Multicast" When an IP address is in the multicast address range, an attempt is
made to join a multicast group using IGMP.
Set "Multicast Address" and "Port".

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:TYPE on page 94

Multicast Address
Editing requires "Type > Multicast".

Sets the destination IP address (IPv4) of the IP connection.

You can set addresses from "224.0.0.0" to "239.255.255.255".

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess on page 94

Port
Sets the destination UDP port.

Due to UDP/RTP autosensing, we recommend that you set a port offset of at least 6
between neighboring IP TS channels.

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:PORT on page 94

IGMPv3 Source Address
Requires "Type > Multicast".

Sets the IGMPv3 source address.

If you need to filter the data sent to the multicast address, specify the source address.
A source address different from "0.0.0.0" accepts only data originating from the speci-
fied IP address.

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:ADDRess on page 94

Ping Source Address
Clicking "Ping Source Address" triggers pinging of the IGMPv3 source address.

If you set a different value from "IGMPv3 Source Address = 0.0.0.0" and click the but-
ton, the software checks if the address is reachable.

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING on page 95

Ping Result
Displays the result after pinging the source address.

If "Ping Result > Ping: Successful", the source address is available in the network.
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If "Ping Result > Ping: Transmit Failed. xxx", the source address is not available in the
network. "xxx" can be, e.g. "General Failure". Try another "IGMPv3 Source Address".

Remote command: 
[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult? on page 95

Local IP Data Network
Accesses local IP data network settings, see Chapter 3.12, "Local IP Data Network
Settings", on page 68.

3.3  Mode & Stream Settings

Access:

► Select "Baseband > DVB-T2 > Mode & Stream".

The tab provides settings necessary to configure mode and stream adaptation
parameters.

Settings:

● PLP 0 Settings........................................................................................................ 29
● PLP Info.................................................................................................................. 31

3.3.1  PLP 0 Settings

Access:

► Select "Mode & Stream > PLP 0".

The tab provides settings necessary to configure mode and stream parameters of
"PLP 0".

Editing "PLP 0" settings requires "T2-MI Interface > Off".
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Settings:

PLP ID (Hex)................................................................................................................. 30
PLP Group ID (Hex)...................................................................................................... 30
PLP Type.......................................................................................................................30
BB Mode....................................................................................................................... 30

PLP ID (Hex)
Sets the PLP ID. The PLP ID has to be unique.

You can set the PLP ID in hexadecimal representation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ID on page 99

PLP Group ID (Hex)
Sets the PLP group ID for multi-PLP, i.e. the number of PLPs is greater than 1.

Multi-PLP requires number of PLPs > 1, see "Number of PLPs" on page 17.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:GROup on page 98

PLP Type
Sets the PLP type.

The type depends on the number of PLPs in the setup.

"Common" Requires a multi-PLP setup.
Common PLP of the PLP Group.

"D. Type 1" Data type 1.
Fixed for a single-PLP setup. Configurable for a multi-PLP stream.

"D. Type 2" Requires a multi-PLP setup.
Data type 2.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TYPE on page 101

BB Mode
Defines the baseband mode.

"HEM" High efficiency mode.

"NM" Normal mode.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:BB_Mode on page 97
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3.3.2  PLP Info

Access:

► Select "Mode & Stream > PLP Info".

The tab displays the "PLP <num>" table, that contains individual PLP information of
up to 20 PLPs.
The information comprises mode and stream parameters for each PLP.

To configure "PLP Info" "Mode & Stream" parameters

1. Select "DVB-T2 > T2-MI Interface > Off".

2. Select "Mode & Stream > PLP 0".

You can configure the parameters only for "PLP 0".

Settings:

PLP <num> table.......................................................................................................... 32
└ PLP ID (Hex)...................................................................................................32
└ PLP Group ID (Hex)........................................................................................32
└ PLP Type........................................................................................................ 32
└ BB Mode......................................................................................................... 32
└ ISSY................................................................................................................32
└ Null Packet Deletion........................................................................................33
└ In-Band Signaling............................................................................................33
└ In-Band Signaling A........................................................................................ 33
└ In-Band Signaling B........................................................................................ 33
└ Other In-Band PLPs........................................................................................33
└ CM Type..........................................................................................................33
└ Static Flag.......................................................................................................34
└ Static Padding Flag.........................................................................................34

Mode & Stream Settings



DVB-T2 Configuration and SettingsR&S®SMCVB-K164

32User Manual 1179.0974.02 ─ 03

PLP <num> table
Displays individual parameters for each PLP <num>. The table displays information of
up to 20 PLPs with <num> ranging from 0 to 19.

Note: Numbering in remote control commands.
The suffix PLP<ch> ranges from 1 to 20, the PLP number num ranges from 0 to 19.
See "Common suffixes" on page 78.
How to: "To configure "PLP Info" "Mode & Stream" parameters" on page 31

PLP ID (Hex) ← PLP <num> table
Sets the PLP ID. The PLP ID has to be unique.

You can set the PLP ID in hexadecimal representation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ID on page 99

PLP Group ID (Hex) ← PLP <num> table
Sets the PLP group ID for multi-PLP, i.e. the number of PLPs is greater than 1.

Multi-PLP requires number of PLPs > 1, see "Number of PLPs" on page 17.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:GROup on page 98

PLP Type ← PLP <num> table
Sets the PLP type.

The type depends on the number of PLPs in the setup.

"Common" Requires a multi-PLP setup.
Common PLP of the PLP Group.

"D. Type 1" Data type 1.
Fixed for a single-PLP setup. Configurable for a multi-PLP stream.

"D. Type 2" Requires a multi-PLP setup.
Data type 2.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TYPE on page 101

BB Mode ← PLP <num> table
Defines the baseband mode.

"HEM" High efficiency mode.

"NM" Normal mode.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:BB_Mode on page 97

ISSY ← PLP <num> table
Displays the ISSY state.

"OFF" ISSY is not active. ISSY indicator field is 0.

"Short" ISSY is active. ISSY indicator field is 1. The synchronizer uses a
short ISCR.
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"Long" ISSY is active. ISSY indicator field is 1. The synchronizer uses a long
ISCR.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ISSY? on page 99

Null Packet Deletion ← PLP <num> table
Displays the null packet deletion state.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:NPD? on page 100

In-Band Signaling ← PLP <num> table
Requires "System > L1 T2 Version = 1.1.1", see "L1 T2 Version" on page 46.

Displays the in-band signaling state.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:IBS? on page 98

In-Band Signaling A ← PLP <num> table
Requires "System > L1 T2 Version ≠ 1.1.1", see "L1 T2 Version" on page 46.

Displays the in-band signaling type A state.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:IBS:A? on page 98

In-Band Signaling B ← PLP <num> table
Requires "System > L1 T2 Version ≠ 1.1.1", see "L1 T2 Version" on page 46.

Displays the in-band signaling type B state.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:IBS:B? on page 98

Other In-Band PLPs ← PLP <num> table
Displays the number of other PLPs signaled within the in-band signaling of the PLP for
multi-PLP.

Multi-PLP requires number of PLPs > 1, see "Number of PLPs" on page 17.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:OIBPlp? on page 100

CM Type ← PLP <num> table
Displays the CM type for multi-PLP.

Multi-PLP requires number of PLPs > 1, see "Number of PLPs" on page 17.

Displays the CM type for multi-PLP (number of PLPs > 1).
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"CCM" Constant coding and modulation.

The setting implies identical settings for all PLPs of the following
parameters:
● "FEC Frame" on page 35
● "Code Rate" on page 35
● "Constellation" on page 36
● "Const. Rotation" on page 36

"ACM" Variable coding and modulation.
The term ACM is retained for compatibility with DVB-S2 specified in
ETSI EN 302 307. Not all PLPs use the same coding and modulation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CMTYpe? on page 97

Static Flag ← PLP <num> table
Indicates if the scheduling for the current PLP varies from T2 frame to T2 frame or
remains static.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:STAFlag? on page 100

Static Padding Flag ← PLP <num> table
Indicates if BBFrame padding other than for in-band signaling is used for the current
PLP.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:PADFlag? on page 100

3.4  BICM Settings

Access:

► Select "Baseband > DVB-T2 > BICM".

The tab provides settings necessary to configure bit-interleaved coding and modu-
lation (BICM) parameters.

Settings:

● PLP 0 Settings........................................................................................................ 35
● PLP Info.................................................................................................................. 37
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3.4.1  PLP 0 Settings

Access:

► Select "BICM > General".

The tab provides settings necessary to configure BICM parameters of "PLP 0".

Settings:

FEC Frame....................................................................................................................35
Code Rate..................................................................................................................... 35
Constellation................................................................................................................. 36
Const. Rotation............................................................................................................. 36
Time Interleaver Type....................................................................................................36
Frame Interval (IJump).....................................................................................................36
Time Interleaver Length................................................................................................ 36
First Frame Index.......................................................................................................... 36

FEC Frame
Editing the parameter requires "T2-MI Interface > Off".

Sets the FEC frame.

"Normal" NLDPC = 64800

"Short" NLDPC = 16200

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:FECFrame on page 103

Code Rate
Editing the parameter requires "T2-MI Interface > Off".

Sets the code rate.

"1/3"/"2/5" Code rates not available for "System > Network > Transmission Sys-
tem > SISO/MISO".
See "Transmission System" on page 43.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:RATE on page 104
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Constellation
Editing the parameter requires "T2-MI Interface > Off".

Defines the constellation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CONStel on page 103

Const. Rotation
Editing the parameter requires "T2-MI Interface > Off".

Sets the constellation rotation state.

"On" Transmits the constellation rotated, i.e. the Q path is delayed vs. the I
path. For each constellation, there is a different (but fixed) angle of
rotation.

"Off" Transmits non-rotated constellation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CROTation on page 103

Time Interleaver Type
Editing the parameter requires "T2-MI Interface > Off".

Defines the time interleaver type.

"0" Maps each interleaving frame directly to a T2 frame.

"1" Maps each interleaving frame to more than one T2 frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TIL:TYPE on page 105

Frame Interval (IJump)
Defines the time interleaver frame interval (IJump).

"1" Used if the PLP appears in each frame. Fixed setting for single PLP.

"2" to "255" Requires a multi-PLP setup.
If frame interval is 2, for example, an interleaving frame is distributed
among two successive T2 frames with an even frame index. For limi-
tations, see specification ETSI EN 302 755.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TIL:FINT on page 104

Time Interleaver Length
Defines the time interleaver length within the time interleaving frame.

If a length of "0" is set and if "Time Interleaver Type" = "0", time interleaving is disabled.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TIL:LENGth on page 105

First Frame Index
Displays the index of the first frame of the super frame, in that the current PLP occurs.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:FRAMeindex on page 104
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3.4.2  PLP Info

Access:

► Select "BICM > PLP Info".

The tab displays the "PLP <num>" table, that contains individual PLP information of
up to 20 PLPs.
The information comprises BICM parameters for each PLP.

To configure "PLP Info" BICM parameters

1. Select "DVB-T2 > T2-MI Interface > Off".

2. Select "BICM > PLP 0".

You can configure the parameters only for "PLP 0".

Settings:

PLP <num> table.......................................................................................................... 37
└ FEC Blocks per IF...........................................................................................37
└ Max. Number of Blocks...................................................................................38

PLP <num> table
Displays individual parameters for each PLP <num>. The table displays information of
up to 20 PLPs with <num> ranging from 0 to 19.

Note: Numbering in remote control commands.
The suffix PLP<ch> ranges from 1 to 20, the PLP number num ranges from 0 to 19.
See "Common suffixes" on page 78.
How to: "To configure "PLP Info" BICM parameters" on page 37

FEC Blocks per IF ← PLP <num> table
Displays the number of FEC blocks per interleaving frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:BLOCks? on page 102
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Max. Number of Blocks ← PLP <num> table
Displays the maximum number of FEC blocks per interleaving frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:MAXBlocks? on page 104

3.5  OFDM Settings

Access:

► Select "Baseband > DVB-T2 > OFDM".

The dialog provides settings necessary to configure OFDM settings.

Settings:

Channel Bandwidth....................................................................................................... 38
Used Bandwidth............................................................................................................ 39
Bandwidth Variation.......................................................................................................39
FFT Size........................................................................................................................39
Guard Interval............................................................................................................... 39
Pilot Pattern...................................................................................................................40
T2 Frames per Super Frame (N_T2)............................................................................ 40
OFDM Symbols per T2 Frame (L_F)............................................................................ 40
Data Symbols per T2 Frame (L_DATA).........................................................................40
Subslices per T2 Frame (N_SUB).................................................................................41

Channel Bandwidth
Selects the channel bandwidth.

The channel bandwidth correlates with the used bandwidth, that is smaller. See
Table 3-2.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:CHANnel[:BANDwidth] on page 107
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Used Bandwidth
Displays the used bandwidth.

The used bandwidth depends on the channel bandwidth, the FFT size and the carrier
mode as described in Table 3-2.

You can set the carrier mode via "FFT Size", e.g. "32K Ext." means 32K FFT size using
extended carrier mode.
Table 3-2: Dependencies of the used bandwidth

"Channel Bandwidth" Elementary frequency "Used Bandwidth"

Normal carrier mode

"Used Bandwidth"

Extended carrier mode

1.7 MHz 131/71 MHz 1.535156 MHz 1.567589 MHz

5 MHz 40/7 MHz 4.754464 MHz 4.854911 MHz

6 MHz 48/7 MHz 5.705357 MHz 5.825893 MHz

7 MHz 56/7 MHz 6.656250 MHz 6.796875 MHz

8 MHz 64/7 MHz 7.607143 MHz 7.767857 MHz

Remote command: 
[:SOURce<hw>]:BB:T2DVb:USED[:BANDwidth]? on page 109

Bandwidth Variation
Requires "Requires T2-MI Interface > Off".

Changes the used bandwidth in the range of ±1000 ppm.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:BANDwidth:VARiation on page 106

FFT Size
Editing the parameter requires "T2-MI Interface > Off".

Defines the FFT size.

Note:
Not all possible combinations of the FFT size with the following parameters are
allowed:
● "Guard Interval" on page 39
● "Pilot Pattern" on page 40

"1K/2K/4K/8K/16K/32K"
1K/2K/4K/8K/16K/32K FFT size using normal carrier mode

"8K Ext./16K Ext./32K Ext."
8K/16K/32K FFT size using extended carrier mode

Remote command: 
[:SOURce<hw>]:BB:T2DVb:FFT:MODE on page 107

Guard Interval
Editing the parameter requires "T2-MI Interface > Off".

Sets the guard interval length.
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The length Δ is expressed in fractions of the active OFDM symbol duration TU, e.g.
Δ / TU = 19/256

Note:
Not all possible combinations of the guard interval with the following parameters are
allowed:
● "FFT Size" on page 39
● "Pilot Pattern" on page 40

Remote command: 
[:SOURce<hw>]:BB:T2DVb:GUARd:INTerval on page 107

Pilot Pattern
Editing the parameter requires "T2-MI Interface > Off".

Sets the pilot pattern.

You can select pattern "PP1" to "PP8".

Note:
Not all possible combinations of the pilot pattern with the following parameters are
allowed:
● "FFT Size" on page 39
● "Guard Interval" on page 39

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PILot on page 109

T2 Frames per Super Frame (N_T2)
Editing the parameter requires "T2-MI Interface > Off".

Sets the number of T2 frames per super frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:NT2Frames on page 108

OFDM Symbols per T2 Frame (L_F)
Displays the computed number of OFDM symbols per T2 frame LF.

LF equals the sum of number of data symbols per T2 frame LData plus the number of
P2 symbols LP2:

LF = LData + LP2

The sum constitutes the number of P2 symbols and the data symbols without the
P1 symbol. The number of P2 symbols in a T2 frame depends on the "FFT Size".

Remote command: 
[:SOURce<hw>]:BB:T2DVb:LF? on page 108

Data Symbols per T2 Frame (L_DATA)
Editing the parameter requires "T2-MI Interface > Off".

Sets the number of data symbols per T2 frame.

LData equals the difference of number of OFDM symbols per T2 frame LF minus the
number of P2 symbols LP2:

LData = LF - LP2
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Note:
The value of LData depends on the following parameters:
● "Guard Interval" on page 39
● "FFT Size" on page 39
● "T2 Frame Duration (TF)" on page 54

The maximum allowed T2 frame duration is 250 ms
The number of P2 symbols in a T2 frame depends on the "FFT Size".

Remote command: 
[:SOURce<hw>]:BB:T2DVb:LDATa on page 108

Subslices per T2 Frame (N_SUB)
Sets the number of subslices per T2 frame.

The number of subslices is "1" for "T2-MI Interface > Off".

The set value depends on the constellation and the FEC type of all data type 2 PLPs.

"1" Fixed setting for single PLP.

"1" to "6480" Configurable setting for multi-PLP.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:NSUB on page 108

3.6  System Settings

Access:

► Select "Baseband > DVB-T2 > System".

The dialog provides settings necessary to configure DVB-T2 system parameters.

Settings:

● Network Settings.....................................................................................................42
● L1 Settings.............................................................................................................. 46
● ID Settings...............................................................................................................48
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3.6.1  Network Settings

Access:

► Select "System > Network".

The tab provides network settings.

Settings:

Network Mode............................................................................................................... 42
└ Profile Mode....................................................................................................43

Transmission System....................................................................................................43
└ MISO Group Mode..........................................................................................44
└ MISO Group....................................................................................................44

Peak To Average Power Ratio (PAPR)......................................................................... 44
Future Extension Frames..............................................................................................44

└ FEF Type (Hex)...............................................................................................44
└ FEF Length..................................................................................................... 45
└ FEF Interval.................................................................................................... 45
└ FEF Payload................................................................................................... 45

Time Frequency Slicing (TFS).......................................................................................45

Network Mode
Sets the network mode.

Note: GPS receiver required.
Correct SFN synchronization requires a GPS receiver:
● Connect the 1PPS output of the GPS receiver to the "User 2" connector of the

R&S SMCV100B.
● Connect the 10 MHz output of the GPS receiver to the "Ref. In" connector of the

R&S SMCV100B.
At the R&S SMCV100B, set "RF > Reference Frequency > Reference Frequency >
Source > External".
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"SFN" In SFN mode, all transmitters in a network are tuned to the same fre-
quency and have frequency coupling (based on the 10 MHz refer-
ence output of a GPS receiver). In addition, it is necessary in an SFN
network to compensate any signal delays that occur in the program
data supply. This involves the use of a GPS receiver, see also "GPS
receiver required" on page 42, and timestamps inserted into the T2-
MI transport stream. The maximum delay in the network is set on the
T2 gateway. It represents the maximum delay which can occur in the
program data supply at the most remote transmitter in the network.
If a timestamp was received at the SFN transmitter, its modulator
measures the dynamic delay regarding its own received seconds
pulse from the local GPS receiver. From this information, together
with the processing delay (of the modulator), the RF delay (from mod-
ulator to antenna) and the optional static delay, it computes the local
delay. The supplied transport stream must undergo the computed
local delay value to attain data synchronicity in the network. Note,
that it is critical for the incoming transport stream to be identical for all
the transmitters in the network, i.e. it may not be changed in any way.
See also "Total Delay" on page 50.

"MFN" In MFN mode, there is no mandatory coupling between an individual
transmitter and the incoming transport stream (based on the seconds
pulse from a GPS receiver). In addition, the transmitters are not
synchronized with one another based on a common reference and
output frequency. You can select the modulation parameters of the
transmitters involved in the network. In addition, the incoming trans-
port stream can be adapted to the data rate requirements of the mod-
ulation parameter settings.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:NETWorkmode on page 113

Profile Mode ← Network Mode
Requires "Network Mode > SFN".

Sets the profile mode.

If the modulator operates in a multiple profile environment and is used to generate an
RF combined T2 base/T2 lite composite signal, can be used to mute P1FEF.

"Single" Modulator operates in normal mode. P1FEF is generated according
to DVB-T2 specification ETSI EN 302 755.

"Multi" Modulator operates in multiple profile environment mode. P1FEF is
muted to allow T2 base/T2 lite signal overlay on RF level.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PROFile on page 114

Transmission System
Editing the parameter requires "T2-MI Interface > Off".

Sets the transmission system.

"SISO" Enables the SISO transmission.

"MISO" Enables the MISO transmission.
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"Non-T2" Enables the non-T2 transmission.

"T2 Lite SISO" Enables the T2-Lite SISO transmission.

"T2 Lite MISO" Enables the T2-Lite MISO transmission.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:TXSYs on page 114

MISO Group Mode ← Transmission System
Requires "Transmission System > MISO/T2 Lite MISO".

Sets the MISO group mode, that allows to set the MISO group of the modulator man-
ually.

"Manual" Fixed MISO group mode. Allows manual setting of the "MISO Group".

Remote command: 
[:SOURce<hw>]:BB:T2DVb:MISO:MODE? on page 113

MISO Group ← Transmission System
Requires "Transmission System > MISO/T2 Lite MISO".

Sets the MISO group.

"1" Modulator transmits with MISO group 1.

"2" Modulator transmits with MISO group 2.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:MISO[:GROup] on page 113

Peak To Average Power Ratio (PAPR)
Editing the parameter requires "T2-MI Interface > Off".

Sets the technique to reduce the peak to average power ratio.

The current firmware does not support ACE.

"Off" Technique disabled.

"TR" Tone reservation enabled. I/Q values of the TR carriers are set to
zero.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:PAPR on page 113

Future Extension Frames
Enables/disables FEF.

"Off" Disables FEF.

"On" Requires "T2-MI Interface > On".
Enables FEF and shows the following subparameters.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:FEF on page 111

FEF Type (Hex) ← Future Extension Frames
Displays the type of the associated FEF part.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:FEF:TYPE on page 112

System Settings



DVB-T2 Configuration and SettingsR&S®SMCVB-K164

45User Manual 1179.0974.02 ─ 03

FEF Length ← Future Extension Frames
Displays the length of the associated FEF part as the number of elementary periods T.
The length is measured from the start of the P1 symbol of the FEF part to the start of
the P1 symbol of the next T2 frame.

The FEF length is "0" for "T2-MI Interface > Off" because FEF is only supported for
"T2-MI Interface > On". FEF is enabled or disabled by the information received from
the T2-MI stream.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:FEF:LENGth on page 112

FEF Interval ← Future Extension Frames
Displays the number of T2 frames between two FEF parts. The specification ETSI EN
302 755 states, that the T2 frame is the first frame in a T2 super frame which contains
both FEF parts and T2 frames.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:FEF:INTerval on page 111

FEF Payload ← Future Extension Frames
Sets the FEF payload.

"Null" I/Q values of the FEF payload are set to zero.

"Noise" I/Q values of the FEF payload are modulated in the frequency domain
using a PRBS and transformed into the time domain by IFFT.
The technique allows generating payload with a power level equal to
the T2 frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:FEF:PAYLoad on page 112

Time Frequency Slicing (TFS)
Displays the TFS state.

The current firmware does not support TFS.

"Off" Fixed setting.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:TFS on page 114
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3.6.2  L1 Settings

Access:

► Select "System > L1".

The tab provides common layer 1 (L1) settings.

Settings:

L1 T2 Version................................................................................................................ 46
L1 Post Modulation....................................................................................................... 46
L1 Repetition................................................................................................................. 47
L1 Post Extension......................................................................................................... 47
L1 Post Scrambled........................................................................................................47
T2 Base Lite.................................................................................................................. 47
Num. Aux. Streams....................................................................................................... 47
L1 RF Signaling.............................................................................................................47

└ Frequency.......................................................................................................48

L1 T2 Version
Editing the parameter requires "T2-MI Interface > Off".

Sets the version of T2 specification ETSI EN 302 755, that is used for transmission.

"1.1.1"/"1.2.1"/"1.3.1"
Version V1.1.1/V1.2.1/V1.3.1

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:T2Version on page 118

L1 Post Modulation
Editing the parameter requires "T2-MI Interface > Off".

Sets the modulation of the L1 post signal.

You can select between constellations BPSK/QPSK/16QAM/64QAM.
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Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:CONStel on page 116

L1 Repetition
Editing the parameter requires "T2-MI Interface > Off".

Enables/disables L1 repetition.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:REPetition on page 116

L1 Post Extension
Displays the L1 post extension state.

The current firmware does not support L1 post extension.

"Off" Fixed setting.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:EXTension on page 116

L1 Post Scrambled
Editing the parameter requires "T2-MI Interface > Off".

Enables/disables L1 post scrambling according to T2 version 1.3.1 of specification
ETSI EN 302 755.

See also "L1 T2 Version" on page 46.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:SCRambled on page 117

T2 Base Lite
Editing the parameter requires "T2-MI Interface > Off".

Enables/disables T2 base lite signaling according to T2 version 1.3.1 of specification
ETSI EN 302 755.

See also "L1 T2 Version" on page 46.

"Off" Disables the T2 base lite signaling.

"On" Requires "T2-MI Interface > On".
Enables the T2 base lite signaling.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:T2Baselite on page 117

Num. Aux. Streams
Displays the number of auxiliary streams.

The current firmware does not support auxiliary streams.

"0" Fixed setting.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:NAUX on page 118

L1 RF Signaling
Displays the RF signaling state in L1.

System Settings



DVB-T2 Configuration and SettingsR&S®SMCVB-K164

48User Manual 1179.0974.02 ─ 03

The setting depends on the setting of the "T2-MI Interface".

"Off" Requires "T2-MI Interface > Off".
Transmitted frequency: 0x0000 0000

"On" Requires "T2-MI Interface > On".
The frequency is received from the T2-MI stream. The value is dis-
played under "Frequency" on page 48.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:RFSignalling on page 117

Frequency ← L1 RF Signaling
Requires "T2-MI Interface > On".

Displays the signaled frequency in the L1 signaling.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:L:RFSignalling:FREQuency? on page 116

3.6.3  ID Settings

Access:

► Select "System > ID".

The tab system ID settings.

Settings:

Cell ID (Hex)..................................................................................................................48
Network ID (Hex)...........................................................................................................49
T2 System ID (Hex).......................................................................................................49
TX ID Availability (Hex)................................................................................................. 49

Cell ID (Hex)
Editing the parameter requires "T2-MI Interface > Off".

Sets the cell identification (ID).

The cell ID is a 16-bit value in hexadecimal representation.
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Remote command: 
[:SOURce<hw>]:BB:T2DVb:ID:CELL on page 119

Network ID (Hex)
Editing the parameter requires "T2-MI Interface > Off".

Sets the network identification.

The network ID is a 16-bit value in hexadecimal representation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:ID:NETWork on page 119

T2 System ID (Hex)
Editing the parameter requires "T2-MI Interface > Off".

Sets the T2 system identification.

The T2 system ID is a 16-bit value in hexadecimal representation.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:ID:T2SYstem on page 119

TX ID Availability (Hex)
Displays if transmitter identification signals are available within the current geographic
cell. The parameter is an 8-bit value in hexadecimal representation.

If no transmitter identification signals are used, the parameter is "0x00". All other bit
combinations are reserved for future use.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:ID:TXID:AVAil on page 120

3.7  SFN Settings

Requires "DVB-T2 > T2-MI Interface > On" and "System > Network Mode > SFN".

Access:

► Select "Baseband > DVB-T2 > SFN".

The tab provides settings necessary to configure SFN parameters.

Settings

● Delays..................................................................................................................... 50
● Mode....................................................................................................................... 51
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3.7.1  Delays

Access:

► Select "SFN > Delays".

The tab provides settings to configure the SFN delay parameters.

Settings

Processing Delay.......................................................................................................... 50
Static Delay................................................................................................................... 50
Dynamic Delay.............................................................................................................. 50
Total Delay.................................................................................................................... 50
Max. Deviation Time......................................................................................................51
Mute 1st Super Frame P1............................................................................................. 51

Processing Delay
Displays the delay from the modulator input up to the SFN delay (FIFO).

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:PROCess? on page 122

Static Delay
Sets the delay to shift the time of transmission positively or negatively.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:STATic on page 122

Dynamic Delay
Displays the transmission delay currently generated by the SFN delay (FIFO).

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:DYNamic? on page 121

Total Delay
Displays the sum of all individual delays.
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"Total Delay" = "Process Delay" + "Static Delay" + "Dynamic Delay"

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TOTal? on page 123

Max. Deviation Time
Sets the maximum permissible delay.

The delay Δtmax depends on the time of emission TOEtimestamp from timestamp, the
static delay tstatic and the actual time of emission TOEactual as follows:

Δtmax = TOEtimestamp + tstatic - TOEactual

If the above sum is greater than the "Max. Deviation Time", the SFN delay (FIFO)
restarts. The transmit signal is reset and transmission is restarted.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:DEViation on page 121

Mute 1st Super Frame P1
Activates muting the P1 symbol of the first T2 frame in a super frame. To mute the P1
symbol, the symbol is set to zero.

Activate muting, e.g., to synchronize different modulators in the same SFN, using an
oscilloscope.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:MUTep1 on page 122

3.7.2  Mode

Access:

► Select "SFN > Mode".

The tab provides settings to configure the SFN mode parameters.

Settings

Timestamp Mode...........................................................................................................52
Update Timestamp........................................................................................................52
UTC Date...................................................................................................................... 52
UTC Time......................................................................................................................52
Offset.............................................................................................................................52
Seconds Since 2000..................................................................................................... 53
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Timestamp Mode
Displays the type of the currently received T2-MI timestamps.

Note:
If you use T2-MI timestamp packets with absolute time information for SFN operation,
make sure that the following prerequisites are met:
● The R&S SMCV100B is connected to an NTP time server for time synchronization.
● The R&S SMCV100B uses the automatic time synchronization of the Linux opera-

tion system.
For automatic time synchronization, access "System Configuration > Setup > Mainte-
nance > Date/Time". In the "NTP Settings" panel, enter the NTP address and activate
"Use Time From NTP Server".

"Relative" Received T2-MI stream has T2-MI packets with relative timestamps.

"Absolute" Received T2-MI stream has T2-MI packets with absolute timestamps.
If received, the following subparameters are displayed.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TSP:MODE? on page 123

Update Timestamp
Clicking the button triggers an update of the UTC time and date reference.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TSP:UPDate on page 124

UTC Date
Displays the UTC date from the last UTC reference update.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TSP:DATE? on page 123

UTC Time
Displays the UTC time from the last UTC reference update.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TSP:TIME? on page 124

Offset
Modifies the UTC/GPS leap seconds offset.
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Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TSP:OFFSet on page 124

Seconds Since 2000
Displays the elapsed time in seconds since 2000. The value is based on the value of
the last UTC reference update.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:DELay:TSP:SEConds? on page 124

3.8  Frame Info

Access:

► Select "Baseband > DVB-T2 > Frame Info".

The tab provides information on frame and symbol duration parameters.

Settings:

● Frame......................................................................................................................53
● Symbols.................................................................................................................. 54
● L1 Signaling............................................................................................................ 55
● Data Cells................................................................................................................56

3.8.1  Frame

Access:

► Select "Frame Info > Frame".

The tab displays frame duration parameters.

Frame Info
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Settings:

Super Frame Duration (TSF)..........................................................................................54
T2 Frame Duration (TF).................................................................................................54
Future Extension Frame Duration (TFEF).......................................................................54

Super Frame Duration (TSF)
Displays the super frame duration.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:TSF? on page 126

T2 Frame Duration (TF)
Displays the T2 frame duration.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:TF? on page 125

Future Extension Frame Duration (TFEF)
Displays the future extension frame duration.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:TFEF? on page 126

3.8.2  Symbols

Access:

► Select "Frame Info > Symbols".

The tab displays symbol duration parameters.

Settings:

P1 Symbol Duration (TP1)..............................................................................................55
OFDM Symbol Duration (TP2, TS)..................................................................................55
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P1 Symbol Duration (TP1)
Displays the P1 symbol duration.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:TP1? on page 126

OFDM Symbol Duration (TP2, TS)
Displays the P2 and OFDM data symbol duration.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:TP2|TS? on page 127

3.8.3  L1 Signaling

Access:

► Select "Frame Info > L1 Signaling".

The tab displays L1-pre signaling and L1-post signaling parameters.

Settings:

L1 Pre Signaling Bits.....................................................................................................55
L1 Pre Signaling Cells...................................................................................................55
L1 Post Signaling Bits................................................................................................... 56
L1 Post Signaling Cells................................................................................................. 56

L1 Pre Signaling Bits
Displays the L1-pre signaling length in bits.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:PREBits? on page 128

L1 Pre Signaling Cells
Displays the L1-pre signaling length in cells.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:PRECells? on page 129
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L1 Post Signaling Bits
Displays the L1-post signaling length in bits.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:POSBits? on page 128

L1 Post Signaling Cells
Displays the L1-post signaling length in cells.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:POSCells? on page 128

3.8.4  Data Cells

Access:

► Select "Frame Info > Data Cells".

The tab displays payload information of the PLP data cells.

Settings:

PLP Data Cells Per T2 Frame (DPLP)............................................................................ 56
PLP Data Cells in Current T2 Frame (DPLP_USED)..........................................................56

PLP Data Cells Per T2 Frame (DPLP)
Displays the possible number of PLP data cells per T2 frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:DP? on page 129

PLP Data Cells in Current T2 Frame (DPLP_USED)
Displays the current number of PLP data cells in the T2 frame.

Remote command: 
[:SOURce<hw>]:BB:T2DVb:INFO:DPUSed? on page 129

Frame Info



DVB-T2 Configuration and SettingsR&S®SMCVB-K164

57User Manual 1179.0974.02 ─ 03

3.9  Data Generation Settings

Access:

► Select "Baseband > DVB-T2 > Data Generation".

The "Export Data" tab provides settings to generate data of the DVB-T2 signal
characteristics. You can generate data from the input signal, Mode & Stream and
BICM and export the data to a file.

Settings:

Data ..............................................................................................................................57
File Name .....................................................................................................................57
Directory .......................................................................................................................57
Generate ...................................................................................................................... 58
File Info panel................................................................................................................58
PLP <num> table.......................................................................................................... 58

Data
Sets the data source, for that the data is generated.

The table displays information on the PLPs for each data source "Input Signal/Mode &
Stream/BICM", see .

Remote command: 
n.a.

File Name
Displays the file name, for that the data is generated.

Remote command: 
n.a.

Directory
Accesses the directory of the export data.

A standard "File Select" dialog opens.

Data Generation Settings
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Remote command: 
n.a.

Generate
Triggers export data generation.

Remote command: 
n.a.

File Info panel
Displays information on the selected file, such as data source, directory and filename.

PLP <num> table
Displays individual parameters for each PLP <num>. The table displays information of
up to 20 PLPs with <num> ranging from 0 to 19.

3.10  Global Connector Settings

The "Input Signal" dialog, the "Trigger/Marker/Clock" dialog and "Trigger In", "Marker"
and "Clock" tabs in "Baseband > ARB/Custom Digital Mod" configuration dialogs pro-
vide quick access to the related connector settings. Click the "Global Connectors" but-
ton to access the settings.

See also chapter "Global Connector Settings" in the user manual.

3.11  TS Player

The "TS Player" application allows you to play stream files for simulation of dedicated
transport stream (TS) scenarios. Also, the R&S SMCV100B offers stream libraries con-
taining stream files with a wide range of ready-made signals for testing systems with
different transmission parameters. For supported file types, see Table 3-3.

Key features

The key features for playing stream files with "TS Player" application are:
● Support of numerous broadcast transmission standards
● Streaming of high-quality video contents
● Streaming of high-quality audio contents
● Efficient use with dedicated streams

TS Player
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Required options

The equipment layout for processing stream files includes:
● Base unit, including arbitrary waveform generator (64 MSample ARB memory, 60

MHz RF bandwidth)
● Broadcast standard option for the "TS Player" application (R&S SMCVB-Kxxx)
● Enable Broadcast Standards option (R&S SMCVB-K519)
● Optional stream library option (R&S SMCVB-KSxx)

For more information, see data sheet.

To access and download a stream library file

The steps to access a stream library and to download stream library files is analogous
as for waveform libraries. See chapter "How to Work with Waveform Libraries" in the
R&S SMCV100B user manual.

For information on the content of a stream library, see the user manual of the stream
library at:

www.rohde-schwarz.com/manual/smcv100b/ksxx-kvxx-stream-and-waveform-libraries-
user-manuals-manuals-gb1_78701-972224.html

To access the "TS Player" application

1. Select "Baseband > DVB-T2 > Input Signal".

2. Select "Source > TS Player".

3. Select "TS Player" button.

Opens the TS player dialog, where you can load files.

Support in broadcast standard configuration

Various broadcast baseband standards of the R&S SMCV100B support the "TS
Player" application. For an overview, see the table below.

Baseband standard "Source > TS Player" Baseband standard "Source > TS Player"

"ATSC/ATSC-M/H" Yes "T-DMB/DAB" Yes

"ATSC 3.0" Yes "DVB-S" Yes

"DTMB" Yes "DVB-S2" Yes

"DVB-T" Yes "DRM" No

"DVB-T2" Yes "Audio AM" No

"ISDB-T" Yes "Audio FM" No

The remote commands required to define these settings are described in Chapter 5.9,
"TSGen Subsystem", on page 130.

TS Player
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Settings:

● TS Player Settings.................................................................................................. 60
● Player Output Settings............................................................................................ 63
● Seamless Loop Settings......................................................................................... 66

3.11.1  TS Player Settings

Access:

1. Follow the steps in "To access the "TS Player" application" on page 59.

2. Select "TS Player > TS-Player".

The tab provides settings necessary to configure the general settings of the TS
player application.

Settings:

Running/Position Player [hh:mm:ss:fff]......................................................................... 60
Select File..................................................................................................................... 61
Start [hh:mm:ss.fff]........................................................................................................ 62
Position Player [hh:mm:ss.fff]........................................................................................62
Stop [hh:mm:ss.fff]........................................................................................................ 62
Reset Window............................................................................................................... 62
Play............................................................................................................................... 62
Pause............................................................................................................................ 62
Stop...............................................................................................................................62

Running/Position Player [hh:mm:ss:fff]
Displays the current position in time, while playing the file.

You can set an individual position via Position Player [hh:mm:ss.fff].

Remote command: 
:TSGen:CONFigure:SEEK:POSition on page 134

TS Player
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Select File
Provides access to the standard "File Select" function of the instrument. The provided
navigation possibilities in the dialog are self-explanatory.

See also, chapter "File and Data Management" in the R&S SMCV100B User Manual.

The dialog allows you to select user-defined, predefined and recent files. Table 3-3 lists
file extensions of supported files.
Table 3-3: Supported TS player file types

File extension Stream libraries Remark Option

*.atsc_c ATSC/ATSC & Mobile DTV Encrypted R&S SMCVB-KS13

*.dab T-DMB/DAB Unencrypted -

*.dab_c T-DMB/DAB Encrypted R&S SMCVB-KS10

*.dabp_c DAB+ Encrypted R&S SMCVB-KS11

*.eti T-DMB/DAB Unencrypted -

*.xeti T-DMB/DAB Unencrypted -

*.emc_c EMC Encrypted R&S SMCVB-KS15

*.isdbt_c ISDB-T Encrypted R&S SMCVB-KS12

*.pcap - Captured IPv4 stream for ATSC 3.0
player

-

*.t2mi1) - Unencrypted -

*.t2mi_c DVB-T2 MI Encrypted R&S SMCVB-KS14

*.t2trp_c DVB-T2 MI Encrypted R&S SMCVB-KS14

*.trp - Unencrypted -

*.trp_c - Encrypted

Included in various stream libraries

R&S SMCVB-KS12

R&S SMCVB-KS17

R&S SMCVB-KS18

R&S SMCVB-KS19

R&S SMCVB-KS20

*.bin - Unencrypted -

*.ts - Unencrypted -

*.mpg - Unencrypted -

*.t10 - - -

1) For T2MI stream files, the data rate of a T2MI file is determined automatically, if the
following applies:
● Data rate is not part of the TRP file header information.
● PCR information is not available.
● T2MI TRP file is not encrypted, that means not of type *.t2mi_c.
● TRP file has the *.t2mi file extension.

TS Player
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Remote command: 
:TSGen:CONFigure:PLAYfile on page 133
:TSGen:READ:PLAYfile:LENGth? on page 137
:TSGen:READ:FMEMory on page 137

Start [hh:mm:ss.fff]
Sets the start position in the loaded player file. Data which chronologically precedes
the start position is not replayed by the player.

The entered time stamp must chronologically always precede the entry under Stop.

Remote command: 
:TSGen:CONFigure:SEEK:STARt on page 135

Position Player [hh:mm:ss.fff]
Displays the current play position in the file.

Remote command: 
:TSGen:CONFigure:SEEK:POSition on page 134

Stop [hh:mm:ss.fff]
Sets the end position in the player file. Data which chronologically follows the end posi-
tion is not replayed by the player.

When the player reaches the "Stop" position, it returns to the "Start" position (continu-
ous play).

The entered time stamp must chronologically always follow the entry under Play.

Remote command: 
:TSGen:CONFigure:SEEK:STOP on page 135

Reset Window
Resets "Start/Stop/Position Player" parameters.

Remote command: 
:TSGen:CONFigure:SEEK:RESet on page 135

Play
Plays the selected file.

For supported file types, see Table 3-3.

Remote command: 
:TSGen:CONFigure:COMMand<ch> on page 132

Pause
Pauses the player.

After pausing, you can resume playing the file by clicking "Play" again.

Remote command: 
:TSGen:CONFigure:COMMand<ch> on page 132

Stop
Stops the player and returns to the start position.

TS Player
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Remote command: 
:TSGen:CONFigure:COMMand<ch> on page 132

3.11.2  Player Output Settings

Access:

► Select "TS Player > Player Output".

The tab provides settings necessary to configure the output of the TS player.

3.11.2.1  General Settings

The tab provides settings necessary to configure general player output properties.

Data Rate...................................................................................................................... 63
Orig. Data Rate............................................................................................................. 63
Packet Length............................................................................................................... 64
Nullpacket Stuffing........................................................................................................ 64
Stop Data...................................................................................................................... 64

Data Rate
Sets the output data rate of the player.

Note: If "Nullpacket Stuffing > Off", we recommend that you set the output data rate
equal to the original data rate.
If you want to use a different data rate, activate "Nullpacket Stuffing". The function
ensures that the data stream is replayed in the same way as it was recorded. The time
references in the tables of the TS stream are also correct during replay.

Remote command: 
:TSGen:CONFigure:TSRate on page 136

Orig. Data Rate
Displays the calculated original TS data rate.

TS Player
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Remote command: 
:TSGen:READ:ORIGtsrate on page 137

Packet Length
Requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the "TS Player" dia-
log. *.trp files are previously recorded files.

Displays the packet length of the loaded TS player file.

Remote command: 
:TSGen:CONFigure:TSPacket on page 136

Nullpacket Stuffing
Requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the "TS Player" dia-
log. *.trp files are previously recorded files.

Enables or disables nullpacket stuffing.

The output data rate of the TS player equals the original data rate. The equality
ensures that the time references in the tables of the played TS stream are correct dur-
ing replay.

"On" Activate stuffing, if you need a higher rate than the original data rate.
Null packets are inserted into the data stream.
To ensure correct time references in the stream tables, activate pro-
gram clock reference correction ("PCR, DTS/PTS > On").

"Off" Deactivate stuffing, if you want to use the same data rate as the origi-
nal data rate.

Remote command: 
:TSGen:CONFigure:STUFfing on page 136

Stop Data
Requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the "TS Player" dia-
log. *.trp files are previously recorded files.

Ensures that a standardized TS data stream is always output at the TS output at the
rear of the R&S SMCV100B.

In pause or stop status, the TS generator generates "test packets", which have data
and header parts, that can be configured using the Test TS Packet.

Remote command: 
:TSGen:CONFigure:STOPdata on page 136

TS Player
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3.11.2.2  Stuffing Settings

The tab comprises settings necessary to configure stuffing.

Settings

Test TS Packet.............................................................................................................. 65
PID Test Packet.............................................................................................................66
PID (Hex)...................................................................................................................... 66
Payload Test/Stuff......................................................................................................... 66
PRBS............................................................................................................................ 66

Test TS Packet
Specifies the structure of the test transport stream packet that is fed to the modulator.

"Head/184 Payload"
A sync byte (0x47) followed by three header bytes and 184 payload
bytes.

"Sync/187 Payload"
A sync byte (0x47) followed by 187 payload bytes.

"Head/200 Payload"
A sync byte (0x47) followed by three header bytes and 200 payload
bytes.

"Sync/203 Payload"
A sync byte (0x47) followed ) followed by 203 payload bytes.

"Head/204 Payload"
A sync byte (0x47) followed by three header bytes and 204 payload
bytes.

"Sync/207 Payload"
A sync byte (0x47) followed ) followed by 207 payload bytes.

Remote command: 
:TSGen:CONFigure:TSPacket on page 136

TS Player
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PID Test Packet
If a header is present in the test packet ("Test TS Packet > Head/184 Payload"), you
can specify a fixed or variable packet identifier (PID).

"Null" The header of the test transport stream packets has a fixed setting of
null packet header 1FFF (hex).

"Variable" Uses the header value defined with PID (Hex).

Remote command: 
:TSGen:CONFigure:PIDTestpack on page 133

PID (Hex)
Sets the PID.

If "PID Test Packet > Null", "PID (Hex) = 1FFF" is fixed.

If "PID Test Packet > Variable", you can edit the value.

Remote command: 
:TSGen:CONFigure:PID on page 132

Payload Test/Stuff
Defines the payload area content of the TS packet.

"PRBS" PRBS data in accordance with ITU-T O.151
See also chapter "Internal Modulation Data" in the R&S SMCV100B
User Manual.

"0x00" Exclusively 00 (hex) data

"0xFF" Exclusively FF (hex) data

Remote command: 
:TSGen:CONFigure:PAYLoad on page 132

PRBS
Sets the length of the PRBS sequence.

You can select a PRBS 15 or a PRBS 23 sequence as specified by ITU-T O.151.

Remote command: 
:TSGen:CONFigure:PRBS[:SEQuence] on page 133

3.11.3  Seamless Loop Settings

Displaying the tab requires a *.trp, *.trp_c, *.emc or *.emc_c file loaded into the
"TS Player" dialog. *.trp files are previously recorded files.

TS Player
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Access:

► Select "TS Player > Seamless Loop".

The tab provides settings necessary to configure settings for playing the file in a
loop.

Settings:

Continuity Counter........................................................................................................ 67
PCR, DTS/PTS............................................................................................................. 67
TDT/TOT....................................................................................................................... 67

Continuity Counter
Activates the correction of the continuity counters in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.

Remote command: 
:TSGen:CONFigure:SEAMless:CC on page 134

PCR, DTS/PTS
Activates the correction of time stamps in the replayed TS data stream. The correction
allows you to decode the stream without interruption when the play file is looping.

If you set "Nullpacket Stuffing = On" and "PCR, DTS/PTS = On", the time stamps in the
streams are corrected when nullpackets are inserted into the stream.

Remote command: 
:TSGen:CONFigure:SEAMless:PCR on page 134

TDT/TOT
Activates the correction of the time and date table in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.

Remote command: 
:TSGen:CONFigure:SEAMless:TT on page 134

TS Player
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3.12  Local IP Data Network Settings

Access:

1. Select "Input Signal > General > Source > External".

2. Select "Input Signal > General > Input > IP"

3. Select "Input Signal > IP Channel x > Local IP Data Network".

The tab provides access to local IP data settings necessary to configure the board
address.

The remote commands necessary to configure local IP data network settings are
described in Chapter 5.10, "BCIP Subsystem", on page 138.

How to: Chapter 4.1.1, "How to Apply an External IP Input Signal", on page 71

Settings:

Network Status..............................................................................................................68
Restart Network............................................................................................................ 69
Hostname......................................................................................................................69
Address Mode............................................................................................................... 69
IP Address.....................................................................................................................69
Protocol......................................................................................................................... 70
Subnet Mask................................................................................................................. 70
Show Connector............................................................................................................70
MAC Address................................................................................................................ 70

Network Status
Indicates that the instrument is connected to the network.

If the instrument is disconnected, try "Restart Network".

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:STATus on page 140

Local IP Data Network Settings
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Restart Network
Terminates the network connection of the instrument and sets it up again later. You can
use this function to fix network problems.

Note: This function restarts only the connection of the instrument to the network. It
does not impact the network itself.

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:RESTart on page 140

Hostname
Displays the hostname.

Displayed is the board name, that is the name of the IP data board of the
R&S SMCV100B, e.g. SMCV100B-123456-IP-Data.

Each instrument is delivered with an assigned hostname, a logical name which can be
used instead of the IP address. With the default network settings, the IP address is
allocated by the DHCP server. This address can change each time the instrument is
reconnected. Unlike the IP address, the hostname name does not change.

Note:
This function is password-protected. Unlock the protection level 1 to access it.
We recommend that you do not change the default network settings or the hostname
to avoid problems with the network connection.

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:COMMon:HOSTname on page 139

Address Mode
Selects the mode for assigning the IP address.

"Auto (DHCP)"
Assigns the IP address automatically, provided the network supports
DHCP.

"Static" Enables you to assign the IP address manually.

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:MODE on page 139

IP Address
Displays the IP address of the instrument in the local IP data network.

By default, the R&S SMCV100B is configured to use dynamic TCP/IP configuration
and to obtain the whole address information automatically.

If the network does not support DHCP or the attempt does not succeed, the instrument
tries to obtain the IP address via Zeroconf (APIPA) protocol. IP addresses assigned via
Zeroconf start with the number blocks 169.254.*.*.

Note: An IP address that is assigned via the Zeroconf protocol although the network
requires an IP address assigned via the DHCP server can cause network connection
failures.

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress on page 139

Local IP Data Network Settings



DVB-T2 Configuration and SettingsR&S®SMCVB-K164

70User Manual 1179.0974.02 ─ 03

Protocol
Sets the protocol type of the input IP data.

The current firmware supports UDP and UDP/RTP.

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:PROTocol on page 140

Subnet Mask
Displays the bit group of the subnet in the host identifier.

To assign the subnet mask manually, select "Address Mode > Static".

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:SUBNet:MASK
on page 139

Show Connector
Accesses a dialog that displays the physical location of the selected connector on the
front/rear panel of the instrument.

MAC Address
Displays the MAC address, a unique identifier of the network adapter in the
R&S SMCV100B.

Remote command: 
:SYSTem:COMMunicate:BCIP<hw>:NETWork:MACaddress on page 140

Local IP Data Network Settings
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4  Performing DVB-T2 Signal Generation
Tasks
This chapter tells you how to configure the R&S SMCV100B to generate signals for
simple receiver tests.

● Configuring the Input Signal....................................................................................71
● Monitoring the Input Signal..................................................................................... 76

4.1  Configuring the Input Signal

This chapter provides an overview of the different input signals, that the
R&S SMCV100B uses as modulation data.

● How to Apply an External IP Input Signal............................................................... 71
● How to Apply an External TS Input Signal.............................................................. 74
● How to Generate an Internal TS Signal.................................................................. 75

4.1.1  How to Apply an External IP Input Signal

To connect the R&S SMCV100B to local IP data network

1. Connect the IP source to the "IP Data" connector of the R&S SMCV100B.
See chapter "Connecting to IP Data Interface" in the R&S SMCV100B Getting Star-
ted user manual.

2. Select "Input Signal > General > Source > External".

3. Select "Input Signal > General > Input > IP".

4. In the "IP Channel x" side tab, click "Local IP Data Network".

By default, the R&S SMCV100B assigns the IP address automatically using DHCP
("Address Mode > Auto (DHCP)").

5. If "Network Status > Disconnected", try "Restart Network".

Configuring the Input Signal
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The R&S SMCV100B is connected to the local IP data network.

6. If DHCP does not assign an IP address, assign the IP address manually.
See chapter "How to Assign the IP Address" in the R&S SMCV100B user manual.

7. Specify the protocol type of the input IP data.
The current firmware supports UDP and UDP/RTP.

To configure an external IP input signal

The R&S SMCV100B is connected to a local IP data network, see "To connect the
R&S SMCV100B to local IP data network" on page 71.

1. Specify general IP input signal properties:

a) Select "Input Signal > General > Source > External".
b) Select "Input > IP".
c) Specify the IP TS Channel, e.g. "IP TS Channel > 1".

The "IP Channel 1" side tab appears, where you can configure the IP connection
for channel 1 and channel-independent local IP network settings.

1

1 = IP channel notation: IP TS Channel

Configuring the Input Signal
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2. Optionally, if supported, activate "Stuffing" to adjust the TS data rate.

3. Specify IP TS channel properties, e.g. for "IP TS Channel > 1":

a) Define the input type, e.g. "Type > Multicast".
b) Specify the "Multicast Address", that is the destination IPv4 address of the IP

connection.
Note: Use the destination address also in the IP data source, e.g. a stream
program.

c) Specify the port, that is the destination port of the IP connection.
Note: Use the destination port also in the IP data source.

d) Specify the IGMPv3 source address, that is the source IPv4 address of the IP
connection.
A source address different from "0.0.0.0" accepts only data originating from the
specified IP address.

e) Optionally, to check availability of the "IGMPv3 Source Address", click "Ping
Source Address"
● If "Ping Result > Ping: Successful", the source address is available.
● If "Ping Result > Ping: Transmit Failed. Destination Host Unreachable", try

another address.
f) Optionally, specify a name for the IP connection, e.g. "Alias > Service".
g) Activate the IP channel, select "Input IP > On".

The R&S SMCV100B is prepared for receiving IP TS data, that is input at the "IP
Data" connector.

Monitor IP data stream properties in the "Info" side tab, see Chapter 4.2.1, "How to
Monitor External IP Input Data", on page 76.

Configuring the Input Signal



Performing DVB-T2 Signal Generation TasksR&S®SMCVB-K164

74User Manual 1179.0974.02 ─ 03

4.1.2  How to Apply an External TS Input Signal

To connect to the external TS input interface

1. Use a double-shielded 75 Ω BNC cable for connection between R&S SMCV100B
and the external MPEG TS data source.
See also Section "Cable selection and electromagnetic interference (EMI)" in the
R&S SMCV100B Getting Started user manual.

2. At the R&S SMCV100B, connect the cable to the "User 1" connector.
The connector is on the rear panel of the R&S SMCV100B.
How to: Section "To connect to non-screwable connectors (BNC)" in the
R&S SMCV100B Getting Started user manual.

To specify the TS input interface at the R&S SMCV100B

The R&S SMCV100B is connected to an MPEG TS data source via the "User 1" con-
nector.

1. Select "Input Signal > General > Source > External".

2. Select "General > Global Connectors".

3. In the "Global Connectors" dialog, configure the "User 1" connector for a TS input
signal:

a) Select "Direction > Input".
b) Select "Signal > TS".

To configure an external TS input signal

The R&S SMCV100B is prepared for receiving a TS input signal at the "User 1" con-
nector.

1. Specify general TS input signal properties:

a) Select "Input Signal > General > Source > External".
b) Select "Input > TS IN".
c) Specify the format of the input signal:

● Select "ASI", if you have a source supporting ASI format.
● Select "SMPTE 310", if you have a source supporting SMPTE 310 format.

2. Optionally, activate "Stuffing" to adjust the TS data rate.

Configuring the Input Signal
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You can further specify the payload of the stuffing data, see "Test Signal > Payload
Test/Stuff."

The R&S SMCV100B is prepared for receiving TS data, that is input at the "User 1"
connector.

Monitor TS data stream properties in the "Info" side tab, see Chapter 4.2.2, "How to
Monitor an External TS Input Signal", on page 77.

4.1.3  How to Generate an Internal TS Signal

To play a TS file with the "TS Player"

1. Select "Input Signal > Source > TS Player".

The "TS Player" button appears below.

2. Click "TS Player".

The "TS Player" dialog for playing TS data files opens.

3. Click "Play" to play the default file DIVER.trp.
Playing the file requires no option.

To play a file of stream library with the "TS Player"

1. Download the

2. Select "Input Signal > Source > TS Player".

The "TS Player" button appears below.

3. Click "TS Player".

The "TS Player" dialog for playing TS data files opens.

4. Click "Play" to play the default file DIVER.trp.

Configuring the Input Signal
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Playing the file requires no option.

4.2  Monitoring the Input Signal

This chapter provides an overview of the different input signals, that the
R&S SMCV100B uses as modulation data.

● How to Monitor External IP Input Data....................................................................76
● How to Monitor an External TS Input Signal........................................................... 77
● How to Monitor an Internal TS Player Signal.......................................................... 77

4.2.1  How to Monitor External IP Input Data

The R&S SMCV100B receives external IP input data as described in Chapter 4.1.1,
"How to Apply an External IP Input Signal", on page 71.

► Select "Input Signal > Info"

The "Info" side tab displays physical properties of the input IP stream data.

The standard packet length is 188 byte. The maximum useful data rate is specified by
the broadcast standard.

The measured data rate is lower and depends on the TS source settings. The useful
data rate is lower than the measured data rate due to null packets present in the trans-
port stream.

If "Stuffing > On", the useful data rate can be lower than the maximum useful data rate.

Monitoring the Input Signal
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4.2.2  How to Monitor an External TS Input Signal

The R&S SMCV100B receives external TS input data as described in Chapter 4.1.2,
"How to Apply an External TS Input Signal", on page 74.

► Select "Input Signal > Info"

The "Info" side tab displays physical properties of the input TS stream data.

4.2.3  How to Monitor an Internal TS Player Signal

The R&S SMCV100B receives internal TS input data as described in Chapter 4.1.3,
"How to Generate an Internal TS Signal", on page 75.

► Select "Input Signal > Info"

The "Info" side tab displays physical properties of the TS player stream data.

Monitoring the Input Signal
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5  Remote-Control Commands
The following commands are required to generate signals with the DVB-T2 option in a
remote environment. We assume that the R&S SMCV100B has already been set up
for remote operation in a network as described in the R&S SMCV100B documentation.
A knowledge about the remote control operation and the SCPI command syntax are
assumed.

Conventions used in SCPI command descriptions
For a description of the conventions used in the remote command descriptions, see
section "Remote-Control Commands" in the R&S SMCV100B user manual.

Common suffixes

The following common suffixes are used in the remote commands:

Suffix Value range Description

SOURce<hw> 1 Available baseband signals

PLP<ch> 1 to 20 Available number PLPs

Programming examples

This description provides simple programming examples. The purpose of the examples
is to present all commands for a given task. In real applications, one would rather
reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the example
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of the most remote control program, an instrument preset/reset is rec-
ommended to set the instrument to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

The following commands specific to the DVB-T2 are described here:

● General Commands................................................................................................79
● Input Commands.....................................................................................................81
● Mode and Stream Commands................................................................................ 95
● BICM Commands..................................................................................................101
● OFDM Commands................................................................................................ 105
● System Commands...............................................................................................109
● SFN Delay Commands......................................................................................... 120
● Frame Info Commands......................................................................................... 125
● TSGen Subsystem................................................................................................130
● BCIP Subsystem...................................................................................................138
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5.1  General Commands

Example: Saving current configuration
:SOURce1:BB:T2DVb:SETTing:STORe "/var/user/my_dvbt2"
// Saves the file "my_dvbt2.dvbt2" in the directory as above.

*RST

:SOURce1:BB:T2DVb:SETTing:CATalog?
// Response: my_dvbt2
:SOURce1:BB:T2DVb:SETTing:LOAD "/var/user/my_dvbt2"
:SOURce1:BB:T2DVb:STATe 1
:SOURce1:BB:T2DVb:SETTing:DELete "/var/user/my_dvbt2"

Commands

[:SOURce<hw>]:BB:T2DVb:PRESet.................................................................................. 79
[:SOURce<hw>]:BB:T2DVb:STATe.....................................................................................79
[:SOURce<hw>]:BB:T2DVb:SETTing:CATalog?...................................................................80
[:SOURce<hw>]:BB:T2DVb:SETTing:DELete......................................................................80
[:SOURce<hw>]:BB:T2DVb:SETTing:LOAD........................................................................80
[:SOURce<hw>]:BB:T2DVb:SETTing:STORe......................................................................80

[:SOURce<hw>]:BB:T2DVb:PRESet

Sets the parameters of the digital standard to their default values (*RST values speci-
fied for the commands).

Not affected is the state set with the command SOURce<hw>:BB:T2DVb:STATe.

Example: See Example "Saving current configuration" on page 79.

Usage: Event

Manual operation: See "Set To Default" on page 13

[:SOURce<hw>]:BB:T2DVb:STATe <State>

Activates the standard and deactivates all the other digital standards and digital modu-
lation modes in the same path.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Saving current configuration" on page 79.

Manual operation: See "State" on page 13

General Commands
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[:SOURce<hw>]:BB:T2DVb:SETTing:CATalog?

Queries the files with settings in the default directory. Listed are files with the file exten-
sion *.dvbt2.

Return values: 
<FileNames> <filename1>,<filename2>,...

Returns a string of filenames separated by commas.

Example: See Example "Saving current configuration" on page 79.

Usage: Query only

Manual operation: See "Save/Recall" on page 13

[:SOURce<hw>]:BB:T2DVb:SETTing:DELete <Delete>

Deletes the selected file from the default or the specified directory. Deleated are files
with extension *.dvbt2.

Parameters:
<Filename> "<filename>"

Filename or complete file path; file extension can be omitted

Example: See Example "Saving current configuration" on page 79.

Usage: Setting only

Manual operation: See "Save/Recall" on page 13

[:SOURce<hw>]:BB:T2DVb:SETTing:LOAD <Recall>

Loads the selected file from the default or the specified directory. Loaded are files with
extension *.dvbt2.

Parameters:
<Filename> "<filename>"

Filename or complete file path; file extension can be omitted

Example: See Example "Saving current configuration" on page 79.

Manual operation: See "Save/Recall" on page 13

[:SOURce<hw>]:BB:T2DVb:SETTing:STORe <Save>

Saves the current settings into the selected file; the file extension (*.dvbt2) is
assigned automatically.

Parameters:
<Filename> "<filename>"

Filename or complete file path

Example: See Example "Saving current configuration" on page 79.

General Commands
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Manual operation: See "Save/Recall" on page 13

5.2  Input Commands

The section contains the commands for configuring the input signal. It also contains
commands for querying IP input information.

For configuring IP channel settings and local IP data network parameters, see:
● Chapter 5.2.5, "IP Subsystem", on page 92
● Chapter 5.10, "BCIP Subsystem", on page 138

Commands

● General Commands................................................................................................81
● PLP Info Commands...............................................................................................85
● T2-MI Packet Timing Commands............................................................................88
● Test Signal Commands........................................................................................... 90
● IP Subsystem..........................................................................................................92

5.2.1  General Commands

Example: Querying general T2-MI interface parameters
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface?
// Response: 0

:SOURce1:BB:T2DVb:INPut:T2MI:INTerface ON
:SOURce1:BB:T2DVb:INPut:T2MI:ANALyzer?
// Response: "No error"

:SOURce1:BB:T2DVb:INPut:T2MI:RESetlog
:SOURce1:BB:T2DVb:INPut:T2MI:PID #H1000
:SOURce1:BB:T2DVb:INPut:T2MI:SID #H0

Example: Configuring general input signal properties
:SOURce1:BB:T2DVb:SOURce EXT

//********************************************************************************
// Incoming MPEG transport stream for single PLP transmission.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface 0

//********************************************************************************
// Incoming T2-MI stream.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface 1
// Input transport stream for single- or multi-PLP transmission.

Input Commands
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//********************************************************************************
// Prepare for IP based transport stream
//********************************************************************************
:SOURce1:BB:T2DVb:INPut?
// Response: "TS"
:SOURce1:BB:T2DVb:INPut:FORMat?
// Response: "ASI"
:SOURce1:BB:T2DVb:INPut IP
:SOURce1:BB:T2DVb:INPut:TSCHannel 2

//********************************************************************************
// Query incoming stream properties
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:NPLP?
// Response: 1
:SOURce1:BB:T2DVb:INPut:T2MI:ANALyzer?
// Response: "No error"

For configuring IP channel settings and local IP data network parameters, see:
● Chapter 5.2.5, "IP Subsystem", on page 92
● Chapter 5.10, "BCIP Subsystem", on page 138

Commands

[:SOURce<hw>]:BB:T2DVb:SOURce.................................................................................82
[:SOURce<hw>]:BB:T2DVb:INPut......................................................................................82
[:SOURce<hw>]:BB:T2DVb:INPut:FORMat.........................................................................83
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:ANALyzer?............................................................ 83
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:INTerface...............................................................83
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:PID....................................................................... 83
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:RESetlog...............................................................84
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:SID....................................................................... 84
[:SOURce<hw>]:BB:T2DVb:INPut:TSCHannel.................................................................... 84

[:SOURce<hw>]:BB:T2DVb:SOURce <Dvbt2Source>

Sets the modulation source for the input signal.

Parameters:
<Dvbt2Source> EXTernal | TSPLayer | TESTsignal

*RST: EXTernal

Manual operation: See " Source " on page 16

[:SOURce<hw>]:BB:T2DVb:INPut <Dvbt2Input>

Sets the external input interface.

Parameters:
<Dvbt2Input> TS | IP

*RST: TS

Input Commands
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Manual operation: See " Input " on page 17

[:SOURce<hw>]:BB:T2DVb:INPut:FORMat <Dvbt2InpFormat>

Sets the input format of the input signal.

Parameters:
<Dvbt2InpFormat> ASI | SMPTE

*RST: ASI

Example: See Example "Configuring general input signal properties"
on page 81.

Manual operation: See " Input Format " on page 17

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:ANALyzer?

Queries the status of the T2-MI analyzer by an error message.

Return values: 
<Analyzer> string

No error
Implies correct behavior of the analyzer.
*RST: No error

Example: See Example "Querying general T2-MI interface parameters"
on page 81.

Usage: Query only

Manual operation: See "Status Info" on page 15

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:INTerface <Interface>

Activates the T2-MI modulator interface.

Parameters:
<Interface> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Querying general T2-MI interface parameters"
on page 81.

Example: See Example "Querying T2-MI packet timing parameters"
on page 88.

Manual operation: See "T2-MI Interface" on page 14

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:PID <Pid>

Sets the PID.

The PID belongs to MPEG transport stream packets, that contain T2-MI data.

Input Commands
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Parameters:
<Pid> integer

Range: #H0  to  #H1FFF
*RST: #H1000

Example: See Example "Querying general T2-MI interface parameters"
on page 81.

Manual operation: See "T2-MI PID (Hex)" on page 14

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:RESetlog

Resets the log file.

Example: See Example "Querying general T2-MI interface parameters"
on page 81.

Usage: Event

Manual operation: See "Reset Log File" on page 14

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:SID <Sid>

Sets the T2-MI transport SID.

Use the SID, when transmitting a composite signal, in accordance with annex I of the
specification ETSI EN 302 755.

Parameters:
<Sid> integer

Range: #H0  to  #H7
*RST: #H0

Example: See Example "Querying general T2-MI interface parameters"
on page 81.

[:SOURce<hw>]:BB:T2DVb:INPut:TSCHannel <Dvbt2TsChannel>

Selects the IP-based transport stream (TS) channel. You can select 1 out of 4 IP TS
channels as input at the "IP Data" interface.

To configure a particular channel, see Chapter 3.2.5, "IP Channnel x Settings",
on page 26.

Parameters:
<Dvbt2TsChannel> 1 | 2 | 3 | 4

*RST: 1

Example: See Example "Configuring general input signal properties"
on page 81.

Manual operation: See "IP TS Channel" on page 18

Input Commands
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5.2.2  PLP Info Commands

Example: Querying PLP input properties
:SOURce1:BB:T2DVb:SOURce EXT

//********************************************************************************
// Query properties of external input signals at TS IN interface.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut TS
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface?
// Response: "0"

:SOURce1:BB:T2DVb:INPut:NPLP?
// Response: 1

// Single-PLP transmission. PLP<ch> = PLP1 in SCPI denotes PLP 0 in GUI.
:SOURce1:BB:T2DVb:PLP1:INPut:FORMat?
// Response: "TS"
:SOURce1:BB:T2DVb:PLP1:PACKetlength?
// Response: P188
:SOURce1:BB:T2DVb:PLP1:INPut:STUFfing?
// Response: "ON"
:SOURce1:BB:T2DVb:PLP1:USEFul:RATE:MAX?
// Response: 36140759 Bit/s
:SOURce1:BB:T2DVb:PLP1:INPut:DATarate?
// Response: 5018504 Bit/s
:SOURce1:BB:T2DVb:PLP1:USEFul:RATE?
// Response: 4550760 Bit/s

//********************************************************************************
// Query properties of external input signals at IP Data interface.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut IP
:SOURce1:BB:T2DVb:INPut:TSCHannel 1
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface?
// Response: "1"

:SOURce1:BB:T2DVb:INPut:NPLP?
// Response: "19"
// Multi-PLP transmission.

:SOURce1:BB:T2DVb:PLP19:INPut:FORMat?
// Response: "GFPS"
// PLP 18 (GUI) input format is a generic fixed-length packetized stream.

:SOURce1:BB:T2DVb:PLP19:USEFul:RATE?
// Response: 100344 Bit/s

//********************************************************************************
// Query properties of internal TS player input signals.
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//********************************************************************************
:SOURce1:BB:T2DVb:SOURce TSPL
:SOURce1:BB:T2DVb:PLP1:INPut:FORMat?
// Response: "TS"

:SOURce1:BB:T2DVb:PLP1:USEFul:RATE:MAX?
// Response: 38583461 Bit/s

:SOURce1:BB:T2DVb:PLP1:USEFul:RATE?
// Response: 4566952 Bit/s

Commands

[:SOURce<hw>]:BB:T2DVb:INPut:NPLP?.......................................................................... 86
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:FORMat.......................................................... 86
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:STUFfing.........................................................87
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:PACKetlength?..........................................................87
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:USEFul[:RATE]?....................................................... 87
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:USEFul[:RATE]:MAX?................................................88
[:SOURce<hw>]:BB:T2DVb:PLP<ch>[:INPut]:DATarate?......................................................88

[:SOURce<hw>]:BB:T2DVb:INPut:NPLP?

Displays the number of PLPs.

Return values: 
<Nplp> integer

Range: 1  to  20
*RST: 1

Example: See Example "Querying PLP input properties" on page 85.

Usage: Query only

Manual operation: See "Number of PLPs" on page 17

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:FORMat <Format>

Queries the input format of each PLP <num> for all input sources.

Parameters:
<Format> GFPS | GCS | GSE | TS

GFPS
Generic fixed-length packetized stream
GCS
Generic continuous stream
GSE
Generic stream encapsulation
TS
Transport stream
*RST: TS

Input Commands
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Manual operation: See "PLP Input Format" on page 19

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:STUFfing <Stuffing>

Activates stuffing.

Parameters:
<Stuffing> OFF | ON

ON
Inserts null packets and corrects the PCR values.
OFF
The data rate of the transport stream source must match the
data rate required for the current modulation parameters.
*RST: ON

Manual operation: See "Stuffing" on page 18

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:PACKetlength?

Queries the packet length of the external transport stream in bytes.

Return values: 
<Packetlength> P188 | INValid

P188|P204|P208
188/204/208 byte packets specified for serial input and parallel
input.
INValid
Packet length does not match the specified length.

Usage: Query only

Manual operation: See " Packet Length " on page 19

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:USEFul[:RATE]?

Queries the data rate of useful data ruseful of the external transport stream. The data
rate is measured at the input of the installed input interface.

Return values: 
<Rate> integer

Range: 0  to  999999999
*RST: 0

Usage: Query only

Manual operation: See "Useful Data Rate / Mbit/s" on page 20
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[:SOURce<hw>]:BB:T2DVb:PLP<ch>:USEFul[:RATE]:MAX?

Queries the maximum data rate, that is derived from the current modulation parameter
settings.

The value is the optimal value at the TS input interface, that is necessary for the modu-
lator.

Return values: 
<Max> integer

Range: 0  to  999999999

Usage: Query only

Manual operation: See "Max. Useful Data Rate / Mbit/s" on page 20

[:SOURce<hw>]:BB:T2DVb:PLP<ch>[:INPut]:DATarate?

Queries the measured value of the data rate of one of the following:
● External transport stream including null packets input at "User 1" connector
● External transport stream including null packets input at "IP Data/LAN" connector

(TSoverIP)

The value equals the sum of useful data rate rmeas and the rate of null packets r0:

rmeas =  rmeas +  r0

Return values: 
<Datarate> integer

Range: 0  to  999999999

Usage: Query only

Manual operation: See "Measured Data Rate / Mbit/s" on page 20

5.2.3  T2-MI Packet Timing Commands

Example: Querying T2-MI packet timing parameters
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface ON
:SOURce1:BB:T2DVb:INPut:T2MI:MEASuremode ABSOLUTE

// All following responses to timing commands are in seconds.
:SOURce1:BB:T2DVb:INPut:T2MI:MIN:T1?
// Response: 0.297277
:SOURce1:BB:T2DVb:INPut:T2MI:MIN:T2?
// Response: 0.155838
:SOURce1:BB:T2DVb:INPut:T2MI:MIN:T3?
// Response: 0
:SOURce1:BB:T2DVb:INPut:T2MI:MAX:T1?
// Response: 0.254925
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:SOURce1:BB:T2DVb:INPut:T2MI:MAX:T2?
// Response: 0
:SOURce1:BB:T2DVb:INPut:T2MI:MAX:T3?
// Response: 0.303451
:SOURce1:BB:T2DVb:INPut:T2MI:MAX:T4?
// Response: 0

Commands

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MEASuremode.......................................................89
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T3?................................................................ 89
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T2?................................................................ 89
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T1?................................................................ 89
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T4?...............................................................90
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T3?...............................................................90
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T2?...............................................................90
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T1?...............................................................90

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MEASuremode <Measuremode>

Specifies the measurement mode to configure the evaluation of T2-MI timing parame-
ters.

Parameters:
<Measuremode> ABSOLUTE | DELTA

*RST: ABSOLUTE

Example: See Example "Querying T2-MI packet timing parameters"
on page 88.

Manual operation: See "Measurement Mode" on page 22

[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T3?
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T2?
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MIN:T1?
Queries the current value of minimum time parameters Tmin1/Tmin2/Tmin3.

Return values: 
<MinT1> float

Range: -99.999999  to  99.999999
Increment: 0.000001
*RST: 0
Default unit: s

Example: See Example "Querying T2-MI packet timing parameters"
on page 88.

Usage: Query only

Manual operation: See "T2-MI Tmin1" on page 22
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[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T4?
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T3?
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T2?
[:SOURce<hw>]:BB:T2DVb:INPut:T2MI:MAX:T1?
Queries the current value of the maximum time parameters Tmax1/Tmax2/Tmax3/Tmax4.

Return values: 
<MaxT1> float

Range: -99.999999  to  99.999999
Increment: 0.000001
*RST: 0
Default unit: s

Example: See Example "Querying T2-MI packet timing parameters"
on page 88.

Usage: Query only

Manual operation: See "T2-MI Tmax1" on page 23

5.2.4  Test Signal Commands

Example: Configuring test signal properties
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface OFF

:SOURce1:BB:T2DVb:SOURce TEST
:SOURce1:BB:T2DVb:PLP1:INPut:TESTsignal?
// Response: TTSP
:SOURce1:BB:T2DVb:PLP1:INPut:FORMat?
// Response: TS

//********************************************************************************
// Configure test signal properties.
//********************************************************************************
:SOURce1:BB:T2DVb:TSPacket H184
:SOURce1:BB:T2DVb:PIDTestpack NULL
:SOURce1:BB:T2DVb:PID?
// Response: 8191 in decimal representation
// 1FFF in hexadecimal representation

:SOURce1:BB:T2DVb:PIDTestpack VAR
:SOURce1:BB:T2DVb:PID 4607
// Corresponds to 11FF in hexadecimal representation

:SOURce1:BB:T2DVb:PAYLoad PRBS
:SOURce1:BB:T2DVb:PRBS P23_1
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Commands

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:TESTsignal...................................................... 91
[:SOURce<hw>]:BB:T2DVb:PAYLoad.................................................................................91
[:SOURce<hw>]:BB:T2DVb:PID........................................................................................ 91
[:SOURce<hw>]:BB:T2DVb:PIDTestpack............................................................................91
[:SOURce<hw>]:BB:T2DVb:PRBS[:SEQuence]...................................................................92
[:SOURce<hw>]:BB:T2DVb:TSPacket................................................................................92

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:INPut:TESTsignal <TestSignal>

Defines the test signal data.

Parameters:
<TestSignal> TTSP

*RST: TTSP

Manual operation: See "Test Signal" on page 18

[:SOURce<hw>]:BB:T2DVb:PAYLoad <Payload>

Defines the payload area content of the TS packet.

Parameters:
<Payload> PRBS | H00 | HFF

*RST: PRBS

Manual operation: See "Payload Test/Stuff" on page 25

[:SOURce<hw>]:BB:T2DVb:PID <Pid>

Sets the PID.

Parameters:
<Pid> integer

Range: 0  to  8191
*RST: 8191

Manual operation: See "PID (Hex)" on page 25

[:SOURce<hw>]:BB:T2DVb:PIDTestpack <PidTSPacket>

If a header is present in the test packet ("Test TS Packet > Head/184 Payload"), you
can specify a fixed or variable packet identifier (PID).

Parameters:
<PidTSPacket> NULL | VARiable

*RST: NULL

Manual operation: See " PID Test Packet" on page 25
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[:SOURce<hw>]:BB:T2DVb:PRBS[:SEQuence] <Prbs>

Sets the length of the PRBS sequence.

You can select a PRBS 15 or a PRBS 23 sequence as specified by ITU-T O.151.

Parameters:
<Prbs> P23_1 | P15_1

*RST: P23_1

Manual operation: See "PRBS" on page 25

[:SOURce<hw>]:BB:T2DVb:TSPacket <TSPacket>

Specifies the structure of the test transport stream packet that is fed to the modulator.

Parameters:
<TSPacket> H184 | S187

*RST: H184

Manual operation: See "Test TS Packet" on page 25

5.2.5  IP Subsystem

The SOURce:BB:INPut:IP subsystem contains the commands for configuring input
IP data from a local IP data network.

To configure local IP data network parameters, see Chapter 5.10, "BCIP Subsystem",
on page 138.

Common suffixes

The following common suffixes are used in the SOURce:BB:INPut:IP remote com-
mands:

Suffix Value range Description

IP<ch> 1 to 4 IP channel number

Example: Configure IP channel 2 properties
// Use the data from IP channel 2 as input for modulation data.
:SOURce1:BB:INPut:IP2:STATe ON
// Specify alias as "Alias 2".
:SOURce1:BB:INPut:IP2:ALIas "Alias 2"

//********************************************************************************
// Define Unicast properties.
//********************************************************************************
:SOURce1:BB:INPut:IP2:TYPe UNI
// Local IP data interface is configured for Unicast reception
:SOURce1:BB:INPut:IP2:PORT 6002
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//********************************************************************************
// Define Multicast properties.
//********************************************************************************
:SOURce1:BB:INPut:IP2:TYPe MULT
// Local IP data interface is configured for Multicast reception
:SOURce1:BB:INPut:IP2:MULTicast:ADDRess?
// Response: "226.0.0.0"
:SOURce1:BB:INPut:IP2:IGMP:SOURce:ADDRess?
// Response: "0.0.0.0"
:SOURce1:BB:INPut:IP2:IGMP:SOURce:ADDRess "192.168.10.1"
:SOURce1:BB:INPut:IP2:IGMP:SOURce:PING
:SOURce1:BB:INPut:IP2:IGMP:SOURce:RESult?
// Response: "Ping: Successful"
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[:SOURce<hw>]:BB:INPut:IP<ch>[:STATe]..........................................................................93
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[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING.................................................... 95
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[:SOURce<hw>]:BB:INPut:IP<ch>[:STATe] <Alias>

Activates/deactivates the "IP Channel x" as IP input.

Specify the current IP TS Channel with the command
SOURce1:BB:DigStd:INPut:TSCHannel. DigStd stands for the IP TS Channel in
the corresponding broadcast standard.

Parameters:
<Alias> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configure IP channel 2 properties" on page 92.

Manual operation: See "Input IP" on page 27

[:SOURce<hw>]:BB:INPut:IP<ch>:ALIas <Alias>

Specifies an alias, i.e. name for the IP connection.

Parameters:
<Alias> string

Example: See Example "Configure IP channel 2 properties" on page 92.

Manual operation: See "Alias" on page 27
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[:SOURce<hw>]:BB:INPut:IP<ch>:PORT <Port>

Sets the port of the input IP data at the "IP Data" connector.

Parameters:
<Port> integer

Range: 0  to  65535
*RST: 6002

Example: See Example "Configure IP channel 2 properties" on page 92.

Manual operation: See "Port" on page 28

[:SOURce<hw>]:BB:INPut:IP<ch>:TYPE <Type>

Sets the IP input type.

Parameters:
<Type> UNIcast | MULTicast

UNIcast
Analyzes all unicast IP packets that arrive at the specified port.
See [:SOURce<hw>]:BB:INPut:IP<ch>:PORT on page 94.

MULTicast
When an IP address is in the multicast address range, an
attempt is made to join a multicast group using IGMP. Set multi-
cast address and port.
See:
[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess
on page 94
[:SOURce<hw>]:BB:INPut:IP<ch>:PORT on page 94

*RST: UNIcast

Example: See Example "Configure IP channel 2 properties" on page 92.

Manual operation: See "Type" on page 28

[:SOURce<hw>]:BB:INPut:IP<ch>:MULticast:ADDRess

Sets the destination IP address (IPv4) of the IP connection.

Parameters:
<Address> string

Range: 224.0.0.0  to  239.255.255.255

Example: See Example "Configure IP channel 2 properties" on page 92.

Manual operation: See "Multicast Address" on page 28

[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:ADDRess

Specifies the IGMP source address of the network.
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Parameters:
<Address> string

Example: See Example "Configure IP channel 2 properties" on page 92.

Manual operation: See "IGMPv3 Source Address" on page 28

[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING

Triggers pinging of the IGMP source address in the local IP data network. Query the
result via [:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult?
on page 95.

Example: See Example "Configure IP channel 2 properties" on page 92.

Usage: Event

Manual operation: See "Ping Source Address" on page 28

[:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:RESult?

Queries the result of pinging the IGMP source address.

See [:SOURce<hw>]:BB:INPut:IP<ch>:IGMP[:SOURce]:PING on page 95.

Return values: 
<PingResult> string

Returns ping messages.

Example: See Example "Configure IP channel 2 properties" on page 92.

Usage: Query only

Manual operation: See "Ping Result" on page 28

5.3  Mode and Stream Commands

The section contains the commands for configuring mode and stream parameters of
individual PLPs.

Example: Configuring mode and stream parameters
//********************************************************************************
// Enable setting of PLP 0 parameters by deactivating the T2-MI interface.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface OFF

//********************************************************************************
// Set PLP 0 mode and stream parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:PLP1:ID 0
:SOURce1:BB:T2DVb:PLP1:GROup 0
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:SOURce1:BB:T2DVb:PLP1:TYPE?
// Response: DT1
// Fixed type for single-PLP transmission.
:SOURce1:BB:T2DVb:PLP1:BB_Mode HEM
// Enables high-efficiency baseband mode.

//********************************************************************************
// Query PLP 0 mode and stream parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:PLP1:ISSY?
// Response: OFF
// The synchronizer uses a short input stream clock reference.
:SOURce1:BB:T2DVb:PLP1:NPD?
// Response: 0
// Null packet deletion is off.
// Query in-band signaling state.
:SOURce1:BB:T2DVb:PLP1:IBS?
// Response: 0
:SOURce1:BB:T2DVb:L:T2Version V121
// Setting L1 T2 version V1.2.1 allows querying in-band sign. types A/B states.
:SOURce1:BB:T2DVb:PLP1:IBS:A?
// Response: 0
:SOURce1:BB:T2DVb:PLP1:IBS:B?
// Response: 0

//********************************************************************************
// Query parameters related to multi-PLP transmission.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:NPLP?
// Response: 4
// Indicates multi-PLP trasmission with four PLPs.
// Query the number of other PLPs signaled within in-band signaling.
:SOURce1:BB:T2DVb:PLP1:OIBPlp?
// Response: 0
:SOURce1:BB:T2DVb:PLP1:CMTYpe?
// Response: ACM
:SOURce1:BB:T2DVb:PLP1:STAFlag?
// Response: "1"
// Static scheduling for PLP 0 from T2 frame to T2 frame.
:SOURce1:BB:T2DVb:PLP1:PADFlag?
// Response: "0"
// BBFrame padding disabled for PLP 0.
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[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ID............................................................................ 99
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ISSY?...................................................................... 99
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:NPD?.....................................................................100
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[:SOURce<hw>]:BB:T2DVb:PLP<ch>:BB_Mode <BBMode>

Defines the baseband mode.

Parameters:
<BBMode> HEM | NM

*RST: HEM

Example: See Example "Configuring mode and stream parameters"
on page 95.

Manual operation: See "BB Mode" on page 30

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CMTYpe?

Queries the CM type for multi-PLP. Multi-PLP requires number of PLPs > 1, see [:
SOURce<hw>]:BB:T2DVb:INPut:NPLP? on page 86.

Return values: 
<CMType> CCM | ACM

CCM
Constant coding and modulation. The setting implies identical
settings for all PLPs of the commands:
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:FECFrame
on page 103
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:RATE on page 104
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CONStel
on page 103
[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CROTation
on page 103
ACM
Variable coding and modulation. Not all PLPs use the same cod-
ing and modulation.
*RST: CCM

Example: SeeExample "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "CM Type" on page 33
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[:SOURce<hw>]:BB:T2DVb:PLP<ch>:GROup <Group>

Sets the PLP group ID for multi-PLP, i.e. the number of PLPs is greater than 1.

See [:SOURce<hw>]:BB:T2DVb:INPut:NPLP? on page 86.

Parameters:
<Group> integer

Range: 0  to  255
*RST: 1

Example: See Example "Configuring mode and stream parameters"
on page 95.

Manual operation: See "PLP Group ID (Hex)" on page 30

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:IBS?

Queries the in-band signaling state.

Return values: 
<IBS> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "In-Band Signaling" on page 33

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:IBS:A?

Queries the in-band signaling type A state.

Query requires L1 T2 specification version higher than V1.1.1, see [:SOURce<hw>]:
BB:T2DVb:L:T2Version on page 118.

Return values: 
<IBSA> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "In-Band Signaling A" on page 33

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:IBS:B?

Queries the in-band signaling type B state.
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Query requires L1 T2 specification version higher than V1.1.1, see [:SOURce<hw>]:
BB:T2DVb:L:T2Version on page 118.

Return values: 
<IBSB> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "In-Band Signaling B" on page 33

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ID <PlpId>

Sets the PLP ID. The PLP ID has to be unique.

Parameters:
<PlpId> integer

Range: 0  to  255
*RST: 0

Example: See Example "Configuring mode and stream parameters"
on page 95.

Manual operation: See "PLP ID (Hex)" on page 30

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:ISSY?

Queries the ISSY state.

Return values: 
<Issy> OFF | SHORt | LONG

OFF
ISSY is not active. ISSY indicator field is 0.
SHORt
ISSY is active. ISSY indicator field is 1. The synchronizer uses a
short ISCR.
LONG
ISSY is active. ISSY indicator field is 1. The synchronizer uses a
long ISCR.
*RST: OFF

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "ISSY" on page 32
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[:SOURce<hw>]:BB:T2DVb:PLP<ch>:NPD?

Queries the null packet deletion state.

Return values: 
<NPD> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "Null Packet Deletion" on page 33

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:OIBPlp?

Queries the number of other PLPs signaled within the in-band signaling of the PLP for
multi-PLP. Multi-PLP requires number of PLPs > 1, see [:SOURce<hw>]:BB:T2DVb:
INPut:NPLP? on page 86.

Return values: 
<OIBPlps> integer

Range: 0  to  255
*RST: 0

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "Other In-Band PLPs" on page 33

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:PADFlag?

Queries if BBFrame padding other than for in-band signaling is used for the current
PLP.

Return values: 
<PaddingFlag> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "Static Padding Flag" on page 34

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:STAFlag?

Queries if the scheduling for the current PLP varies from T2 frame to T2 frame or
remains static.
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Return values: 
<StaticFlag> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Configuring mode and stream parameters"
on page 95.

Usage: Query only

Manual operation: See "Static Flag" on page 34

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TYPE <Type>

Sets the PLP type.

The type depends on the number of PLPs in the setup.

Parameters:
<Type> DT1 | DT2 | COMMon

COMMon
Common PLP of the PLP Group. Requires a multi-PLP setup,
see [:SOURce<hw>]:BB:T2DVb:INPut:NPLP? on page 86.

DT1
Data type 1. Fixed for a single-PLP setup. Configurable for a
multi-PLP setup.
DT2
Data type 2. Requires a multi-PLP setup.
*RST: DT1

Example: See Example "Configuring mode and stream parameters"
on page 95.

Manual operation: See "PLP Type" on page 30

5.4  BICM Commands

The section contains the commands for configuring BICM.

Example: Configure BICM parameters
//********************************************************************************
// Enable setting of PLP 0 parameters by deactivating the T2-MI interface.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface OFF

//********************************************************************************
// Set PLP 0 coding and modulation parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:PLP1:FECFrame NORM
// Sets the FEC frame N_LDPC = 64800.
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:SOURce1:BB:T2DVb:PLP1:RATE R3_5
// Sets the code rate 3/5.
:SOURce1:BB:T2DVb:PLP1:CONStel T256
// Sets 256 QAM constellation.
:SOURce1:BB:T2DVb:PLP1:CROTation?
// Response: 0
// Constellation rotation is disabled.

//********************************************************************************
// Set PLP 0 interleaving parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:PLP1:TIL:TYPE 0
// Set time interleaver type 0.
:SOURce1:BB:T2DVb:PLP1:TIL:FINT?
// Response: 1
// Time interleaver frame interval is fixed to 1 for single-PLP transmission.
:SOURce1:BB:T2DVb:PLP1:TIL:LENGth 3
// Set the time interleaver length to 3.
:SOURce1:BB:T2DVb:PLP1:FRAMeindex?
// Response: 0
// Index of the first frame of the superframe is 0.
:SOURce1:BB:T2DVb:PLP1:BLOCks?
// Response: "202"
// 202 FEC blocks per interleaving frame.
:SOURce1:BB:T2DVb:PLP1:MAXBlocks?
// Response: "202"
// 202 FEC blocks is maximum per interleaving frame.
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[:SOURce<hw>]:BB:T2DVb:PLP<ch>:BLOCks?

Queries the number of FEC blocks per interleaving frame.

Return values: 
<FECBlocks> integer

Range: 0  to  1023
*RST: 0

Example: See Example "Configure BICM parameters" on page 101.
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Usage: Query only

Manual operation: See "FEC Blocks per IF" on page 37

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CONStel <Constellation>

Defines the constellation.

Parameters:
<Constellation> T4 | T16 | T64 | T256

T4
QPSK
T16|T64|T256
16/64/256QAM
*RST: T256

Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "Constellation" on page 36

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:CROTation <CRotation>

Sets the constellation rotation state.

Parameters:
<CRotation> 0 | 1 | OFF | ON

ON
Transmits the constellation rotated, i.e. the Q path is delayed vs.
the I path. For each constellation, there is a different (but fixed)
angle of rotation.
OFF
Transmits non-rotated constellation.
*RST: 1

Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "Const. Rotation" on page 36

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:FECFrame <NPFecFrame>

Sets the FEC frame.

Parameters:
<NPFecFrame> NORMal | SHORt

NORMal
NLDPC = 64800

SHORt
NLDPC = 16200

*RST: NORMal

Example: See Example "Configure BICM parameters" on page 101.
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Manual operation: See "FEC Frame" on page 35

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:FRAMeindex <FFIndex>

Queries the index of the first frame of the super frame, in that the current PLP occurs.

Parameters:
<FFIndex> integer

Range: 0  to  255
*RST: 0

Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "First Frame Index" on page 36

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:MAXBlocks?

Queries the maximum number of FEC blocks per interleaving frame.

Return values: 
<FECBlocksMax> integer

Range: 0  to  1023
*RST: 0

Example: See Example "Configure BICM parameters" on page 101.

Usage: Query only

Manual operation: See "Max. Number of Blocks" on page 38

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:RATE <Coderate>

Sets the code rate.

Parameters:
<Coderate> R1_2 | R3_5 | R2_3 | R3_4 | R4_5 | R5_6 | R1_3 | R2_5

*RST: R3_5

Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "Code Rate" on page 35

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TIL:FINT <FrameInterval>

Defines the time interleaver frame interval (IJump).

For limitations, see specification ETSI EN 302 755.

Parameters:
<FrameInterval> integer

Range: 1  to  255
*RST: 1
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Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "Frame Interval (IJump)" on page 36

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TIL:LENGth <TILLength>

Defines the time interleaver length within the time interleaving frame.

For limitations, see specification ETSI EN 302 755.

Parameters:
<TILLength> integer

Range: 0  to  255
*RST: 3

Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "Time Interleaver Length" on page 36

[:SOURce<hw>]:BB:T2DVb:PLP<ch>:TIL:TYPE <TILType>

Defines the time interleaver type.

Parameters:
<TILType> integer

0
Maps each interleaving frame directly to a T2 frame.
1
Maps each interleaving frame to more than one T2 frame.
Range: 0  to  1
*RST: 0

Example: See Example "Configure BICM parameters" on page 101.

Manual operation: See "Time Interleaver Type" on page 36

5.5  OFDM Commands

The section contains the commands for configuring OFDM symbol parameters.
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Example: Configuring OFDM parameters
//********************************************************************************
// Configure bandwidth parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:CHANnel:BANDwidth BW_1_7
// Sets 1.7 MHz channel bandwidth
// Query the used bandwidth in MHz.
:SOURce1:BB:T2DVb:USED:BANDwidth?
// Response in Hz: 1535156.3
// The used bandwidth value indicates, that extended carrier mode is active.
:SOURce1:BB:T2DVb:FFT:MODE?
// Response: "M32E"
// 32K FFT size using extended carrier mode.
:SOURce1:BB:T2DVb:BANDwidth:VARiation 10
// Sets a bandwidth variation of 10 ppm.

//********************************************************************************
// Set/query OFDM parameters with deactivated the T2-MI interface.
//********************************************************************************
:SOURce1:BB:T2DVb:GUARd:INTerval G19256
// Sets guard interval to 19/256.
:SOURce1:BB:T2DVb:PILot PP4
// Sets the pilot pattern to PP4.
:SOURce1:BB:T2DVb:NT2Frames 10
// Sets 10 T2 frames per super frame.
:SOURce1:BB:T2DVb:LDATa 9
// Sets 9 data symbols per T2 frame.
:SOURce1:BB:T2DVb:LF?
// Response: 10
// 10 OFDM symbols per T2 frames.
:SOURce1:BB:T2DVb:NSUB?
// Response: 1
// Subslices per T2 frame is fixed to 1 for single-PLP transmission.
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[:SOURce<hw>]:BB:T2DVb:BANDwidth:VARiation <BandwidthVar>

Changes the used bandwidth in the range of ±1000 ppm.
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Parameters:
<BandwidthVar> integer

Range: -1000  to  1000
*RST: 0
Default unit: ppm

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "Bandwidth Variation" on page 39

[:SOURce<hw>]:BB:T2DVb:CHANnel[:BANDwidth] <ChannelBW>

Selects the channel bandwidth.

Parameters:
<ChannelBW> BW_2 | BW_5 | BW_6 | BW_7 | BW_8

*RST: BW_8

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "Channel Bandwidth" on page 38

[:SOURce<hw>]:BB:T2DVb:FFT:MODE <FFTSize>

Defines the FFT size.

Parameters:
<FFTSize> M1K | M2K | M4K | M8K | M8E | M16K | M16E | M32K | M32E

M1K|M2K|M4K|M8K|M16K|M32K
1K/2K/4K/8K/16K/32K FFT size using normal carrier mode
M8E|M16E|M32E
8K/16K/32K FFT size using extended carrier mode
*RST: M32E

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "FFT Size" on page 39

[:SOURce<hw>]:BB:T2DVb:GUARd:INTerval <GuardInterval>

Sets the guard interval length.

Parameters:
<GuardInterval> G1_4 | G1_8 | G1_16 | G1_32 | G1128 | G19128 | G19256

*RST: G1128

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "Guard Interval" on page 39
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[:SOURce<hw>]:BB:T2DVb:LDATa <DataSymbols>

Sets the number of data symbols per T2 frame.

Parameters:
<DataSymbols> integer

Range: 0  to  4095
*RST: 59

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "Data Symbols per T2 Frame (L_DATA)" on page 40

[:SOURce<hw>]:BB:T2DVb:LF?

Queries the computed number of OFDM symbols per T2 frame.

Return values: 
<OfdmSymbols> integer

Range: 0  to  4095
*RST: 4

Example: See Example "Configuring OFDM parameters" on page 106.

Usage: Query only

Manual operation: See "OFDM Symbols per T2 Frame (L_F)" on page 40

[:SOURce<hw>]:BB:T2DVb:NSUB <Subslices>

Sets the number of subslices per T2 frame.

The number of subslices is "1" for "T2-MI Interface > Off".

Parameters:
<Subslices> integer

Range: 0  to  32767
*RST: 1

Example: :SOURce1:BB:T2DVb:INPut:T2MI:INTerface 0
:SOURce1:BB:T2DVb:NSUB?
\\ Response: "1"

Example: See also Example "Configuring OFDM parameters"
on page 106.

Manual operation: See "Subslices per T2 Frame (N_SUB)" on page 41

[:SOURce<hw>]:BB:T2DVb:NT2Frames <NT2Frames>

Sets the number of T2 frames per super frame.
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Parameters:
<NT2Frames> integer

Range: 2  to  255
*RST: 2

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "T2 Frames per Super Frame (N_T2)" on page 40

[:SOURce<hw>]:BB:T2DVb:PILot <PilotPattern>

Sets the pilot pattern.

Parameters:
<PilotPattern> PP1 | PP2 | PP3 | PP4 | PP5 | PP6 | PP7 | PP8

*RST: PP7

Example: See Example "Configuring OFDM parameters" on page 106.

Manual operation: See "Pilot Pattern" on page 40

[:SOURce<hw>]:BB:T2DVb:USED[:BANDwidth]?

Queries the used channel bandwidth.

The used bandwidth depends on the channel bandwidth, the FFT size and the carrier
mode as described in Table 3-2.

Return values: 
<UsedBW> integer

Range: 0.0  to  9999999.9

Example: See Example "Configuring OFDM parameters" on page 106.

Usage: Query only

Manual operation: See "Used Bandwidth" on page 39

5.6  System Commands

The section contains the commands for configuring the DVB-T2 system.

● Network Commands..............................................................................................110
● L1 Commands.......................................................................................................115
● ID Commands....................................................................................................... 118
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5.6.1  Network Commands

Example: Configuring network parameters
//********************************************************************************
// Configure common T2 network settings
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface OFF

SOURce:BB:T2DVb:PAPR TR
// Enables tone reservation (TR).

:SOURce1:BB:T2DVb:TXSYs MISO
// Sets for multi input single output (MISO) transmission system.
:SOURce1:BB:T2DVb:MISO:MODE?
// Response: MAN
// Manual MISO mode
:SOURce1:BB:T2DVb:MISO:GROup G2
// Modulator transmits with MISO group 2.

:SOURce1:BB:T2DVb:FEF?
// Response: 0
// Future extension frames are disabled.
:SOURce1:BB:T2DVb:TFS?
// Response: OFF
// Time frequency slicing is disabled.

//********************************************************************************
// Query future extension frame (FEF) parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface ON
// T2-MI stream with FEF settings is needed for the following commands

:SOURce1:BB:T2DVb:FEF?
// Response: 1
// Future extension frames are enabled.
:SOURce1:BB:T2DVb:FEF:TYPE?
// Response: 0
// FEF part has type 0.
:SOURce1:BB:T2DVb:FEF:LENGth?
// Response: 555000
// FEF length is 555000 elementary periods T.
:SOURce1:BB:T2DVb:FEF:INTerval?
// Response: 1
// One T2 frame between two FEF parts.
:SOURce1:BB:T2DVb:FEF:PAYLoad?
// Response: NULL
// I/Q values of the FEF payload are zero.

//********************************************************************************
// Configure single-frequency network properties.
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//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface ON
:SOURce1:BB:T2DVb:NETWorkmode SFN

:SOURce1:BB:T2DVb:PROFile MULTi
// Modulator operates in multiple profile operation mode.

For single-frequency network delays and mode commands, see Chapter 5.7, "SFN
Delay Commands", on page 120.

Commands
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[:SOURce<hw>]:BB:T2DVb:MISO[:GROup]...................................................................... 113
[:SOURce<hw>]:BB:T2DVb:NETWorkmode......................................................................113
[:SOURce<hw>]:BB:T2DVb:PAPR................................................................................... 113
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[:SOURce<hw>]:BB:T2DVb:FEF <FEF>

Enables/disables FEF.

Parameters:
<FEF> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "Future Extension Frames" on page 44

[:SOURce<hw>]:BB:T2DVb:FEF:INTerval <FEFInterval>

Queries the number of T2 frames between two FEF parts. The T2 frame shall always
be the first frame in a T2 super frame which contains both FEF parts and T2 frames.

Parameters:
<FEFInterval> integer

Range: 0  to  255
*RST: 0

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "FEF Interval" on page 45
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[:SOURce<hw>]:BB:T2DVb:FEF:LENGth <FEFLength>

Queries the length of the associated FEF part as the number of elementary periods T,
from the start of the P1 symbol of the FEF part to the start of the P1 symbol of the next
T2 frame.

The FEF length is "0" for "T2-MI Interface > Off".

Parameters:
<FEFLength> integer

Range: 0  to  16777215
*RST: 0

Example: :SOURce1:BB:T2DVb:INPut:T2MI:INTerface 0
:SOURce1:BB:T2DVb:INPut:FEF:LENGth?
\\ Response: "0"

Example: See also Example "Configuring network parameters"
on page 110.

Manual operation: See "FEF Length" on page 45

[:SOURce<hw>]:BB:T2DVb:FEF:PAYLoad <FEFPayload>

Sets the FEF payload.

Parameters:
<FEFPayload> NULL | NOISe

NULL
I/Q values of the FEF payload are zeroes.
NOISe
I/Q values of the FEF payload are modulated in the frequency
domain using a PRBS and transformed into the time domain by
IFFT.
The technique allows generating payload with a power level
equal to the T2 frame.
*RST: NULL

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "FEF Payload" on page 45

[:SOURce<hw>]:BB:T2DVb:FEF:TYPE <FEFType>

Queries the type of the associated FEF part.

Parameters:
<FEFType> integer

Range: 0  to  15
*RST: 0

Example: See Example "Configuring network parameters" on page 110.
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Manual operation: See "FEF Type (Hex)" on page 44

[:SOURce<hw>]:BB:T2DVb:MISO:MODE?

Sets the MISO group mode, that allows to set the MISO group of the modulator man-
ually.

Return values: 
<GroupMode> MANual

*RST: MANual

Example: See Example "Configuring network parameters" on page 110.

Usage: Query only

Manual operation: See "MISO Group Mode" on page 44

[:SOURce<hw>]:BB:T2DVb:MISO[:GROup] <MisoGroup>

Sets the MISO group.

Parameters:
<MisoGroup> G1 | G2

*RST: G1

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "MISO Group" on page 44

[:SOURce<hw>]:BB:T2DVb:NETWorkmode <Networkmode>

Sets the network mode.

Parameters:
<Networkmode> MFN | SFN

*RST: MFN

Manual operation: See "Network Mode" on page 42

[:SOURce<hw>]:BB:T2DVb:PAPR <Papr>

Sets the technique to reduce the peak to average power ratio.

Parameters:
<Papr> OFF | TR

*RST: OFF

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "Peak To Average Power Ratio (PAPR)" on page 44
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[:SOURce<hw>]:BB:T2DVb:PROFile <Profilemode>

Sets the profile mode.

Mutes P1FEF, if the modulator operates in a multi profile environment and is used to
generate a RF combined T2Base/T2Lite composite signal.

Parameters:
<Profilemode> SINGLE | MULTI

*RST: SINGLE

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "Profile Mode" on page 43

[:SOURce<hw>]:BB:T2DVb:TFS <TFS>

Queries the TFS state.

The current firmware does not support TFS.

Parameters:
<TFS> OFF

OFF
Fixed response of the query.
*RST: OFF

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "Time Frequency Slicing (TFS)" on page 45

[:SOURce<hw>]:BB:T2DVb:TXSYs <TransmissionSys>

Sets the transmission system.

Parameters:
<TransmissionSys> T2LM | T2LS | NONT2 | MISO | SISO

T2LM
T2 Lite MISO
T2LS
T2 Lite SISO
NONT2
Non-T2
MISO
MISO
SISO
SISO
*RST: SISO

Example: See Example "Configuring network parameters" on page 110.

Manual operation: See "Transmission System" on page 43
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5.6.2  L1 Commands

Example: Configuring L1 parameters
//********************************************************************************
// Setting L1 parameters requires disabling T2-MI interface.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface OFF

:SOURce1:BB:T2DVb:L:T2Version V111
// Sets T2 version to V1.1.1.
:SOURce1:BB:T2DVb:L:CONStel T64
// Sets L1 post modulation to 64QAM constellation.
:SOURce1:BB:T2DVb:L:REPetition ON
:SOURce1:BB:T2DVb:L:EXTension?
// Response: OFF
// L1 post extension is off.
:SOURce1:BB:T2DVb:L:SCRambled?
// Response: 0
// L1 post scrambling is off. Set version V1.3.1 to activate it.
:SOURce1:BB:T2DVb:L:T2Version V131
:SOURce1:BB:T2DVb:L:SCRambled ON
:SOURce1:BB:T2DVb:L:T2Baselite?
// Response: 0
// T2 base lite transmission not acitve.
:SOURce1:BB:T2DVb:NAUX?
// Response: 0
// Number of auxiliary frames is fixed to zero.
:SOURce1:BB:T2DVb:L:RFSignalling?
// Response: 0
// RF signaling is disabled.
:SOURce1:BB:T2DVb:L:RFSignaling:FREQuency?
// Response: 0
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[:SOURce<hw>]:BB:T2DVb:L:CONStel <L1PostMod>

Sets the modulation of the L1 post signal.

Parameters:
<L1PostMod> T2 | T4 | T16 | T64

T2
BPSK
T4
QPSK
T16
16QAM
T64
64QAM
*RST: T64

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "L1 Post Modulation" on page 46

[:SOURce<hw>]:BB:T2DVb:L:EXTension <L1PostExt>

Queries the L1 post extension state.

The current firmware does not support L1 post extension.

Parameters:
<L1PostExt> OFF

OFF
Fixed response of the query.
*RST: OFF

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "L1 Post Extension" on page 47

[:SOURce<hw>]:BB:T2DVb:L:REPetition <L1Repetition>

Enables/disables L1 repetition.

Parameters:
<L1Repetition> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "L1 Repetition" on page 47

[:SOURce<hw>]:BB:T2DVb:L:RFSignalling:FREQuency?

Queries the signaled frequency in the L1 signaling.
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Return values: 
<L1Freq> integer

Range: 0  to  4294967295
*RST: 0
Default unit: Hz

Example: See Example "Configuring L1 parameters" on page 115.

Usage: Query only

Manual operation: See "Frequency" on page 48

[:SOURce<hw>]:BB:T2DVb:L:RFSignalling <RFSignalling>

Queries the RF signaling state in L1.

The setting depends on the setting of the "T2-MI Interface":
● "T2-MI Interface > Off": 0x0000 0000 is sent.
● "T2-MI Interface > On": The value from the T2-MI stream is sent.

Parameters:
<RFSignalling> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "L1 RF Signaling" on page 47

[:SOURce<hw>]:BB:T2DVb:L:SCRambled <L1PostScr>

Enables/disables L1 post scrambling according to T2 version 1.3.1 of specification
ETSI EN 302 755.

You can query the used version via [:SOURce<hw>]:BB:T2DVb:L:T2Version
on page 118.

Parameters:
<L1PostScr> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "L1 Post Scrambled" on page 47

[:SOURce<hw>]:BB:T2DVb:L:T2Baselite <T2Baselite>

Enables/disables T2 base lite signaling according to T2 version 1.3.1 of specification
ETSI EN 302 755.

You can query the used version via [:SOURce<hw>]:BB:T2DVb:L:T2Version
on page 118.
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Parameters:
<T2Baselite> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "T2 Base Lite" on page 47

[:SOURce<hw>]:BB:T2DVb:L:T2Version <T2Version>

Sets the version of T2 specification ETSI EN 302 755, that is used for transmission.

Parameters:
<T2Version> V111 | V121 | V131

*RST: V121

Example: See Example "Configuring mode and stream parameters"
on page 95.

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "L1 T2 Version" on page 46

[:SOURce<hw>]:BB:T2DVb:NAUX <NumAuxStr>

Queries the number of auxiliary streams.

The current firmware does not support auxiliary streams.

Parameters:
<NumAuxStr> integer

0
Fixed response of the query.
*RST: 0

Example: See Example "Configuring L1 parameters" on page 115.

Manual operation: See "Num. Aux. Streams" on page 47

5.6.3  ID Commands

Example: Configuring ID parameters
:SOURce1:BB:T2DVb:ID:CELL #H0123
// Sets the hexadecimal cell ID 0123.
:SOURce1:BB:T2DVb:ID:NETWork #H4567
// Sets the hexadecimal network ID 4567.
:SOURce1:BB:T2DVb:ID:T2SYstem #H89AB
// Sets the hexadecimal T2 sytsem ID 89AB.
:SOURce1:BB:T2DVb:ID:TXID:AVAil?
// Response: 0
// No transmitter identification signals within the current geographic cell.
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Commands
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[:SOURce<hw>]:BB:T2DVb:ID:TXID:AVAil........................................................................120

[:SOURce<hw>]:BB:T2DVb:ID:CELL <CellId>

Sets the cell identification (ID).

Parameters:
<CellId> integer

16-bit value in hexadecimal representation.
Range: #H0  to  #HFFFF
*RST: #H0

Example: See Example "Configuring ID parameters" on page 118.

Manual operation: See "Cell ID (Hex)" on page 48

[:SOURce<hw>]:BB:T2DVb:ID:NETWork <NetworkId>

Sets the network identification.

Parameters:
<NetworkId> integer

16-bit value in hexadecimal representation.
Range: #H0  to  #HFFFF
*RST: #H0

Example: See Example "Configuring ID parameters" on page 118.

Manual operation: See "Network ID (Hex)" on page 49

[:SOURce<hw>]:BB:T2DVb:ID:T2SYstem <T2SystemId>

Sets the T2 system identification.

Parameters:
<T2SystemId> integer

16-bit value in hexadecimal representation.
Range: #H0  to  #HFFFF
*RST: #H0

Example: See Example "Configuring ID parameters" on page 118.

Manual operation: See "T2 System ID (Hex)" on page 49
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[:SOURce<hw>]:BB:T2DVb:ID:TXID:AVAil <Avail>

Queries if transmitter identification signals are available within the current geographic
cell.

Parameters:
<Avail> integer

8-bit value in hexadecimal representation.
Range: #H0  to  #HFF
*RST: #H0

Example: See Example "Configuring ID parameters" on page 118.

Manual operation: See "TX ID Availability (Hex)" on page 49

5.7  SFN Delay Commands

The section contains the commands for configuring single-frequency network delays.

Example: Configuring single-frequency network delay parameters
//********************************************************************************
// Activate SFN network mode.
//********************************************************************************
:SOURce1:BB:T2DVb:INPut:T2MI:INTerface ON
:SOURce1:BB:T2DVb:NETWorkmode SFN

//********************************************************************************
// Configure timestamp parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:DELay:TSP:MODE?
// Response: ABS
// Timestamp mode is relative.
:SOURce1:BB:T2DVb:DELay:TSP:UPDate
// Updates the UTC time and date reference.
:SOURce1:BB:T2DVb:DELay:TSP:DATE?
// Response: "2020-02-26"
:SOURce1:BB:T2DVb:DELay:TSP:TIME?
// Response: "10:01.15"
//:SOURce1:BB:T2DVb:DELay:TSP:OFFSet -2
// Sets an offset of -2 seconds.
:SOURce1:BB:T2DVb:DELay:TSP:SEConds?
// Response: 636026505
// 636026505 seconds elapsed since 2000.

//********************************************************************************
// Configure delay parameters.
//********************************************************************************
:SOURce1:BB:T2DVb:DELay:PROCess?
// Response: 0.3522332
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// Processing delay is 0.3522332 seconds.
:SOURce1:BB:T2DVb:DELay:STATic 0.000003
// The start of transmission is shifted to 3 µs later.
:SOURce1:BB:T2DVb:DELay:DYNamic?
// Response: 1.5111824
// Dynamic delay is 1.5111824 seconds.
// Query the total delay in µs, that is the sum of processing and dynamic delay.
:SOURce1:BB:T2DVb:DELay:TOTal?
// Response: 1.8638689
// Total delay is 1.8638689 seconds.

// Set a maximum permissible delay of, e.g., 10 µs.
:SOURce1:BB:T2DVb:DELay:DEViation 0.00001
// Mutes the P1 symbol of the first T2 frame in a super frame.
:SOURce1:BB:T2DVb:DELay:MUTep1 ON
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[:SOURce<hw>]:BB:T2DVb:DELay:DEViation <MaxDevTime>

Sets the maximum permissible delay.

Parameters:
<MaxDevTime> float

Range: 1E-6  to  500E-6
Increment: 0.0000001
*RST: 10E-6

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Manual operation: See "Max. Deviation Time" on page 51

[:SOURce<hw>]:BB:T2DVb:DELay:DYNamic?

Queries the transmission delay currently generated by the SFN delay (FIFO).
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Return values: 
<DynDelay> float

Range: 0  to  8.0
Increment: 0.0000001
*RST: 0

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Usage: Query only

Manual operation: See "Dynamic Delay" on page 50

[:SOURce<hw>]:BB:T2DVb:DELay:MUTep1 <MuteP1>

Activates muting the P1 symbol of the first T2 frame in a super frame. To mute the P1
symbol, the symbol is set to zero.

Parameters:
<MuteP1> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Manual operation: See "Mute 1st Super Frame P1" on page 51

[:SOURce<hw>]:BB:T2DVb:DELay:PROCess?

Queries the delay from the modulator input up to the SFN delay (FIFO).

Return values: 
<ProcDelay> float

Range: 0  to  4.0
Increment: 0.0000001
*RST: 0

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Usage: Query only

Manual operation: See "Processing Delay" on page 50

[:SOURce<hw>]:BB:T2DVb:DELay:STATic <StaticDelay>

Sets the delay to shift the time of transmission positively or negatively.

Parameters:
<StaticDelay> float

Range: -4.0  to  4.0
Increment: 0.0000001
*RST: 0

SFN Delay Commands



Remote-Control CommandsR&S®SMCVB-K164

123User Manual 1179.0974.02 ─ 03

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Manual operation: See "Static Delay" on page 50

[:SOURce<hw>]:BB:T2DVb:DELay:TOTal?

Queries the sum of processing delay and dynamic delay.

Return values: 
<TotalDelay> float

Range: -4.0  to  16.0
Increment: 0.0000001
*RST: 0

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Usage: Query only

Manual operation: See "Total Delay" on page 50

[:SOURce<hw>]:BB:T2DVb:DELay:TSP:DATE?

Queries the UTC date from the last UTC reference update.

Return values: 
<TSPDate> string

Format <yyyy>-<mm>-<dd>
Example: See Example "Configuring single-frequency network delay

parameters" on page 120.

Usage: Query only

Manual operation: See "UTC Date" on page 52

[:SOURce<hw>]:BB:T2DVb:DELay:TSP:MODE?

Queries the type of the currently received T2-MI timestamps.

Return values: 
<TimestampMode> RELative | ABSolute

RELative
Received T2-MI stream has T2-MI packets with relative time-
stamps.
ABSolute
Received T2-MI stream has T2-MI packets with absolute time-
stamps. If received, the following subparameters are displayed.

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.
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Usage: Query only

Manual operation: See "Timestamp Mode" on page 52

[:SOURce<hw>]:BB:T2DVb:DELay:TSP:OFFSet <TSPOffset>

Modifies the UTC/GPS leap seconds offset.

Parameters:
<TSPOffset> integer

Range: -255  to  255
*RST: 0

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Manual operation: See "Offset" on page 52

[:SOURce<hw>]:BB:T2DVb:DELay:TSP:SEConds?

Queries the elapsed time in seconds since 2000. The value is based on the value of
the last UTC reference update.

Return values: 
<TSPSeconds> integer

Range: 0  to  1099511627775
*RST: 0

Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Usage: Query only

Manual operation: See "Seconds Since 2000" on page 53

[:SOURce<hw>]:BB:T2DVb:DELay:TSP:TIME?

Queries the UTC time from the last UTC reference update.

Return values: 
<TSPTime> string

Format <hour>:<minute>:<second>
Example: See Example "Configuring single-frequency network delay

parameters" on page 120.

Usage: Query only

Manual operation: See "UTC Time" on page 52

[:SOURce<hw>]:BB:T2DVb:DELay:TSP:UPDate

Triggers an update of the UTC time and date reference.
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Example: See Example "Configuring single-frequency network delay
parameters" on page 120.

Usage: Event

Manual operation: See "Update Timestamp" on page 52

5.8  Frame Info Commands

The section contains the commands for querying frame information.

● Frame and Symbol Duration Commands..............................................................125
● L1 Signaling Commands.......................................................................................127
● Data Cell Commands............................................................................................129

5.8.1  Frame and Symbol Duration Commands

Example: Querying frame and symbol duration information
:SOURce1:BB:T2DVb:INFO:TSF?
// Response in s: 0.433888
// Super frame duration is 33.888 ms.
:SOURce1:BB:T2DVb:INFO:TF?
// Response in s: 0.216944
// T2 frame duration is 216.944 ms.
:SOURce1:BB:T2DVb:INFO:TFEF?
// Response in s: 0
// Future extension frame duration is 0 s.
:SOURce1:BB:T2DVb:INFO:TP1?
// Response in s: 0.000224
// P1 symboly duration is 0.224 ms.
:SOURce1:BB:T2DVb:INFO:TP2?
:SOURce1:BB:T2DVb:INFO:TS?
// Response for both commands in s: 0.003612
// P2 symbol and OFDM data symbol duration is 3.612 ms.

Commands

[:SOURce<hw>]:BB:T2DVb:INFO:TF?............................................................................. 125
[:SOURce<hw>]:BB:T2DVb:INFO:TFEF?......................................................................... 126
[:SOURce<hw>]:BB:T2DVb:INFO:TSF?........................................................................... 126
[:SOURce<hw>]:BB:T2DVb:INFO:TP1?........................................................................... 126
[:SOURce<hw>]:BB:T2DVb:INFO:TP2|TS?...................................................................... 127

[:SOURce<hw>]:BB:T2DVb:INFO:TF?

Queries the T2 frame duration.
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Return values: 
<T2FrameDur> float

Range: 0  to  0.999999
Increment: 0.000001
*RST: 0

Example: See Example "Querying frame and symbol duration information"
on page 125.

Usage: Query only

Manual operation: See "T2 Frame Duration (TF)" on page 54

[:SOURce<hw>]:BB:T2DVb:INFO:TFEF?

Queries the future extension frame duration.

Return values: 
<FEFDur> integer

Range: 0  to  9.999999
Increment: 0.000001
*RST: 0

Example: See Example "Querying frame and symbol duration information"
on page 125.

Usage: Query only

Manual operation: See "Future Extension Frame Duration (TFEF)" on page 54

[:SOURce<hw>]:BB:T2DVb:INFO:TSF?

Queries the super frame duration.

Return values: 
<SuperFrameDur> float

Range: 0  to  999.999999
Increment: 0.000001
*RST: 0

Example: See Example "Querying frame and symbol duration information"
on page 125.

Usage: Query only

Manual operation: See "Super Frame Duration (TSF)" on page 54

[:SOURce<hw>]:BB:T2DVb:INFO:TP1?

Queries the P1 symbol duration.
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Return values: 
<P1SymbolDur> float

Range: 0  to  0.001000
Increment: 0.000001
*RST: 0

Example: See Example "Querying frame and symbol duration information"
on page 125.

Usage: Query only

Manual operation: See "P1 Symbol Duration (TP1)" on page 55

[:SOURce<hw>]:BB:T2DVb:INFO:TP2|TS?

Queries the P2 and OFDM data symbol duration.

Return values: 
<OfdmSymbolDur> float

Range: 0  to  0.010000
Increment: 0.000001
*RST: 0

Example: See Example "Querying frame and symbol duration information"
on page 125.

Usage: Query only

Manual operation: See "OFDM Symbol Duration (TP2, TS)" on page 55

5.8.2  L1 Signaling Commands

Example: Querying L1 signaling parameters
:SOURce1:BB:T2DVb:INFO:PREBits?
// Response: 200
// L1-pre singnaling length is 200 bit.
:SOURce1:BB:T2DVb:INFO:PRECells?
// Response: 1800
// L1-pre singnaling length is 1800 cells.
:SOURce1:BB:T2DVb:INFO:POSBits?
// Response: 350
// L1-post singnaling length is 350 bit.
:SOURce1:BB:T2DVb:INFO:POSCells?
// Response: 750
// L1-post singnaling length is 750 cells.
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Commands

[:SOURce<hw>]:BB:T2DVb:INFO:POSBits?..................................................................... 128
[:SOURce<hw>]:BB:T2DVb:INFO:POSCells?................................................................... 128
[:SOURce<hw>]:BB:T2DVb:INFO:PREBits?..................................................................... 128
[:SOURce<hw>]:BB:T2DVb:INFO:PRECells?................................................................... 129

[:SOURce<hw>]:BB:T2DVb:INFO:POSBits?

Queries the L1-post signaling length in bits.

Return values: 
<L1PostSigBits> integer

Range: 0  to  262175
*RST: 0

Example: See Example "Querying L1 signaling parameters" on page 127.

Usage: Query only

Manual operation: See "L1 Post Signaling Bits" on page 56

[:SOURce<hw>]:BB:T2DVb:INFO:POSCells?

Queries the L1-post signaling length in cells.

Return values: 
<L1PostSigCells> integer

Range: 0  to  262143
*RST: 0

Example: See Example "Querying L1 signaling parameters" on page 127.

Usage: Query only

Manual operation: See "L1 Post Signaling Cells" on page 56

[:SOURce<hw>]:BB:T2DVb:INFO:PREBits?

Queries the L1-pre signaling length in bits.

Return values: 
<L1PreSigBits> integer

Range: 0  to  200
*RST: 0

Example: See Example "Querying L1 signaling parameters" on page 127.

Usage: Query only

Manual operation: See "L1 Pre Signaling Bits" on page 55
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[:SOURce<hw>]:BB:T2DVb:INFO:PRECells?

Queries the L1-pre signaling length in cells.

Return values: 
<L1PreSigCells> integer

Range: 0  to  1840
*RST: 0

Example: See Example "Querying L1 signaling parameters" on page 127.

Usage: Query only

Manual operation: See "L1 Pre Signaling Cells" on page 55

5.8.3  Data Cell Commands

Example: Querying the number of data cells
:SOURce1:BB:T2DVb:INFO:DP?
// Response: 1637178
// Maximum number of PLP data cells per T2 frame is 1637178.
:SOURce1:BB:T2DVb:INFO:DPUSed?
// Response: 1636200
// Current T2 frame has 1636200 data cells.

Commands

[:SOURce<hw>]:BB:T2DVb:INFO:DP?.............................................................................129
[:SOURce<hw>]:BB:T2DVb:INFO:DPUSed?.....................................................................129

[:SOURce<hw>]:BB:T2DVb:INFO:DP?

Queries the maximum possible number of PLP data cells in the T2 frame.

Return values: 
<Dplp> integer

Range: 0  to  1E7
*RST: 0

Example: See Example "Querying the number of data cells" on page 129.

Usage: Query only

Manual operation: See "PLP Data Cells Per T2 Frame (DPLP)" on page 56

[:SOURce<hw>]:BB:T2DVb:INFO:DPUSed?

Queries the current number of PLP data cells in the T2 frame.
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Return values: 
<Dplpused> integer

Range: 0  to  1E7
*RST: 0

Example: See Example "Querying the number of data cells" on page 129.

Usage: Query only

Manual operation: See "PLP Data Cells in Current T2 Frame (DPLP_USED)"
on page 56

5.9  TSGen Subsystem

The TSGen subsystem contains the commands for configuring the TS player.

Example: Play a TS player file
//*********************************************************************************
// Select a file, e.g. a user-defined setting.
//*********************************************************************************
:TSGen:CONFigure:PLAYfile "/var/user/my_test_player_test.trp"
// Selects the file "my_test_player_test" with extension *.trp.

//*********************************************************************************
// Within the file, define a section, that you want to play.
// You can set start/stop position for a maximum section length of 10 hours.
//*********************************************************************************
:TSGen:CONFigure:SEEK:STARt 60000 // milliseconds
// Section start is after one minute from the original file start.
// The first minute is ignored.
:TSGen:CONFigure:SEEK:STOP 120000 // milliseconds
// Section stop is after one minute from the original file start.
// The total section length is one minute.

//*********************************************************************************
// Navigate to a certain position within the file/section of the file.
//*********************************************************************************
:TSGen:CONFigure:SEEK:POSition 100000 // milliseconds
// The current player position of file/section of the file is at 1 minute 40 seconds.

//*********************************************************************************
// Reset play-related settings
//*********************************************************************************
:TSGen:CONFigure:SEEK:RESet

//*********************************************************************************
// Pause, stop, play the file.
//*********************************************************************************
:TSGen:CONFigure:COMMand PAUS
// Pauses playing the file.
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:TSGen:CONFigure:COMMand STOP
// Stops playing the file.
:TSGen:CONFigure:COMMand PLAY
// Activates playing the file.

Example: Configure and monitor TS player output
//*********************************************************************************
// Configure general and stuffing parameters of the TS player output.
//*********************************************************************************
:TSGen:CONFigure:STUFfing ON
:TSGen:CONFigure:STOPdata TTSP
:TSGen:CONFigure:TSPacket H184
//:TSGen:CONFigure:PIDTestpacket VAR
:TSGen:CONFigure:PIDTestpack VAR
:TSGen:CONFigure:PID 8100
// Corresponds to a PID = 1FA4 in hexadecimal format.
:TSGen:CONFigure:PAYLoad PRBS
:TSGen:CONFigure:PRBS:SEQuence P23_1

//*********************************************************************************
// Monitor TS player output data.
//*********************************************************************************
:TSGen:CONFigure:COMMand STOP
// TSRate can only be changed if player is in stop mode
:TSGen:CONFigure:TSRate 350E6 // net data rate = 350 MBit/s
:TSGen:CONFigure:COMMand PLAY

:TSGen:CONFigure:PLENgth?
// Response: P188 // packet length = 188 byte
:TSGen:READ:ORIGtsrate?
// Response: 5018502 bit/s

Example: Configure seamless loop parameters
:TSGen:CONFigure:SEAMless:CC ON
:TSGen:CONFigure:SEAMless:PCR OFF
:TSGen:CONFigure:SEAMless:TT ON

Commands

:TSGen:CONFigure:COMMand<ch>................................................................................ 132
:TSGen:CONFigure:PAYLoad..........................................................................................132
:TSGen:CONFigure:PID..................................................................................................132
:TSGen:CONFigure:PIDTestpack.....................................................................................133
:TSGen:CONFigure:PLAYfile...........................................................................................133
:TSGen:CONFigure:PLENgth..........................................................................................133
:TSGen:CONFigure:PRBS[:SEQuence]............................................................................133
:TSGen:CONFigure:SEAMless:CC.................................................................................. 134
:TSGen:CONFigure:SEAMless:PCR................................................................................ 134
:TSGen:CONFigure:SEAMless:TT................................................................................... 134
:TSGen:CONFigure:SEEK:POSition.................................................................................134

TSGen Subsystem



Remote-Control CommandsR&S®SMCVB-K164

132User Manual 1179.0974.02 ─ 03

:TSGen:CONFigure:SEEK:RESet.................................................................................... 135
:TSGen:CONFigure:SEEK:STARt.................................................................................... 135
:TSGen:CONFigure:SEEK:STOP.....................................................................................135
:TSGen:CONFigure:STOPdata........................................................................................136
:TSGen:CONFigure:STUFfing......................................................................................... 136
:TSGen:CONFigure:TSPacket.........................................................................................136
:TSGen:CONFigure:TSRate............................................................................................136
:TSGen:READ:FMEMory................................................................................................ 137
:TSGen:READ:ORIGtsrate..............................................................................................137
:TSGen:READ:PLAYfile:LENGth?....................................................................................137

:TSGen:CONFigure:COMMand<ch>

Triggers playing, pausing and stopping of the TS player file selected with :TSGen:
CONFigure:PLAYfile.

Setting parameters: 
<PlayerStatus> STOP | PLAY | PAUSe

*RST: STOP

Example: See Example "Play a TS player file" on page 130.

Usage: Event

Manual operation: See "Play" on page 62

:TSGen:CONFigure:PAYLoad <PayLoad>

Determines the payload of the test packet. Also influences the payload of the gener-
ated stuffing packets while the TS player is running.

Parameters:
<PayLoad> HFF | H00 | PRBS

*RST: PRBS

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Payload Test/Stuff" on page 66

:TSGen:CONFigure:PID <PID>

The available values depend on the settings of :TSGen:CONFigure:PIDTestpack.

If :TSGen:CONFigure:PIDTestpack is set to NULL,
then :TSGen:CONFigure:PID is 1FFF(hex).

Otherwise the values are variable.

Parameters:
<PID> integer

Range: 0  to  8191
*RST: 8191

TSGen Subsystem



Remote-Control CommandsR&S®SMCVB-K164

133User Manual 1179.0974.02 ─ 03

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "PID (Hex)" on page 66

:TSGen:CONFigure:PIDTestpack <PIDTestpack>

Sets the PID, if :TSGen:CONFigure:TSPacket is H184|H200|H204.

Parameters:
<PIDTestpack> VARiable | NULL

*RST: NULL

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "PID Test Packet" on page 66

:TSGen:CONFigure:PLAYfile <PlayFile>

Specifies the file path and filename of the TS player file.

Parameters:
<PlayFile> string

Example: See Example "Play a TS player file" on page 130.

Manual operation: See "Select File" on page 61

:TSGen:CONFigure:PLENgth <PLength>

Queries the packet length of the loaded file.

Parameters:
<PLength> P188 | P204 | P208 | INV

*RST: INV

Example: See Example "Configure and monitor TS player output"
on page 131.

:TSGen:CONFigure:PRBS[:SEQuence] <PRBS>

Sets the length of the PRBS sequence.

Parameters:
<PRBS> P15_1 | P23_1

*RST: P23_1

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "PRBS" on page 66
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:TSGen:CONFigure:SEAMless:CC <CC>

Activates the correction of the continuity counters in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.

Parameters:
<CC> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configure seamless loop parameters"
on page 131.

Manual operation: See "Continuity Counter" on page 67

:TSGen:CONFigure:SEAMless:PCR <PCR>

Activates the correction of time stamps in the replayed TS data stream. The correction
allows you to decode the stream without interruption when the play file is looping.

Parameters:
<PCR> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configure seamless loop parameters"
on page 131.

Manual operation: See "PCR, DTS/PTS" on page 67

:TSGen:CONFigure:SEAMless:TT <TT>

Activates the correction of the time and date table in the replayed TS data stream. The
correction allows you to decode the stream without interruption when the play file is
looping.

Parameters:
<TT> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configure seamless loop parameters"
on page 131.

Manual operation: See "TDT/TOT" on page 67

:TSGen:CONFigure:SEEK:POSition <Position>

Sets the position, that is the current playing time position.

You can select a value in a 10-hour range.

TSGen Subsystem



Remote-Control CommandsR&S®SMCVB-K164

135User Manual 1179.0974.02 ─ 03

Parameters:
<Position> float

Range: 0  to  36000000
Increment: 0.1
*RST: 0

Example: See Example "Play a TS player file" on page 130.

Manual operation: See "Running/Position Player [hh:mm:ss:fff]" on page 60

:TSGen:CONFigure:SEEK:RESet

Resets the following parametets to their default state:
● :TSGen:CONFigure:SEEK:STARt on page 135
● :TSGen:CONFigure:SEEK:STOP on page 135

Example: See Example "Play a TS player file" on page 130.

Manual operation: See "Reset Window" on page 62

:TSGen:CONFigure:SEEK:STARt <Start>

Sets an individual start time.

You can select a value in a 10-hour range.

Parameters:
<Start> float

Range: 0  to  36000000
Increment: 0.1
*RST: 0

Example: See Example "Play a TS player file" on page 130.

Manual operation: See "Start [hh:mm:ss.fff]" on page 62

:TSGen:CONFigure:SEEK:STOP <Stop>

Sets an individual stop time.

You can select a value in a 10-hour range.

Parameters:
<Stop> float

Range: 0  to  36000000
Increment: 0.1
*RST: 23040.2

Example: See Example "Play a TS player file" on page 130.

Manual operation: See "Stop [hh:mm:ss.fff]" on page 62
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:TSGen:CONFigure:STOPdata <StopData>

Ensures that a standardized TS data stream is always output at the TS output at the
rear of the R&S SMCV100B.

Parameters:
<StopData> TTSP | NONE

*RST: NONE

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Stop Data" on page 64

:TSGen:CONFigure:STUFfing <Stuffing>

Enables or disables nullpacket stuffing.

Parameters:
<Stuffing> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Nullpacket Stuffing" on page 64

:TSGen:CONFigure:TSPacket <TSPaket>

Sets the structure of the generated test packets in pause or stop status.

Parameters:
<TSPaket> H184 | H200 | H204 | S187 | S203 | S207

S187|S203|S207
A sync byte (0x47) followed by 187/203/207 payload bytes.
H184|H200|H204
A sync byte (0x47) followed by three header bytes and
184/200/204 payload bytes.
*RST: H184

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Packet Length" on page 64

:TSGen:CONFigure:TSRate <TSRate>

Sets the output data rate of the player.
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Parameters:
<TSRate> integer

Range: 1  to  35E7
*RST: 5018502

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Data Rate" on page 63

:TSGen:READ:FMEMory <FMemory>

Queries the file size of the TS player file.

Parameters:
<FMemory> integer

Range: 0  to  10
*RST: 0

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Select File" on page 61

:TSGen:READ:ORIGtsrate <ORIGtsrate>

Displays the calculated original TS data rate.

Parameters:
<ORIGtsrate> integer

Range: 1  to  350000000
*RST: 5018502

Example: See Example "Configure and monitor TS player output"
on page 131.

Manual operation: See "Orig. Data Rate" on page 63

:TSGen:READ:PLAYfile:LENGth?

Queries calculated original loop time.

Return values: 
<Length> integer

Range: 0  to  100
*RST: 0

Example: See Example "Configure and monitor TS player output"
on page 131.

Usage: Query only

Manual operation: See "Select File" on page 61
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5.10  BCIP Subsystem

The SYSTem:COMMunicate:BCIP subsystem contains the commands for configuring
local IP data network parameters.

Common suffixes

The following common suffixes are used in the remote commands:

Suffix Value range Description

BCIP<hw> 1 Available local IP LAN interfaces

Example: Retrieving information on local network-related settings
//********************************************************************************
// Monitor IP interface 1 local network status.
//********************************************************************************
:SYSTem:COMMunicate:BCIP1:NETWork:STATus?
// Response: "0"
// The instrument is diconnected from the local IP network.
:SYSTem:COMMunicate:BCIP1:NETWork:RESTart
:SYSTem:COMMunicate:BCIP1:NETWork:STATus?
// Response: "1"

//********************************************************************************
// Query local IP data network properties.
//********************************************************************************
:SYSTem:COMMunicate:BCIP1:NETWork:COMMon:HOSTname?
// Response: "SMCV100B-123456-IP-Data"
:SYSTem:COMMunicate:BCIP1:NETWork:IPADdress:MODE STAT
:SYSTem:COMMunicate:BCIP1:NETWork:IPADdress "10.113.0.104"
:SYSTem:COMMunicate:BCIP1:NETWork:IPADdress:SUBNet:MASK "255.255.252.0"
:SYSTem:COMMunicate:BCIP1:NETWork:MACaddress?
// Response: "00 90 B8 21 89 F8"
:SYSTem:COMMunicate:BCIP1:NETWork:PROTocol?
// Response: "UDP"

Commands

:SYSTem:COMMunicate:BCIP<hw>:NETWork:COMMon:HOSTname................................. 139
:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress..................................................139
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:SYSTem:COMMunicate:BCIP<hw>:NETWork:COMMon:HOSTname <Hostname>

Sets an individual hostname for the vector signal generator.

Note:We recommend that you do not change the hostname to avoid problems with the
network connection. If you change the hostname, be sure to use a unique name.

Parameters:
<Hostname> string

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Manual operation: See "Hostname" on page 69

:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0  to  255.255.255.255
*RST: 0.0.0.0

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Manual operation: See "IP Address" on page 69

:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:MODE <IPMode>

Selects manual or automatic setting of the IP address.

Parameters:
<IPMode> AUTO | STATic

*RST: AUTO

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Manual operation: See "Address Mode" on page 69

:SYSTem:COMMunicate:BCIP<hw>:NETWork:IPADdress:SUBNet:MASK

Sets the subnet mask.

Parameters:
<Mask> string

Range: 0.0.0.0  to  255.255.255.255
*RST: 0.0.0.0

Example: See Example "Retrieving information on local network-related
settings" on page 138.

BCIP Subsystem
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Manual operation: See "Subnet Mask" on page 70

:SYSTem:COMMunicate:BCIP<hw>:NETWork:MACaddress <MACAddress>

Queries the MAC address of the network adapter.

Parameters:
<MACAddress> string

Range: 00:00:00:00:00:00  to  ff:ff:ff:ff:ff:ff

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Manual operation: See "MAC Address" on page 70

:SYSTem:COMMunicate:BCIP<hw>:NETWork:PROTocol <Protocol>

Specifies the network protocol.

Parameters:
<Protocol> UDP

*RST: UDP

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Manual operation: See "Protocol" on page 70

:SYSTem:COMMunicate:BCIP<hw>:NETWork:RESTart

Triggers a restart of the network.

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Usage: Event

Manual operation: See "Restart Network" on page 69

:SYSTem:COMMunicate:BCIP<hw>:NETWork:STATus <NetworkStatus>

Queries the network connection state.

Parameters:
<NetworkStatus> 0 | 1 | OFF | ON

*RST: n.a. (no preset. default: 0)

Example: See Example "Retrieving information on local network-related
settings" on page 138.

Manual operation: See "Network Status" on page 68

BCIP Subsystem
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Annex
A  DVB-T2 Test Cases

Test case type Test case Remark

DTG DVBT2_DTG_xyz 117 test cases,
xyz = 000 to 109, 162 to 168

DVBT2_DTG_xyz_MISO_Groupa 104 test cases, xyz = 110 to 161
a = 1 to 2

NorDig UTP 2.4 DVBT2_NORDIG_3_xy_z -

NorDig UTS 2.2.2 DVBT2_NORDIG_3_xy_z -

DVB V&V DVBT2_VV_xyz_OFCOMa 7 test cases, xyz = 001, 003, 012 to 016
a = 1 to 7

DVBT2_VV_xyz 13 test cases,
xyz = 004 to 011, 017, 019,
034 to 036

DVBT2_VV_xyz_MISO_Groupa 2 test cases, xyz = 018 a = 1 to 7
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Glossary: Abbreviations
A

ACE: Active Constellation Extension

ACM: Adaptive Coding and Modulation

ASI: Asynchronous Serial Interface

B
BICM: Bit-Interleaved Coding and Modulation

BPSK: Binary Phase Shift Keying

C
CM: Coding and Modulation

D
DHCP: Dynamic Host Configuration Protocol

DVB-H: Digital Video Broadcast - Handheld

DVB-T: Digital Video Broadcast - Terrestrial

F
FEC: Forward Error Correction

FEF: Future Extension Frame(s)

FFT: Fast Fourier Transform

FIFO: First In First Out

G
GPS: Global Positioning System

I
IFFT: Inverse Fast Fourier Transform

IGMP: Internet Group Management Protocol

IGMPv3: Internet Group Management Protocol version 3

ISCR: Input Stream Clock Reference
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ISSY: Input Stream Synchronizer

M
MAC: Media Access Control

MFN: Multi-frequency Network

MISO: Multiple Input Single Output

MPE FEC: Multiprotocol encapsulation forward error correction

MPEG: Moving Picture Experts Group
https://mpeg.chiariglione.org/

N
NTP: Network Time Protocol

O
OFDM: Orthogonal Frequency-Division Multiplexing

P
PCR: Programme Clock Reference

PID: Packet Identifier

PLP: Physical Layer Pipe

PRBS: Pseudo-Random Bit Sequence

Q
QAM: Quadrature Amplitude Modulation

QPSK: Quaternary Phase Shift Keying

R
RTP: Real-Time Transport Protocol

S
SFN: Single-frequency Network

SID: Stream Identifier

SISO: Single Input Single Output

SMPTE: Society of Motion Picture and Television Engineers

https://mpeg.chiariglione.org/
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https://www.smpte.org/

T
T2-MI: T2 Modulator interface

TCP: Transmission Control Protocol

TFS: Time Frequency Slicing

TPS: Transmission Parameter Signalling

TR: Tone Reservation

TS: Transport Stream

U
UDP: User Datagram Protocol

UTC: Universal Time Coordinated

V
VSB: Vestigial Sideband Modulation

https://www.smpte.org/
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Glossary: Specifications
E

ETSI EN 302 307: Digital Video Broadcasting (DVB); Second generation framing struc-
ture, channel coding and modulation systems for Broadcasting, Interactive Services,
News Gathering and other broadband satellite applications (DVB-S2)
https://www.etsi.org/deliver/etsi_en/302300_302399/302307/

ETSI EN 302 755: Digital Video Broadcasting (DVB); Frame structure channel coding
and modulation for a second generation digital terrestrial television broadcasting sys-
tem (DVB-T2)
https://www.etsi.org/deliver/etsi_en/302700_302799/302755/

ETSI TS 102 773: Digital Video Broadcasting (DVB); Modulator Interface (T2-MI) for a
second generation digital terrestrial television broadcasting system (DVB-T2)
https://www.etsi.org/deliver/etsi_ts/102700_102799/102773/

I
ITU-T O.151: ITU-T Recommendation O.151
https://www.itu.int/rec/T-REC-O.151-199210-I/en

 

https://www.etsi.org/deliver/etsi_en/302300_302399/302307/
https://www.etsi.org/deliver/etsi_en/302700_302799/302755/
https://www.etsi.org/deliver/etsi_ts/102700_102799/102773/
https://www.itu.int/rec/T-REC-O.151-199210-I/en
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