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Warranty

THE MATERIAL CONTAINED IN THIS 
DOCUMENT IS PROVIDED “AS IS,” 
AND IS SUBJECT TO BEING 
CHANGED, WITHOUT NOTICE, IN 
FUTURE EDITIONS. FURTHER, TO 
THE MAXIMUM EXTENT PERMITTED 
BY APPLICABLE LAW, KEYSIGHT 
DISCLAIMS ALL WARRANTIES, 
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Technology Licenses

The hardware and/or software 
described in this document are 
furnished under a license and may be 
used or copied only in accordance 
with the terms of such license.

U.S. Government Rights

The Software is “commercial 
computer software,” as defined 
by Federal Acquisition Regulation 
(“FAR”) 2.101. Pursuant to FAR 
12.212 and 27.405-3 and 
Department of Defense FAR 
Supplement (“DFARS”) 227.7202, 
the U.S. government acquires 
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embodied in its End User License 
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http://www.keysight.com/find/sweula
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may use, modify, distribute, or 
disclose the Software. The EULA 
and the license set forth therein, 
does not require or permit, 
among other things, that 
Keysight: (1) Furnish technical 
information related to 
commercial computer software 
or commercial computer 
software documentation that is 
not customarily provided to the 
public; or (2) Relinquish to, or 
otherwise provide, the  
government rights in excess of 
these rights customarily provided 
to the public to use, modify, 
reproduce, release, perform, 
display, or disclose commercial 
computer software or 
commercial computer software 

documentation. No additional 
government requirements 
beyond those set forth in the 
EULA shall apply, except to the 
extent that those terms, rights, or 
licenses are explicitly required 
from all providers of commercial 
computer software pursuant to 
the FAR and the DFARS and are 
set forth specifically in writing 
elsewhere in the EULA. Keysight 
shall be under no obligation to 
update, revise or otherwise 
modify the Software.  With 
respect to any technical data as 
defined by FAR 2.101, pursuant 
to FAR 12.211 and 27.404.2 and 
DFARS 227.7102, the U.S. 
government acquires no greater 
than Limited Rights as defined in 
FAR 27.401 or DFAR 227.7103-5 
(c), as applicable in any technical 
data.

Safety Notices

A CAUTION notice denotes a hazard. It 
calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or adhered 
to, could result in damage to the 
product or loss of important data. Do 
not proceed beyond a CAUTION 
notice until the indicated conditions 
are fully understood and met. 

A WARNING notice denotes a hazard. 
It calls attention to an operating 
procedure, practice, or the like that, 
if not correctly performed or adhered 
to, could result in personal injury or 
death. Do not proceed beyond a 
WARNING notice until the indicated 
conditions are fully understood and 
met.
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Where to Find the Latest Information

Documentation is updated periodically. For the latest information about these products, including instrument software 
upgrades, application information, and product information, browse to one of the following URLs, according to the name 
of your product:

http://www.keysight.com/find/X-Series_SG

To receive the latest updates by email, subscribe to Keysight Email Updates at the following URL:

http://www.keysight.com/find/MyKeysight

Information on preventing instrument damage can be found at:

www.keysight.com/find/PreventingInstrumentRepair

Is your product software up-to-date?

Periodically, Keysight releases software updates to fix known defects and incorporate product enhancements. To search 
for software updates for your product, go to the Keysight Technical Support website at:

http://www.keysight.com/find/techsupport

What has Changed

In this document the terms "master" and "slave" have been replaced with "primary" and "secondary."
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— Custom Digital Modulation (Option N5180431B)
— Multitone and Two-Tone Waveforms  (Option N5180430B)
— Troubleshooting
— Working in a Secure Environment

Programming Guide — Getting Started with Remote Operation
— Using IO Interfaces
— Programming Examples
— Programming the Status Register System
— Creating and Downloading Files
— Creating and Downloading User–Data Files

SCPI Reference — SCPI Basics
— Basic Function Commands
— System Commands
— Analog Modulation Commands
— Arb Commands
— Avionics VOR/ILS Commands
— Bit Error Rate Test (BERT) Commands
— Digital Signal Interface Module Commands
— Real-Time Commands
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Programming 
Compatibility Guide

— Provides a listing of SCPI commands and programming codes for 
signal generator models that are supported by the Keysight CXG, 
EXG, and MXG X- Series signal generators.

Service Guide — Troubleshooting
— Replaceable Parts
— Assembly Replacement
— Post–Repair Procedures
— Safety and Regulatory Information
— Instrument History

Error Messages Guide — Error Messages
— Error Message Format
— Error Message Type
— List of Error Messages

Key Helpa — Key function description
— Related SCPI commands

a. Press the Help key, and then the key for which you wish help.
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Keysight Technologies

X-Series Signal Generators

User’s Guide

1 Signal Generator Overview

— Signal Generator Features on page 20

— Modes of Operation on page 21

— Front Panel Overview on page 23

— Front Panel Display on page 27

— Rear Panel Overview (N5166B, N5171B, N5172B, N5181B, & N5182B) on page 30

— Rear Panel Overview (N5173B & N5183B) on page 39

To avoid damaging or degrading the performance of the instrument, do not 
exceed 33 dBm (2W) maximum (27 dBm (0.5W) for N5173N/83B) of reverse 
power levels at the RF input. See also Tips for Preventing Signal Generator 
Damage on www.keysight.com.
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Signal Generator Features

— N5171B/N5181B, RF analog models: 9 kHz to 1 (N5171B only), 3, or 6 GHz (Options 501, 503, 
and 506 respectively)

— N5166B/N5172B/N5182B, RF vector models: 9 kHz to 3 or 6 GHz (Options 503, and 506 
respectively)

— N5173B/N5183B, Microwave analog models: 9 kHz to 13, 20, 31.8 or 40 GHz (Options 513, 520, 
532, and 540 respectively)

— electronic attenuator (N5166B, N5172B, N5173B, N5181B, N5182B)

— mechanical attenuator (N5173B or N5183B, Option 1E1)

— vector models can include waveforms in list sweep

— automatic leveling control (ALC)

— real-time modulation filtering

— 8648/ESG code compatible

— 10 MHz reference oscillator with external output

— two channel power meter display

— user settable maximum power limit 

— user flatness correction

— external analog I/Q inputs (vector models)

— enhanced assembly replacement

— GPIB, USB 2.0, and 100Base–T LAN interfaces

— deep amplitude modulation providing greater dynamic range

— manual power search (ALC off)

— SCPI and IVI–COM driver 

— multiple baseband generator synchronization when using multiple signal generators 
(primary/secondary setup)

— with Signal Studio Software, vector models can generate 802.11 WLAN, W–CDMA, cdma2000, 
1xEV–DO, GSM, EDGE, and more

— real-time baseband generator (Option 660)

— pulse train generator (Option N5180320B)

— LF multifunction generator (Option 303)

— narrow pulse modulation, including internal pulse generator (Option UNW)

— analog differential I/Q outputs (vector models, Option 1EL)

— analog modulation: AM, FM, and ΦM (Option UNT)
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— arbitrary I/Q waveform playback up to 200 MSa/s (vector models, Option 656/657)

— external AM, FM, and ΦM inputs (Option UNT)

— Wideband AM (vector models, Option UNT)

— flexible reference input, 1 – 50 MHz (Option 1ER)

— LO In/Out for phase coherency (Option 012)

— phase noise interference (vector models, Option N5180432B)

— expanded license key upgradability (Option 099)

For more details on hardware, firmware, software, and documentation features and options, refer to 
the data sheet shipped with the signal generator and available from the Keysight Technologies 
website at http://www.keysight.com/find/X-Series_SG. 

Modes of Operation
Depending on the model and installed options, the Keysight X-Series signal generator provides up 
to four basic modes of operation: continuous wave (CW), swept signal, analog modulation, and 
digital modulation.

Continuous Wave

In this mode, the signal generator produces a continuous wave signal. The signal generator is set to 
a single frequency and power level. Both the analog and vector models can produce a CW signal.

Swept Signal

In this mode, the signal generator sweeps over a range of frequencies and/or power levels. Both the 
analog and vector models provide list and step sweep functionality.

Analog Modulation

In this mode, the signal generator modulates a CW signal with an analog signal. The analog 
modulation types available depend on the installed options. 

Option UNT provides AM, FM, and ΦM modulations. Some of these modulations can be used 
together. 

Option 303 provides a multifunction generator that consists of seven waveform generators.

Option UNW provides standard and narrow pulse modulation capability.
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Digital Modulation (Vector Models with Option 65x Only)

In this mode, the signal generator modulates a CW signal with an arbitrary I/Q waveform. I/Q 
modulation is only available on vector models. An internal baseband generator (Option 65x) adds 
the following digital modulation formats:

— Custom Arb Waveform Generator mode can produce a single–modulated carrier or multiple–
modulated carriers. Each modulated carrier waveform must be calculated and generated before 
it can be output; this signal generation occurs on the internal baseband generator. Once a 
waveform has been created, it can be stored and recalled, which enables repeatable playback of 
test signals. To learn more, refer to “Using the Arbitrary Waveform Generator” on page 401.

— Custom Real-Time Waveform Generator mode can produce a single–modulated carrier or 
multiple–modulated carriers. Each modulated carrier waveform must be calculated and 
generated before it can be output; this signal generation occurs on the internal baseband 
generator. Once a waveform has been created, it can be stored and recalled, which enables 
repeatable playback of test signals. To learn more, refer to “Using the Arbitrary Waveform 
Generator” on page 401.

— Multitone mode produces up to 64 continuous wave signals (or tones). Like the Two Tone mode, 
the frequency spacing between the signals and the amplitudes are adjustable. To learn more, 
refer to “Creating a Custom Multitone Waveform” on page 434.

— Two–tone mode produces two separate continuous wave signals (or tones). The frequency 
spacing between the signals and the amplitudes are adjustable. To learn more, refer to Chapter 
17, “Multitone and Two-Tone Waveforms  (Option N5180430B).”.

— Dual ARB mode is used to control the playback sequence of waveform segments that have been 
written into the ARB memory located on the internal baseband generator. These waveforms can 
be generated by the internal baseband generator using the Custom Arb Waveform Generator 
mode, or downloaded through a remote interface into the ARB memory. To learn more, refer to 
“Dual ARB Player” on page 207. 
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Front Panel Overview 

1. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. The 
instrument also has a rear panel device USB connector (see page 32) used to remotely control the 
instrument.

2. Display

The LCD screen provides information on the current function. Information can include status 
indicators, frequency and amplitude settings, and error messages. Labels for the softkeys are 
located on the right hand side of the display. See also, “Front Panel Display” on page 27.

3. Softkeys

A softkey activates the function indicated by the displayed label to the left of the key.

4. Numeric Keypad

The numeric keypad comprises the 0 through 9 hardkeys, a decimal point hardkey, a minus sign 
hardkey, and a backspace hardkey. See “Entering and Editing Numbers and Text” on page 61.

Connector Type A

USB Protocol 2.0

22. Power Switch and LEDs 

21. More and LED 

20. Return 

18. Knob 

19. Incr Set 
15. Page 
Down 

16. I Input 
(vector 
models only) 

17. Q Input (vector 
models only) 

12. RF Output 
(N5166B, 
N5171B, 
N5172B, 
N5181B, 
N5182B) 

13. RF On/Off and LED 

14. Mod On/Off and LED 

7. MENUS  

11. Preset and 
User Preset 

9. Local 
Cancel/(Esc) 

5. Arrows and Select 

6. Page Up 

8. Trigger 

4. Numeric 
Keypad 

3. Softkeys 

2. Display 1. Host USB 
10. Help 
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5. Arrows and Select

The Select and arrow hardkeys enable you to select items on the signal generator’s display for 
editing. See “Entering and Editing Numbers and Text” on page 61.

6. Page Up

In a table editor, use this hardkey to display a previous page. See “Example: Using a Table Editor” 
on page 62. When text does not fit on one page in the display area, use this key in conjunction with 
the Page Down key (page 25) to scroll text.

7. MENUS

These hardkeys open softkey menus that enable you to configure instrument functions or access 
information.

8. Trigger

When trigger mode is set to Trigger Key, this hardkey initiates an immediate trigger event for a 
function such as a list or step sweep.

9. Local Cancel/(Esc)

This hardkey deactivates remote operation and returns the signal generator to front panel control, 
cancels an active function entry, and cancels long operations (such an IQ calibration).

10. Help

Use this key to display a description of any hardkey or softkey. See “Viewing Key Descriptions” on 
page 60.

See page 82

See page 76

See page 63

See page 179

See page 189Active only on 
vector models.

See page 63

See page 66

See page 43

See page 185

See page 205

See page 88

See page 90
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11. Preset and User Preset

These hardkeys set the signal generator to a known state (factory or user–defined). See “Presetting 
the Signal Generator” on page 60.

12. RF Output (N5166B, N5171B, N5172B, N5181B, N5182B)

12. RF Output (N5173B, N5183B)

13. RF On/Off and LED

This hardkey toggles the operating state of the RF signal present at the RF OUTPUT connector. The 
RF On/Off LED lights when RF output is enabled.

14. Mod On/Off and LED

This hardkey enables or disables the modulation of the output carrier signal by an active 
modulation format. This hardkey does not set up or activate a format (see “Modulating the Carrier 
Signal” on page 74).

The MOD ON/OFF LED lights when modulation of the output is enabled.

15. Page Down

In a table editor, use this hardkey to display the next page. See “Example: Using a Table Editor” on 
page 62. When text does not fit on one page in the display area, use this key in conjunction with the 
Page Up key (page 24) to scroll text.

16. I Input (vector models only)

See also, “I/Q Modulation” on page 265.

Connector Standard: 
Option 1EM: 
Impedance:

female Type–N 
Rear panel output 
50 Ω

Damage Levels 50 Vdc, 2 W maximum RF power

Connector Option 513/520: 
Option 532/540: 
Option 1ED Option 
1EM: 
Impedance:

male Precision APC-3.5  
male Precision 2.4 mm  
female Type–N 
Rear panel output 
50 Ω

Damage Levels 0 Vdc, 0.5 W maximum RF power

Connector Type: female BNC Impedance: 50 Ω
Signal An externally supplied analog, in–phase component of I/Q modulation. 

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1 Vrms
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17. Q Input (vector models only)

See also, “I/Q Modulation” on page 265.

18. Knob

Rotating the knob increases or decreases a numeric value, or moves the highlight to the next digit, 
character, or item in a list. See also, “Front Panel Knob Resolution” on page 46.

19. Incr Set 

This hardkey enables you to set the increment value of the currently active function. The increment 
value also affects how much each turn of the knob changes an active function’s value, according to 
the knob’s current ratio setting (see “Front Panel Knob Resolution” on page 46).

20. Return 

This hardkey enables you to retrace key presses. In a menu with more than one level, the Return key 
returns to the prior menu page.

21. More and LED

When a menu contains more softkey labels than can be displayed, the More LED lights and a More 
message displays below the labels. To display the next group of labels, press the More hardkey.

22. Power Switch and LEDs

This switch selects the standby mode or the power on mode. In the standby position, the yellow 
LED lights and all signal generator functions deactivate. The signal generator remains connected to 
the line power, and some power is consumed by some internal circuits. In the on position, the green 
LED lights and the signal generator functions activate.

Connector Type: female BNC Impedance: 50 Ω
Signal An externally supplied analog, quadrature–phase component of I/Q modulation. 

The signal level is  = 0.5 Vrms for a calibrated output level.

Damage Levels 1 Vrms
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Front Panel Display

1. Active Function Area

This area displays the currently active function. For example, if frequency is the active function, the 
current frequency setting appears. If the currently active function has an increment value 
associated with it, that value also appears. 

2. Frequency Area

This area displays the current frequency setting.

3. Annunciators

Annunciators show the status of some of the signal generator functions, and indicate error 
conditions. An annunciator position may be used by more than one annunciator; in this case, only 
one of the functions sharing a given position can be active at a given time.

This annunciator appears when...

ΦM Phase modulation is on. If you turn frequency modulation on, the FM annunciator replaces ΦM.

ARB The ARB generator is on. ARB is running and not waiting on a trigger.

ALC OFF The ALC circuit is disabled. The UNLEVEL annunciator appears in the same position if the ALC is enabled and 
is unable to maintain the output level.

AM Amplitude modulation is on.

ARMED A sweep has been initiated and the signal generator is waiting for the sweep trigger event.

ATTNHOLD The attenuator hold function is on. When this function is on, the attenuator is held at its current setting.

AWGN Real Time I/Q Baseband additive white Gaussian noise is on.

BBG DAC A DAC overflow is occurring, adjust the runtime scaling adjust until the BBG DAC annunciator turns off. 
Another annunciator, UNLOCK, appears in the same position and has priority over the BBG DAC annunciator 
(see UNLOCK, below).

CHANCORR The internal channel correction is enabled.

DETHTR The ALC detector heater is not up to temperature. To meet ALC specifications the heater must be at 
temperature.

DIGBUS The digital bus is in use.

5. Error Message Area 6. Text Area 
 
7. Softkey Label Area 

4. Amplitude Area 3. Annunciators 2. Frequency Area 1. Active Function Area 

Scroll Bar
If there is more 
text than can be 
displayed on one 
screen, a scroll 
bar appears here. 
Use the Page Up 
and Page Down 
keys to scroll 
through the text.
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4. Amplitude Area

This area displays the current output power level setting (If the RF Output is off, this area is greyed 
out).

5. Error Message Area

This area displays abbreviated error messages. If multiple messages occur, only the most recent 
message remains displayed. See “Reading Error Messages” on page 88.

DIGMOD Custom Arb waveform generator is on.

ERR An error message is placed in the error queue. This annunciator does not turn off until you either view all of the 
error messages or clear the error queue (see “Reading Error Messages” on page 88).

EXTREF An external frequency reference is applied.

FM Frequency modulation is on. If you turn phase modulation on, the ΦM annunciator replaces FM.

I/Q I/Q vector modulation is on.

L The signal generator is in listener mode and is receiving information or commands over the GPIB, USB, or VXI–
11/Sockets (LAN) interface.

M–TONE Multitone waveform generator is on.

MULT A frequency multiplier is set (see “Setting a Frequency Multiplier” on page 128).

OFFS An output offset is set (see “Setting an Output Offset” on page 126).

PN Phase noise interference is on.

PULSE Pulse modulation is on.

R The signal generator is remotely controlled over the GPIB, USB, or VXI–11/Sockets (LAN) interface. When the 
signal generator is in remote mode, the keypad is locked out. To unlock the keypad, press Local (see page 
24).

REF An output reference is set (see “Setting an Output Reference” on page 127).

RF OFF The signal generator’s RF Output is not enabled.

S The signal generator has generated a service request (SRQ) over the GPIB, USB, or VXI–11/Sockets (LAN) 
interface.

SWEEP The signal generator is currently sweeping in list or step mode.

SWMAN The signal generator is in manual sweep mode.

T The signal generator is in talker mode and is transmitting information over the GPIB, USB, or VXI–11/Sockets 
(LAN) interface.

T–TONE Two–Tone waveform generator is on.

UNLEVEL The signal generator is unable to maintain the correct output level. This is not necessarily an indication of 
instrument failure; unleveled conditions can occur during normal operation. Another annunciator, ALC OFF, 
appears in the same position when the ALC circuit is disabled (see ALC OFF, above).

UNLOCK Any of the phase locked loops cannot maintain phase lock. To determine which loop is unlocked, examine the 
error messages (see “Reading Error Messages” on page 88).

WATRG The current modulation mode is waiting on the Arb trigger.

WINIT The signal generator is waiting for you to initiate a single sweep.

This annunciator appears when...
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6. Text Area

This area displays signal generator status information, such as the modulation status, and other 
information such as sweep lists and file catalogs. This area also enables you to perform functions 
such as managing information (entering information, and displaying or deleting files).

7. Softkey Label Area

This area displays labels that define the function of the softkeys located immediately to the right of 
the display. Softkey labels change, depending on the function selected.
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Rear Panel Overview  
(N5166B, N5171B, N5172B, N5181B, & N5182B)

1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the Getting 

Started Guide.

To avoid the loss of data, GPIB settings, or current user instrument states that have not been 
permanently saved to nonvolatile memory, the signal generator should always be powered down 
either via the instrument’s front panel power button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down with the system rack power switch rather 
than the instrument’s front panel switch display a Error -310 due to the instrument not being 
powered down correctly.

4. SWEEP OUT 

2. EXT 1 & 
EXT 2 

5. PULSE 

6. TRIG 1 & 2 

7. REF IN 

9. GPIB 10. LAN 

11. Device USB 

8. 10 MHz OUT 

1. AC Power Receptacle 

Option 1EM 
only  
See 
page 25

Digital Modulation Connectors (Vector Models 
Only) on page 33

12. Host USB 

13. SD Card 

3. LF OUT 
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2. EXT 1 & EXT 2

3. LF OUT

4. SWEEP OUT

5. PULSE

6. TRIG 1 & 2

7. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this 
connector and automatically switch from internal to external reference operation. See “Presetting 
the Signal Generator” on page 60. With Option 1ER (flexible reference input), you must explicitly 
tell the signal generator the external reference frequency you wish to use; enter the information 
through the front panel or over the remote interface.

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied ±1 Vp signal that produces the indicated depth.

Damage Levels 5 Vrms and 10 Vp

Connector female BNC Impedance 50 Ω
Signal Voltage range: 0 to +5 Vp 

Offset: -5 V to +5 V, nominal

For more information, see page 185.

Connector female BNC  
Can drive 2 kΩ.

Impedance <1 Ω

Signal Voltage range: 0 to +10 V, regardless of sweep width 
In swept mode: beginning of sweep = 0 V; end of sweep = +10 V 
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 67 and 189.

Connector female BNC Impedance nominally 50 Ω
Signal Externally supplied: +1 V = on; 0 V = off 

Damage Levels ≤ −0.3 and ≥+5.3 V

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as point to point in 
manual sweep mode or an LF sweep in external sweep mode. 
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5 and ≥+5.5 V

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.
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8. 10 MHz OUT

9. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 10. LAN and 
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this 
connector, which enables a LAN–connected computer to remotely program the signal generator. 
The LAN interface supports auto–MDIX. The signal generator is limited to 100 meters on a single 
cable (100Base–T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

12. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. 

13. SD Card

Holds the Secure Digital (SD) nonvolatile memory card.

Connector female BNC Impedance nominally 50 Ω
Signal A nominal signal level greater than 4 dBm.

Connector Type B

USB Protocol Version 2.0

Connector Type A

USB Protocol 2.0
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Digital Modulation Connectors (Vector Models Only)

I OUT, Q OUT,  OUT,  OUT

BB TRIG 1 & BB TRIG 2

EVENT 1

 OUT and  OUT, require Option 1EL.

Connector Type: female BNC Impedance: 50 Ω  
DC–coupled

Signal

 I OUT The analog, in–phase component of I/Q modulation from the internal baseband generator.

 Q OUT The analog, quadrature–phase component of I/Q modulation from the internal baseband 
generator.

      OUT Used in conjunction with the I OUT connector to provide a balanceda baseband stimulus.

a. Balanced signals are signals present in two separate conductors that are symmetrical relative 
to ground, and are opposite in polarity (180 degrees out of phase).

  OUT Used in conjunction with the Q OUT connector to provide a balanceda baseband stimulus.

Damage Levels > 1 Vrms DC Origin 
Offset

typically <10 mV

Output Signal Levels into a 50 Ω Load

— 0.5 Vpk, typical, corresponds to one unit length of the I/Q vector
— 0.69 Vpk (2.84 dB), typical, maximum crest factor for peaks for π/4 DQPSK, 

alpha = 0.5
— 0.71 Vpk (3.08 dB), typical, maximum crest factor for peaks for π/4 DQPSK, 

alpha = 0.35
— Typically 1 Vp–p maximum

Connector female BNC Impedance nominally 50 Ω
Signal Reserved for arbitrary and real-time baseband generators I/O, such as markers or trigger inputs.

Connector female BNC Impedance: nominally 50 Ω
Signal A pulse that can be used to trigger the start of a data pattern, frame, or timeslot.  

Adjustable to ± one timeslot; resolution = one bit 
Markers 
Each Arb–based waveform point has a marker on/off condition associated with it.  
Marker 1 level = +3.3 V CMOS high (positive polarity selected); –3.3 V CMOS low (negative 
polarity selected).  
Output on this connector occurs whenever Marker 1 is on in an Arb–based waveform (see 
“Using Waveform Markers” on page 223).

Damage Levels < −4 and > +8 V

I Q

I Q

I

Q
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PAT TRIG

DIGITAL BUS I/O

This is a proprietary bus used by Keysight Technologies signal creation software. This connector is 
not operational for general purpose use. Signals are present only when a signal creation software 
option is installed (for details, refer to http://www.keysight.com/find/signalcreation).

Connector female BNC 

Signal A TTL/CMOS low to TTL/CMOS high, or TTL/CMOS high to TTL/CMOS low edge trigger.  
The input to this connector triggers the internal digital modulation pattern generator to start a 
single pattern output or to stop and re–synchronize a pattern that is being continuously output. 
To synchronize the trigger with the data bit clock, the trigger edge is latched, then sampled 
during the falling edge of the internal data bit clock.  
This is the external trigger for all ARB waveform generator triggers.

Minimum Trigger Input Pulse 
Width

(high or low) = 10 ns

Minimum Trigger Delay (trigger edge to first bit of frame) = 1.5 to 2.5 bit clock periods

Damage Levels < −4 and > +8 V

The X-Series’ Digital BUS I/O connector can be used for enabling 
operation with the Keysight Technologies N5106A PXB MIMO Receiver 
Tester.
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AUX I/O Connector

This female 36-pin connector is available only on instruments with an internal baseband generator 
(Option 653, 655, 656, 657). On signal generators without one of these options, this connector is 
not present. 

The AUX I/O connector allows the X-Series signal generator to interface with external equipment 
by sending and/or receiving supplementary (auxiliary) signaling information. This information is 
non-RF related signaling such as:

— output markers to an external device from Arbitrary waveform playback sent to external 
equipment to trigger or respond to waveform changes.

— output of signal markers to an external device from real-time signal generation personalities. 
Signals such as frame markers, pulse-per-second, and even-second, for example, may be 
supported, depending on the signal generation personality (CDMA, 3GPP, GNSS, LTE, etc.).

— input signals from external devices under test to cause the signal generator to modify 
characteristics of a signal being generated, depending on the signal generation personality 
(CDMA, 3GPP, LTE, etc.).

Table 1-1 on page 37 describes the inputs and outputs accessible through the AUX I/O connector. 
The specific functions controllable by auxiliary signaling vary significantly from one real-time signal 
generation personality to another. Refer to the documentation for each real-time signal generation 
personality for additional information.

The AUX I/O connector supports standard 3.3V TTL signaling levels. 
Signals support data rates up to 50 MHz with minimum rise and fall times 
of 3ns. Any pins that are not connected will have a weak pull-up to 3.3V.

18 1

1936

The AUX I/O connector is a shielded .050 series 

View looking into the rear panel 

The AUX I/O mating connector manufacturer’s part number is 
3M® 10136-3000 (wire mount plug).
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Markers (pins 1-4) 
Each Arb–based waveform point has a marker on/off condition associated with it.  
Each real-time signal can be routed to the output marker signals using SCPI commands or the real-time personalities. 
Marker level = +3.3 V high (positive polarity selected); 0V low (negative polarity selected).

Event 1 (pin 1) 
Pin 1 outputs a pulse that can be used to trigger the start of a data pattern, frame, or timeslot.  
Adjustable to ± one timeslot; resolution = one bit

Data Clock Out (pin 7) 
Pin 7 is used with an internal baseband generator. This pin relays a CMOS bit clock signal for synchronizing serial data. 

Data In (pin 23) 
Pin 23 accepts an externally supplied CMOS-compatible signal data input used with digital modulation applications. The 
expected input is a CMOS signal where a CMOS high is equivalent to a data 1 and a CMOS low is equivalent to a data 0.

The maximum input data rate is 50 Mb/s. The data must be valid on the DATA CLOCK 
falling edges.

Symbol Sync In (pin 25) 
Pin 25 accepts an externally supplied symbol sync signal for use with digital modulation applications. 

Data Clock In (pin 29) 
Pin 29 accepts an externally supplied CMOS-compatible signal data-clock input used with digital modulation applications. 
The expected input is a MCOS bit clock signal where the rising edge is aligned with the beginning data bit. The falling edge 
is used to clock the DATA and SYMBOL SYNC signals.

The maximum clock rate is 50 MHz. 

Event 2 (pin 31) 
Pin 31 outputs data enable signal for gating external equipment. The output is applicable when the external data is clocked 
into internally generated timeslots. Data is enabled when the signal is low.
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Table 1-1 AUX I/O Connector Configuration

CXG, MXG, and EXG AUX I/O Connector Configuration

ARB & ARB-Based 
Applications

Real-Time Custom 
Modulation

Real-Time 
Applications

BERT Capability 

Pin # Input Output Input Output Input Output Input Output

1 Marker(1) Event 1 Marker(1)

2 Marker(2) Marker(2)

3 Marker(3) Marker(3)

4 Marker(4) Marker(4)

5

6 AUX 
Strobe

7 Data 
Clock 
Output

10MHz 
Clock

8 AUX(0)

9 AUX(1)

10 AUX(2)

11 AUX(3)

12 AUX(4)

13 AUX(5)

14 AUX(6) AUX I/O

15 AUX(7) BER Meas 
Enda

16 AUX(8) BER Sync 

Lossa

17 AUX(9) BER Test 

Outa

18 AUX(10) BER Gate 

Outa

19 AUX(11) BER No 

Dataa

20 GND GND GND GND GND GND

21 AUX(12)
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22 GND GND GND GND GND GND

23 Data 
Input

AUX(13)

24 GND GND GND GND GND GND

25 Symbol 
Sync 
Input

AUX(14)

26 GND GND GND GND GND GND

27 Burst 
Input

AUX(15)

28 GND GND GND GND GND GND

29 Data 
Clock 
Input

AUX 
Sample 
Clock

30 GND GND GND GND GND GND

31 Event 2

32 GND GND GND GND GND GND

33 Data Out AUX 
Out(1)

34 GND GND GND GND GND GND

35 Symbol 
Sync 
Output

AUX 
Out(2)

36 GND GND GND GND GND GND

a. Settings shown are for the Error Out signal configuration of the AUX I/O connector (BERT > I/O 
Setup > Aux I/O Out). Press the Help hardkey, then either Reference Out or PN9 Out for the 
respective signal configuration.

Table 1-1 AUX I/O Connector Configuration

CXG, MXG, and EXG AUX I/O Connector Configuration

ARB & ARB-Based 
Applications

Real-Time Custom 
Modulation

Real-Time 
Applications

BERT Capability 

Pin # Input Output Input Output Input Output Input Output
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1. AC Power Receptacle

The AC power cord receptacle accepts a three–pronged AC power cord that is supplied with the 
signal generator. For details on line setting requirements and the power cord, see the Getting 

Started Guide.

To avoid the loss of data, GPIB settings, or current user instrument states 
that have not been permanently saved to nonvolatile memory, the signal 
generator should always be powered down either via the instrument’s 
front panel power button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down with the system 
rack power switch rather than the instrument’s front panel switch display a 
Error -310 due to the instrument not being powered down correctly.

4. SWEEP OUT 

2. EXT 1 & EXT 2 5. PULSE 

6. TRIG 1 & 2 

7. REF IN 

9. GPIB 10. LAN 

11. Device USB 

8. 10 MHz OUT 

1. AC Power Receptacle 

Option 1EM 
only  
See 
page 25

12. Host USB 
13. SD Card 3. LF OUT 

14. ALC INPUT 
15. Z AXIS OUTPUT 
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2. EXT 1 & EXT 2

3. LF OUT

4. SWEEP OUT

5. PULSE

6. TRIG 1 & 2

7. REF IN

In its factory default mode, the signal generator can detect a valid reference signal at this 
connector and automatically switch from internal to external reference operation. See “Presetting 
the Signal Generator” on page 60. With Option 1ER (flexible reference input), you must explicitly 
tell the signal generator the external reference frequency you wish to use; enter the information 
through the front panel or over the remote interface.

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied ±1 Vp signal that produces the indicated depth.

Damage Levels 5 Vrms and 10 Vp

Connector female BNC Impedance 50 Ω
Signal Voltage range: 0 to +5 Vp 

Offset: -5 V to +5 V, nominal

For more information, see page <PagenumOnlyCallout>185.

Connector female BNC  
Can drive 2 kΩ.

Impedance <1 Ω

Signal Voltage range: 0 to +10 V, regardless of sweep width 
In swept mode: beginning of sweep = 0 V; end of sweep = +10 V 
In CW mode: no output

This is a multiple use connector. For signal routing selections, see pages 67 and 189.

Connector female BNC Impedance nominally 50 Ω
Signal Externally supplied: +1 V = on; 0 V = off 

Damage Levels ≤ −0.3 and ≥+5.3 V

Connector female BNC Impedance high Z

Signal An externally supplied TTL or CMOS signal for triggering operations, such as point to point in 
manual sweep mode or an LF sweep in external sweep mode. 
Triggering can occur on either the positive or negative edge.

Damage Levels ≤ −0.5 and ≥+5.5 V

Connector female BNC Impedance nominally 50 Ω
Signal An externally supplied −3.5 to +20 dBm signal from a timebase reference that is within ±1 ppm.
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8. 10 MHz OUT

9. GPIB

This connector enables communication with compatible devices such as external controllers, and is 
one of three connectors available to remotely control the signal generator (see also 10. LAN and 
11. Device USB).

10. LAN

The signal generator supports local area network (LAN) based communication through this 
connector, which enables a LAN–connected computer to remotely program the signal generator. 
The LAN interface supports auto–MDIX. The signal generator is limited to 100 meters on a single 
cable (100Base–T). For more information on the LAN, refer to the Programming Guide.

11. Device USB

Use this universal serial bus (USB) connector to connect a PC to remotely control the signal 
generator.

12. Host USB

Use this universal serial bus (USB) to connect a USB Flash Drive (UFD) for data transfer. You can 
connect or disconnect a USB device without shutting down or restarting the signal generator. 

13. SD Card

Holds the Secure Digital (SD) nonvolatile memory card.

14. ALC INPUT

This input connector is used for negative external detector leveling.

Connector female BNC Impedance nominally 50 Ω
Signal A nominal signal level greater than 4 dBm.

Connector Type B

USB Protocol Version 2.0

Connector Type A

USB Protocol 2.0

Connector female BNC Impedance nominally 100 kΩ
Signal -0.2 mV to -0.5 V

Damage Levels -12 to 1 V
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15. Z AXIS OUTPUT

This female BNC connector supplies a +5 V (nominal) level during retrace and band-switch intervals 
of a step or list sweep. During step or list sweep, this female BNC connector supplies a -5 V 
(nominal) level when the RF frequency is at a marker frequency and intensity marker mode is on. 
This signal is derived from an operational amplifier output so the load impedance should be greater 
than or equal to 5 kohms.1

Connector female BNC Impedance nominally 50 Ω
Signal A nominal signal level greater than 4 dBm.
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2 Preferences & Enabling Options

The Utility menu provides access to both user and remote operation preferences, and to the menus 
in which you can enable instrument options.

Display Settings on page 45

Front Panel Knob Resolution on page 46

Power On and Preset on page 46

Enabling an Option on page 55

GPIB Address and Remote Language on page 49
Configuring the LAN Interface on page 50
Enabling LAN Services: “Browser,” “Sockets,” and “VXI–11” on page 50
Configuring the Remote Languages on page 51

User Preferences

Remote Operation Preferences

Setting Time and Date on page 47

Upgrading Firmware on page 49

Hardware Assembly Installation and Removal Softkeys on page 57

Reference Oscillator Tune on page 48
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User Preferences
From the Utility menu, you can set the following user preferences:

— Display Settings, below

— Power On and Preset on page 46

— Front Panel Knob Resolution on page 46
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Display Settings

X-Series signal generators are shipped from the factory with default display settings. Automated 
Test Environment (ATE) users may benefit from display settings other than the default settings. 
When the signal generator display is not required to be active for long periods of time, consider 
using the Screen Saver Mode to extend the life of the display. 

With the brightness set to minimum, the display may be too dark to see the softkeys. If this 
happens, use the figure above to locate the brightness softkey and adjust the value so that you 
can see the display.

Range: 0 to 100

Range: 1 to 12 hours, in 1 hour increments

Light Only: turns the display light off, leaving the text visible at a low intensity. 

Light & Text: turns the display light and the text off.
If the display remains unchanged for long periods of time, use this mode to 
prevent the text from burning the display.

When on, commands executed through 
the remote control bus update the signal 
generator display accordingly.

Bright without color

Utility > Display 

See also, Using Secure Display (Option 006) on page 460.

For details on each key, use key help 
as described on page 60.

page 460

Dark text on a light 
background.

Light text on a dark 
background.
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Power On and Preset

Front Panel Knob Resolution

Select the GPIB language desired after a preset.
See also, the Programming Guide and the SCPI Command 
Reference.

Utility > Power On/Preset 

Restores persistent settings  
(those unaffected by a power 
cycle*, preset, or recall) 
to their factory defaults.

Available only when 8648 is either the selected preset language or 
the selected remote language (see page 49).

*Caution 
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to 
nonvolatile memory, the X-Series signal generator should always be powered down either via the instrument’s front 
panel power button or the appropriate SCPI command. X-Series signal generators installed in rack systems and 
powered down with the system rack power switch rather than the instrument’s front panel switch display a Error -310 
due to the instrument not being powered down correctly.

Note
To define a user preset, set the instrument up as desired and press User Preset > Save User Preset.

Makes the increment value of the current function the active entry.

Utility >  
Instrument Adjustments 

The increment value and the step/knob ratio determine how much each 
turn of the knob changes the active function value.

For example, if the increment value of the active function is 10 dB and the 
step/knob ratio is 50 to 1, each turn of the knob changes the active 
function by 0.2 dB (1/50th of 10 dB). 

To change the amount for each turn of the knob, modify the increment 
value, the step/knob ratio, or both.

For details on each key, use key help 
as described on page 60.

 page 48.

 page 47.

Executes the ALC Modulator Bias Adjustment. When using 
the ALC in open loop mode, this compensates for open loop 
power drift due to temperature and humidity.

SCPI Commands:
:CALibration:ALC:MODulator:BIAS
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Setting Time and Date

The signal generator’s firmware tracks the time and date, and uses the latest time and date as its 
time/date reference point.

Figure 2-1 

Setting the Time or Date Forward

If you set the time or date forward, be aware that you are using up any installed time–based 
licenses, and that you are resetting the signal generator’s time/date reference point. When you 
set a new time or date that is later than the signal generator’s current reference point, that date 
becomes the new reference point. If you then set the date back, you run the risk described in the 
next section.

Setting the Time or Date Backward

When you set the time back, the signal generator notes that the time has moved back from the 
reference point. If you set the time back more than a few hours, you disable the signal generator’s 
ability to use time–based licenses, even if there is no license installed at the time that you set the 
time back. In this case, you can re-enable the signal generator’s ability to use time–based licenses 
by moving the clock forward to the original time or simply waiting that length of time.

Changing the time or date can adversely affect the signal generator’s ability to use time.

— based licenses, even if a time based license is not installed.

Utility >  
Instrument Adjustments
 >

Original time/date reference point

Time

New time/date reference point
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Reference Oscillator Tune

Tunes the internal VCTXCO oscillator frequency. 

The user value offsets the factory tuned value (the value is added to the 
factory calibrated DAC value). The tune value of 0 sets the factory 
calibrated value.

The range; –8192 to 8192, can be set by using the front panel keypad, 
knob or remote command. 

For details on each key, use key help 
as described on page 60.

See also the SCPI Command Reference.

Utility > Instrument Adjustments 
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Upgrading Firmware
For information on new firmware releases, go to http://www.keysight.com/find/upgradeassistant.

Remote Operation Preferences
For details on operating the signal generator remotely, refer to the Programming Guide.

GPIB Address and Remote Language

page 50

page 50

NOTES
USB is also available. It is not shown in the menu because it requires no configuration.
For details on using the instrument remotely, see the Programming Guide.

Select the desired language. 

This setting is not persistent and is cleared by performing an 
instrument Preset. In most cases, it is best to use Utility > Power 
On/Preset > Language for a permanent language change. See 
page 51. 

For details on each key, use key help as described on page 60.

Select On to view the associated SCPI command for a key press.

Select On to place a copy of every subsequent SCPI command 
executed in the log.
Select Off to stop logging. Selecting Off does not clear the log.
Press the Clear SCPI Log softkey to clear the log.
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Configuring the LAN Interface

Enabling LAN Services: “Browser,” “Sockets,” and “VXI–11” 

NOTES 
Use a 100Base–T LAN cable to connect the 
signal generator to the LAN. 

Use a crossover cable to connect the signal 
generator directly to a PC.

For details on using the instrument remotely, 
refer to the Programming Guide and to 
www.keysight.com and search on FAQs: 
Hardware Configurations and Installation for the 
Keysight MXG.

Utility > I/O Config

Values are listed in the 
Programming Guide

For details on each key, use key help as described on page 60.

 page 50.

Enable remote (browser) 
access to the 
instrument’s file system. Use a browser to control 

the signal generator.

Utility > I/O Config

For details on each key, use key help 
as described on page 60.

License Manager Server (On) 
allows updates of the 
instrument licenses, disable 
for additional instrument 
security.

For more information refer to 
the Programming Guide.
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Configuring the Remote Languages

Figure 2-2 N5166B/71B/72B/81B/82B

Utility > I/O Config

For details on each key, use key help 
as described on page 60.

Select the desired Remote language.

Refer to the SCPI Command Reference.
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Figure 2-3 N5173B/83B

Utility > I/O Config

For details on each key, use key help as described on page 60.

Select the desired Remote language.

Refer to the SCPI Command Reference.
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Remote Operation Preferences

Configuring the Preset Languages

Figure 2-4 N5166B/71B/72B/81B/82B

Utility > Power On/Preset 

For details on each key, use key help 
as described on page 60.

Select the desired Remote language.

page 46

Refer to the SCPI Command Reference.
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Figure 2-5 N5173B/83B

Utility > Power On/Preset 

For details on each key, use key help as described on page 60.

Select the desired Remote language.

page 46

Refer to the SCPI Command Reference.
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Enabling an Option

There are three ways to enable an option: 

— Download and run the License Manager software on a PC connected to the instrument from: 
www.keysight.com/find/LicenseManager.

— Place the license file (*.lic) on a USB flash drive:

1. Insert the USB flash drive into one of the instrument front panel USB ports.

2. Select the license file.

3. Press Install Licenses.

— Use SCPI commands, as described in the SCPI Command Reference.

With firmware version B.0.175 or later, the following options have changed to a new eight-digit 
format:

— Option 302 to Option N5180302B

— Option 320 to Option N5180320B

— Option 403 to Option N5180403B

— Option 430 to Option N5180430B

— Option 431 to Option N5180431B

— Option 432 to Option N5180432B

— Option UN7 to Option N5180UN7B

Only software options are changed to the eight-digit format. Hardware options remain with 
three-digits.
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Viewing Options and Licenses
Utility >  
Instrument Info

Service Software Licenses 

Waveform licenses from some 

Instrument options appear 
here. A check mark means that 
an option is enabled.

For details on each key, use key help 
as described on page 60.

Signal Studio applications appear here.

appear here.

Displays software options and information such as those 
that are internal to the instrument. With firmware B.01.75 or 
later, these options are an eight-digit format as shown in 
this figure.
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 Hardware Assembly Installation and Removal Softkeys
Utility > More  2 of 2 > 

For details on each key, use key help 
as described on page 60.

Verify output attenuator 
operation using a power 
meter at the RF Output.

Select either Enhanced Factory 
Calibration or Factory Calibration 
to calibrate your instrument.

The Enhanced Factory 
Calibration requires a spectrum 
analyzer in addition to a power 
meter.

The Factory Calibration uses only 
a power meter.

Whether a softkey 
is available depends 
on the model of signal 
generator.

Whether a softkey is 
available depends on 
the model of signal 
generator.
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3 Basic Operation

This chapter introduces fundamental front panel operation. For information on remote operation, 
refer to the Programming Guide.

— Presetting the Signal Generator on page 60

— Viewing Key Descriptions on page 60

— Entering and Editing Numbers and Text on page 61

— Setting Frequency and Power (Amplitude) on page 63

— Setting ALC Bandwidth Control on page 65

— Configuring a Swept Output on page 66

— Modulating the Carrier Signal on page 74

— Working with Files on page 76

— Reading Error Messages on page 88
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Presetting the Signal Generator

Viewing Key Descriptions

To return the signal generator to a known state, press either Preset or User Preset. 

Preset is the factory preset; User Preset is a custom preset** (see also, page 46). 

To reset persistent settings (those unaffected by preset, user preset, or power cycle*), 
press: Utility > Power On/Preset > Restore System Defaults.

*Caution 
To avoid the loss of data, GPIB settings, or current user instrument states that have not been permanently saved to nonvolatile memory, 
the instrument should always be powered down either via the instrument's front panel power button or the appropriate SCPI command. 
instrument's installed in rack systems and powered down with the system rack power switch rather than the instrument's front panel 
switch display a Error -310 due to the instrument not being powered down correctly.

**You can create more than one user preset by giving each saved state file a different name (see Figure 3-9 on page 86).

The Help hardkey enables you to display a description of any hardkey or softkey.
To display help text:

1. Press Help.
2. Press the desired key. 

The help displays and the key’s normal function does not execute. 
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Entering and Editing Numbers and Text

Entering Numbers and Moving the Cursor

Entering Alpha Characters

Data entry softkeys appear in various 
menus. If their meaning is not clear in 
context, use the help key (described on 
page 60) to display an explanation. Use the 
softkey next to the alpha table for help on 
the table.

Selecting data that accepts alpha 
characters, displays one of the menus 
shown at right.

Use the arrow keys or knob to highlight the 
desired letter, then press the Select 
hardkey (or the softkey next to the alpha table). To correct errors, use Bk Sp or Clear Text.

To terminate the entry, press the Enter softkey.

A subset of this menu appears for hexadecimal characters. The character menu displays only the 
letters A through F (use the numeric keypad for other values).

Up/down arrow keys increase/decrease a selected (highlighted) numeric value, and move the cursor vertically.

To specify a negative value, enter the
negative sign either before or after

Backspace moves the cursor to the left,
deleting characters as it goes.

Left/right arrow keys move the cursor horizontally.

Page up/down keys move tables of data up and down within the display area.

 

Use the number keys and decimal point to enter numeric data.

Note: Rotating the knob increases or
decreases a numeric value, changes a 
highlighted digit or character, or steps 
through lists or items in a row.

the numeric value (this key is a toggle).

For details on each key, see page 60.

Use the Select hardkey to choose part of an entry, as when entering alpha 
characters. In some menus, the Select key also acts as a terminator, and is 
equivalent to the Enter softkey.

See also “Front Panel Knob Resolution” on page 46.

to move the cursor 
within the active value 
rather than within the 
alpha table, turn the 
alpha table off.

Add/edit comments for saved 
instrument state files (see page 82).

Note: File names are limited to 25 characters.
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Example: Using a Table Editor

Table editors simplify configuration tasks. The following procedure describes basic table editor 
functionality using the List Mode Values table editor.

1. Preset the signal generator: Press Preset.

2. Open the table editor: Press Sweep > More > Configure List Sweep.

The signal generator displays the editor shown in the following figure.

3. Highlight the desired item: use the arrow keys or the knob to move the cursor. 

4. (Optional) Display the selected item in the active function area: Press Select.

5. Modify the value:

— If the value is displayed in the active function area, use the knob, arrow keys, or numeric 
keypad to modify the value.

— If the value is not displayed in the active function area, use the numeric keypad to enter the 
desired value (which then appears in the active function area).

6. Terminate the entry:

— If available, press the desired units.
— If units are not displayed, press either Enter (if available) or Select.

The modified item is displayed in the table.

Cursor

Table Editor Softkeys Table Editor Name Table Items

Displays the active item as you edit it. Highlighting indicates the selected item. To make this the active (editable) 
item, either press Select, or simply enter the desired value.

Table items are also 
called data fields.

Used to load, navigate, modify, and 
store table item values. For details 
on each key, use the key help: 
Press the Help hardkey and then 
the desired key.

Active Function Area

Current / Total Number of Pages

Indicates that 
another menu 
is available; to 
display the 
second menu, 
press More.

(vector models only)
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Setting Frequency and Power (Amplitude)

Figure 3-1 Frequency and Amplitude Softkeys

 

page 126

To display the next menu, press More.

For details on each key, use key help 
as described on page 60.

page 64

Refer to the SCPI Command Reference.

Opens the 
Atten/ALC 
Control 
menu.

Enables the optimize signal-to-noise ratio state (Optimize S/N) On or Off.
The optimize signal–to–noise softkey changes the attenuator and alc setting to provide 
optimal signal–to–noise performance; it does not change the RF output power. 
Caution: When the optimize signal-to-noise ratio state is enabled, some increased levels of 
harmonic distortion can occur. This increased harmonic distortion could degrade ACPR and 
EVM.
Note: This mode is mutually exclusive with attenuator hold (Atten Hold), and any modulation 
type. A settings conflict error will be generated if attentuator hold or any modulation is 
activated when optimize signal–to–noise is active (On).

page 65

This softkey sets a user determined 
maximum power level on the 
instrument that is persistent.

Available on vector 
models with BBG. 
Enables the instrument 
to select between two 
power levels with a 
hardware marker or 
using an external BNC.

page 102

In Amplitude mode, this menu is 
automatically displayed when entering 
a numeric value with the front panel 
keypad.

In Frequency mode, this menu is 
automatically displayed when entering 
a numeric value with the front panel 
keypad.

Sets the current relative 
phase of the RF output 
signal as the zero 
reference.
All subsequent 
adjustments are relative 
to this adjustment.

dBuVemf terminates 
the value as dBuV 
electromotive force. 
Emf is the output 
voltage with no load. 
This unit is external 
only. Internal 
representation as well 
as increment and 
decrement values are 
in dBm. 

Note: dBuV, mV, and 
nVemf behave similarly 
(i.e. Values are external 
only. Internal 
representation as well 
as increment and 
decrement values are 
in dBm).

Enables the mode to improve non-harmonics performance (low spurs mode). 

Note: When this mode is enabled, the instrument switching speed and behavior of 
the source’s settled signal are affected.

Modifies the attenuator and ALC settings 
for optimal performance. It does not 
change the RF output power.

Available on 
vector models.
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Example: Configuring a 700 MHz, −20 dBm Continuous Wave Output

1. Preset the signal generator.

The signal generator displays its maximum specified frequency and minimum power level (the 
front panel display areas are shown on page 27).

2. Set the frequency to 700 MHz: Press Freq > 700 > MHz. 

The signal generator displays 700 MHz in both the FREQUENCY area of the display and the 
active entry area.

3. Set the amplitude to −20 dBm: Press Amptd > –20 > dBm.

The display changes to −20 dBm in the AMPLITUDE area of the display, and the amplitude 
value becomes the active entry. Amplitude remains the active function until you press another 
function key.

4. Turn on the RF Output: Press RF On/Off.

The RF Output LED lights, and a 700 MHz, −20 dBm CW signal is available at the RF OUTPUT 
connector.

Using an External Reference Oscillator

When using an external reference, you can select either narrow or wide bandwidth mode.

 

For details on each key, use key help as described on page 60.

Range: 1 to 50 MHz
For guaranteed operation below 2 MHz, select Narrow bandwidth; in Wide bandwidth, 
operation using frequencies below 2 MHz is not guaranteed.

Freq > More

Figure 3-2 illustrates the better close in phase noise of the wide bandwidth mode. If the 
external reference you are using is noisy or spurious, use the narrow bandwidth mode.
With Wide bandwidth selected, if you select a frequency less than 2 MHz, the signal 
generator displays a warning message.

uses the signal generator’s internal reference oscillator.

uses the REF IN connector to get it’s Frequency Reference. Note: An error 
screen is displayed if the reference is not connected or is tuned to the wrong 
frequency.
uses the signal generator’s internal reference unless a signal is present at 
the rear panel REF IN connector. If an external signal is present, that signal is 
used as  the reference.

uses the baseband generator clock (BBG) as the reference oscillator source. 
Available on vector models with BBG.
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Figure 3-2 Using an External Reference Oscillator

Setting ALC Bandwidth Control

Figure 3-3 Amplitude Softkeys

To display the next menu, press 
More.

For details on each key, use key help 
as described on page 60.

Refer to the SCPI Command Reference.

Enables the 
automatic 
ALC 
bandwidth 
mode (Auto).
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Configuring a Swept Output
The signal generator has two methods of sweeping through a set of frequency and amplitude 
points:

Step sweep (page 67) provides a linear or logarithmic progression from one selected frequency, 
amplitude, or both, to another, pausing at linearly or logarithmically spaced points (steps) along 
the sweep. The sweep can progress forward, backward, or manually. 

List sweep (page 69) enables you to enter frequencies and amplitudes at unequal intervals, in 
nonlinear ascending, descending, or random order. List sweep also enables you to copy the current 
step sweep values, include an Arb waveform in a sweep (on a vector instrument), and save list 
sweep data in the file catalog (page 81).

Figure 3-4 Sweep Softkeys

Sweep without waiting for  
a trigger at each point.  
Point Trigger pauses for the dwell 
time prior to the first sweep. See 
page 130.

Apply a TTL/CMOS signal to the 
Trigger In connector.

Periodically issue a trigger event to 
whatever selects it as a source.

Using timer trigger with single 
sweep results in a delay prior to the 
first sweep. See page 130.

Trigger on a remote command.

Down sweeps from 
stop to start 
frequency/amplitude.
 
Up sweeps from start 
to stop 
frequency/amplitude.

page 69

The selected sweep type determines the displayed parameter.  
Selecting step sweep also displays the step spacing (Lin or Log).

On vector models:
Available when 
Sweep Type = List

page 73

During a sweep, the swept parameter (frequency, amplitude, or both) turns grey and changes as the parameter sweeps.

Progress Bar: Note that very fast sweeps 
can appear to sweep randomly or 
backward.

page 67

For details on each key, use key help as described on page 60.

 page 67
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Routing Signals

Sweep > More > More > Route Connectors

Step Sweep

Step sweep provides a linear or logarithmic progression from one selected frequency, or amplitude, 
or both, to another, pausing at linearly or logarithmically spaced points (steps) along the sweep. 
The sweep can progress forward, backward, or be changed manually. 

Figure 3-5 Signal Routing Softkeys

These softkeys are 
only available for 
the vector models 
with a BBG.

Routes non 
Step or List 
Sweep signals 
(i.e. SCPI 
command 
development.

Source Settled 
is not affected 
by Trig Out 
Polarity Neg 
Pos softkey 
selection.

Routes Step or 
List Sweep 

For details on each key, use key help as described on page 60.

Opens a menu for 
routing Markers 1 
through 4 to the 
rear panel 
baseband BNC 
connectors.

Routes a signal to the Trig Out (Trig 1 or Trig 2) rear panel 
connectors as follows:

None:  No signals are routed to Trig 1 or Trig 2 BNCs

Sweep Trigger Out: Sweep Trigger Out signal (trigger 
handshake)

Source Settled: Source Settled signal

Pulse Sync: Pulse Modulation Synchronization signal

Pulse Video: Pulse Modulation Video signal

LXI: LXI Trigger Output

Sweep Run: Sweep Run signal (sweep is running)

Other Trigger BNC: The signal on the other Trigger BNC

Pulse BNC: The signal on the PULSE IN BNC

Swept Func Done: Swept Function Sweep Done signal
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Figure 3-6 Sweep Softkeys

Example: Configuring a Continuous, Linear Step Sweep

1. Preset the instrument and open the Sweep/List menu: Press Preset > SWEEP.

Because continuous is the default sweep repeat selection, and linear is the default step 
spacing selection, you do not need to set these parameters.

2. Open the step sweep menu: Press Configure Step Sweep.

3. Set the following parameters:

4. Sweep both frequency and amplitude: Press Return > Return > Sweep > Freq Off On > Amptd 
Off On.

Output: A signal that continuously sweeps from 500 to 600 MHz and from −20 to 0 dBm, with a dwell time of 
500 ms at each of six equally spaced points

Start frequency 500 MHz: Press Freq Start > 500 > MHz

Stop frequency 600 MHz: Press Freq Stop > 600 > MHz

Amplitude at the beginning of the sweep, −20 dBm: Press Amptd Start > −20 > dBm

Amplitude at the end of the sweep, 0 dBm: Press Amptd Stop > 0 > dBm.

6 sweep points: Press # Points > 6 > Enter

Dwell time at each point, 500 milliseconds: Press More > Step Dwell > 500 > msec

Dwell Time = the time that the signal is settled and you can make 
a measurement before the sweep moves to the next point.

(Point to point time is the sum of the value set for the dwell plus 
processing time, switching time, and settling time.) 

Lin = steps equally spaced over the sweep; the output 
changes linearly.

Log = step spacing increases logarithmically over the 
sweep; the output changes exponentially.

Step Sweep and List Sweep dwell times are set 

For details on each key, use key help 
as described on page 60.

Sets the step size for a linear step sweep in frequency (the 
difference between frequency points).

NOTE: Setting the step size will determine the number of 
points in the step sweep based on the current start and stop 
frequencies. Due to the integer number of step points, the 
step size may be adjusted in order to yield a true linear 
sweep between the start and stop frequencies.

Enables protection for the mechanical attenuator by automatically turning on 
Atten Hold during frequency and/or power step sweeps.

This may cause unleveled RF output to occur for certain sweep configurations. 
Disabling this attenuator protection will allow the sweep to optimally set both 
the automatic leveling control (ALC) and output attenuation at each sweep 
point.

When the attenuator protection is disabled, the step dwell time will be set to a 
minimum of 50 ms as a precaution. 

[:SOURce]:SWEep:ATTen:PROTection[:STATe] ON|OFF|1|0
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A continuous sweep begins, from the start frequency/amplitude to the stop 
frequency/amplitude. The SWEEP annunciator displays, and sweep progress is shown in the 
frequency display, the amplitude display, and the progress bar.

5. Turn the RF output on: Press RF On/Off. 

The RF LED lights, and the continuous sweep is available at the RF Output connector.

List Sweep

List sweep enables you to enter frequencies and amplitudes at unequal intervals in nonlinear 
ascending, descending, or random order. List sweep also enables you to copy the current step 
sweep values, include a waveform in a sweep (on a vector instrument), and save list sweep data in 
the file catalog (page 81). Dwell time is editable at each point. For fastest switching speeds, use list 
sweep.

Figure 3-7 List Sweep Configuration Softkeys and Display

see page 70

The selected sweep determines which dwell time the signal generator uses. Step Sweep dwell 
time is the same at each point; List Sweep dwell time can be different at each point.

Dwell Time = the time that the signal is settled and you can make a measurement before the 
sweep moves to the next point.

Point–to–Point Time = the sum of the value set for the dwell plus processing time, switching 
time, and settling time. 

Each line defines the 
corresponding point in 
the sweep. For example, 
line 1 defines point 1.

page 67

Available only on vector models,  
and  
only when Sweep Type = List.

Displays the selected 
sweep type parameters 
(see page 70)

Vector models only

page 67

For details on each key, use key help 
as described on page 60.
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Example: Configuring a List Sweep Using Step Sweep Data

1. Set up the desired step sweep, but do not turn the sweep on. This example uses the step 
sweep configured on page 68.

2. In the SWEEP menu, change the sweep type to list:  
Press SWEEP > Sweep Type List Step to highlight List. 

The display shows sweep list parameters, as shown below.

3. Open the List Sweep menu: Press More > Configure List Sweep.

4. Clear any previously set values from the menu and load the points defined in the step sweep 
into the list: Press More > Preset List > Preset with Step Sweep > Confirm Preset. 

The display updates with the values loaded from the step sweep, as shown.

5. Sweep frequency and amplitude: Press SWEEP (hardkey) > Sweep > Freq Off On > Amptd Off 
On.

Setting the sweep turns on the sweep function; a continuous sweep begins. On the display, 
the SWEEP annunciator appears, and the progress bar shows the progression of the sweep.

6. If not already on, turn the RF output on: Press RF On/Off.  
The RF Output LED lights, and a continuous sweep is available at the RF OUTPUT connector.

Example: Editing List Sweep Points

If you are not familiar with table editors, refer to page 62.

1. Create the desired list sweep. This example uses the list sweep created in the previous 
example.

Vector Models:

Presetting the list clears any 
previously selected waveforms. 

For information on selecting a list 
sweep waveform, see “Example: 
Editing List Sweep Points” on 
page 70.

Waveforms are available 
only on vector models.
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2. If sweep is on, turn it off. Editing list sweep parameters with sweep on can generate an error. 

3. Ensure that the sweep type is set to list: Press SWEEP > Sweep Type List Step to highlight 
List. 

4. In the List Mode Values table editor, change the point 1 dwell time (defined in row 1) to 100 
ms:

a. Press More > Configure List Sweep.
b. Highlight the point 1 dwell time.
c. Press 100 > msec.

The next item in the table (the frequency value for point 2) highlights.

5. Change the selected frequency value to 445 MHz: Press 445 > MHz.

6. Add a new point between points 4 and 5: Highlight any entry in row 4 and press Insert Row. 

This places a copy of row 4 below row 4, creating a new point 5, and renumbers subsequent 
rows.

7. Shift frequency values down one row, beginning at point 5: Highlight the frequency entry in 
row 5, then press More > Insert Item.

This places a copy of the highlighted frequency value in row 6, shifting the original frequency 
values for rows 6 and 7 down one row. The new row 8 contains only a frequency value (the 
power and dwell time entries do not shift down).

8. Change the still active frequency value in row 5 to 590 MHz: Press 590 > MHz. The power in 
row 5 is now the active parameter.

9. Insert a new power value (−2.5 dBm) for point 5, and shift down the original power values for 
points 5 and 6 by one row: Press Insert Item > −2.5 > dBm. 

10.To complete the entry for point 8, insert a duplicate of the point 7 dwell time by shifting a copy 
of the existing value down: Highlight the dwell time in row 7 and press Insert Item.

11.For an analog instrument, go to step 14. For a vector instrument, continue with step 12.

12.Select a waveform for point 2:

a. Highlight the waveform entry for point 2 and press the More > Select Waveform. 
The signal generator displays the available waveforms, as shown in the following example.

b. Highlight the desired waveform (in this example, SINE_TEST) and press either the Select 
hardkey or the Select Waveform softkey.

Either select a waveform, 
page 60

or  

select no modulation.



 72                                                         Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

Basic Operation
Configuring a Swept Output

13.As desired, repeat step 12 for the remaining points for which you want to select a waveform. 
The following figure shows an example of how this might look.

14.Turn sweep on:  
Press Return > Return > Return > Sweep > Freq Off On > Amptd Off On > Waveform Off On.

15.If it is not already on, turn the RF output on:  
Press RF On/Off. 

The SWEEP annunciator appears on the display, indicating that the signal generator is 
sweeping, and the progress bar shows the progression of the sweep. 

Example: Using a Single Sweep

1. Set up either a step sweep (page 68) or a list sweep (page 70).

2. In the List/Sweep menu, set the sweep repeat to single:  
Press Sweep Repeat Single Cont to highlight Single.

Sweep does not occur until you trigger it.

Note that the WINIT annunciator appears on the display, indicating that the sweep is waiting 
to be initiated.

3. If not already on, turn the RF output on: Press RF On/Off.

4. Initiate the sweep: Press Single Sweep.

A single repetition of the configured sweep is available at the RF Output connector. 

As the signal generator sweeps, the SWEEP annunciator replaces WINIT on the display, and the 
progress bar shows the progression of the sweep. 

At the end of the sweep, there is no progress bar, and the WINIT annunciator replaces SWEEP.

If the instrument is in manual sweep (page 73), the active row (row 6 in the 
figure above) is the selected (manual) point, and the signal generator 
outputs the settings for that selection when the RF output is on.

The empty entry is equivalent to 
choosing CW (no modulation).
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Example: Manual Control of Sweep

1. Set up either a step sweep (page 68) or a list sweep (page 70).

2. In the Sweep/List menu, select a parameter to sweep: Press Sweep > parameter > Return.

3. Select manual mode: Press More > Manual Mode Off On.

When you select manual mode, the current sweep point becomes the selected manual point.

4. If it is not already on, turn the RF output on: Press RF On/Off.

5. Select the desired point to output: Press Manual Point > number > Enter.

The progress bar changes to indicate the selected point.

6. Use the knob or arrow keys to move from point to point. As you select each point, the RF 
output changes to the settings in that selection.

The parameters of the selected sweep point (point 3 
of 6 in this example) define the signal available at the 
RF Output connector.

When you enter a manual point, 
the progress bar moves to and 
stops at the selected point.

The SWMAN annunciator 
indicates that the sweep 
is in manual mode.

When you turn manual mode on, the 
current sweep point becomes the 
manual point.

The currently sweeping 
parameter stops and 
displays the selected point.
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Modulating the Carrier Signal
To modulate the carrier signal, you must have both 

— an active modulation format 
and

— modulation of the RF output enabled

Example

1. Preset the signal generator.

2. Turn on AM: Press AM > AM Off On (requires Option UNT).

You can turn on the modulation format before or after setting signal parameters.

The modulation format generates, but does not yet modulate the carrier signal.

Once the signal generates, an annunciator showing the name of the format appears, indicating 
that a modulation format is active.

3. Enable modulation of the RF output: Press the Mod On/Off key until the LED lights.

If you enable modulation without an active modulation format, the carrier signal does not 
modulate until you subsequently turn on a modulation format.

4. To make the modulated carrier available at the RF output connector, press the RF On/Off key 
until the LED lights.

To turn modulation off, press the Mod On/Off key until the LED turns off. 
 
When the Mod On/Off key is off, the carrier signal is not modulated, even 
with an active modulation format.

See also: “  Analog Modulation (Option UNT)” on page 179 
“  Pulse Modulation (Options UNW and N5180320B)” on page 189 
“I/Q Modulation” on page 265

 

Annunciator indicates active AM modulation

AM format on 

A lit LED indicates that any active 
modulation format can modulate 
the carrier.
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Simultaneous Modulation

The Keysight X-Series signal generators are capable of simultaneous 
modulation. All modulation types (AM, FM, fM, Pulse, and I/Q) may be 
simultaneously enabled, but there are some exceptions. Refer to Table 3-1.

Table 3-1 Simultaneous Modulation Type Combinations

AMa

a. Linear AM and Exponential AM cannot be enabled simultaneously. Refer to Chapter 6.

FM fM Pulseb

b. Pulse modulation requires Option UNW. Refer to Chapter 7.

I/Q

AM -- x x x x

FM xc

c. FM and fM cannot be enabled simultaneously.

-- not 
applicable

x x

fM xc not 
applicable

-- x x

Pulse x x x -- x

I/Q x x x x --
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Working with Files

— File Softkeys on page 77

— Viewing a List of Stored Files on page 78

— Storing a File on page 80

— Loading (Recalling) a Stored File on page 81

— Moving a File from One Media to Another on page 82

— Working with Instrument State Files on page 82

— Selecting the Default Storage Media on page 87

The signal generator recognizes several types of files, such as instrument state files, license files, 
and list sweep files. Files can be stored either in the signal generator’s internal storage or on the 
USB media. This section provides an overview of how to navigate the signal generator’s file menus, 
and how to view, store, load, and move files.

The Keysight CXG, MXG, and EXG nonvolatile internal memory is allocated according to a Microsoft 
compatible file allocation table (FAT) file system. Refer to the Programming Guide.

See also: Storing, Loading, and Playing a Waveform Segment on page 209.
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File Softkeys

Instrument operating parameters (see page 82).

Sweep data from the List Mode Values table editor.

User flatness calibration corrections.

Note: Available file types depend on the installed options.

For details on each key, use key help as described on page 60.

Deletions require 
confirmation.

Available only with USB connected 
(i.e. Without external USB connected, 
softkeys are greyed out).

page 87

This key changes, depending on 
the selected file. See 

Shows the current directory

page 82

page 82

Requires 
confirmation

The display indicates when the current directory is the default storage path.  
For information on setting the default storage path, see page 87.

When you connect USB media to the instrument, the signal generator displays the USB Media menu and the message External USB Storage attached. When you 
disconnect the USB media, the message External USB Storage detached displays. When you open the External Media menu without USB media connected, the 
signal generator displays the message External Media Not Detected.

The signal generator does not 
format USB media or change file 
permissions. Use a computer to 
perform these operations.

Available only when the 
current directory is not the 
top level directory.

Display internal or USB 
files, depending on the 
selected storage media. 

page 78

Displays IQ Files

Displays FSK 
Files

Displays FIR 
Files

Displays a list of 
Pulse Train files.

Displays Bit 
Files

page 459
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ARB File Softkeys

Viewing a List of Stored Files

The information in this section is provided with the assumption that default storage media is set to 
Auto, as described on page 87.

Viewing a List of Files Stored in the Signal Generator

1. If USB media is connected, disconnect it. The signal generator’s storage media switches to 
internal, so you can now use the file catalogs to see files stored in the signal generator.

2. Select the desired file catalog: Press File > Catalog Type > desired catalog (in this example, 
All). The selected files appear in alphabetical order by file name, as shown in the following 
figure. 

For details on each key, use key help as described on page 60.

Waveform files and their associated marker 
and header information.

Note: Available file types depend on the installed options.

The selected file catalog and 
the storage media
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Viewing a list of Files Stored on USB Media

With USB media connected, you can view files on USB media using either the file catalogs, which 
can display only a selected type of file, or the USB File Manager, which displays all files.

Using the File Catalogs:

— With the USB media connected, select the desired file catalog: press  > Catalog Type > 
desired catalog. The selected files appear in alphabetical order by file name. 

Using the USB File Manager:

— With USB media connected, open the USB File Manager: press File > More > 
USB File Manager.  
The instrument displays the default directory on the USB Media, as shown in the following 
figure. Note that when you attach USB media, the display goes directly to this menu.

Use the Page Up and 
Page Down hardkeys to scroll 
through the contents of the 
directory.
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Storing a File

Several menus enable you to store instrument parameters. For example, you can store instrument 
states, lists, and waveforms.

— An instrument state file contains instrument settings. For this type of file, use the Save hardkey 
shown in Figure 3-8 on page 83.

— For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Use this menu to enter the file name, 
as described on page 61.

For details on each key, use key help as described on page 60.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Save From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

File Length (including extension)

Internal Media: 25 characters

USB Media: 39 characters
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Loading (Recalling) a Stored File

There are several ways to load (recall) a stored file.

— For an instrument state file, use the Recall hardkey shown in Figure 3-8 on page 83.

— For other types of data, use the Load/Store softkey (shown below) that is available through the 
menu used to create the file. 

Loading a File From USB Media

To load a file from USB media, use the USB file manager shown below.

File Type
List
State
Waveform
User Flatness
User Preset
Pulse Train

Recall From
Sweep menu
Save menu
Mode menu
Amplitude menu
User Preset menu
Pulse Train menu

This key changes, depending 
on the selected file. 

If the signal generator does not recognize the file, 
you must select how the file is to be used.

File Type
List
State
Waveform
User Flatness
User Preset
License
Pulse Train

Extension
.list
.state
.waveform
.uflat
.uprst
.lic
.ptrain

Pressing Select with file highlighted...
loads list and starts sweep
load instrument state
loads and plays waveform
loads and applies user flatness
loads and executes user preset
installs purchased license
loads and applies pulse train

For details on each key, use key help as described on page 60.

 
  Copy & Select User Flatness
  Copy & Play Waveform
  Copy & Play Sequence
  Enter Directory
  Recall Instrument State
  Load List
  Load Pulse Train
  Install licenses
  No action (USB disconnected)
  Use As

File > Catalog Type > <type> > More > USB File Manager 
or
File > More > USB File Manager
or
Insert the USB media
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Moving a File from One Media to Another

Use the USB Media Manager to move files between USB and internal media.

Working with Instrument State Files

— Saving an Instrument State on page 84

— Saving a User Preset on page 84

— Recalling an Instrument State on page 84

— Recalling an Instrument State and Associated Waveform File on page 85

— Recalling an Instrument State and Associated List File on page 85

— Moving or Copying a Stored Instrument State on page 86

Selecting a waveform or 
an unknown file type 
displays this softkey.

File > Catalog Type > <type> > More > USB File Manager
or
File > More > USB File Manager
or
Insert the USB Flash Drive (UFD)

For details on each key, use key help as described on page 60.

This key changes, 
depending on the selected 
file. See page 81

Whether a menu is available 
depends on the selected file. 

Requires confirmation

Catalog Type Menu
page 77

Requires confirmation

Moves up one directory level 

These 
softkeys are 

These 
softkeys 

If the file type is recognized 
the “Filename.xxx copied 
to Internal Storage” is 
displayed.
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Figure 3-8 Save and Recall Softkeys

Table 3-2 

The following information is not stored in a state file:

System Security Level Sweep lists Hostname Remote 
Language

Step increment values

System Security Level Display Pulse Train lists IP Address FTP Server ARB Files

System Security Level State Display State On/Off Subnet Mask Manual DHCP MAC

Web Server (HTTP) Files Default 
Gateway

VXI–11 SCPI User Power 
Correction

Sockets SCPI (TELNET) I/Q Calibration Data

When saved to the signal generator, instrument settings 
(states) save to instrument state memory*. Instrument 
state memory is divided into 10 sequences (0 through 9); 
each sequence comprises 100 registers (00 through 99).

Delete softkeys in the Save and Recall menus enable you 
to delete the contents of a specific register, or the contents 
of all sequences in the state file catalog. 

The signal generator requires that you confirm a deletion.

*Caution 
To avoid the loss of data, GPIB settings, or current user 
instrument states that have not been permanently saved 
to nonvolatile memory, the instrument should always be 
powered down either via the instrument's front panel 
power button or the appropriate SCPI command. 
instrument's installed in rack systems and powered down 
with the system rack power switch, rather than the 
instrument's front panel switch display a Error -310 due to 
the instrument not being powered down correctly.For details on each key, use key help 

as described on page 60.
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Saving an Instrument State

1. Preset the signal generator and set the following:

2. (Optional, vector models only) Associate a waveform file with these settings: 

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight the desired file and press Select Waveform. If the file is not listed, you must first 

move it from internal or external media to BBG media, see page 209. 

3. Select the desired memory sequence (for this example, 1): Press Save > Select Seq > 1 > 
Enter.

4. Select the desired register (in this example, 01): Press Select Reg > 1 > Save Reg. 

If a waveform is currently selected, saving the instrument state also saves a pointer to the 
waveform file name. 

5. Add a descriptive comment to sequence 1 register 01: 

Press Add Comment to Seq[1] Reg[01], enter the comment and press Enter. The comment 
appears in the Saved States list when you press Recall. If the instrument state has an 
associated waveform, entering the waveform name in the comment makes it easy to identify 
which instrument state applies to which waveform. 

Saving a User Preset

A user preset is a special type of instrument state file.

1. Preset the signal generator and set as desired.

2. Press User Preset > Save User Preset.

This saves a state file named USER_PRESET, which the signal generator recognizes as 
containing user preset information.

You can set up several preset conditions under different names:

1. After you save a user preset, rename it to something other than USER_PRESET (see page 86). 

2. Save as many user presets as you wish, renaming the USER_PRESET file each time.

3. Give the desired file the name USER_PRESET.

Recalling an Instrument State

1. Preset the signal generator.

2. Press Recall.

The Select Seq softkey shows the last sequence used, and the display lists any states stored 
in the registers in that sequence; RECALL Reg is the active entry. 

3. Select the desired instrument state: 

• Frequency: 800 MHz • Amplitude: 0 dBm • RF: on
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If the desired state is listed in the currently selected sequence, press desired number > Enter. 
If not, press Press Select Seq > desired number > Enter > RECALL Reg > desired number > 
Enter.

Recalling an Instrument State and Associated Waveform File 

1. Ensure that the desired waveform file exists, and that it is in BBG media (page 209). 

If the waveform file is not in BBG media, this procedure generates an error.

Recalling an instrument state with an associated waveform file recalls only the waveform 
name. It does not recreate the waveform file if it was deleted, or load the file into BBG media if 
it is in internal or USB media.

2. Recall the desired instrument state (see previous example).

3. View the waveform file name recalled with the instrument state: press Mode > Dual ARB.

The name is displayed as the selected waveform. 

4. Turn on the waveform file: Press Mode > Dual ARB > ARB Off On.

Recalling an Instrument State and Associated List File 

Recalling an instrument state recalls only the list sweep setup. It does not recall the frequency 
and/or amplitude values. Because you must load the list file from the file catalog, when you store a 
list file, be sure to give it a descriptive name (up to 25 characters).

1. Recall the desired instrument state (see previous example).

2. Load the desired list file: 

a. Press Sweep > More > Configure List Sweep > More > Load/Store.

b. Highlight the desired file and press Load From Selected File > Confirm Load From File.

Editing The Comment on an Instrument Comment

Use the following steps to change a comment on an instrument state saved using the Save key. 
This is not the file name that appears in the State catalog (which is the file’s memory location).

1. Press Save

2. Highlight the desired register

3. Press Edit Comment In Seq[n] Reg [nn].

4. Press Re–SAVE Seq[n] Reg[nn]. 

This overwrites previously saved instrument state settings with the new comment. 
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Moving or Copying a Stored Instrument State

Figure 3-9 Instrument State File Catalog

A user–created state file’s default name is its memory location (sequence and register).

To move the file, rename it to the desired sequence and register; you can not give a file the same 
name as an existing file. If you rename a state file to something other than a valid sequence/register 
name, the file does not appear in either the Save or Recall menu.

Sequence Register

The signal generator recognizes only the file named USER_PRESET as user preset information (page 84). 
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Selecting the Default Storage Media

You can configure the signal generator to store user files to either the internal storage or to external 
USB media. To automatically switch between USB media and internal storage, depending on 
whether USB media is attached, select Automatically Use USB Media If Present. To avoid storing 
any confidential information in the instrument, select Use Only USB Media. To avoid storing any 
confidential information to USB media, select Use Only Internal Storage.

This selection is unaffected by a power cycle or preset.

File > More > 

Current 
selection

Memory in the instrument is used, and USB media is ignored.

Media attached to the front panel USB connector is used, and no user 
data is stored to internal storage.

This is the recommended selection. When USB media is attached to the 
front panel, it is the selected media; when USB media is not attached, 
internal storage is used.

For details on each key, use key help as described on page 60.

Select the directory on the USB media to be used for all file operations 
when USB media is attached and enabled.
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Reading Error Messages
If an error condition occurs, the signal generator reports it to both the front panel display error 
queue and the SCPI (remote interface) error queue. These two queues are viewed and managed 
separately; for information on the SCPI error queue, refer to the Programming Guide.

Error Message Format

Characteristic Front Panel Display Error Queue

Capacity (#errors) 30

Overflow Handling Drops the oldest error as each new error comes in.

Viewing Entries Press: Error > View Next (or Previous) Error Page

Clearing the Queue Press: Error > Clear Error Queue(s)

Unresolved Errorsa

a. Errors that must be resolved. For example, unlock.

Re–reported after queue is cleared.

No Errors
When the queue is empty (every error in the queue has been read, or the queue is cleared), the 
following message appears in the queue: 
No Error Message(s) in Queue    0 of  0

Error Number Error Message
Error Description 
(May be truncated on the 

−222        Data out of range;   value clipped to lower limit.

Indicates that the user has entered a deviation, depth, or internal 
source frequency that is beyond the specific limits 

Explanation is provided in the Error Message file (see page 453) 
(This is not displayed on the instrument)

Message number and longer description

new indicates a message generated 
since messages were last viewed.

The annunciator indicates an unviewed message.

Error messages appear in the lower left corner 
of the display as they occur.
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Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in 
that chapter.

— Using the Dual Power Meter Display on page 90

— Using the USB Pass Through Commands on page 97

— Using the Power Meter Servo on page 99

— Using Flatness Correction on page 102

— Using Internal Channel Correction (N5166B/72B/82B Only) on page 111

— Using External Leveling (N5173B/83B Only) on page 115

— Using Unleveled Operating Modes on page 122

— Using an Output Offset, Reference, or Multiplier on page 126

— Using Free Run, Step Dwell, and Timer Trigger on page 130

— Using a USB Keyboard on page 132



 90                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

Optimize Performance
Using the Dual Power Meter Display

Using the Dual Power Meter Display
The dual power meter display can be used to display the current frequency and power of either one 
or two power sensors. The display outputs the current frequency and power measured by the power 
sensors in the larger center display and in the upper right corner of the display. Refer to Figure 4-2, 
Figure 4-2, and Figure 4-3.

Figure 4-1 Dual Power Meter Display with Power Sensors A and B Calibrated

Figure 4-2 Dual Power Meter Display Menu

Once turned on, the 
power meter 
readings are always 
visible, even if 
another instrument 
feature is selected 
(i.e. Sweep, AM, 
etc.).

This area is the main 
display for the dual 
power meter 
calibration frequency 
and current power 
measured.
If channel A or 
channel B power 
sensors or both are 
displayed, and the 
AMPTD or the FREQ 
softkeys are pressed, 
the large power 
meter measurements 
remains displayed.
After the first 
connection, if the 
connection is 
successful, the 
model number and 
serial number of the 
power sensor is 
displayed.

For details on each key, use key help as described on page 60.

See page 91

Enables the power sensor on  
channel A.

Enables the power sensor on 
channel B.

Channel B is configured similarly to 
channel A. See page 91

For details on each key, use key help 
as described on page 60.
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Figure 4-3 Configuring the Power Sensor Channels

Example: Dual Power Meter Calibration

In the following example a U2004A USB Power Sensor is connected to channel A and a N1912A P–
Series Power Meter and 8482A Power Sensor are connected to channel B and are zeroed and 
calibrated, as required.

On the signal generator:

AUX Fctn > Power Meter 
Measurements 

Sockets LAN: Sets the 
IP port to 5025 (standard) 
or 5023 (telnet) 
programming.

Sets the power meter’s IP 
address or LAN–GPIB 
gateway’s IP address (Sockets 
LAN and VXI–11 LAN only).

Whether a softkey is available 
depends on the selected 
Connection Type. 

VXI–11 LAN: Opens a menu for 
entering a device name for the 
power meter being used.

Enables the power meter 
connection type: Sockets 
LAN, VXI–11 LAN, or USB.

Note: The VXI–11 softkey is 
used to communicate 
remotely with a power meter 
that has a GPIB connector 
via LAN–GPIB gateway.

USB U2000A Series Power 
Sensors do not require the 
sensor to be calibrated.

The CXG/MXG/EXG use 
the USB U2000A Series 
Power Sensor’s “Internal” 
zero. Refer to the USB 
U2000A Series Power 
Sensor’s documentation.

Zero Sensor and Calibrate 
Sensor softkeys are 
inactive during a 
measurement.

Selects the frequency that channel A has 
been calibrated to.

Selects the channel on the external 
power meter that the power sensor 
is connected to.

Enables a power offset in dB for 
the current channel.

Enables averaging. Instrument 
default is Auto with 1024 points.

Note: This figure illustrates channel A. Channel B is similar.

For details on each key, use key help as 
described on page 60.
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1. Setup for Step Sweep. “Configuring a Swept Output” on page 66.

2. Connecting the Channel A power sensor: Connect USB sensor to the signal generator. The 
CXG/MXG/EXG should display a message across the bottom that reads similar to:  
USB TMC488 device (USB POWER SENSOR,MY47400143) connected

Figure 4-4    CXG/MXG/EXG Displays Connection to U2000 USB Power Sensor

3. Press Aux Fctn > Power Meter Measurements > Channel A Setup > Connection Settings > 
Connection Type > USB Device (None) > USB POWER SENSOR (MY47400143)

4. Press Return > Zero Sensor

A diagnostic dialog box appears the initial time that a U2000 Series power sensor with a 
different serial number is connected to the signal generator (refer to Figure 4-5). After the 
U2000 has been recognized by the signal generator, the U2000 power sensor is saved as a 
softkey in the instrument and the dialog box in Figure 4-5 won’t be displayed (press DONE, if 
you see this message).

Figure 4-5    Diagnostic Dialog Box for USB Sensor 

A Running Calibration(s) bar is displayed on the signal generator. Refer to Figure 4-6 on 
page 93.

Verify RF Output power is off before continuing.
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Figure 4-6    Running Calibration(s) Bar (Zeroing Sensor)

Figure 4-7    Diagnostic Dialog Box Displayed for U2000 Power Sensor

5. Press Return > Return > Channel A to On

The current power meter sensor reading should be displayed in the ChA portion of the 
instrument's display and in the upper right portion of the display under Power Meter. Refer to 
Figure 4-8.

Figure 4-8    Channel A Power Sensor Displayed on CXG/MXG/EXG

The U2000 Series USB Power Sensor, does not require a 50 MHz 
calibration. If a calibration is attempted with the U2000 Series Power 
Sensors, the signal generator displays a message reading:  
The U2000 series power sensor does not require a 50 MHz 
calibration. Refer to Figure 4-7 on page 93.

For details on 
each key, use key 
help as described 
on page 60.

For details on 
each key, use key 
help as described 
on page 60.

For details on 
each key, use key 
help as described 
on page 60.
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6. On the N1912A P–Series Power Meter (Channel B power sensor): Connect the N1912A P–
Series Power Meter to the LAN.

7. Connect the power meter sensor to channel B of the power meter.

8. Connect the power sensor input to the 50 MHz reference of the power meter.

9. Press Channel B Setup

10.Press Connection Settings > Sockets

11.Press IP Address > IP address > Enter

Figure 4-9    Channel B Power Sensor with IP Address Entered

12.Press Return > Channel Settings > External Power Meter Channel to B.

It is recommended, but not required to use the channel B on the N1912A. 
This provides continuity with the signal generator’s dual display. For this 
example, the U2004A has already used up the channel A position on the 
signal generator.

The IP address of the power meter should be displayed in the ChB section 
of the display.

For details on 
each key, use key 
help as described 
on page 60.
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13.On the signal generator: Press Channel B to On and then back to Off again. This initializes the 
signal generator to the external power meter.

14.Press Return > Zero Sensor

A diagnostic dialog box is displayed each time an external power meter is being used and the 
Zero Sensor or Calibrate Sensor softkey is pressed (refer to Figure 4-10 on page 95). 

Verify the power sensor is connected to the 50 MHz reference of the power meter.

Figure 4-10    Diagnostic Dialog Box for Channel B

15.Press Done

The Running Calibration(s) bar is displayed: Zeroing Sensor Please wait.... 

16.After Running Calibration(s) bar disappears: Press Calibrate Sensor 

Diagnostic Dialog box is displayed that prompts for verifying the connection of the power 
sensor to the power meter 50 MHz reference (refer to Figure 4-11 on page 95).

Figure 4-11    Diagnostic Dialog Box for Calibration

For details on 
each key, use key 
help as described 
on page 60.

For details on 
each key, use key 
help as described 
on page 60.
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17.Press Done

Calibration progress bar is displayed. Refer to Figure 4-12 on page 96.

Figure 4-12    Running Calibration(s) Bar (Calibrating Sensor)

18.Press Return > Channel B to On

19.The current power meter sensor reading should be displayed on the signal generator in the 
ChB portion of the display and in the upper right corner of the display under Power Meter and 
to the left of the Power Meter power sensor reading.

Figure 4-13    Channel B Power Sensor Displayed on CXG/MXG/EXG

20.The power sensors are now ready to be connected in a measurement setup.

For details on 
each key, use key 
help as described 
on page 60.

For details on 
each key, use key 
help as described 
on page 60.
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Using the USB Pass Through Commands
The USB pass through SCPI commands are used remotely and or to program your system setup 
and power meter sensor setup.

This section applies to the following USB power sensors:

— U2040 X-Series

— U2020 X-Series

— U8480 Series

— U2000 Series

—

This section contains the following: 

— Table 4-1, “SCPI Pass Through Commands” 

— “Procedure”

If the power sensor is configured to return peak power, then the MXG 
displays peak power (i.e., Use the :fetch? and :measure? power sensor 
SCPI commands, which returns a value based on the configuration). Refer 
to the X-Series Signal Generators SCPI Command Reference.

Table 4-1 SCPI Pass Through Commands

:SYSTem:PMETer[1]|2:PASSthrough <"scpiCommand">
:SYSTem:PMETer[1]|2:PASSthrough? <"scpiQuery">
:SYSTem:PMETer[1]|2:PASSthrough:ENABle 0|1
:SYSTem:PMETer[1]|2:PASSthrough:ENABle?
:SYSTem:PMETer[1]|2:PASSthrough:TIMeout <valueInSeconds>
:SYSTem:PMETer[1]|2:PASSthrough:TIMeout?
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Procedure

Step Substeps Results/Notes

1. Setup equipment.

2. Enable the pass 
through capability in 
the MXG.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough:ENABle 1

3. Query the instrument 
and verify pass 
through status.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough:ENABle?

The instrument should return a 1, indicating that the 
pass through feature has been enabled.

4. Sending additional 
SCPI commands.

If you are sending a 
query, go to step 5.

Else, repeat steps 4 and 
or 5 as needed.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough "SCPI 
command"

Where "SCPI command" is any SCPI pass through 
command. Refer to Table 4-1 on page 97.

5. Sending additional 
SCPI queries.

If you are sending a 
command, go to step 4.

Else, repeat steps 4 and 
or 5as needed.

a. Enter:

:SYSTem:PMETer:PAS
Sthrough? “*IDN?”

The power sensor model and serial number should be 
returned.
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Using the Power Meter Servo
The Power Meter Servo mode uses power meter readings to adjust the output power of the source, 
maintaining a constant DUT output power.

The servo loop measures the output power of the DUT, compares it to the user-provided reference 
power, and adjusts the output of the source to achieve the user-provided power level within the 
settling error. The servo loop will abort after twenty unsuccessful attempts to achieve the 
user-provided power level.

Figure 4-14 Power Meter Servo Menus

For details on each key, use key help as 
described on see page 60.

See page 91

Sets the allowed 
settling error.

The system automatically adjusts 
power level according to the power 
meter reading.

Once performs the adjustment only at 
the end of any transition (amplitude or 
frequency change). After the 
adjustment is performed and the 
power error is corrected, no further 
adjustments are performed until the 
next transition.

Continuous performs the adjustment 
as in Once mode, and continues to 
adjust the power periodically if the 
value differs by more than the 
specified Settling Error.

N5173B/83B only

N5173B/83B 
only

Sets the relative initial power 
when leveling with the Power 
Meter Servo mode. The 
default of 0 dB means that the 
system starts with the power 
it thinks is needed (based on 
output power, offset and 
reference) but this might lead 
to power overshoots in certain 
cases (especially when the 
offset is not set up correctly). 
This value allows to specify 
an additional safe-margin to 
start the measure/adjust 
cycles lower than the target 
power to protect the device 
from power overshoots.
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Power Meter Servo Configuration

The following procedure is a basic configuration for using the signal generator’s Power Meter Servo 

mode. 

1. Connect the equipment as shown in Figure 4-15.

Figure 4-15    Power Meter Servo Configuration

2. Set the signal generator frequency and amplitude to the desired settings for your device. 

3. On the signal generator, press AMPTD > Leveling Control > Power Meter Servo Configuration.

4. Press Channel A Setup and configure the power meter. Refer to Configuring the Power Sensor 
Channels on page 91.

5. Press Return > Return > Settling Error. Set the Settling Error value. 

6. Press Return > Return > Leveling Mode. Select the leveling mode. 
 
Power Meter Once performs the adjustment only at the end of any transition (amplitude or 
frequency change). After the adjustment is performed and the power is corrected, no further 
adjustments are performed until the next transition. 

The configuration described below is one possible setup example. 
Consider the limits of your DUT and use caution to protect the DUT from 
being exposed to too much power.

To get the best results and reduce stress on the DUT, the amplitude offset 
should be set to match the approximate gain of the device. For example, if 
the DUT is an amplifier with 20 dB of gain, set the amplitude offset to 20 
dB. 
 
Press AMPTD > More > Amptd Offset, then enter a value.

For details on each key, 
use key help as described 
on page 60.

Power Sensor

Directional Coupler
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Power Meter Continuous performs the adjustment as in Once mode, and continues to adjust 
the power periodically if the value differs by more than the specified Settling Error.

Once these parameters are set, the servo loop engages and levels the DUT’s output power. 

Example

The following example emphasizes the importance of setting the amplitude offset, as it protects the 
DUT from being exposed to too much power.

For this example, the source amplitude offset is 20 dB and the source amplitude is programmed to 
25 dBm. The offset is subtracted from the programmed level, making the actual source output 
power 5 dBm. If the power meter measures 24.5 dBm, for example, the output power will be 
adjusted by 0.5 dBm since the power meter measurement is 0.5 dBm lower than the desired 25 
dBm. The new source output power is 5.5 dBm. If the power meter then measures 24.97 dBm, no 
further adjustments will be made since the measured value is within half of the settling error of 0.2 
dB. 

If using the continuous leveling mode, the power meter readings are monitored and the output 
power of the source will be adjusted if the measurement drifts outside the specified settling error.

Continuing with this example, if the amplitude offset remained at the default of 0 dB, the output 
power would have been 25 dBm, resulting in a power meter measurement of 40 dBm (assuming the 
amplifier already went into compression). The algorithm would have reduced the source power by 
15 dB, thus outputting 10 dBm and resulting in a measurement of maybe 29.5 dBm. The additional 
reduction of another 4.5 dB would have lead to the same outcome as with the 20 dB amplitude 
offset (source output power of 5.5 dBm). However, in-between, the DUT was stressed possibly past 
its specified operating range.
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Using Flatness Correction
User flatness correction allows the digital adjustment of RF output amplitude for up to 1601 
sequential linearly or arbitrarily spaced frequency points to compensate for external losses in 
cables, switches, or other devices. Using an Keysight N1911A/12A, E4419A/B, or U2000 Series 
power meter/sensor to calibrate the measurement system, a table of power level corrections can 
automatically be created for frequencies where power level variations or losses occur. Supported 
connection types to the power meter/sensor are Sockets LAN, VXI–11 LAN, USB, and GPIB via VXI–
11 LAN using a LAN–GPIB gateway (e.g. E5810A Gateway or equivalent).

If you do not have an Keysight N1911A/12A or E4419A/B power meter, or U2000A/01A/02A/04A 
power sensor, or if your power meter does not have a LAN, GPIB, or USB interface, the correction 
values can be manually entered into the signal generator.

To allow different correction arrays for different test setups or different frequency ranges, you may 
save individual user flatness correction tables to the signal generator’s memory catalog and recall 
them on demand.

Follow the steps in the next sections to create and apply user flatness correction to the signal 
generator’s RF output (see page 106).

Afterward, follow the steps in “Recalling and Applying a User Flatness Correction Array” on 
page 110 to recall a user flatness file from the memory catalog and apply it to the signal 
generator’s RF output.

A power meter with GPIB requires using the Connection Type VXI–11 
softkey, as well as a LAN–GPIB gateway, to control a power meter. Refer to 
the Keysight Connectivity Guide USB/LAN/GPIB Connectivity Guide 
(E2094–90009), Keysight X-Series FAQs “How do I connect to the LAN?”, 
and to the E5810A User’s Guide or equivalent, LAN/GPIB gateway device.
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Figure 4-16 User Flatness Correction Softkeys

Confirm

For details on each key, use key help 
as described on page 60.

See 
page 105

Starts the 
user  
flatness 
calibration.
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Creating a User Flatness Correction Array

In this example, you will create a user flatness correction array. The flatness correction array 
contains ten frequency correction pairs (amplitude correction values for each specified frequency), 
from 500 MHz to 1 GHz. 

An Keysight N1911A/12A or E4419A/B power meter and E4413A power sensor are used to 
measure the RF output amplitude at the specified correction frequencies and transfer the results to 
the signal generator. (A U2000 Series power meter/sensor could be used in lieu of the power meter 
and E4413A power sensor.) The signal generator reads the power level data from the power meter, 
calculates the correction values, and stores the correction pairs in the user flatness correction 
array.

If you do not have the required Keysight power meter, or if your power meter does not have a LAN, 
GPIB, or USB interface, you can enter correction values manually. 

Required Equipment

— Keysight N1911A/12A or E4419A/B power meter (a power meter is not required with the 
U2000A/01A/02A/04A Power Sensor)

— Keysight E4413A E Series CW power sensor or U2000A/01A/02A/04A Power Sensor

— GPIB, LAN, or USB interface cables, as required

— adapters and cables, as required

Connect the Equipment

Connect the equipment as shown in “Connect the Equipment” on page 105.

For operating information on a particular power meter/sensor, refer to its 
operating guide.

During the process of creating the user flatness correction array, the power 
meter is remotely controlled by the signal generator.
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Connect the Equipment

Figure 4-17 Configure Power Meter Menu Softkeys

— Keysight N1911A/12A or E4419A/B 
power metera

— Keysight U2000A/01A/02A/04A power 

Sensora

a. For operating information, refer to the power meter/sensor documentation.

— LAN, GPIB, or USB interface 
cables, as required

— adapters and cables, as 
required

The LAN, GPIB*, and USB connections are for 
convenience. If your power meter does not have 
LAN, GPIB, or USB, then manually enter corrections 
as described in the correction entry step in this 
section.

*GPIB control of a power meter requires a LAN–
GPIB gateway and use of the connection type VXI–
11. Refer to the Keysight Connectivity Guide 
USB/LAN/GPIB Connectivity Guide (E2094–90009), 
Keysight X-Series FAQs “How do I connect to the 
LAN?”, and to the E5810A User’s Guide or 
equivalent LAN/GPIB gateway device.

Power Sensor

Power Meter  
(if applicable)

Signal 
Generator

Device Under Test

Out In

Input Port

RF Output

Cables 
and other 
Devices

Flatness 
Corrected 
Output 

LAN/ 

Note: Keysight U2000 Series USB 
Power Sensors connect directly to the 
signal generator’s front panel USB 
port (i.e. the power meter is not 
applicable).

USB port for connecting 
USB–compatible power 
meters/sensors (e.g. 
N1911A/12A Power Meters 
and U2000A Series USB 
Power Sensors).

GPIB E5810A 

AMPTD > More > User Flatness > 
Configure Power Meter

Sockets LAN: Sets the IP 
port to 5025 (standard) or 
5023 (telnet) programming.

Sets the power meter’s IP 
address or LAN–GPIB 
gateway’s IP address 
(Sockets LAN and VXI–11 

VXI–11 LAN: Opens a menu 
for entering a device name 
for the power meter being 
used.

Enables the power meter 
connection type: Sockets 
LAN, VXI–11 LAN, or USB.

Note: The VXI–11 softkey is 
used to communicate 
remotely with a power meter 
that has a GPIB connector 
via LAN–GPIB gateway.

USB U2000A Series Power 
Meters do not require the 
sensor to be calibrated.

For details on each key, use key help as 
described on page 60.

Open a menu 
to enter the 
USB device 
name.

This softkey is dependent 
on the selected 
Connection Type.

Attempts to connect to the 
specified external power 
meter and execute a 
“*IDN?” command. If the 
result is “Connected, but no 
*IDN? response”, then the 
IP address connected to 
something, but the socket 
port or VXI-11 device name 
was not correct.
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Basic Procedure

1. Create a user flatness array.

a. Configure the power meter/sensor

b. Connect the equipment

c. Configure the signal generator

d. Enter the user flatness correction values

2. Optionally, save the user flatness correction data.

3. Apply user flatness correction to the RF Output.

Configure the U2000A/01A/02A/04A Power Sensor

1. Connect the power sensor to the signal generator’s front panel USB port. Refer to “Connect 
the Equipment” on page 105.

2. Zero the power sensor using the signal generator softkeys.

Configure the E4419A/B and N1911A/12A Power Meter

1. Select SCPI as the remote language for the power meter.

2. Zero and calibrate the power sensor to the power meter, using the softkeys on the signal 
generator or the front panel of the power meter.

3. Enter the power sensor calibration factors into the power meter as required.

Verify the signal generator RF Output power is set to the desired amplitude 
before performing the power meter zero. No RF Output amplitude check is 
done by the signal generator during zero.

The signal generator’s RF Output LED remains unchanged during zeroing 
of the power sensor (e.g. if the RF Output LED was on prior to starting the 
Zeroing of the power sensor, the LED remains on throughout the 
zero/calibration). But, actually the instrument’s firmware has turned off 
the RF Output’s power. 

For operating information on your particular power sensor, refer to its 
operation guide.
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4. Enable the power meter’s cal factor array.

Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction Values

Create the User Flatness Array

1. Configure the signal generator:

a. Preset the signal generator.

b. Set the signal generator’s connection type to the power meter/sensor:

i. Press AMPTD > More > User Flatness > Configure Power Meter > Connection Settings > 
Connection Type > connection type.

ii. If connection type is USB:

1. Zero Sensor

2. Go to step c.

else 
 
If Sockets LAN or VXI–11 LAN: Press Power Meter IP Address > power meter’s or LAN–
GPIB gateway IP address > Enter.

iii. If Sockets LAN: Press Power Meter IP Port > IP port > Enter.

else

If VXI–11: Press PM VXI–11 Device Name > device name > Enter.

When connecting directly to the power meter, enter the device name as specified in the 
power meter’s documentation. Typically, this is “inst0” and is case sensitive for some 
power meters. Refer to your power meter’s documentation, the Keysight Connectivity 
Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), and Keysight X-Series FAQs 
“How do I connect to the LAN?”

When connecting via a LAN–GPIB gateway, enter the SICL address of the power meter. 
Typically, this is “gpib0,13”, where “gpib0” is the GPIB SICL interface name of the 
gateway and “13” is the GPIB address of the power meter. Refer to the Keysight 
Connectivity Guide USB/LAN/GPIB Connectivity Guide (E2094–90009), Keysight 
X-Series FAQs “How do I connect to the LAN?”, and to the E5810A User’s Guide or 
equivalent, LAN/GPIB gateway device.

The signal generator’s RF Output LED remains unchanged during zeroing 
of the power sensor (e.g. if the RF Output LED was on prior to starting the 
Zeroing of the power sensor, the LED remains on throughout the 
zero/calibration). But, actually the instrument’s firmware has turned off 
the RF Output’s power.

For operating information on your particular power meter/sensor, refer to 
its operating guide.
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c. Open the User Flatness table editor and preset the cal array: 
Press Return > Configure Cal Array > More > Preset List > Confirm Preset with Defaults.

d. In the Step Array menu, enter the desired flatness–corrected start and stop frequencies, 
and the number of points: 

e. Populate the user flatness correction array with the step array configured in the previous 
step: 

Press Return > Load Cal Array From Step Array > Confirm Load From Step Data.

f. Set the output amplitude to 0 dBm.

g. Turn on the RF output.

Press More > Configure Step 
Array > 

Freq Start > 500 > MHz >

Freq Stop > 1 > GHz >

# of Points > 10 > Enter
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2. Connect the power meter to the RF output and enter the correction values:

The user flatness correction array title displays User Flatness: (UNSTORED), without a 
name, indicating that the current user flatness correction array data has not been saved to the 
file catalog.

Optional: Save the User Flatness Correction Data

1. Press Load/Store > Store to File.

2. Enter a file name (for this example, FLATCAL1) and press Enter.

The user flatness correction array file is now stored in the file catalog as a USERFLAT file. Any 
user flatness correction files saved to the catalog can be recalled, loaded into the correction 
array, and applied to the RF output to satisfy specific RF output flatness requirements.

3. Press Return.

Enable the Flatness Correction at the RF Output

— Press Return > Flatness Off On.

With a Power Meter Over LAN, GPIB, or USB Manually

i. Create the correction values: 

Press More > User Flatness > Do Cal.

The signal generator begins the user  
flatness calibration, and displays a 
progress bar.

The amplitude correction values load 
automatically into the  
user flatness correction array.

ii. View the stored amplitude correction 
values: 
Press Configure Cal Array. 

i. Open the User Flatness table editor and 
highlight  
the frequency value in row 1:  
Press More > User Flatness > Configure Cal 
Array.

The RF output changes to the frequency value 
of  
the table row containing the cursor. 

ii. Note the value measured by the power meter.

iii. Change the sign on the delta value (e.g. the 
delta value of the 0 dBm reference value (step 
f), and the measured value from ii is –.34, 
change the value to +.34).

iv. Highlight the correction value in row 1.

v. Press  
Select > enter the delta calculated in step iii > 
dB.

(e.g. For this example enter +.34)

The signal generator adjusts the output 
amplitude  
based on the correction value entered.

vi. Repeat steps ii - v until the power meter 
reads 0 dBm.

vii. Highlight the frequency value in the next row. 

viii.Repeat steps ii through vii for the remaining 
rows.
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The UF annunciator appears in the AMPLITUDE area of the display, and the correction data in the 
array is applied to the RF output.

Recalling and Applying a User Flatness Correction Array

The following example assumes that a user flatness correction array has been created and stored. If 
not, perform the Example: A 500 MHz to 1 GHz Flatness Correction Array with 10 Correction 
Values on page 107.

1. Preset the signal generator.

2. Recall the desired User Flatness Correction file:

a. Press AMPTD > More > User Flatness > Configure Cal Array > More > Preset List > Confirm 
Preset.

b. Press Load/Store.

c. Highlight the desired file.

d. Populate the user flatness correction array with the data contained in the selected file:  
Press Load From Selected File > Confirm Load From File.

The user flatness correction array title displays User Flatness: Name of File.

3. Apply the correction data in the array to the RF output: Press Return > Flatness Off On to On.
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Using Internal Channel Correction (N5166B/72B/82B Only)

The internal channel correction feature flattens the system magnitude and phase response across 
the maximum bandwidth supported by the instrument (up to 160 MHz BW, depending on the 
option). This performance improvement is available at any arbitrary center frequency or amplitude 
level.

Correction filter generation and application is performed internally. The correction filtering occurs 
in real time and is applied to live data.

There are two correction types: factory and user. The Factory Calibration optimizes the performance 
at the front panel RF output connector into a precision 50 ohm load. The User Calibration can 
extend this performance to a new calibration reference plane and deliver the highest signal quality 
to the user’s DUT.

This feature also minimizes unwanted baseband images by flattening (and matching) the 
magnitude and phase response of the I and Q channels from the signal DACs to the IQ modulator.

This calibration should be run when the ambient temperature has varied by at least ±5 degrees 
Celsius from the ambient temperature at which the previous calibration was run.

When this feature is off, the box will behave as it always has. When this feature is on, the internal 
I/Q path is active, the I/Q Correction Optimized Path is RF Output, and the frequency is changed by 
more than 1 kHz, the firmware will calculate a channel correction filter. For List/Sweep, the 
calculation will be done prior to the first sweep using the specified frequencies when either 
waveform sweep is active or the baseband is on and the instrument is optimized for the internal 
path. This calculation will cache corrections for up to the maximum number of cache points (256). 
For list/sweep, the sweep will pause and recalculate the correction caches before running again.

Additional characteristics of the internal channel correction:

— When the internal channel correction is on, arbitrary frequency switching while the baseband is 
on will take up to an additional 290 ms (72 ms typical) the first time that frequency is specified. 
After the first time that a frequency is selected, switching to that frequency again takes an 
additional 1 ms.

There is an internal calibration routine (Factory Calibration) that collects 
correction data for both the baseband and RF magnitude and phase errors 
over the entire RF frequency and power level range on any unit with 
options 653, 655, 656, and 657. The internal channel correction cannot be 
turned on until after the Enhanced Factory Calibration has been executed 
once. See “Perform Enhanced Factory Calibration” on page 114.

In the case of arbitrary frequency switching, once the correction cache is 
full (256 unique frequency points), the oldest frequency corrections will be 
forgotten as new frequencies are selected. 

Whenever I/Q Timing Skew, I/Q Delay, Quadrature Angle Adjustment, or 
the Int Equalization Filter is adjusted, all caches are forgotten.
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— If a frequency sweep is activated, then the calculation and caching will occur up front for the 
first 256 unique frequencies, and all additional unique frequencies will have the characteristics 
of arbitrary frequency switching.

— If the I/Q Correction Optimized Path softkey is set to Ext I/Q, then only the baseband corrections 
will be applied and the frequency switching will be unaffected.

— If active, the ACP Internal I/Q Channel Optimization filter and the Equalization filter, will be 
convolved with the internal channel correction filter. A hamming window is applied and the 
resulting filter will be truncated to 256 taps.
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Figure 4-18 Internal Channel Correction Softkeys

SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?
:CALibration:BBG:CHANnel

:MEMory:LOAD:CHANnel <"filename"> 
:MEMory:STORe:CHANnel <"filename">

For details on each key, use key help as described on page 60.

I/Q > More

Toggles on or off the application of the 
internal baseband generator RF and 
baseband magnitude and phase 
corrections across the 160MHz 
baseband bandwidth at the current RF 
frequency.
When this feature is on, arbitrary 
frequency switching while the 
baseband is on will take up to an 
additional 3.3ms (typical) to 6.8ms the 
first time that frequency is specified. 
After that, switching to that frequency 
will take up to an additional 1.3ms. 
Up to 1024 unique frequencies can be 
cached before the oldest cache will be 
forgotten. If a frequency sweep is 
activated, then the calculation and 
caching will occur up front for the first 
1024 unique frequencies, and all 
further unique frequencies will have 
the characteristics of arbitrary 
frequency switching.
If the I/Q Correction Optimized Path is 
set to Ext I/Q Output then only the 
baseband corrections will be applied 
and the frequency switching speed will 
be unaffected.
This correction will be convolved with 
the ACP Internal I/Q Channel 
Optimization filter and the Equalization 
filter if they are active. The resulting 
filter will be truncated to 256 taps.
NOTE: The Enhanced Factory 
Calibration must be executed once 
before the Factory correction type can 
be turned on. See page 114.

Provides additional correction to the 
DUT.
Specify the start and stop frequencies, 
configure the power meter, then 
execute the calibration.

Displays a menu that controls the 
calibration and application of the 
internal baseband generator RF and 
baseband magnitude and phase 
corrections across the entire 
baseband bandwidth.

Toggles on or off the application 
of Factory or User I/Q channel 
correction. 

Factory optimizes the 
performance to the RF output 
connector.

User extends the correction to 
the DUT.

NOTE: The Enhanced Factory 
Calibration must be executed 
once before the Factory 
correction type can be turned on. 
See Perform Enhanced 
Factory Calibration.

To perform the Factory 
calibration, press Utility > More 
> Service > I/Q Int Channel 
Correction Calibrations.

Select either Factory 
Calibration or Enhanced 
Factory Calibration. Follow the 
instructions on the signal 
generator display.
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Configure Internal Channel Correction

The following is a basic configuration for using the signal generator’s internal channel correction. 
Refer to Figure 4-18.

On the signal generator:

1. Set the center frequency:

Press Freq > 3 > GHz

2. Set the I/Q to internal (default):

Press I/Q > I/Q Source > Internal

3. Press I/Q to On

4. Perform internal channel correction:

Press More > Int Channel Correction Off On to On

Using User Corrections

Use a USB power sensor to perform a User Channel Corrections calibration to correct the response 
of the DUT/poor matching network. And, verify the EVM of the DUT with the new User Channel 
Corrections calibration.

Perform Enhanced Factory Calibration

For instruments with firmware prior to B.01.10, the Enhanced Factory Calibration must be run once 
before you can turn on the I/Q Internal Channel Corrections (Factory Correction Type). Optionally, 
this calibration procedure can be run anytime for new calibration data.

On the signal generator:

1. Press Utility > More > Service > I/Q Int Channel Correction Calibrations > Enhanced Factory 
Calibration.

2. Follow the instructions on the signal generator display to complete the calibration.

There is an internal calibration routine (Enhanced Factory Calibration) that 
collects correction data for both the baseband and RF magnitude and 
phase errors over the entire RF frequency and power level range on any 
unit with options 653, 655, 656, and 657. The internal channel correction 
cannot be turned on until after the Enhanced Factory Calibration has been 
executed once.

Depending on the equipment you use, the Enhanced Factory Calibration 
may take up to four hours to complete.
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Using External Leveling (N5173B/83B Only)

External leveling lets you move the ALC feedback source closer to the device under test (DUT) so 
that it accounts for most of the power uncertainties inherent to the cabling and components in a 
test setup. Refer to Figure 4-19.

While operating in external leveling mode, if either the RF or the DC 
connection between the signal generator and the detector is broken, 
maximum signal generator power can occur. This maximum power may 
overstress a power–sensitive device under test.

Atten Hold sets to On and grays out (inactive) with Ext Detector selection. When re–
selecting Internal, the softkey becomes active, but attenuator hold remains on. If 
desired, manually set it to off.

With the Ext Detector selection, Set Atten has no effect on the output power level. 
During external detector use, use the attenuator to keep the ALC power level at 
approximately 0 dBm when using negative dBm power levels. See page 118.

These settings do not 
change the output power 
amplitude of the signal 
generator, they only let 
you modify the front panel 
display amplitude value so 
it closely approximates the 
power level measured at 
the output of the 
coupler/splitter. See 
page 121.

This softkey works with only the Ext Detector selection. It uses 16 dB as its zero 
reference point.

See page page 90.

Opens a menu in which you can specify the manner in which power is set. 
Power setting can be optimized for different parameters.
Select Optimize S/N to maximize the signal to noise performance in the 
resulting signal.
Select Optimize Harmonics to minimize the amplitude of harmonics in the 
resulting signal.
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Figure 4-19 ALC Circuity

The external detector outputs a negative voltage to the signal generator’s rear panel ALC INPUT 
connector based on the power level at the detector. As the RF power level at the coupler’s/power 
splitter input changes, the external detector returns a compensating negative voltage. The ALC 
circuit uses this negative voltage to level the RF output power by raising and lowering the signal’s 
power, thus ensuring a constant power level at the point of detection (external detector). Since the 
point of detection does not occur at the output of the device to which the detector is connected, 
there is some power loss that is not compensated for by the external detector. For example on a 
coupler, the coupled port siphons some of the signal’s energy to drive the external detector. In 
addition the coupler experiences some insertion loss between the coupled port and the output. 
Figure 4-21 on page 117 shows the input power versus output voltage characteristics for typical 
Keysight Technologies diode detectors. Using this chart, you can determine the leveled power at 
the diode detector input by measuring the external detector output voltage. For a coupler, you 
must then add the coupling factor to determine the leveled output power.

When using an external detector, the signal generator’s power range may vary from the values 
shown in the data sheet. This is primarily due to the efficiency of the detector. Always ensure that 
the detector, coupler/power splitter are specified for the power and frequency range of interest. To 
determine the signal generator’s actual power range during external leveling, see “Determining the 
Signal Generator’s Amplitude Range” on page  120.

With external leveling, the displayed amplitude value can vary significantly from the actual output 
power of the coupler/power splitter to which the external detector is connected (see Figure 4-20). 
This is because the coupler/power splitter has it own signal characteristics (insertion loss, coupling 
factor, and so forth), which are unknown to the signal generator, so it is typically unable to display 
an accurate amplitude value. Also components between the signal generator and the external 
detector can affect the output power of the coupler/power splitter. You can compensate for this 
power display difference by using the  
Ext Leveling Amptd Offset softkey or the Amptd Offset softkey. The difference between the two 
softkeys is that the Ext Leveling Amptd Offset functions only while external leveling is active. For 
more information on using the external leveling offset feature, see “Adjusting the Signal Generator 
Display’s Amplitude Value” on page 121.

External Detector

Power Splitter
Component

DUT

RF

Cabling

OUTPUT

ALC INPUT

ALC Modulator

ALC Internal DetectorDriver

Signal Generator

Leveled Output

(Amp, Filter,
Atten, etc.)

(Negative output)

or Coupler

Opt 1E1 Output 
Attenuator 
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Figure 4-20 Power Value Differences with External Leveling

Figure 4-21 Typical Diode Detector Response at 25° C

Measured output power 
of a coupler

Signal generator set power level
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Option 1E1 Output Attenuator Behavior and Use

When using the internal detector, the Option 1E1 output attenuator enables signal generator 
power levels down to -130 dBm at the RF Output connector. It accomplishes this by adding 
attenuation to the output signal after the ALC detection circuit. The output power value (shown in 
the Amplitude area of the display) is the resultant of the Set Atten and Set ALC Level values (see 
page 115). With the external detector selected, the output attenuator no longer attenuates the 
output signal since the feedback for the detection circuit has been moved beyond the output 
attenuator. Because the attenuator no longer affects the amplitude of the output signal, the output 
amplitude is determined by only the Set ALC Level softkey.

With external leveling selected, the signal generator enables attenuator hold and the power range 
approximates the range of a standard option (no attenuator) signal generator (see the Data Sheet). 
As stated earlier, the actual output power may vary due to the external detector and the 
coupler/power splitter performance characteristics.

Even though the output attenuator no longer affects the output power, it is still useful to drive the 
ALC circuit to its mid–power point of approximately 0 dBm, which is optimal for the internal leveling 
circuitry and typically provides the best amplitude flatness results. This is useful with power values 
of -5 dBm or less. For example, to drive the ALC to approximately mid–power with a -20 dBm 
power setting, add 25 dB of attenuation. This sets the ALC circuit to 5 dBm (-20 + 25).

Configure External Leveling

Basic Setup Process

— If working with a single frequency signal, perform Steps 1 through 5.

— If working with multiple frequencies:

a. Perform Steps 1 through 4.

b. Perform a user flatness correction, see “Using Flatness Correction” on page 102.

— If working with a sweep:

a. Perform Steps 1 through 4.

b. Setup the sweep, see “Configuring a Swept Output” on page 66.

1. Setup the equipment, see “Equipment Setup” on page 119

2. Configure the carrier signal, see “Configuring the Carrier” on page  119

3. Select external leveling, see “Selecting External Leveling” on page 119.

When the internal detector (Internal selection) is reselected, the signal 
generator does not turn the attenuator hold off.

If there is too much attenuation, it will drive the ALC circuit too high and 
cause the signal generator to go unleveled. Ensure that you decrease the 
attenuation as you increase the power level.
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4. Determine the output amplitude range, see “Determining the Signal Generator’s Amplitude 
Range” on page 120

5. Set the displayed power value, see “Adjusting the Signal Generator Display’s Amplitude 
Value” on page 121

Equipment Setup

Set up the equipment as shown in Figure 4-22 on page 119. Place the external detector (detector 
and coupler/power splitter) as close as possible to the DUT.

Recommended Equipment

— Keysight 8474E negative detector

— Keysight 87301D directional coupler

— cables and adapters, as required

Figure 4-22 Typical External Leveling Setup using a Directional Coupler

Configuring the Carrier 

1. Press Preset.

2. Set the carrier frequency.

3. Set the power level to 0 dBm:

— If the signal generator has Options 1E1 and 520, set the output attenuator to zero dBm:

a. Press AMPTD > Atten/ALC Control > Atten Hold Off On to On.

b. Press Set Atten > 0 > dB.

c. Press Set ALC Level > 0 > dBm.

Selecting External Leveling

Press AMPTD > Leveling Control > Leveling Mode > Ext Detector.

Leveled Signal

Signal Generator CouplerAmplifier

Negative Detector

RF OUTPUT

ALC INPUT
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Determining the Signal Generator’s Amplitude Range

The maximum output amplitude is frequency dependent. So if you are using multiple frequency 
points and there is a need to know the maximum output amplitude for each frequency point, refer 
to the “Amplitude” section of the X-Series Data Sheet. Then use this procedure to determine the 
maximum amplitude for each band.

With external leveling and Option 1E1, the signal generator’s power range approximates that of a 
standard option instrument (no Option 1E1). But Option 1E1 does let you use the attenuator to 
drive the ALC to its mid–power point when using amplitude values less than 0 dBm. However 
adding attenuation does decrease the upper range limit. For more information, see “Option 1E1 
Output Attenuator Behavior and Use” on page  118.

1. If Option 1E1 is installed, adjust the attenuator to the desired level.

a. Press AMPTD > Atten/ALC Control > Atten Hold On > Set Atten.

b. Enter the attenuator value.

2. Turn on the RF output: Press RF On/Off to On

3. Set the AMPTD step increment value to one dB.

— Press AMPTD > Incr Set > 1 > dB.

4. Determine the minimum amplitude value:

a. Set the amplitude to -25 dBm.

b. Using the down arrow key, decrease the amplitude until the UNLEVEL annunciator appears.

c. Using the up arrow key, increase the amplitude until the UNLEVEL annunciator is gone.

The value showing when the UNLEVEL annunciator is gone is the minimum amplitude range 
value.

5. Determine the maximum amplitude value:

a. Set the amplitude to a value that does not cause the signal generator to go unleveled.

b. Using the up arrow key, increase the amplitude until it goes unleveled or an error message 
indicating that the upper limit has been reached shows at the bottom of the display.

c. Decrease the amplitude value:

— If the unleveled annunciator appeared, decrease the amplitude until the annunciator is 
gone. The value where the annunciator disappears is the maximum upper range value.

— If the signal generator displays Error: 501, Attenuator hold setting over 
range at the bottom of the display, the value showing is the maximum upper range 
value. 

If the Option 1E1 output attenuator value is too high (approximately 

 >55 dB), it will cause an unlevel condition to occur when the RF output is 
turned on.
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To remove the error message, press the down arrow key until the message is gone. The 
error appears when an attempt is made to increase the amplitude beyond the maximum 
value as it relates to the current attenuator setting.

Adjusting the Signal Generator Display’s Amplitude Value

When using external leveling, the signal generator’s displayed amplitude value will not match the 
leveled power of the signal at the output of the coupler/splitter. To compensate for this difference, 
the signal generator provides two methods for configuring the displayed power value so that it 
closely matches the measured value at the output of the coupler/splitter. 

1. Connect and configure a measurement instrument:

a. Connect the output of the coupler/splitter to either a power meter or a signal analyzer.

b. Configure the power meter/signal analyzer for measuring the power level of the signal.

2. Adjust the signal generator’s displayed amplitude value:

— If using the Ext Leveling Amptd Offset Softkey:

This softkey uses 16 dB as its zero reference. The 16dB is the coupling factor of the internal 
detector.

a. On the signal generator, press AMPTD > Leveling Control > Ext Leveling Amptd Offset.

b. While viewing the carrier amplitude value on the signal generator display, use the RPG 
knob (detent knob) to adjust the offset value until the integer part of the displayed 
amplitude value is the same as the integer portion of the measured value.

Each detent position adjusts the value by 1 dB. 

c. Using the number keypad, make the necessary fractional adjustments to the display 
amplitude value.

— If using the Amptd Offset Softkey:

a. On the signal generator, press AMPTD > More > Amptd Offset.

b. Calculate the difference between the signal generators displayed Amplitude value and 
the measured value.

c. Using the numeric keypad, enter this difference as the Amptd Offset softkey value.



 122                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

Optimize Performance
Using Unleveled Operating Modes

Using Unleveled Operating Modes

Figure 4-23 Power Search and ALC Off Softkeys

ALC Off Mode

Turning ALC off deactivates the signal generator’s automatic leveling circuitry. Turning ALC off is 
useful when the modulation consists of very narrow pulses that are below the pulse width 
specification of the ALC or when up converting external IQ signals and the modulation consists of 

Available only when
ALC = Off

Available only when
Power Search Reference =

Available only when 
Power Search = Span 

Auto: The calibration routine executes whenever 
output frequency or amplitude changes.

Span: Pressing Do Power Search executes the 
power search calibration routine once over a 
selected frequency range.
The corrections are stored and used whenever you 
tune the signal generator to within the calibrated 
frequency range.

For details on each key, use key help as described on page 60.

RMS: Value is a DC 
bias equivalent to the 
value derived from the 
file header or the 
calculated value from 
the current I/Q data.
Fixed: Uses a fixed 0.5 
Vrms value (Same 
value is used with Ext 
I/Q data).
Manual: Allows user to 
specify the DC bias 
voltage value  
(0–1.414 Vrms).
Modulated: Uses the 
AC bias from the actual 
modulating signal.

Manual

User: Enables the 
user to set the 
signal generator 
frequency settings.
Full: The signal 
generator selects 
its full frequency 
range for the power 
search.

Only available when 
I/Q is on. 

These 
softkeys are 
only active 
when an ARB 
waveforms is 
playing in 
memory.

Manual: User must explicitly execute a power 
search to calibrate the open loop ALC level.  

See page 105

Sets the allowed 
settling error.

Only available when 
I/Q is on. 

N5173B/83B only

N5173B/83B only
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slow amplitude variations or bursts that the automatic leveling would remove or distort. When 
using the internal IQ baseband generator, the best technique is to use the ALC hold marker 
function vs. ALC off for the types of signals just described.

Power Search Mode

The CXG/MXG/EXG has three power search modes (for internal and external I/Q modulation) and 
four power search references (for external I/Q modulation only). Refer to Figure 4-23 on page 122.

Power search executes a routine that temporarily activates the ALC, calibrates the power of the 
current RF output, and then disconnects the ALC circuitry.

Power Search Modes (Applies to External and Internal I/Q Modulation)

— Auto — A power search is executed at each frequency or power change, and at each change to 
the AM, burst, pulse, or I/Q modulation state.

— Span — When Power Search is set to Span, pressing Do Power Search executes the power 
search calibration routine over a range of user-defined frequencies. The power search is stored 
and used when the signal generator is tuned within a user-defined range. After the Span softkey 
is pressed, select either Full or User. If User is selected, then the start and stop frequencies need 
to be selected.

— Manual — When Power Search is set to Manual, pressing Do Power Search executes the power 
search calibration routine for the current RF frequency and amplitude. In this mode, if there is a 
change in RF frequency or amplitude, you will need to press Do Power Search again.

Power Search References (Only applies to Internal I/Q Modulation)

The four Power Search References control the power search function. These four references select 
the reference voltage used while the RF signal is being I/Q modulated. (Power search references are 

not used for analog modulation: FM, fM, or pulse modulation.)

After the ALC has been turned off, power search must be executed to set 
the proper output power level requested on the front panel. Power search 
is executed automatically by default, but the these settings can be 
overridden by using the Manual mode.

The power search mode cannot be used with bursted signals input via the 
external IQ inputs.

If the power search reference has the incorrect RMS voltage, the output 
power will be incorrect. Refer to Figure 4-24, "Calculating the Output 
Power Error for a Single Waveform Sample Point" and Figure 4-25, 
“Calculating the RMS Voltage of the Waveform.”

A successful power search is dependent on a valid power search reference.
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— Fixed – Reference level is 0.5 Vrms. 

This reference functions with internal, external IQ and bursted signals. This is the instrument’s 
default setting. 

— RMS – User provided reference level 0–1.414 Vrms placed in the Waveform Header. Refer to 
“Saving a Waveform’s Settings & Parameters” on page 217.

This reference functions with internal IQ and bursted signals.

— Manual – User provided reference level 0–1.414 Vrms. 

This reference functions with internal, external IQ and bursted signals. 

— Modulated – Uses the I/Q modulation signal as the reference level.

This reference functions with internal or external IQ. It is not functional with bursted signals or a 
signal with varying Vrms.

Figure 4-24 Calculating the Output Power Error for a Single Waveform Sample Point

Figure 4-25 Calculating the RMS Voltage of the Waveform

The RMS and MANUAL references are the most powerful selections. The user provides the reference 
level. The IQ signal can be bursted (radar) or have different RMS levels (Wireless Signals). Once the 
RMS/MANUAL reference level is set, the power search runs independent of the current Vrms value 
of the waveform. 

The RMS and MANUAL references, with a reference level of 1.0 Vrms are equivalent to a calculated 
rms value of 1 and can be measured using SINE_TEST_WFM. 

20 10 V1( ) V2( )⁄( )log×=

Where:

V1 is the actual waveform RMS voltage

V2 is the entered RMS voltage

The Output Power Error

Note: If the RMS voltage value entered is lower than the actual RMS voltage, the output power will be higher than desired. If the RMS 
voltage value entered is higher than the actual RMS voltage, the output power will be lower than desired.

The signal generator can calculate the RMS value automatically.if more 
than two contiguous IQ data points are zero, the signal generator 
calculation ignores those zero points. Also, because the RMS calculation, 
that is done by the signal generator, is slow and may not be appropriate for 
your application, it is recommended that the user calculate and enter in 
their measured RMS value for the waveform file.

RMS value for the waveform =

SCPI Commands:

[:SOURce]:RADio:ARB:HEADER:RMS <"file_name">,<val>|UNSPecified 
[:SOURce]:RADio:ARB:HEADER:RMS? <"file_name">

For a programming example of determining the RMS voltage of a waveform, refer to the Programming Guide.
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The FIXED, RMS, and MANUAL references use a DAC to apply the reference voltage and do not 

require the IQ signal to be present.

Power Search Settings

For the power search routine to execute, the instrument must be in the following conditions:

— The I/Q modulation enabled On.

— The RF output enabled On.

— The Automatic Leveling Circuitry deactivated (Off).

— The RF Blanking set to On. 

This function prevents power spikes during the power search (refer to “Using the RF Blanking 
Marker Function” on page 234.)

— When using summing for the internal Arb and the external I/Q, all four power reference modes 
are available (e.g. Fixed, RMS, Manual, and Modulated).

— When using the external IQ inputs, use the MANUAL reference mode, and make sure the 
external I/Q signal is present when executing a power search. If the external I/Q signal is not 
present, the power search will fail.

Example: Automatic Power Search

1. Preset the signal generator.

2. Set the desired frequency.

3. Set the desired amplitude.

4. Turn the RF output on.

5. Deactivate the signal generator’s automatic: 

Press AMPTD > ALC Off On to highlight Off

Deactivating the signal generator’s automatic leveling control is a significant instrument 
change that automatically initiates a power search.

The CXG/MXG/EXG reference voltage is designed to operate between 0.1 
Vrms to 1 Vrms nominally, but it can overrange to 1.414 Vrms. (The RMS 
can overrange to 1.414, if the constant values are loaded manually and all 
“1”s are entered for the I and Q values.) See also “Saving a Waveform’s 
Settings & Parameters” on page 217.

The minimum reference level that results in a successful power search is 
dependent on RF Frequency, RF Amplitude, and Temperature. An 
CXG/MXG/EXG power search using a reference level of 0.1 Vrms for 0 dBm 
at 1 GHz may fail.
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When set to Auto, power search automatically executes when a significant instrument setting 
changes. The Do Power Search feature enables you to decide when to execute a power search to 
compensate for changes, such as temperature drift or a change in the external input.

Using an Output Offset, Reference, or Multiplier

Setting an Output Offset

Using an output offset, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) from the entered value.

RF Output = entered value – offset value

Displayed Value = output frequency + offset value

To set an offset:

— Frequency: Press Freq > Freq Offset > offset value > frequency unit.

— Amplitude: Press Amptd > More > Amptd Offset > offset value > dB.

Examples

When using the signal generator as a local oscillator (LO), you can use the offset to display the 
frequency of interest, as illustrated below:

Parameter
Example 
#1

Example 
#2

Example 
#3

Comments

Entered (and displayed) 
Value:

300 MHz 300 MHz 2 GHz The entered value must be positive.

Offset: 50 MHz −50 MHz −1 GHz An offset value can be positive or negative.

Output Frequency: 250 MHz 350 MHz 3 GHz
The signal generator alerts you if the  
output frequency or amplitude is out of range.

Indicates that an offset is on
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Setting an Output Reference

Using an output reference, the signal generator can output a frequency or amplitude that is offset 
(positive or negative) by the entered value from a chosen reference value. 

RF Output = reference value + entered value

To set a reference:

1. Set the frequency or amplitude to the value you want as the output reference level.

2. Frequency: Press Frequency > Freq Ref Set  
The frequency displays 0.00 Hz, indicating that this is the RF output frequency “zero level.”  
All frequencies entered are interpreted as being relative to this reference frequency.

Amplitude: Press Amptd > More > Amptd Ref Set 
The amplitude displays 0.00 dB, indicating that this is the RF output amplitude “zero level.” 
All amplitudes entered are interpreted as being relative to this reference amplitude.

Examples

Parameter
Example 
#1

Example 
#2

Example 
#3

Comments

Reference: 50 MHz 50 MHz 2 GHz A reference value must be positive.

Entered (and displayed) 
Value:

2 MHz −2 MHz −1 GHz The entered value can be positive or negative.

Output Frequency: 52 MHz 48 MHz 1 GHz
The signal generator alerts you if the output frequency or 
amplitude is out of range.

IF AmplifierRF Amplifier Mixer Filter

Signal Generator
(local oscillator)

Output Frequency = 1000 MHz

IF = 321 MHz

Antenna tuned to 1321 MHz

Selected Offset

321 MHz

−679 MHz

SIgnal Generator Display

1321 MHz  (Antenna 
Frequency)

  321  MHz (IF Output)

IF Output
321 MHz

Indicates that a reference is on
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To set a new frequency or amplitude reference, turn the frequency reference off, and then follow the 
steps above.

Setting a Frequency Multiplier

Using a frequency multiplier, the signal generator can display a frequency that is the multiple 
(positive or negative) of the output value. 

Displayed Value = multiplier value ´ output frequency

Output Frequency = displayed value ¸ multiplier value

To set a frequency multiplier:

1. Press Frequency > Freq Multiplier > multiplier value > x.

2. Set the desired frequency. 
The display equals the output frequency times the multiplier value.

Examples

Parameter
Example 
#1

Example 
#2

Example 
#3

Comments

Frequency Multiplier: 3 −3 4 The multiplier range can be set from:

 +0.001 to +1000

 –1000 to –0.001

Entered (and displayed) 
Value:

600 MHz −600 
MHz

8 GHz

Output Frequency: 200 MHz 200 MHz 2 GHz
The signal generator alerts you if the output frequency is 
out of range.

Indicates that a frequency multiplier is on
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When using the signal generator as the input to a system, you can set the frequency multiplier so 
that the signal generator displays the output of the system, as illustrated below using a doubler:

When measuring mixers, the frequency multiplier and frequency offset are often used together. In 
the upconverter example below, the multiplier is set to 

-1 and the offset is set to 3 GHz so that the signal generator displays fRF.

Using the Frequency and Phase Reference Softkeys
The CXG/MXG/EXG can be set to have either a user-determined frequency or phase reference.

Figure 4-26 Frequency Reference and Frequency Offset Softkeys

Signal Generator Doubler

Output = 4 GHzX2Input = 2 GHz Selected 
Multiplier
2

Signal Generator 
Output
2 GHz

Entered/Displayed 
Frequency
4 GHz

Mixer

Signal Generator
(local oscillator)

fLO = 800 − 600 MHz

fIF = 3000 MHz

Selected 
Multiplier 

−1
−1

Signal Generator 
Output (fLO) 

800 MHz
600 MHz

fRF = 2200  2400 MHz

Selected 
Offset 

3000 MHz
3000 MHz

Entered/Displayed 
Frequency 
(fRF)
2200 MHz
2400 MHz
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Using Free Run, Step Dwell, and Timer Trigger
Free Run, Step Dwell (time), and Timer Trigger can be used to adjust the time spent at any point in 
a Step Sweep or a List Sweep. There are two possible measurement combinations:

Free Run with Step Dwell time (Figure 4-27 on page 131) the signal generator waits for the signal 
to settle and then waits for the Step Dwell time, then it jumps to the next frequency point. In 
addition, the time to complete the entire sweep can vary. There is always a minimum value of Step 
Dwell for each frequency point. The minimum Step Dwell timing for any point is fixed at a value of 
100 us. The time between frequency points is the sum of the settling time, plus the Step Dwell time. 
The settling time is dependent on frequency, amplitude, band crossings, and other factors, so the 
time between frequency points can vary. 

Timer Trigger instead of Free Run (Figure 4-27 on page 131) the signal generator generates 
equally spaced triggers, and it moves to the next point at each trigger. This has the advantage that 
the time between points is consistent and the overall sweep time is consistent. But, if the trigger is 
too fast, the signal may not have time to settle before jumping to the next point.

Understanding Free Run, Step Dwell, and Timer Trigger Setup

If the signal is to be settled for a minimum specific time at each point and it is not important if the 
point to point time is consistent, use Free Run and Set Dwell time.

If the signal’s point to point time requires consistency but the specific settling time at each point 
can vary, then use the Timer Trigger. Avoid using too fast of a sweep which does not allow the 
signal generator to settle.

If the signal needs to be settled for a specific minimum time and consistent point to point time is 
required, then you should set the Timer Trigger to be the sum of the switching time (900 us or 5 ms, 
depending on options) plus the minimum settled time that is needed to make the measurement.

If the measurement requires external equipment synchronization, consider using hardware triggers. 
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Figure 4-27 Free Run, Set Dwell, and Timer Trigger Softkeys
Sweep > Configure Step 
Sweep > More 

Use Step Dwell with Free Run when additional measurement wait time is 
desired after settling.
If the signal is to be settled for a minimum specific time at each point and it is 
not important if the point to point time is consistent, use Step Dwell and Free 
Run time.

Sweep > 

If the signal’s point to point time requires 
consistency but the specific settling time 
at each point can vary, then use the 
Timer Trigger. Avoid using too fast of a 
sweep which does not allow the signal 
generator to settle.  
If the signal needs to be settled for a 
specific minimum time and consistent 
point to point time is required, then you 
should set the Timer Trigger to be the 
sum of the switching time (900 us (Option 
UNZ) or 5 ms (Standard)) plus the 
minimum settled time that is needed to 
make the measurement. 
Example: If you need the signal to remain 
settled for 3 ms, and you have Option 
UNZ which settles in 0.9 ms, then set the 
time trigger to the sum which is 3.9 ms.

For details on each key, use key help as described on see page 60.

N5173B/83B only
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Using a USB Keyboard
You can use a USB keyboard to remotely control the RF output state, the modulation state, and to 
select a memory sequence and register. 

The register selection, RF output state, and modulation state are affected by power cycle or preset, 

but the USB keyboard control state and the sequence selection are not.

To avoid the loss of data, GPIB settings, or current user instrument states 
that have not been permanently saved to nonvolatile memory, the signal 
generator should always be powered down either via the instrument’s 
front panel power button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down with the system 
rack power switch rather than the instrument’s front panel switch display a 
Error –310 due to the instrument not being powered down correctly.

Turning the USB keyboard control off disables the USB 
keyboard; it has no effect on the Auto Recall softkeys.

For details on each key, use key help as described on page 60.

USB Keyboard Key
Delete, Enter
Insert
Home, Right Arrow
End, Left Arrow
Page Up, Up Arrow, +
Page Down, Down Arrow, –

Signal Generator Function
RF On/Off
Mod On/Off
Next Sequence
Previous Sequence
Recall Next State Register
Recall Previous State Register

Deletes every register in every sequence.

NOTE: You cannot recover the registers after 
deleting them.
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5   Avionics VOR/ILS (Option N5180302B)

This chapter describes the avionics softkeys used by Keysight N5171B/72B EXG and N5181B/82B 
MXG X-Series signal generators with Option N5180302B Avionics License during either VOR [VHF 
Omnidirectional Ranging] or ILS [Instrument Landing System] aircraft navigation receiver test. 
Avionics is a term used to describe the electronic instrumentation on aircraft.

Before using the information in this chapter, you should be familiar with the basic operation of the 
signal generator. If you are not comfortable with functions such as setting the power level and 
frequency, refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the 
information in that chapter.

Use the Aux Fctn [Auxiliary Functions] key to access the Avionics softkeys.

Figure 5-1 Avionics Softkeys 

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.

Using ILS Glide Slope Softkeys on page 161

Using ILS Localizer Softkeys on page 149

Using VOR [VHF Omnidirectional Range] Softkeys on page 134

Using ILS Marker Beacon Softkeys on page 173
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Using VOR [VHF Omnidirectional Range] Softkeys
The purpose of the VOR system is to provide directional information for aircraft in flight. VOR 
ground based transmitter stations are strategically located to provide complete coverage for air 
traffic. Each VOR ground based transmitter station radiates a carrier in the range from 108.00 to 
117.95 MHz, which is modulated in a way that provides aircraft bearing information relative to the 
VOR ground based transmitter location.

The VOR radiated electromagnetic signal consists of the sum of two antenna's signals radiating at 
the same RF carrier frequency:

— The first antenna signal is from a non-directional antenna radiating a carrier that is AM 
modulated by a signal that varies from 9480 Hz to 10440 Hz and back 30 times per second.

— The second antenna signal is from a horizontal dipole which rotates at a rate of 30 revolutions 
per second.The dipole produces a figure-eight pattern. The RF voltages are opposite in polarity 
on front and back side of the dipole pattern. Since the RF on one side is in phase with the RF 
radiated from the non-directional antenna, a cardioid field pattern, which rotates at 30 Hz is 
formed. The signal received by the aircraft is an RF carrier with amplitude varying at 30 Hz which 
is caused by the rotating cardioid pattern. The carrier is also amplitude modulated by the 9960 
Hz frequency modulated sub-carrier. The 30 Hz FM signal provides the phase reference and the 
30 Hz AM caused by the cardioid pattern provides the variable phase signal.

By demodulating the transmitted VOR signal, an aircraft receiver can compare the phases of the 
two 30 Hz signals (REF Freq vs VAR Freq) to determine the compass bearing to a VOR station. By 
tuning to two or more VOR stations and recording each bearing angle, pilots can determine their 
exact location on an air chart by triangulation. A VOR Bearing Angle is the phase difference 
between the 30 Hz reference signal (REF Freq) and the 30 Hz variable phase signal (VAR Freq). The 
30 Hz reference signal (REF Freq) is transmitted from the ground-based stationary VOR transmitter 
while the 30 Hz variable phase signal (VAR Freq) is transmitted from the VOR signal that is rotating 
at 30 Hz clockwise.

Figure 5-2 VOR Transmitter Antenna Pattern

When using an X-Series signal generator with Option N5180302B Avionics License to simulate VOR 
signals, the 30 Hz reference signal (REF Freq) is placed on a sub-carrier of 9960 Hz (SubCarrier 
Freq) using frequency modulation with a peak deviation set to 480 Hz (REF Deviation). This 
frequency modulated sub-carrier is then amplitude modulated onto one of the VOR carriers (108.00 
to 117.95 MHz). This makes the reference signal essentially an FM/AM multiplex signal.



Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide                                                         135

  Avionics VOR/ILS (Option N5180302B)

Using VOR [VHF Omnidirectional Range] Softkeys

Figure 5-3 VOR Softkeys

When testing a VOR system, the following VOR parameters can be set:

VOR Menu Parameters Default State

VOR Mode OFF

Carrier Freq Index 1 108.00 MHz

Bearing menu Angle 0.00 Deg

Direction From

REF/VAR menu REF/VAR Freq 30.00 Hz

REF Deviation 480.0 Hz

VAR Depth 30.0%

SubCarrier Freq 9.96000 kHz

SubCarrier Depth 30.0%

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.

- Turns on the VOR 
carrier and variable 
phase signal

- Turns on all 
VOR modulation 
and VOR carrier

- Turns on only the 
sub-carrier
- Turns on the sub-carrier 
modulated with the 
reference signal

- Sets the Bearing angle 
FROM the VOR station

- Sets the Bearing 
direction as either 
From or To 
the VOR station

- Sets the frequency of 
the reference signal and 
variable phase signal

- Sets the amount of 
FM deviation the 30 Hz 
reference signal applies 
on the sub-carrier

- Turns off all 
VOR modulation; 
VOR carrier remains on.

- Sets AM depth of the 
variable phase signal

- Sets the frequency of 
the sub-carrier

- Sets the AM depth of 
the sub-carrier as it 
modulates the main carrier

- Sets a Carrier Frequency by selecting an Index from 1 to 160. 
(Default: Index is 1 and corresponds to 108.00 MHz)
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To set the VOR mode that produces a full or partial VOR signal

1. Press Aux Fctn > Avionics > VOR

2. Press VOR Mode 
(Default selection is OFF.)

3. Select either: OFF | NORM | VAR | Sub-carrier | Sub-carrier+FM

— Selecting OFF turns off all VOR modulation. When set to OFF, all VOR mode parameter settings 
are turned off, but the selected VOR carrier is still present on the RF Output connector. To turn 
off this VOR carrier, set RF Off/On to Off.

— Selecting NORM turns on all VOR signals so that a standard VOR signal is generated with a 
default VOR Bearing of zero degrees.

— Selecting VAR turns on the main VOR carrier and the 30 Hz variable phase signal (VAR Freq); 
suppressed the Sub-carrier.

— Selecting Sub-carrier turns on the Sub-carrier without the 30 Hz reference signal (REF Freq); 
suppresses the main VOR carrier.

— Selecting Sub-carrier+FM turns on the Sub-carrier and the 30 Hz reference signal (REF Freq); 
suppresses the main VOR carrier.

To set the VOR carrier frequency

1. Press Aux Fctn > Avionics > VOR

2. Press Carrier Freq Index 
(Default value is 1 and corresponds to 108.00 MHz.)

3. Select a value from 1 to 160 and press Enter.

The index value that is entered sets the VOR carrier frequency to one of the standard defined 
corresponding values and produces a VOR carrier.

VOR carrier frequencies range from 108.00 to 117.95 MHz and can be set by selecting index values 
from 1 to 160.

ILS Localizer frequencies range from 108.10 to 111.95 MHz, which overlaps the VOR carrier 
frequency range, and can be set by selecting index values from 1 to 40. (For information, see: “To 
set the ILS Localizer carrier frequency” on page 152.)

Because VOR carrier frequencies and ILS Localizer carrier frequencies have a frequency range that 
overlaps, only frequencies where the 100 kHz digit is even (tenths of a megacycle count is even) are 
used as VOR carrier frequencies.
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The default VOR carrier frequency Index is 1 and corresponds to 108.00 MHz.

VOR Carrier Frequencies (MHz)     Carrier Freq Index = 1 to 160

1 to 32 33 to 64 65 to 96 97 to 128 129 to 160

108.00 111.20 113.20 114.80 116.40

108.05 111.25 113.25 114.85 116.45

108.20 111.40 113.30 114.90 116.50

108.25 111.45 113.35 114.95 116.55

108.40 111.60 113.40 115.00 116.60

108.45 111.65 113.45 115.05 116.65

108.60 111.80 113.50 115.10 116.70

108.65 111.85 113.55 115.15 116.75

108.80 112.00 113.60 115.20 116.80

108.85 112.05 113.65 115.25 116.85

109.00 112.10 113.70 115.30 116.90

109.05 112.15 113.75 115.35 116.95

109.20 112.20 113.80 115.40 117.00

109.25 112.25 113.85 115.45 117.05

109.40 112.30 113.90 115.50 117.10

109.45 112.35 113.95 115.55 117.15

109.60 112.40 114.00 115.60 117.20

109.65 112.45 114.05 115.65 117.25

109.80 112.50 114.10 115.70 117.30

109.85 112.55 114.15 115.75 117.35

110.00 112.60 114.20 115.80 117.40

110.05 112.65 114.25 115.85 117.45

110.20 112.70 114.30 115.90 117.50

110.25 112.75 114.35 115.95 117.55

110.40 112.80 114.40 116.00 117.60

110.45 112.85 114.45 116.05 117.65

110.60 112.90 114.50 116.10 117.70

110.65 112.95 114.55 116.15 117.75
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To set the VOR bearing angle between the VAR signal and the REF signal

1. Press Aux Fctn > Avionics > VOR

2. Press Bearing

3. Press Angle 
(Default value is 0.00 deg.)

4. Select a <value> from 0 to 360 deg and press Enter.

By demodulating the transmitted VOR signal, an aircraft receiver can compare the phases of the 
two 30 Hz signals (REF Freq vs VAR Freq) to determine the compass bearing to a VOR station. By 
tuning to two or more VOR stations and recording each bearing angle, pilots can determine their 
exact location on an air chart by triangulation.

A VOR Bearing Angle is the phase difference between the 30 Hz reference signal (REF Freq) and the 
30 Hz variable phase signal (VAR Freq).

The 30 Hz reference signal (REF Freq) is transmitted from the ground-based stationary 
VOR transmitter while the 30 Hz variable phase signal (VAR Freq) is transmitted from the VOR 
signal that is rotating at 30 Hz clockwise.

Figure 5-4 VOR Transmitter Antenna Pattern

110.80 113.00 114.60 116.20 117.80

110.85 113.05 114.65 116.25 117.85

111.00 113.10 114.70 116.30 117.90

111.05 113.15 114.75 116.35 117.95
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To set the VOR bearing direction as From or To

1. Press Aux Fctn > Avionics > VOR

2. Press Bearing

3. Press Direction 
(Default selection is From.)

4. Select either From | To

From - In the From convention, the VOR transmitter beacon is made the reference point and the 
Bearing Angle is between local magnetic-North and the beacon-to-aircraft radial line (RL).

To - In the To convention, the aircraft is made the reference point and the Bearing Angle is between 
local magnetic-North and the aircraft-to-beacon radial line (RL).

RL(To) = 180° – RL(From)

To set the frequency of the reference signal (REF Freq) and the variable phase 
signal (VAR Freq)

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press REF/VAR Freq 
(Default value is 30 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 10 to 60 Hz.

Enter a value in Hz to set the frequency of the reference signal (REF Freq) and the variable phase 
signal (VAR Freq).

To set the amount of FM deviation that the 30 Hz reference signal (REF Freq) 
applies on the sub-carrier

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press REF Deviation 
(Default value is 480 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 1 kHz.

Enter a value in Hz to set the amount of FM Deviation that the 30 Hz reference signal (REF Freq) 
applies on the sub-carrier. 

The 30 Hz reference signal (REF Freq) is placed on a sub-carrier of 9960 Hz (SubCarrier Freq) using 
frequency modulation with a peak deviation set to 480 Hz (REF Deviation). This frequency 
modulated sub-carrier is then amplitude modulated onto one of the VOR carriers (108.00 to 117.95 
MHz). This makes the reference signal essentially an FM/AM multiplex signal.
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To set the AM depth of the variable phase signal (VAR Freq)

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press VAR Depth 
(Default value is 30%.)

4. Select a value from 0 to 49.9% and press Enter.

Enter a value in percentage to set the AM depth of the variable phase signal (VAR Freq).

To set the frequency of the sub-carrier signal (SubCarrier Freq)

This process sets the frequency of the sub-carrier for a VOR signal.

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press SubCarrier Freq 
(Default value is 9960 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 20 kHz.

The 30 Hz reference signal (REF Freq) is placed on a sub-carrier of 9960 Hz (SubCarrier Freq) using 
frequency modulation with a peak deviation set to 480 Hz (REF Deviation). This frequency 
modulated sub-carrier is then amplitude modulated onto a VOR carrier (108.00 to 117.95 MHz). 
This makes the reference signal essentially an FM/AM multiplex signal.

To set the sub-carrier AM depth that modulates the VOR carrier

1. Press Aux Fctn > Avionics > VOR

2. Press REF/VAR

3. Press SubCarrier Depth 
(Default value is 30%.)

4. Select a value from 0 to 49.9% and press Enter.

Enter a value in percentage to set the Sub-carrier AM depth as it modulates the main carrier of a 
VOR signal.

Sub-carrier AM depth is typically 30%, but can range from 0 to 49.9%.

To set or return the VOR subsystem parameters to a default state

This process returns the VOR system parameters to a set of default state conditions.

1. Press Aux Fctn > Avionics > VOR

2. Press More 1 of 2
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3. Press Recall Default Settings

Example of Setting All VOR Parameters

1. Press Preset to place the signal generator in a known preset state.

2. Set the VOR carrier frequency.

a.Press Aux Fctn > Avionics > VOR

b.Press Carrier Freq Index 
(Default value is 1 and corresponds to 108.00 MHz carrier frequency.)

c.(Optional) Select a value from 1 to 160 and press Enter 
to change to a different carrier frequency.

3. Set the VOR bearing angle between the VAR signal and the REF signal.

a.Press Bearing

b.Press Angle 
(Default value is 0.00 deg.)

c.(Optional) Select a value from 0 to 360 deg and press Enter.

4. Set the VOR bearing direction as From or To.

a.Press Direction 
(Default selection is From.)

b.(Optional) Select either From | To

5. Set the frequency of the reference signal (REF Freq)  
and variable phase signal (VAR Freq).

VOR Menu Parameters Default State

VOR Mode OFF

Carrier Freq Index 1 108.00 MHz

Bearing menu Angle 0.00 Deg

Direction From

REF/VAR menu REF/VAR Freq 30.00 Hz

REF Deviation 480.0 Hz

VAR Depth 30.0%

SubCarrier Freq 9.96000 kHz

SubCarrier Depth 30.0%

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.
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a.Press Return

b.Press REF/VAR

c.Press REF/VAR Freq 
(Default value is 30 Hz.)

d.(Optional) Select a <value> from 10 to 60 Hz.

6. Set the amount of FM deviation that the 30 Hz reference signal (REF Freq) applies on the 
sub-carrier.

a.Press REF Deviation 
(Default value is 480 Hz.)

b.(Optional) Select a <value> from 0 Hz to 1 kHz.

7. Set the AM depth of the variable phase signal (VAR Freq).

a.Press VAR Depth 
(Default value is 30%.)

b.(Optional) Select a <value> from 0 to 49.9% and press Enter.

8. Set the frequency of the sub-carrier signal.

a.Press SubCarrier Freq 
(Default value is 9960 Hz.)

b.(Optional) Select a <value> from 0 Hz to 20 kHz.

9. Set the sub-carrier AM depth that modulates the VOR carrier.

a.Press SubCarrier Depth 
(Default value is 30%.)

b.(Optional) Select a <value> from 0 to 49.9% and press Enter.

10.Set the VOR mode to produce a full VOR signal.

a.Press Aux Fctn > Avionics > VOR

b.Press VOR Mode 
(Default selection is OFF.)

c.Select NORM to turn on all VOR signals so that a standard VOR signal is generated with a 
default VOR Bearing of zero degrees.

11.Set modulation to on.

a.Press MOD On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is on).

12.Set a desired RF power level.

a.Press Amptd 
(Default power level is around -144 dBm, and depends on the signal generator model 
being used, so the signal may be very low and hard to find if you do not specify a high 
enough power level.)
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b.Select a value from -20 dBm to -40 dBm.

13.Set RF output to on.

a.Press RF On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is off).

14.Verify that all settings are as expected on the signal generator display.

a.Press Aux Fctn > Avionics > VOR

b.Review the settings under 
VOR Status Information
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Using COM/ID Softkeys
The purpose of COM/ID commands are to set parameters related to 
airport communication identification codes. (This code may also be referred to as an, “airport 
call-sign”.)

During VOR and ILS testing, a COM/ID code can be transmitted as a three letter Morse-code signal 
of 1.02000 kHz and is placed on the carrier; this COM/ID code is used to identify the ground-based 
transmitting station.

Each COM/ID code (airport identification code) must correspond to one of the International Air 
Transport Association (IATA) codes.

IATA owns, controls, and has a copyright to the complete list of airport identification codes; STS is 
the airport identification code that refers to the Sonoma County Airport in Santa Rosa, CA, USA.

Figure 5-5 COM/ID Softkeys

When testing a VOR [VHF Omnidirectional Ranging] 
or ILS [Instrument Landing System], 
the following COM/ID parameters can be set:

To set the COM/ID on or off

This process toggles COM/ID Off (0) or On (1).

1. Press Aux Fctn > Avionics > VOR

COM/ID Menu Parameters Default State

COM/ID Off/On Off

COM/ID Code/Type Code

COM/ID Code STS

Frequency 1.02000 kHz

Depth 10.0%

- Sets either Code or Tone 
as the COM/ID type

- Sets a 3-character 
airport ID Code enclosed 
in single or double-quotes
- Sets the COM/ID tone 
modulating frequency

- Turns off all 
COM/ID signals

- Sets the COM/ID tone 
amplitude modulation depth 
(Range: 0 to 49.9%)
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2. Press COM/ID 
(Default is COM/ID Off.)

3. Select either COM/ID Off | COM/ID On

When COM/ID is set to Off, all COM/ID functions are turned off and must be set to On before 
any of the other COM/ID parameters have an effect.

To set the COM/ID type between Code or Tone

1. Press Aux Fctn > Avionics > VOR

2. Press COM/ID

3. Press COM/ID Type

4. Select either Code | Tone

Code - When set to Code, the signal generator plays the code associated with the COM/ID Code 
setting.

— To change the COM/ID Code setting, see “To set the COM/ID 3-character code (airport 
identification code)” on page 145

Tone - When set to Tone, the COM/ID Code setting is disabled and the signal generator plays a 
continuous tone based on the COM/ID Frequency setting.

— To change the COM/ID Tone setting, see “To set the COM/ID tone/code modulating frequency” 
on page 146

To set the COM/ID 3-character code (airport identification code)

1. Press Aux Fctn > Avionics > VOR

2. Press COM/ID

3. Press COM/ID Code 
(Default 3-character code is STS.)

4. Select a 3-character code and select Enter.

Enter a valid COM/ID code (airport identification code) by typing a 3-character code (for example, 
STS).

This value sets the airport communication identification code to be played by the COM/ID 
generator. (This value/code may also be referred to as an, 
“airport call-sign”.)

The COM/ID code is transmitted as a three letter-code signal of 1.02000 kHz and is placed on the 
VOR carrier; this COM/ID code is used to identify the VOR ground-based transmitting station.

Each COM/ID code (airport identification code) must correspond to one of the International Air 
Transport Association (IATA) codes.

IATA owns, controls, and has a copyright to the complete list of airport identification codes; STS is 
the airport identification code that refers to the Sonoma County Airport in Santa Rosa, CA, USA.
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To find a valid COM/ID code (airport communication identification code) for a particular area, refer 
to the following websites:

Airline Coding Directory (http://www.iata.org)

AirNav (http://www.airnav.com)

To set the COM/ID tone/code modulating frequency

1. Press Aux Fctn > Avionics > VOR

2. Press COM/ID

3. Press Frequency 
(Default value is 1.02000 kHz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 20 kHz.

Enter a value in Hz to set the frequency of the COM/ID tone modulating frequency.

To set the COM/ID tone AM depth

1. Press Aux Fctn > Avionics > VOR

2. Press COM/ID

3. Press Depth 
(Default value is 10%.)

4. Select a value from 0 to 49.9% and press Enter.

Enter a value in percentage to set the COM/ID tone AM depth.

To set or return the COM/ID parameters to a default state

1. Press Aux Fctn > Avionics > VOR

2. Press COM/ID

3. Press More 1 of 2

4. Press Recall Default Settings
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Selecting these softkeys returns the COM/ID parameters to a set of default state conditions.

Example of Setting All COM/ID Parameters

1. Press Preset to place the signal generator in a known preset state.

2. Set the COM/ID type to Code.

a.Press Aux Fctn > Avionics > VOR

b.Press COM/ID

c.Press COM/ID Type 
(Default setting is Code.)

d.Select Code

3. Set the COM/ID 3-character code (airport identification code).

a.Press COM/ID Code 
(Default 3-character code is STS.)

b.(Optional) Select a 3-character code and select Enter.

To find a valid COM/ID code (airport communication identification code) for a particular 
area, refer to the following websites:

Airline Coding Directory (http://www.iata.org)

AirNav (http://www.airnav.com)

4. Set the COM/ID tone/code modulating frequency.

a.Press Frequency 
(Default value is 1.02000 kHz.)

b.(Optional) Select a <value> from 0 Hz to 20 kHz.

5. Set the COM/ID tone AM depth. 

a.Press Depth 
(Default value is 10%.)

b.(Optional) Select a <value> from 0 to 49.9% and press Enter.

6. Set the COM/ID mode to on.

COM/ID Menu Parameters Default State

COM/ID Off/On Off

COM/ID Code/Type Code

COM/ID Code STS

Frequency 1.02000 kHz

Depth 10.0%
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a.Press COM/ID 
(Default is COM/ID Off.)

b.Select COM/ID On

7. Set modulation to on.

a.Press MOD On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is on).

8. Set a desired RF power level.

a.Press Amptd 
(Default value is around -144 dBm, and depends on the signal generator model being 
used, so the signal may be very low and hard to find if you do not specify a high enough 
power level.)

b.Select a value from -20 dBm to -40 dBm.

9. Set RF output to on.

a.Press RF On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is off).

10.Verify that all settings are as expected on the signal generator display.

a.Press Aux Fctn > Avionics > VOR

b.Review the settings on the right-side of the display.
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Using ILS Localizer Softkeys
An ILS [Instrument Landing System] is a navigation system, used by aircraft to obtain guidance to a 
runway (performing a “runway approach” while attempting to land the aircraft) and includes the 
following three functions operating in tandem (working together):

— ILS Localizer - ensures that the lateral/horizontal left-right approach of an aircraft is aligned 
with the center of a runway

— ILS Glide Slope - ensures that the vertical descent path of an aircraft is aligned to the proper 
descent path (~ 3 degrees downwards slope) of a runway

— ILS Marker Beacons - ensures the proper distance from a runway; the distances are based on 
the Outer, Middle, and Inner ILS Marker Beacons

The purpose of the ILS Localizer is to provide signals that indicate whether an aircraft is left, right, 
or in-line with the glide path to a runway and enables a pilot to adjust the aircraft left or right 
correctly during landing. This lateral/horizontal correction is performed using two AM signals with 
an AM depth of 20%, operating at a carrier frequency range between 108.10 to 111.95 MHz.

For an aircraft on approach, using the ILS Localizer to land on a runway, the left signal is modulated 
at a frequency of 90 Hz AM by default and the right signal is modulated at a frequency of 150 Hz 
AM by default.

The primary mechanism which makes it possible for a pilot to obtain guidance to a runway is the 
aircraft receiver's ability to detect the “Difference in Depth of Modulation (DDM)” between this 90 
Hz and 150 Hz amplitude modulation.
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Figure 5-6 ILS Localizer: 108.10 MHz w/ 90 Hz AM (Left), 150 Hz AM (Right) @ 20% 

Figure 5-7 ILS Glide Slope: 334.70 MHz w/ 90 Hz AM (Up), 150 Hz AM (Down) @ 40% 

Figure 5-8 ILS Marker Beacons: 75 MHz, Inner 3000 Hz, Middle 1300 Hz, Outer 400 Hz 
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Figure 5-9 ILS Localizer Softkeys

When testing an ILS [Instrument Landing System], 
the following ILS Localizer parameters can be set:

To set the ILS Localizer mode to produce a full or partial signal

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press ILS LOC Mode 
(Default selection is OFF.)

ILS Localizer Menu Parameters Default State

ILS LOC Mode OFF

Carrier Freq Index 1 108.10 MHz

Left/Right menu Left Frequency 90 Hz

Right Frequency 150 Hz

Left/Right Phase 0.00 deg

DDM/SDM menu Fly Left/Right None

DDM 0.0000

DDM uA 0.0 uA

DDM% 0.00%

SDM 40.0%

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.

- Sets Right Frequency
-Sets DDM Polarity 
Left | Right | In-line

- Sets DDM (Difference 
in Depth of Modulation)

- Sets DDM in uA

- Sets DDM in %. 
DDM of 1% is 
equivalent to 0.001 
- Sets the Sum of 
Depth of Modulation

- Sets the Phase of the 
Right signal relative to 
the Left signal

- Turns off the Left (90 Hz) 
and Right (150 Hz) 
ILS Localizer signals
- Turns on the Left (90 Hz) 
and Right (150 Hz) 
ILS Localizer signals
- Turns off the Left (90 Hz) 
ILS Localizer signal

- Turns off the Right (150 Hz) 
ILS Localizer signal

- Sets Left Frequency

- Sets a Carrier Frequency by selecting an Index from 1 to 40. 
(Default: Index is 1 and corresponds to 108.10 MHz)
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3. Select either: OFF | NORM | Suppress Left | Suppress Right

These softkeys allow selection of a complete or partial ILS Localizer signal and can set the ILS 
Localizer Mode to one of the following:

— Selecting OFF turns off both the Left (90 Hz) and the Right (150 Hz) ILS Localizer signals. When 
set to OFF, all ILS Localizer mode parameter settings are turned off, but the selected ILS 
Localizer carrier is still present on the RF Output connector. To turn off this ILS Localizer carrier, 
set RF Off/On to Off.

— Selecting NORM turns on both the Left (90 Hz) and the Right (150 Hz) ILS Localizer signals.

— Selecting Suppress Left turns off the Left (90 Hz) ILS Localizer signal.

— Selecting Suppress Right turns off the Right (150 Hz) ILS Localizer signal. 

To set the ILS Localizer carrier frequency

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press Carrier Freq Index 
(Default value is 1 and corresponds to 108.10 MHz.)

3. Select a value from 1 to 40 (108.10 to 111.95 MHz) and press Enter.

These softkeys set a carrier index between 1 and 40. 
Each index corresponds to a standard defined ILS Localizer carrier channel in the range from 
108.10 to 111.95 MHz.

There are forty channels that are allocated to the ILS Localizer in the range from 108.10 to 111.95 
MHz; each ILS Localizer carrier has a corresponding ILS Glide Slope carrier frequency in the range 
from 329.15 to 335.00 MHz.

The default ILS Localizer carrier frequency Index is 1 and corresponds to 108.10 MHz.

ILS Localizer and Corresponding ILS Glide Slope 
Carrier Frequencies (MHz)

ILS Localizer 
(MHz)   Index 
1-20

ILS Glide 
Slope 
(MHz)   Index 
1-20

ILS Localizer 
(MHz) 
Index 21-40

ILS Glide 
Slope 
(MHz)   Index 
21-40

1=108.10 1=334.70 21=110.10 21=334.40

2=108.15 2=334.55 22=110.15 22=334.25

3=108.30 3=334.10 23=110.30 23=335.00

4=108.35 4=333.95 24=110.35 24=334.85

5=108.50 5=329.90 25=110.50 25=329.60

6=108.55 6=329.75 26=110.55 26=329.45

7=108.70 7=330.50 27=110.70 27=330.20

8=108.75 8=330.35 28=110.75 28=330.05
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To set the ILS Localizer left frequency

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press Left/Right

3. Press Left Frequency 
(Default value is 90 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 6 MHz.

These softkeys set the frequency of the Left ILS Localizer signal.

To set the ILS Localizer right frequency

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press Left/Right

3. Press Right Frequency 
(Default value is 150 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

These softkeys set the frequency of the Right ILS Localizer signal.

To set the ILS Localizer phase of the right signal relative to the left

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press Left/Right Phase 
(Default value is 0.00 deg.)

3. Select a value from 0.00 deg to 360 deg and press Enter.

9=108.90 9=329.30 29=110.90 29=330.80

10=108.95 10=329.15 30=110.95 30=330.65

11=109.10 11=331.40 31=111.10 31=331.70

12=109.15 12=331.25 32=111.15 32=331.55

13=109.30 13=332.00 33=111.30 33=332.30

14=109.35 14=331.85 34=111.35 34=332.15

15=109.50 15=332.60 35=111.50 35=332.90

16=109.55 16=332.45 36=111.55 36=332.75

17=109.70 17=333.20 37=111.70 37=333.50

18=109.75 18=333.05 38=111.75 38=333.35

19=109.90 19=333.80 39=111.90 39=331.10

20=109.95 20=333.65 40=111.95 40=330.95



 154                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

  Avionics VOR/ILS (Option N5180302B)
Using ILS Localizer Softkeys

These softkeys set the phase of the right (150 Hz) ILS Localizer signal relative to the left (90 Hz) ILS 
Localizer signal.

To set the ILS Localizer DDM polarity to fly left or fly right

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press DDM/SDM

3. Press Fly Left | Right 
(Default selection is Left.)

4. Select either Left | Right

These softkeys set the “Difference in Depth of Modulation” (DDM) 
polarity of the ILS Localizer signal to either: 

LEFT = positive | RIGHT = negative

The ILS Localizer provides signals that indicate whether an aircraft is Left, Right, or in-line with the 
glide path to the runway and enables a pilot to adjust the aircraft Left or Right correctly during 
landing. This lateral/horizontal correction is performed using two AM carriers with an AM depth of 
20%, operating at a carrier frequency range between 108.10 - 111.95 MHz.

For an aircraft on approach, the left signal is modulated at a frequency of 90 Hz by default, and the 
right signal is modulated at a frequency of 150 Hz by default. When an aircraft is in-line with the 
glide path to the runway, the amplitude of the 90 Hz and 150 Hz sine-wave signals are equal. Left 
or right of this glide path, the amplitudes are different.The difference in amplitude can determine 
the relative position of an aircraft from this theoretical glide path.

The primary mechanism which makes it possible for a pilot to obtain guidance to a runway is the 
aircraft receiver's ability to detect the “Difference in Depth of Modulation (DDM)” between the 90 
Hz modulation and the 150 Hz modulation.

DDM is defined to be the “percentage modulation depth of the larger signal” minus the “percentage 
modulation depth of the smaller signal”, divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

When this formula yields a negative DDM value, the right signal at 150 Hz is stronger; this is 
indicating that the aircraft is to the Right of the ILS Localizer

centerline signal and would have to Fly “Left” to bring the DDM value back to zero so that the 
aircraft is back in-line with the centerline of the runway.
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Figure 5-10 ILS Localizer @ 108.10 MHz w/ Aircraft In-Line, Fly Left, Fly Right
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Example:

To correct if the left signal at 90 Hz is stronger at 0.2 DDM, the 
aircraft would have to be pointed Right with a DDM of 0.2. 

The following steps of key presses demonstrate the correction for Right:

1.Aux Fctn > Avionics.

2.ILS Localizer > DDM/SDM > Fly Left Right to Right highlighted.

3. DDM > 0.2 > Enter.

Example:

To correct if the right signal at 150 Hz is stronger at –0.2 DDM, 
the aircraft would have to be pointed Left with a DDM of –0.2 

The following steps of key presses demonstrate the correction for Left:

1.Aux Fctn > Avionics.

2.ILS Localizer > DDM/SDM > Fly Left Right to Left highlighted.

3. DDM > –0.2 > Enter.

To set the ILS Localizer DDM value

This process sets a value for the Difference in Depth of Modulation (DDM).

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press DDM/SDM

3. Press DDM 
(Default value is 0.0000.)

4. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (–0.40 to 0.40) for most applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is available. The following 
demonstrates the limits of DDM’s range:

(–SDM/100) to (SDM/100)

As SDM’s value increases or decrease, so does DDM’s range.

DDM is defined to be the “percentage modulation depth of the larger signal” minus the “percentage 
modulation depth of the smaller signal”, divided by 100.

DDM = [AM(90 Hz)% – AM(150 Hz)%] / 100

The primary mechanism which makes it possible for a pilot to obtain guidance to a runway is the 
aircraft receiver's ability to detect the DDM between the 90 Hz and 150 Hz amplitude modulation.
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To set the ILS Localizer DDM value in micro-amps (μA)

This process sets a value for the difference in depth of modulation (DDM) 
in μA.

1. Press Aux Fctn > Avionics > ILS Localizer.

2. Press DDM/SDM.

3. Press DDM uA

4. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range for most applications.

If SDM is set to 99%, then the full range (–958.1 to 958.1 μA) of DDM uA is available. The 
following demonstrates the limits of DDM uA’s range:

((–SDM/100)*(150/.155)) to ((SDM/100)*(150/.155))

As SDM’s value increases or decrease, so does the range.

The DDM  uA default value is 0.0 uA.

To set the ILS Localizer DDM value as a percentage (%)

This process sets a value for the difference in depth of modulation (DDM) 
in %. DDM can be expressed either in terms of percentage (%) or as a modulation index. A DDM of 
1% is equivalent to 0.01 DDM.

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press DDM/SDM

3. Press DDM% 
(Default value is 0.00%.)

4. Enter a value within the range of the current SDM value.

Typically the SDM default value provides sufficient range (–40% to 40%) for most applications.

If SDM is set to 99%, then the full range (-99% to 99%) of DDM is available. The following 
demonstrates the limits of DDM’s range:

(-SDM) to (SDM)

As SDM’s value increases or decrease, so does DDM’s range.

To set the ILS Localizer SDM value

This process sets the sum of depth of modulation (SDM):

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press DDM/SDM

3. Press SDM
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(Default value is 40.00%.)

4. Select a value from 0 to 99% and press Enter.

The SDM range is defined by the following equation:

SDM = [AM(90 Hz) + AM(150 Hz)] / 100:

To set or return the ILS Localizer parameters to a default state

This process returns the ILS Localizer parameters to a set of default state conditions.

1. Press Aux Fctn > Avionics > ILS Localizer

2. Press More 1 of 2

3. Press Recall Default Settings

The following table lists the default values:

ILS Localizer Menu Parameters Default State

ILS LOC Mode OFF

Carrier Freq Index 1 108.1 MHz

Left/Right menu Left Frequency 90 Hz

Right Frequency 150 Hz

Left/Right Phase 0.00 deg

DDM/SDM menu Fly Left/Right Left

DDM 0.0000

DDM uA 0.0 uA

DDM% 0.00%

SDM 40.0%

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.
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Example of Setting All ILS Localizer Parameters

1. Press Preset to place the signal generator in a known preset state.

2. Set the ILS Localizer carrier frequency.

a.Press Aux Fctn > Avionics > ILS Localizer

b.Press Carrier Freq Index 
(Default value is 1 and corresponds to 108.10 MHz carrier frequency.)

c.(Optional) Select a value from 1 to 40 and press Enter 
to change to a different carrier frequency.

3. Set the ILS Localizer left frequency. 

a.Press Left/Right

b.Press Left Frequency 
(Default value is 90 Hz.)

c.(Optional) Select a <value> from 0 Hz to 6 MHz.

4. Set the ILS Localizer right frequency.

a.Press Right Frequency 
(Default value is 150 Hz.)

b.(Optional) Select a <value> from 0 Hz to 10 MHz.

5. Set the ILS Localizer phase of the right signal relative to the left.

a.Press Left/Right Phase 
(Default value is 0.00 deg.)

b.(Optional) Select a <value> from 0.00 deg to 360 deg and press Enter.

6. Set the ILS Localizer DDM polarity to fly left or fly right.

a.Press Return

b.Press DDM/SDM

c.Press Fly Left | Right 
(Default selection is Left.)

d.(Optional) Select either Left | Right

7. Set the ILS Localizer DDM value.

a.Press DDM 
(Default value is 0.0000)

b.Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (–0.40 to 0.40) for most 
applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is available. The 
following demonstrates the limits of DDM’s range:
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(–SDM/100) to (SDM/100)

As SDM’s value increases or decrease, so does DDM’s range.

8. Set the ILS Localizer SDM value.

a.Press SDM 
(Default value is 40.00%.)

b.(Optional) Select a <value> from 0 to 99% and press Enter.

9. Set the ILS Localizer mode.

a.Press ILS LOC Mode 
(Default selection is OFF.)

b.Select NORM to turn on both the Left (90 Hz) and the Right (150 Hz) ILS Localizer signals.

10.Set the modulation to on.

a.Press MOD On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is on).

11.Set a desired RF power level.

a.Press Amptd 
(Default power level is around -144 dBm, and depends on the signal generator model 
being used, so the signal may be very low and hard to find if you do not specify a high 
enough power level.)

b.Select a value from -20 dBm to -40 dBm.

12.Set the RF output to on

a.Press RF On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is off).

13.Verify that all settings are as expected on the signal generator display.

a.Press Aux Fctn > Avionics > ILS Localizer

b.Review the settings under 
ILS-LOC Status Information
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Using ILS Glide Slope Softkeys
An ILS [Instrument Landing System] is a navigation system, used by aircraft to obtain guidance to a 
runway (performing a “runway approach” while attempting to land the aircraft) and includes the 
following three functions operating in tandem (working together):

— ILS Localizer - ensures that the lateral/horizontal left-right approach of an aircraft is aligned 
with the center of a runway

— ILS Glide Slope - ensures that the vertical descent path of an aircraft is aligned to the proper 
descent path (~ 3 degrees downwards slope) of a runway

— ILS Marker Beacons - ensures the proper distance from a runway; the distances are based on 
the Outer, Middle, and Inner ILS Marker Beacons

The purpose of the ILS Glide Slope is to provide signals that indicate whether an aircraft is above, 
below, or in-line with the glide path to a runway and enables a pilot to adjust the aircraft up or 
down correctly during landing. This is the same type of information as provided by the ILS Localizer, 
but for the vertical reference rather than the lateral/horizontal reference; the same modulation and 
antenna techniques are used. This vertical correction is performed using two AM signals with an 
AM depth of 40%, operating at a carrier frequency range between 329.90 to 334.70 MHz.

For an aircraft on approach, using the ILS Glide Slope to land on a runway, the upper signal is 
modulated at a frequency of 90 Hz AM by default, and the lower signal is modulated at a frequency 
of 150 Hz AM by default.

The primary mechanism which makes it possible for a pilot to obtain guidance to a runway is the 
aircraft receiver's ability to detect the “Difference in Depth of Modulation (DDM)” between this 90 
Hz and 150 Hz amplitude modulation.
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Figure 5-11 ILS Localizer: 108.10 MHz w/ 90 Hz AM (Left), 150 Hz AM (Right) @ 20% 

Figure 5-12 ILS Glide Slope: 334.70 MHz w/ 90 Hz AM (Up), 150 Hz AM (Down) @ 40% 

Figure 5-13 ILS Marker Beacons: 75 MHz, Inner 3000 Hz, Middle 1300 Hz, Outer 400 Hz 
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Figure 5-14 ILS Glide Slope Softkeys

When testing an ILS [Instrument Landing System], 
the following ILS Glide Slope parameters can be set:

ILS Glide Slope Menu Parameters Default State

ILS GS Mode OFF

Carrier Freq Index 1 334.70 MHz

Up/Down menu Up Frequency 90 Hz

Down Frequency 150 Hz

Up/Down Phase 0.00 deg

DDM/SDM menu Fly Up/Down Up

DDM 0.0000

DDM uA 0.0 uA

DDM% 0.00%

SDM 80.0%

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.

- Sets DDM Polarity 
Up | Down | In-line

- Sets DDM (Difference 
in Depth of Modulation)

- Sets DDM in uA

- Sets DDM in %. 
DDM of 1% is 
equivalent to 0.001
- Sets the Sum of 
Depth of Modulation

- Turns off the Up (90 Hz) 
and Down (150 Hz) 
ILS Glide Slope signals
- Turns on the Up (90 Hz) 
and Down (150 Hz) 
ILS Glide Slope signals
- Turns off the Up (90 Hz) 
ILS Glide Slope signal

- Turns off Down (150 Hz) 
ILS Glide Slope signal

- Sets the Frequency of 
the Down signal

- Sets the Phase of the 
Down signal relative to 
the Up signal

- Sets the Frequency of 
the Up signal

- Sets a Carrier Frequency by selecting an Index from 1 to 40. 
(Default: Index is 1 and corresponds to 334.70 MHz)
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To set the ILS Glide Slope mode to produce a full or partial signal

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press ILS GS Mode 
(Default selection is OFF.)

3. Select either: OFF | NORM | Suppress Up | Suppress Down

These softkeys allow selection of a complete or partial ILS Glide Slope signal and can set the ILS 
Glide Slope Mode to one of the following:

— Selecting OFF turns off all ILS Glide Slope signals. When set to OFF, all ILS Glide Slope mode 
parameter settings are turned off, but the selected ILS Glide Slope carrier is still present on the 
RF Output connector. To turn off this ILS Glide Slope carrier, set RF Off/On to Off.

— Selecting NORM turns on both Up (90 Hz) and Down (150 Hz) ILS Glide Slope signals.

— Selecting Suppress Up turns off the Up (90 Hz) ILS Glide Slope signal.

— Selecting Suppress Down turns off the Down (150 Hz) ILS Glide Slope signal.

To set the ILS Glide Slope carrier frequency

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press Carrier Freq Index 
(Default value is 1 and corresponds to 334.70 MHz.)

3. Select a value from 1 to 40 (see table) and press Enter.

There are forty channels that are allocated to the ILS Localizer in the range from 108.10 to 111.95 
MHz; each ILS Localizer carrier has a corresponding ILS Glide Slope carrier frequency in the range 
from 329.15 to 335.00 MHz.

The default ILS Glide Slope carrier frequency Index is 1 and corresponds to 334.70 MHz.

ILS Localizer and Corresponding ILS Glide Slope 
Carrier Frequencies (MHz)

ILS Localizer 
Index 1-20

ILS Glide 
Slope 
Index 1-20

ILS Localizer 
Index 21-40

ILS Glide 
Slope 
Index 21-40

1=108.10 1=334.70 21=110.10 21=334.40

2=108.15 2=334.55 22=110.15 22=334.25

3=108.30 3=334.10 23=110.30 23=335.00

4=108.35 4=333.95 24=110.35 24=334.85

5=108.50 5=329.90 25=110.50 25=329.60

6=108.55 6=329.75 26=110.55 26=329.45

7=108.70 7=330.50 27=110.70 27=330.20
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To set the ILS Glide Slope up frequency

This process sets the ILS Glide Slope up frequency.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press Up/Down

3. Press Up Frequency 
(Default value is 90 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 6 MHz.

To set the ILS Glide Slope down frequency

This process sets the ILS Glide Slope down frequency.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press Up/Down

3. Press Down Frequency 
(Default value is 150 Hz.)

4. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

8=108.75 8=330.35 28=110.75 28=330.05

9=108.90 9=329.30 29=110.90 29=330.80

10=108.95 10=329.15 30=110.95 30=330.65

11=109.10 11=331.40 31=111.10 31=331.70

12=109.15 12=331.25 32=111.15 32=331.55

13=109.30 13=332.00 33=111.30 33=332.30

14=109.35 14=331.85 34=111.35 34=332.15

15=109.50 15=332.60 35=111.50 35=332.90

16=109.55 16=332.45 36=111.55 36=332.75

17=109.70 17=333.20 37=111.70 37=333.50

18=109.75 18=333.05 38=111.75 38=333.35

19=109.90 19=333.80 39=111.90 39=331.10

20=109.95 20=333.65 40=111.95 40=330.95
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To set the ILS Glide Slope phase of the down signal relative to the up

This process sets the phase of the Down (150 Hz) ILS Glide Slope signal relative to the Up (90 Hz) 
ILS Glide Slope signal.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press Up/Down Phase 
(Default value is 0.00 deg.)

3. Select a value from 0.00 deg to 360 deg and press Enter.

To set the ILS Glide Slope DDM polarity to fly up or fly down

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press DDM/SDM

3. Press Fly Up | Down 
(Default selection is Up.)

4. Select either Up | Down

The ILS Glide Slope enables a pilot to adjust the aircraft up or down correctly during landing.

The ILS Glide Slope provides signals that indicate whether an aircraft is above, below, or in-line 
with the glide path to the runway and enables a pilot to adjust the aircraft Up or Down correctly 
during landing.

This is the same type of information as provided by the ILS Localizer, but for the vertical reference 
rather than the lateral/horizontal reference; the same modulation and antenna techniques are 
used.

This vertical adjustment is performed using two AM signals with an AM depth of 40% operating at a 
carrier frequency range between 329.90 to 334.70 MHz. 

For aircraft approach, the upper signal is modulated at a frequency of 90 Hz AM by default, and the 
lower signal is modulated at a frequency of 150 Hz AM by default.

The primary mechanism which makes it possible for a pilot to obtain guidance to a runway is the 
aircraft receiver's ability to detect the “Difference in Depth of Modulation (DDM)” between the 90 
Hz and the 150 Hz amplitude modulation.

DDM is defined to be the “percentage modulation depth of the larger signal” minus the “percentage 
modulation depth of the smaller signal”, divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

When this formula yields a positive DDM value, the upper signal at 90 Hz is stronger; this is 
indicating that the aircraft is Above the ILS Glide Slope  
centerline signal and would have to Fly “Down” to bring the DDM value back to zero so that the 
aircraft is back in-line with the centerline of the runway.
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Figure 5-15 ILS Glide Slope @ 334.70 MHz w/ Aircraft In-Line, Fly Down, Fly Up

Example:

To correct if the upper tone at 90 Hz is stronger at 0.4 DDM, the aircraft 
 would have to fly Down with a DDM of 0.4. 

The following steps of key presses demonstrate the fly Down correction:

1.Aux Fctn > Avionics.

2.ILS Glide Slope > DDM/SDM > Fly Up Down to Down highlighted.

3. DDM > 0.4 > Enter.

Example:

To correct if the upper tone at 150 Hz is stronger at –0.4 DDM, the aircraft 
 would have to fly Up with a DDM of –0.4. 

The following steps of key presses demonstrate the fly Up correction:

1.Aux Fctn > Avionics.

2.ILS Glide Slope > DDM/SDM > Fly Up Down to Up highlighted.
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3. DDM > –0.4 > Enter.

To set the ILS Glide Slope DDM value

This process sets a value for the “Difference in Depth of Modulation” (DDM).

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press DDM/SDM

3. Press DDM 
(Default value is 0.0000.)

4. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (–0.80 to 0.80) for most applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is available. The following 
demonstrates the limits of DDM’s range:

(–SDM/100) to (SDM/100)

As SDM’s value increases or decrease, so does DDM’s range.

The primary mechanism which makes it possible for a pilot to obtain guidance to a runway is the 
aircraft receiver's ability to detect the “Difference in Depth of Modulation (DDM)” between this 90 
Hz and 150 Hz amplitude modulation.

DDM is defined to be the “percentage modulation depth of the larger signal” minus the “percentage 
modulation depth of the smaller signal”, divided by 100.

DDM = [AM(90 Hz)% - AM(150 Hz)%] / 100

To set the ILS Glide Slope DDM value in micro-amps (μA)

This process sets a value for the difference in depth of modulation (DDM) expressed in μA.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press DDM/SDM

3. Press DDM uA 
(Default value is 0.0 μA.)

4. Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range for most applications.

If SDM is set to 99%, then the full range (–846.6 to 846.6 μA) of DDM uA is available. The 
following demonstrates the limits of DDM uA’s range:

((–SDM/100)*(150/.175)) to ((SDM/100)*(150/.175))

As SDM’s value increases or decrease, so does the range.
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To set the ILS Glide Slope DDM value in percentage (%)

This process sets a value for the difference in depth of modulation (DDM) 
in %. DDM can be expressed either in terms of percentage (%) or as a modulation index. A DDM of 
1% is equivalent to 0.01 DDM.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press DDM/SDM

3. Press DDM% 
(Default value is 0.00%.)

4. Enter a value within the range of the current SDM value.

Typically the SDM default value provides sufficient range (–80% to 80%) for most applications.

If SDM is set to 99%, then the full range (-99% to 99%) of DDM is available. The following 
demonstrates the limits of DDM’s range:

(-SDM) to (SDM)

As SDM’s value increases or decrease, so does DDM’s range.

To set the ILS Glide Slope SDM value

This process sets the sum of depth of modulation (SDM):

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press DDM/SDM

3. Press SDM

4. Select a value from 0 to 99% and press Enter. 
(Default value is 80%.)

The SDM value is calculated using the following equation:

SDM = [AM(90 Hz) + AM(150 Hz)] / 100

To set or return the ILS Glide Slope parameters to a default state

This process returns the ILS Glide Slope parameters 
to a set of default state conditions.

1. Press Aux Fctn > Avionics > ILS Glide Slope

2. Press More 1 of 2

3. Press Recall Default Settings
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Example of Setting All ILS Glide Slope Parameters

1. Press Preset to place the signal generator in a known preset state.

2. Set the ILS Glide Slope carrier frequency.

a.Press Aux Fctn > Avionics > ILS Glide Slope

b.Press Carrier Freq Index 
(Default value is 1 and corresponds to 334.70 MHz.)

c.(Optional) Select a <value> from 1 to 40 and press Enter to change to a different carrier 
frequency.)

3. Set the ILS Glide Slope up frequency.

a.Press Up/Down

b.Press Up Frequency 
(Default value is 90 Hz.)

c.(Optional) Select a <value> from 0 Hz to 6 MHz.

4. Set the ILS Glide Slope down frequency. 

a.Press Down Frequency 
(Default value is 150 Hz.)

b.(Optional) Select a <value> from 0 Hz to 10 MHz.

ILS Glide Slope Menu Parameters Default State

ILS GS Mode OFF

Carrier Freq Index 1 334.70 MHz

Up/Down menu Up Frequency 90 Hz

Down Frequency 150 Hz

Up/Down Phase 0.00 deg

DDM/SDM menu Fly Up/Down Up

DDM 0.0000

DDM uA 0.0 uA

DDM% 0.00%

SDM 80.0%

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.
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5. Set the ILS Glide Slope phase of the down signal relative to the up.

a.Press Up/Down Phase 
(Default value is 0.00 deg.)

b.(Optional) Select a <value> from 0.00 deg to 360 deg and press Enter.

6. Set the ILS Glide Slope DDM polarity to fly up or fly down.

a.Press Return

b.Press DDM/SDM

c.Press Fly Up | Down 
(Default selection is Up.)

d.(Optional) Select either Up | Down

7. Set the ILS Glide Slope DDM value.

a.Press DDM 
(Default value is 0.0000.)

b.Enter a value that is within the range of the current SDM value.

Typically the SDM default value provides sufficient range (–0.80 to 0.80) for most 
applications.

If SDM is set to 99%, then the full range (-0.99 to 0.99) of DDM is available. The 
following demonstrates the limits of DDM’s range:

(–SDM/100) to (SDM/100)

As SDM’s value increases or decrease, so does DDM’s range.

8. Set the ILS Glide Slope SDM value.

a.Press SDM 
(Default value is 80%.)

b.(Optional) Select a <value> from 0 to 99% and press Enter.

9. Set the ILS Glide Slope mode.

a.Press ILS GS Mode 
(Default selection is OFF.)

b.Select NORM to turn on both the Up (90 Hz) and Down (150 Hz) ILS Glide Slope signals.

10.Set the modulation to on.

a.Press MOD On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is on).

11.Set a desired RF power level.

a.Press Amptd 
(Default power level is around -144 dBm, and depends on the signal generator model 
being used, so the signal may be very low and hard to find if you do not specify a high 
enough power level.)



 172                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

  Avionics VOR/ILS (Option N5180302B)
Using ILS Glide Slope Softkeys

b.Select a value from -20 dBm to -40 dBm.

12.Set the RF output to on.

a.Press RF On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is off).

13.Verify that all settings are as expected on the signal generator display.

a.Press Aux Fctn > Avionics > ILS Glide Slope

b.Review the settings under 
ILS-GS Status Information
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Using ILS Marker Beacon Softkeys
An ILS [Instrument Landing System] is a navigation system, used by aircraft to obtain guidance to a 
runway (performing a “runway approach”) and includes the following three functions operating in 
tandem (working together):

— ILS Localizer - ensures that the lateral/horizontal left-right approach of an aircraft is aligned 
with the center of a runway

— ILS Glide Slope - ensures that the vertical descent path of an aircraft is aligned to the proper 
descent path (~ 3 degrees downwards slope) of a runway

— ILS Marker Beacons - ensures the proper distance from a runway; the distances are based on 
the Outer, Middle, and Inner ILS Marker Beacons

Marker Beacons are used to alert a pilot that an action is needed, such as checking the aircraft 
altitude. Marker Beacon information is presented to pilots by audio and visual information. The ILS 
Localizer may contain present information on the Outer, Middle, and Inner ILS Marker Beacons. All 
ILS Marker Beacons are broadcast at 75 MHz and are located at specific intervals along an ILS 
approach. Each ILS Marker Beacon is identified by specific audio as well as visual characteristics.

Figure 5-16 ILS Marker Beacon Softkeys

When testing an ILS [Instrument Landing System], the following ILS Marker Beacon parameters 
can be set:

ILS Marker Beacon Code Color Sound

Outer Marker _ _ _ Blue 400 Hz 
two dashes per second

Middle Marker ._._._ Amber 1300 Hz 
alternating dot and dash

Inner Marker . . . . White 3000 Hz 
dots only

- Turns on and simulates 
the Inner Marker Beacon 
(3000 Hz modulation)
- Turns on and simulates 
the Middle Marker Beacon 
(1300 Hz modulation)
- Turns on and simulates 
the Outer Marker Beacon 
(400 Hz modulation)

- Sets a Carrier Frequency by selecting an Index from 1 to 33. 
(Default: Index is 17 and corresponds to 75.000 MHz)

- Sets the selected Marker Beacon, different from nominal: 
Inner=3000 Hz, Middle=1300 Hz, Outer=400 Hz 
(Range: 0 Hz to 10 MHz)

- Sets the amplitude modulation depth 
on the Marker Beacon Carrier. 
(Range: 0 to 99%)

- Turns off all 
Marker Beacon signals
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To set the ILS Marker Beacon mode to off, inner, middle, or outer

This process selects a Marker Beacon Mode and can be one of the following:

1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Marker Beacon 
(Default selection is Off.)

3. Select either: Off | Inner | Middle | Outer

— Selecting Off turns off all Marker Beacon signals. When set to Off, all Marker Beacon parameter 
settings are turned off.

— Selecting Inner turns on and simulates the Inner Marker Beacon (nominal 3000 Hz modulation) 
signal.

— Selecting Middle turns on and simulates the Middle Marker Beacon (nominal 1300 Hz 
modulation) signal.

— Selecting Outer turns on and simulates the Outer Marker Beacon (nominal 400 Hz modulation) 
signal.

To set the ILS Marker Beacon carrier frequency

This process sets the carrier frequency for the three Marker Beacons: 
Inner, Middle, and Outer.

1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Carrier Freq Index 
(Default value is 17 and corresponds to 75.000 MHz.)

3. Select a value from 1 to 33 and press Enter.

ILS Marker Beacon Menu Parameters Default State

Marker Beacon mode Off

Carrier Freq Index 17 75.0 MHz

Marker Freq 400 Hz Outer

Marker Depth 95.0% Up

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.

Setting the mode back to OFF, after selecting one of the other modes 
(either: Inner | Middle | Outer) does not turn off the Marker Beacon carrier, specified by 
Carrier Freq Index, it is still present on the RF Output of the signal generator. 
 
To turn off this ILS Marker Beacon carrier, set RF Off/On to Off.
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The default ILS Marker Beacon carrier frequency Index is 17 and corresponds to 75.000 MHz.

To set the ILS Marker Beacon AM depth

This process sets the AM depth on the Marker Beacon carrier.

1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Marker Depth 
(Default value is 95%.)

3. Select a value from 0 to 99.9% and press Enter.

To set the ILS Marker Beacon inner marker frequency

This process sets the frequency for the Inner Marker Beacon.

1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Marker Beacon

3. Press Inner

4. Press Marker Freq 
(Default value is 3000 Hz.)

5. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

To set the ILS Marker Beacon middle marker frequency

This process sets the frequency for the Middle Marker Beacon.

1. Press Aux Fctn > Avionics > Marker Beacon

ILS Marker Beacon Carrier Frequencies (Index = 1 to 33)

1=74.600 12=74.875 23=75.150

2=74.625 13=74.900 24=75.175

3=74.650 14=74.925 25=75.200

4=74.675 15=74.950 26=75.225

5=74.700 16=74.975 27=75.250

6=74.725 17=75.000 28=75.275

7=74.750 18=75.025 29=75.300

8=74.775 19=75.050 30=75.325

9=74.800 20=75.075 31=75.350

10=74.825 21=75.100 32=75.375

11=74.850 22=75.125 33=75.400
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2. Press Marker Beacon

3. Press Middle

4. Press Marker Freq 
(Default value is 1300 Hz.)

5. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

To set the ILS Marker Beacon outer marker frequency

This process sets the frequency for the Outer Marker Beacon.

1. Press Aux Fctn > Avionics > Marker Beacon

2. Press Marker Beacon

3. Press Outer

4. Press Marker Freq 
(Default value is 400 Hz.)

5. Select a value in Hz | kHz | MHz | GHz from 0 Hz to 10 MHz.

To set or return the ILS Marker Beacon parameters to a default state

This process returns the ILS Marker Beacon parameters to a set of default state conditions.

1. Press Aux Fctn > Avionics > Marker Beacon

2. Press More 1 of 2

3. Press Recall Default Settings

ILS Marker Beacon Menu Parameters Default State

Marker Beacon mode Off

Carrier Freq Index 17 75.0 MHz

Marker Freq 400 Hz Outer

Marker Depth 95.0% Up

COM/ID menua

a. For information on the COM/ID menu, 
refer to “Using COM/ID Softkeys” on page 144.
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Example of Setting All ILS Marker Beacon Parameters

1. Press Preset to place the signal generator in a known preset state.

2. Set the ILS Marker Beacon mode to inner, middle, or outer mode.

a.Press Aux Fctn > Avionics > Marker Beacon

b.Press Marker Beacon 
(Default selection is Off.)

c.Select either: Inner | Middle | Outer

3. Set the ILS Marker Beacon carrier frequency.

a.Press Carrier Freq Index 
(Default value is 17 and corresponds to 75.000 MHz.)

b.(Optional) Select a <value> from 1 to 33 and press Enter to change to a different carrier 
frequency.

4. Set the ILS Marker Beacon AM depth.

a.Press Marker Depth 
(Default value is 95%.)

b.(Optional) Select a value from 0 to 99.9% and press Enter.

5. (Optional, if Inner was selected in step 2 above.) 
Set the ILS Marker Beacon inner marker frequency.

a.Press Marker Beacon

b.Press Inner

c.Press Marker Freq 
(Default value is 3000 Hz.)

d.(Optional) Select a value from 0 Hz to 10 MHz.

6. (Optional, if Middle was selected in step 2 above.) 
Set the ILS Marker Beacon middle marker frequency.

a.Press Marker Beacon

b.Press Middle

c.Press Marker Freq 
(Default value is 1300 Hz.)

d.(Optional) Select a <value> from 0 Hz to 10 MHz.

7. (Optional, if Outer was selected in step 2 above.) 
Set the ILS Marker Beacon outer marker frequency.

a.Press Marker Beacon

b.Press Outer 
(Default value is 400 Hz.)
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c.Press Marker Freq

d.(Optional) Select a <value> from 0 Hz to 10 MHz.

8. Set the modulation to on.

a.Press MOD On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is on).

9. Set a desired RF power level.

a.Press Amptd 
(Default power level is around -144 dBm, and depends on the signal generator model 
being used, so the signal may be very low and hard to find if you do not specify a high 
enough power level.)

b.Select a value from -20 dBm to -40 dBm.

10.Set the RF output to on.

a.Press RF On and verify that the front panel LED is illuminated, indicating that it is on. 
(Default is off).

11.Verify that all settings are as expected on the signal generator display.

a.Press Aux Fctn > Avionics > Marker Beacon

b.Review the settings under 
Marker Beacon Status Information
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Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in 
that chapter.

— Using an Internal Modulation Source on page 182

— Using an External Modulation Source on page 183

— Removing an External Source DC Offset on page 183

— Using Wideband AM on page 184

— Configuring the LF Output (Option 303) on page 185
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Analog Modulation Waveforms
The signal generator can modulate the RF carrier with four types of analog modulation: amplitude, 
frequency, phase, and pulse. For pulse modulation information, refer to Chapter 7, “  Pulse 
Modulation (Options UNW and N5180320B)”, on page  189.

Available internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Triangle  triangle wave with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Pos Ramp  positive going ramp with adjustable amplitude and frequency

Neg Ramp  negative going ramp with adjustable amplitude and frequency

Analog Modulation Sources
The signal generator provides the following internal and external modulation input sources. Internal 
modulation sources generate the five waveforms listed above unless noted otherwise.

Ext1 & Ext2  an externally applied signal is used as the modulation input. Connect the signal to 
the EXT 1 or EXT 2 connector on the rear panel of the instrument.

Func Gen 1  sine wave from the internal function generator. Instruments with Option 303 have 
additional waveform choices listed above.

Func Gen 2  Func Gen 2 has the same capability as Func Gen 1. Available on instruments with 
Option 303.

Dual Func Gen  dual waveforms with individually adjustable frequencies and a percent-of- 
peak-amplitude setting for the second tone. Available on instruments with Option 
303. 

Swept Func Gen  swept waveforms with adjustable start and stop frequencies, sweep time, and 
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2  noise with adjustable amplitude generated as a peak-to-peak value (RMS value is 
approximately 80% of the displayed value). Uniform and Gaussian distribution is 
available. Available on instruments with Option 303.
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Figure 6-1 Analog Modulation Softkeys

page 182page 182 page 182

For details on each key, use key help 
as described on page 60.
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Using an Internal Modulation Source

1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

5. Turn on the modulation:

The appropriate modulation annunciator displays, indicating that you enabled modulation.

6. Turn on the RF output.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 447.

See also “Modulating the Carrier Signal” on page 74.

AM FM  ΦM

a. Press AM
b. Set the AM type (Linear or Exponential):  
   AM Type to highlight desired type.

c. Set the AM Mode (Normal or Deep). 
Default is Deep. To select  Normal 
enable More to highlight desired 
type.   

d. Set the AM Depth:    AM Depth > 
value > unit
e. Set the rate:  
   More > Setup AM Source > 
AM Rate > value > frequency unit

a. Press FM/ΦM

b. Set the deviation:  
   FM Dev > value > 
frequency unit

c. Set the rate:  
   More > Setup FM 
Source > FM Rate > 
value > frequency unit

a. Press FM/ΦM > FM/ΦM 
(ΦM is highlighted)

b. Set the BW (normal or high): 
   FM ΦM to highlight desired 
type

c. Set the deviation:  
   ΦM Dev > value > pi rad

d. Set the rate:  
   More > Setup ΦM 
Source > ΦM Rate > 
value > frequency unit

AM FM  ΦM

AM Off On softkey to On FM Off On softkey to On  ΦM Off On softkey to On
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Using an External Modulation Source 

Removing an External Source DC Offset

To eliminate an offset in an externally applied FM or ΦM signal, perform an external DC calibration 
(Ext DC Cal).

1. Set up and turn on the desired modulation.

2. Press FM/ΦM > FM Source > Ext1 or Ext2 > More > Setup FM Source.

3. Ensure that Ext Coupling is set to DC. 
- If not, press Ext Coupling DC AC until DC is highlighted.

4. Press Ext DC Cal. 

This begins the calibration.

Performing the calibration with a DC signal applied removes any deviation caused by the DC signal, 
and the applied DC level becomes the new zero reference point. When you disconnect the DC 
signal, perform the calibration again to reset the carrier to the correct zero reference.

Rear panel inputs are described on page 30

AM, FM or ΦM inputs
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Using Wideband AM

Wideband AM uses the I input of the I/Q modulation system. When the wideband AM is turned on, 
the I/Q is turned on and the I/Q source is set to external. If the I/Q is turned off or the I/Q source is 
set to internal, then the wideband AM turns off.

Figure 6-2 Wideband AM Softkey Menu

Setting the Wideband AM

1. Set up and enable the desired modulation type.

2. Press AM > AM Path 1 2 WB to WB.

For frequencies between 9 kHz and 5 MHz, Wideband AM turns off.

AM > AM Path 1 2 WB

Enables and disables the 
wideband AM feature.
Note: If the I/Q is turned off or 
the I/Q source is set to 
internal, then the wideband 
AM turns off.

For details on each key, use key help 
as described on page 60.

When the Wideband AM is enabled, these fields are active.
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Configuring the LF Output (Option 303)
The signal generator has a low frequency (LF) output. The LF output’s source can be switched 
between an internal modulation source or an internal function generator.

Using internal modulation (Int Monitor) as the LF output source, the LF output provides a replica of 
the signal from the internal source that is being used to modulate the RF output. The specific 
modulation parameters for this signal are configured through the AM, FM, or ΦM menus. The 
internal source (AM, FM, or ΦM) must be configured for the LF Out to provide a signal.

Using function generator as the LF output source, the function generator section of the internal 
modulation source drives the LF output directly. Frequency and waveform are configured from the 
LF output menu, not through the AM, FM, or ΦM menus. You can select the waveform shape from 
the following choices:

Available internal waveforms include:

Sine  sine wave with adjustable amplitude and frequency

Triangle  triangle wave with adjustable amplitude and frequency

Square  square wave with adjustable amplitude and frequency

Pos Ramp  positive going ramp with adjustable amplitude and frequency

Neg Ramp  negative going ramp with adjustable amplitude and frequency

Pulse  pulse with adjustable period and width

LF Out Modulation Sources

The signal generator provides the following modulation input sources. Internal modulation sources 
generate the five waveforms listed above unless noted otherwise.

Int Monitor  uses AM, FM or ΦM settings.

Func Gen 1  waveforms from the internal function generator

Func Gen 2  waveforms from the internal function generator

Dual Func Gen  dual waveforms with individually adjustable frequencies and a percent-of- 
peak-amplitude setting for the second tone. Available on instruments with Option 
303. 

Swept Func Gen  swept waveforms with adjustable start and stop frequencies, sweep time, and 
sweep trigger settings. Available on instruments with Option 303.

Noise Gen 1 & 2  noise with adjustable amplitude generated as a peak-to-peak value (RMS value is 
approximately 80% of the displayed value). Uniform and Gaussian distribution is 
available. Available on instruments with Option 303.
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DC  selects a DC voltage level as the LF output BNC source.

Configuring the LF Output with an Internal Modulation Source

In this example, the internal FM is the LF output source. See Figure 6-3 on page 187.

Configuring the Internal Modulation as the LF Output Source

1. Press Preset.

2. Press the FM/ΦM hardkey.

3. Press FM Dev > 75 > kHz.

4. Press More > Setup FM Source > FM Rate > 10 > kHz. 

5. Press Return > Return > FM Off On. 

You have set up the FM signal with a rate of 10 kHz and 75 kHz of deviation. The FM annunciator is 
activated indicating that you have enabled frequency modulation.

Configuring the Low Frequency Output

1. Press the LF Out hardkey.

2. Press LF Out Amplitude > 3 > V. 

3. Press LF Out Off On.

You have configured the LF output signal for a 3 volt sine wave (default wave form) output which is 
frequency modulated using the Int Monitor source selection (default source).

The LF Out Off On softkey controls the operating state of the LF output. However when the LF 
output source selection is Int Monitor, you have three ways of controlling the output. You can 
use the modulation source (AM, FM, or ΦM) on/off key, the LF output on/off key, or the Mod 
On/Off softkey.

The RF On/Off hardkey does not apply to the LF OUTPUT connector.

Internal modulation (Int Monitor) is the default LF output source.
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Figure 6-3 Configure the LF Out Source with FM

Configuring the LF Output with a Function Generator Source

In this example, the function generator is the LF output source.

Configuring the Function Generator as the LF Output Source

1. Press Preset.

2. Press the LF Out hardkey.

3. Press LF Out Source > Func Gen 1.

Configuring the Waveform

1. Press Setup LF Out Source > LF Out Waveform > Sine.

2. Press LF Out Freq > 500 > Hz.

3. Press Return.

This returns you to the top LF Output menu. 

Configuring the Low Frequency Output

1. Press LF Out Amplitude > 3 > V.

This sets the LF output amplitude to 3 V.

2. Press LF Out Off On.

Figure 6-4 on page 188 shows that the LF output is now transmitting a signal using the function 
generator that is providing a 3 V sine waveform. 

For details on each key, use key help LF Out using the Int Monitor source (default selection).

FM as the LF Out Source

FM and LF annunciators indicate Frequency Modulation is the LF Out source
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Figure 6-4 LF Out Status Display

For details on each key, use key help 
as described on page 60.

LF Out configuration

LF Out annunciator
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Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in 
that chapter.

Option UNW with Option N5180320B provides the pulse train generation support.

— Pulse Characteristics on page 191

— The Basic Procedure on page 193

— Example on page 194

— Pulse Train (Options UNW and N5180320B) on page 195

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.



 190                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

  Pulse Modulation (Options UNW and N5180320B)

Figure 7-1 Pulse Softkeys

page 193

page 193

Latency from the external 
pulse input to the pulse 
sync output ≈ 50−60 ns.
Width      Period
50 ns       > 50 ns
20 ns       ≤ 50 ns

For details on each key, use key help 
as described on page 60.

Determines how the signal generator 
responds to an external pulse signal.
Normal = high state.
Invert = low state.

Low = settled

TTL signal

See also, page 31 and 
page 33

Select the signal 
routed to each 
output connector.

Available on vector 
instruments with 
BBG.

These softkeys are 
only available when 
the Pulse–Source is 
set to Adjustable 
Doublet.

page 195

Note: Pulse Period 
and Pulse Width are 
not available when 
Pulse Train is selected 
as the Pulse Source.
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Pulse Characteristics

Pulse Characteristics

When using very narrow pulses that are below the signal generator’s ALC 
pulse width specification, or leveled pulses with an unusually long duty 
cycle, it is often useful to turn ALC off (see page 122).

Pulse Source Type Perioda

a. All delays, widths, and periods have a resolution of 10 ns.

Width & Delaya Uses Trigger Eventb

b. A signal at the rear panel pulse connector must be held high for at least 20 ns to trigger an 
internally generated pulse.

Square
Internal free run pulse train with 
50% duty cycle.

Determined by 
user defined 
rate.

⎯ ⎯

Free Run  
(default)

Internal free run pulse train User Defined User Defined ⎯

Triggered Internal pulse train ⎯ User Defined ?

Adjustable  
Doublet

Two internal pulse trains for each 
trigger event.

⎯

User Defined:

First pulse is relative to the 
rising edge of trigger signal.

Second pulse is relative to 
the rising edge of first pulse.

See Figure 7-2 on 
page 192

?

Trigger  
Doublet

Two internal pulse trains for each 
trigger event.

⎯

The first pulse follows the 
trigger signal.

Second pulse is user defined.

See Figure 7-3 on 
page 192

?

Gated Internal gated pulse train ⎯ User Defined ?

External
External pulse signal at the rear 
panel Pulse connector

⎯ ⎯ ⎯

Pulse Train Internal pulse train

User Defined

User Defined:

See Figure 7-4 on 
page 195

?
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Pulse Characteristics

 

Figure 7-2 Adjustable Doublet

Figure 7-3 Trigger Doublet

 

Rear panel inputs are described on page 30

External pulse input

The delay of the first pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External 
Trigger

The delay of the second pulse is measured from 
the leading edge of the first pulse.

Delay Width
PulsPuls

PulsPuls

The delay of the second pulse is measured from 
the leading edge of the external trigger signal.

Delay Width

RF Output

External 
Trigger

The first pulse follows the 
external trigger signal.

Puls Puls
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The Basic Procedure

The Basic Procedure

1. Preset the signal generator.

2. Set the carrier (RF) frequency.

3. Set the RF amplitude.

4. Configure the modulation:

a.Set the pulse source: Press Pulse > Pulse Source > selection

b.Set the parameters for the selected pulse source:

5. Turn on the modulation: Pulse Off On softkey to On.

The the PULSE annunciator lights, indicating that you enabled modulation.

6. Output the modulated signal from the signal generator: Press the front panel RF On Off key.

The RF output LED lights, indicating that the signal is transmitting from the RF output connector.

See also, “Modulating the Carrier Signal” on page 74.

Square Free Run 
(default)

Triggered Adjustable Doublet Trigger Doublet Gated Pulse 
Traina

a.  Requires Option N5180320B.

External

Pulse 
Rate

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ ⎯

⎯ Pulse 
Period

⎯ ⎯ ⎯ Pulse 
Period

⎯ ⎯

⎯ Pulse 
Delay

Pulse 
Delay

Pulse Delay Pulse Delay ⎯ Pulse 
Delay

⎯

⎯ Pulse 
Width

Pulse 
Width

Pulse Width Pulse Width Pulse 
Width

⎯ ⎯

⎯ ⎯ ⎯ Pulse 2 Delay ⎯ ⎯ ⎯ ⎯

⎯ ⎯ ⎯ Pulse 2 Width ⎯ ⎯ ⎯ ⎯

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ Pulse Onb

b.  Up to 2047 pulse cycles (elements) composed of both Pulse On and Pulse Off can be user 
defined.

⎯

⎯ ⎯ ⎯ ⎯ ⎯ ⎯ Pulse Offb ⎯
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Example
The following example uses the factory preset pulse source and delay.

1. Preset the signal generator.

2. Set the frequency to 2 GHz.

3. Set the amplitude to 0 dBm.

4. Set the pulse period to 100 microseconds: Press Pulse > Pulse Period > 100 > usec.

5. Set the pulse width to 24 microseconds: Press Pulse > Pulse Width > 24 > usec

6. Turn on both the pulse modulation and the RF output. 

The PULSE annunciator displays and the RF output LED lights.

If the modulation does not seem to be working properly, refer to “No Modulation at the RF Output” 
on page 447. 

Output: A 2 GHz, 0 dBm carrier modulated by a 24 μs pulse that has a period of 100 μs.
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Pulse Train (Options UNW and N5180320B) 
The Option N5180320B Pulse Train feature enables the specification of up to 2047 independent 
pulse cycles, each of which has an “On Time”, during which the RF output is measurable at the RF 
output connector, and an "Off Time", during which the RF output is attenuated. Each pulse cycle is 
similar in function to other X-Series signal generator Pulse modes—the Pulse Train feature has up 
to 2047 cycles, instead of only a maximum of two (with Doublets). There are also repeat counts 
available for each pulse. These repetitions count against the total count of 2047 cycles.

The instrument can import pulse trains from a .csv (comma separated values) file or some other 
common ASCII format. It can also export to ASCII/CSV files as well. Export allows specification of 
the decimal separator and a column separator. The import allows specification of the decimal 
separator (to allow for ","), but the column separator is auto-detected. Refer to “Pulse Train Menu 
Softkeys” on page 195 and “Display Pulse Train Menu Softkeys” on page 197.

Figure 7-4 Pulse Train Menu Softkeys
Pulse > Pulse Source > More > Pulse Train 

Free-Run continuously plays 
the pulse train, ignoring all 
triggers.
Triggered runs the pulse 
train (after waiting the Pulse 
Delay) each time an external 
trigger is supplied to the 
PULSE BNC, the Trigger 
Immediately softkey is 
pressed, or the Trigger SCPI 
command is sent.
Gated runs the pulse train 
while an external trigger is 
supplied (level triggered) to 
the PULSE BNC connector. 
The state of the GATEd 
trigger is detected only when 
the playback is transitioning 
to or in idle. This means that, 
once started, playback is 
always completed, even if 
the GATE trigger changes to 
the inactive state.

For details on each key, use key help as 
described on page 60.

Display area indicates Pulse Train is the current pulse 
source.

Trigger Immediately causes 
the pulse train to run once.

SCPI Commands:

[:SOURce]:PULM:INTernal:TRAin:TRIGger FRUN|{TRIGgered}|GATEd
[:SOURce]:PULM:INTernal:TRAin:TRIGger:IMMediate  

Refer to the SCPI Command Reference.
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Figure 7-5 Edit Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train

page 197

This column indicates the 
row of a each pulse train 
cycle.
Note: When the cycles 
(elements) are repeated, 
the row numbers are 
skipped in the displayed 
count for the number of 
pulse cycles repeated.
Example: For the pulse 
train displayed above, in 
row 2, the 3 us On Time 
and 2 us Off Time pulse 
cycle is repeated twice. 
But, only row 2 is 
displayed for that pulse 
cycle (i.e. row 3 is not 
displayed). 

This column 
displays the on 
times for each 
pulse cycle 
(element) in the 
pulse train.

This column 
displays the off 
times for each 
pulse cycle 
(element) in the 
pulse train.

This column 
displays the repeat 
times for each 
pulse cycle 
(element) in the 
pulse train.

These softkeys provide 
ease of use in changing 
the pulse cycle settings 
in the pulse train.

SCPI Commands:
[:SOURce]:PULM:INTernal:TRAin:LIST:PRESet
[:SOURce]:PULM:INTernal:TRAin:OFFTime <20ns - 42sec>
[:SOURce]:PULM:INTernal:TRAin:OFFTime?
[:SOURce]:PULM:INTernal:TRAin:OFFTime:POINts?
[:SOURce]:PULM:INTernal:TRAin:ONTime <20ns - 42sec>
[:SOURce]:PULM:INTernal:TRAin:ONTime?
[:SOURce]:PULM:INTernal:TRAin:ONTime:POINts?
[:SOURce]:PULM:INTernal:TRAin:REPetition <1-2047>
[:SOURce]:PULM:INTernal:TRAin:REPetition?
[:SOURce]:PULM:INTernal:TRAin:REPetition:POINts? 

Refer to the SCPI Command Reference.

SCPI Commands (continued):
:MEMory:CATalog:PTRain? 
:MEMory:DELete:PTRain
:MEMory:EXPort[:ASCii]:PTRain <"filename">
:MEMory:EXPort[:ASCii]:SEParator:COLumn 
TAB|SEMicolon|{COMMa}|SPACe
:MEMory:EXPort[:ASCii]:SEParator:COLumn?
:MEMory:EXPort[:ASCii]:SEParator:DECimal {DOT}|COMMa
:MEMory:EXPort[:ASCii]:SEParator:DECimal?
:MEMory:IMPort[:ASCii]:PTRain <"filename">
:MEMory:IMPort[:ASCii]:SEParator:DECimal {DOT}|COMMa
:MEMory:IMPort[:ASCii]:SEParator:DECimal?
:MMEMory:LOAD:PTRain <"filename">
:MMEMory:STORe:PTRain <"filename">

For details on each key, use key help as described on page 60.

page 198
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Pulse Train (Options UNW and N5180320B)

Figure 7-6 Display Pulse Train Menu Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > Display Pulse Train

Use these softkeys to optimize 
the view of the different 
characteristics of the pulse 
train.

This softkey shifts the time 
offset from the left hand side 
of the display to the one 
specified. Increments and 
decrements are 1/20th of 
the visible pulse train.

This value can be 
adjusted with the 
Time Offset softkey.

These are the division markers currently 
set at 10.00 us/div for the currently 
displayed view. Use the zoom softkeys 
to change the time/div value.

This is the initial 
pulse cycle (row 1) 
note that the On 
Time portion of this 
pulse is not showing 
due to the  
2 us offset.

5th, 6th, and 7th 
pulse cycles 
(elements) or rows 

Final pulse cycle 
(element) in the 
displayed pulse 
train above. 8th 
pulse cycle or row. 

2nd and 3rd 
pulse cycles 
(elements) or 
rows 2 and 3.

4th pulse cycle 
(element) or row 4.

For details on each key, use key help as described on page 60.
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Figure 7-7 Pulse Train: Import From Selected File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

page 80

These softkeys delete 
individual On Time or Off 
Time elements as well as the 
Repeat cycle counts.

This file’s data structure uses decimals in the numbers 
and so requires the Import Decimal Separator to be set to 
Dot.

Selects whether the decimal point 
is a "." or a "," during import of 
CSV/ASCII files.
This value is persistent across 
preset/recall and power cycles.

SCPI Commands:
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal DOT|COMMa
:MEMory:IMPort[:ASCii]:SEParato
r:DECimal?

After confirming import of the file 
the new file’s pulse train values 
are displayed.

Deleting all Pulse Cycle rows 
(elements) must be 
confirmed.

For details on each key, use key help as described on page 60.

Note: Column 
separated values are 
auto-detected by the 
instrument.

page 199

page 199
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Pulse Train (Options UNW and N5180320B)

Figure 7-8 Pulse Train: Export to File Softkeys

Pulse > Pulse Source > More > Pulse Train > Edit Pulse Train > More

page 198

Use the text editor keys to 
rename the file to be exported 
to the BIN (Binary) folder. 

The Export to File softkey menu, 
writes out a CSV/ASCII file to the 
BINARY directory. You may supply 
your own extender as part of the 
filename.
Example: 
MEM:EXP:PTR "myfile.csv".
SCPI Command:
:MEMory:EXPort[:ASCii]:PTRAin 
<"filename">

Note: Files can be FTP’d to the BIN (Binary) folder in the instrument, or a USB 
stick can be used to download the files to the instrument. Refer to page 81.

For details on each key, use key help as described on page 60.

Note: Since there is already a file named PTRAIN.CSV the new 
filename should be different, to avoid overwriting the original 
PTRAIN.CSV file.

Selects whether the column 
separator is a tab, “;”, “,” or “a “ ” 
during export of the CSV/ASCII 
files. This value is persistent 
across preset/recall and power 
cycles.
SCPI Commands: 
:MEMory:EXPort[:ASCii]:SEParato
r:COLumn 
TAB|SEMicolon|COMMa|SPACe
:MEMory:EXPort[:ASCii]:SEParato
r:COLumn?

Selects whether the 
decimal point is a “.” 
or “, “ ” during export 
of the CSV/ASCII 
files. This value is 
persistent across 
preset/recall and 
power cycles.
SCPI Commands: 
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal DOT|COMMa
:MEMory:EXPort[:AS
Cii]:SEParator:DECi
mal?
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8   Basic Digital Operation—No BBG Option Installed

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting power level and frequency, refer 
to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in that 
chapter.

See also “Adding Real–Time Noise to a Dual ARB Waveform” on page 364.
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I/Q Modulation
The following factors contribute to the error vector magnitude:

— Differences in amplitude, phase, and delay between the I and Q channels

— DC offsets

The I/Q menu provides adjustments and calibration to compensate for some of the differences in 
the I and Q signals or to add impairments. See I/Q Modulation on page 265 for additional 
information.

See also “Modulating the Carrier Signal” on page 74.

Figure 8-1 I/Q Display and Softkeys

This panel displays the external 
I/Q signal routing.

This panel displays the current status and settings 
of the I/Q adjustments. Grey text indicates I/Q 
adjustments are off.

For details on each key, use key help 
as described on page 60.

Offsets the phase of the Q signal relative to the 
phase of the I signal. The quadrature adjustment 
key is in units of degrees. This adjustment is not 
calibrated. 

Sets the dc 
offset

Toggles between DC, User, and Full IQ calibration types. 
DC: Calibrates I/Q offset, gain and quadrature error for a single 
frequency at the current signal generator settings. 
This calibration requires that the I/Q be on, the optimized path be set to 
RF Out, and the source be set to the internal baseband generator. 
Changing any instrument setting except for I/Q adjustments after 
performing a DC calibration voids the DC calibration and causes the 
signal generator to revert to the factory supplied calibration data. 
User: Calibrates I/Q offset, gain, and quadrature error for all signal 
generator settings over a range of frequencies that you define. 
Full: Calibrates I/Q offset, gain, and quadrature error for all settings 
over the full frequency range of the signal generator.

Starts the I/Q calibration routine for the 
selected frequency range. (Use the 
Calibration Type softkey to select the 
frequency range.) You can abort the 
calibration by pressing the Abort Cal 
softkey or the Local Cancel/(Esc) 
hardkey. If you abort the calibration, the 
previous calibration data is restored.
This calibration should be run when the 
ambient temperature has varied by at 
least +/-5 degrees Celsius from the 
ambient temperature at which the 
previous calibration was run.
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I/Q Modulation

The following table shows common uses for the adjustments.

Configuring the Front Panel Inputs

The CXG/MXG/EXG accepts externally supplied analog I and Q signals through the front panel I 
Input and Q Input for modulating onto the carrier.

1. Connect I and Q signals to the front panel connectors. For voltage levels, refer to “Front Panel 
Overview” on page 23. 

a.Connect an analog I signal to the signal generator’s front panel I Input.

b.Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Turn on the I/Q modulator: Press I/Q Off On to On.

3. Configure the RF output:

a.Set the carrier frequency.

b.Set the carrier amplitude.

c.Turn the RF output on.

4. Make adjustments to the I/Q signals (page 202) as needed.

Table 8-1 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier Feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q Images I/Q path delay
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9    Basic Digital Operation (Option 653/655/656/657)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting power level and frequency, refer 
to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in that 
chapter.

The features described in this chapter are available only in vector signal generators with Option 
653, 655, 656 or 657.

— Waveform File Basics on page 207

— Storing, Loading, and Playing a Waveform Segment on page 209

— Waveform Sequences on page 212

— Saving a Waveform’s Settings & Parameters on page 217

— Using Waveform Markers on page 223

— Triggering a Waveform on page 239

— Clipping a Waveform on page 246

— Scaling a Waveform on page 255

— Setting the Baseband Frequency Offset on page 261

— I/Q Modulation on page 265

— I/Q Adjustments on page 269

— I/Q Calibration on page 270

— Using the Equalization Filter on page 272

— Using Finite Impulse Response (FIR) Filters in the Dual ARB Real-Time Modulation Filter on 
page 274

— Modifying a FIR Filter Using the FIR Table Editor on page 280

— Setting the Real-Time Modulation Filter on page 283

— Multiple Baseband Generator Synchronization on page 285

— Understanding Option 012 (LO In/Out for Phase Coherency) with Multiple Baseband Generator 
Synchronization on page 291

— Waveform Licensing on page 296
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See Also: 

— Adding Real–Time Noise to a Dual ARB Waveform on page 364

— Real–Time Phase Noise Impairment on page 372

— Multitone and Two-Tone Waveforms  (Option N5180430B) on page 433
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Waveform File Basics

Waveform File Basics
There are two types of waveform files: 

— A segment is a waveform file that you download to the signal generator.

For information on creating and downloading waveform files, refer to the Programming Guide. 

— A sequence is a file you create in the signal generator that contains pointers to one or more 
waveform files (segments, other sequences, or both). 

For information on creating sequences, see page 212.

Signal Generator Memory

The signal generator has two types of memory:

— Volatile memory, baseband generator (BBG) media, where waveform files are played from or 
edited.

— Non–volatile memory, either internal (int) or external (USB) media, where waveform files are 
stored.

Dual ARB Player

The dual ARB waveform player enables you to play, rename, delete, store, and load (external or 
internal) waveform files in addition to building waveform sequences. The dual ARB waveform player 
also provides markers (page 223), triggering (page 239), clipping (page 246), and scaling 
(page 255) capabilities.

Most procedures in this section start from the Dual ARB menu, shown below. 

The CXG/MXG/EXG’s ARB Waveform File Cache is limited (see the Data 
Sheet). Consequently, once the file cache limit has been reached, the 
waveform switching speed is much slower for additional files loaded into 
the volatile waveform memory (BBG).
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Figure 9-1 Dual ARB Softkeys

page 364

page 246

page 255

page 246

page 209

If you set the ARB sample clock when the dual ARB 
is off, the new setting is applied when the dual ARB 
player is turned on; this setting survives toggling 
the Dual ARB player off and on.

page 67

page 217

page 239

For details on each key, use key help 
as described on page 60.

Note: This is second of 
           two Arb menus.

page 212

page 261

page 255

page 255

page 264

page 285

These softkeys are 
only available in the Dual 
ARB’s Arb Setup 
menu.

page 223

Available on  
vector models with 
opt 2xx.

page 296

page 285
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Storing, Loading, and Playing a Waveform Segment

Storing, Loading, and Playing a Waveform Segment

Before using this information, you should be familiar with the signal generator’s file menus. If you 
are not, refer to “Working with Files” on page 76 and familiarize yourself with that information.

See also: “Waveform Sequences” on page 212.

The signal generator has two types of waveform media: non–volatile (internal or USB), and volatile 
(BBG). BBG media is also called “working” media, because before you can play, edit, or include a 
waveform file in a sequence, the waveform file must be loaded into BBG media.

Figure 9-2 Waveform Segment Softkeys

Loading a Waveform Segment into BBG Media

Waveforms must reside in BBG media before they can be played, edited, or included in a sequence. 
Cycling power or rebooting the signal generator deletes the files in BBG media.

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Load, then use the arrow keys to highlight the desired waveform 
segment.

The CXG/MXG/EXG’s ARB Waveform File Cache is limited to 128 files. 
Consequently, once the 128 file cache limit has been reached, the 
waveform switching speed will be much slower for additional files loaded 
into the volatile waveform memory (BBG).

Each time the instrument powers up, two factory–supplied segments are automatically created in 
BBG media: RAMP_TEST_WFM and SINE_TEST_WFM.

page 223

For details on each key, use key help 
as described on page 60.

Note: When a sequence is selected, this key name 
changes to Show Waveform Sequence Contents.

Use the arrow keys or knob to 
highlight a letter or character.

These keys change to indicate the default media.  
For information on selecting the default media,  
see page 87.
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3. If there is already a copy of this segment in the currently selected media and you do not want 
to overwrite it, rename the waveform segment before you load it (refer to the previous 
procedure).

4. Press Load Segment From currently selected Media.

To load all files from the currently selected media into BBG media, press 
Load All From currently selected Media. 

Storing/Renaming a Waveform Segment to Internal or USB Media

Use the following steps to store a copy of a file in BBG memory to the currently selected media 
(page 87). If you have not downloaded a waveform segment, either refer to the Programming 
Guide, or use one of the factory–supplied segments. 

1. Press Mode > Dual ARB > Select Waveform > Waveform Segments.

2. Press Load Store to highlight Store.

3. Using the arrow keys, highlight the waveform segment you want to store.

4. Optionally, rename the segment.

If there is already a copy of this segment in the currently selected media and you do not want 
to overwrite it, rename the waveform segment before you store it:

a. Press More > Rename Segment > Clear Text.
b.Enter a name for the waveform segment.
c. Press Enter > More.
d.Highlight the waveform segment that was renamed.

5. Press Store Segment to currently selected Media.

6. Repeat Step 3 through Step 5 for all segments that you want to store.

To save all segments from BBG media to the currently selected media, press 
Store All to currently selected Media.

Playing a Waveform Segment

1. Press Mode > Dual ARB > Select Waveform.

2. In the Segment on BBG Media column, highlight the waveform segment you want to play.

3. Press Select Waveform.

4. Set ARB Off On to On.

This plays the selected waveform segment. Both the I/Q and ARB annunciators turn on, and 
the waveform modulates the RF carrier. 
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Storing, Loading, and Playing a Waveform Segment

5. Configure the RF Output: 

Set the RF carrier frequency and amplitude, and turn on the RF output.

The waveform segment is now available at the signal generator’s RF Output connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)
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Waveform Sequences

Figure 9-3 Waveform Sequence Softkeys

A waveform sequence is a file that contains pointers to one or more waveform segments or other 
waveform sequences, or both. This lets the signal generator play multiple waveform segments, or 
other sequences, or both thereby eliminating the need to stop waveform playback just to select 
another waveform.

The segments that a waveform sequence points to are not automatically stored when you store the 
sequence; you must also store the individual segments or they are lost when you turn off or reboot 
the signal generator. If the segments are located in internal/external media, you must load them 
into BBG media prior to selecting a waveform sequence (see page 209). If you attempt to play a 
sequence without the segments loaded into BBG media, the signal generator reports: ERROR: 
629, File format invalid. If this happens and the segments are not stored in internal/external 
media, you must recreate the segments using the same file names that the sequence points to 
before you can play the sequence. 

Creating a Sequence

A waveform sequence can contain up to 1,024 segments and have both segments and other 
sequences (nested sequences). The signal generator lets you set the number of times the segments 
and nested sequences repeat during play back. But there is a difference between repeating a 

For details on each key, use key help 
as described on page 60.

Mode > 
Dual ARB

Sequence name

Sequence contents

see page 235

To display this softkey, select a waveform sequence.
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Waveform Sequences

segment versus repeating a nested sequence. Each segment can repeat up to 65,535 times, but no 
matter how many times a segment repeats, it counts as a single segment. However each repetition 
of a nested sequence counts as additional segments.

The maximum number of times that a nested sequence can repeat is based on the number of 
segments in the nested sequence and the remaining number of allowed segments (1,024). For 
example, with a sequence that contains 24 segments and one nested sequence with 4 segments, 
the nested sequence is limited to 250 repetitions:

24 + (4 ´ 250) = 1,024 maximum number of segments per sequence

Even though there is a limiting factor on the maximum number of times that a nested sequence can 
repeat, each segment within the nested sequence can repeat up to 65,535 times.

Example

Use the following procedure to create and store a waveform sequence using one repetition each of 
two different segments.

Assumption: The waveform segments are in BBG media (volatile memory). For information on 
loading waveform segments into BBG media, see page 209. 

1. Select the first segment:

a. Press Mode > Dual ARB > More > Waveform Sequences > Build New Waveform Sequence 
> Insert Waveform.

b. Highlight the desired waveform segment and press Insert.

2. Select the second segment:

a. Highlight the next desired waveform segment and press Insert.

b. Press Done Inserting

Waveform 
Sequence

Sequence A

Sequence B

Sequence A 
repeated 4x

Segment 1

Segment 2

Segment 3

2 segments

9 segments

11 segments

8 Segments
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3. Name and store the waveform sequence to the Seq file catalog:

a. Press More > Name and Store.

b. Enter a file name and press Enter.

See also, “Viewing the Contents of a Sequence” on page 214 and “Setting Marker Points in a 
Waveform Segment” on page 230.

Viewing the Contents of a Sequence

There are two ways to view the contents of a waveform sequence:

Through the Waveform Sequences Softkey

1. Press Mode > Dual ARB > More > Waveform Sequences.

2. Highlight the desired sequence.

3. Press Show Waveform Sequence Contents.

Using the Select Waveform Softkey

1. Press Mode > Dual ARB > Select Waveform.

2. In the Sequence On column, highlight the desired waveform sequence.

3. Press Show Waveform Sequence Contents.

Editing a Sequence

When editing a waveform sequence, you can:

— change the number of times each segment or nested sequence plays

— delete segments or nested sequences from the sequence

— add segments or nested sequences to the sequence

— toggle markers on and off (described on page 235)

— save changes either to the current waveform sequence or as a new sequence

If you exit the sequence editing menu before saving changes, the changes are lost.

Sequences save to the Seq file catalog.

Use the following steps to edit a sequence that has two different segments so that the first 
segment repeats 100 times and the second segment repeats 200 times, then save the changes.

If you edit and resave a segment used in a sequence, the sequence does not automatically 
update the RMS value in its header. You must select and update the sequence header 
information (page 217).
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Assumption: A waveform sequence that has two different segments has been created and stored 
(see previous example on page 213).

1. Select the sequence:  
Press Mode > Dual ARB > More > Waveform Sequences > highlight the desired sequence > 
Edit Selected Waveform Sequence.

2. Change the first segment so that it repeats 100 times:  
Highlight the first segment entry and press Edit Repetitions > 100 > Enter.

The cursor moves to the next entry. 

3. Change the repetition for the selected entry to 200:  
Press Edit Repetitions > 200 > Enter.

4. Save the changes made in the previous steps:  
Press More > Name and Store > Enter.

To save the changes as a new sequence: 

a. Press More > Name and Store > Clear Text.
b.Enter a file name (for example, SINE100+RAMP200).
c. Press Enter.

The edited sequence saves as a new waveform sequence. 

Playing a Sequence

If you have not created a waveform sequence, refer to “Creating a Sequence” on page 212.

1. Select a waveform sequence:

a. Press Mode > Dual ARB > Select Waveform.

b. Highlight a waveform sequence (for this example, SINE100+RAMP200) from the Sequence 
On column.

c. Press Select Waveform.

The display shows the currently selected waveform (for example, Selected Waveform: 
SEQ:SINE100+RAMP200).

To play a waveform segment individually or as part of a waveform sequence, the segment must 
reside in BBG media. See also, “Loading a Waveform Segment into BBG Media” 
on page 209.
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2. Generate the waveform:  
Press ARB Off On to On. 

This plays the selected waveform sequence. During the waveform sequence generation, both 
the I/Q and ARB annunciators turn on, and the waveform modulates the RF carrier. 

3. Configure the RF output: 

a.Set the RF carrier frequency.
b.Set the RF output amplitude.
c.Turn on the RF output.

The waveform sequence is now available at the signal generator’s RF OUTPUT connector. 

Current waveform selection

Annunciators display with active waveform (ARB On)



Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide                                                         217

   Basic Digital Operation (Option 653/655/656/657)

Saving a Waveform’s Settings & Parameters

Saving a Waveform’s Settings & Parameters
This section describes how to edit and save a file header. When you download only a waveform file 
(I/Q data, which the signal generator treats as a waveform segment), the signal generator 
automatically generates a file header and a marker file with the same name as the waveform file. 
Initially the file header has no signal generator settings saved to it, and the marker file consists of 
all zeros. For a given waveform, you can save signal generator settings and parameters in its file 
header and marker settings in its marker file (page 223); when you load a stored waveform file into 
BBG media, the file header and marker file settings automatically apply to the signal generator so 
that the dual ARB player sets up the same way each time the waveform file plays. 

Figure 9-4 Header Utilities Softkeys

When you create a waveform sequence (as described on page 212), the signal generator 
automatically creates a waveform sequence header that takes priority over the individual waveform 
segment headers. During a waveform sequence playback, the segment headers are ignored, except 
to verify that all required options are installed. Storing a waveform sequence also stores its file 
header. 

Some of the current signal generator settings shown in the file header appear as part of the softkey 
labels, and others appear in the dual ARB summary display, shown in the following example.

page 220

Mode > Dual ARB >  
More > 
Header Utilities

For details on each key, 
use key help 
as described on 
page 60.
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Table 9-1 File Header Entries

32–Character 
Description

A description entered for the header, such as a the waveform’s function (saved/edited with the 
Edit Description softkey, see Figure 9-4 on page 217).

Sample Rate The waveform playback rate. This is the ARB sample clock rate, set in the Arb Setup menu (shown 
in “Dual ARB Softkeys” on page 208).

Runtime Scaling The Runtime scaling value is applied in real–time while the waveform is playing. This setting can be 
changed only for files playing in the dual ARB player (see page 258).

RMS When the modulator attenuation setting (see page 208) is set to Auto, this value is used to calculate 
the I/Q modulator attenuation setting to optimize ACPR. Value: 0 to 1.414213562.

Marker 1...4 Polarity Marker polarity can be positive or negative (described on page 235). 

ALC Hold Routing Which marker, if any, implements the ALC hold function (described on page 225), which holds the 
ALC at its current level when the marker signal is low. All waveforms generated in the signal 
generator have a marker on the first sample point. To see the results from the three routing 
selections, you may need to select a range of sample (marker) points (see “Setting Marker 
Points in a Waveform Segment” on page 230). 

RF Blank Routing Which marker, if any, implements the RF blanking function (described on page 234) when the 
marker signal is low. RF blanking also uses ALC hold. There is no need to select the ALC Hold 
Routing for the same marker when you are using the RF Blank Routing function. When the marker 
signal goes high, RF blanking discontinues. 

Mod Attenuation The I/Q modulator attenuation setting (set in the Arb Setup menu shown in Figure 9-1 on 
page 208).

BB Freq Offset The baseband frequency offset, in Hz (see page 261).

ARB summary, file
header settings

Softkey labels,
file header
settings

Softkey label,
file header
setting

All settings in this menu can be stored 
to thefile header 
(Table 9-1 on page 218 lists all 
settings stored in a file header)

The Runtime 
Scaling softkey is 
only available under 
the Dual ARB menu.

see page 261
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Viewing and Modifying Header Information 

The following example uses the factory–supplied waveform file RAMP_TEST_WFM.

1. From BBG media, select the waveform RAMP_TEST_WFM: 

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On column, highlight the waveform RAMP_TEST_WFM.

c. Press Select Waveform.

2. Open the Header Utilities menu:

Press More > Header Utilities

The Figure 9-5 shows the default file header for the factory–supplied waveform 
RAMP_TEST_WFM. The Header Field column lists the file header parameters; use the Page 
Down key to see them all.

The Saved Header Settings column shows that most of the settings are Unspecified. 
Unspecified means that there is no setting saved for that particular parameter.

The Current Inst. Settings column shows the current signal generator settings. In this 
example, these are the settings that you will save to the file header. 

AWGN: State Indicated whether real–time noise is on (1) or off (0) (see page 363).

AWGN: C/N Ratio Carrier to noise ration, in dB (see page 368).

AWGN: Carrier BW Bandwidth over which the noise power is integrated, in Hz (see page 368).

AWGN: Noise BW Bandwidth of the noise, in Hz (see page 368).

AWGN: Carrier RMS The carrier RMS across the carrier bandwidth (see page 368).

Phase Noise State Indicated whether phase noise is on (1) or off (0) (see page 372).

Phase Noise F1 The start frequency for the level mid–frequency characteristics (see page 372).

Phase Noise F2 The end frequency for the level mid–frequency characteristics (see page 372).

Phase Noise Lmid The amplitude for the level mid–frequency characteristics (see page 372).

Modulation Filter The real-time modulation filter type selected (see page 283).

Over–Range Protect Indicated whether DAC Over–Range Protection is on (1) or off (0) (see page 376).

Unique Waveform Id 0 = no Id; once an Id is assigned, it cannot be changed.

License Required Indicates whether a license is required to play the waveform. See also: “Viewing Options and 
Licenses” on page 56

Can be Read Out Indicates whether the waveform can be queried through SCPI or FTP.

Table 9-1 File Header Entries
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Figure 9-5 Example File Header

3. Save the information in the Current Inst. Settings column to the file header:

Press Save Setup To Header.

Both the Saved Header Settings column and the Current Inst. Settings column now 
display the same values; the Saved Header Settings column lists the settings saved in the 
file header.

4. Edit and Update Settings

a. Return to the ARB Setup menu:  
Press Return > More > ARB Setup.

From this menu you can access some of the signal generator settings that are saved to the 
file header. Figure 9-1 on page 208 shows the ARB Setup softkeys used in the following 
steps.

b. Set the ARB sample clock to 5 MHz:  
Press ARB Sample Clock > 5 > MHz.

c. Set waveform runtime scaling to 60%: 
Press Waveform Runtime Scaling > 60 > %.

d. Return to the Header Utilities menu:  
Press Return > More > Header Utilities.

If a setting is unspecified in the file header, the signal generator uses its 
current value for that setting when you select and play the waveform.

The name of the waveform file.

The description can be up to 
32–characters.

Mode > Dual ARB > More > Header Utilities

Default header settings Current signal generator settings

Resets the saved 
header settings 
entries to default 
settings

To calculate the RMS waveform voltage: 
Press Calculate
Then refer to Header Field information.
Note: For greater accuracy, if the waveform has long rise/fall times, a DC 
offset, or noise* already added to the waveform (for a bursted signal), it 
is recommended that the Edit RMS and Edit AWGN RMS Override 
softkeys are used for the best measurement accuracy. 
*Option N5180403B Real–time AWGN does not affect the Header Field 
RMS value. But, noise added to the waveform prior to downloading and 
playing in the signal generator does affect the Header Field RMS value.

Opens a menu for manually 
defining the carrier RMS value 
to use for calculating the 
AWGN: Carrier RMS value in 
the Header Field. 
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As shown in the following figure, the Current Inst. Settings column now reflects the 
changes to the current signal generator setup, but the saved header values have not 
changed.

e. Save the current settings to the file header:  
Press the Save Setup To Header softkey.

The settings from the Current Inst. Settings column now appear in the Saved 
Header Settings column. This saves the new current instrument settings to the file 
header.

If you change any of the signal generator settings listed in the file header after you select the 
waveform file, the changed setting(s) appear in the file header’s Current Inst. Settings 
column and are used instead of the saved header settings. To reapply the saved header settings, 
reselect the waveform for playback.

Viewing & Editing a Header without Selecting the Waveform

As described on page 219, you can view and edit a waveform’s header information after you select 
the waveform; you can also edit waveform header information without selecting a waveform, or for 
another waveform than the one that is currently selected.

1. Access the file header utilities menu: 
Press Mode > Dual ARB > More > Header Utilities > More > Select Different Header.

The signal generator displays an alphabetical list of the waveform files in the media that was 
last selected. The following figure shows an example of the factory–supplied waveforms in 
BBG media.

Values differ between  
the two columns
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2. If the desired catalog is not displayed, select it. 

3. Highlight the desired waveform file and press Select Header.

The signal generator displays the file header for the selected waveform file. 

4. To edit the header, press More, and proceed as described in Step 4 on page 220 (Viewing and 
Modifying Header Information section).

Active waveform catalog

Active media

Type:
WFM1 = Volatile Segment
NVWFM = Non–Volatile Segment
SEQ = Sequence

Active catalog

For details on each key, use key help 
as described on page 60.

Catalogs that enable you to 
view files in the active media.
For details on selecting the 
active media, see page 78.

Files in BBG media
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Using Waveform Markers
The signal generator provides four waveform markers to mark specific points on a waveform 
segment. When the signal generator encounters an enabled marker, an auxiliary signal is routed to 
a rear panel event output that corresponds to the marker number.

— Event 1 is available at both the EVENT 1 BNC connector (see page 33), and a pin on the 
AUXILIARY I/O connector (see page 35).

— Event 2 is available at the TRIG 1 & TRIG 2 connectors (see page 31), and a pin on the 
AUXILIARY I/O connector (see page 35).

— Events 3 and 4 are available at pins on the AUXILIARY I/O connector (see page 35).

You can use an auxiliary output signal to synchronize another instrument with the waveform, or as a 
trigger signal to start a measurement at a given point on a waveform.

You can also configure markers to initiate ALC hold or RF Blanking (which includes ALC hold). Refer 
to “Using Waveform Markers” on page 223 for details.

When you download a waveform file that does not have a marker file associated with it, the signal 
generator creates a marker file without any marker points. Factory–supplied segments 
(RAMP_TEST_WFM and SINE_TEST_WFM) have a marker point on the first sample for all four 
markers.

The following procedures demonstrate how to use markers while working in the dual ARB player. 
These procedures also discuss two types of points: a marker point and a sample point. A marker 
point is a point at which a given marker is set on a waveform; you can set one or more marker 
points for each marker. A sample point is one of the many points that compose a waveform.

There are three basic steps to using waveform markers:

Clearing Marker Points from a Waveform Segment on page 229

Setting Marker Points in a Waveform Segment on page 230

Controlling Markers in a Waveform Sequence on page 235

This section also provides the following information:

— Waveform Marker Concepts on page 224

— Accessing Marker Utilities on page 228

— Viewing Waveform Segment Markers on page 229

— Viewing a Marker Pulse on page 232

— Using the RF Blanking Marker Function on page 234

— Setting Marker Polarity on page 235
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Waveform Marker Concepts

The signal generator’s Dual ARB provides four waveform markers for use on a waveform segment. 
You can set each marker’s polarity and marker points (on a single sample point or over a range of 
sample points). Each marker can also perform ALC hold, or RF Blanking and ALC hold.

Marker Signal Response

The signal generator aligns the marker signals with the I and Q signals at the baseband generator. 
However some settings such as amplitude, filters, and so forth within the RF output path can create 
delays between the marker EVENT output signal and the modulated RF output. When using the 
marker EVENT output signal, observe the signals (marker relative to modulated RF) for any latency, 
and if needed, reset the marker point positions, include delay (page 269), or both.

Marker File Generation

Downloading a waveform file (as described in the Programming Guide) that does not have a marker 
file associated with it causes the signal generator to automatically create a marker file, but does 
not place any marker points.

Marker Point Edit Requirements

Before you can modify a waveform segment’s marker points, the segment must reside in BBG 
media (see “Loading a Waveform Segment into BBG Media” on page 209).

Saving Marker Polarity and Routing Settings

Marker polarity and routing settings remain until you reconfigure them, preset the signal generator, 
or cycle power. To ensure that a waveform uses the correct settings when it is played, set the 
marker polarities or routing (RF Blanking and ALC Hold) and save the information to the file header 
(page 217). 

When you use a waveform that does not have marker routings and polarity settings stored in the 
file header, and the previously played waveform used RF Blanking, ensure that you set RF 
Blanking to None. Failure to do so can result in no RF output or a distorted waveform.

Marker 
File
Bit N

Marker
Polarity

Marker N 
RF Blank Off On

Marker N
Blanks RF when 
Marker is Low

EVENT N

Negative

Positive

Set Marker
On Off

Marker N 
ALC Hold Off On

Marker N
Holds ALC when 

Marker is Low

When the signal generator encounters an enabled marker (described on page 235), an 
auxiliary output signal is generated and routed to the rear panel. 

Event 1 is available at the EVENT 1 BNC connector (see page 33), and at a pin on the 
AUXILIARY I/O connector (see page 35).

Events 2 through 4 are available at pins on the AUXILIARY I/O connector 

RF Blank Only: includes ALC Hold
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ALC Hold Marker Function

While you can set a marker function (described as Marker Routing on the softkey label) either 
before or after you set marker points (page 230), setting a marker function before setting marker 
points may cause power spikes or loss of power at the RF output.

Use the ALC hold function by itself when you have a waveform signal that incorporates idle periods, 
burst ramps, or when the increased dynamic range encountered with RF blanking (page 234) is not 
desired. 

The ALC hold marker function holds the ALC circuitry at the average value of the sampled points 
set by the marker(s). For both positive and negative marker polarity, the ALC samples the RF output 
signal (the carrier plus any modulating signal) when the marker signal goes high:

Positive: The signal is sampled during the on marker points.

Negative The signal is sampled during the off marker points.

Because it can affect the waveform’s output amplitude, do not use the ALC hold for longer than 
100 ms. For longer time intervals, refer to “Power Search Mode” on page 123.

Incorrect ALC sampling can create a sudden unleveled condition that may 
create a spike in the RF output, potentially damaging a DUT or connected 
instrument. To prevent this condition, ensure that you set markers to let 
the ALC sample over an amplitude that accounts for the higher power 
levels encountered within the signal.

Positive 
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Close–up of averaging

The ALC samples the waveform when the marker 
signal goes high, and uses the average of the 
sampled waveform to set the ALC circuitry.

Here the ALC samples during the on marker points 
(positive polarity).

Marker Marker

MarkerMarker

Example of Correct Use

Waveform: 1022 points 
Marker range: 95–97 
Marker polarity: Positive

This example shows a marker set to sample the 
waveform’s area of highest amplitude. Note that the 
marker is set well before the waveform’s area of lowest 
amplitude. This takes into account any response 
difference between the marker and the waveform signal.

Pulse Unleveled

Example of Incorrect Use

Waveform: 1022 points 
Marker range: 110–1022 
Marker polarity: Positive

This example shows a marker set to sample the low 
part of the same waveform, which sets the ALC 
modulator circuitry for that level; this usually results 
in an unleveled condition for the signal generator 
when it encounters the high amplitude of the pulse.

MarkerMarker
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Sample range begins on first point of signal

Negative range set between signal and  
off time

Example of Incorrect Use

Waveform: 1022 points 
Marker range: 110–1022 
Marker polarity: Negative

This figure shows that a negative polarity marker goes 
low during the marker on points; the marker signal goes 
high during the off points. The ALC samples the 
waveform during the off marker points.

Marker On Marker On

Sampling both on and off time sets the modulator 
circuitry incorrectly for higher signal levels. Note the 
increased amplitude at the beginning of the pulse.

Marker
Off

Marker On
MarkerMarker

Off On
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Accessing Marker Utilities
Mode > Dual ARB > More > Marker Utilities

Note: This is the 
second Arb menu.

The display below shows the I 
and Q components of the waveform, and the 
marker points set in a factory–supplied segment.

First sample point 
shown on display

These softkeys change 
the range of waveform 
sample points shown 
on the marker display.

Each press of the 
softkey changes the 
sample range by 
approximately a factor 
of two.Marker points 

on first  
sample point

For details on each key, use key help 
as described on page 60.

The settings in these menus 
can be stored to the file 
header, see page 217.

page 67
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Viewing Waveform Segment Markers

Markers are applied to waveform segments. Use the following steps to view the markers set for a 
segment (this example uses the factory–supplied segment, SINE_TEST_WFM).

1. In the second Arb menu (page 228), press Marker Utilities > Set Markers.
2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).
3. Press Display Waveform and Markers > Zoom in Max. 

The maximum zoom in range is 28 points.

Experiment with the Zoom functions to see how they display the markers.

The display can show a maximum of 460 points; displayed waveforms with a sample point range 
greater than 460 points may not show the marker locations.

Clearing Marker Points from a Waveform Segment

When you set marker points they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set points, view the segment 
(page 229) and remove any unwanted points. With all markers cleared, the level of the event output 
signal is 0V. To clear marker points on a segment, the segment must reside in BBG media 
(page 209).

Clearing All Marker Points

1. In the second Arb menu (page 228), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment (in this example, SINE_TEST_WFM).

3. Highlight the desired marker number: Press Marker 1 2 3 4.

4. For the selected marker number, remove all marker points in the selected segment:

a. Press Set Marker Off Range of Points.

Notice that the softkeys for the first and last marker points correspond with the length of 
the waveform. The factory–supplied waveform (SINE_TEST_WFM) contains 200 samples. To 
clear all set marker points, the range must equal to the length of the waveform.

b. Press Apply To Waveform > Return.

5. Repeat from Step 3 for any remaining marker points that you want to remove from the other 
markers.

Clearing a Range of Marker Points

The following example uses a waveform with marker points (Marker 1) set across points 10−20. This 
makes it easy to see the affected marker points. The same process applies whether the existing 
points are set over a range or as a single point (page 230).‘

1. In the second Arb menu (page 228), press Marker Utilities > Set Markers, then select Marker 
1.

2. Set the first sample point that you want off (for this example, 13): 
Press Set Marker Off Range Of Points > First Mkr Point > 13 > Enter.



 230                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

   Basic Digital Operation (Option 653/655/656/657)
Using Waveform Markers

3. Set the last marker point in the range that you want off to a value less than or equal to the 
number of points in the waveform, and greater than or equal to the value set in Step 2 (for this 
example, 17): 

Press Last Mkr Point > 17 > Enter > Apply To Waveform > Return.

 
This turns off all marker points for the 
active marker within the range set in 
Steps 2 and 3, as shown at right.

How to view markers is described on 
page 229.

Clearing a Single Marker Point

Use the steps described in “Clearing a Range of Marker Points” on page 229, but set both the first 
and last marker point to the value of the point you want to clear. For example, if you want to clear a 
marker on point 5, set both the first and last value to 5.

Setting Marker Points in a Waveform Segment

To set marker points on a segment, the segment must reside in BBG media (page 209).

When you set marker points, they do not replace points that already exist, but are set in addition to 
existing points. Because markers are cumulative, before you set marker points within a segment, 
view the segment (page 229) and remove any unwanted points (page 229).

Placing a Marker Across a Range of Points

1. In the second Arb menu (page 228), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: Press Marker 1 2 3 4

4. Set the first sample point in the range (in this example, 10):

Press Set Marker On Range Of Points > First Mkr Point > 10 > Enter.

5. Set the last marker point in the range to a value less than or equal to the number of points in 
the waveform, and greater than or equal to the first marker point (in this example, 20):

Press Last Mkr Point > 20 > Enter.

6. Press Apply To Waveform > Return.

This sets a range of waveform marker points. The marker signal starts on sample point 10, and ends 
on sample point 20, as shown in the following figure.
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Placing a Marker on a Single Point

On the First Point

1. In the second Arb menu (page 228), press Marker Utilities > Set Markers.

2. Highlight the desired waveform segment.

3. Select the desired marker number: 
Press Marker 1 2 3 4.

4. Press  Set Marker On First Point.

This sets a marker on the first point in the segment for the marker number selected in Step 3.

On Any Point

Use the steps described in “Placing a Marker Across a Range of Points” on page 230, but set both 
the first and last marker point to the value of the point you want to set. For example, if you want to 
set a marker on point 5, set both the first and last value to 5.

Placing Repetitively Spaced Markers

The following example sets markers across a range of points and specifies the spacing (skipped 
points) between each marker. You must set the spacing before you apply the marker settings; you 
cannot apply skipped points to a previously set range of points.

1. Remove any existing marker points (page 224).

2. In the second Arb menu (page 228), press Marker Utilities > Set Markers.

3. Highlight the desired waveform segment. 

4. Select the desired marker number:  
Press Marker 1 2 3 4.

5. Set the first sample point in the range (in this example, 5): 
Press Set Marker On Range Of Points > First Mkr Point > 5 > Enter.

6. Set the last marker point in the range. (The last marker point value must always be less than 
or equal to the number of points in the waveform, and greater than or equal to the first marker 
point, in this example, 25): 
Press Last Mkr Point > 25 > Enter.

The skipped points value is limited to the size of the range of points.

How to view markers is described on page 229
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7. Enter the number of sample points that you want skipped (in this example, 1): 
Press # Skipped Points > 1 > Enter.

8. Press Apply To Waveform > Return.

This causes the marker to occur on every 
other point (one sample point is skipped) 
within the marker point range, as shown at 
right.

How to view markers is described on 
page 229.

One application of the skipped point feature is the creation of a clock signal as the EVENT output.

Viewing a Marker Pulse

When a waveform plays (page 215), you can detect a set and enabled marker’s pulse at the rear 
panel event connector/Aux I/O pin that corresponds to that marker number. This example 
demonstrates how to view a marker pulse generated by a waveform segment that has at least one 
marker point set (page 230). The process is the same for a waveform sequence.  

This example uses the factory–supplied segment, SINE_TEST_WFM in the dual ARB Player. 
Factory–supplied segments have a marker point on the first sample point for all four markers, as 
shown.

1. In the first Arb menu (page 208), press Select Waveform.

2. Highlight the SINE_TEST_WFM segment and press Select Waveform.

3. Press ARB Off On to On.

4. Connect the signal generator’s rear panel Q OUT output to the oscilloscope’s channel 1 input.

5. Connect the signal generator’s rear panel EVENT 1 output to the oscilloscope’s channel 2 
input. 

Marker points on 
first sample point of 
waveform segment

How to view markers is described on page 229
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When marker 1 is present, the Keysight CXG/MXG/EXG outputs a signal through EVENT 1 as 
shown in the following example.

Q OUT

Marker pulse on the Event 1 signal.
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Using the RF Blanking Marker Function

While you can set a marker function (described as Marker Routing on the softkey label in the 
Marker Utilities menu) either before or after setting the marker points (page 230), setting a marker 
function before you set marker points may change the RF output. RF Blanking includes ALC hold 
(described on page 225, note Caution regarding unleveled power). The signal generator blanks the 
RF output when the marker signal goes low. This example is a continuation of the previous example, 
Viewing a Marker Pulse.

1. Using the factory–supplied segment SINE_TEST_WFM, set Marker 1 across points 1−180 
(page 230).

2. From the Marker Routing softkey menu, assign RF Blanking to Marker 1:  
In the second Arb menu (page 228), press Marker Utilities > Marker Routing > Pulse/RF 
Blank > Marker 1.

Marker Polarity = Positive
When marker polarity is positive (the default 
setting), the RF output is blanked during the off 
marker points.

200180Point 1
Marker

Segment

RF Signal

200180Point 1
Marker

Segment

Marker Polarity = Negative
When marker polarity is negative, the 
RF output is blanked during the on marker 
points

≈3.3V

0V

≈3.3V

0V

RF SignalRF Signal

RF Signal
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Setting Marker Polarity

Setting a negative marker polarity inverts the marker signal.

1. In second Arb menu (page 228), press Marker Utilities > Marker Polarity.

2. For each marker, set the marker polarity as desired.

—The default marker polarity is positive.

—Each marker polarity is set independently.

See also, “Saving Marker Polarity and Routing Settings” on page 224.

As shown on page 234:

Positive Polarity:  On marker points are high (≈3.3V). 

Negative Polarity:  On marker points are low (0V).

RF blanking always occurs on the low part of the signal regardless of the polarity setting.

Controlling Markers in a Waveform Sequence

In a waveform segment, an enabled marker point generates an auxiliary output signal that is routed 
to the rear panel EVENT output (described in “Rear Panel Overview (N5166B, N5171B, N5172B, 
N5181B, & N5182B)” on page 30) corresponding to that marker number. For a waveform 
sequence, you enable or disable markers on a segment–by–segment basis; this enables you to 
output markers for some segments in a sequence, but not for others. Unless you change the 
sequence marker settings or cycle the power, the marker setting for the last segment edited in the 
sequence applies to all segments in the next sequence that you build. For information on building a 
waveform sequence, see “Creating a Sequence” on page 212.
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Figure 9-6 Waveform Sequence Menus for Enabling/Disabling Segment Markers

Mode > Dual ARB > 
More 

Note: This is the second Arb menu.

For details on each key, use key help 
as described on page 60.

Enable/Disable markers while 
creating a waveform sequence

Edit a sequence to 
enable/disable markers
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Enabling and Disabling Markers in a Waveform Sequence

Select the waveform segments within a waveform sequence to enable or disable each segment’s 
markers independently. You can enable or disable the markers either at the time of creating the 
sequence or after the sequence has been created and stored. If the sequence has already been 
stored, you must store the sequence again after making any changes. Enabling a marker that has 
no marker points has no effect on the auxiliary outputs. To set marker points on a segment, see 
“Setting Marker Points in a Waveform Segment” on page 230. This example assumes that a 
waveform sequence exists.

1. Ensure that all waveform segments for the sequence reside in BBG media (see page 209).

2. From the second Arb menu, press Waveform Sequences.

3. Highlight the desired waveform sequence.

4. Press Edit Selected Waveform Sequence > Enable/Disable Markers.

5. Toggle the markers: 

a.Highlight the first waveform segment.

b. As desired, press Toggle Marker 1, Toggle Marker 2, Toggle Marker 3, and Toggle Marker 
4.

An entry in the Mkr column (see figure below) indicates that the marker is enabled for that 
segment; no entry in the column means that all markers are disabled for that segment.

c.In turn, highlight each of the remaining segments and repeat Step b.

6. Press Return > More > Name and Store.

7. Either rename the sequence using the text entry keys (see page 210) or just press Enter to 
save the sequence with the existing name.

The markers are enabled or disabled per the selections, and the changes saved to the sequence 
file.

The following figure shows a sequence built using one of the factory–supplied waveform segments; 
a factory–supplied segment has a marker point on the first sample for all four markers. In this 
example, marker 1 is enabled for the first segment, marker 2 is enable for the second segment, and 
markers 3 and 4 are enabled for the third segment.

For each segment, only the markers enabled for that segment produce a rear panel auxiliary output 
signal. In this example, the marker 1 auxiliary signal appears only for the first segment, because it is 
disabled for the remaining segments. The marker 2 auxiliary signal appears only for the second 
segment, and the marker 3 and 4 auxiliary signals appear only for the third segment.

Sequence marker column

This entry shows that markers 
3 and 4 are enabled for this 
segment.
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Using the EVENT Output Signal as an Instrument Trigger

 
One of the uses for the EVENT output 
signal (marker signal) is to trigger a 
measurement instrument. You can set 
up the markers to start the 
measurement at the beginning of the 
waveform, at any single point in the 
waveform, or on multiple points in the 
waveform. To optimize the use of the 
EVENT signal for measurements, you 
may also need to adjust the sample 
rate. The location of the sample rate setting is shown in the figure at right.

The EVENT output signal can exhibit jitter of up to ±4 ns on the rising and falling edge. This jitter 
can be minimized in either of two ways. 

Method 1: Use a sample clock of 125 MHz/N where N is a positive integer and where 125 MHz/N 
can be represented exactly on the display.  
For example: 125 MHz, 62.5 MHz, 31.25 MHz, 25 MHz, and so on. 

If the result cannot be represented exactly on the display, jitter will be present. 
For example: N = 6 will result in jitter, because 125 MHz/6 = 20.833 Mhz, which is truncated when 
displayed.

Method 2: Select a sample clock and waveform length that spaces the markers by a multiple of 8 
ns. For example: A 200 point waveform with a marker on the first point and a sample clock of 50 
MHz provides a marker every 4 µs. Because 4 µs is a multiple of 8 ns, the jitter is minimized.

When the EVENT output signal exhibits jitter and it is used as a measurement trigger, it can cause 
the waveform to falsely appear as having jitter. If this condition occurs, you can adjust the sample 
rate to a value (see above) that does not cause the jitter appearance. To maintain the integrity of 
the original waveform with a sample rate change, you will have to also recalculate the sample 
values. The following figures illustrate the marker signal jitter and its affect on the waveform.

Sample 
rate  
setting

The settings in this menu 
can be stored to the file 
header, see page 217.

For details on each key, use key help as described on page 60.

The jitter is gone with
an optimal sample rate

Waveform appears to exhibit jitter when
triggered using EVENT signal with jitter.

Oscilloscope triggering on waveform Oscilloscope triggering on EVENT signal Oscilloscope triggering on EVENT signal

EVENT output signal exhibits jitter
due to a non–optimal sample rate
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Triggering a Waveform

Figure 9-7 Triggering Softkeys

Triggers control data transmission by controlling when the signal generator transmits the 
modulating signal. You can configure trigger settings so that data transmission occurs once (Single 
mode), continuously (Continuous mode), or starts and stops repeatedly (Gated and Segment 
Advance modes).

A trigger signal contains both positive and negative states; you can use either for triggering.

When you initially select a trigger mode or when you change from one triggering mode to another, 
you may lose the carrier signal at the RF output until the modulating signal is triggered. This is 
because the signal generator sets the I and Q signals to zero volts prior to the first trigger event. To 
maintain the carrier signal at the RF output, create a data pattern with the initial I and Q voltages 
set to values other than zero. 

When you initially turn the Arb ON or select a trigger mode or when you change from one triggering 
mode to another, you may temporarily lose the carrier signal for a few tens of milliseconds at the RF 
output. The Arb will present the idle IQrms value of the next Arb waveform to the IQ modulator. This 
ensures that the RF carrier output is at the correct amplitude level while the Arb waits for a trigger. 
When that trigger is received, the Arb begins playing the waveform and the modulated RF carrier 
exhibits no undesirable transients.

There are two parts to configuring a waveform trigger:

— Type determines the behavior of the waveform when it plays (see Trigger Type on page 240).

— Source determines how the signal generator receives the trigger that starts the modulating 
waveform playing (see Trigger Source on page 241).

Mode > Dual ARB

page 240

page 241

For details on each key, use key help 
as described on page 60.
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Trigger Type

Type defines the trigger mode: how the waveform plays when triggered. 

— Continuous mode repeats the waveform until you turn the signal off or select a different 
waveform, trigger mode, or response (Free Run, Trigger & Run, Reset & Run).

— Single mode plays the waveform once. 

No Retrigger: If a trigger is received early it will be ignored. The gap in your playback is 
dependent on the trigger period, after which time the RF will start up again where it is expected.

Buffered Trigger: An early trigger will cause the waveform to play to the end and then start 
again. The RF will not be aligned with this early trigger.

Restart on Trigger: The ARB will reset itself and trigger again but there will some gap in the 
playback while this is occurring. It will reset itself for every trigger it receives.

The example above shows Dual ARB Mode, but trigger functionality is 
similar for other modulation modes. Available trigger types vary 
depending on the modulation mode selected.

In Single No Retrigger, do not use Continuous Reset & Run mode due to the 
variable latency of this setup.

Mode > 
Dual ARB > 
Trigger Type

Immediately triggers and plays the waveform; triggers 
received while the waveform is playing are ignored.

Plays the waveform when a trigger is received; 
subsequent triggers are ignored.

Plays the waveform when a trigger is received; subsequent 
triggers restart the waveform.

The waveform stops during the inactive 
state of the trigger source, and plays 
during the active state.

Ignores an early trigger 
received while a 
waveform is playing.

An early trigger received 
while a waveform is 
playing waits until the 
current waveform 
completes, then plays 
the waveform once 
more.

An early trigger received 
while the waveform is 
playing immediately 
restarts the waveform.

A segment in a sequence plays 
once, ignoring the repetition 
setting, after which the dual ARB 
player stops and waits for a 
trigger before advancing to the 
next segment. The next segment 
then plays to completion.  
 
If a trigger is received while a 
segment is playing, the segment 
plays to completion. The dual 
ARB player then advances to the 
next segment and plays that 
segment to completion.

A segment in a sequence plays continuously until the waveform receives another trigger.  
 
If a trigger is received while a segment is playing, the segment plays to completion. The 
dual ARB player then advances to the next segment and plays that segment continuously. 

For details on each key, use key help 
as described on page 60.
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— Segment Advance mode plays a segment in a sequence only if triggered. The trigger source 
controls segment–to–segment playing (see Example: Segment Advance Triggering on page 
242). A trigger received during the last segment loops play to the first segment in the sequence.

— Gated mode triggers the waveform at the first active triggering state, then repeatedly starts and 
stops playing the waveform in response to an externally applied gating signal. See Example: 
Gated Triggering on page 243.

Trigger Source

External Trigger Polarity

— In Continuous, Single, and Segment Advance modes, use the Ext Polarity softkey to set the 
external trigger polarity.

— In Gated mode, the Active Low and Active High softkeys (page 240) determine the external 
trigger polarity. 

Mode > 
Dual ARB > 
Trigger Source

Patt Trig In BNC connector  
(see page 34)

Aux I/O connector  
(see page 35)

Neg = the signal generator 
responds during the trigger signal 
low state.

Pos = the signal generator 
responds during the trigger signal 
high state.

For details on each key, use key help 
as described on page 60.

Key inactive until Ext 
Delay is enabled On.
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Example: Segment Advance Triggering

Segment advance triggering enables you to control the segment playback within a waveform 
sequence. This type of triggering ignores the repetition value (page 214). For example if a segment 
has repetition value of 50 and you select Single as the segment advance triggering mode, the 
segment still plays only once. The following example uses a waveform sequence that has two 
segments.

If you have not created and stored a waveform sequence, refer to “Creating a Sequence” on 
page 212.

1. Preset the signal generator.

2. Configure the RF output:

—Set the desired frequency.

—Set the desired amplitude.

—Turn on the RF output.

3. Select a waveform sequence for playback:

a. Press Mode > Dual ARB > Select Waveform.

b. In the Sequence On column, highlight a waveform sequence file.

c. Press Select Waveform.

4. Set the triggering as follows:

— Trigger Type: continuous Segment Advance 
Press Trigger Type > Segment Advance > Continuous.

— Trigger source: Trigger hardkey 
Press Trigger Source > Trigger Key.

5. Generate the waveform sequence:  
Press ARB Off On until On highlights.

6. (Optional) Monitor the waveform:

Connect the RF OUTPUT of the signal generator to the input of an oscilloscope, and configure 
the oscilloscope so that you can see the signal.

7. Trigger the first waveform segment to begin playing continuously:  
Press the Trigger hardkey.

8. Trigger the second segment:  
Press the Trigger hardkey.

Pressing the Trigger hardkey causes the currently playing segment to finish and the next 
segment to start.

If the last segment in the sequence is playing, pressing the Trigger hardkey causes the first 
segment in the waveform sequence to start when the last segment finishes.
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Example: Gated Triggering

Gated triggering enables you to define the on and off states of a modulating waveform.

1. Connect the output of a function generator to the signal generator’s rear panel PAT TRIG IN 
connector, as shown in the following figure. This connection is applicable to all external 
triggering methods. The optional oscilloscope connection enables you to see the effect that 
the trigger signal has on the RF output.

2. Preset the signal generator.

3. Configure the RF output:

—Set the desired frequency.

—Set the desired amplitude.

—Turn on the RF output.

4. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.

b. In the Segment On or Sequence On column, highlight a waveform.

c. Press Select Waveform.

5. Set the triggering as follows:

— Trigger type: Gated 
Press Trigger Type > Gated.

— Active state: Low 
Press Active Low.

— Trigger source: External 
Press Trigger Source > Ext.

— Input connector: Rear panel Patt Trig In BNC 
Press Ext Source > Patt Trig In 1.

6. Generate the waveform: Press Return > ARB Off On until On highlights.

7. On the function generator, configure a TTL signal for the external gating trigger.
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8. (Optional) Monitor the waveform:

Configure the oscilloscope to display both the output of the signal generator, and the external 
triggering signal. You will see the waveform modulating the output during the gate active 
periods (low in this example).

The following figure shows an example display.

RF Output

Externally Applied Gating Signal 
Gate Active = Low

Modulating Waveform
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Example: External Triggering

Use the following example to set the signal generator to output a modulated RF signal 
100 milliseconds after a change in TTL state from low to high occurs at the PATT TRIG IN rear panel 
BNC connector

1. Connect the signal generator to the function generator as shown above.

2. Configure the RF output:

—Set the desired frequency.
—Set the desired amplitude.
—Turn on the RF output.

3. Select a waveform for playback (sequence or segment):

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On or Sequence On column, highlight a waveform.
c. Press Select Waveform.

4. Generate the waveform:  
Press ARB Off On until On highlights.

5. Set the waveform trigger as follows:

a. Trigger Type: single 
Press Trigger Type > Single > No Retrigger

b. Trigger Source: external 
Press Trigger Source > Ext

c. Input connector: Rear panel Patt Trig In BNC 
Press Ext Source > Patt Trig In 1.

d. External Trigger Polarity: positive 
Press Ext Polarity until Pos highlights

e. External Delay: 100 ms 
Press More > Ext Delay until On highlights 
Press Ext Delay Time > 100 > msec

6. Configure the Function Generator:

—Waveform: 0.1 Hz square wave
—Output Level: 3.5V to 5V. 
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Clipping a Waveform
Digitally modulated signals with high power peaks can cause intermodulation distortion, resulting 
in spectral regrowth that can interfere with signals in adjacent frequency bands. The clipping 
function enables you to reduce high power peaks by clipping the I and Q data to a selected 
percentage of its highest peak, thereby reducing spectral regrowth.

— How Power Peaks Develop on page 247

— How Peaks Cause Spectral Regrowth on page 249

— How Clipping Reduces Peak–to–Average Power on page 250

— Configuring Circular Clipping on page 253

— Configuring Rectangular Clipping on page 254

Figure 9-8 Clipping Softkeys

Mode > Dual ARB > More 

Available only when  
clipping type = |I|, |Q|

For details on each key, use key help 
as described on page 60.
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How Power Peaks Develop

To see how clipping reduces high power peaks, it is important to understand how the peaks 
develop as you construct a signal.

Multiple Channel Summing

I/Q waveforms can be the summation of multiple channels, as shown in the following figure. If a bit 
in the same state (high or low) occurs simultaneously in several individual channel waveforms, an 
unusually high power peak (positive or negative) occurs in the summed waveform. 

Because the high and low states of the bits in channel waveforms are random and generally result 
in a canceling effect, high power peaks occur infrequently with multiple channel summing.
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Combining the I and Q Waveforms

When the I and Q waveforms combine in the I/Q modulator to create an RF waveform, the 

magnitude of the RF envelope is , where the squaring of I and Q always results in a positive 
value.

As shown in the following figure, simultaneous positive and negative peaks in the I and Q 
waveforms do not cancel each other, but combine to create an even greater peak.



Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide                                                         249

   Basic Digital Operation (Option 653/655/656/657)

Clipping a Waveform

How Peaks Cause Spectral Regrowth

In a waveform, high power peaks that occur infrequently cause the waveform to have a high peak–
to–average power ratio, as illustrated in the following figure. 

Because the gain of a transmitter’s power amplifier is set to provide a specific average power, high 
peaks can cause the power amplifier to move toward saturation. This causes the intermodulation 
distortion that generates spectral regrowth. Spectral regrowth is a range of frequencies that 
develops on each side of the carrier (similar to sidebands) and extends into the adjacent frequency 
bands (see the following figure). Clipping provides a solution to this problem by reducing the peak–
to–average power ratio.
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How Clipping Reduces Peak–to–Average Power

You can reduce peak–to–average power, and consequently spectral regrowth, by clipping the 
waveform. Clipping limits waveform power peaks by clipping the I and Q data to a selected 
percentage of its highest peak. The Signal Generator provides two methods of clipping:

— Circular clipping is applied to the composite I/Q data (I and Q data are equally clipped).

As shown in Figure 9-9, the clipping level is constant for all phases of the vector and appears as 
a circle in the vector representation.

— Rectangular clipping is independently applied the I and Q data.

 As shown in Figure 9-10 on page 251, the clipping level is different for I and Q, and appears as 
a rectangle in the vector representation.

In both circular and rectangular clipping, the objective is to clip the waveform to a level that 
reduces spectral regrowth but does not compromise the integrity of the signal. The two 
complementary cumulative distribution plots in Figure 9-11 on page 252 show the reduction in 
peak–to–average power that occurs after applying circular clipping to a waveform.

The lower the clipping value, the lower the peak power that is passed (the more the signal is 
clipped). The peaks can often be clipped without substantially interfering with the rest of the 
waveform. In many cases, data that might otherwise be lost in the clipping process is retained 
because of the error correction inherent in the coded systems. If you apply excessive clipping, 
however, lost data cannot be recovered. Experiment with clipping settings to find a percentage that 
reduces spectral regrowth while retaining needed data.

Figure 9-9 Circular Clipping
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Figure 9-10 Rectangular Clipping
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Figure 9-11 Reduction of Peak–to–Average Power
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Configuring Circular Clipping

Use this example to configure circular clipping and observe its affect on the peak–to–average 
power ratio of a waveform. Circular clipping clips the composite I/Q data (I and Q data are clipped 
equally). For more information about circular clipping, refer to “How Clipping Reduces Peak–to–

Average Power” on page 250.

Copy a Waveform File

1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_CIRC) and press Enter.

Apply Circular Clipping to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform 
Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_CIRC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of the 
waveform’s curve (the dark line in the 
example at right).

5. Activate circular clipping: Press Return > 
Clipping > Clipping Type until |I+jQ| 
highlights.

6. Set circular clipping to 80%:  
Press Clip |I+jQ| To > 80 > %.

7. Apply 80% clipping to the I and Q data: Press Apply to Waveform.

8. Create the CCDF plot (see the example 
at right): Press Plot CCDF. 

9. Observe the waveform’s curve after 
clipping. 

Note the reduction in peak–to–average 
power relative to the previous plot.

Clipping is non–reversible and cumulative. Save a copy of the waveform 
file before you apply clipping.

Example waveform curve before clipping 

Example waveform curve after circular clipping
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Configuring Rectangular Clipping

Use this example to configure rectangular clipping. Rectangular clipping clips the I and Q data 
independently. For more information about rectangular clipping, refer to “How Clipping Reduces 

Peak–to–Average Power” on page 250.

Copy a Waveform File

1. Display the signal generator’s files: Press File > Catalog Type > More > Volatile Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

4. Name the copy (in this example, the name is MY_TEST_REC) and press Enter.

Apply Rectangular Clipping to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: Press Mode > Dual ARB > More > Waveform 
Utilities.

2. In the list of files, highlight the copied file (in this example, MY_TEST_REC).

3. Create the CCDF plot: Press Plot CCDF. 

4. Observe the shape and position of the 
waveform’s curve (the dark line in the 
example at right).

5. Activate rectangular clipping: Press 
Return > Clipping > Clipping Type until 
|I|,|Q| highlights.

6. Set 80% clipping for the I data: Press 
Clip |I| To > 80 > %.

7. Set 40% clipping for the Q data: Press Clip |Q| To > 40 > %.

8. Apply the rectangular clipping to the waveform: Press Apply to Waveform.

9. Create the CCDF plot (see the example 
at right): Press Plot CCDF. 

10.Observe the waveform’s curve after 
clipping. 

Note the reduction in peak–to–average 
power relative to the previous plot.

Clipping is non–reversible and cumulative. Save a copy of the waveform 
file before you apply clipping.

Example waveform curve before clipping 

Example waveform curve after rectangular 
clipping
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Scaling a Waveform
The signal generator uses an interpolation algorithm (sampling between the I/Q data points) when 
reconstructing a waveform. For common waveforms, this interpolation can cause overshoots, which 
may create a DAC over–range error condition. This chapter describes how DAC over–range errors 
occur and how you can use waveform scaling to eliminate these errors.

— How DAC Over–Range Errors Occur on page 256

— How Scaling Eliminates DAC Over–Range Errors on page 257

— Keysight CXG/MXG/EXG waveform scaling on page 258 and page 259:

—Waveform runtime scaling to scale a currently–playing waveform

—Waveform scaling to permanently scale either the currently playing waveform, or a non–
playing waveform file in BBG media

Figure 9-12 Scaling Softkeys

For details on each key, use key help 
as described on page 60.

The settings in this menu can 
be stored to the file header, 
see page 217.

Waveform Runtime Scaling, see page 258.

Waveform Scaling, see page 259.
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How DAC Over–Range Errors Occur

The signal generator uses an interpolator 
filter when it converts digital I and Q 
baseband waveforms to analog 
waveforms. Because the clock rate of the 
interpolator is four times that of the 
baseband clock, the interpolator 
calculates sample points between the 
incoming baseband samples and smooths 
the waveform as shown in the figure at 
the right.

The interpolation filters in the DACs 
overshoot the baseband waveform. If a 
baseband waveform has a fast–rising 
edge, the interpolator filter’s overshoot 
becomes a component of the interpolated 
baseband waveform. This response 
causes a ripple or ringing effect at the 
peak of the rising edge. If this ripple 
overshoots the upper limit of the DAC 
range, the interpolator calculates 
erroneous sample points and is unable to 
replicate the true form of the ripple (see 
the figure at the right). As a result, the 
signal generator reports a DAC over–
range error.
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How Scaling Eliminates DAC Over–Range Errors

Scaling reduces the amplitude of the baseband 
waveform while maintaining its basic shape and 
characteristics, such as peak–to–average power 
ratio. If the fast–rising baseband waveform is 
scaled enough to allow an adequate margin for 
the interpolator filter overshoot, the interpolator 
filter can calculate sample points that include the 
ripple effect and eliminate the over–range error 
(see the figure at the right).

Although scaling maintains the basic shape of the 
waveform, excessive scaling can compromise 
waveform integrity. For example, if the bit 
resolution becomes too low the waveform 
becomes corrupted with quantization noise. To 
achieve maximum accuracy and optimize 
dynamic range, scale the waveform no more than 
is required to remove the DAC over–range error. 
Optimum scaling varies with waveform content.
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Setting Waveform Runtime Scaling

Runtime scaling scales the waveform data during playback; it does not affect the stored data. You 
can apply runtime scaling to either a segment or sequence, and set the scaling value either while 
the ARB is on or off. This type of scaling is well suited for eliminating DAC over–range errors. 
Runtime scaling adjustments are not cumulative; the scaling value is applied to the original 
amplitude of the waveform file. There are two ways to save the runtime scaling setting: by using the 
save function (page 84) and by saving the setting to the file header (page 219). Saving to the file 
header saves the value with the waveform file, saving with the Save function stores the value as the 
current instrument setting.

Use this example to learn how to scale the currently selected waveform. 

1. Select the waveform to which you want to apply scaling:

a. Press Mode > Dual ARB > Select Waveform.
b.Highlight the desired waveform (segment or sequence).
c. Press Select Waveform.

2. Play the selected waveform: Press ARB Off On until On highlights.

3. Set the Waveform Runtime Scaling value: 

a. Press ARB Setup > Waveform Runtime Scaling. 

b.Enter a scaling value.

The signal generator automatically applies the new scaling value to the waveform. There is 
no single value that is optimal for all waveforms. To achieve the maximum dynamic range, 
use the largest scaling value that does not result in a DAC over–range error. 

c. Press Return. 
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Setting Waveform Scaling

Waveform scaling differs from waveform runtime scaling in that it permanently affects waveform 
data and only applies to waveform segments stored in BBG media. You scale the waveform either 
up or down as a percentage of the DAC full scale (100%). If you scale your waveforms using this 
method, you may also need to change the waveform runtime scaling value to accommodate this 
scaling.

When you scale, the signal generator permanently modifies the waveform file’s sample values so 
that they conform to the desired scaling value. When you initiate scaling, the signal generator 
performs the following actions:

— locates the waveform file’s absolute peak sample value
— determines its current percentage of full scale
— calculates the ratio of the desired scale value to the determined absolute peak sample scale 

value
— multiplies each sample in the waveform file by this ratio

When you scale a waveform, you can create fractional data, lose data, or both. Fractional data 
occurs almost every time you reduce or increase the scaling value, and causes quantization errors. 
Quantization errors are more noticeable when scaling down, since you are closer to the noise floor. 
You lose data when either the signal generator rounds fractional data down or the scaling value is 
derived using the results from a power of two. This means that scaling a waveform in half (power of 
two: 21 = 2) causes each waveform sample to lose one bit. The waveform data modifications are not 
correctable and may cause waveform distortion. It is always best to make a copy of the original file 
prior to applying scaling.

Use the following examples to apply waveform scaling to a waveform file. While this process uses 
the factory–supplied waveform RAMP_TEST_WFM, it is the same for any waveform file.

Copy a Waveform File

1. Display the waveform files in BBG media: Press File > Catalog Type > More > Volatile 
Segments.

2. Highlight the waveform RAMP_TEST_WFM.

3. Press Copy File.

Peak sample

85% of full scale—Prescaling

60% of full scale–Post scaling

DAC full scale 100%

Scaled sample value = scaling ratio × prescale sample val

Scaling ratio = desired scale val / current scale val
                     = 60 / 85
                     = 0.70588

Each sample in the waveform is multiplied by 0.70588 to
reach the 60% post scaling waveform amplitude.

Original ramp waveform Scaled ramp waveform

= Samples
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4. Name the copy (this example uses the name MY_TEST_SCAL) and press Enter.

Apply Scaling to the Copied Waveform File

1. Open the DUAL ARB Waveform Utilities menu: 

Press Mode > Dual ARB > More > Waveform Utilities.

2. In the list of BBG Media segment files, highlight the copied file (in this example, 
MY_TEST_SCAL).

3. Set and apply a scaling value (in this example 70% scaling is applied): 

Press Scale Waveform Data > Scaling > 70 > % > Apply to Waveform.

This type of scaling is non–reversible. Any data lost in the scaling 
operation cannot be restored. Save a copy of the waveform file before 
scaling.
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Setting the Baseband Frequency Offset
The baseband frequency offset specifies a value to shift the baseband frequency up to ±50 MHz 
within the BBG 100 MHz signal bandwidth, depending on the signal generator’s baseband 
generator option. While the following figure shows how to access the control using the Dual ARB 
player, the location of the Baseband Frequency Offset softkey within each ARB format, through the 
ARB Setup softkey, is the same as for the Dual ARB player.

When the Baseband Frequency Offset is non–zero, the hardware rotator accumulates phase–shift 
of the baseband signal. This residual phase remains even after the offset value is returned to zero. 
To remove this phase accumulation, either restart the personality or select the Baseband 
Frequency Offset Phase Reset softkey. This softkey will grey out whenever the phase, due to the 
frequency offset, is zero. In addition, while there is a non–zero residual phase present in the signal, 
the DAC Over–Range Protection feature will automatically ensure that the reduced internal scaling 
is applied. This reduced scaling will be removed when both the frequency offset is returned to zero 
and the phase is reset. 

Figure 9-13 Baseband Frequency Offset Softkey for the Dual ARB Player

Common uses for the offset feature include:

— offsetting the carrier from any LO feedthrough (carrier signal spur at the carrier frequency)
— sum the baseband signal with external I and Q inputs to create a multicarrier signal
— use the signal generator’s I/Q signal as an IF

page 364

Sets the Baseband 
Frequency Offset value 
entered in the signal to 
baseband.

Clears the phase 
accumulation and so zeros 
the phase shift. Causes a 
sudden phase shift 
discontinuity of the 
baseband signal.

The settings in this menu can 
be stored to the file header, 
see page 217.

For details on each key, use key help 
as described on page 60.

page 364

page 263

page 285

page 255

page 285
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The baseband frequency offset value is one of the file header parameters (page 217), which means 
you can store this value with the waveform. When you select a waveform with a stored frequency 
offset value, the signal generator changes the current value to match the stored file header value. If 
there is no stored baseband offset frequency value for the current waveform, the signal generator 
uses the last set frequency offset value. 

You can also use the Save function (page 84) to store this value as part of the signal generator 
setup. When you Recall a setup stored with the Save function, the baseband frequency offset value 
becomes the current instrument setting value, disregarding the stored file header value.

Use the following steps to offset the carrier from LO/carrier feedthrough. This example uses the 
factory supplied waveform, SINE_TEST_WFM available in the Dual ARB Player. To view the output 
for this example, connect the RF OUTPUT of the signal generator to the input of a spectrum 
analyzer.

1. Select and play the waveform.

a. Press Mode > Dual ARB > Select Waveform.
b. In the Segment On BBG Media column, select SINE_TEST_WFM.
c. Press Select Waveform.

2. Generate the waveform: Press ARB Off On to On.

3. Configure the carrier signal:

a.Set the carrier signal to 1 GHz.
b.Set the amplitude to 0 dBm.
c.Turn on the RF OUTPUT.

4. Press Mode > Dual Arb > ARB Setup > More > Baseband Frequency Offset > 20 MHz.

The modulated RF signal is now offset from the carrier frequency by 20 MHz as shown in the 
following figures.

Changing the baseband frequency offset may cause a DAC over range condition that generates 
error 628, Baseband Generator DAC over range. The signal generator 
incorporates an automatic scaling feature to minimize this occurrence. For more information, see 
“DAC Over–Range Conditions and Scaling” on page  263.
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DAC Over–Range Conditions and Scaling

When using the baseband frequency offset (at a setting other than 0 Hz), it is possible to create a 
DAC over–range condition, which causes the Keysight CXG/MXG/EXG to generate an error. To 
minimize this condition with the frequency offset feature, the Keysight CXG/MXG/EXG incorporates 
an automatic DAC over–range protection feature that scales down the I/Q data by 1/square root of 
2 when the offset is something other than zero. Because it can scale the data by more than what is 
actually need, it typically decreases the dynamic range of the waveform. This is especially 
noticeable when using a constant amplitude signal such as GSM.

For the Dual ARB Player, this automatic over–range feature can be turned off. When on, it is active 
for the Dual ARB signal only when the offset is something other than 0 Hz. The control for the Dual 
ARB DAC over–range protection feature is located in the key path as shown in Figure 9-14.

Modulated carrier with 0 Hz 
baseband frequency offset

Modulated carrier with 20 MHz 
baseband frequency offset Modulated RF signal

LO/carrier feedthrough

Spectrum analyzer set to a span of 100 MHz
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Figure 9-14 Dual ARB DAC Over–Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
feature off and use the Waveform Runtime Scaling softkey to eliminate DAC over–range 
conditions.

For details on each key, use key help 
as described on page 60.

Default setting is On. Available only 
when Phase Noise or AWGN are on 
(see page 371), or when the 
baseband frequency offset is set to a 
value other than zero.
Turn off when you want to manually 
control scaling while using the 
baseband frequency offset feature. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
above.
Enables or disables the automatic 
internal scaling used to keep DAC 
over-range errors from occuring with 
the Phase Noise, AWGN and 
Frequency Offset features. This 
automatic scaling can be excessive 
(particularly for a constant amplitude 
signal) and thus reduce the dynamic 
range more than is necessary.
When the protection is disabled, no 
automatic scaling occurs, so the 
Runtime Scaling feature must be 
used to adjust for the highest scaling 
value that does not cause DAC 
overranges.
Since the over-range protection 
works with only three features, this 
key grays out until one of the three 
features is active even when the 
protection is on. 

When the DAC over–range protection is off, 
eliminate over–range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on 
page 258).

page 285
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I/Q Modulation
The following factors contribute to the error vector magnitude:

— Differences in amplitude, phase, and delay between the I and Q channels

— DC offsets

The I/Q menu not only enables you to select the I/Q signal source and output, it also provides 
adjustments and calibrations to compensate for differences in the I and Q signals.

See also, “Modulating the Carrier Signal” on page 74.
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Figure 9-15 I/Q Display and Softkeys

These selections are 
reflected in the  
I/Q Routing & 
Optimization graphic.page 269

This panel displays the current 
settings for the I/Q signal routing 
and I/Q correction optimized path.

This panel displays the current status and settings 
of the I/Q adjustments. Use the Page Up and 
Page Down keys to scroll through these 
parameters. Grey indicates an inactive (off) 
adjustment.

Used only with internally generated, bursted modulation 
formats. Enables/disables the RF burst modulator.

For details on each key, use key help 
as described on page 60.

Each path requires different optimization values; 
when you select a path, you are selecting the 
unique optimization values required by that path. 
The signal generator applies the selected 
optimization values to all paths, which impairs the 
unselected paths.

Inverts an internally generated Q signal, so that the I component lags the 
Q component by 90 degrees.

Opens the internal I/Q Equalization Filter which can be used 
to correct and/or impair the RF and External I/Q outputs for 
the internal I/Q source.
Selects between optimizing the internal I/Q channel for EVM (in channel 
performance) at the expense of ACP (out of channel performance) or 
optimizing for ACP at the expense of EVM.
EVM is an 80% nyquist filter (100Mhz wide) with a wide transition band. 
When an equalization filter is active, this filter is not active.
ACP is also an 80% nyquist filter (100Mhz wide), but the transition band 
is very narrow, thus reducing images for wide-band signals. This filter will 
be convolved with the active equalization filter and the Int Channel 
Correction filter (if it is on), the result of which will be truncated to the 
center 256 taps.
SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:OPTimization EVM|ACP
[:SOURce]:DM:INTernal:CHANnel:OPTimization?

Toggles on or off the application of the internal baseband generator RF, and baseband magnitude and 
phase corrections across the 160MHz baseband bandwidth at the current RF frequency.
When this feature is on, arbitrary frequency switching while the baseband is on will take up to an 
additional 3.3ms (typical) to 6.8ms the first time that frequency is specified. After that, switching to that 
frequency will take up to an additional 1.3ms.
Up to 1024 unique frequencies can be cached before the oldest cache will be forgotten. If a frequency 
sweep is activated, then the calculation and caching will occur up front for the first 1024 unique 
frequencies, and all further unique frequencies will have the characteristics of arbitrary frequency 
switching.
If the I/Q Correction Optimized Path is set to Ext I/Q Output, then only the baseband corrections will be 
applied and the frequency switching speed will be unaffected.
This correction will be convolved with the ACP Internal I/Q Channel Optimization filter and the 
Equalization filter if they are active. The resulting filter will be truncated to 256 taps.
SCPI Commands:
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe] ON|OFF|1|0
[:SOURce]:DM:INTernal:CHANnel:CORRection[:STATe]?

page 270
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Using the Rear Panel I and Q Outputs

In addition to modulating the carrier, the signal generator also routes the internally generated I and 
Q signals to the rear panel I and Q connectors. These output signals are post DAC, so they are in 
analog form. You can use these rear panel I and Q signals to:

— drive a system’s transmitter stage
— test individual analog I and Q components such as an I/Q modulator
— route the I and Q signals into another signal generator

The factory default setting routes the internally generated I and Q signals to the I/Q modulator and 
the rear panel I and Q output connectors. However to optimize (apply calibration factors) the rear 
panel signals, you need to select the external I/Q output path.

Select and Play a Waveform

1. Press Mode > Dual ARB > Select Waveform.
2. Highlight the desired waveform.
3. Press Select Waveform > ARB Off On to On.

Optimize the Signal Path

1. Connect cables from the rear panel I and Q connectors to either a DUT or another signal 
generator.

When you turn the ARB on, the signal generator automatically outputs the I and Q signals to 
the rear panel connectors. You can use the rear panel I and Q signals as I and Q inputs to 
another signal generator. The CXG/MXG/EXG has front panel connectors, I Input and Q Input, 
for this purpose.

2. Press I/Q > I/Q Correction Optimized Path > Ext I/Q Output.

When you optimize a path, the path indicator turns green.

The rear panel I and Q connectors only output a signal while using the 
internal BBG.

Factory default setting—RF Output path optimized

Rear panel I/Q path optimized
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Configuring the Front Panel Inputs

The signal generator accepts externally supplied analog I and Q signals through the front panel I 
Input and Q Input. You can use the external signals as the modulating source, or sum the external 
signals with the internal baseband generator signals.

1. Connect I and Q signals to the front panel connectors.

a.Connect an analog I signal to the signal generator’s front panel I Input.

b.Connect an analog Q signal to the signal generator’s front panel Q Input.

2. Set the signal generator to recognize the front panel input signals: 

—To Modulate onto the Carrier

Press I/Q > I/Q Source > External.

—To Sum and Modulate onto the Carrier

Press I/Q > I/Q Source > Sum.

To select and play a waveform for the BB GEN path, see page 210.

Notice that only the internal BBG (BB GEN) routes I and Q signals to the rear panel I and Q 
outputs.

3. If you are using only the external I and Q signals (no summing), turn on the I/Q modulator:  
Press I/Q Off On to On.

4. Configure the RF output:

a.Set the carrier frequency.

b.Set the carrier amplitude.

c.Turn the RF output on.

Signal generator display: both paths are calibrated 
when the I/Q Correction Optimized Path is set to 
Ext I/Q Output (see page 267)

Note: when the optimized path is set to RF, only the 
RF Out path is calibrated.

Signal generator display: both RF paths are calibrated 
when the I/Q Correction Optimized Path is set to 
RF Output (see page 267)
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I/Q Adjustments
Use the I/Q Adjustments to compensate for or add impairments to the I/Q signal.

I/Q > I/Q Adjustments

Available only when a 
waveform is playing.

Adjusts the I signal amplitude relative to the Q 
signal amplitude. Use this as an internal 
impairment, or to compensate for differences in 
signal path loss that occur due to path irregularities 
in the external I and Q output cabling.

Offsets the phase of the Q signal 
relative to the phase of the I signal. 
The baseband quadrature 
adjustment key is calibrated in units 
of degrees. The external input 
quadrature adjustment is not 
calibrated. 
The function provided by this key is 
not the same as the function 
provided by the I/Q Skew key.

Skew is typically used either to create 
impairments, or to reduce error vectors on large 
bandwidth signals.
Provides a relative time delay correction between 
the I and Q signals. The different signal paths 
traveled by the I and Q signals result in time delay 
differences that show up as an EVM error in large 
bandwidth modulated signals. 
Adding an equal and opposite time delay (skew) in 
the I/Q signals during baseband generation 
eliminates the time delay error, correcting for any 
delays in signals that are generated in the internal 
baseband generator. 

Changes the absolute phase of 
both the I and Q signals with 
respect to triggers and markers. 
Positive values add delay and 
negative values advance the 
signals. This value affects both 
the baseband signal modulated 
onto the RF and the external 
output signals (I and Q). This 
setting cannot be used with 
constant envelope modulation 
and it does not affect external I 
and Q inputs.

Offsets are typically used to either reduce carrier leakage, or to create an impairment that simulates carrier leakage.

Common Mode I/Q Offset Range
This changes the adjustment range of the Common Mode I/Q Offset from Coarse (Default) to fine or vice versa. The Coarse 
range corresponds to the default value of ± 2.5V. The Fine range corresponds to a value of ± 100 mV.
Common Mode I/Q Offset
This adjusts the DC offset of both I and Q signals simultaneously.
Diff Mode I Offset
This adjusts the DC offset level of the I and I–bar output signal. I and I–bar cannot be adjusted independently.
Diff Mode Q Offset
This adjusts the DC offset level of the I and I–bar output signal. I and I–bar cannot be adjusted independently.

The DC offset values are calibrated relative to 
the RMS waveform voltage being played out of 
the ARB. See page 220.

The I/Q Attenuator softkey affects the I/Q signal to the 
RF Output and the External I/Q Outputs.

This softkey is active when the I/Q optimized path is set 
to Ext I/Q Output and a digital modulation personality 
is on. This attenuation is also adjustable using the Mod 
Attenuator key located in the Arb Setup menus in each 
personality. This adjustment is not affected by the I/Q 
Adjustments On/Off key. 

When Auto mode is selected, the signal generator 
automatically optimizes I/Q attenuation for the current 
conditions. When the Manual mode is selected, I/Q 
Attenuation is the active function. The value you enter 
sets the attenuation level of the I/Q signal.

SCPI Commands (Refer to the commands for each 
personality):
[:SOURce]:RADio:<personality>:IQ:MODulation:ATTen

This feature allows adjustment of the absolute phase of the internal I/Q channel by 
rotating both I and Q, thus adjusting the relative phase of the RF carrier. For option 
012, this is the only way to adjust the RF phase for a unit with an external LO.

Note: The I/Q signal will be 
scaled down by 0.7071 for all 
phase offsets except 0. Use 
-360 or +360, if it is desirable 
to maintain a constant power 
level with the ALC off while 
adjusting the I/Q phase.
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The I/Q adjustment, I/Q Delay, is not for adding impairments; its function is to compensate for any 
latency between the EVENT output signals (marker signals) and the RF output.

I/Q Calibration
Use the I/Q calibration for I and Q signal corrections. What aspects of the I and Q signal is corrected 
depends on whether the signal is internally or externally generated.

When you perform an I/Q calibration, that calibration data takes precedence over the factory–
supplied calibration data. The calibration routines improve performance that may degrade over 
time or due to temperature changes. An I/Q calibration should be run when the ambient 
temperature has varied by at least ±5 degrees Celsius from the ambient temperature at which the 
previous calibration was run.

— The user I/Q calibration is persistent (i.e. Pressing instrument preset or cycling power does not 
remove the user I/Q calibration from memory).

— If the start and stop frequencies are set to the same value, then the calibration will be performed 
exactly at that frequency and the data will be persisted in the bounding calibration array 
elements.

Table 9-2 I/Q Adjustments Uses

I/Q Adjustment Effect Impairment

Offset Carrier feedthrough dc offset

Quadrature Angle
EVM error phase skew

I/Q images I/Q path delay

I/Q Skew EVM error
high sample rate phase 
skew or I/Q path delay

I/Q Gain Balance I/Q amplitude difference I/Q gain ratio

I/Q Phase I/Q phase rotation RF phase adjustment

Correction Internal I and Q External I and Q

Offset X X

Gain Balance X X

Quadrature 
Error

X X
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I/Q > I/Q Calibration

Available only when 
Calibration type = User

DC optimizes the I/Q performance for the current 
instrument settings, and typically completes in several 
seconds. Changing any instrument setting after performing 
a DC calibration voids the DC calibration and causes the 
signal generator to revert to the user calibration data (or 
factory-supplied calibration data, if no user calibration data 
exists)
User provides a quicker calibration when a full calibration 
is not required. You can limit the calibration by specifying 
the calibration start and stop frequencies. 
When you limit the calibration to less than the instrument’s 
full frequency range, the factory−supplied calibration data 
is used for the rest of the range. If the start and stop 
frequencies are set to the same value, then the calibration 
will be performed exactly at that frequency and the data will 
be persisted in the bounding calibration array elements. 
Information is retained through a preset or power cycle*.
Full takes approximately a minute, executing 
measurements over the instrument’s entire frequency 
range. 
Information is retained through a preset or power cycle*.
*Caution: 
To avoid the loss of data, GPIB settings, or current user 
instrument states that have not been permanently saved to 
non-volatile memory, the signal generator should always be 
powered down either via the Instrument’s front panel power 
button or the appropriate SCPI command. Signal 
generators installed in rack systems and powered down 
with the system rack power switch rather than the 
instrument’s front panel switch display an Error -310 due to 
the instrument not being powered down correctly.

Deletes any user–generated 
calibration data and restores 
the factory−supplied 
calibration data.

Note
A DC calibration requires the following settings:
• I/Q: On
• Optimized Path: RF Output
• Source: Internal

For details on each key, use key help 
as described on page 60.



 272                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

   Basic Digital Operation (Option 653/655/656/657)
Using the Equalization Filter

Using the Equalization Filter
An equalization FIR file can be created externally, uploaded via SCPI, and subsequently selected 
from the file system (refer to “Working with Files” on page 76). For information related to 
downloading FIR file coefficients, refer to the Programming Guide. For information regarding 
working with FIR file coefficients manually, refer to “Modifying a FIR Filter Using the FIR Table 
Editor” on page 280.

This filter can be used to correct and/or impair the RF and External I/Q outputs for the internal I/Q 
source. This filter will be convolved with the ACP Internal I/Q Channel Optimization filter if that filter 
is selected, the result of which will be truncated to the center 256 taps. The equalization filter 
operates at 200 MHz, so all equalization filters must be resampled to 200 MHz prior to selection, if 
they are sampled at some other rate.

The CXG/MXG/EXG supports equalization filters—either Complex or Real—that are programmable 
FIR filters with two inputs (I, Q) and two outputs (I, Q) per sample. This 256-tap filter has two modes 
of operation:

The equalization filter can be turned on and off.

The maximum number of taps is 256 (with 2 coefficients per tap for a 
complex filter) for equalization filters. The minimum number of taps is 2.

Equalization filters can also be referred to as predistortion filters or 
correction filters.

Type of Filter Description

Real The I and Q samples are independently filtered by a single set of real coefficients.

Complex The samples are treated as complex (I + jQ) and convolved with the filter coefficients which are 
specified as (I + jQ) in the time domain. 
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Figure 9-16 Int Equalization Filter Softkeys

I/Q > More
For details on each key, use key help 
as described on page 60.

SCPI commands:
Equalization filter state: [:SOURce]:DM:INTernal:EQUalization:FILTer:STATe { OFF } | 
ON [:SOURce]:DM:INTernal:EQUalization:FILTer:STATe? 
Equalization filter selection: 
[:SOURce]:DM:INTernal:EQUalization:FILTer:SELect "filename" 
[:SOURce]:DM:INTernal:EQUalization:FILTer:SELect? 
To add a real filter to the file system:
:MEMory:DATA:FIR "filename", [REAL,] osr, coeff1 [,coeff2 […, coeffN]]  
:MEMory:DATA:FIR? "filename" 
To add complex filter to the file system: 
:MEMory:DATA:FIR "filename", COMPlex, osr, hIRe0, hQIm0 [, hIRe1, hQIm1 […, 
hIReN, hQImN]]  
:MEMory:DATA:FIR? "filename"
To add I/Q symbol data to the file system: 
:MEMory:DATA “WFM1:filename", <blockdata>

page 275

Opens a file catalog of FIR filters to select as the equalization filter. Equalization filters are 
typically complex and must have an oversample ratio of 1. The filter must not have more than 
256 taps (512 coefficients for a complex filter). The equalization filter operates at 200 MHz, so 
all equalization filters must be resampled to 200 MHz prior to being placed in the signal 
generator.

Enables the internal 
equalization filter.

For more information on the SCPI commands, 
refer to the SCPI Command Reference.

page 266

Note:
Use the FIR Table editor to view the filter’s coefficients. 
Refer to page 280.
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Using Finite Impulse Response (FIR) Filters in the Dual ARB 
Real-Time Modulation Filter

Finite Impulse Response filters can be used to compress single carrier I/Q waveforms down to just 
the I/Q constellation points and then define the transitions similar to the modulation filter in Arb 
Custom (refer to “Using Finite Impulse Response (FIR) Filters with Custom Modulation” on 
page 416). The key difference for dual ARB real-time modulation is that a filter is applied as the 
waveform plays, rather than in the waveform data itself. 

Figure 9-17      Filter Menu
Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter >

This softkey changes, depending 

on the selected filter–type.

Available only when the 

Available only when the filter 
selected = Gaussian

page 280

page 275

For details on each key, use key help as described on page 60.

Opens the IS–95 
filter selection 
menu.

Enables or disables the Modulation Filter. This filter is typically applied to an Arb Waveform 
containing just the I/Q symbol decision points. The Modulation Filter then effectively 
defines the transitions between the symbol decision points. This means that the filter must 
have an oversample ratio of 2 or more. When this feature is active, the Sample Clock Rate 
is actually the Symbol Rate. Also, the filter must be real (refer to page 283).

page 272
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Creating a User–Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8–symbol, windowed 
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press Preset.

2. Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Select > Nyquist.

3. Press Define User FIR. 

4. Press More 1 of 2 > Delete All Rows > Confirm Delete of All Rows. 

This will initialize the table editor as shown in Figure 9-18.

Figure 9-18 Creating a User–Defined FIR Filter Using the FIR Filter Table Editor

Entering the Coefficient Values

1. Press the Return softkey to get to the first page of the table editor. 

2. Use the cursor to highlight the Value field for coefficient 0. 

3. Use the numeric keypad to type the first value (−0.000076) from Table 4. As you press the 
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you 
can correct it using the backspace key.)

Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > 
Define User FIR > More 1 of 2 > Delete All Rows > Confirm Delete of 
All Rows

Opens a menu that 
enables you to select 
and load a saved file 
into volatile memory. 

page 280

Active only when:
FIR filter coefficient table 
has minimum of two 
values visible.

For details on each key, use key help as described on page 60.

Adds a column for specifying the 
imaginary coefficients of the filter.* 
(All of the imaginary coefficients 
will be 0 initially.) If the Convert to 
Complex Filter softkey has been 
selected the Convert to Real Filter 
softkey becomes available. 
Caution: Selecting the Convert to 
Real Filter softkey removes the 
Imaginary Values column and the 
imaginary values are lost.

Note:
Modulation filters must be real and have an oversample ratio (OSR) of 2 or greater.
Equalization filers are typically complex and must have an oversample ratio (OSR) of 1.
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4. Continue entering the coefficient values from the table in step 1 until all 16 values have been 
entered.

Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in 
reverse order. The signal generator provides a mirror table function that automatically duplicates 
the existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and 
the first of these coefficients (number 16) highlights, as shown in Figure 9-19 on page 276. 

Figure 9-19 

Table 9-3 

Coefficient Value Coefficient Value

0 −0.000076 8 −0.035667

1 −0.001747 9 −0.116753

2 −0.005144 10 −0.157348

3 −0.004424 11 −0.088484

4 0.007745 12 0.123414

5 0.029610 13 0.442748

6 0.043940 14 0.767329

7 0.025852 15 0.972149

FIR table coefficient values, 
may be from the factory 
default values or entered by 
the user.

Use the Goto Row menu 
to move around and 
make changes to the FIR 
Values coefficient table.

For details on each key, use key help as described on page 60.
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Setting the Oversample Ratio

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range 
from 1 through 32; the maximum number of taps allowed by the table editor is 1024. 

The actual limits on OSR, number of coefficients, and number of symbols depends on the feature 
with which the FIR is used. Refer to Table 9-4.

For modulation filters, if the oversample ratio is different from the internal, optimally selected one, 
then the filter is automatically resampled to an optimal oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and 
frequency dimensions.

1. Press More 1 of 2 > Display Filter > Display FFT (fast Fourier transform). 

Refer to Figure 9-20 on page 278.

Modulation filters are real and have an oversample ratio (OSR) of two or 
greater.

Equalization filters are typically complex and must have an OSR of one 
(refer to “Using the Equalization Filter” on page 272 and to “Setting the 
Real-Time Modulation Filter” on page 283). 

Table 9-4 

Filter Type Oversampling Ratio 
(OSR)

Number of Taps
(Maximum)

Symbols/Coefficients 
(Maximum)

Equalizationa

a. When I/Q timing skew, I/Q delay, or the ACP internal I/Q channel 
optimization features are active, the effective number of taps for the 
equalization filter are reduced.

1 256 --

ARB Custom 
Modulationb

b. The filter may be sampled to a higher or lower OSR.

≥ 2 -- 512/1024

Dual ARB 
Real-Time 
Modulationc

c. The filter will be decimated to a 16 or lower OSR depending on the 
symbol rate.

≥ 2 -- 32/1024
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Figure 9-20 

2. Press Return.

3. Press Display Impulse Response. 

Refer to Figure 9-21.

Figure 9-21 

4.  Press Return to return to the menu keys.

Storing the Filter to Memory

 Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of 
memory available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 209, name and 
store this file as FIR_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional file 
names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The amount 
of memory used is also displayed. The number of files that can be saved depends on the size of the 
files and the amount of memory used. Refer to Figure 9-22.

For details on each key, use key 
help as described on page 60.

For details on each key, use key 
help as described on page 60.
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Figure 9-22 

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new 
filter design. 

Catalog displays FIR files that have 
been previously saved by the user.

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 60.
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Modifying a FIR Filter Using the FIR Table Editor
FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You 
can load the FIR table editor with coefficient values from user–defined FIR files stored in non–
volatile memory or from one of the default FIR filters. Then you can modify the values and store the 
new files. 

Loading the Default Gaussian FIR File

Figure 9-23  Loading the Default Gaussian FIR File

1. Press Preset.

2. Press Mode > Dual ARB > Arb Setup > More > Real-Time Modulation Filter > Define User FIR > 
More > Load Default FIR > Gaussian.

3. Press Filter BbT > 0.300 > Enter.

4. Press Filter Symbols > 8 > Enter.

5. Press Generate. 

6. Press Display Filter > Display Impulse Response (refer to Figure 9-24).

The actual oversample ratio during modulation is automatically selected 
by the instrument. A value between 4 and 16 is chosen dependent on the 
symbol rate, the number of bits per symbol of the modulation type, and 
the number of symbols.

Mode > Dual ARB > Arb Setup > More > Real-Time 
Modulation Filter

These softkeys select a 
window function 
(apodization function) for 
a filter.

For details on each key, use key help as described on page 60.
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Figure 9-24 

7. Press Return.

Modifying the Coefficients

1. Using the front panel arrow keys, highlight coefficient 15.

2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 9-25 

Refer to Figure 9-25. The graphic display can provide a useful troubleshooting tool (in this 
case, it indicates that a coefficient value is missing, resulting in an improper Gaussian 
response).

4. Press Return.

5. Highlight coefficient 15. 

6. Press 1 > Enter. 

For details on each key, use key 
help as described on page 60.

For details on each key, use key 
help as described on page 60.
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Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press Return > Return > Load/Store > Store To File. 

2. Name the file NEWFIR2.

3. Press Enter. 

The contents of the current FIR table editor are stored to a file in non–volatile memory and the 
catalog of FIR files is updated to show the new file. 
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Setting the Real-Time Modulation Filter
The real-time modulation filter effectively compresses a single carrier I/Q waveform down to just 
the I/Q constellation points and then controls the transitions similar to the modulation filter in Arb 
Custom modulation. The key difference is that this filter is applied as the waveform plays, rather 
than in the waveform data itself. The real-time modulation filter is only available for Dual ARB 
waveforms.

When the real-time modulation filter is on, the sample clock rate acts as the symbol rate. The 
sample clock rate must be set to one half of the sample rate for the real-time Arb modulation filter 

feature to be turned on. The sample rate is determined by the Option 65x baseband generator.

Figure 9-26 Real-Time Modulation Filter Softkeys for the Dual ARB Player

Common uses for the real-time modulation feature include:

— Where the single carrier rectangular ideal I/Q symbol decision points are known and are to have 
an over-sampled filter applied. 

— Where greater effective CXG/MXG/EXG memory size is required.

Because the Arb format only supports rectangular I/Q data for defining the 
symbol decision points, constant envelope modulation, which should be 
specified as magnitude and phase, are not supported. (Examples of 
constant envelope modulation are MSK and FSK.)

The carrier frequency must be the same for all frequencies used (i.e. only 
single carrier applications work with arb real-time modulation filters).

page 274

The settings in this menu 
can be stored to the file 
header, see page 217.

For details on each key, use key help 
as described on page 60.

Mode > Dual ARB > Arb 
Setup > More 

These are the available 
real-time modulation filters that 
can be applied to a waveform.
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— When you have a low rate waveform that could benefit from a higher OSR that does not make 
the waveform longer.

The real-time modulation filter setup is one of the file header parameters (page 217), which means 
you can store this setup with the waveform. When you select a waveform with a stored modulation 
filter setup, the signal generator changes the current setup to match the stored file header setup. If 
there is no stored modulation filter setup for the current waveform, the signal generator uses the 
last set modulation filter setup. 

You can also use the Save function (page 84) to store this value as part of the signal generator 
setup. When you Recall a setup stored with the Save function, the modulation filter value becomes 
the current instrument setting value, disregarding the stored file header value.

Use the following steps to apply a real-time modulation filter to the current waveform loaded into 
volatile memory. This example uses the factory supplied waveform, SINE_TEST_WFM available in 
the Dual ARB Player. To view the output for this example, connect the RF OUTPUT of the signal 
generator to the input of a spectrum analyzer.

1. Configure the modulation filter:

Press Mode > Dual ARB > Arb setup > More > Real-Time Modulation Filter > Select > Root 
Nyquist

2. Press Filter Alpha > .4 > Enter.

The modulated RF signal now has a real-time modulation filter of type root nyquist, with a 
filter alpha of 0.400.

The following setup assumes you have completed the setup in “Setting the 
Baseband Frequency Offset” on page 261 for creating a modulated RF 
signal that is offset from the carrier frequency by 20 MHz.
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Multiple Baseband Generator Synchronization
Available in the Dual ARB menu, this feature lets you set up a primary/secondary system of up to 
sixteen Keysight CXG/MXG/EXGs so that the baseband generators (BBG) synchronize the playing 
of waveforms. The system count includes one Keysight CXG/MXG/EXG to function as the primary 
(see “Equipment Setup” on page 288).

The MXG/EXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common 
external LO signal to create phase coherent system. Refer to “Understanding Option 012 (LO 
In/Out for Phase Coherency) with Multiple Baseband Generator Synchronization” on page 291 
and the Data Sheet.

Figure 9-27 Multiple Baseband Generator Synchronization (BBG Synchronization) Trigger 
Softkeys and Menu Location

For details on each key, use key help 
as described on page 60.

Greys out for secondary instruments. 
Remains active for the primary 
instrument.

see page 286
BBG sync automatically changes the trigger type to Trigger and Run if 
the current setting is Free Run or Gated. If desired, manually set 
differently on either the primary or secondaries, or both either before or 
after configuring the BBG sync setup parameters.

Free Run and Gated are unavailable choices while using BBG sync.

Primary default settings. If 
desired, change these 
settings after designating the 
instrument as the primary.

Secondary default settings. 
These settings are not 
accessible after selecting an 
instrument as a secondary.

Note: The BBG sync feature automatically configures the trigger settings shown below. To avoid a settings conflict error in this 
process, manually configure the trigger settings prior to setting the BBG sync parameters shown on page 286.

see page 209

see page 239

Neg is the factory default setting. The 
secondary selection changes it to Pos. 
If desired, manually change to Pos prior 
to selecting as a secondary.

Note: A setting conflict error occurs 
when at the time of the 
primary/secondary selection, the 
following trigger setting(s) is true:
Primary
• Free Run or Gated trigger type
Secondary
• Free Run or Gated trigger type
• Ext Polarity Neg trigger source
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Figure 9-28 Multiple BBG Synchronization Front Panel Displays

Understanding the Primary/Secondary System

System Delay

The multiple BBG synchronization feature provides a system for synchronizing the waveform 
generation capability of up to 16 signal generators to within a characteristic value of ± 8 ns 
between the primary and the last secondary. This minor amount of delay (± 8 ns) can be reduced 
further to picosecond resolution by using the I/Q Delay softkey located in the I/Q menu. To reduce 
the delay, check and adjust the BBG signal alignment for each signal generator in the system. For 
more information on adjusting the delay, see “I/Q Adjustments” on page 269.

For details on each key, use key help 
as described on page 60.

Primary Display and Available Softkeys

Secondary Display and Available Softkeys

Select Off, Primary, or 
Secondary.

Synchronizes the baseband 
generators for all instruments in the 
system. 

Note: Press only after pressing 
Listen for Sync on all secondary 
instruments and the secondaries 
show “Waiting For Sync” as the 
status.

Primary shows one of the following 
messages:
• Out of Sync
• In Sync

Shows after pressing Sync Secondaries.

Primary/secondary indicator and setup 
diagram. 

After pressing, the secondary waits 
for the synchronization signal 
initiated by the primary.

Note: Press before pressing Sync 
Secondaries on the primary 
instrument.Secondary shows one of the following messages:

• Out of Sync
• Waiting for Sync

Shows after pressing Listen for Sync
• In Sync

Shows after pressing Sync Secondaries on the 
primary.

Primary/secondary indicator and setup diagram. 
The bottom secondary indicator is green on the 
last secondary in the system.

Select Off, Primary, or 
Secondary.

This is a persistent setting that 
survives both preset and cycling 
the power. Menu sets total number 
of secondaries to include MXG-A.

These are persistent settings that 
survive both preset and cycling the 
power. Menu sets the current 
secondary position and total 
number of secondaries to include 
MXG-A.

Applies additional trigger delay. 
Multi-BBG Sync Type Primary: 
applies trigger delay to all devices 
including secondaries.

Mode > Dual ARB > Arb Setup > More > 
Multi-BBG Sync Setup

Allows instrument to ignore all incoming triggers 
while configuring a multiple BBG synchronization 
setup. Feature must be enabled—Multi-BBG Sync 
Type is Primary or Secondary.

Applies additional trigger delay. 
Multi-BBG Sync Type Secondary: 
only applies trigger delay to 
secondaries.

Allows instrument to ignore all incoming triggers 
while configuring a multiple BBG synchronization 
setup. Feature must be enabled—Multi-BBG Sync 
Type is Primary or Secondary.
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The delay value includes compensation for cables that have less than 1 ns of propagation delay 
between the EVENT 1 and PAT TRIG connectors (see Equipment Setup). The recommended cable is 
an Keysight BNC cable, part number 10502A. The use of cables with greater propagation delay may 
not allow the signal generators to properly synchronize.

System Synchronization

Synchronization occurs after the primary signal generator sends a one–time event pulse that 
propagates through and to each secondary in the system. Prior to this event, each secondary must 
recognize that it is waiting for this event pulse, which occurs during the system configuration (see 
“Configuring the Setup” on page  288). In order to properly send the synchronization pulse, the 
trigger source and the Dual ARB Player for each signal generator must be turned off.

The primary/secondary setup does not incorporate a feedback system between the secondaries 
and the signal generator selected as the primary. After synchronization, if changes occur to the 
Multi–BBG Sync Setup menu or a signal generator is added to the system, the primary does not 
automatically resynchronize the setup. This may cause the signal generators in the system to 
incorrectly report their status as In Sync. 

The system can also misinterpret other signals as the synchronization pulse, which results in an 
incorrect In Sync status. These types of signals include a continuous trigger or an active Marker 
routed to the EVENT 1 connector. Improperly connected rear panel cables can also create a false 
status.

You must resynchronize the entire system after making any change in one or all of the Multi–BBG 
Sync Setup menus, after adding a signal generator to the system, or in doubt as to the true status 
of a signal generator. Changes to parameters that are outside of the Multi–BBG Sync Setup menu 
such as waveform files, Dual ARB state, sample rate, scaling, carrier frequency or amplitude have 
no effect on the system synchronization. To resynchronize a system, see “Making Changes to the 
Multiple Synchronization Setup and Resynchronizing the Primary/Secondary System” on page  
290.

System Trigger Setup

The multiple BBG synchronization feature restricts the trigger selections (see page 285) for each 
signal generator. For signal generators selected as secondaries, you can only modify the trigger 
type (with restrictions). The trigger source is fixed and set to receive a trigger through the rear panel 
PAT TRIG connector. On the primary, you can change both the trigger type (with restrictions) and 
the trigger source. The trigger source provides three options for triggering the waveforms: external 
trigger, front panel Trigger key, or the GPIB trigger.

If the trigger settings are other than what the BBG synchronization feature supports, the feature 
changes the trigger settings to what is shown on page 285. When this change occurs, the Keysight 
CXG/MXG/EXG generates a settings conflict error to alert you to the changes. To avoid the error 
generation, appropriately configure the trigger settings prior to selecting a signal generator as the 
primary or secondary.

The system trigger propagates in the same manner as the synchronization pulse initiated by the 
primary (see System Synchronization). So if it is not turned off during changes to the 
synchronization parameters, it can cause a false In Sync status.

The signal generator does not reset the trigger parameters when the multiple BBG synchronization 
feature is turned off. To play waveforms after disabling the feature, you must either set the trigger 
type to Free Run or provide a trigger to start the waveform play back.



 288                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

   Basic Digital Operation (Option 653/655/656/657)
Multiple Baseband Generator Synchronization

Equipment Setup

Figure 9-29 Multiple Baseband Synchronization Setup

Configuring the Setup

Set the Common Parameters

Perform the following steps on all signal generators:

1. Set the frequency of the carrier signal.

2. Set the power level of the carrier signal.

3. Select the desired waveform (see page 209).

Do not turn the Dual ARB on.

4. Except for triggering, set the desired waveform parameters such as markers and sample clock.

The baseband synchronization feature limits the trigger selections for both the primary and 
secondaries. If the current trigger settings include unsupported BBG synchronization 
parameters, the Keysight CXG/MXG/EXG generates a settings conflict error and changes the 
trigger settings. To avoid the settings conflict error, manually set the trigger parameters as 
shown on page 285 prior to setting the multiple BBG synchronization parameters.

5. Turn on the RF Output.

Set the BBG Synchronization Primary Parameters

1. Press Mode > Dual ARB > ARB Setup > More > Multi–BBG Sync Setup > Multi–Bbg Sync Type 
> Primary.

2. Set the number of secondaries using the Number of Secondaries softkey.

3. If desired, modify the trigger parameters (see page 285).

There can be 1 to 15 
secondaries in a setup. 

If not using the Trigger key, provide an external trigger 
source. For information on the PAT TRIG connector, 
see page 34.

PAT TRIG

PAT TRIG

PAT TRIG

10MHz Out

REF IN

10MHz Out

REF IN

REF IN

10MHz Out

EVENT 1

EVENT 1

EVENT 1
RF OUTPUT

RF OUTPUT

RF OUTPUT

RF OUTPUT

Note: To minimize synchronization delay, the Keysight BNC cable 10502A is the 
recommended cable for the rear panel daisy chain connections (see page 286).

PAT TRIG 
or GPIB

Secondaries
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The primary signal generator allows the modifications of both the trigger type and the trigger 
source.

a.Return to the Dual ARB menu (see page 285).

b.Set the desired trigger type and source.

c.Return to the Multi–BBG Sync Setup menu.

Set the BBG Synchronization Secondary Parameters

1. Press Mode > Dual ARB > ARB Setup > More > Multi–BBG Sync Setup > Multi–BBG Sync Type 
> Secondary.

2. Set the number of secondaries using the Number of Secondaries softkey.

3. Set the secondary position that the signal generator occupies.

There can be up to fifteen secondaries in a system.

4. Press the Listen for Sync softkey and verify that Waiting for Sync appears in the Status 
area of the display.

5. If desired, select a different trigger type parameter:

a.Return to the Dual ARB menu (see page 285).

b.Set the desired trigger type.

c.Return to the Multi–BBG Sync Setup menu.

6. Repeat for each secondary signal generator in the system.

Synchronize the System

Perform this procedure only after setting the parameters for both the primary and secondary signal 
generators. If resynchronizing a system, use the procedure “Making Changes to the Multiple 
Synchronization Setup and Resynchronizing the Primary/Secondary System” on page  290.

1. On the primary, press the Sync Secondaries softkey.

2. On the front panel displays, ensure that all of the signal generators show In Sync as the 
Status.

Trigger and Play the Waveform

1. On all Keysight signal generators, press Mode > Dual ARB > ARB Off On to On.

2. Start the trigger signal going to the primary signal generator.

All of the signal generators in the primary/secondary system must be resynchronized when any 
changes are made to the primary/secondary settings or with the addition of a secondary 
instrument, even if In Sync appears after pressing the Listen for Sync softkey on the 
secondary instruments.
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Making Changes to the Multiple Synchronization Setup 
and Resynchronizing the Primary/Secondary System

If any changes are made to the primary/secondary parameters or a signal generator (secondary 
unit) is added to the system, the system must be resynchronized even if In Sync appears in the 
Status portion of the display. 

1. Turn off the trigger source. If using the Trigger key, there is nothing to turn off.

If the trigger source is on and provides a continuous pulse stream, it may cause the signal 
generators to incorrectly display In Sync as the status after pressing the Listen for Sync 
softkey. 

2. On each of the signal generators, press Mode > Dual ARB > ARB Off On to Off.

If a signal generator(s) has the Dual ARB on during changes, signal generators further in the 
chain may incorrectly display In Sync after pressing the Listen for Sync softkey.

3. On each of the signal generators, press ARB Setup > More > Multi–BBG Sync Setup.

4. Make the changes in the Multi–BBG Sync Setup menu.

Out Of Sync appears as the status message.

5. On each of the secondary signal generators, press Listen for Sync.

6. Ensure that all of the secondary’s Status show Waiting for Sync. If In Sync shows as the 
status, perform the following steps:

a.Check that the PATT TRIG to EVENT 1 cables are properly connected on the rear panel.

A disconnected cable can cause a false In Sync status.

b.If the cables are connected, perform steps 1 and 2.

c.Press Listen for Sync and ensure that Waiting for Sync appears as the status.

7. On the primary signal generator, press Sync Secondaries.

8. Verify that In Sync appears as the status on all primary/secondary signal generators.

9. Perform the process “Trigger and Play the Waveform” on page  289.
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Understanding Option 012 (LO In/Out for Phase Coherency)  
with Multiple Baseband Generator Synchronization

The MXG/EXG with Option 012, enables 2x2, 3x3, or 4x4 MIMO configurations to share a common 
external LO signal to create a phase coherent system (refer also, to “Multiple Baseband Generator 
Synchronization” on page 285).

RF phase coherency may not be needed for general STC/MIMO receiver testing, since a MIMO 
receiver perceives any phase differences between the sources as part of the channel conditions and 
correct for them. But, RF phase coherency might be desirable for certain applications such as R&D 
on beamforming systems.

Configuring the Option 012 (LO In/Out for Phase Coherency) with MIMO

The Keysight BNC cable, part number 10502A, is the recommended cable for the standard multi–
BBG synchronization setup, and is recommended for Option 012 too (see also Figure 9-29 on 
page 288). Additionally, for the 2x2, 3x3, and 4x4 MIMO connections from the LO IN and LO OUT to 
the splitter, additional cables are required (refer to Table , Figure 9-30 on page 293, and Figure 
9-31 on page 294).

The phase coherent configuration requires the following:

— The recommended LO input drive level should be in the 0 to 6 dBm range.

— The I/Q calibration and the self–test must be performed with the LO In/Out jumper cable in 
place. Where the I/Q calibration cannot be run, the baseband offset can be manually adjusted 
to minimize the I/Q offsets.

This section assumes that the previous section on Multiple Baseband 
Generator Synchronization has been read and understood. If not, refer to 
“Multiple Baseband Generator Synchronization” on page 285 before 
continuing.

Keysight recommends the LO Output be covered when not in use.

When the LO In/Out jumper cable is removed and the instrument is in Dual 
ARB mode, the instrument is unleveled and the instrument displays an 
Unlevel error message.

All test equipment requires a 12 hour warm–up period to ensure accurate 
performance.

The 0 to 6 dBm LO input drive level ensures the instruments will operate 
over the full frequency and over the full 0 to 55 ambient temperature 
rangea.

a. LO input power requirements vary with temperature; power <0 dBm may work at 20–30 degree 
ambient temperature conditions. Refer to the Data Sheet.
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— The phase coherency feature only applies to the Dual ARB modulation mode.

— All cables from the splitter output to the instrument inputs should be of equal lengths.

Table 9-5 Option 012 (LO In/Out for Phase Coherency) Equipment

MIMO Configuration Parta

a. On all of the MIMO configurations, the same length of SMA flexible cables are connected 
from the splitter output to the inputs on the primary and secondary instruments. Refer to 
Figure 9-30 on page 293 and to Figure 9-31 on page 294.

Cable Length Notes

2x2 n/a

11636A

As required

n/a

SMA flexible cables are connected from 
the power splitter outputs to the LO 
inputs on the rear panel of both the 
primary and secondary MXG/EXGs. 
Refer to Figure 9-30 on page 293. 
 
Power Divider, DC to 18 GHz. Refer to 
www.keysight.com.

3x3 n/a

 

PS3–20–
451/12S

As required

 

n/a

SMA flexible cables are connected from 
the power splitter outputs to the LO 
inputs on the rear panel of the 
secondary MXG/EXGs. Refer to Figure 
9-31 on page 294. 
 
3–Way Pulser Microwave Corp., 3–Way 
Wilkinson Dividers

4x4 n/a

 

PS4–16–
452/10S

As required

 

n/a

The SMA flexible cables are connected 
to the power splitter output to the LO 
inputs on the rear panel of the 
secondary MXG/EXGs. Refer to Figure 
9-31 on page 294. 
 
4–Way Pulser Microwave Corp., 4–Way 
Wilkinson Dividers

All 10502A 22.86 cm (9 inches) Refer to Figure 9-30 on page 293 and 
Figure 9-31 on page 294. See also 
“Multiple Baseband Generator 
Synchronization” on page 285.
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2x2 MIMO (LO In/Out for Phase Coherency) Configuration 

For the 2x2 MIMO (LO In/Out for phase coherency) setup, the LO from the primary MXG/EXG can 
be run through a power splitter and used as the LO input to both the primary and the secondary 
signal generators. No external source is required.

To generate phase coherent signals for a 2x2 MIMO configuration, the primary MXG LO OUT is 
connected via a power splitter to the secondary LO IN. The LO OUT provides a sufficient amplitude 
LO signal when connected directly, to drive the secondary MXG/EXG(s), thus providing phase 
coherency for the RF output signals. In this example, we show two MXG signal generators with 
Option 012 connected for a phase coherent 2x2 MIMO solution. Refer to Figure 9-30.

Figure 9-30 2x2 MIMO (LO In/Out for Phase Coherency) Equipment Setup

3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Configurations

For a 3x3 and 4x4 MIMO (LO In/Out for phase coherency) setups, an additional analog source is 
needed to provide the higher LO power required by the power splitter and the additional 
instruments.

Splitting the LO output four ways causes too much loss to drive the LO input of the N5172B/82Bs in 
the system. Also, there is no amplitude adjustment to the LO output of the N5172B/82B. To 
generate phase coherent signals for 3x3 and 4x4 configurations with the MXG/EXG, an external 
Primary LO is needed to provide a sufficient amplitude LO input signal to the vector MXG/EXGs 
(refer to Figure 9-31 on page 294). 

The Primary LO is not controlled by any of the Signal Studio software, but must be set manually—
via the RF frequency settings on the primary signal generator—by the user to the desired 
frequency and amplitude.

Note: 

To optimize the phase coherence, the same length SMA flexible cable is recommended 
for the output of the 2–way splitter connections to the LO IN of the signal generator 

Primary

Secondary
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Figure 9-31 3x3 and 4x4 MIMO (LO In/Out for Phase Coherency) Equipment Setup

NOTE: 

A SMA flexible cable is recommended for the input to the 4–way splitter connections 
to the LO IN and LO OUT of the instruments with Option 012 (see page 291).
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Real-Time Applications
The Keysight X-Series signal generators provide access to several real-time applications for signal 
creation. 

Figure 9-32  Real-Time Applications Softkeys

page 207

For details on each key, use key help as described on page 60.

page 433

page 382

page 382

Licensed Signal Studio applications are displayed here.

Refer to www.keysight.com/find/signalstudio.

page 363

page 371

page 239



 296                                                       Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide

   Basic Digital Operation (Option 653/655/656/657)
Waveform Licensing

Waveform Licensing 
Waveform licensing enables you to license waveforms that you generate and download from any 
Signal Studio application for unlimited playback in a signal generator. Each licensing option 
(221-229) allows you to permanently license up to five waveforms or (250-259) allows you to 
permanently license up to 50 waveforms of your choice (i.e. Waveform Option 22x or Option 25x are 
perpetual fixed waveform licenses). 

Waveforms licensed with Options 221-229 or Options 250-259 cannot be exchanged for different 
waveforms. Once a waveform is licensed, that license is permanent and cannot be revoked or 
replaced. Option 22x and 25x waveform licenses are signal generator specific (i.e. signal generator 
serial number specific). If a licensed Option 22x or Option 25x waveform file is transferred to 
another signal generator, the file must be licensed by a separate Option 22x or Option 25x that is in 
the other signal generator before it can be played.

To redeem Option 22x or Option 25x, refer to the N5182B–2xx Entitlement Certificate that comes 
with the N5182B–2xx order. For more information on extracting and downloading waveform files, 
refer to the Programming Guide.

Understanding Waveform Licensing

Use any N76xxB Signal Studio software to build and download waveforms to the signal generator. 
Each Option 22x provides 5 available slots and Option 25x license provides 50 available slots, where 
you can add and play waveforms for a trial period of 48 hours per slot. During this time, you can 
replace the waveform any number of times until you are satisfied with it. After the trial period 
expires, the waveform in the slot is no longer playable until the slot is locked for permanent 
playback; however, you can replace the waveform in the slot with another waveform of your choice 
before locking the slot.

To license additional waveforms that exceed the number permitted by an Option 22x or Option 25x, 
you must purchase another Option 22x or Option 25x that you do not already own. For example, if 
you already own Option 250, purchase Option 251 to add an additional 50 slots. Adding all options, 
250-259, provides a maximum of 500 slots. Adding all options, 221-229, provides a maximum of 45 
slots. (Repurchasing the same option for the same signal generator, gives you no additional 
Waveform licenses.) 

Installing an Option N5182-22x or Option N5182B–25x 

Load a Waveform License, Option N5182-22x or Option N5182B–25x, into the signal generator 
using License Manager or a USB media. For more information on loading the Waveform License, 
refer to the N5182B–2xx Entitlement Certificate included with your order.

Licensing a Signal Generator Waveform

Create and download a waveform into the signal generator using any of the N76xxB Signal Studio 
software. Refer to your Signal Studio software help if you need assistance using the application.

Refer to page 301 for steps in adding the waveform to a license slot for a 48-hour trial period. 
During the trial period, the waveform can be played and replaced any number of times. When the 
trial time expires, the slot can no longer be used for playback until the slot is locked for permanent 
playback capability.
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Waveform Licensing Softkeys Overview

Figure 9-33 Waveform Licensing Softkeys

For details on each key, use key help 
as described on page 60.

Mode > Dual ARB > More 

Note: Waveforms licensed with Option 2xx cannot be exchanged for other waveforms. Once a waveform is 
locked into a license slot, that license is permanent and cannot be revoked or replaced. 

This softkey is only available if there is an Option 2xx license installed on the instrument.
Pressing this softkey displays the licensing status and associated filename for each slot and accesses the 
waveform licensing menu selections. 

This softkey allows you to add a 
waveform that you select to the 
first available slot. Refer to 
page 298.

Refer to the SCPI Command Reference for 
related license commands.

This softkey allows you to replace 
a waveform in the selected slot. 
Refer to page 299.

This softkey clears the waveform 
from the selected slot.

This softkey allows you to lock a 
waveform into a slot. After the 
trial period has expired, the 
waveform must be locked in 
order to be able to play the 
waveform. Refer to page 299.

This softkey allows you to select 
a specific slot where you want to 
add, replace, or clear a 
waveform. You can also select a 
slot by using the front panel 
arrow keys or by scrolling to the 
slot. Refer to page 298.

 
Note: When Waveform Licensing is first accessed, all slots appear as Available. For 
licensing status descriptions after waveforms have been added to a slot, refer to Table 
9-6 on page 299.

page 299
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Figure 9-34 Waveform Licensing Softkeys

For details on each key, use key help as described on page 60.

Mode > Dual ARB > More > 
Waveform Licensing > Add 
Waveform to First Available Slot
or
Mode > Dual ARB > More > 
Waveform Licensing > Replace 
Waveform in Slot

The softkey is greyed out, if a 
waveform is already licensed or does 
not require licensing.

This softkey displays a catalog 
of the waveform segments 
stored in the Int Storage or 
USB Media.

This softkey displays a catalog 
of the waveforms stored in the 
BBG memory.

To select a waveform, use 
the arrow keys to highlight 
the waveform and then 
press Add Waveform. 

Note: Waveforms licensed with Option 2xx cannot be “exchanged”. Once a slot is locked, 
that license for the waveform in the locked slot is permanent and cannot be revoked or 
replaced.

Refer to the SCPI Command 
Reference for related License 
Commands.The waveform to be added or replaced can be selected from BBG memory, internal storage, or a USB device.
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Figure 9-35 Waveform Licensing Softkeys

Table 9-6 Waveform Licensing Slot Status Messages

Status Column Meaning Notes

Available The slot has never had a waveform 
added to it.

50 slots are initially available for 
each Option 25x.

5 slots are initially available for each 
Option 22x.

For details on each key, 
use key help as described 
on page 60.

Mode > Dual ARB > More > 
Waveform Licensing > Goto Slot

Press this softkey after entering a specific slot number using the front panel numeric pad.

Press this softkey to go to the first slot.

Press this softkey to go to the first slot whose status is available.

Press this softkey to go to the last slot. The number of slots depends on the number of licensing 
options installed on the instrument.

Mode > Dual ARB > More > Waveform Licensing 
> Lock Waveform in Slot

This softkey is displayed if the waveform is not found in the internal storage memory of the 
signal generator. Press this softkey to store the waveform into the Internal Storage and to 
activate the Confirm Locking Waveform softkey. Refer to Step 4 on page 302. 

Mode > Dual ARB > More > Waveform 
Licensing > More > More

Press this softkey to play the 
waveform in the highlighted 
slot.

Press this softkey to locate 
the waveform in memory that 
was added to this slot 
regardless of the name. If the 
search returms no results, the 
original waveform has been 
deleted from memory and 
cannot be found.

Press this softkey to confirm that you want to lock the waveform into the slot for permanent 
licensing. If the waveform has not been saved to internal storage, a warning message appears. 
Refer to Step 4 on page 302. 

Refer to the SCPI Command Reference for 
related license commands.
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Locked MM/DD/YY The slot is locked and can no longer 
be modified.

The waveform in this slot is licensed 
to this signal generator for 
unlimited playback.

Remaining Trial Time HH:MM The slot is in a trial period that is 
available for 48 hours that begins 
when a waveform is added.

During the trial period, the 
waveform in this slot can be played, 
cleared, or replaced with another 
waveform.

Lock Required The trial period for the slot has 
expired but the slot has not been 
locked. 

The slot can be cleared or replaced 
with a different waveform but the 
waveform cannot be played until 
the slot is locked. A trial period is 
no longer available.

Table 9-6 Waveform Licensing Slot Status Messages

Status Column Meaning Notes
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Example: Licensing a Signal Studio Waveform

The following steps add a waveform file to a license slot and lock the slot for permanent playback.

1. Press Mode > Dual ARB > More > Waveform Utilities > Waveform Licensing

The signal generator displays a catalog of files labeled: Catalog of BBG Segment Files in 
BBG Memory.

2. Use the arrow keys to highlight and select the file to be licensed.

3. Press Add Waveform to add the selected waveform to the first available slot.

Figure 9-36       Add Waveform
Mode > Dual ARB > More > Waveform Licensing> 
Add Waveform to First Available Slot

page 298

Status area for the waveform 
N7602B–WFM1 is empty and the 
Add Waveform softkey is active, 
indicating the waveform is 
licensable.

The selected waveform is 
added to the first 
available slot. The trial 
time for the slot begins as 
soon as the waveform is 
added.
During the 48 hour trial 
period, the waveform can 
be played and replaced 
any number of times.
When the trial time 
expires, the licensing 
status of the slot changes 
to Lock Required after 
which the waveform can 
no longer be played until 
the slot is locked.
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4. License the waveform:

a.Press Lock Waveform in Slot.

A warning is displayed: *** Waveform Lock Warning!!! ***. If necessary, verify you 
have selected the correct waveform you want for licensing by pressing Return.

Figure 9-37  Waveform Lock Warning

b.Press Confirm Locking Waveform.

The licensing status of the slot will be changed to Locked MM/DD/YY.

c.If the waveform has not been previously backed up in internal storage, a warning is 
displayed: *** Waveform Backup Required!!! ***.

d.Make a backup copy of this waveform on a USB media or a computer before pressing 
Backup Waveform to Int Storage. (If the waveform is lost or deleted on the signal 
generator, it cannot be recovered).

Figure 9-38  Backup Waveform To Int Storage softkey

It is important that you make a backup copy of any waveforms that you are 
licensing. Do not store the backup copy on the signal generator. If all copies of 
the waveforms are deleted or lost, there is no way to recover the waveform or 
reassign the license. Refer to “Working with Files” on page 76.

Press this softkey to store the waveform 
into the internal storage and to activate the 
Confirm Locking Waveform softkey.

The Confirm Locking Waveform 
softkey remains inactive until the 
waveform is stored in internal storage.
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Waveform Licensing Warning Messages

Figure 9-39 
This standard warning is 
displayed every time a 
waveform is selected to be 
locked. This notification 
indicates that one of the 
available “license slots” is 
about to be used from 
Option 2xx.
ALWAYS make backup 
copies of waveforms in a 
separate non–volatile 
memory in case a file is 
deleted or lost from the 
instrument’s internal 
storage.

This warning is displayed 
when an attempt is made 
to lock a waveform that 
has not been saved to 
internal storage or USB 
media (i.e. waveforms 
cannot be locked unless 
they have been stored to 
non–volatile memory). 
Press the Backup 
Waveform To Int Storage 
softkey.

This warning is displayed 
when there is insufficient 
memory or other problems 
with the internal storage, 
or USB media (non–
volatile memory) and the 
waveform could not be 
saved to non–volatile 
memory.

This warning is displayed 
when the waveform file 
cannot be found in BBG or 
internal storage. You must 
ensure that the waveform 
still resides in the 
instrument before you can 
lock it.
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X-Series Signal Generators

User’s Guide

10    Digital Signal Interface Module (Option 003/004)

This chapter provides information on the N5102A Baseband Studio Digital Signal Interface Module. 
These features are available only in N5172B/82B Vector Signal Generators with Options 003/004 
and 653/655/656/657. The following list shows the topics covered in this chapter:

— Clock Timing on page 306

— Data Types on page 320

— Connecting the Clock Source and the Device Under Test on page 318

— Operating the N5102A Module in Output Mode on page 321

— Operating the N5102A Module in Input Mode on page 331
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Clock Timing
This section describes how clocking for the digital data is provided. Clock timing information and 
diagrams are supplied for the different port configurations (serial, parallel, or parallel interleaved 
data transmission) and phase and skew settings. All settings for the interface module are available 
on the signal generator user interface (UI).

Clock and Sample Rates

A sample is a group of bits where the size of the sample is set using the Word Size softkey. The 
clock is the signal that tells when the bits of a sample are valid (in a non-transition state). The clock 
and sample rates are displayed in the first-level and data setup softkey menus. The clock rate and 
sample rate are usually the same. They will differ when serial mode is selected, or when there are 
multiple clocks per sample.

Figure 10-1 Data Setup Menu for a Parallel Port Configuration

The N5102A module clock rate is set using the Clock Rate softkey and has a range of 1 kHz to  
400 MHz. The sample rate is automatically calculated and has a range of 1 kHz to 200 MHz. These 
ranges can be smaller depending on logic type, data parameters, and clock configuration.

Maximum Clock Rates

The N5102A module maximum clock rate is dependent on the logic and signal type. Table 10-1 and  
Table 10-2 show the warranted rates and the maximum clock rates for the various logic and signal 
types. Notice that LVDS in the output mode using an IF signal is the only logic type where the 
warranted and maximum rates are the same.

Table 10-1 Warranted Parallel Output Level Clock Rates and Maximum Clock Rates

Logic Type
Warranted Level Clock Rates Maximum Clock Rates (typical)

IQ Signal Type IF Signal Type1 IQ Signal Type IF Signal Type

LVTTL and CMOS 100 MHz 100 MHz 150 MHz 150 MHz

LVDS 200 MHz 400 MHz 400 MHz 400 MHz

Clock and sample ratesLeast significant bit Most significant bit
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The levels will degrade above the warranted level clock rates, but they may still be usable.

Serial Port Configuration Clock Rates

For a serial port configuration, the lower clock rate limit is determined by the word size (word size 
and sample size are synonymous), while the maximum clock rate limit remains constant at 150 MHz 
for LVTTL and CMOS logic types, and 400 MHz for an LVDS logic type. 

The reverse is true for the sample rate. The lower sample (word) rate value of 1 kHz remains while 
the upper limit of the sample rate varies with the word size. For example, a five-bit sample for an 
LVTTL or CMOS logic type yields the following values in serial mode:

— Clock rate of 5 kHz through 150 MHz

— Sample rate of 1 kHz through 30 MHz

 Refer to Table 10-3 and Table 10-4, for the serial clock rates. 

1. The IF signal type is not available for a serial port configuration.

Table 10-2 Warranted Parallel Input Level Clock Rates and Maximum Clock Rates

Logic Type Warranted Level Clock Rates Maximum Clock Rates (typical)

LVTTL and CMOS 100 MHz 150 MHz

LVDS 200 MHz 200 MHz

Table 10-3 Output Serial Clock Rates

Logic Type Minimum Rate Maximum Rate 

LVDS 1 x (word size) kHz 400 MHz

LVTTL and CMOS 1 x (word size) kHz 150 MHz

Table 10-4 Input Serial Clock Rates

Logic Type Data Type Minimum Rate Maximum Rate 

LVDS Samples 1 x (word size) kHz 400

Pre-FIR 
Samples

1 x (word size) kHz the smaller of: 501 x (word size) MHz 
or  
400 MHz

1. The maximum sample rate depends on the selected filter when the data rate is Pre-FIR Samples. 
Refer to “Input Mode” on page 320 for more information.

LVTTL and CMOS N/A 1 x (word size) kHz 150 MHz
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Parallel and Parallel Interleaved Port Configuration Clock Rates 

Parallel and parallel interleaved port configurations have other limiting factors for the clock and 
sample rates:

— logic type

— Clocks per sample selection

— IQ or IF digital signal type

Clocks per sample (clocks/sample) is the ratio of the clock to sample rate. For an IQ signal type, the 
sample rate is reduced by the clocks per sample value when the value is greater than one. For an IF 
signal or an input signal, clocks per sample is always set to one. Refer to Table 10-5 for the Output 
mode parallel and parallel interleaved port configuration clock rates.

For Input mode, the maximum clock rate is limited by the following factors:

— sample size

— data type

Refer to Table 10-6 for the Input mode parallel and parallel interleaved port configuration clock 
rates.

Table 10-5 Output Parallel and Parallel Interleaved Clock Rates

Logic Type Signal Type Minimum Rate Maximum Rate 

LVDS IQ 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz 
or  
400 MHz

IF 4 kHz 400 MHz

Other IQ 1 x (clocks/sample) kHz the smaller of: 100 x (clocks /sample) MHz 
or  
150 MHz

IF 4 kHz 150 MHz

Table 10-6 Input Parallel and Parallel Interleaved Clock Rates

Logic Type Data Type Minimum Rate Maximum Rate 

N/A Samples 1 kHz 200 MHz

Pre-FIR Samples 1 kHz 100 MHz
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Clock Source

The clock signal for the N5102A module is provided in one of three ways through the following 
selections:

— Internal: generated internally in the interface module (requires an external reference)

— External: generated externally through the Ext Clock In connector 

— Device: generated externally through the Device Interface connector

The clock source is selected using the N5102A module UI on the signal generator, see Figure 10-2. 

Figure 10-2 Clock Source Selection

When you select a clock source, you must let the N5102A module know the frequency of the clock 
signal using the Clock Rate softkey. In the internal clock source mode, use this softkey to set the 
internal clock rate. For device and external clock sources, this softkey must reflect the frequency of 
the applied clock signal. 

When the clock source is Internal, a frequency reference must be applied to the Freq Ref connector. 
The frequency of this applied signal needs to be specified using the Reference Frequency softkey, 
unless the current setting matches that of the applied signal. 

The selected clock source provides the interface module output clock signal at the Clock Out and 
the Device Interface connectors.

Common Frequency Reference

The clocking flexibility of the digital signal interface module allows the setting of arbitrary clock 
rates for the device under test. In general, the clock rate inside the signal generator will be different 
from the interface module clock rate, so the interface module performs a rate conversion. An 
important aspect of this conversion is to have accurate clock rate information to avoid losing data. 
The module relies on relative clock accuracy, instead of absolute accuracy, that must be ensured by 
using a single frequency reference for all clock rates involved in the test setup. This can be 
implemented in various ways (see the five drawings in Figure 10-3 on page 310), but whatever way 
it is implemented, the clock inside the signal generator must have the same base frequency 
reference as the clock used by the device under test.

 Internal clock source 
selection: Set the frequency of 
the applied reference signal.

External and Device 
selection: 
Set to match the clock rate 
of the applied clock signal 
internal selection: Set the 
internal clock rate.
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Signal Generator Frequency Reference Connections

When a frequency reference is connected to the signal generator, it is applied the REF In rear panel 
connector.

Figure 10-3 Frequency Reference Setup Diagrams for the N5102A Module Clock Signal

NOTE: Use only one of the two signal generator frequency reference inputs.

Internally Generated Clock

Device (DUT) Supplied Clock
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Clock Timing for Parallel Data

Some components require multiple clocks during a single sample period. (A sample period consists 
of an I and Q sample). For parallel data transmissions, you can select one, two, or four clocks per 
sample. For clocks per sample greater than one, the I and Q samples are held constant to 
accommodate the additional clock periods. This reduces the sample rate relative to the clock rate 
by a factor equal to the clocks per sample selection. For example, when four is selected, the sample 
rate is reduced by a factor of four (sample rate to clock rate ratio). Figure 10-4 demonstrates the 
clock timing for each clocks per sample selection. For input mode, the clocks per sample setting is 
always one.

NOTE: Use only one of the two signal generator frequency reference inputs.

Externally Supplied Clock
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Figure 10-4 Clock Sample Timing for Parallel Port Configuration

1 Sample Period

Q sample

1 Clock Per Sample

1 Clock

Clock and sample rates are the same

I sample

Clock

4 bits per word 

4 bits per word 
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1 Sample Period

4 Clocks Per Sample

4 Clocks

Sample rate decreases by a factor of four

I sample 

Q sample 

Clock

4 bits per word 

4 bits per word 

1 Sample Period

2 Clocks Per Sample

2 Clocks

I sample

Q sample 

Sample rate decreases by a factor of two

Clock

4 bits per word

4 bits per word
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Clock Timing for Parallel Interleaved Data

The N5102A module provides the capability to interleave the digital I and Q samples. There are two 
choices for interleaving:

— IQ, where the I sample is transmitted first

— QI, where the Q sample is transmitted first

When parallel interleaved is selected, all samples are transmitted on the I data lines. This effectively 
transmits the same number of samples during a sample period on half the number of data lines as 
compared to non-interleaved samples. (A sample period consists of an I and Q sample.) Clocks per 
sample is still a valid parameter for parallel interleaved transmissions and creates a reduction in the 
sample rate relative to the clock rate. The clocks per sample selection is the ratio of the reduction. 
Figure 10-5 shows each of the clocks per sample selections, for a parallel IQ interleaved port 
configuration, using a word sized of four bits and the clock timing relative to the I and Q samples. 
For a parallel QI interleaved port configuration, just reverse the I and Q sample positions. For input 
mode, the clocks per sample setting is always one.

Figure 10-5 Clock Timing for a Parallel IQ Interleaved Port Configuration

Q sample 
4 bits per word 

I sample 
4 bits per word 

1 Sample Period

1 Clock Per Sample

1 Clock

The I sample is transmitted on one clock transition and the Q sample is transmitted on the

Clock

other transition; the sample and clock rates are the same.
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Clock Timing for Serial Data

Figure 10-6 shows the clock timing for a serial port configuration. Notice that the serial 
transmission includes frame pulses that mark the beginning of each sample where the clock 
delineates the beginning of each bit. For serial transmission, the clock and the bit rates are the 
same, but the sample rate varies depending on the number of bits per word that are entered using 
the Word Size softkey. The number of bits per word is the same as the number of bits per sample.

1 Sample Period

4 Clocks Per Sample

4 Clocks

The I sample is transmitted for the first two clock periods and the Q sample is transmitted during the second two

Clock

Q sample 
4 bits per word 

I sample 
4 bits per word 

clock periods; the sample rate is decreased by a factor of four.

1 Sample Period

2 Clocks Per Sample

2 Clocks

The I sample is transmitted for one clock period and the Q sample is transmitted during the second 

Clock

Q sample 
4 bits per word 

I sample 
4 bits per word 

clock period; the sample rate decreases by a factor of two.
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Figure 10-6 Clock Timing for a Serial Port Configuration

Clock Timing for Phase and Skew Adjustments

The N5102A module provides phase and skew adjustments for the clock relative to the data and 
can be used to align the clock with the valid portion of the data. The phase has a 90 degree 
resolution (0, 90, 180, and 270 degree selections) for clock rates from 10 to 200 MHz and a 180 
degree resolution (0 and 180 degree selections) for clock rates below 10 MHz and greater than 200 
MHz. 

The skew is displayed in nanoseconds with a maximum range of ±5 ns using a maximum of ±127 
discrete steps. Both the skew range and the number of discrete steps are variable with a 
dependency on the clock rate. The skew range decreases as the clock rate is increased and 
increases as the clock rate is decreased. The maximum skew range is reached at a clock rate of 
approximately 99 MHz and is maintained down to a clock rate of 25 MHz. For clock rates below 25 
MHz, the skew adjustment is unavailable. 

A discrete step is calculated using the following formula:

The number of discrete steps required to reach the maximum skew range decreases at lower 
frequencies. For example, at a clock rate of 50 MHz, 127 steps would exceed the maximum skew 
range of ±5 ns, so the actual number of discrete steps would be less than 127. 

Figure 10-7 is an example of a phase and skew adjustment and shows the original clock and its 
phase position relative to the data after each adjustment. Notice that the skew adjustment adds to 
the phase setting.

Clock

4 bits per word 

1 Sample

Frame Marker

Data Bits

 1
256 Clock Rate×
------------------------------------------
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Figure 10-7 Clock Phase and Skew Adjustments

Clock skew adjustment
90 degree phase adjustment

Clock

Phase adjusted

skew adjusted

clock

clock

Data

Phase and
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Connecting the Clock Source and the Device Under Test
As shown in Figure 10-3 on page 310, there are numerous ways to provide a common frequency 
reference to the system components (signal generator, N5102A module, and the device under test). 
Figure 10-8 shows an example setup where the signal generator supplies the common frequency 

reference and the N5102A module is providing the clock to the device.

Figure 10-8 Example Setup using the Signal Generator 10 MHz Frequency Reference

1. Refer to the five setup diagrams in Figure 10-3 on page 310 and connect the frequency 
reference cable according to the clock source.

2. If an external clock source is used, connect the external clock signal to the Ext Clock In 
connector on the interface module.

The Device Interface connector on the interface module communicates 
using high speed digital data. Use ESD precautions to eliminate potential 
damage when making connections.

You must disconnect the digital bus cable and the digital module while 
downloading firmware to the signal generator.

Signal generator 10 MHz Out

Freq Ref connector

Device interface connection

Device under test
Break-out board

User furnished ribbon cable(s) connect 
between the device and break-out board.

Common Freq Ref cable

The clock to the device is in the ribbon
cable.
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3. Select the break-out board that has the output connector suited for the application.

4. Refer to Figure 10-8. Connect the break-out board to the Device Interface connector on the 
N5102A module.

5. Connect the device to the break-out board.

If the Device Interface mating connector is used with the device under test, 
refer to Figure 10-8 for the device interface connection and connect the 
device to the N5102A module. Then proceed to “Operating the N5102A 
Module in Output Mode” on page 321 or “Operating the N5102A Module in 
Input Mode” on page 331.
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Data Types
The following block diagram indicates where in the signal generation process the data is injected 
for input mode or tapped for output mode.

Output Mode

When using an ARB format with no real-time modulation filter, the data type is always Samples and 
no filtering is applied to the data samples. The samples are sent to the digital module at the ARB 
sample clock rate and resampled.

For real-time formats or Dual ARB with a real-time modulation filter, choosing Samples as the data 
type will send filtered samples to the digital module at the module’s clock rate. Selecting Pre-FIR 
Samples, sends unfiltered but potentially resampled samples to the module at the module’s clock 
rate.

Input Mode

When the data type is Samples, the data samples coming through the digital module are injected at 
a point that bypasses the filtering process. 

If Pre-FIR Samples is selected, the data samples are injected before the filtering process. 

The Filter softkey accesses a menu that enables you to set the desired filtering parameters. 

Data FIR
DACs

RF

Samples
Samples

Output 

Samples Samples
Pre-FIR

Mode

Filtering &
I,Q

Modulator

LO

Input 
Mode

Pre-FIR

Signal Generator

Generator I/Q

Input Mode

Output Mode

Resampling
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Operating the N5102A Module in Output Mode
This section shows how to set the parameters for the N5102A module using the signal generator UI 
in the output direction. Each procedure contains a figure that shows the softkey menu structure for 
the interface module function being performed. 

Setting up the Signal Generator Baseband Data

The digital signal interface module receives data from a baseband source and outputs a digital IQ 
or digital IF signal relative to the selected logic type. Because a signal generator provides the 
baseband data, the first procedure in operating the interface module is configuring the signal 
generator using one of the real-time or ARB modulation formats, or playing back a stored file using 
the Dual ARB player. For information on configuring the signal generator, refer to Chapter 9, 
“   Basic Digital Operation (Option 653/655/656/657)”, on page  205.

1. Preset the signal generator.

2. Select the modulation format (GSM, Custom, and so forth) and set the desired parameters.

3. Turn-on the modulation format.

Accessing the N5102A Module User Interface

Figure 10-9 shows the Auxiliary menu that is accessed by pressing the Aux Fctn key on the front 
panel of the signal generator.

Figure 10-9  First-Level Softkey Menu

Select either PXB or N5102A
connectivity.
The default selection is N5102A.

Aux 

Press here to access the N5102A
menu.
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Press N5102A Interface to access the UI (first-level softkey menu shown in Figure 10-10) that is 
used to configure the digital signal interface module. Notice the graphic in the signal generator 
display, showing a setup where the N5102A module is generating its own internal clock signal. This 
graphic changes to reflect the current clock source selection.

Figure 10-10 N5102A Interface Menu

Choosing the Logic Type and Port Configuration

Figure 10-11 Logic and Port Configuration Softkey Menus

1. Refer to Figure 10-11. Press the Logic Type softkey.

Line is grayed out until the N5102A module interface is turned on

Internal clock going to the DUT
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From this menu, choose a logic type.

2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey 
selection appears requesting confirmation.

3. Refer to Figure 10-11. Press the Port Config softkey.

In this menu, select either a serial, parallel, or parallel interleaved data transmission.

4. Select the port configuration for the device.

Selecting the Output Direction

Press Data Setup > Direction Input Output to Output and press Return. 

Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory 
names are generally not mentioned. For example, the Word Size softkey. 

1. Refer to Figure 10-12. Press the Data Setup softkey.

Changing the logic type can increase or decrease the signal voltage level 
going to the device under test. To avoid damaging the device and/or the 
N5102A module, ensure that both are capable of handling the voltage 
change.

Within the data and clock setup softkey menus, some softkeys function 
relative to the current configuration. Softkeys that are grayed out are not 
available for the current setup.

If Option 003 is the only option installed, the direction softkey will be 
unavailable and the mode will always be output. With both Option 003 
(output mode) and Option 004 (input mode) installed, the default direction 
is output. 
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Figure 10-12  Data Setup Menu Location

This softkey menu accesses the various parameters that govern the data received by the 
device under test. The status area of the display shows the number of data lines used for both 
I and Q along with the clock position relative to the data. When the port configuration is 
parallel or parallel interleaved, the number of data lines indicated is equivalent to the word 
(sample) size. When the port configuration is serial, the display will show that only one I and 
one Q data line is being used along with the frame marker that delineates the beginning of a 
sample. Figure 10-13 shows the data setup menu structure.

Accesses the Data Setup menu
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Figure 10-13  Data Setup Softkey Menu with Parallel Port Configuration

2. If a real-time modulation format or the real-time modulation filter feature in Dual ARB is being 
used, press the Data Type softkey. 

In this menu, select whether the real-time baseband data from the signal generator is either 
filtered (Samples) or unfiltered (Pre-FIR Samples). The selection is dependent on the test 
needs. The Samples selection provides FIR filtered baseband samples according to the 
communication standard of the active modulation format. This is the preset selection and the 
one most commonly used. However if the device being tested already incorporates FIR filters, 
the Pre-FIR Samples selection should be used to avoid double filtering.

3. Select the data type that is appropriate for the test.

4. Press the Numeric Format softkey.

From this menu, select how the binary values are represented. Selecting 2’s complement 
allows both positive and negative data values. Use the Offset Binary selection when 
components cannot process negative values.

Inactive for a serial port

Frame polarity is active

configuration 

for a serial port configuration

Inactive for ARB formats

Inactive for word  
size = 16 bits

Available only while in 
output mode
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5. Select the numeric format required for the test.

6. Press the More (1 of 2) softkey.

From this softkey menu, select the bit order, swap I and Q, select the polarity of the 
transmitted data, and access menus that provide data negation, scaling, gain, offset, and IQ 
rotation adjustments.

7. Press the Data Negation softkey.

Negation differs from changing the I and Q polarity. Applied to a sample, negation changes the 
affected sample by expressing it in the two's complement form, multiplying it by negative one, 
and converting the sample back to the selected numeric format. This can be done for I 
samples, Q samples, or both. 

 The choice to use negation is dependent on the device being tested and how it needs to 
receive the data.

8. Press the Gain, Offset & Scaling softkey.

Use the softkeys in this menu for the following functions:

—reduce sample values for both I and Q using the Scaling softkey

—increase or decrease the sample values independently for I and Q using the I Gain and Q Gain 
softkeys

—compensate for or add a DC offset using the I Offset and Q Offset softkeys

—rotate the data on the IQ plane using the Rotation softkey

9. Make any required scaling, gain, offset, or rotation adjustments to properly test the device.

10.Press Return > Return to return to the first-level softkey menu.

Configuring the Clock Signal

1. Refer to Figure 10-14. Press the Clock Setup softkey.

Figure 10-14  Clock Setup Menu Location

Accesses the 
Clock Setup Menu
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From this softkey menu, set all of the clock parameters that synchronize the clocks between 
the N5102A module and the signal generator. You can also change the clock signal phase so 
the clock occurs during the valid portion of the data. Figure 10-15 shows the clock setup 
menu.

Figure 10-15  Clock Setup Softkey Menu for a Parallel Port Configuration

The top graphic on the display shows the current clock source that provides the output clock 
signal at the Clock Out and Device Interface connectors. The graphic changes to reflect the 
clock source selection discussed later in this procedure. The bottom graphic shows the clock 
position relative to the data. The displayed clock signal will change to reflect the following:

—clocks per sample selection

—clock phase choice

—clock skew adjustment

—clock polarity selection

If the device or external clock does not match the frequency, one of the following error 
messages will appear on the signal generator:

805  Digital module output FIFO overflow error; There are more 
samples being produced than can be consumed at the 
current clock rate. Verify that the digital module clock 
is set up properly.

Inactive for a serial port configuration and the IF signal type

Active for only the Internal clock source selection

Inactive for clock rates below 25 MHz

Inactive for clock rates below  
10 MHz and above 200 MHz
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This error is reported when the output FIFO is overflowing in

the digital module. This error can be generated if an external clock

or its reference is not set up properly, or if the internal VCO is

unlocked.

806  Digital module output FIFO underflow error; There are not 
enough samples being produced for the current clock rate. 
Verify that the digital module clock is set up properly.
This error is reported when the output FIFO is underflowing in the digital 
module. This error can be generated if an external clock or its reference is not 
set up properly, or if the internal VCO is unlocked.

2. If the port configuration is parallel or parallel interleaved, using an IQ signal type, press the  
Clocks Per Sample softkey.

Notice that multiple clocks per sample can be selected. Some DACs require the ability to clock 
multiple times for each sample; having a clocks per sample value greater than one reduces the 
rate by a factor equal to the selected number of clocks per sample. The sample rate is viewed 
on the first-level and Data Setup softkey menus.

3. Select the clocks per sample value to fit the test.

4. Press the Clock Source softkey.

From this menu, select the clock signal source. With each selection, the clock routing display 
in the signal generator clock setup menu will change to reflect the current clock source. This 
will be indicated by a change in the graphic.

5. Select the clock source.

If External or Device is Selected

Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal. 

For the External selection, the signal is supplied by an external clock source and applied to the 
Ext Clock In connector. For the Device selection, the clock signal is supplied through the 
Device Interface connector, generally by the device under test.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock 
signal. The reference frequency signal must be applied to the Freq Ref connector on the digital 
module.

a.Press the Reference Frequency softkey and enter the frequency of the externally applied 
frequency reference.

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  316.
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b.Press the Clock Rate softkey and enter the appropriate clock rate.

Table 10-7 provides a quick view of the settings and connections associated with each clock 
source selection.

6. Press the Clock Phase softkey.

From the menu that appears, you can adjust the phase of the clock relative to the data in 90 
degree increments. The selections provide a coarse adjustment for positioning the clock on the 
valid portion of the data. Selecting 180 degrees is the same as selecting a negative clock 
polarity.

The 90 degree and 270 degree selections are not available when the clock rate is set below 10 
MHz or above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rate is set 
below 10 MHz or above 200 MHz, the phase will change to 0 degrees or 180 degrees, 
respectively. 

7. Enter the required phase adjustment.

8. Press the Return softkey to return to the clock setup menu.

9. Press the Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is 
a phase adjustment using increments of time. This enables greater skew adjustment capability 
at higher clock rates. For clock rates below 25 MHz, this softkey is inactive.

The skew has discrete values with a range that is dependent on the clock rate. Refer to “Clock 
Timing for Phase and Skew Adjustments” on page  316 for more information on skew settings.

10.Enter the skew adjustment that best positions the clock with the valid portion of the data.

Table 10-7 Clock Source Settings and Connectors

Clock 
Source

Softkeys N5102A Module Connection

Reference 
Frequency

Clock Rate1

1. For the Internal selection, this sets the internal clock rate. For the External 
and Device selections, this tells the interface module the rate of the 
applied clock signal.

Freq 
Ref

Ext Clock 
In

Device 
Interface

External X X

Device X X

Internal2

2. There should be no clock signal applied to the Ext Clock In connector.

X X X

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  316.
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11.Press the Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock 
transition. This has the same affect as selecting the 180 degree phase adjustment.

12.Make the clock polarity selection that is required for the device being tested.

13.Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu graphic. For 
example, if the device is the new clock source, the graphic will show that the frequency 
reference is now connected to the DUT and the DUT has an input clock line going to the 
N5102A module.

Generating Digital Data

Press the N5102A Off On softkey to On.

Digital data is now being transferred through the N5102A module to the device. The green status 
light should be blinking. This indicates that the data lines are active. If the status light is solidly 
illuminated (not blinking), all the data lines are inactive. The status light comes on and stays on 
(blinking or solid) after the first time the N5102A module is turned on (N5102A Off On to On). The 
status light will stay on until the module is disconnected from its power supply.

The interface module can only be turned on while a modulation format is active. If the modulation 
format is turned off while the module is on, the module will turn off and an error will be reported.

If changes are made to the baseband data parameters, it is recommended 
that you first disable the digital output (N5102A Off On softkey to Off) to 
avoid exposing your device and the N5102A module to the signal variations 
that may occur during the parameter changes.
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Operating the N5102A Module in Input Mode
This section shows how to set the parameters for the N5102A module using the signal generator UI 
in the input direction. Each procedure contains a figure that shows the softkey menu structure for 
the interface module function being performed.

Refer to “Connecting the Clock Source and the Device Under Test” on page 318 and configure the 
test setup.

Accessing the N5102A Module User Interface

Figure 10-16 shows the Auxiliary menu that is accessed by pressing the Aux Fctn key on the front 
panel of the signal generator.

Figure 10-16  First-Level Softkey Menu

All parameters for the N5102A module are set with softkeys on the signal generator.

Press N5102A Interface to access the UI (first-level softkey menu shown in Figure 10-17) that is 
used to configure the digital signal interface module. Notice the graphic in the signal generator 
display, showing a setup where the N5102A module is generating its own internal clock signal. This 
graphic changes to reflect the current clock source selection.

Figure 10-17  N5102A Interface Menu

Select either PXB or N5102A
connectivity.
The default selection is N5102A.

Aux 

Press here to access the N5102A
menu.

Internal clock going to the DUT

Line is grayed out until the N5102A module interface is turned on
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Selecting the Input Direction

If both Option 003 (output mode) and Option 004 (input mode) are installed, you must select the 
input direction.

Press Data Setup > Direction Input Output to Input and press Return. 

Choosing the Logic Type and Port Configuration

Figure 10-18 Logic and Port Configuration Softkey Menus

1. Refer to Figure 10-18. Press the Logic Type softkey.

From this menu, choose a logic type.

If only Option 004 is installed, the direction softkey will be unavailable and 
the mode will always be input. 

Changing the logic type can increase or decrease the signal voltage level. 
To avoid damaging the device and/or the N5102A module, ensure that both 
are capable of handling the voltage change.
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2. Select the logic type required for the device being tested.

A caution message is displayed whenever a change is made to the logic types, and a softkey 
selection appears asking for confirmation.

3. Refer to Figure 10-18. Press the Port Config softkey.

In this menu, select either a serial, parallel, or parallel interleaved data transmission.

4. Select the port configuration for the device being tested.

Configuring the Clock Signal

1. Refer to Figure 10-19. Press the Clock Setup softkey.

Figure 10-19  Clock Setup Menu Location

From this softkey menu, set all of the clock parameters that synchronize the data between the 
N5102A module and the device. From this menu, the clock signal phase can be changed so the 
clock occurs during the valid portion of the data. Figure 10-20 shows the clock setup menu.

If the device or external clock does not match the frequency, one of the following error 
messages will appear on the signal generator:

803  Digital module input FIFO overflow error; There are more 
samples being produced than can be consumed at the 
current clock rate. Verify that the digital module clock 
is set up properly.
This error is reported when the digital module clock setup is not

synchronized with the rate the samples are entering the digital

module. Verify that the input clock rate matches the specified

Within the data and clock setup softkey menus, some softkeys function 
relative to the current configuration. Softkeys that are grayed out are not 
available for the current setup. Refer to the help text to determine which 
parameter is causing the softkey to be unavailable. Press the Help hardkey 
on the signal generator front panel and then the softkey that is 
unavailable.

Accesses the Clock Setup 
Menu
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clock rate under the clock setup menu.

804  Digital module input FIFO underflow error; There are not 
enough samples being produced for the current clock rate. 
Verify that the digital module clock is set up properly.
This error is reported when the digital module clock setup is not

synchronized with the rate the samples are entering the digital

module. Verify that the input clock rate matches the specified

clock rate under the clock setup menu.

Figure 10-20  Clock Setup Softkey Menu for a Parallel Port Configuration

The top graphic on the display shows the current clock source that provides the output clock 
signal at the Clock Out and Device Interface connectors. The graphic changes to reflect the 
clock source selection discussed later in this procedure. The bottom graphic shows the clock 
edges relative to the data. The displayed clock signal will change to reflect the following:

—clock phase choice

—clock skew adjustment

—clock polarity selection

2. Press the Clock Source softkey.

Inactive for Input mode

Active for only the Internal clock source selection

Inactive for clock rates below 25 MHz

Inactive for clock rates below  
10 MHz and above 200 MHz
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From this menu, select the clock signal source. With each selection, the clock routing display 
in the signal generator clock setup menu will change to reflect the current clock source. This 
will be indicated by a change in the graphic.

3. Select the clock source.

If External or Device is Selected

Press the Clock Rate softkey and enter the clock rate of the externally applied clock signal. 

For the External selection, the signal is supplied by an external clock source and applied to the 
Ext Clock In connector. For the Device selection, the clock signal is supplied through the 
Device Interface connector, generally by the device being tested.

If Internal is Selected

Using an external frequency reference, the N5102A module generates its own internal clock 
signal. The reference frequency signal must be applied to the Freq Ref connector on the digital 
module.

a.Press the Reference Frequency softkey and enter the frequency of the externally applied 
frequency reference.

b.Press the Clock Rate softkey and enter the appropriate clock rate.

Table 10-8 provides a quick view of the settings and connections associated with each clock 
source selection.

4. Press the Clock Phase softkey.

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  316.

Table 10-8 Clock Source Settings and Connectors

Clock 
Source

Softkeys N5102A Module Connection

Reference 
Frequency

Clock Rate1

1. For the Internal selection, this sets the internal clock rate. For the External 
and Device selections, this tells the interface module the rate of the 
applied clock signal.

Freq 
Ref

Ext Clock 
In

Device 
Interface

External X X

Device X X

Internal2

2. There should be no clock signal applied to the Ext Clock In connector 
when Internal is being used.

X X X
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From the menu that appears, the phase of the clock relative to the data can be changed in 90 
degree increments. The selections provide a coarse adjustment for positioning the clock on the 
valid portion of the data. Selecting 180 degrees is the same as selecting a negative clock 
polarity.

The 90 degree and 270 degree selections are not available when the clock rate is set below 10 
MHz or above 200 MHz. If 90 degrees or 270 degrees is selected when the clock rate is set 
below 10 MHz or above 200 MHz, the phase will change to 0 degrees or 180 degrees, 
respectively. 

5. Enter the required phase adjustment.

6. Press the Return softkey to return to the clock setup menu.

7. Press the Clock Skew softkey.

This provides a fine adjustment for the clock relative to its current phase position. The skew is 
a phase adjustment using increments of time. This enables greater skew adjustment capability 
at higher clock rates. For clock rates below 25 MHz, this softkey is inactive.

The skew has discrete values with a range that is dependent on the clock rate. Refer to “Clock 
Timing for Phase and Skew Adjustments” on page  316 for more information on skew settings.

8. Enter the skew adjustment that best positions the clock with the valid portion of the data.

9. Press the Clock Polarity Neg Pos softkey to Neg.

This shifts the clock signal 180 degrees, so that the data starts during the negative clock 
transition. This has the same affect as selecting the 180 degree phase adjustment.

10.Make the clock polarity selection that is required for the device being tested.

11.Press the Return hardkey to return to the first-level softkey menu.

The clock source selection is also reflected in the first-level softkey menu graphic. For 
example, if the device is the new clock source, you will see that the frequency reference is now 
connected to the DUT and the DUT has an input clock line going to the N5102A module.

The clock phase and clock skew may need to be adjusted any time the 
clock rate setting is changed. Refer to “Clock Timing for Phase and Skew 
Adjustments” on page  316.
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Selecting the Data Parameters

This procedure guides you through the data setup menu. Softkeys that have self-explanatory 
names are generally not mentioned. For example, the Word Size softkey.

1. Refer to Figure 10-21. Press the Data Setup softkey.

Figure 10-21  Data Setup Menu Location

This softkey menu accesses the various parameters that govern the data received by the signal 
generator. The status area of the display shows the number of data lines used for both I and Q 
along with the clock position relative to the data. Figure 10-22 shows the data setup menu 
structure.

Accesses the Data Setup 
Menu
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Figure 10-22  Data Setup Softkey Menu with Parallel Port Configuration

2. Press the Data Type softkey. 

In this menu, select the data type to be either filtered (Samples) or unfiltered (Pre-FIR 
Samples). The selection is dependent on the test needs and the device under test. However if 
the device being tested already incorporates FIR filters, the Pre-FIR Samples selection should 
be used to avoid double filtering. Refer to “Data Types” on page 320, for more information.

3. Select the data type that is appropriate for the test needs.

4. Press the Numeric Format softkey.

Inactive for a serial port

Frame polarity is active

configuration 

for a serial port configuration

Only available when the N5102A 
digital module is  
turned on and using input mode

Only available when  
Data Type is  
Pre-FIR Samples
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From this menu, select how the binary values are represented. Selecting 2’s complement 
allows both positive and negative data values. Use the Offset Binary selection when 
components cannot process negative values.

5. Select the numeric format required for the test.

6. Press the More (1 of 2) softkey.

From this softkey menu, select the bit order, swap I and Q, the polarity of the data, and access 
menus that provides data negation, scaling, and filtering parameters.

7. Press the Data Negation softkey.

Negation differs from changing the I and Q polarity. Applied to a sample, negation changes the 
affected sample by expressing it in the two's complement form, multiplying it by negative one, 
and converting the sample back to the selected numeric format. This can be done for I 
samples, Q samples, or both. 

 The choice to use negation is dependent on the device being tested.

8. To access I/Q scaling and filter parameters, press Return > N5102A Off On to On. This will 
invoke the real time Custom format in the signal generator’s baseband generator. This is 
needed to set the filter parameters when Pre-FIR Samples is selected as the data type. 

9. Press the Baseband Setup softkey.

Use this softkey menu to adjust the I/Q scaling and access filter parameters. If the selected 
data type is Samples, the Filter softkey is grayed out (inactive). For more information on 
user-defined filtering, refer to the “Using Finite Impulse Response (FIR) Filters in the Dual ARB 
Real-Time Modulation Filter” on page 274 and “Modifying a FIR Filter Using the FIR Table 
Editor” on page 280.

Digital Data

If the N5102A digital module is not on, press Return > Return > N5102A Off On to On.

Digital data is now being transferred through the N5102A module to the signal generator. The 
green status light should be blinking. This indicates that the data lines are active. If the status light 
is solidly illuminated (not blinking), all the data lines are inactive. The status light comes on and 
stays on (blinking or solid) after the first time the N5102A module is turned on (N5102A Off On to 
On). The status light will stay on until the module is disconnected from its power supply.

If changes are made to the baseband data parameters, it is recommended 
that you first disable the digital input (N5102A Off On softkey to Off) to 
avoid exposing the device and the N5102A module to the signal variations that 
may occur during the parameter changes.
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11   Baseband Operating Mode—Primary, BERT, or N5102A

This chapter describes the Baseband Operating Mode feature used by 
Keysight N5172B EXG, and N5182B MXG X-Series signal generators.

The Baseband Operating Mode can be one of three different ARB FPGA images; each ARB FPGA 
image changes the supported features available while in the selected mode.

The selected Baseband Operating Mode is a persistent instrument setting and its value is 
maintained through power cycles, Preset, or *RST.

The default Baseband Operating Mode is set to Primary and can only be changed when one or 
more of the following options are installed. 
(BERT and/or N5102A will appear grayed-out if they are not available.)

— Internal Bit Error Rate Analyzer (BERT), Option N5180UN7B

— Digital Output Connectivity with the N5102A, Option 003 or 004 or both.

Figure 11-1 Baseband Operating Mode Softkeys 

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.

Baseband Operating Mode is available on all Keysight N5172B EXG, and N5182B MXG X-Series 
signal generators that have installed firmware version B.01.70 or later.

To set the Baseband Operating Mode to Primary on page 344

To set the Baseband Operating Mode to BERT on page 342

To set the Baseband Operating Mode to N5102A on page 343
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To set the Baseband Operating Mode to BERT
In this mode, all installed and licensed signal generator features as well as all BERT features are 
fully supported, but N5102A features are not available.

Figure 11-2 Changing to the BERT Baseband Operating Mode 

1. Press Aux Fctn.

2. Press Baseband Operating Mode. 
(Default selection is Primary.)

3. Press BERT. (Press the Return key to cancel the change.)

4. After reading the above caution and taking any needed actions, 
press Confirm Change to BERT Operating Mode or Return to cancel.

This confirmation selects the BERT ARB FPGA image. 
All BERT features are fully supported, but N5102A is not available in this mode. The BERT ARB 
FPGA image contains all functionality and features from the B.01.65 PXB Input FPGA image. For 
backwards compatibility, selecting the BERT Baseband Operating Mode sets the I/Q Digital Bus 
Connectivity to PXB.

Changing the Baseband Operating Mode selection will cause all files in 
volatile waveform memory to be lost. Backup any files you want to keep before 
confirming the change. 
See “Working with Files” on page 76.

The BERT annunciator is displayed indicating that the 
BERT Baseband Operating Mode is currently selected. 
(For more information on annunciators, see page 27.)
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To set the Baseband Operating Mode to N5102A
In this mode, all installed and licensed signal generator features as well as all N5102A features are 
fully supported, but BERT features are not available.

Figure 11-3 Changing to the N5102A Baseband Operating Mode 

1. Press Aux Fctn.

2. Press Baseband Operating Mode. 
(Default selection is Primary, but image above shows changing from BERT.)

3. Press N5102A. (Press the Return key to cancel the change.)

4. After reading the above caution and taking any needed actions, 
press Confirm Change to N5102A Operating Mode or Return to cancel.

This confirmation selects the N5102A ARB FPGA image. All N5102A features are fully supported, 
but BERT is not available in this N5102A Baseband Operating Mode. For backwards 
compatibility, selecting the N5102A Baseband Operating Mode sets the I/Q Digital Bus 
Connectivity to N5102A.

Changing the Baseband Operating Mode selection will cause all files in the 
volatile waveform memory to be lost. Backup any files you want to keep before 
confirming the change. 
See “Working with Files” on page 76.

The N5102A annunciator is displayed indicating that the 
N5102A Baseband Operating Mode is currently selected. 
(For more information on annunciators, see page 27.)
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To set the Baseband Operating Mode to Primary
In this mode, all installed and licensed signal generator features are fully supported, but BERT and 
N5102A features are not available.

Figure 11-4 Changing to the Primary Baseband Operating Mode 

1. Press Aux Fctn.

2. Press Baseband Operating Mode.

3. Press Primary. (Press the Return key to cancel the change.)

4. After reading the above caution and taking any needed actions, 
press Confirm Change to Primary Operating Mode or Return to cancel.

This confirmation selects the PXB Input ARB FPGA image. All signal generator features are 
available in this mode except BERT and N5102A functionality. For backwards compatibility, 
selecting the Primary Baseband Operating Mode sets the I/Q Digital Bus Connectivity to PXB.

Changing the Baseband Operating Mode selection will cause all files in the 
volatile waveform memory to be lost. Backup any files you want to keep before 
confirming the change. 
See “Working with Files” on page 76.

The Primary annunciator is NOT displayed and it overwrites 
both the BERT and N5102A annunciators, indicating that the 
Primary Baseband Operating Mode is currently selected. 
Annunciators for BERT or N5102A are only displayed when  
the Baseband Operating Mode is not set to Primary.

(For more information on annunciators, see page 27.)
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12     BERT (Option N5180UN7B)

The bit error rate test (BERT) capability allows you to perform bit error rate (BER) analysis on digital 
communications equipment. This enables functional and parametric testing of receivers and 
components including sensitivity and selectivity.

This feature is available in X-Series vector signal generators (N5172B, and N5182B). 

The following options are recommended:

— Option 653, 655, 656, or 657 -- Internal Baseband Generator 

— Option N5180431B -- Custom Digital Modulation 

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.
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Bit Error Rate Tester–Option N5180UN7B
The bit error rate test (BERT) capability allows you to perform bit error rate (BER) analysis on digital 
communications equipment. This enables functional and parametric testing of receivers and 
components including sensitivity and selectivity.

Block Diagram

When measuring BER, a clock signal that corresponds to the unit under test (UUT) output data 
must be input to the BER CLK IN connector. If the clock is not available from the UUT, use the DATA 
CLK OUT signal from the X-Series baseband modulator. Refer to Figure 12-16 for information 
about these connections.

Figure 12-1 

Clock Gate Function

When you use the clock gate function, the clock signal to the BER CLK IN (rear panel BB TRIG 1) 
connector is valid only when the clock gate signal to the BER GATE IN connector is ON.

Press the Clock Gate Off On softkey to toggle the clock gate function off and on.The Clock Gate 
Polarity Neg Pos softkey sets the input polarity of the clock gate signal supplied to the rear panel 
BER GATE IN connector. When you select Pos (positive), the clock signal is valid when the clock 
gate signal is high; when you select Neg (negative), the clock signal is valid when the clock gate 
signal is low.

The following figure shows an example of the clock gate signal.
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Figure 12-2 

— When the Clock Gate Off On softkey is set to Off:

The clock signal in both “A” and “B” parts is effective and no gate function is required. Therefore, 
the bit error rate is measured using the clock and data signal in both “A” and “B” parts.

— When the Clock Gate Off On softkey is set to On, and the Clock Gate Polarity Neg Pos softkey 
is set to Pos:

The clock signal in “A” part is effective. Therefore, the bit error rate is measured using the clock 
and data signals in “A” part.

— When the Clock Gate Off On softkey is set to On, and the Clock Gate Polarity Neg Pos softkey 
is set to Neg:

The clock signal in “B” part is effective. Therefore, the bit error rate is measured using the clock 
and data signals in “B” part.

Clock/Gate Delay Function

This function enables you to restore the timing relationship between the clock/gate timing as it 
passes through the unit under test (UUT) and the packet data.

The shifted clock signal is emitted from pin 17 of the AUX I/O rear panel connector. When you use 
the clock delay function, the clock signal to the BER CLK IN connector is delayed by the clock delay 
function. When you use the gate delay function with the clock gate function, the clock signal is 
gated by the gate signal which is delayed by the gate delay function.

To see the signal flow using the clock and gate functions, refer to Figure 12-3.
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Figure 12-3 
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Clock Delay Function

In this example, the clock delay function is off. Figure 12-4 shows the input of the internal error 
detector of N5180UN7B through AUX I/O and indicates that the data is delayed from the clock.

Figure 12-4 

CH1: BER TEST OUT (pin 17 of AUX I/O connector) 
CH2: BER MEAS END (pin 15 of AUX I/O connector)

In this example, the clock delay function is on. The rising edge of the clock was delayed by 200 ns 
and was adjusted to the center of the data. Figure 12-5 indicates the result of the using the clock 
delay function. 

Figure 12-5 

CH1

CH2

CH1

CH2
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Gate Delay Function in the Clock Mode

To use this function, the clock must be set to continuous mode. 

In this example, the clock is used to delay the gate function. The clock of the internal error detector 
was gated by the gate signal which is delayed by two clocks. Figure 12-6 shows that CH0 and CH1 
are the input of the clock and data from the rear panel input connectors of Option N5180UN7B. 
CH2 is the gated clock through the AUX I/O connector.

Figure 12-6 

CH0: BER CLK IN (rear panel BNC connector labeled BB TRIG 1) 
CH1: BER GATE IN (rear panel BNC connector labeled BB TRIG 2) 
CH2: BER TEST OUT (pin 17 of AUX I/O connector)

CH1

CH2

CH0
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Triggering

This section describes the operating principles of the triggering function for Option N5180UN7B. To 
see the signal flow of the triggering function refer to Figure 12-7.

Figure 12-7 

In this example, the triggering sequence is where you have an incoming data clock and data bit 
sequences, the trigger is active, and the BERT measurement begins. Refer to Figure 12-8.

Figure 12-8 
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In this example, synchronization occurs after receiving a trigger. 

The reference data is generated by stored data bits. If the BERT measurement accepts data bits 
immediately after receiving a trigger, set the trigger delay to On and the trigger delay count to a 
value corresponding to the data format. For PN9 set the delay to 9. Refer to Figure 12-9.

Figure 12-9 
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In this example, the triggering sequence is where the trigger delay is active with a cycle count. 

The reference data is generated by stored data bits. If the BERT measurement accepts data bits 
immediately after receiving a trigger, set the trigger delay to On and the trigger delay count to a 
value corresponding to the data format. For PN9 set the delay to 9. If the cycle count is set to more 
than 1, it is not necessary to store data bits and no unnecessary delay occurs. Refer to Figure 12-10 
and “Repeat Measurements” on page 354.

Figure 12-10 

Data Processing

Data Rates

Data rates up to 90 MHz are supported for BERT analysis on unframed or framed PN sequences. 
Note that the BERT analyzer supports only continuous PN sequences.

Synchronization

Immediately after the trigger event, the DSP for the BERT measurement tries to establish 
synchronization using the first incoming bit stream. 

If the Bit Delay Off On softkey is set to On, the number of bits specified by the Delayed Bits are 
ignored. The synchronization checking is repeated using an error-free bit string, lengthened by the 
Delayed Bits, until synchronization is established. 

When the BERT Resync Off On softkey is set to On, the BERT measurements will automatically be 
restarted if the intermediate BERT measurement result exceeds the value specified by the BERT 
Resync Limits. 

Special Pattern Ignore Function

The special pattern ignore function is especially useful when performing BERT analysis on radios 
that generate consecutive 0’s or 1’s data for traffic channels when they fail to detect the Unique 
Word or lose synchronization. If 160 or more consecutive incoming data bits are either 1’s or 0’s, 
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and the Spcl Pattern Ignore Off On softkey is set to On, then all of the consecutive 0’s or 1’s are 
ignored. Select either 0’s or 1’s as the data to ignore by using the Spcl Pattern 0’s 1’s softkey. The 
following figure shows an example of the special pattern ignore function.

Figure 12-11  Pattern Ignore Function Example

The 160 or more ignored bits can be anywhere in the PN sequence. The signal generator ignores 
these bits as error, but they are counted in the PN sequence bit count.

Pass/Fail Judgement

There are two pass/fail judgement update modes: cycle end and fail hold. With cycle end selected, 
either pass or fail judgement is made for the results of each measurement cycle. With fail hold 
selected, the fail judgement is retained whenever a failure occurs during one loop of BERT repeat 
measurements. Fail hold mode allows you to determine when a failure occurs at least once during 
an entire cycle of measurements.

Repeat Measurements

When the Cycle Count softkey is set to more than 1, the synchronization performed before the start 
of each measurement is only executed the first time; then it keeps track of the clock signal and the 
PRBS generation for the incoming data. This function can reduce the total time for BERT 
measurements. Also, once synchronization is established, it is retained even if the BERT 
measurement result degrades. You may wish to adjust the signal level to find a specific BERT value. 
However, once synchronization is lost in a repeat sequence, it will not be restored until the initiation 
of a new sequence. The following figure shows an example of the repeat measurements.

Figure 12-12  Repeat Measurements Example
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Testing Signal Definitions

The timing diagram <Keysight Red >Figure 12-13, “Testing Signal Definitions,” shows the 
relationships between a trigger event and the output signals at the BER MEAS END and BER TEST 
OUT connectors.

If a BER MEAS END signal stays high following a trigger event, the BERT measurement is in 
progress and other trigger events are ignored. This state is stored in the status register and can be 
queried.

Figure 12-13  Testing Signal Definitions

— T1 is a firmware handling time measured from a Trigger event to the rising edge of a BER MEAS 
END signal.

— T2 is a firmware handling time measured from the falling edge of a BER TEST OUT signal to the 
falling edge of the BER MEAS END signal.

— T3 is a minimum requirement time measured from the falling edge of the BER MEAS END signal 
to the next trigger event. T3 should be greater than 0 second.

The pulse output of the BER TEST OUT for the Nth-1 test result ends prior to the falling edge of the 
BER MEAS END signal for the Nth measurement; so you can use this edge to start latching the Nth 
test result.
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Verifying BERT Operation 
The following procedures verify the operation of the signal generator’s bit error rate test (BERT) 
function. The tests can be performed as part of a daily validation routine or can be used whenever 
you want to check the validity of your BERT measurements. 

Figure 12-14  BERT Softkeys

The following procedures check the signal generator’s BERT operation and 
do not ensure system performance to specifications.

Select PXB/BERT to enable 
BERT functionality.

see page 357

see page 357

see page 357
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Figure 12-15  BERT I/O Setup Softkeys

The highlighted BNC connectors in Figure 12-16 are used for different signals in the BERT 
capability mode. The BERT-specific configuration is shown here. The AUX I/O connector 
configuration is customizable for the applications/options being used. Figure 12-16 shows the rear 
panel connectors used for the BERT capability, and the configuration of the AUX I/O connector. For 
more information about the AUX I/O connector, refer to Rear Panel Overview (N5166B, N5171B, 
N5172B, N5181B, & N5182B) on page 30.

Select PXB/BERT to enable 
BERT functionality.

see page 356
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Measurement Setup Using Self-Test Mode

The following steps set up the signal generator for the BERT measurement selt-test. 

1. Refer to Figure 12-16 and make the following connections on the signal generator’s rear panel. 

—DATA OUT (Aux I/O connector pin 15) to BER DATA IN (BNC connector labeled EVENT 1). 

—DATA CLK OUT (Aux I/O connector pin 17) to BER CLK IN (BNC connector labeled BB 
TRIG1). 

Figure 12-16  Rear Panel Connectors for BERT Configuration

2. Press the Preset hardkey. This configures the signal generator to a pre-defined state.

3. Press the Aux Fctn hardkey.

4. Press Digital Bus Connectivity PXB/BERT N5102A to PXB/BERT > Confirm Changes > BERT > 
BERT Off On to On > BER Display > BER Display % Exp to % > Display Update Cycle End Cont 
to Cont. 

5. Press BERT > I/O Setup > AUX I/O Out > PN9 Out. 

6. Press Return > Configure Trigger > BERT Trigger > Immediate. 

7. Press Return > BERT > On.  
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Verifying BERT Operation

The Total Bits will count to 10000 Bits (default setting) and the Error Bits should read 0 Bits. 
See Figure 12-17.

Figure 12-17  Self-Test Mode Results
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Measurement Example Using Custom Digital Modulation (Requires Option 
N5180431B)

The following steps set up the signal generator for a BERT measurement using Custom Digital 
Modulation. 

1. Refer to Figure 12-16 and make the following connections on the signal generator’s rear panel. 

—DATA OUT (Aux I/O connector pin 33) to BER DATA IN (BNC connector labeled EVENT 1). 

—DATA CLK OUT (Aux I/O connector pin 7) to BER CLK IN (BNC connector labeled BB 
TRIG1). 

2. Press the Preset hardkey. This configures the signal generator to a pre-defined state.

3. Press the Mode hardkey.

4. Press Real-Time Custom > Modulation Setup > Modulation Type > QPSK. 

5. Press Return > Return > Return > Data > PN Sequence > More > PN9.

6. Press Return > More > More > Data/Clk/Sync Signal Polarity Setup > Data/Clk/Sync Rear 
Outputs On.

7. Press the Aux Fctn hardkey.

8. Press Digital Bus Connectivity PXB/BERT N5102A to N5102A > Confirm Changes > BERT > 
BERT Off On to On > BER Display > BER Display % Exp to % > Display Update Cycle End Cont 
to Cont. 

The following steps configure BERT measurement parameters. 

9. Press Return > Configure BERT > Total Bits to 100000 > Enter > More > Special Pattern Ignore 
Off On to Off.

10.Press BERT Resync Off On to Off > Return > Pass/Fail Off On to Off.

11.Press Return > I/O Setup > Gate Control > Gate Off On to Off.

12.Press Return > Polarity Setup > Clock Polarity Pos Neg to Neg > Data Polarity Pos Neg to Pos.

13.Press Return > Return > Configure Trigger > Cycle Count 0 > Enter.

14.Press Bit Delay Off On to Off > BERT Trigger to Trigger Key.

15.Press the Trigger hardkey. Figure 12-18 shows the signal generator’s front-panel display after 
completion of the these steps. 
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Figure 12-18  Configuration Using Custom Digital Modulation

BERT Verification

1. Press BERT Trigger to Immediate.

Notice the cycle counter updating in the lower left-hand corner of the signal generator 
display. 

2. Disconnect the cable connecting the DATA OUT to BER DATA IN connectors. 

Notice the No Data annunciator in the lower left corner of the display and the BER result is 
approximately 50%. The Error Bits counter updates the error bit count. Re-establishing the 
connection turns the annunciator off, and sets the error bits count to 0 bits and BER 
0.00000000%. 

3. Disconnect the cable connecting the DATA CLK OUT to BER CLK IN connectors. 

Notice the No Clock annunciator in the lower left corner of the display. This annunciator 
turns off when you re-connect the cable, but the error bits counter and BER % readings 
indicate loss of synchronization. 

4. Press Return. 

Toggle the BERT Off On softkey to Off and to On. You will see the new BER result as shown in 
the previous front-panel display with the Error Bits counter reading 0 Bits and BER 
0.00000000%.

If the verification procedures produce the expected results, then the signal generator BERT 
measurement function is operating correctly. If the above procedure produces unexpected results, 
then contact the Keysight Service Center. For a list of Keysight Service Centers, refer to the 
X-Series Signal Generators Getting Started Guide.
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Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in 
that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option N5180403B. 
Option N5180431B requires Option 653, 655, 656 or 657.

This chapter contains examples of using the additive white gaussian noise (AWGN) waveform 
generator.

— Adding Real–Time Noise to a Dual ARB Waveform on page 364

— Using Real Time I/Q Baseband AWGN on page 370

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.
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Adding Real–Time Noise to a Dual ARB Waveform

A vector signal generator with Option N5180403B enables you to apply additive white gaussian 
noise (AWGN) to a carrier in real time while the modulating waveform plays in the dual ARB 
waveform player. This feature appears in each of the arb formats and as a stand–alone menu (Refer 
to Figure 13-7 on page 370).

The procedures in this section that pertain specifically to adding Real–
Time Noise (AWGN) to a waveform, are applicable to the Custom ARB, 
Multitone, and Two–Tone modulation standards too.
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Adding Real–Time Noise to a Dual ARB Waveform

Figure 13-1 Real Time I/Q Baseband AWGN Softkeys

see page 366

For details on each key, use key help 
as described on page 60.

The state of the noise (on or off) 
is shown on the display.

Figure 13-6 on page 368 
provides additional details on 
these settings.

This is the stand–alone Real–
Time AWGN and the 2nd page of 
the Modulation Mode menu (see 

Static graphic representation of 
ARB Real–Noise AWGN (i.e. 
graphic does not update as 
values change).

The relationship of the values are displayed in the 
static graphic of ARB Real–Time AWGN.
The Total Noise Power is the Noise Power over the 
occupied noise bandwidth (NBW * 1.25). 

see page 366

see page 366

For the selected carrier to noise ratio, 
the bandwidth over which the noise is 
integrated. Typically, Carrier 
Bandwidth (CBW) is the occupied 
bandwidth of the carrier.

Flat Noise Bandwidth (NBW): The 
actual flat noise bandwidth (NBW), 
which should be slightly wider than 
the carrier bandwidth (typically 1.6 
times wider). The occupied 
bandwidth is =  
(1.25 * the Flat Noise Bandwidth)

see page 367

The Carrier Bit Rate softkey sets the 
carrier bit rate. (The default carrier bit 
rate is 1 bps.)

The Carrier Bit Rate softkey is only 
available when the Carrier to Noise 
Ratio Format Softkey is set to Eb/No. 
See also page 368.
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Figure 13-2 Real Time I/Q Baseband AWGN - Power Control Mode Softkeys
For details on each key, use key help 
as described on page 60.

Mode > Dual ARB > Arb Setup >
Real-Time AWGN Setup

Selecting Total as the power 
control mode makes the total 
power and C/N independent 
variables while making the 
carrier power and total noise 
power dependent variables. The 
dependent variables carrier 
power and total noise power are 
set by the total power, C/N, and 
the rest of the Noise settings. 
The carrier power and total 
noise power change as any 
noise parameter is adjusted to 
keep the total power and the 
C/N at their last specified 
values.

Selecting Carrier as the power 
control mode makes the carrier 
power and C/N independent 
variables while making the total 
power and total noise power 
dependent variables. The 
dependent variables total power 
and total noise power are set by 
the carrier power, C/N, and the 
rest of the Noise settings. The 
total power and total noise 
power change as any noise 
parameter is adjusted to keep 
the carrier power and the C/N at 
their last specified values.

Selecting Total Noise as the 
power control mode makes the 
total noise power and C/N 
independent variables while 
making the total power and 
carrier power dependent 
variables. The dependent 
variables total power and carrier 
power are set by the total noise 
power, C/N, and the rest of the 
Noise settings. The total power 
and carrier power change as 
any noise parameter is adjusted 
to keep the total noise power 
and the C/N at their last 
specified values.

Figure 13-6 on page 368 
provides additional details on 
these settings.

see page 367
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Figure 13-3 Real Time I/Q Baseband AWGN - Noise Mux Menu Softkeys

Eb/No Adjustment Softkeys for Real Time I/Q Baseband AWGN

This feature allows the AWGN C/N to be set using the Eb/No (energy per bit over noise power 
density at the receiver or signal to noise ratio per bit) form. This requires the carrier bit rate to be 
known. Refer to Figure 13-4, “Eb/No Carrier Bit Equation.”

Figure 13-4 Eb/No Carrier Bit Equation

For details on each key, use key help 
as described on page 60.

Mode > Dual ARB > Arb Setup >
Real-Time AWGN Setup > More

Enables diagnostic control of 
additive noise, so that only the 
noise, only the carrier, or the 
sum of both the noise and the 
carrier are output from the 
internal baseband generator. 
With the ALC off, this feature 
enables direct measurement of 
the carrier or the noise 
contributions independently 
from the total power. The system 
still behaves as if both the noise 
and the carrier are present on 
the output when it comes to 
determining the Auto Modulation 
Attenuation and the RMS level 
for RMS Power Search.

Figure 13-6 on page 368 
provides additional details on 
these settings.

The Carrier Bit 
Rate softkey is 
only available 
when the Carrier 
to Noise softkey 
is set to Eb/No.

C
N Bd
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Figure 13-5 Real Time I/Q Baseband AWGN - Eb/N0 Adjustment Softkeys

Figure 13-6 Carrier to Noise Ratio Components

Example

Use the following steps to modulate a 1 GHz, –10 dBm carrier with the factory–supplied waveform 
SINE_TEST_WFM, and then apply noise with a 45 MHz bandwidth signal that has a 30 dB carrier–
to–noise ratio across a 40 MHz carrier bandwidth.

1. Preset the signal generator and set the following:

For details on each key, use key help 
as described on page 60.

Mode > Dual ARB > Arb Setup > Real-Time AWGN Setup

Selects either the Carrier to 
Noise Ratio (C/N) or energy per 
bit over noise power density at 
the receiver (Eb/No) as the 
variable controlling the ratio of 
the carrier power to noise power 
in the carrier bandwidth. When 
Eb/No is selected, the second 
page of the AWGN Setup menu 
shows the Carrier Bit Rate 
softkey to enable the Eb/No 
value to be calculated.

Figure 13-6 on page 368 
provides additional details on 
these settings.

C/N selected

Eb/No selected

Whether a softkey is available 
depends on the Carrier to 
Noise Ratio Format softkey 
setting (e.g. C/N or Eb/No). 

The Carrier Bit Rate softkey sets the 
carrier bit rate. (The default carrier bit 
rate is 1 bps.)

The Carrier Bit Rate softkey is only 
available when the Carrier to Noise 
Ratio Format Softkey is set to Eb/No.

To view the carrier bit rate equation, 
refer to page 60.

Eb/No is displayed when Carrier to Noise Ratio 
Format softkey is set to Eb/No.

The active 
softkey changes 
with the Carrier to 
Noise Ratio 
Format selected 
(C/N or Eb/No). 
See below.

Display remains grayed out until 
real-time AWGN is enabled.
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—Frequency: 1 GHz
—Amplitude: –10 dBm
—RF output: on

2. Select the factory–supplied waveform SINE_TEST_WFM:

a. Press Mode > Dual ARB > Select Waveform.
b. Highlight SINE_TEST_WFM and press Select Waveform.

3. Turn on the dual ARB player: press ARB Off On to highlight On.

4. Set the ARB sample clock to 50 MHz: Press ARB Setup > ARB Sample Clock > 50 > MHz.

5. Press Real–Time AWGN Setup and set the following:

—Carrier to Noise Ratio: 30 dB
—Carrier Bandwidth: 40 MHz
—Noise Bandwidth: 45 MHz
—Real–time AWGN: on

The signal generator’s displayed power level (–10 dBm) includes the noise power.

Carrier BW 
    (CBW)

RMS  
(total carrier power)

C

Carrier BW 
     (CBW)

Carrier

Noise N

Noise BW 
(NBW) = 
flat noise 
bandwidth

The carrier now appears 
larger because of the 
added noise power.

Carrier Bandwidth (CBW) is typically the occupied 
bandwidth of the carrier and the Noise Bandwidth is the 
flat noise bandwidth (NBW).
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Using Real Time I/Q Baseband AWGN

Figure 13-7 Real Time I/Q Baseband AWGN Softkeys

Use the following steps to apply 10 MHz bandwidth noise to a 500 MHz, –10 dBm carrier.

1. Configure the noise:

a.Preset the signal generator.

b.Press Mode > More > Real-Time AWGN

c.Press Bandwidth > 10 > MHz.

2. Generate the noise:

Press Real-Time AWGN Off On until On highlights.

During generation, the AWGN and I/Q 
annunciators activate (as shown at 
right). AWGN is now available to 
modulate the RF carrier.

3. Configure the RF output:

—Frequency: 500 MHz

—Amplitude: −10 dBm

—RF output: on

The carrier with AWGN is now available at the signal generator’s RF OUTPUT connector.

For details on each key, use key help 
as described on page 60.
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(Option N5180432B)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in 
that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option N5180431B. 
Option N5180431B requires Option 653, 655, 656 or 657.

This chapter contains the softkey maps to locate the Phase Noise Impairment option functions and 
information on the use of this feature.

— Real–Time Phase Noise Impairment on page 372

— Phase Noise Shape and Additive Phase Noise Impairments on page 373

— Understanding the Phase Noise Adjustments on page 375

— DAC Over–Range Conditions and Scaling on page 376

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.
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Real–Time Phase Noise Impairment
This feature lets you degrade the phase noise performance of the signal generator by controlling 
two frequency points and an amplitude value. The signal generator adds this phase noise to the 
phase noise normally produced by the signal generator. This feature appears in each of the arb 
formats and as a stand–alone menu. While the following figure shows how to access the controls 
using both the stand–alone menu and the Dual ARB player, the location and softkeys within each 
arb format is the same as for the Dual ARB player.

Figure 14-1 Stand–Alone and Dual ARB Player Real–Time Phase Noise Softkeys

The end frequency for the flat 
mid–frequency characteristics.

The start frequency for the flat 
mid–frequency characteristics.

For details on each key, use key help 
as described on page 60. 

The display updates even 
when the feature is off.

For an explanation on these 
settings see
“Phase Noise Shape and 
Additive Phase Noise 
Impairments” on page 373.

Flat Mid–

This softkey is 
available in all arb 
formats.

The amplitude for the flat mid–
frequency characteristics. 
(Lmid stands for the level 
amplitude of the mid–frequency 
characteristic.)

NOTE: The phase noise impairment is added to the base phase noise of    
             the signal generator.

Stand–alone menu
Use to add phase noise to the 
CW output without having to 
play a waveform.
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Phase Noise Shape and Additive Phase Noise Impairments

Flat mid–frequency offset

−50 dBc/Hz−50 dBc/Hz

Keysight X-Series Phase Noise Plots Without Phase Noise Impairment

The Keysight X-Series vector signal 
generator demonstrates a definitive shape to 
its phase noise plot. The mid–frequency 
offsets are characterized by a leveling 
(flattening) of the phase noise amplitude from 
approximately a 3 kHz offset to 
approximately a 70 kHz offset.

Close in and far out offsets demonstrate 
sloping characteristics (areas before and 
after the mid–frequency offsets).

The signal generator degrades the phase noise by moving the mid–frequency 
characteristics and/or changing its amplitude using the following settings:

Start frequency (f1) of the mid–frequency characteristics

Stop frequency (f2) of the mid–frequency characteristics

Amplitude (Lmid) of the mid–frequency characteristics

f1 f2

Mid–frequency characteristics

−50 dBc/Hz−50 dBc/Hz

Amplitude 
 (Lmid)

This is a plot of the unmodified phase noise 
shape that shows the location that each 
value alters.
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f1
f2

Phase Noise Plots With Phase Noise Impairments

−50 dBc/Hz −50 dBc/Hz

Flat mid–frequency offset 
(Lmid)characteristics

No additive 
phase noise

Resultant phase
noise plot

When turned on, this phase noise is added 
to the base phase noise of the signal 
generator. 
 
Even though it is only the mid–frequency 
characteristics placement that are modified, 
these changes affect the entire phase noise 
shape. The close in and far out offset 
characteristics change by exhibiting 
approximately a 20 dBc/Hz slope for each 
octave of frequency offset.

The resultant phase noise plot shown on 
the left has the following settings:

— f1 = 100 Hz
— f2 = 1 kHz
— Amplitude (Lmid) = –70 dBc

The frequency values entered for the impairments may not be the exact values when 
viewed on the RF output. The entered values are guidelines that the signal generator uses 
to calculate the real values. See “Understanding the Phase Noise Adjustments” on 
page 375 for more information. 
 

−50 dBc/Hz −50 dBc/Hz

Signal generator front panel plot:

— f1 = 100 Hz
— f2 = 1 kHz
— Lmid = –70 dBc

Ensure that the f1 value is less than or 
equal to f2. If not, f2 changes its value to 
match f1. Conversely if f2 is set to a value 
that is less than f1, f1 changes its value to 
match f2.

100 Hz

Flat mid–frequency offset 
(Lmid)characteristics

−20 dBc/Hz 
slope

100 Hz 1 kHz

f1

f2

f2

–70 dBc
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Understanding the Phase Noise Adjustments
The signal generator bases the resultant phase noise shape on three settings, Lmid (amplitude), f1 
(start frequency), and f2 (stop frequency).

The range for Lmid is coupled to f2, so as f2 increases in value, Lmid’s upper boundary decreases. If 
the current Lmid setting is too high for the new f2 setting, the signal generator changes the Lmid 
value and generates an error to alert you to the change. In addition, the actual Lmid value can vary 
by 0.28 dBc/Hz from the entered value.

The frequency settings (f1 and f2) are really guidelines that the signal generator uses to calculate 
the real frequency offset values seen on the RF OUTPUT. This means that the entered start and stop 
frequency values are an approximation and may not be the values seen on a measurement 
instrument, however they will be close. 

The effects of the f1 and f2 parameters are based on a varying logarithmic scale. This scale is 
determined by the f2 value. The higher the f2 value the larger the scale, which makes this behavior 
more noticeable at higher frequency settings. This becomes apparent when a change in the f1 or f2 
value causes little to no change in the f1 or f2 position. This is easy to view using the signal 
generator’s front panel phase noise graph and demonstrated in Figure 14-2. This behavior makes 
the frequency adjustments coarser as the f2 frequency value increases.

Figure 14-2 f1 and f2 Frequency Setting Behavior

The only way to make an accurate determination of the effect of the f1 and f2 values is by viewing 
the front panel graph or making a measurement. You can view the front panel graph remotely by 
using the LXI interface. For more information on the LXI interface, see the Programming Guide.

f1 and f2 softkey settings for the front 
panel phase noise graph. 

f1 did not change frequency until 
12.1 MHz was set. This means that it 
took an increase of 1.6 MHz to change 
its frequency offset.

f2 did not change frequency until 40 
MHz was set. This means that it took an 
increase of 10 MHz to change its 
frequency offset.

f1—original 10.5 MHz 
setting

f1—12.1 MHz setting that 
moved the offset position

f2—original 30 MHz 
setting

f2—40 MHz setting that 
moved the offset position

For details on each key, use key help 
as described on page 60.
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DAC Over–Range Conditions and Scaling
When using phase noise impairment, it is possible to create a DAC over–range condition, which 
causes the signal generator to generate an error. To minimize this condition with the phase noise 
impairment feature, the Keysight X-Series signal generator incorporates an automatic DAC over–
range protection feature that scales down the I/Q data. Because it can scale the data by more than 
what is actually need, it typically decreases the dynamic range of the waveform. This is especially 
noticeable when using a constant amplitude signal such as GSM.

For the Dual ARB Player, the automatic over–range protection can be turned off (on is the factory 
default). The control for the Dual ARB DAC over–range protection feature is located in the key path 
as shown in Figure 14-3.

Figure 14-3 Dual ARB DAC Over–Range Protection Softkey Location

In the Dual ARB Player, to avoid excessive scaling or to just perform scaling manually, turn the 
over–range protection off and use the Waveform Runtime Scaling softkey to eliminate DAC over–
range conditions.

When the automatic feature is disabled, the other options to eliminate a DAC over–range condition 
are to reduce the f2 value, or the Lmid value, or both until the condition corrects itself. 

For details on each key, use key help 
as described on page 60.

When the DAC over–range protection is off, 
eliminate over–range conditions by 
decreasing the scaling value (see “Setting 
Waveform Runtime Scaling” on 
page 258).

Default setting is On. 

Turn off to manually control scaling while 
using the phase noise impairment option. 
Manually adjust the scaling using the 
Waveform Runtime Scaling softkey 
shown above.
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The feature described in this chapter is available only in Keysight N5172B EXG and N5182B MXG 
X-Series signal generators with Option 660 Upgrade Baseband Generator with Real-Time 
Capability.

Option 660 requires Option 653, 655, 656 or 657.

Before using the information in this chapter, you should be familiar with the basic operation of the 
signal generator. If you are not comfortable with functions such as setting the power level and 
frequency, refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the 
information in that chapter.

This chapter contains the softkey maps to locate the Real-Time Fading information for this feature.

— Using Real-Time Fading Softkeys on page 378
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Using Real-Time Fading Softkeys
This feature lets you open a menu to configure Real-Time Fading simulations.

Figure 15-1 Real-Time Fading Softkeys

For details on each key, use key help 
as described on page 60. 

- Sets to Pass-Through Mode; 
route through the Fading path with the Fader 
having only a latency and scale effect.

- Turns on Fading Mode; 
route through the Fading path with 
the Fader in operation.

- Turns off Fading Mode; 
do not route through the 
Fading path.
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To configure a Real-Time Fading simulation

When configuring a Real-Time Fading simulation, perform the following steps:

1. Press Mode

2. Press Fading Mode 
(Default selection is Off.)

3. Select either: Off | On | Pass-Through

— Selecting Off sets the state of the Real-Time Fading simulation to Off; do not route through the 
Fading path. 

— Selecting On sets the state of the Real-Time Fading simulation to On; route through the Fading 
path with the Fader in operation. When Real-Time Fading is On, the FADING annunciator 
appears in the same annunciator position as ALC OFF. See 3. Annunciators on page 27. 

— Selecting Pass-Through sets the state of the Real-Time Fading simulation to Pass-Through; 
route through the Fading path with the Fader having only a latency and scale effect. 

Before Real-Time Fading can be set to On or Pass-Through, a modulation format 
must be selected and Real-Time Custom Modulation must be set to On; if this is 
not done, an Error: -221 Setting Conflict is generated and written to the 
error queue. 

If an error occurs, clear the error queue and turn on a modulation format.

To clear the error queue

1. Press Error

2. Press Clear Error Queue(s).

To turn on a modulation format

1. Press Mode

2. Press Real-Time Custom Modulation

3. Press Modulation Setup > Modulation Type and select a modulation type. 
(Default selection is QPSK.)

4. Press Mode > More > Real-Time Custom Modulation and change the selection 
to On. 
(Default selection is Off.)

5. Press Mode > Fading Mode 
(Default selection is Off.)

6. Select On or Pass-Through
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Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Chapter 3, “Basic Operation”, on page  59 and familiarize yourself with the information in 
that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option N5180431B. 
Option N5180431B requires Option 653, 655, 656 or 657.

— Custom Modulation on page 382

— Creating and Using Bit Files on page 390

— Using Customized Burst Shape Curves on page 395

— Using the Arbitrary Waveform Generator on page 401

— Using Finite Impulse Response (FIR) Filters with Custom Modulation on page 416

— Modifying a FIR Filter Using the FIR Table Editor on page 423

— Differential Encoding on page 426

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.
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Custom Modulation 
For creating custom modulation, the signal generator offers two modes of operation: the ARB 
custom modulation mode and the real-time custom modulation mode. The ARB custom 
modulation mode has built-in modulation formats such as NADC or GSM and pre-defined 
modulation types such as BPSK and 16QAM that can be used to create a signal. It also provides the 
flexibility to modify the digital format’s attributes. The real-time custom modulation mode can be 
used to create custom data formats using built-in PN sequences or custom-user files along with 
various modulation types and different built-in filters such as Gaussian or Nyquist. 

Both modes of operation are used to build complex, digitally modulated signals that simulate 
communication standards with the flexibility to modify existing digital formats, define or create 
digitally modulated signals, and add signal impairments.

ARB Custom Modulation Waveform Generator

The signal generator’s ARB Custom Modulation mode is designed for out–of–channel test 
applications. This mode can be used to generate data formats that simulate random 
communication traffic and can be used as a stimulus for component testing. Other capabilities of 
the ARB Custom Modulation mode include: 

— configuring single or multicarrier signals. Up to 100 carriers can be configured. 

— creating waveform files using the signal generator’s front panel interface.

The waveform files, when created as random data, can be used as a stimulus for component testing 
where device performance such as adjacent channel power (ACP) can be measured. The 
AUTOGEN_WAVEFORM file, that is automatically created when you turn the ARB Custom Modulation 
on, can be renamed and stored in the signal generator’s non–volatile memory. This file can later be 
loaded into volatile memory and played using the dual ARB waveform player. 

For more information, refer to “Waveform File Basics” on page 207 and “Modes of Operation” on 
page 21.

Real-Time Custom Modulation Waveform Generator

The real-time mode simulates single-channel communication using user-defined modulation types 
along with custom FIR filters, and symbol rates. Data can be downloaded from an external source 
into PRAM memory or supplied as real-time data using an external input. The real-time I/Q 
baseband mode can also generate pre-defined data formats such as PN9 or FIX4. A continuous 
data stream generated in this mode can be used for receiver bit error analysis. This mode is limited 
to a single carrier. The real-time custom modulation mode:

— has more data and modulation types available than the ARB waveform generator mode

— supports custom I/Q constellation formats

— has the capability to generate continuous PN sequences for bit error rate testing (BERT)

— needs no waveform build time when signal parameters are changed.
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Custom Modulation

Figure 16-1 ARB Custom Modulation Softkeys

page 384

page 261

page 207

page 413

This softkey changes, 
depending on the selected 
mode of modulation.

Available only when 
Multicarrier is On.

Available only when 
Multicarrier is Off.

page 413

Enables the current ARB custom 
modulation settings.

For details on each key, use key help as described on page 60.

page 239

page 208

page 433

page 387

page 295
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Figure 16-2 Quick Setup Softkeys

page 385

page 416

page 406

Mode > ARB Custom Modulation > Single Carrier Setup

page 386

This softkey label shows the currently 
selected modulation standard.

Press Symbol Rate 
softkey and use 
numeric keypad to 
change value as 
required. 
The default (initial) 
Symbol Rate 
maximum range value 
is dependent upon the 
modulation standard 
selected with the 
Quick Setup softkey.

When one of these pre–defined 
modulation standards is selected, 
default values for components of the 
setup (including filter, symbol rate, and 
modulation type) are automatically 
specified.

For details on each key, use key help as described on page 60.

Default: This softkey selects the 
following default settings:
Modulation Type = QPSK, 
Symbol Rate = 1 Msps, 
Filter = Root Nyquist, and 
Filter Alpha = 0.5
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Custom Modulation

Figure 16-3 Mod Type Softkeys

page 416

page 384

page 386

Mode > ARB Custom Modulation > Single 

page 402

Sets the modulation depth for the 
Amplitude Shift Keying (ASK).

For details on each key, use key help as described on page 60.

These symbol 
maps utilize Gray 
coded bit mapping.

These symbol maps 
are consistent with 
the symbol maps in 
the VSA software.
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Figure 16-4 Custom Modulation Formats and Applications

Figure 16-5 Store Custom Dig Mod State Softkeys

Catalog displays digital modulation 
(DMOD) files that have been previously 
saved.

page 405

Mode > ARB Custom Modulation > Single Carrier Setup > Store Custom Dig Mod State

For details on each key, use key help as described on page 60.
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Custom Modulation

Figure 16-6  Real-Time Custom Modulation Softkeys

page 207

For details on each key, use key help as described on page 60.

page 433
page 388

Opens a menu from 
which you can set burst 
shape parameters.

page 295

page 382

Enables the current 
custom real-time 
modulation settings.

page 426

page 364

page 372

page 239

page 261
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Figure 16-7  Modulation Setup Softkeys

page 389

page 416

Mode > Real-Time Custom Modulation > Modulation Setup

page 391

This softkey label shows 
the currently selected 

Press Symbol Rate 
softkey and use 
numeric keypad to 
change value as 
required. 
The default (initial) 
Symbol Rate 
maximum range value 
is dependent upon the 
modulation standard 
selected with the 
Quick Setup softkey.

When one of these pre–defined modulation 
standards is selected, default values for 
components of the setup (including filter, 
symbol rate, and modulation type) are 
automatically specified.

For details on each key, use key help as described on page 60.
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Custom Modulation

Figure 16-8  Modulation Type Softkeys

page 416

page 388

Mode > Real-Time Custom Modulation 
> Modulation Setup

For details on each key, use key help as described on page 60.

page 390

These symbol maps 
utilize Gray coded 
bit mapping.

These symbol maps 
are consistent with 
the symbol maps in 
the VSA software.

page 407

page 408
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Creating and Using Bit Files
This procedure teaches you how to use the Bit File Editor to create, edit, and store 
user-defined files for data transmission within real time I/Q baseband generated modulation. For 
this example, a user file is defined within a custom digital communications format.

User files (user-defined data files) can be created on a remote computer and moved to the signal 
generator for subsequent modification, or they can be created and modified using the signal 
generator’s Bit File Editor.

These user files can then be transmitted data as a continuous unframed data stream according to 
the protocol of the active format, transmitted as the data for a custom ARB modulation or real-time 
format. User files are not available for signals generated by the dual ARB waveform generator.

Figure 16-9  Data Selection Softkeys

For information on creating user-defined data files on a remote computer, 
see the Keysight Signal Generators Programming Guide.

Mode > Real-Time Custom Modulation > 
Modulation Setup

For details on each key, use key help as described on page 60.

Press this key to select from a 
number of P sequences and 
whether to invert them.

Press this key to select data 
patterns of 1s and 0s.

Press this key to create, select, 
and edit files to use as the bit 
pattern.

Press this key to select a Pattern 
RAM (PRAM) file. 
PRAM files are binary arrays in byte 
format. Each byte consists of a data 
bit (LSB/bit 0), a burst bit (bit 2), and 
an Event 1 output bit (bit 6). The 
PRAM internal format consists of 4 
bytes for each PRAM byte.
PRAM files are useful for specifying 
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Creating a User File

Accessing the Table Editor

1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Data > User File > Create 
File.

This opens the Bit File Editor. The Bit File Editor contains three columns: Offset, 
Binary Data, and Hex Data, as well as cursor position (Position) and file name (Name) 
indicators, as shown in the following figure.

 

Figure 16-10  Bit File Display

Entering Bit Values

Bit data is entered into the table editor in 1-bit format. The current hexadecimal value of the binary 
data is shown in the Hex Data column, and the cursor position (in hexadecimal) is shown in the 
Position indicator.

1. Refer to the following figure.

2. Enter the 32 bit values shown.

When you create new file, the default name appears as UNTITLED, or 
UNTITLED1, and so forth. This prevents overwriting previous files.

Offset 
(in 
Hex)

Bit Data Cursor Position 
Indicator (in Hex)

Hexadecimal Data File Name 
Indicator
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Figure 16-11  Entering Bit Values

Renaming and Saving a User File

In this example, you learn how to store a user file. If you have not created a user file, complete the 
steps in the previous section, “Creating a User File” on page 391.

1. Press More (1 of 2) > Rename > Editing Keys > Clear Text.

2. Enter a file name (for example, USER1) using the alpha keys and the numeric keypad.

3. Press Enter.

The user file has now been renamed and stored to the Bit memory catalog with the name 
USER1.

Enter these bit 
values

Cursor Position 
Indicator

Hexadecimal 
Data
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Recalling a User File

In this example, you learn how to recall a user-defined data file from the memory catalog. If you 
have not created and stored a user-defined data file, complete the steps in the previous sections, 
“Creating a User File” on page 391 and “Renaming and Saving a User File” on page 392.

1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Data > User File.

3. Highlight the file USER1.

4. Press Edit File.

The Bit File Editor opens the file USER1.

Modifying an Existing User File

In this example, you learn how to modify an existing user-defined data file. If you have not created, 
stored, and recalled a user-defined data file, complete the steps in the previous sections, “Creating 
a User File” on page 391, “Renaming and Saving a User File” on page 392 and “Recalling a User 
File” on page 393.

Navigating the Bit Values

1. Press Return > Goto > 4 > C > Enter.

This moves the cursor to bit position 4C in the table, as shown in the following figure.

Figure 16-12  Navigating the Bit Values

Cursor moves to new 
position

Position indicator 
changes
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Inverting Bit Values

1. Press 1011.

This inverts the bit values that are positioned 4C through 4F. Notice that hex data in this row 
has now changed to 76DB6DB6, as shown in the following figure.

Figure 16-13  Inverting Bit Values

Applying Bit Errors to a User File 

In this example, you learn how to apply bit errors to a user-defined data file. If you have not created 
and stored a user-defined data file, complete the steps in the previous sections, “Creating a User 
File” on page 391 and “Renaming and Saving a User File” on page 392.

1. Press Apply Bit Errors.

2. Press Bit Errors > 5 > Enter.

3. Press Apply Bit Errors.

Notice both Bit Errors softkeys change value as they are linked.

Bits 4C through 4F are 
inverted

Hex Data changed
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Using Customized Burst Shape Curves
You can adjust the shape of the rise time curve and the fall time curve using the Rise Shape and 
Fall Shape editors. Each editor allows you to enter up to 256 values, equidistant in time, to 
define the shape of the curve. The values are then resampled to create the cubic spline that passes 
through all of the sample points.

The Rise Shape and Fall Shape table editors are available for custom real-time I/Q baseband 
generator waveforms.

Understanding Burst Shape

The default burst shape of each format is implemented according to the standards of the format 
selected. You can, however, modify the following aspects of the burst shape:

Rise time  the period of time, specified in symbols or bits, where the burst 
increases from a minimum of −70 dB (0) to full power (1).

Fall time  the period of time, specified in symbols or bits, where the burst 
decreases from full power (1) to a minimum of −70 dB (0).

Rise delay  the period of time, specified in symbols or bits, that the start of 
the burst rise is delayed. Rise delay can be either negative or 
positive. Entering a delay other than zero shifts the full power 
point earlier or later than the beginning of the first useful symbol.

Fall delay  the period of time, specified in symbols or bits, that the start of 
the burst fall is delayed. Fall delay can be either negative or 
positive. Entering a delay other than zero shifts the full power 
point earlier or later than the end of the last useful symbol.

User-defined burst shape  up to 256 user-entered values which define the shape of the 
curve in the specified rise or fall time. The values can vary 
between 0 (no power) and 1 (full power) and are scaled linearly. 
Once specified, the values are resampled as necessary to create 
the cubic spline that passes through all of the sample points.

Burst shape maximum rise and fall time values are affected by the following factors:

— the symbol rate

0

1

Po
w

er Ris Ris Fall Fall 

Time 

User-Def User-Def
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— the modulation type

When the rise and fall delays equal 0, the burst shape is attempting to synchronize the maximum 
burst shape power to the beginning of the first valid symbol and the ending of the last valid symbol 
of the timeslot. The following figure illustrates a bursted signal in an EDGE frame with a rise delay of 
0 and a fall delay of +1 bit.

The signal generator firmware computes optimum burst shape based on the settings you’ve chosen 
for modulation. You can further optimize burst shape by lining up the data portion with the 
modulation. For example, if you’re designing a new modulation scheme, do the following:

— Adjust the modulation and filtering to set the spectrum you want.

— Adjust the burst rise and fall delay and rise and fall time for the timeslots.

If you find that the error vector magnitude (EVM) or adjacent channel power (ACP) increases when 
you turn bursting on, you can adjust the burst shape to assist with troubleshooting.
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Figure 16-14  Burst Shape Softkeys

Creating a User-Defined Burst Shape Curve

Using this procedure, you learn how to enter rise shape sample values and mirror them as fall 
shape values to create a symmetrical burst curve.

This section teaches you how to perform the following tasks:

— “Accessing the Table Editors” on page 397

— “Entering Sample Values” on page 398

Accessing the Table Editors

1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Burst Shape.

3. Press More > Define User Burst Shape > More (1 of 2) > Delete All Rows > Confirm Delete Of 
All Rows.

Mode > Real-Time Custom 
Modulation 

For details on each key, use key help as described on page 60.
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Entering Sample Values

Use the sample values in the following table.

1. Highlight the value (1.000000) for sample 1.

2. Press .4 > Enter.

3. Press .6 > Enter.

4. Enter the remaining values for samples 3 through 6 from the table above.

5. Press Return > Edit Fall Shape > Load Mirror Image of Rise Shape >  
Confirm Load Mirror Image Of Rise Shape.

This changes the fall shape values to a mirror image of the rise shape values, as shown in 
Figure 16-15 on page 398.

Figure 16-15  Mirror Image of Rise Shape

Rise Shape Editor

Sample Value Sample Value

0 0.000000 4 0.830000

1 0.400000 5 0.900000

2 0.600000 6 1.000000

3 0.750000
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Display the Burst Shape

Press Display Burst Shape.

This displays a graphical representation of the waveform’s rise and fall characteristics, as shown in 
Figure 16-16.

Figure 16-16  Burst Shape

To return the burst to the default conditions, press the following keys:

Return > Return > Return > Confirm Exit From Table Without Saving > Restore Default Burst 
Shape.

Storing a User-Defined Burst Shape Curve

1. Press Define User Burst Shape > More (1 of 2) > Load/Store > Store To File.

If there is already a file name from the Catalog of SHAPE Files occupying the active entry 
area, press the following keys:

Editing Keys > Clear Text

2. Enter a file name (for example, NEWBURST) using the alpha keys and the numeric keypad.

The maximum file name length is 23 characters (alphanumeric and special characters).

3. Press Enter.

The contents of the current Rise Shape and Fall Shape table editors are stored to the Catalog 
of SHAPE Files. This burst shape can now be used to customize a modulation or as a basis for a 
new burst shape design.

Recalling a User-Defined Burst Shape Curve

Once a user-defined burst shape file is stored in memory, it can be recalled for use with real-time 
I/Q baseband generated digital modulation.

This example requires a user-defined burst shape file stored in memory. If you have not created and 
stored a user-defined burst shape file, complete the steps in the previous sections, “Creating a 
User-Defined Burst Shape Curve” on page 397 and “Storing a User-Defined Burst Shape Curve” 
on page 399.
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1. Press Preset.

2. Press Mode > Real-Time Custom Modulation > Burst Shape > Burst Shape Type > User File.

3. Highlight the desired burst shape file (for example, NEWBURST).

4. Press Select File.

The selected burst shape file is now applied to the current real time I/Q baseband digital 
modulation state.
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Using the Arbitrary Waveform Generator
This section teaches you how to build dual arbitrary (ARB) waveform files containing custom digital 
modulation for testing component designs. 

Figure 16-17  Adding Custom Modulation to a Waveform

Using Predefined Custom Digital Modulation

This section teaches you how to perform the following tasks:

— Selecting a Predefined EDGE Setup on page 401

— Generating the Waveform on page 401

— Configuring the RF Output on page 401

Selecting a Predefined EDGE Setup

1. Press Preset.

2. In the ARB Custom Modulation menu (page 401), press Single Carrier Setup > Quick Setup > 
EDGE.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the pre–defined EDGE state selected in the step. The display 
changes to Dig Mod Setup: EDGE. During waveform generation, the DIGMOD and I/Q 
annunciators appear and the pre–defined digital modulation state is stored in volatile memory 
(BBG). The waveform is now modulating the RF carrier.

Configuring the RF Output

1. Set the RF output frequency to 891 MHz. 

page 416

page 386

This softkey label updates to reflect the 
current modulation type.

Mode > ARB Custom Modulation > Single Carrier Setup

page 385

page 406

For details on each key, use key help as described on page 60.
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2. Set the output amplitude to −5 dBm. 

3. Press RF On/Off.

The predefined EDGE signal is now available at the signal generator’s RF OUTPUT connector.

Creating a Custom Digital Modulation State

In this procedure, you learn how to set up a single–carrier NADC digital modulation with 
customized modulation type, symbol rate, and filtering.

Figure 16-18  Setting a Digital Modulation Filter

This softkey label updates to reflect the 
current modulation standard.

Mode > ARB Custom Modulation > Single Carrier Setup

page 406

This softkey 
sets the filter 
bandwidth 
parameter, 
alpha. The 
default Alpha 
value changes 
with the 
modulation 
standard (see 
page 416) 
and modulation 
type selected 
(see 
page 385).

For details on each key, use key help as described on page 60.

This softkey sets 
the filter shape. page 403

Opens a menu to select a 
IS-95 filter.
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Figure 16-19  Modifying a Digital Modulation Type

This section teaches you how to perform the following tasks:

— Selecting a Digital Modulation Setup on page 403

— Configuring the RF Output on page 401

— Selecting the Filter on page 404

— Configuring the RF Output on page 401

Selecting a Digital Modulation Setup

1. Press Preset.

2. In the ARB Custom Modulation menu (page 402), press Single Carrier Setup > Quick Setup > 
NADC.

Modifying the Modulation Type and Symbol Rate

1. In the ARB Custom Modulation menu (page 402), press Single Carrier Setup > Modulation 
Type > Select > PSK > QPSK and OQPSK > QPSK.

2. Press Return > Symbol Rate > 56 > ksps.

Note: This is the 
2nd page of the 
PSK menu.

Note: This is the 
2nd page of the 
QPSK menu.

Mode > ARB Custom Modulation > Single Carrier Setup >  
Modulation Type > Select

For details on each key, use key help as described on page 60.

These softkeys, 
open a menu to 
select an 
existing user I/Q 
or user FSK file 
that can be 
selected and 
applied to the 
current 
modulation type.
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Selecting the Filter

1. In the Setup Mod menu (page 402), press Filter > Select > Nyquist.

2. Press Return > Return.

Generating the Waveform

Press Digital Modulation Off On.

This generates a waveform with the custom, single–carrier NADC, digital modulation state created 
in the previous sections. The display changes to Dig Mod Setup: NADC (Modified). During 
waveform generation, the DIGMOD and I/Q annunciators appear and the custom single–carrier 
digital modulation state is stored in volatile memory. The waveform is now modulating the RF 
carrier.

For instructions on storing this custom, single–carrier NADC, digital modulation state to the non–
volatile memory catalog, see Storing a Custom Digital Modulation State on page 404. 

Configuring the RF Output

1. Set the RF output frequency to 835 MHz. 

2. Set the output amplitude to 0 dBm. 

3. Press RF On/Off.

The user–defined NADC signal is now available at the RF OUTPUT connector.

Storing a Custom Digital Modulation State

Using this procedure, you learn how to store a custom digital modulation state and a custom 
multicarrier digital modulation state to non–volatile memory.

If you have not created a custom, single–carrier, digital modulation state, complete the steps in the 
previous section, Creating a Custom Digital Modulation State on page 402.
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Figure 16-20  Storing a Custom Digital Modulation State

1. Return to the top–level ARB Custom Modulation menu, where Digital Modulation Off On is the 
first softkey.

2. In the ARB Custom Modulation menu (page 405), press Single Carrier Setup > Store Custom 
Dig Mod State > Store To File.

If there is already a file name from the Catalog of DMOD Files occupying the active entry 
area, press the following key: Clear Text

3. Enter a file name (for example, NADCQPSK) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters.

4. Press Enter.

The user–defined, single–carrier, digital modulation state is now stored in non–volatile memory.

Recalling a Custom Digital Modulation State

Using this procedure, you will learn how to recall a custom digital modulation state from signal 
non–volatile memory.

The RF output amplitude, frequency, and operating state settings are not stored as part of a user–
defined, digital modulation state file.

Catalog displays DMOD files that have 
been previously saved by the user.

Mode > ARB Custom Modulation > Single 
Carrier Setup

page 61

These keys manage the table 
of DMOD files in internal 
storage.

For details on each key, use key help as described on page 60.
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If you have not created and stored a user-defined, single–carrier, digital modulation 
state, complete the steps in the previous sections, Creating a Custom Digital Modulation State on 
page 402 and Storing a Custom Digital Modulation State on page 404, then preset the signal 
generator to clear the stored user–defined, digital modulation waveform from volatile ARB memory.

Figure 16-21  Recalling a Custom Digital Modulation State

1. In the Quick Setup menu, press Custom Digital Mod State.

2. Highlight the desired file (for example, NADCQPSK).

3. Press Select File > Return.

4. Press Digital Modulation Off On until On is highlighted.

The instrument regenerates the custom, digital modulation waveform in volatile memory. After 
waveform generation, the custom, digital modulation waveform is available to be modulated on the 
RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 401.

Defining a Modulation

You can build a unique modulation by utilizing two tools, the FSK table editor or the I/Q table 
editor. These tables map data onto specific absolute modulation states. To map transitions 
between states, a differential table editor is provided.

Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup

Loads the highlighted file 
into the instrument 

memory.

These keys manage the table 
of DMOD files in internal 

For details on each key, use key 
help as described on page 60.
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Building an Asymmetric FSK Modulation with the FSK Table Editor

You can use the FSK table editor to create customized asymmetric FSK modulation of up to 16 
levels, then apply the custom FSK modulation to one of the modulation standards. An example of 
this capability is to create an interfering signal for adjacent channel selectivity testing of FLEXTM 
pagers. To do this, build a 4-level FSK modulation at 4.8 kHz and 1.6 kHz in the FSK table editor, 
shown in Figure 16-22. Then use this signal to modulate a PN15 data transmission. In the FLEXTM 
protocol, each of the levels in 4-level FSK represents a 2-bit sequence.

Create a Continuous 4-Level FSK Signal

Use this procedure to create a 4-level FSK signal for adjacent channel testing of FLEXTM pagers.

1. Press Preset on the signal generator.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define 
User FSK. 

3. Enter the frequency deviations shown in Figure 16-22 into the FSK table editor.

4. Store the file as 4FSK. Press Load/Store > Store To File > 4FSK > Enter.

5. Load the file. Press Load from Selected File > Confirm Load From File.

6. Turn on Custom Modulation. Press Return > Return > Return > Real-Time Custom On.

7. Set the Frequency to the desired carrier frequency for the adjacent channel.

8. Set the desired Amplitude.

9. Press RF On. The amplitude of the interferer can then be adjusted to measure the performance 
of the device under test.
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Figure 16-22  FSK Table Editor

Mapping I/Q Values with the I/Q Table Editor

In most digital radio systems, the frequency of the carrier is fixed so only phase and magnitude 
need to be considered. The phase and magnitude of symbols can be represented as a discrete point 
in the I/Q plane. I represents "in phase" and Q represents "quadrature".

Figure 16-23  I/Q Constellation Diagram

Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User FSK

For details on each key, use key 
help as described on page 60.
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By modulating the carrier to one of several predetermined positions in the I/Q plane, you can then 
transmit encoded information. Each position or state represents a certain bit pattern that can be 
decoded at the receiver. The mapping of the states at each symbol decision point on the I/Q plane 
is referred to as a constellation diagram. You can create a unique signal by mapping your 
constellation diagram into the I/Q table editor, shown in Figure 16-24. The table editor also has a 
display feature, which provides a quick visual check of the expected I/Q constellation. 

Figure 16-24  I/Q Table Editor

Utilizing this I/Q mapping flexibility, you can create unique modulation schemes. For example, a 
circular constellation arrangement called a STAR QAM is easily implemented and saved for later 
recall with the real-time I/Q baseband generator. Figure 16-25 shows that the STAR QAM has 16 
states or symbols. Four data bits define each symbol. Thus, the diagram and the table are 
equivalents.

Create a STAR QAM Modulation Scheme

1. Press Preset on the signal generator.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define 
User IQ. 

3. Enter the values shown in Figure 16-25 for I and Q using the numeric keypad and arrow keys.  
Press Display IQ Map to check your entry and adjust any entry errors.

4. Press Return > Store To File > Clear Text.

5. Turn on Custom Modulation. Press Return > Return > Return > Real-Time Custom On.

6. Name the file STAR and press Enter.

7. Load the file. Highlight STAR and press Load from Selected File > Confirm Load From File.

8. Turn on Custom Modulation. Press Return > Return > Return > Return > Real-Time Custom On.

9. Set the Frequency and Amplitude to the desired values.

10.Press RF On. 

For details on each key, use key help 
as described on page 60.

Mode > Real-Time Custom Modulation > Modulation Setup > Modulation Type > Define User I/Q
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Figure 16-25  STAR QAM Diagram and Table
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Figure 16-26 shows the X-Series setup and the I/Q display.

Figure 16-26  Custom Modulation and I/Q Display

Hints for Constructing Modulations

— The map is limited to 16 total signal levels for I and Q combined. The readout on the right-hand 
side of the table tracks the number of I and Q levels utilized. Levels are I or Q values. Figure 
16-27 shows an 8PSK signal built in two different ways. The 8PSK signal in Figure 16-27 utilizes 
five of the available sixteen I/Q values on the left, and utilizes four of the available sixteen I/Q 
values on the right.

— Following this example, the real-time I/Q baseband generator supports a symmetric 256QAM 
constellation but not an asymmetric 256QAM constellation, since the asymmetry requires more 
than sixteen I/Q values.

— The levels do not have to be equally spaced or symmetric in the I/Q plane. For example, the 
16QAM modulations shown in Figure 16-28 are both possible.

Figure 16-27  8PSK Signal Built Two Ways
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Figure 16-28  16QAM I/Q Map with Even and Uneven Levels
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Creating a Custom Multicarrier Digital Modulation State

In this procedure, you learn how to customize a predefined, multicarrier, digital modulation setup 
by creating a custom, 3–carrier EDGE, digital modulation state.

This section teaches you how to perform the following tasks:

— Creating a Multicarrier Digital Modulation Setup on page 414

— Modifying Carrier Frequency Offset on page 414

— Modifying Carrier Power on page 414

— Generating the Waveform on page 414

— Configuring the RF Output on page 414

Figure 16-29  Creating a Multicarrier Digital Modulation Setup

Mode > ARB Custom Modulation

Becomes active when a change 
has been made to the 
Multicarrier Setup table values 
or to the multicarrier menu 
values (i.e. Carrier Setup, # of 
Carriers, Freq Spacing, or to the 
Carrier Phases).

For details on each key, use key help as described on page 60.
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Creating a Multicarrier Digital Modulation Setup

1. Press Preset.

2. Press Mode > ARB Custom Modulation > Multicarrier Off On to On.

3. Press Multicarrier Setup > Select Carrier and Initialize Table > Carrier Setup > EDGE > Done.

Modifying Carrier Frequency Offset

1. Highlight the Freq Offset value (500.000 kHz) for the carrier in row 2.

2. Press –625 > kHz.

Modifying Carrier Power

1. Highlight the Power value (0.00 dB) for the carrier in row 2.

2. Press –10 > dB.

You now have a custom 2–carrier EDGE waveform with a carrier at a frequency offset of 

–625 kHz and a power level of –10.00 dBm, as shown in the following figure.

Generating the Waveform

Press Return > Digital Modulation Off On.

This generates a waveform with the custom, multicarrier, EDGE state created in the previous 
sections. The display changes to Dig Mod Setup: Multicarrier (Modified). During 
waveform generation, the DIGMOD and I/Q annunciators appear and the new custom, multicarrier, 
EDGE state is stored in volatile memory. The waveform is now modulating the RF carrier.

For instructions on storing this custom, multicarrier, EDGE state to non–volatile memory, see 
“Storing a Custom Multicarrier Digital Modulation State” on page 415. 

Configuring the RF Output

1. Set the RF output frequency to 890.01 MHz. 

2. Set the output amplitude to −10 dBm. 

3. Press RF On/Off.

The custom multicarrier EDGE signal is now available at the RF OUTPUT connector.

If Digital Modulation is already on, you 
must press Apply Multicarrier to apply 
the changes and generate a new 
custom multicarrier digital modulation 
waveform based on the updated 
values.

For details on each key, use key help 
as described on page 60.



Keysight CXG, EXG, and MXG X-Series Signal Generators User’s Guide                                                         415

Custom Digital Modulation (Option N5180431B)

Using the Arbitrary Waveform Generator

Storing a Custom Multicarrier Digital Modulation State

Using this procedure, you learn how to store a custom, multicarrier, digital modulation state to 
non–volatile memory.

If you have not created a custom, multicarrier, digital modulation state, complete the steps in the 
previous section, “Creating a Custom Multicarrier Digital Modulation State” on page 413.

Figure 16-30  Storing a Custom Multicarrier Softkeys

1. Return to the top–level Digital Modulation menu, where Digital Modulation Off On is the first 
softkey.

2. Press Multicarrier Setup > More > Load/ Store > Store To File.

If there is already a file name from the Catalog of MDMOD Files occupying the active entry 
area, press the following key: Clear Text

3. Enter a file name (for example, EDGEM1) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters.

4. Press Enter.

The user–defined, multicarrier, digital modulation state is now stored in non–volatile memory.

Applying Changes to an Active Multicarrier Digital Modulation State

If the digital modulation format is currently in use (Digital Modulation Off On set to On) while 
changes are made in the Multicarrier Setup table editor, you must apply the changes before 
the updated waveform will be generated.

From the Multicarrier Setup table editor, press Apply Multicarrier to apply the changes and 
generate a new custom multicarrier digital modulation waveform based on the updated values.

The RF output amplitude, frequency, and operating state settings are not stored as part of a user–
defined, digital modulation state file.

page 61

Fixed: All the carriers are set to a 
phase of 0.
Random: All of the carriers are 
set to a random phase value.

For details on each key, use key help as 
described on page 60.
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Using Finite Impulse Response (FIR) Filters with Custom Modulation 
Finite Impulse Response filters can be used to refine the transitions between symbol decision points 
of the generated waveforms. 

Figure 16-31      Filter Menu

Understanding FIR Filters 

FIR filters are used to limit the bandwidth of the input to the I and Q modulators. Several different 
types of FIR filters exist. The NADC, PDC, PHS, and TETRA standards specify a root Nyquist filter in 
both the transmitter and the receiver. The combined response is equivalent to a Nyquist filter. The 
Nyquist filter has an impulse response that rings at the data clock rate so nulls appear at all symbol 
decision points except the desired one at the center of the impulse response. Since each symbol 
causes zero response at all undesired decision points, there can be no inter-symbol interference 
(ISI). The alpha term (a) defined for Nyquist-type filters identifies the frequency cutoff point were 
the filter response is zero. The closer the alpha term is to zero, the steeper the filter roll-off 
becomes. Alpha gives a direct measure of the occupied bandwidth of the system and is calculated 
as

Occupied Bandwidth = Symbol Rate x (1 + α)

Mode > ARB Custom Modulation > Single Carrier Setup > Filter

This replaces the current 
FIR filter with the factory 
installed default filter 
settings for the current 
modulation type.

This softkey changes, depending 

on the selected filter–type.

Available only when the filter selected =
Root Nyquist or Nyquist

Available only when the filter 
selected = Gaussian

page 423Only applies to Dual ARB 
Modulation. Refer to 
page 205.

For details on each key, use key help as described on page 60.

Opens the IS–95 
filter selection 
menu.

page 418
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The NADC and TETRA standards specify an alpha of 0.35. PDC and PHS standards specify an alpha 
of 0.50. For each of these standards, the Keysight X-Series signal generator provides a root Nyquist 
filter with the designated alphas as the default premodulation filter. Figure 16-32 shows the 
Nyquist impulse response for several values of alpha.

Notice that the half-amplitude point is always at the half-symbol rate. Since all of the information 
is contained within the half symbol rate bandwidth, alpha is a measure of the additional occupied 
bandwidth.

Another type of FIR filter, which is specified in the GSM and DECT standards, is the Gaussian filter. 
Gaussian filters typically have more inter-symbol interference than Nyquist filters, but their 
adjacent channel power performance is better for constant-amplitude modes like MSK, where 
Nyquist filtering of I and Q is not possible. The bandwidth bit time (BbT) product (similar to α) is 
defined by the GSM standard as 0.30 and by the DECT standard as 0.50. For each of these 
standards, the Keysight X-Series signal generator provides a Gaussian filter with the designated 
BbT product as the default premodulation filter.

Figure 16-32  Nyquist Filter Impulse Response

Selecting a Filter and the Alpha (α) or Bandwidth Bit Time (Bbt) Product

Due to individual system design requirements, you may decide to change the filter or the filter α or 
BbT. You can adjust the alpha from 0 to 1 and the BbT from 0.1 to 1.

To change the filter alpha:

1. Preset the instrument.

2. Press Mode > Real-Time Custom Modulation > Modulation Setup > Filter > Select Nyquist > 
Filter Alpha.

3. Enter a new value between 0 and 1. Press Enter.

4. To restore the default filter values, press Restore Default Filter.
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Creating a User–Defined FIR Filter Using the FIR Table Editor

In this procedure, you use the FIR Values table editor to create and store an 8–symbol, windowed 
sync function filter with an oversample ratio of 4.

Accessing the Table Editor

1. Press Preset.

2. Press Mode > ARB Custom Modulation > Single Carrier Setup > Filter > Select > Nyquist.

3. Press Filter > Define User FIR. 

4. Press More 2 of 2 > Delete All Rows > Confirm Delete of All Rows. 

This will initialize the table editor as shown in Figure 16-33.

Figure 16-33  Creating a User–Defined FIR Filter Using the FIR Filter Table Editor

Entering the Coefficient Values

1. Press the Return softkey to get to the first page of the table editor. 

2. Use the cursor to highlight the Value field for coefficient 0. 

To change the filter Bbt, press Mode > Real-Time Custom Modulation > 
Modulation Setup > Filter > Select Gaussian > Filter Bbt.

Enter a new value between 0.1 and 1.

Mode > ARB Custom Modulation> Single Carrier Setup > Filter > 
Define User FIR > More > Delete All Rows > Confirm Delete of All 

Opens a menu that 
enables you to select 
and load a saved file 
into volatile memory. 

page 275

Active only when:
FIR filter coefficient table 
has minimum of two 
values visible.

For details on each key, use key help as described on page 60.

Note:
Modulation filters are typically real and have an oversample ratio (OSR) of two or greater.
Equalization filters are typically complex and have an oversample ratio (OSR) of one (Dual ARB only).
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3. Use the numeric keypad to type the first value (−0.000076) from Table 16-1. As you press the 
numeric keys, the numbers are displayed in the active entry area. (If you make a mistake, you 
can correct it using the backspace key.)

4. Continue entering the coefficient values from the table in step 1 until all 16 values have been 
entered.

Table 16-1 

Coefficient Value Coefficient Value

0 −0.000076 8 −0.035667

1 −0.001747 9 −0.116753

2 −0.005144 10 −0.157348

3 −0.004424 11 −0.088484

4 0.007745 12 0.123414

5 0.029610 13 0.442748

6 0.043940 14 0.767329

7 0.025852 15 0.972149
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Duplicating the First 16 Coefficients Using Mirror Table

In a windowed sinc function filter, the second half of the coefficients are identical to the first half in 
reverse order. The signal generator provides a mirror table function that automatically duplicates 
the existing coefficient values in the reverse order.

1. Press Mirror Table. The last 16 coefficients (16 through 31) are automatically generated and 
the first of these coefficients (number 16) highlights, as shown in Figure 16-34 on page 420. 

Figure 16-34 

Setting the Oversample Ratio

The oversample ratio (OSR) is the number of filter coefficients per symbol. Acceptable values range 
from 1 through 32; the maximum combination of symbols and oversampling ratio allowed by the 
table editor is 1024. The instrument hardware, however, is actually limited to 32 symbols, an 
oversample ratio between 4 and 16, and 512 coefficients. So if you enter more than 32 symbols or 
512 coefficients, the instrument is unable to use the filter. If the oversample ratio is different from 
the internal, optimally selected one, then the filter is automatically resampled to an optimal 
oversample ratio.

For this example, the desired OSR is 4, which is the default, so no action is necessary.

Displaying a Graphical Representation of the Filter

The signal generator has the capability of graphically displaying the filter in both time and 
frequency dimensions.

1. Press More > Display Filter > Display FFT (fast Fourier transform). 

Refer to Figure 16-35 on page 421.

Modulation filters must be real and have an oversample ratio (OSR) of two 
or greater.

FIR table coefficient values, 
may be from the factory 
default values or entered by 
the user.

Use the Goto Row menu 
to move around and 
make changes to the FIR 
Values coefficient table.

For details on each key, use key help as described on page 60.
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Figure 16-35 

2. Press Return.

3. Press Display Impulse Response. 

Refer to Figure 16-36.

Figure 16-36 

4.  Press Return to return to the menu keys.

Storing the Filter to Memory

 Use the following steps to store the file.

1. Press Load/Store > Store To File. The catalog of FIR files appears along with the amount of 
memory available.

2. As described in Storing, Loading, and Playing a Waveform Segment on page 209, name and 
store this file as FIR_1.

The FIR_1 file is the first file name listed. (If you have previously stored other FIR files, additional file 
names are listed below FIR_1.) The file type is FIR and the size of the file is 260 bytes. The amount 
of memory used is also displayed. The number of files that can be saved depends on the size of the 
files and the amount of memory used. Refer to Figure 16-37.

For details on each key, use key 
help as described on page 60.

For details on each key, use key 
help as described on page 60.
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Figure 16-37 

Memory is also shared by instrument state files and list sweep files.

This filter can now be used to customize a modulation format or it can be used as a basis for a new 
filter design.

Catalog displays FIR files that have 
been previously saved by the user.

These keys manage the table of DMOD 
files in internal storage.

For details on each key, use key help as described on page 60.
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Modifying a FIR Filter Using the FIR Table Editor
FIR filters stored in signal generator memory can easily be modified using the FIR table editor. You 
can load the FIR table editor with coefficient values from user–defined FIR files stored in non–
volatile memory or from one of the default FIR filters. Then you can modify the values and store the 
new files. 

Loading the Default Gaussian FIR File

Figure 16-38  Loading the Default Gaussian FIR File

1. Press Preset.

2. Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup > NADC.

3. Press Filter > Define User FIR > More 1 of 2 > Load Default FIR > Gaussian.

4. Press Filter BbT > 0.300 > Enter.

Mode > ARB Custom Modulation > Single Carrier 
Setup

These 
softkeys 
select a 

For details on each key, use key help as described on page 60.
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5. Press Filter Symbols > 8 > Enter.

6. Press Generate. 

7. Press Display Filter > Display Impulse Response (refer to Figure 16-39).

Figure 16-39  Impulse Response Display

8. Press Return.

Modifying the Coefficients

1. Using the front panel arrow keys, highlight coefficient 15.

2. Press 0 > Enter.

3. Press Display Impulse Response.

Figure 16-40  Impulse Response Display with Modified Coefficients

Refer to Figure 16-40 on page 424. The graphic display can provide a useful troubleshooting 
tool (in this case, it indicates that a coefficient value is missing, resulting in an improper 
Gaussian response).

4. Press Return.

The actual oversample ratio during modulation is automatically selected 
by the instrument. A value between 4 and 16 is chosen dependent on the 
symbol rate, the number of bits per symbol of the modulation type, and 
the number of symbols.

For details on each key, use key 
help as described on page 60.

For details on each key, use key 
help as described on page 60.
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5. Highlight coefficient 15. 

6. Press 1 > Enter. 

Storing the Filter to Memory

The maximum file name length is 23 characters (alphanumeric and special characters).

1. Press Return > Load/Store > Store To File. 

2. Name the file NEWFIR2.

3. Press Enter. 

The contents of the current FIR table editor are stored to a file in non–volatile memory and the 
catalog of FIR files is updated to show the new file. 
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Differential Encoding
Differential encoding is a digital–encoding technique whereby a binary value is denoted by a signal 
change rather than a particular signal state. Using differential encoding, binary data in any user–
defined I/Q or FSK modulation can be encoded during the modulation process via symbol table 
offsets defined in the Differential State Map.

For example, consider the signal generator’s default 4QAM I/Q modulation. With a user–defined 
modulation based on the default 4QAM template, the I/Q Values table editor contains data that 
represent four symbols (00, 01, 10, and 11) mapped into the I/Q plane using two distinct values, 
1.000000 and –1.000000. The following illustration shows the 4QAM modulation in the I/Q 
Values table editor.

The following illustration shows a 4QAM modulation I/Q State Map.

Differential encoding employs relative offsets between the states in the symbol table to encode 
user–defined modulation schemes. The Differential State Map table editor is used to 
introduce symbol table offset values which in turn cause transitions through the I/Q State Map 
based on their associated data value. Whenever a data value is modulated, the offset value stored 
in the Differential State Map is used to encode the data by transitioning through the I/Q State Map 
in a direction and distance defined by the symbol table offset value.

1st Symbol

Distinct values: +1, +1
Data = 00000000

2nd Symbol

Distinct values: –1, +1
Data = 00000001

4th Symbol

Distinct values: +1, –1
Data = 00000011

3rd Symbol

Distinct values: –1, –1
Data = 00000010

12

3 4
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Entering a value of +1 will cause a 1–state forward transition through the I/Q State Map, as shown 
in the following illustration. 

As an example, consider the following data/symbol table offset values.

The following I/Q State Map illustrations show all of the possible state 
transitions using a particular symbol table offset value. The actual state–
to–state transition would depend upon the state in which the modulation 
had started.

Table 16-2 

Data Offset Value

00000000 +1

00000001 –1

00000010 +2

00000011 0

The number of bits per symbol can be expressed using the following 
formula. Because the equation is a ceiling function, if the value of x 
contains a fraction, x is rounded up to the next whole number. 

Where x = bits per symbol, and y = the number of differential states.
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These symbol table offsets will result in one of the transitions, as shown.

Data Value 00000001 

transition 1 state backward
with Symbol Table Offset –1

Data Value 00000010 

transition 2 states forward
with Symbol Table Offset +2

Data Value 00000011 

no transition
with Symbol Table Offset 0

Data Value 00000000 

transition 1 state forward
with Symbol Table Offset +1
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When applied to the user–defined default 4QAM I/Q map, starting from the 1st symbol (data 00), 
the differential encoding transitions for the data stream (in 2–bit symbols) 0011100001 appear in 
the following illustration. 

As you can see from the previous illustration, the 1st and 4th symbols, having the same data value 
(00), produce the same state transition (forward 1 state). In differential encoding, symbol values do 
not define location; they define the direction and distance of a transition through the I/Q State 
Map.

Using Differential Encoding

The signal generator’s Differential State Map table editor enables you to modify the 
differential state map associated with user–defined I/Q and user–defined FSK modulations. In this 
procedure, you create a user–defined I/Q modulation and then configure, activate, and apply 
differential encoding to the user–defined modulation. For more information, see “Differential 
Encoding” on page 426.

Configuring User–Defined I/Q Modulation

1. Press Preset.

2. Perform the following keypress sequence required for your format type.

For Custom ARB Format

Press Mode > ARB Custom Modulation > Single Carrier Setup > Modulation Type > Select > 
More 1 of 2 > Define User I/Q > More > Load Default I/Q Map > QAM > 4QAM.

Or this alternate sequence:

Data Value Symbol Table Offset
00
01
10
11

+1
–1
+2
+0

Data = 0011100001

{{

{ {

{
5th Symbol1st Symbol

3rd Symbol

4th Symbol2nd Symbol

1st 

2nd 

3rd 
5th 4th 
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Press Mode > ARB Custom Modulation > Single Carrier Setup > Quick Setup (desired format) > 
Modulation Type > Select > More > Define User I/Q > More 1 of 2 > Load Default I/Q Map > 
QAM > 4QAM.

This loads a default 4QAM I/Q modulation and displays it in the I/Q table editor.

The default 4QAM I/Q modulation contains data that represent 4 symbols (00, 01, 10, and 11) 
mapped into the I/Q plane using 2 distinct values (1.000000 and −1.000000). These 4 symbols will 
be traversed during the modulation process by the symbol table offset values associated with each 
symbol of data. Refer to Figure 16-41.

Figure 16-41 

Accessing the Differential State Map Table Editor

Press Configure Differential Encoding. 

This opens the Differential State Map table editor, as shown. At this point, you see the data 
for the 1st symbol (00000000) and the cursor prepared to accept an offset value.You are now 
prepared to create a custom differential encoding for the user–defined default 4QAM I/Q 
modulation. Refer to Figure 16-42 on page 430.

Figure 16-42 

Editing the Differential State Map

1. Press 1 > Enter.

Data Symbol Table Offset Values Entry Area
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This encodes the first symbol by adding a symbol table offset of 1. The symbol rotates forward 
through the state map by 1 value when a data value of 0 is modulated.

2. Press +/– > 1 > Enter. 

This encodes the second symbol by adding a symbol table offset of 

-

1. The symbol rotates backward through the state map by 1 value when a data value of 1 is 
modulated.

3. Press 2 > Enter.

This encodes the third symbol by adding a symbol table offset of 2. The symbol rotates 
forward through the state map by 2 values when a data value of 10 is modulated.

4. Press 0 > Enter.

This encodes the fourth symbol by adding a symbol table offset of 0. The symbol does not 
rotate through the state map when a data value of 11 is modulated.

Applying Custom Differential Encoding

Press Return > Differential Encoding Off On. 

This applies the custom differential encoding to a user–defined modulation. 

At this point, the modulation has one bit per symbol. For the first two data 
values (00000000 and 00000001) only the last bits (the 0 and the 1, 
respectively) are significant.

At this point, the modulation has two bits per symbol. For the data values 
00000000, 00000001, 00000010, 00000011, the symbol values are 00, 01, 
10, and 11 respectively.

Notice that (UNSTORED) appears next to Differential State Map on the 
signal generator’s display. Differential state maps are associated with the 
user–defined modulation for which they were created. 

In order to save a custom differential state map, you must store the user–
defined modulation for which it was designed. Otherwise the symbol table 
offset data is purged when you press the Confirm Exit From Table Without 
Saving softkey when exiting from the I/Q or FSK table editor.
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(Option N5180430B)

Before using this information, you should be familiar with the basic operation of the signal 
generator. If you are not comfortable with functions such as setting the power level and frequency, 
refer to Basic Operation on page 59 and familiarize yourself with the information in that chapter.

This feature is available only in Keysight X-Series vector signal generators with Option N5180430B. 
Option N5180430B requires Option 653 or 656.

With firmware version B.01.75 or later, option numbers for software internal to the instrument 
have changed. For more information, see “Enabling an Option” on page  55.
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Creating a Custom Two–Tone Waveform
Using the Two-Tone menu, you can define, and modify user–defined Two–Tone waveforms. Two–
Tone waveforms are generated by the dual arbitrary waveform generator.

The section Using Two–Tone Modulation on page 435 teaches you how to perform the following 
tasks:

— Creating a Two–Tone Waveform on page 436

— Viewing a Two–Tone Waveform on page 436

— Minimizing Carrier Feedthrough on page 437

— Changing the Alignment of a Two–Tone Waveform on page 438

Creating a Custom Multitone Waveform
Using the Multitone Setup table editor, you can define, modify and store user–defined multitone 
waveforms. Multitone waveforms are generated by the dual arbitrary waveform generator.

The Using Multitone Modulation on page 440 teaches you how to perform the following tasks:

— Initializing the Multitone Setup Table Editor on page 440

— Configuring Tone Powers and Tone Phases on page 441

— Removing a Tone on page 441

— Generating the Waveform on page 441

— Configuring the RF Output on page 442
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Using Two–Tone Modulation

In the following sections, this chapter describes the two–tone mode, which is available only in 
Keysight X-Series vector signal generators with Option N5180430B:

— Creating a Two–Tone Waveform on page 436

— Viewing a Two–Tone Waveform on page 436

— Minimizing Carrier Feedthrough on page 437

— Changing the Alignment of a Two–Tone Waveform on page 438

See also: Saving a Waveform’s Settings & Parameters on page 217

Two–Tone Modulation Softkeys

For more information about two–tone waveform characteristics, and the 
two–tone standard, download Application Note 1410 from our website by 
going to http://www.keysight.com and searching for “AN 1410” in Test & 
Measurement. 

Becomes active when a change is made to the Freq 
Separation or Alignment Softkeys. Becomes active when Two Tone is 

turned On.

Active when Two–
Tone enabled.
For softkey usage, 
see page 208.

page 364

For details on each key, use key help as described on page 60.

page 440

page 372

see page 208
(Two–Tone’s Arb Setup is similar to the Dual Arb Setup.) 

Exceptions: 
> No Waveform Runtime Scaling softkey, 
> No Multi–BBG Sync Setup softkey, and 
> No DAC Over–Range Protection softkey
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Creating a Two–Tone Waveform

This procedure describes how to create a basic, centered, two–tone waveform.

1. Preset the signal generator.

2. Set the signal generator RF output frequency to 6 GHz.

3. Set the signal generator RF output amplitude to –10 dBm.

4. Press Mode > More > Two–Tone > Freq Separation > 10 > MHz.

5. Press Two Tone Off On to On.

6. Turn on the RF output.

The two–tone signal is now available at the signal generator RF OUTPUT connector. Figure 17-1 on 
page 436 shows what the signal generator display should look like after all steps have been 
completed. Notice that the T-TONE, I/Q, annunciators are displayed; the RF ON, MOD ON  are on; 
and the parameter settings for the signal are shown in the status area of the signal generator 
display.

Figure 17-1 

Viewing a Two–Tone Waveform

This procedure describes how to configure the spectrum analyzer to view a two–tone waveform and 
its IMD products. Actual key presses will vary, depending on the model of spectrum analyzer you 
are using.

1. Preset the spectrum analyzer.

2. Set the carrier frequency to 6 GHz.

3. Set the frequency span to 60 MHz.

4. Set the amplitude for a 10 dB scale with a –10 dBm reference. 

5. Adjust the resolution bandwidth to sufficiently reduce the noise floor to expose the IMD 
products. A 9.1 kHz setting was used in our example.

6. Turn on the peak detector.

Mode > Two–Tone

For details on 
each key, use 
key help as 
described on 
page 60.
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7. Set the attenuation to 4 dB, so you’re not overdriving the input mixer on the spectrum 
analyzer. 

You should now see a two–tone waveform with a 6 GHz center carrier frequency that is similar to 
the one shown in Figure 17-2 on page 437. You will also see IMD products at 10 MHz intervals 
above and below the generated tones, and a carrier feedthrough spike at the center frequency with 
carrier feedthrough distortion products at 10 MHz intervals above and below the center carrier 
frequency.

Figure 17-2 

Minimizing Carrier Feedthrough

This procedure describes how to minimize carrier feedthrough and measure the difference in power 
between the tones and their intermodulation distortion products. Before beginning this procedure, 
it is important that a recent I/Q calibration has been performed on the instrument. The procedure 
for performing an I/Q calibration (refer to “I/Q Calibration” on page 270).

This procedure builds upon the previous procedure.

1. On the spectrum analyzer, set the resolution bandwidth for a sweep rate of about  
100 to 200 ms. This will allow you to dynamically view the carrier feedthrough spike as you 
make adjustments.

2. On the signal generator, press I/Q > I/Q Adjustments > I/Q Adjustments Off On to On.

3. Press Internal Baseband Adjustments > I Offset and turn the rotary knob while observing the 
carrier feedthrough with the spectrum analyzer. Changing the I offset in the proper direction 
will reduce the feedthrough level. Adjust the level as low as possible.

4. Press Q Offset and turn the rotary knob to further reduce the carrier feedthrough level.

 

Intermodulation
Distortion

Two–Tone
Channels

Carrier Feedthrough
Distortion

Carrier
Feedthrough

For details on each key, use key help as described on page 60.
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5. Repeat steps 3 and 4 until you have reached the lowest possible carrier feedthrough level.

6. On the spectrum analyzer, return the resolution bandwidth to its previous setting.

7. Turn on waveform averaging.

8. Create a marker and place it on the peak of one of the two tones.

9. Create a delta marker and place it on the peak of the adjacent intermodulation product, which 
should be spaced 10 MHz from the marked tone.

10.Measure the power difference between the tone and its distortion product. 

You should now see a display that is similar to the one shown in Figure 17-3 on page 438. Your 
optimized two–tone signal can now be used to measure the IMD products generated by a device–
under–test. 

Note that carrier feedthrough changes with time and temperature. Therefore, you will need to 
periodically readjust your I and Q offsets to keep your signal optimized.

Figure 17-3 

Changing the Alignment of a Two–Tone Waveform

This procedure describes how to align a two–tone waveform left or right, relative to the center 
carrier frequency. Because the frequency of one of the tones is the same as the carrier frequency, 
this alignment typically hides any carrier feedthrough. However, image frequency interference 
caused by left or right alignment may cause minor distortion of the two–tone signal. This procedure 
builds upon the previous procedure.

1. On the signal generator, press Mode > Two Tone > Alignment Left Cent Right to Left.
2. Press Apply Settings to regenerate the waveform.

 

Main Marker

Delta Marker

Minimized
Carrier
Feedthrough

For details on each 
key, use key help as 
described on 
page 60.
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3. On the spectrum analyzer, temporarily turn off waveform averaging to refresh your view more 
quickly. You should now see a left–aligned two–tone waveform that is similar to the one shown 
in Figure 17-4.

Figure 17-4 

Whenever a change is made to a setting while the two–tone generator is 
operating (Two Tone Off On set to On), you must apply the change by 
pressing the Apply Settings softkey before the updated waveform will be 
generated. When you apply a change, the baseband generator creates a 
two–tone waveform using the new settings and replaces the existing 
waveform in ARB memory.

Carrier
Frequency

Upper Tone
Aligned with

Intermodulation
Distortion

Two–Tone
Channels

Carrier
Frequency

For details on each key, use key help as described on page 60.
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Using Multitone Modulation

Multitone Modulation Softkeys

Initializing the Multitone Setup Table Editor

1. Press Preset.

2. Press Mode > Multitone

3. Press Initialize Table > Number of Tones > 5 > Enter.

4. Press Freq Spacing > 20 > kHz.

page 441

page 440

This softkey is active if changes have been made to 
the current Multitone waveform in the table editor. The 
softkey must be pressed to apply those changes.

page 442

page 442

Active when 
Multitone enabled.
For softkey usage, 
see page 207 page 207

see page 208
(Multitone’s ARB Setup is similar to Dual Arb Setup.) 

Exceptions: 
> No Waveform Runtime Scaling softkey, 
> No Multi–BBG Sync Setup softkey, and 
> No DAC Over–Range Protection softkey

For details on each key, use key help as described on page 60.
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Figure 17-5  

5. Press Done.

You now have a multitone setup with five tones spaced 20 kHz apart. The center tone is placed at 
the carrier frequency, while the other four tones are spaced in 20 kHz increments from the center 
tone.

Configuring Tone Powers and Tone Phases

1. Highlight the value (0 dB) in the Power column for the tone in row 2.

2. Press Edit Table > Edit Item > –4.5 > dB.

3. Highlight the value (0) in the Phase column for the tone in row 2.

4. Press Edit Item > 123 > deg.

Removing a Tone

1. Highlight the value (On) in the State column for the tone in row 4.

2. Press Toggle State.

Generating the Waveform

Press Return > Multitone Off On until On is highlighted.

This generates the multitone waveform with the parameters defined in the previous sections. 
During waveform generation, the M-TONE and I/Q annunciators activate and the multitone 
waveform is stored in volatile ARB memory. The waveform is now modulating the RF carrier.

The Random Seed 
softkey that affects the 
Multitone’s phase values 
is not used in the following 
examples and is shown 
for reference, only.For details on each key, use key help as described on page 60.
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Configuring the RF Output

1. Set the RF output frequency to 100 MHz.

2. Set the output amplitude to 0 dBm. 

3. Press RF On/Off.

The multitone waveform is now available at the signal generator’s RF OUTPUT connector.

Applying Changes to an Active Multitone Signal

If the multitone generator is currently in use (Multitone Off On set to On) while changes are made 
in the Multitone Setup table editor, you must apply the changes before the updated waveform 
will be generated.

From the Multitone Setup table editor, press the following key to apply the changes and 
generate a multitone waveform based on the updated values: Apply Multitone

Storing a Multitone Waveform

In this example, you learn how to store a multitone waveform. If you have not created a multitone 
waveform, complete the steps in the previous section, Creating a Custom Multitone Waveform on 
page 434.

1. Press Load/Store > Store To File.

If there is already a file name from the Catalog of MTONE Files occupying the active entry 
area, press the following keys (see page 61):

Edit Keys > Clear Text

2. Enter a file name (for example, 5TONE) using the alpha keys and the numeric keypad with a 
maximum length of 23 characters (see page 61).

3. Press Enter.

The multitone waveform is now stored in the Catalog of MTONE Files.

The RF output amplitude, frequency, and operating state settings are not 
stored as part of a multitone waveform file. Similarly, the multitone 
settings are not stored as part of the instrument state. Therefore, in most 
cases you should save both the instrument states and the multitone 
settings to be able to restore all of your settings later.
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Recalling a Multitone Waveform

Using this procedure, you learn how to recall a multitone waveform from the signal generator’s 
memory catalog.

If you have not created and stored a multitone waveform, complete the steps in the previous 
sections, Creating a Custom Multitone Waveform on page 434 and Storing a Multitone 
Waveform on page 442, then preset the signal generator to clear the stored multitone waveform 
from volatile ARB memory.

1. Press Mode > Multitone.

2. Press Load/Store.

3. Highlight the desired file (for example, 5TONE).

4. Press Load From Selected File > Confirm Load From File.

5. Press Multitone Off On until On is highlighted.

The firmware generates the multitone waveform in ARB memory. After waveform generation, the 
multitone waveform is available to be modulated on the RF output.

For instruction on configuring the RF output, see Configuring the RF Output on page 442.
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— Display on page 446

— Signal Generator Lock–Up on page 446

— RF Output on page 447

—No RF Output
—Power Supply Shuts Down
—No Modulation at the RF Output
—RF Output Power too Low
—Distortion
—Signal Loss While Working with a Spectrum Analyzer
—Signal Loss While Working with a Mixer

— Sweep on page 451

—Cannot Turn Off Sweep
—Sweep Appears Stalled
—Incorrect List Sweep Dwell Time
—List Sweep Information is Missing from a Recalled Register
—Amplitude Does Not Change in List or Step Sweep

— Internal Media Data Storage on page 452

—Instrument State Saved but the Register is Empty or Contains the Wrong State

— USB Media Data Storage on page 452

—Instrument Recognizes USB Media Connection, but Does Not Display Files

— Preset on page 452

—The Signal Generator Does Not Respond
—Pressing Preset Performs a User Preset

— Error Messages on page 453

— Front Panel Tests on page 454

— Self Test Overview on page 454

— Licenses on page 456

— Contacting Keysight Technologies on page 457

—Returning a Signal Generator to Keysight
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Display

The Display is Too Dark to Read

Brightness may be set to minimum. Use the figure in “Display Settings” on page 45 to locate the 
brightness softkey and adjust the value so that you can see the display.

The Display Turns Black when Using USB Media

Removing the USB media when the instrument begins to use it can cause the screen to go black. 
Cycle instrument power.

Signal Generator Lock–Up

— Ensure that the signal generator is not in remote mode (the R annunciator shows on the display). 
To exit remote mode and unlock the front panel, press Local Cancel/(Esc).

— Ensure that the signal generator is not in local lockout, which prevents front panel operation. For 
information on local lockout, refer to the Programming Guide.

— If a progress bar appears on the signal generator display, an operation is in progress.

— Preset the signal generator.

— Cycle power on the signal generator.
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RF Output

No RF Output

— Check the RF ON/OFF LED (shown on page 23). If it is off, press RF On/Off to turn the output on.

— Ensure that the amplitude is set within the signal generator’s range.

— If the instrument is playing a waveform, ensure that marker polarity and routing settings are 
correct (see “Saving Marker Polarity and Routing Settings” on page 224).

Power Supply Shuts Down

If the power supply does not work, it requires repair or replacement. If you are unable to service the 
instrument, send the signal generator to an Keysight service center for repair (see “Contacting 
Keysight Technologies” on page 457).

No Modulation at the RF Output

Check both the Mod On/Off LED and the <modulation> Off On softkey, and ensure that both are 
on. See also “Modulating the Carrier Signal” on page 74.

For digital modulation on a vector signal generator, ensure that the internal I/Q modulator is on 
(the I/Q annunciator displays).

If using an external modulation source, ensure that the external source is on and that it is operating 
within the signal generator’s specified limits.

RF Output Power too Low

— If the AMPLITUDE area of the display shows the OFFS indicator, eliminate the offset:

Press Amptd > More 1 of 2 > Amptd Offset > 0 > dB. See also “Setting an Output Offset” on 
page 126.

— If the AMPLITUDE area of the display shows the REF indicator, turn off the reference mode:

1.Press Amptd > More > Amptd Ref Off On until Off highlights.

2.Reset the output power to the desired level.

See also “Setting an Output Reference” on page 127.

— If you are using the signal generator with an external mixer, see page 449.

— If you are using the signal generator with a spectrum analyzer, see page 448.

— If pulse modulation is on, turn off the ALC, and check that pulse width is within specifications.

Distortion

If you edit and resave a segment in a waveform sequence, the sequence does not automatically 
update the RMS value stored in it’s header. This can cause distortion on the output signal. Display 
the sequence header information and recalculate the RMS value (see page 217).
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Signal Loss While Working with a Spectrum Analyzer

The effects of reverse power can cause problems with the RF output when you use the signal 
generator with a spectrum analyzer that does not have preselection. Use an unleveled operating 
mode (described on page 122).

A spectrum analyzer can have as much as +5 dBm LO feedthrough at its RF input port at some 
frequencies. If the frequency difference between the LO feedthrough and the RF carrier is less than 
the ALC bandwidth, the LO’s reverse power can amplitude modulate the signal generator’s RF 
output. The rate of the undesired AM equals the difference in frequency between the spectrum 
analyzer’s LO feedthrough and the signal generator’s RF carrier.

Reverse power problems can be solved by using one of the unleveled operating modes. 

See:

— “ALC Off Mode” on page 122

and

— “Power Search Mode” on page 123

To avoid damaging or degrading the performance of the signal generator, 
do not exceed 33 dBm (2W) maximum of reverse power levels at the RF 
input. See also Tips for Preventing Signal Generator Damage on 
www.keysight.com.
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Signal Loss While Working with a Mixer

To fix signal loss at the signal generator’s RF output during low–amplitude coupled operation with 
a mixer, add attenuation and increase the RF output amplitude.

The figure at right shows a 
configuration in which the signal 
generator provides a low 
amplitude signal to a mixer.

The internally leveled signal 
generator RF output (and ALC 
level) is 

–8 dBm. The mixer is driven with 
an LO of +10 dBm and has an LO–
to–RF isolation of 15 dB. The 
resulting 

–5 dBm LO feedthrough enters the 
signal generator’s RF output 
connector and arrives at the internal detector.

Depending on frequency, it is possible for most of this LO feedthrough energy to enter the detector. 
Because the detector responds to its total input power regardless of frequency, this excess energy 
causes the ALC to reduce the RF output. In this example, the reverse power across the detector is 
actually greater than the ALC level, which can result in loss of signal at the RF output.

To avoid damaging or degrading the performance of the signal generator, 
do not exceed 33 dBm (2W) maximum of reverse power levels at the RF 
input. See also Tips for Preventing Signal Generator Damage on 
www.keysight.com.

Mixer

LO 

ALC 
Level = 
−8 dBm

RF 
Level 

Signal Generator
Output Control

Detector 
measures 
−8 dBm 
ALC level

Detector 
measures 
−5 dBm 
reverse 
power

LO 
Feedthru 
= −5 dBm

RF 
Output 
= −8 

LO Level 
= +10 dBm

IF 

Effects of Reverse Power on 
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The solution at right shows a 
similar configuration with the 
addition of a 10 dB attenuator 
connected between the RF output 
of the signal generator and the 
input of the mixer. The signal 
generator’s ALC level increases to 
+2 dBm and transmits through a 
10 dB attenuator to achieve the 
required –8 dBm amplitude at the 
mixer input. 

Compared to the original 
configuration, the ALC level is 10 
dB higher while the attenuator 
reduces the LO feedthrough (and 
the signal generator’s RF output) by 10 dB. Using the attenuated configuration, the detector is 
exposed to a +2 dBm desired signal versus the 

–15 dBm undesired LO feedthrough. This 17 dB difference between desired and undesired energy 
results in a maximum 0.1 dB shift in the signal generator’s RF output level.

Mixer

LO 

ALC Level/ 
RF Output 
= +2 dBm

RF 
Level 

Signal Generator
Output Control

Detector 
measures 
+2 dBm 
ALC level

Detector 
measures 
−15 dBm 
reverse 
power

LO 
Feedthru 
= −5 dBm

RF 
Output 
= −8 

LO Level 
= +10 dBm

IF 

Reverse Power Solution

10 dB 
ATTEN
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Sweep

Sweep

Cannot Turn Off Sweep

Press Sweep > Sweep > Off.

Sweep Appears Stalled

The current status of the sweep is indicated as a shaded rectangle in the progress bar (see 
“Configuring a Swept Output” on page 66). If the sweep appears to stall, check the following:

1. Turn on the sweep with one of the following key sequences:

Sweep > Sweep > Freq 
Sweep > Sweep > Amptd 
Sweep > Sweep > Waveform (vector instruments only)

2. If the sweep is in single mode, press the Single Sweep softkey. 

3. If the sweep trigger (indicated by the Sweep Trigger softkey) is not set to Free Run, set it to 
Free Run to determine if a missing sweep trigger is blocking the sweep.

4. If the point trigger (indicated by the Point Trigger softkey) is not set to Free Run, set it to Free 
Run to determine if a missing point trigger is blocking the sweep.

5. Set the dwell time to one second to determine if the dwell time was set to a value that was too 
slow or too fast to see.

6. Ensure that you set at least two points in the step sweep or list sweep.

Incorrect List Sweep Dwell Time

1. Press Sweep > More > Configure List Sweep.

2. Check that the list sweep dwell values are accurate.

3. If the dwell values are incorrect, edit them. 
If the dwell values are correct, continue to the next step.

4. Press More, and ensure that the Dwell Type List Step softkey is set to List.

If Step is selected, the signal generator sweeps the list points using the dwell time set for step 
sweep rather than list sweep.

See also “Configuring a Swept Output” on page 66.

List Sweep Information is Missing from a Recalled Register

List sweep information is not stored as part of the instrument state in an instrument state register. 
Only the current list sweep is available to the signal generator. You can store list sweep data in the 
instrument catalog (see “Loading (Recalling) a Stored File” on page  81).
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Internal Media Data Storage

Amplitude Does Not Change in List or Step Sweep

Verify that sweep type is set to amplitude (Amptd); the amplitude does not change when the sweep 
type is set to frequency (Freq) or waveform.

Internal Media Data Storage

Instrument State Saved but the Register is Empty or Contains the Wrong 
State

If the register number you intended to use is empty or contains the wrong instrument state, recall 
register 99. If you selected a register number greater than 99, the signal generator automatically 
saves the instrument state in register 99.

See also “Working with Instrument State Files” on page 82.

USB Media Data Storage

Instrument Recognizes USB Media Connection, but Does Not Display Files

If the USB media works on other instruments or computers, it may simply be incompatible with the 
signal generator; try a different USB media. Refer to http://www.keysight.com/find/mxg for 
details on compatible USB media. 

Preset

The Signal Generator Does Not Respond

If the signal generator does not respond to a preset, the instrument may be in remote mode, which 
locks the keypad. 

To exit remote mode and unlock the preset keys, press Local Cancel/(Esc).

Pressing Preset Performs a User Preset

This behavior results from the use of a backward–compatible SCPI command. To return the signal 
generator to normal use, send the command :SYST:PRESet:TYPE NORM. 

For information on SCPI commands, refer to the SCPI Command Reference.
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Troubleshooting

Error Messages

Error Messages

Error Message Types

Events do not generate more than one type of error. For example, an event that generates a query 
error does not generate a device–specific, execution, or command error.

Query Errors (–499 to –400) indicate that the instrument’s output queue control has detected a 
problem with the message exchange protocol described in IEEE 488.2, Chapter 6. Errors in this 
class set the query error bit (bit 2) in the event status register (IEEE 488.2, section 11.5.1). These 
errors correspond to message exchange protocol errors described in IEEE 488.2, 6.5. In this case:

— Either an attempt is being made to read data from the output queue when no output is either 
present or pending, or

— data in the output queue has been lost.

Device Specific Errors (–399 to –300, 201 to 703, and 800 to 810) indicate that a device operation 
did not properly complete, possibly due to an abnormal hardware or firmware condition. These 
codes are also used for self–test response errors. Errors in this class set the device–specific error bit 
(bit 3) in the event status register (IEEE 488.2, section 11.5.1).

The <error_message> string for a positive error is not defined by SCPI. A positive error indicates 
that the instrument detected an error within the GPIB system, within the instrument’s firmware or 
hardware, during the transfer of block data, or during calibration.

Execution Errors (–299 to –200) indicate that an error has been detected by the instrument’s 
execution control block. Errors in this class set the execution error bit (bit 4) in the event status 
register (IEEE 488.2, section 11.5.1). In this case:

— Either a <PROGRAM DATA> element following a header was evaluated by the device as outside 
of its legal input range or is otherwise inconsistent with the device’s capabilities, or

— a valid program message could not be properly executed due to some device condition.

Execution errors are reported after rounding and expression evaluation operations are completed. 
Rounding a numeric data element, for example, is not reported as an execution error.

Command Errors (–199 to –100) indicate that the instrument’s parser detected an IEEE 488.2 
syntax error. Errors in this class set the command error bit (bit 5) in the event status register (IEEE 
488.2, section 11.5.1). In this case:

— Either an IEEE 488.2 syntax error has been detected by the parser (a control–to–device message 
was received that is in violation of the IEEE 488.2 standard. Possible violations include a data 
element that violates device listening formats or whose type is unacceptable to the device.), or

— an unrecognized header was received. These include incorrect device–specific headers and 
incorrect or unimplemented IEEE 488.2 common commands.

Error Message File A complete list of error messages is provided in the Error Messages Guide. In 
the error message file, an explanation is generally included with each error to further clarify its 
meaning. The error messages are listed numerically. In cases where there are multiple listings for 
the same error number, the messages are in alphabetical order.
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Front Panel Tests

Front Panel Tests

Self Test Overview
The self test is a series of internal tests that checks different signal generator functions. The self 
test, is also available by via the remote web interface. For more information on the Web-Enabled 
MXG, refer to the Programming Guide.

Set all display pixels to the selected color. 
To return to normal operation, press any key.

Blink RF On/Off, Mod on/Off, and More LEDs

Correct operation:
Full CCW = 10
Full CW = 10

Displays a keyboard map.  
As you press a key, the map indicates the key 
location.

For details on each key, use key help 
as described on page 60.
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Troubleshooting

Self Test Overview

For details on each key, use key help 
as described on page 60.

Automatically runs diagnostic 
self test. 

Self Test Summary displays 
current status.

Opens a table in which user 
selects specific tests and view 
details in Test Editor display.

Utility > Instrument Info

Displays detailed 
information of highlighted 
test. Refer to page 60

Executes highlighted 
operation.

Executes all selected 
operations.

Selects or deselects 
highlighted operation.

Selects or deselects all 
operations.

Runs a loop of selected 
tests until a failure occurs.

Opens the Go To Menu. 
Adds navigation keys to 
the self test menu.
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Licenses

Licenses

A Time–Based License Quits Working

— The instrument’s time or date may have been reset forward causing the time–based license to 
expire.

— The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time–based licenses.

See page 47 for details and cautions on setting time and date.

Cannot Load a Time–Based License

The instrument’s time or date may have been reset backward more than approximately 25 hours, 
causing the instrument to ignore time–based licenses.

See page 47 for details and cautions on setting time and date.
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Contacting Keysight Technologies

Contacting Keysight Technologies
— assistance with test and measurements needs, and information on finding a local Keysight 

office: 
http://www.keysight.com/find/assist

— accessories or documentation: http://www.keysight.com/find/X-Series_SG.

— new firmware releases: http://www.keysight.com/find/upgradeassistant.

If you do not have access to the Internet, please contact your field engineer.

Returning a Signal Generator to Keysight

Use the following steps to return a signal generator to Keysight Technologies for servicing:

1. Gather as much information as possible regarding the signal generator’s problem. 

2. Call the phone number listed on the Internet (http://www.keysight.com/find/assist) that is 
specific to your geographic location. If you do not have access to the Internet, contact your 
Keysight field engineer. 

After sharing information regarding the signal generator and its condition, you will receive 
information regarding where to ship your signal generator for repair.

3. Ship the signal generator in the original factory packaging materials, if available, or use similar 
packaging to properly protect the signal generator.

In any correspondence or telephone conversation, refer to the signal 
generator by its model number and full serial number. With this 
information, the Keysight representative can determine whether your unit 
is still within its warranty period.
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Keysight Technologies

X-Series Signal Generators

User’s Guide

19     Working in a Secure Environment

If you are using the instrument in a secure environment, you may need details of how to clear or 
sanitize its memory, in compliance with published security standards of the United States 
Department of Defense, or other similar authorities.

For the Series B CXG, MXG and EXG instruments, this information is contained in the PDF 
document "Security Features and Document of Volatility". This document may be downloaded from 
Keysight’s web site, as described below.

The document includes the following topics:

— Security Terms and Definitions

— Instrument Memory Types

— Memory Clearing and Sanitization (Erase All, Erase and Sanitize All functions—requires 
Option 006)

— Clearing Persistent State information

— Using the Secure Display feature (also documented in Using Secure Display (Option 006) on 
page 460 below and requires Option 006)

— Using Restricted Display on page 461—not in the "Security Features and Document of Volatility"

— Declassifying a Faulty Instrument

How to Obtain the Security Features Document

Step Action

1 Click on or browse to the following URL:

http://www.keysight.com/find/security

2 To locate and download the document, select Model Number "N5166B", "N5183B", "N5182B", 
“N5181B”, "N5173B", “N5172B”, or “N5171B”, then click "Submit".

3 Follow the on-screen instructions to download the PDF file.
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Using Secure Display (Option 006)

Using Secure Display (Option 006)
This function prevents unauthorized personnel from reading the instrument display or tampering 
with the current configuration via the front panel. When Secure Display is active, the display is 
blank, except for an advisory message, as shown in Figure 19-1 below. All front panel keys are 
disabled.

To set Secure Display, press: Utility > Display > More > Activate Secure Display > 
Confirm Secure Display.

Once Secure Display has been activated, the power must be cycled to re-enable the display and 
front panel keys.

Figure 19-1 Signal Generator Screen with Secure Display Activated
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Working in a Secure Environment

Using Restricted Display

Using Restricted Display
While in restricted display mode, all frequency information is hidden and the front panel frequency 
control is disabled. 

To set Restricted Display, perform the following key presses:

 Utility > Display > More > Activate Restricted Display > Confirm Restricted Display. 

Once Restricted Display has been activated, an instrument preset or power cycle is required to 
re-enable the front panel frequency control. 
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Working in a Secure Environment
Using Restricted Display
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Glossary

A

Active Entry The currently selected, and therefore editable, entry or parameter

ARB Arbitrary waveform generator

Avionics Avionics is a term used to describe the electronic instrumentation on aircraft.

AWG Arbitrary waveform generator. Additive white Gaussian noise

B

BBG Media Baseband generator media. Volatile memory, where waveform files are played or edited.

BNC Connector Bayonet Neill-Concelman connector. A type of RF connector used to terminate 
coaxial cable. 

C

CCW Counterclockwise

C/N Carrier-to-noise ratio

CW Continuous wave. Clockwise

D

DHCP Dynamic host communication protocol

Dwell Time In a step sweep (see page 67), the time that the signal is settled and you can make a 
measurement before the sweep moves to the next point.

E

EVM Error vector magnitude; the magnitude of the vector difference at a given instant between the 
ideal reference signal and the measured signal.

F

Filter factor Alpha The filter’s alpha coefficient. It is only valid for root Nyquist and Nyquist filters.

Filter Factor BbT The filter’s bandwidth-bit-time (BbT). It is only valid for a Gaussian filter (similar to 
alpha). BbT is defined by the GSM standard as 0.3 and by the DECT standard as 0.5.

G
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Gaussian filter The Gaussian filter does not have a zero Inter-Symbol Interference (ISI). Wireless 
system architects must decide just how much of the ISI can be tolerated in a system and combine 
that with noise and interference. The Gaussian filter is Gaussian shaped in both the time and 
frequency domains, and it does not ring like the root Nyquist filters do. The effects of this filter in 
the time domain are relatively short and each symbol interacts significantly (or causes ISI) with only 
the preceding and succeeding symbols. This reduces the tendency for particular sequences of 
symbols to interact, which makes amplifiers easier to build and more efficient.

GPIB General purpose interface bus. An 8-bit parallel bus common on test equipment.

H

Hard key A labeled button on the instrument.

I

IF Intermediate frequency

Int Media Internal media. Nonvolatile signal generator memory, where waveform files are stored.

 
 
IP Internet protocol. The network layer for the TCP/IP protocol suite widely used on Ethernet 
networks.

L

LAN Local area network

LO Local oscillator

LXI LAN eXtension for Instrumentation. An instrumentation platform based on industry standard 
Ethernet technology designed to provide modularity, flexibility, and performance to small- and 
medium-sized systems. See also http://www.lxistandard.org

M

Modulation Format Custom modulation, Two-Tone, or Multitone.

Modulation Mode Dual ARB, Custom modulation, Two-Tone, or Multitone.

Modulation Standard Refers to a Cellular standard format (i.e. NADC, PDC, PHS, etc.).

Modulation Type Refers to the various I/Q constellation types (i.e. PSK, MSK, FSK, C4FM, etc.)

N

Non - volatile That which survives a power cycle (such as files stored in USB media).
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Nyquist filter Also referred to as a cosine filter. These filters have the property that their impulse 
response rings at the symbol rate. Adjacent symbols do not interfere with each other at the symbol 
times because the response equals zero at all symbol times except the center (desired) one.

P

Persistent That which is unaffected by preset, user preset, or power cycle.

Point-to-point Time In a step sweep (page 67), the sum of the dwell time, processing time, switching 
time, and settling time.

R

Rectangular filter Also referred to as a ideal low pass filter. These filters have very steep cut-off 
characteristics. The pass band is set to equal the symbol rate of the signal. Due to a finite number 
of coefficients, the filter has a predefined length and is not truly “ideal”. The resulting ripple in the 
cut-off band is effectively minimized with a Hamming window. This filter is recommended for 
achieving optimal ACP. A symbol length of 32 or greater is recommended for this filter.

Root Nyquist filter Also referred to as a Root cosine filter. These filters have the property that their 
impulse response rings at the symbol rate. Adjacent symbols do not interfere with each other at the 
symbol times because the response equals zero at all symbol times except the center (desired) one. 
Root Nyquist filters heavily filter the signal without blurring the symbols together at the symbol 
times. This is important for transmitting information without errors caused by ISI. Note that ISI does 
exist at all times except the symbol (decision) times. A cascade of two of these filters has the 
transfer function of a Nyquist filter. One is in the transmitter, the other in the receiver, so that the 
system taken as a whole has the zero-ISI properties of an ISI filter.

RMS Root mean square. A time-varying signal’s effective value (the equivalent DC voltage required 
to generate the equivalent heat across a given resistor). For a sinewave, RMS = 0.707 x peak value. 

S

Softkey A button located along the instrument’s display that performs whatever function is shown 
next to it on that display.

 
T

TCP Transmission control protocol. The most common transport layer protocol used on Ethernet and 
the Internet.

Terminator A unit indicator (such as Hz or dBm) that completes an entry. For example, for the entry 
100 Hz, Hz is the terminator.

Type-N Connector Threaded RF connector used to join coaxial cables.

U

USB Universal serial bus. See also http://www.usb.org
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User FIR Selects a user-defined set of coefficient values. Each line in the FIR values table contains 
one coefficient value. The number of coefficient values listed must be a multiple of the selected 
oversampling ratio. Each coefficient applies to both I and Q components.

V

Volatile That which does not survive a power cycle (such as files stored in BBG media).
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Index

Symbols

, 274
ΦM

annunciator, 27
dc offset, removing, 183
hardkey, 179
softkeys, 179, 183

# points softkey, 67
# Skipped Points softkey, 228

Numerics

10 MHz OUT connector, 32, 41, 
42

100Base-T LAN cable, 50
128 QAM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
16-Lvl FSK softkey, 385, 389, 

390, 391, 392, 393, 394, 397
16QAM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
2’s complement 

description, 325, 339
256 QAM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
2-Lvl FSK softkey, 385, 389, 390, 

391, 392, 393, 394, 397
32QAM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
4-Lvl FSK softkey, 385, 389, 390, 

391, 392, 393, 394, 397
4QAM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
628, error, 261
64QAM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
651/652/654, option

description, 22
multitone mode, 440
two-tone mode, 435

8557D GPIB only softkey, 51, 53
8648A/B/C/D GPIB only 

softkey, 51, 53
8656B,8657A/B GPIB only 

softkey, 51, 53
8-Lvl FSK softkey, 385, 389, 390, 

391, 392, 393, 394, 397

A

AC power receptacle, 30, 39
ACP, 382
Activate Secure Display 

softkey, 45
active

entry, 463
entry area, 27

Active High softkey, 240
Active Low softkey, 240
Add Comment To softkey, 83
additive white Gaussian noise. 

See AWGN
address, GPIB, 49
Adjust Phase softkey, 63, 65
Adjustable doublet 

softkey, 190
adjustments

I/Q, 203, 269
quadrature, 269
real-time phase noise, 375

advance, segment, 242
Advanced Settings softkey, 50
Aeroflex softkey, 51, 53
ALC

hold, 224, 225
OFF annunciator, 27
off mode, 122
softkeys, 63, 65, 228

alc
setting, 65

All softkey, 77
Alpha, 463
AM

annunciator, 27
external source, 183
hardkey, 179
softkeys, 179
wideband, 184

amplitude
display area, 28
hardkey, 63, 65
LF output, 186, 187
modulation, 179
offset, 126
reference, 127
setting, 63, 65
troubleshooting sweep, 452

AMPTD hardkey, 63, 65

analog modulation, 21, 179
configuring, 180, 185

angle, quadrature, 203
annunciators, 27
APCO 25 w/C4FM softkey, 384, 

388
APCO 25 w/CQPSK 

softkey, 384, 388
apodization settings, FIR 

filter, 280, 423
Apply To Waveform 

softkey, 228
ARB

definition, 463
player, dual, 207
softkeys, 207, 238, 365, 366, 

367, 368, 372, 378
waveform clipping, 246

arb, 382
Arb Custom

FIR filters, 416
FIR table editor, 423

Arb Segment softkey, 82
Arb Sequence softkey, 82
arb setup

softkey, 283
ARMED annunciator, 27
arrow keys, 61
ASK Depth softkey, 385, 389, 

390, 391, 392, 393, 394, 397
ASK softkey, 385, 389, 390, 391, 

392, 393, 394, 397
ATTEN HOLD annunciator, 27
Atten/ALC Control softkey, 63, 

65
Auto softkeys

(DHCP/Auto-IP), 50
Auto, 99, 122
Recall, 132

AUTOGEN_WAVEFORM 
file, 382

auto-IP, 50
Auto-IP softkey, 50
Automatically Use USB Media 

If Present softkey, 77
AUX I/O connector, 35
Auxiliary Software Options 

softkey, 56
Avionics

definition, 463
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Avionics Softkey Menus, 133, 
341, 342, 343, 344

Avionics VOR/ILS, 133
AWGN

adding, 363
annunciator, 27
definition, 463
dual ARB player, 364
softkeys, 370

AWGN softkeys, 365, 366, 367, 
368

B

backspace hardkey, 61
bandwidth ratio, 370
Bandwidth softkey, 370
baseband, 35

aligning signals at, 224
clipping, 246
frequency offset

softkey location, 261
frequency offset, setting, 261
I/Q output connectors, 33
memory, 207
noise, 363
noise annunciator, 27
quadrature adjustment, 269
real time I/Q AWGN, 365, 366, 

367, 368, 370
softkey, 261
summing signals, 268
waveforms convert to 

analog, 256
baseband frequency offset

DAC over range & 
scaling, 263

softkey, 261
baseband generator, 382

custom arb mode, 22
dual arb mode, 22
multiple BBG 

synchronization, 285
multitone mode, 22, 440
two-tone mode, 435

BB GEN, 268
BBG

media, 207, 209
media (definition), 463
Memory softkey, 82
Memory to USB softkey, 82
routing, 268
Segments softkey, 77, 217

BBG sync, 285
configure setup, 288
equipment setup, 288

resynchronization, 290
system, 287
system delay, 286
trigger setup, 287

BbT, 463
BERT

Option N5180UN7B, 341
Binary softkey, 77
bit file editor, using, 390
bits per symbol, equation, 427
Bk Sp hardkey, 61
Bluetooth softkey, 384, 385, 388, 

389, 390, 391, 392, 393, 394, 
397

BNC, 463
Bright Color softkey, 45
brightness adjustment, 45
Brightness softkey, 45
Buffered Trig softkey, 240
Build New Waveform Sequence 

softkey, 212, 236
Burst Envelope softkey, 266
Bus softkey, 66

C

C/N, 463
C4FM softkey, 385, 389, 390, 

391, 392, 393, 394, 397
cables

crossover, 50
multi-BBG sync, 286

cables, 100Base-T LAN, 50
Calculate softkey, 217
calibration

I/Q, 270
softkey, 270

Calibration Type softkey, 270
Cancel hardkey, 24
carrier

bandwidth, 364
configuring, 64
feedthrough, 203
modulating, 74
softkeys, 365, 366, 367, 368
to noise ratio, 364

Carrier Bandwidth 
softkey, 365, 366, 367, 368

carrier feedthrough, 
minimizing, 437

Carrier Softkey, 365, 366, 367, 
368

Carrier to Noise softkey, 365, 
366

Carrier+Noise softkey, 365, 367, 
368

Catalog Type softkey, 77, 78, 82, 
217

catalog, state files, 86
ccw, 463
CDPD softkey, 384, 385, 388, 

389, 390, 391, 392, 393, 394, 
397

ceiling function, bits per 
symbol, 427

Channel Band softkey, 63, 65
channel bandwidth, 370
Channel Number softkey, 63, 65
circular clipping, 250, 253
classified. See security
Clear softkeys

Error Queue(s), 88
Header, 217
Text, 61

clipping
circular, 250, 253
rectangular, 251, 254
softkeys, 246

clock adjustment
phase and skew, 316

clock gate, 346
clock rate limits, logic type 

output, 306
clock source

setting, 328, 335
clock timing

parallel data, 311
parallel interleaved data, 314
phase and skew, 316
serial data, 315

clock, sample rate, 35
clocking, frequency 

reference, 309
clocking, frequency reference 

diagrams, 310
clocks per sample

parallel data, 311
parallel interleaved data, 314

coefficient values, 
entering, 275, 418

color palette, display, 45
COM/ID Softkey Menus, 144
comments, adding & editing 

(instrument state), 84
common frequency reference 

diagrams, 310
component test, 382
Config Type softkey, 50
Configure softkeys

Cal Array, 103
List Sweep, 66, 69
Step Array, 103
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Step Sweep, 66, 67
Confirm Load From File 

softkey, 81
Connection Monitoring 

softkey, 50
Connection Type softkeys

Sockets, 105
USB, 105
VXI-11, 105

connections
common frequency 

reference, 310
connectors

external triggering 
source, 243, 245

front panel, 23
rear panel

n5161a, 30, 39
n5162a, 30, 39
n5181a, 30, 39
n5182a, 30, 39

routing signals, 67
Continuous softkey, 240
continuous step sweep 

example, 72
continuous wave

description, 21
continuous wave output, 64
contrast adjustment, 45
Contrast softkey, 45
Copy & softkeys

Play Sequence, 81
Play Waveform, 81
Select User Flatness, 81
Select User Flatness 

Corrections, 81
Copy softkeys

All Files, 82
File, 77
File to Instrument, 77, 82
File to USB, 82

correction array (user 
flatness), 108

viewing, 109
See also user flatness 

correction
corrections, internal 

channel, 111
cosine filter. See nyquist filter
Create Directory softkey, 77, 82
crossover cable, 50
custom

multicarrier TDMA waveforms
creating, 413

TDMA digital modulation, 401
custom arb, 295, 382

Custom ARB softkeys, 295, 383, 
387

custom arb waveform 
generator, 22

custom mode, 382
custom modulation

adding to a waveform, 401
waveform, adding to, 401

cw, 463
CW (no modulation) 

softkey, 69
CW mode

description, 21

D

DAC over range error, 256, 261
DAC over range protection

baseband frequency 
offset, 263

phase noise, 376
Dark Color softkey, 45
data

entry softkeys, 61
erasing, 459
files, 76 to 82
removing, 459
serial, synchronizing, 35
storage

comments, adding and 
editing, 84

troubleshooting, 452
type, 87
using, 76

data files
creating, 391
modifying, 393

data filtering, pre or post 
fir, 325, 338

data processing, 353
data types, 320
date, setting, 47
dc offset, 203
dc offset, removing, 183
DCFMΦ/DCfM Cal softkey, 181
Declassifying faulty 

instrument, 459
DECT softkey, 384, 388
Default Gateway softkey, 50
default settings

restoring, 46, 50, 270
system, restoring, 60

Default softkey, 384, 388
delay

I/Q, 269

multiple BBG sync, 286
Delete softkeys

All Regs in Seq, 83
All Segments On Int 

Media, 209
All Segments On USB 

Media, 209
All Sequence Files, 77
All Sequences, 83, 132
All Waveforms, 212
All Waveforms softkey, 236
File, 77
File or Directory, 77, 79, 82, 87
Item, 69
Row, 69
Selected Waveform, 212, 236
Seq Reg, 83
Waveform Sequence, 236

description & plots, phase 
noise, 373

DETHTR annunciator, 27
device clock source 

selection, 328, 335
Device softkey, 63, 65
DHCP, 50, 463
DHCP softkey, 50
diagram

data types, 320
diagrams

clock timing
parallel data, 311
parallel interleaved 

data, 314
phase and skew, 316
serial data, 315

common frequency 
reference, 310

Diff Mode softkeys, 269
differential encoding, 426
differential encoding, bits per 

symbol, 427
differential state map, bits per 

symbol, 427
DIGBUS annunciator, 27
digital bus, 34
digital modulation

formats, 22
IQ map, QAM, 426
multitone, 440 to 443
TDMA, 401
two tone, 435 to 439

digital modulation type
modifying, 403

digital operation, 205, 296
Digital Signal Interface Module

Option 003 or 004, 341
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digital signal interface module
N5102A, 305

digital signal to analog 
waveform, 256

discrete steps, skew range, 316
display

blanking, 459
error message area, 28
overview, 23
overview, 

N5181A/82A/83A, 27
secure, 459
settings, 45
softkey labels, 29
softkeys, 43, 61, 228
tests, 454
text area, 29
troubleshooting, 446

Display softkeys
Case, 61
display, 43
Waveform And Markers, 228

Displayed Case softkeys, 61
distortion, troubleshooting, 447
DNS Server Override 

softkey, 50
DNS Server softkey, 50
documentation, 17
Domain Name softkey, 50
doublet

adjustable, 192
softkeys, 190
trigger, 192

Dual ARB
FIR table editor, 275, 280
real-time modulation, 283
user-defined FIR, 275

dual ARB
multi-BBG sync, 285
player, 207
real-time noise, 364
softkeys, 208, 365, 366, 367, 

368, 372, 378
dual arb, 382
dual ARB player, 22
Dual ARB Real-Time

filters, 274
dual arbitrary waveform 

generator, 22
dual display, power meter, 90
dwell time, 69, 463
Dwell Type softkey, 69
dwell, troubleshooting, 451
Dynamic DNS Naming 

softkey, 50

Dynamic Hostname Services 
softkey, 50

E

E4428C, E4438C softkey, 51, 53
E442xB, E443xB softkey, 51, 53
E8241A, E8244A, E8251A, 

E8254A softkey, 51, 53
E8247C, E8257C, E8267C 

softkey, 51, 53
E8257D, E8267D softkey, 51, 53
EDGE

custom digital modulation, 
predefined, 401

EDGE softkey, 384, 388
Edit softkeys

Description, 217
Noise RMS Override, 217
Repetitions, 236
RMS, 217
Selected Waveform 

Sequence, 212, 236
Editing Keys softkey, 61
Editing Mode softkey, 61
editor, bit file, 390
Enable/Disable Markers 

softkey, 212, 236
Enter Directory softkey, 81
entry, active, 463
equalization

filter, 272
filter, user, 272

equipment setup, 288
equipment, user flatness 

correction, 104, 105
Erase All, 459
Erase and Sanitize All, 459
ERR annunciator, 28
Error hardkey, 88
error messages, 88

DAC over range, 256, 261
display area, 28
message format, 88
types, 453

Esc hardkey, 24
EVENT

connector, AUX I/O, 35
connector, BNC, 33, 223
output jitter, 238
outputs, 223

EVM, 463
EVM error, 203
example

Waveform license, Opt 25x
adding a waveform, 301

locking a slot, 301
examples

FIR filters
creating, 275, 416, 418
modifying, 280, 423

LF output, configuring, 185
Execute Cal softkey, 270
EXT CLOCK connector, 33
EXT REF annunciator, 27, 28
Ext softkeys

Delay, 241
Delay Time, 241
Ext, 66
I/Q Output, 266, 267
Pulse, 190
Source, 241

extension, file, 81
external

I and Q signals, 268
media, 87, 452
modulation source, 183
reference oscillator, using, 64
trigger source, 243, 245
triggering, 245

external clock source 
selection, 328, 335

external leveling, 115 to 121
softkeys, 115

external leveling, 
configuring, 118

External softkeys
External, 266
Input, 269
Input I Offset, 202
Input Q Offset, 202
Output, 269

F

factory defaults, restoring, 46, 
50, 270

Fading, 378
Fading, Baseband Generator 

with Real-Time Capability
Option 660, 377

features, 20
feedthrough, 203
feedthrough, carrier, 

minimizing, 437
File hardkey, 77, 86
file headers

creating, 217
editing, 219
example, 220
viewing a different file, 221

files
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catalog. See data storage
extensions, 81
working with, 76

filter
equalization, 272
real-time modulation

softkey location, 283
user, equalization, 272

filter, interpolator, 256
filtered & unfiltered 

samples, 325, 338
filters

finite impulse response, 274, 
416

FIR, 274, 416
gaussian, loading 

default, 280, 423
nyquist, selecting, 404

filters Dual ARB, 274
finite impulse response filters

using, 274, 416
FIR filter

apodization settings, 280, 423
Hamming, 280, 423
Hann, 280, 423
Kaiser, 280, 423
window settings, 280, 423

FIR filters
Arb Custom, 416
creating, 275, 416, 418
modifying, 280, 423
storing, 278, 421
using, 274, 416

FIR table editor
accessing, 275, 418
Arb Custom, 423
coefficients, duplicating, 276, 

420
coefficients, entering 

values, 275, 418
coefficients, modifying, 281, 

424
Dual ARB, 275, 280
files, loading, 280, 423
filters

creating, 275, 416, 418
modifying, 280, 423
storing, 278, 282, 421, 

425
oversample ratio, setting, 277, 

420
firmware

upgrading, 49, 457
First Mkr Point softkey, 228
First Sample Point softkey, 228
Fixed softkey, 99, 122

flat bandwidth, 370
flatness correction. See user 

flatness correction
Flatness softkey, 103
FM

annunciator, 28
dc offset, removing, 183
external source, 183
hardkey, 179
softkeys, 179

formula, skew discrete 
steps, 316

Free Run softkey, 66, 130, 240
Free-Run softkey, 190
Freq Dev softkey, 385, 389, 390, 

391, 392, 393, 394, 397
FREQ hardkey, 63, 65
Freq softkeys, 103
frequency

display area, 27
hardkey, 25, 26, 63, 65
LF output, 186

start and stop, 
swept-sine, 187

modulation, 179
multiplier, 128
offset, 126
offset, baseband, 261
offset, softkeys, 261
reference, 127
setting, 63, 65
softkeys, 63, 65

frequency output limits, clock 
rates & logic levels, 306

frequency reference
common, 309
hookup diagrams, 310

frequency units, 63
front panel

disabling keys, 459
display, N5181A, 27
display, N5182A, 27
display, N5183A, 27
I/Q inputs, using, 203
knob resolution, 46
overview, 23
tests, 454

FSK softkey, 385, 389, 390, 391, 
392, 393, 394, 397

FTP Server softkey, 50
fundamental operation See 

basic operation

G

Gated softkey, 190, 240

gated triggering, 241, 243
Gaussian

definition, 464
gaussian filter, loading 

default, 280, 423
Gaussian. See AWGN
glossary, 463
Go To Default Path softkey, 77, 

79, 87
Goto Row softkey, 69, 77
GPIB

connector, 32, 41
definition, 464
setup, 49
softkeys

Address, 49
Setup, 49

green LED, 26
GSM softkey, 384, 388
guides, content of, 17

H

hardkeys
help on, 60
overview, 23
See also specific key

header utilities softkeys, 217
Help hardkey, 24, 60
Hostname softkey, 50
hostname, setting, 50
HP 3300A, emulating, 132

I

I connector, 25
I Offset softkey, 269
I OUT connector, 33
I/O Config softkey, 43
I/Q

adjustments, 203, 269
front panel inputs, using, 203, 

268
Int Equalization Filter 

softkeys location, 273
modulation, 202, 265
optimizing, 267
rear panel outputs, 33
rear panel outputs, using, 267
signal path, optimizing, 267
signal, aligning, 224
softkey, 273
softkeys, 202, 266 to 271
waveform, clipping, 246

ideal low-pass filter. See 
rectangular filter
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IF, 464
ILS Glide Slope 334.70 MHz w/ 

90 Hz AM (Up), 150 Hz AM 
(Down) @ 40%, 150, 162

ILS Glide Slope Softkey 
Menus, 163

ILS Localizer 108.10 MHz w/ 
90 Hz AM (Left), 150 Hz AM 
(Right) @ 20%, 150, 162

ILS Localizer Softkey 
Menus, 151

ILS Marker Beacon Softkey 
Menus, 173

ILS Marker Beacons 75 MHz w/ 
Inner 4000 kHz, Middle 
1300 Hz, Outer 400 Hz, 150, 
162

images, 203
impairments

I/Q adjustments, 203
impairments, real-time

phase noise, 371
Import Waveform softkey, 236
improve non-harmonics, 63
Incr Set hardkey, 26
information, removing from 

memory, 459
Insert softkeys

Insert, 212
Item, 69
Row, 69
Waveform, 212
Waveform Sequence 

Contents, 212
Install Assembly softkey, 57
Install licenses softkey, 81
installation guide content, 17
instrument

firmware, upgrading, 49
softkeys

Adjustments, 43
Info, 43
Options, 56

state
associating with 

waveform, 84
files, 82, 86
register. See data stor-

age
softkey, 82

Int Equalization Filter
softkeys, 273

int media, 464
Int Phase Polarity softkey, 266
interface

GPIB, 49
LAN, 50

internal
reference oscillator, using, 48

Internal Baseband Adjustments 
softkey, 269

internal clock source 
selection, 328, 335

internal media, 87
Internal Storage to USB 

softkey, 82
Internal/USB Storage Selection 

softkey, 77
interpolator filter, 256
IP

Address softkey, 50
address, setting, 50
auto, 50
definition, 464

IQ
clock rates, 308

IQ map, QAM modulation, 426

J

jitter on EVENT output, 238

K

keyboard, using, 132
keys

definition, 464
disabling, 459
front panel, 23
help on, 60
numeric, 23
test, 454
See also specific key

Keysight MXG
modes of operation, 21

Keysight sales and service 
offices, 457

knob, 26, 46, 61

L

L annunciator, 28
LAN

connector, 32, 41
definition, 464
Services Setup softkey, 49
setup, 50
Setup softkey, 49

Last Mkr Point softkey, 228
Last softkey, 46
LEDs, 26

blink test, 454
front panel, 26
modulation, 74

leveling
external, 115 to 121
turn off ALC, 122

LF Out, 185
LF output

amplitude, 186, 187
configuration example, 186, 

187
description, 185
frequency, 186
source

function generator, 187
internal modulation 

monitor, 186
swept-sine

start frequency, 187
stop frequency, 187

waveform, 180, 185, 187
LFO. See LF output
licenses

manager, 55
service software, 55
signal studio, 55
time-based, 47
troubleshooting, 456
viewing, 55
waveform, 55

limits, clock & sample rates, 
logic outputs, 306

line power (green) LED, 26
linear sweep, 67
list mode values, 70
List softkey, 77
list sweep

parameters, 70
status information, 70
troubleshooting, 451
using, 69
waveform, 71

listener mode annunciator, 28
LO, 464
Load From Selected File 

softkey, 80, 81
Load List softkey, 81
Load softkeys

All From Int Media, 209
All From USB Media, 209
Cal Array From Step 

Array, 103
From Selected File, 80, 81
Load/Store, 69, 80, 81
Segment From Int Media, 209
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Segment From USB 
Media, 209

Store, 209
Sweep List, 81

Load/Store softkey, 69, 80, 81
Local hardkey, 24
lock up, troubleshooting, 446
logarithmic sweep, 67
logic type

output levels, 306
selecting, 322

low frequency output. See LF 
output

low spurs, 63
LVDS compatibility with the 

PXB, 21
LXI, 464

M

manual control, sweep, 73
Manual softkey, 99, 122
Manual softkeys

Config Settings, 50
Manual, 50
Mode, 66
Point, 66

manuals, content of, 17
Marker softkeys, 228
markers, aligning signal, 224
markers, waveform, 223 to 238
media

BBG, 463
erasing, 459
Flash Drive, 87
int, 464
storage, 87
types, 207, 459
USB, 87, 452

memory
erasing data from, 459
See also media

menu keys, 24
messages, error, 453
messages, warning

Opt 25x Licensing, 303
mirror table, duplicating 

coefficients, 276, 420
mixer, troubleshooting signal 

loss, 449
Mod On/Off hardkey, 25, 74
Mod On/Off, Option UNT, 179
Mod Type Softkeys, 385, 389, 

390, 391, 392, 393, 394, 397
Mode hardkey, 208, 365, 366, 

367, 368, 370, 372

Mode key, 378
mode, modulation, 464
modes of operation, 21
Modulated softkey, 99, 122
modulation

AM, 179
analog, 21

configuring, 180, 185
annunciators, 28
carrier signal, 74
digital, 22
external source, using, 183
FM, 179
generating, 74
I/Q, 202, 265
phase, 179
pulse, 21, 189
real-time filter, softkeys, 283
simultaneous, 75
troubleshooting, 447

Modulator Atten softkey, 370
module user interface 

location, 321, 331
monochrome display, 

setting, 45
Monochrome softkey, 45
MSK softkey, 385, 389, 390, 391, 

392, 393, 394, 397
MULT annunciator, 28
multi-BBG sync, 285

configure setup, 288
equipment setup, 288
resynchronize, 290
system delay, 286
system sync, 287
trigger setup, 287

multicarrier setup
APCO 25 w/C4FM, 413
APCO 25 w/CQPSK, 413
Bluetooth, 413
CDPD, 413
DECT, 413
Default, 413
EDGE, 413
GSM, 413
NADC, 413
PDC, 413
PHS, 413
PWT, 413
TETRA, 413

multicarrier setup 
softkeys, 413

multicarrier TDMA waveforms
creating, 413

multicarrier, Default softkey. 
See quick setup, Default 
softkey, settings

multiplier, using, 128
multitone, 382, 440 to 443
multitone mode, 22
Multitone softkeys, 440
multitone waveform, 

setup, 434

N

N5102A
baseband data, 321
clock rates, 306
clock settings, 325, 333
clock source

description, 309
clock timing, 306, 311
common frequency 

reference, 309
connections to clock and 

device, 318
data parameters, setting, 323, 

337
data types, 320
digital data, 339
digital signal interface 

module, 305
frequency reference 

connector, 310
generating data, 330
input direction, 332
input mode, 320, 331
interleaving clock timing, 314
logic type, port 

configuration, 332
logic types, 322
Option 003 or 004, 341
output direction, 323
output mode, 320, 321
phase and skew clock 

timing, 316
serial clock timing, 315
user interface, 321
user interface module, 331

N5180430B, option
multitone mode, 440
two-tone, 435
two-tone mode, 435

NADC softkey, 384, 388
Name And Store softkey, 236
negation description, 325, 339
Next REG softkey, 132
Next SEQ softkey, 132
No action softkey, 81
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No Retrigger softkey, 240
noise, 363
noise bandwidth factor, 364
Noise Bandwidth softkey, 365
Noise Mux softkeys, 367, 368
Noise softkey, 365, 367, 368
non-harmonics, 63
non-volatile memory, 207
non-volatile, definition, 464
number keys, 61
numeric format selection, 325, 

339
numeric keypad, 23
nyquist filter

definition
nyquist filter, selecting, 404

O

OFFS annunciator, 28
offset, 203
offset binary use, 325, 339
offsets

baseband frequency, 261
I/Q, 269
output, using, 126

on/off switch, 26
operation

modes of, 21
operation, basic, 59
operation, remote, 49
optimization, I/Q, 202, 266
option

N5180430B
multitone mode, 440
two tone mode, 435
two-tone mode, 435

Option U01, 111
internal channel 

correction, 111
Option UNT

Mod On/Off hardkey, 179
Options

003 or 004 Digital Signal 
Interface Module, 341

660 Real-Time Fading, 378
660 Upgrade Baseband 

Generator with Real-Time 
Capability, Fading, 377

N5180UN7B BERT, 341
options

651/652/654
description, 22
multitone mode, 440
two-tone mode, 435

enabling, 43, 55
resource, 21
UNT, 21
UNU, 21
UNW, 21

Options 250-259, 296
Options Info softkey, 56
oscillator, external 

reference, 64
oscillator, internal 

reference, 48
Output Blanking softkey, 63, 65
output levels, logic types, 306
Output Mux softkeys, 365
output, swept, 66
over range error, DAC, 256, 263, 

376
overshoot, 256
overview, signal generator, 19

P

Page Up hardkey, 24
parallel

clock rates, 308
data clock timing, 311
interleaved data clock 

timing, 314
sample rates, 308

parameters, saving a 
waveform’s, 217

path delay, 203
PATT TRIG IN connector, 34
Patt Trig In softkeys, 241
PDC softkey, 384, 388
peak-to-average power, 

reducing, 250
performance, optimizing, 89
persistent settings

definition, 465
resetting, 60
restoring defaults, 46

phase clock timing, 316
phase noise

adjustments, 375
DAC over range & 

scaling, 376
description & plots, 373
impairments, 371
softkeys, 372, 378

Phase Ref Set softkey, 63, 65
phase skew, 203
PHS softkey, 384, 388
pixel test, 454
Plot CDDF softkey, 255
PM Config

Calibrate Sensor, 105
Zero Sensor, 105

PM Config softkeys
Connection Type, 105
PM VXI-11 Device Name, 105
Power Meter IP Address, 105
Power Meter IP Port, 105

Point Trigger softkey, 66
point-to-point time, 465
polarity, external trigger, 241
polarity, marker, setting, 235
port configuration, 

selecting, 322
power

meter, 102, 107
on, settings, 46
peak-to-average, 

reducing, 250
receptacle, 30, 39
search, 123
search automatic, 125
search settings, 125
sensor, models, 104, 105
setting, 63, 65
softkeys, 43, 46, 99, 122
supply, troubleshooting, 447
switch, 26
troubleshooting, 447
user settable, maximum, 65

Power Control Mode 
softkeys, 366

power meter
configuration, 106

U2000 Series, 106
U2000A/01A/02A/04A,

 106
dual display, 90

power meter configuration 
sofkeys. See PM Config 
softkeys

power meter sofkeys. See PM 
Config softkeys

Power Search Reference 
softkey, 99, 122

Power Search References, 123
Power softkeys

On, 46
On/Preset, 43
Search, 99, 122

power units, 63
preferences, setting, 43
pre-fir samples selection, 325, 

338
preset

hardkey location, 25
settings, 46
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troubleshooting, 452
using, 60

Preset softkeys
Language, 46
List, 69, 103
Preset, 46

Prev REG softkey, 132
Prev SEQ softkey, 132
Proceed With Reconfiguration 

softkey, 50
programming guide 

content, 17
protection, DAC over range

baseband offset 
frequency, 263

phase noise impairment, 376
PSK softkey, 385, 389, 390, 391, 

392, 393, 394, 397
pulse

annunciator, 28
characteristics, 191
connector, 31, 40
marker, viewing, 232
modulation, 189
narrow, 122
sync signal, 67
video signal, 67

Pulse hardkey, 190
pulse modulation, 21
Pulse softkeys, 67, 190
Pulse/RF Blank softkey, 228
PWT softkey, 384, 388

Q

Q connector, 26
Q Offset softkey, 269
QAM modulation IQ map, 426
QAM softkey, 385, 389, 390, 391, 

392, 393, 394, 397
quadrature adjustment, 269
quadrature angle, 203
Quadrature Angle Adjustment 

softkey, 202, 269
queue, error, 88
quick setup

Default softkey
settings, 384, 388

Quick Setup Softkeys, 384, 388

R

R annunciator, 28
raised cosine filter. See nyquist 

filter
real time, 295, 382

real-time
AWGN

softkeys, 365, 366, 367, 
368

I/Q Baseband AWGN 
softkeys, 370

modulation filter, 283
modulation filter, setting, 283
noise, 364
phase noise, 371

adjustments, 375
DAC over range & 

scaling, 376
description & plots, 373
impairments, 371
softkeys, 372, 378

real-time AWGN,bandwidth 
ratio, 370

real-time AWGN,channel 
bandwidth, 370

real-time AWGN,flat 
bandwidth, 370

Real-Time Fading
Option 660, 378

real-time modulation
Dual ARB, 283

real-time modulation filter
softkey, 283

rear panel
I/Q outputs, 267
overview

n5161a, 30, 39
n5162a, 30, 39
n5181a, 30, 39
n5182a, 30, 39

Recall hardkey, 83
Recall keys

hardkey, 132
Instrument State, 77, 81
Reg, 132
State, 81

recall register, 
troubleshooting, 451

receiver test, 382
rectangular clipping, 251, 254
rectangular filter

definition, 465
REF annunciator, 28
REF IN connector, 31, 40
Ref Oscillator Ext Bandwidth 

key, 64
Ref Oscillator Ext Freq key, 64
Ref Oscillator Source 

softkey, 63, 65

Ref Oscillator Tune key, 48
reference oscillator tune, 

internal, 48
reference oscillator, 

external, 64
reference, using, 127
references, content of, 17
regrowth, spectral, 249
remote interface, emulate HP 

3300A, 132
Remote Language softkey, 49, 

51, 53
remote operation 

annunciator, 28
remote operation 

preferences, 49
Remove Assembly softkey, 57
Rename File softkey, 77
Rename Segment softkey, 209
repeat measurements, 354
Reset & Run softkey, 240
Restart on Trig softkey, 240
Restore softkeys

LAN Settings to Default 
Values, 50

System Settings to Default 
Values, 46

resynchronize, 
multi-BBGs, 290

Return hardkey, 26
Reverse Power Protection 

softkey, 46
Revert to Default Cal Settings 

softkey, 270
RF

blanking
marker function, 234
settings, saving, 224

hardkey, 25
output

configuring, 64
connector, 25
leveling, external, 115 to 

121
troubleshooting, 447

RF During Power Search 
softkey, 99, 122

RF Output softkey, 266, 267
RFC NETBIOS Naming 

softkey, 50
ringing, 256
ripple, 256
RMS, 465
RMS softkey, 99, 122
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Rohde & Schwarz softkey, 51, 
53

roort, 465
root cosine filter. See root 

nyquist filter
root mean square, 465
Root Nyquist Filter

definition, 465
root nyquist filter

definition, 465
rotary knob, 61
Route Connectors softkey, 66, 

190
Route To softkeys, 67, 190
routing

I/Q, 202, 266
marker

ALC hold, 225
RF blanking, 234
saving settings, 224

RPG test, 454
runtime scaling, 258

S

S annunciator, 28
sales, Keysight offices, 457
sample

rates, 306
parallel/parallel intrlvd 

port 
configuration, 3
08

serial port 
configuration, 3
07

type selection, 325, 338
sample rate clock, 35
sample rate softkey, 238
Save hardkey, 83
SAVE Seq Reg softkey, 83
Save Setup To Header 

softkey, 217
Scale Waveform Data 

softkey, 255
scaling softkeys, 255
SCPI

enabling, 50
reference content, 17
softkey, 51, 53

screen saver settings, 45
Screen Saver softkey, 45
search, power, 123
secure

display, 459

security, 459
Security softkey, 77
Segment Advance softkey, 240
segment advance 

triggering, 241
segments

advance triggering, 242
file headers, 217
loading, 209
softkeys, 209
storing, loading, & 

playing, 209
Select hardkey, 61
Select Seq softkey, 132
Select softkeys

Color Palette, 45
Different Header, 217, 221
Header, 217
Internal File(s) to Copy to 

USB, 82
Reg, 83
Seq, 83
Waveform, 69

self test, 454
Sequence softkey, 77, 217
sequences

editing, 214
file headers, 217
marker control, 235
playing, 215
waveform, 212

serial
clock and sample rates, 307
clock timing, 315

serial data, synchronizing, 35
server, enabling, 50
service

guide content, 17
Keysight offices, 457
request annunciator, 28

Set Marker softkeys, 228
settings, persistent, 465
settings, phase noise, 375
Show softkeys

Alpha Table, 61
Waveform Sequence, 212
Waveform Sequence 

Contents, 212, 236
signal generator

modes, 21
Signal Studio, 21
signal studio licenses, 55
sinewave, 465
Single softkey, 240
Single Sweep softkey, 66
skew

clock timing, 316
range, 316

skew, I/Q, 269
Sockets SCPI softkey, 50
sockets, enabling, 50
Softkeys, 134
softkeys

definition of, 465
help on, 60
label area, 29
location, 23
See also specific key

source settled signal, 67
Source Settled softkey, 67, 190
Span softkey, 99, 122
special pattern ignore 

function, 353
Specify Default Storage Path 

for User Media softkey, 77
spectral regrowth, 249
spectrum analyzer, 

troubleshooting signal 
loss, 448

square root raised cosine filter. 
See root nyquist filter

Square softkey, 190
standard, modulation, 464
standby (yellow) LED, 26
State softkey, 77
states, persistent, 465
step array (user flatness), 108

See also user flatness 
correction

Step Dwell softkey, 67, 130
Step Spacing softkey, 67
step sweep

spacing, 67
troubleshooting, 451
using, 67

Step/Knob Ratio softkey, 46
Storage Type softkey, 79, 87
Store Custom Dig Mod State 

softkey, 386
Store To File softkey, 80, 81
Stored Segments softkey, 77, 

217
Subnet Mask softkey, 50
Sum softkey, 266
sweep

annunciator, 28
hardkey, 66
linear, 67
list parameters, 70
list status information, 70
logarithmic, 67
manual control, 73
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mode, 21
out connector, 31, 40, 67
out signal, 67
softkeys, 66 to 73, 190
step, 67
troubleshooting, 451
waveform, including, 71

SWEEP hardkey, 66
Sweep softkeys, 66 to 73, 82, 190
swept output, 66
switch, power, 26
SWMAN annunciator, 28
synchronization, 353, 354
synchronize multi-BBGs, 285

configure setup, 288
equipment setup, 288
resynchronize, 290
system delay, 286
system sync, 287
trigger setup, 287

system defaults, restoring, 46

T

T annunciator, 28
talker mode annunciator, 28
TCP, 465
TCP Keep Alive softkeys, 50
TDMA

custom digital modulation, 
predefined, 401

TDMA digital modulation, 401
terminator, 465
test, self, 454
test, self-web-enabled, 454
tests, front panel, 454
TETRA softkey, 384, 388
text area (on display), 29
text entry softkeys, 209
time, dwell, 463
time, setting, 47
time/date reference point, 47
Time/Date softkey, 47
time-based license, 47, 456
Timer Trigger softkey, 66, 130
Toggle softkeys, 236
Total Noise softkey, 366
Total softkey, 366
Trig

in connector, 31, 40
out connector, 67
out signal, 67

trigger
connectors, 31, 40
hardkey, 24
initiating, 24

multiple BBG sync, 287
Trigger setup softkeys, 131
Trigger softkeys

& Run, 240
Doublet, 190
Key, 66
Out Polarity, 66
Source, 239
Triggered, 190
Type, 239

Triggered softkey, 190
triggering

gated, 241, 243
multiple BBG sync, 287

equipment setup, 288
segment advance, 241
softkeys, 239
waveforms, 239

troubleshooting, 445
two tone, 382, 435 to 439
two tone softkeys, 435
two-tone softkeys, 435
two-tone waveform, setup, 434
type, modulation, 464

U

unfiltered & filtered 
samples, 325, 338

UNLEVEL annunciator, 28
unleveled operation, 122
UNLOCK annunciator, 28
Unspecified softkey, 217
UNT, option, 21
UNU, option, 21
UNW, option, 21
Up Directory softkey, 77, 79, 82
Update in Remote softkey, 45
urls, 21, 49, 55, 457
USB

connecting media, 87
definition, 465
device connector, 32, 41
host connector, 23, 32, 41
keyboard, using, 132
softkeys

File Manager, 77, 78
Keyboard Control, 132

to BBG Memory softkey, 82
to Internal Storage 

softkey, 82
troubleshooting, 452

Use softkeys
As, 81
Current Directory As Default 

Path, 77, 87

Only Internal Storage, 77
Only USB Media, 77

user
documentation content, 17
files, backup and restore, 76
flatness correction, 102
preset, 60
preset, troubleshooting, 452

user files
modifying, 393

user files, data, 391, 393
user FIR

definition, 466
user interface location, 

module, 321, 331
User softkeys

Configure Power Meter, 103
Current Directory As Default 

Path, 79
Do Cal, 103
Flatness, 63, 65, 77
Flatness Correction, 103
Flatness Corrections, 82
Span, 99, 122
User, 46

user-defined FIR
Dual ARB, 275

Utility hardkey, 43
Utility softkey, 57

V

vector operation, 205, 296
Using VOR, 134
View Next Error Page 

softkey, 88
View Previous Error Page 

softkey, 88
volatile memory, 207, 209
volatile, definition, 466
VOR mode, producing a full or 

partial VOR signal, 136, 342, 
343, 344

VOR Softkey Menus, 135
VOR Transmitter Antenna 

Pattern, 134, 138
VXI-11, enabling, 50
VXT-11 SCPI softkey, 50

W

warranted logic output clock 
rates, 306

waveform
adding custom 

modulation, 401
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Waveform license, Opt 25x
adding a waveform, 298
backup warning, 303
file missing warning, 303
license status messages, 299
licensing, installing, 296
licensing, understanding, 296
licensing, warning 

messages, 303
lock warning, 303
replacing a waveform, 298
status messages, 300
using, 296
waveform licensing 

softkeys, 298
Waveform softkeys

Licenses, 56
Runtime Scaling, 255
Segments, 209
Sequences, 212, 236
Utilities, 255
Waveform, 66, 69

waveforms
clipping, 246
file headers, 217
from digital baseband 

waveform, 256
in a sweep, 71
license, 55
markers, 223, 224
multiple BBG 

synchronization, 285
multitone, 440 to 443
overview, 207
saving instrument state, 84
scaling, 255
segment softkeys, 209
sequence, 212
storing, loading, & 

playing, 209
triggering, 239
two-tone, 435 to 439

Web Server softkey, 50
wideband AM, 184
window settings, FIR filter, 280, 

423
WINIT annunciator, 28

Y

yellow LED, 26

Z

Zoom softkeys, 228
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