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information contained herein.
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Safety Information

Safety Information

Important Information

Please Note

Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an
electrical hazard exists which will result in personal injury if the instructions are not
followed.

hazards. Obey all safety messages that follow this symbol to avoid possible injury or
death.

A DANGER

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious
injury.

2 This is the safety alert symbol. It is used to alert you to potential personal injury

A WARNING

WARNING indicates a hazardous situation which, if not avoided, could result in death or
serious injury.

A CAUTION

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or
moderate injury.

NOTICE

NOTICE is used to address practices not related to physical injury.

Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

Before You Begin

Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.

EIO0000004426.05



Safety Information

AWARNING

UNGUARDED EQUIPMENT

» Do not use this software and related automation equipment on equipment
which does not have point-of-operation protection.

* Do not reach into machinery during operation.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only you, the user, machine builder or system integrator can be aware of all the
conditions and factors present during setup, operation, and maintenance of the
machine and, therefore, can determine the automation equipment and the related
safeties and interlocks which can be properly used. When selecting automation
and control equipment and related software for a particular application, you should
refer to the applicable local and national standards and regulations. The National
Safety Council's Accident Prevention Manual (nationally recognized in the United
States of America) also provides much useful information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch points or
other hazardous areas and serious injury can occur. Software products alone
cannot protect an operator from injury. For this reason the software cannot be
substituted for or take the place of point-of-operation protection.

Ensure that appropriate safeties and mechanical/electrical interlocks related to
point-of-operation protection have been installed and are operational before
placing the equipment into service. All interlocks and safeties related to point-of-
operation protection must be coordinated with the related automation equipment
and software programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.

Start-up and Test

Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start-up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check are made and that enough time is allowed to perform complete and
satisfactory testing.

AWARNING

EQUIPMENT OPERATION HAZARD
» Verify that all installation and set up procedures have been completed.

» Before operational tests are performed, remove all blocks or other temporary
holding means used for shipment from all component devices.

* Remove tools, meters, and debris from equipment.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Safety Information

Follow all start-up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and temporary
grounds that are not installed according to local regulations (according to the
National Electrical Code in the U.S.A, for instance). If high-potential voltage
testing is necessary, follow recommendations in equipment documentation to
prevent accidental equipment damage.

Before energizing equipment:
* Remove tools, meters, and debris from equipment.
* Close the equipment enclosure door.
* Remove all temporary grounds from incoming power lines.
» Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments

The following precautions are from the NEMA Standards Publication ICS 7.1-
1995:

(In case of divergence or contradiction between any translation and the English
original, the original text in the English language will prevail.)

+ Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

* Itis sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

+ Only those operational adjustments required by the operator should be
accessible to the operator. Access to other controls should be restricted to
prevent unauthorized changes in operating characteristics.

EIO0000004426.05



About the Book

About the Book

Document Scope

Validity Note

Related Documents

The present user guide describes the functionality provided by EcoStruxure
Control Engineering - Documentation.

This document has been updated for the release of EcoStruxure Control
Engineering V23.1.

The characteristics that are described in the present document, as well as those
described in the documents included in the Related Documents section below,
can be found online. To access the information online, go to the Schneider Electric
home page www.se.com/ww/en/download/.

The characteristics that are described in the present document should be the
same as those characteristics that appear online. In line with our policy of constant
improvement, we may revise content over time to improve clarity and accuracy. If
you see a difference between the document and online information, use the online
information as your reference.

Title of documentation Reference number
EcoStruxure Control Engineering - EI00000004426 (eng)
Documentation - User Guide (this user guide)

EcoStruxure Control Engineering - Converter - EI00000004425 (eng)
User Guide

EcoStruxure Control Engineering - Verification - EI00000004424 (eng)
User Guide

EcoStruxure Control Engineering - Monitoring - EI00000004427 (eng)
User Guide

Cybersecurity Best Practices CS-Best-Practices-2019-340
EcoStruxure Control Engineering, Hardening EI00000004982 (eng)
Guide
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About the Book

Product Related Information

AWARNING

LOSS OF CONTROL

» Perform a Failure Mode and Effects Analysis (FMEA), or equivalent risk
analysis, of your application, and apply preventive and detective controls
before implementation.

» Provide a fallback state for undesired control events or sequences.
* Provide separate or redundant control paths wherever required.
» Supply appropriate parameters, particularly for limits.

» Review the implications of transmission delays and take actions to mitigate
them.

* Review the implications of communication link interruptions and take actions
to mitigate them.

» Provide independent paths for control functions (for example, emergency
stop, over-limit conditions, and error conditions) according to your risk
assessment, and applicable codes and regulations.

* Apply local accident prevention and safety regulations and guidelines.!

» Test each implementation of a system for proper operation before placing it
into service.

Failure to follow these instructions can result in death, serious injury, or

equipment damage.

1 For additional information, refer to NEMA ICS 1.1 (latest edition), Safety
Guidelines for the Application, Installation, and Maintenance of Solid State Control
and to NEMA ICS 7.1 (latest edition), Safety Standards for Construction and
Guide for Selection, Installation and Operation of Adjustable-Speed Drive
Systems or their equivalent governing your particular location.

AWARNING

UNINTENDED EQUIPMENT OPERATION

* Perform a risk assessment as per ISO 12100 and/or other equivalent
assessment in view of your use of EcoStruxure Control Engineering.

* Inyour risk assessment, consider all applicable regulations and standards
that apply to your development process and to your machine/process.

» Verify that your use of EcoStruxure Control Engineering is fully covered in
the definition of your software development process and that your software
development process meets all applicable regulations and standards.

» After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
commission or recommission the machine/process in compliance with all
regulations, standards, and process definitions applicable to your machine/
process.

» During commissioning or recommissioning of the machine/process, verify
the correct operation and effectiveness of all safety-related functions and
non-safety-related functions by performing comprehensive tests for all
operating states, for the defined safe state of your machine/process, and for
all potential error situations.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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About the Book

No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

+ Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

« After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Machines, controllers, and related equipment are usually integrated into networks.
Unauthorized persons and malware may gain access to the machine as well as to
other devices on the network/fieldbus of the machine and connected networks
because of insufficiently secure access to software and networks.

10
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About the Book

Schneider Electric adheres to industry best practices in the development and
implementation of control systems. This includes a "Defense-in-Depth" approach
to secure an Industrial Control System. This approach places the controllers
behind one or more firewalls to restrict access to authorized personnel and
protocols only.

AWARNING

UNAUTHENTICATED ACCESS AND SUBSEQUENT UNAUTHORIZED
MACHINE OPERATION

» Evaluate whether your environment or your machines are connected to your
critical infrastructure and, if so, take appropriate steps in terms of prevention,
based on Defense-in-Depth, before connecting the automation system to
any network.

« Limit the number of devices connected to a network to the minimum
necessary.

» Isolate your industrial network from other networks inside your company.

* Protect any network against unintended access by using firewalls, VPN, or
other, proven security measures.

* Monitor activities within your systems.

* Prevent subject devices from direct access or direct link by unauthorized
parties or unauthenticated actions.

* Prepare a recovery plan including backup of your system and process
information.

Failure to follow these instructions can result in death, serious injury, or

equipment damage.

For more information on organizational measures and rules covering access to
infrastructures, refer to ISO/IEC 27000 series, Common Criteria for Information
Technology Security Evaluation, ISO/IEC 15408, IEC 62351, ISA/IEC 62443,
NIST Cybersecurity Framework, Information Security Forum - Standard of Good
Practice for Information Security, and refer to Cybersecurity Guidelines for
EcoStruxure Machine Expert, Modicon and PacDrive Controllers and Associated
Equipment.

For reasons of Internet security, for those devices that have a native Ethernet
connection, TCP/IP forwarding is disabled by default. Therefore, you must
manually enable TCP/IP forwarding. However, doing so may expose your network
to possible cyberattacks if you do not take additional measures to protect your
enterprise. In addition, you may be subject to laws and regulations concerning
cybersecurity.

AWARNING

UNAUTHENTICATED ACCESS AND SUBSEQUENT NETWORK INTRUSION

» Observe and respect any and all pertinent national, regional and local
cybersecurity and/or personal data laws and regulations when enabling
TCP/IP forwarding on an industrial network.

* Isolate your industrial network from other networks inside your company.

» Protect any network against unintended access by using firewalls, VPN, or
other, proven security measures.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Consult the Schneider Electric Cybersecurity Best Practices for additional
information.

EIO0000004426.05
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About the Book

Terminology Derived from Standards

The technical terms, terminology, symbols and the corresponding descriptions in
this manual, or that appear in or on the products themselves, are generally
derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, faulf,
fault reset, malfunction, failure, error, error message, dangerous, etc.

Among others, these standards include:

Standard

Description

IEC 61131-2:2007

Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2015

Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013

Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010

Safety of machinery - General principles for design - Risk assessment
and risk reduction

EN 60204-1:2006

Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013

Safety of machinery - Interlocking devices associated with guards -
Principles for design and selection

ISO 13850:2015

Safety of machinery - Emergency stop - Principles for design

IEC 62061:2015

Safety of machinery - Functional safety of safety-related electrical,
electronic, and electronic programmable control systems

IEC 61508-1:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: General requirements.

IEC 61508-2:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: Requirements for electrical/electronic/programmable
electronic safety-related systems.

IEC 61508-3:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: Software requirements.

IEC 61784-3:2016

Industrial communication networks - Profiles - Part 3: Functional safety
fieldbuses - General rules and profile definitions.

2006/42/EC Machinery Directive
2014/30/EU Electromagnetic Compatibility Directive
2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control — Fieldbus for

use in industrial control systems

Finally, the term zone of operation may be used in conjunction with the description

of specific hazards, and is defined as it is for a hazard zone or danger zone in the

Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.

12
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Introduction to EcoStruxure Control Engineering -

Documentation

Introduction to EcoStruxure Control Engineering -
Documentation

Overview

EcoStruxure Control Engineering - Documentation is a reverse engineering tool
for controller applications that analyzes the source code and documents controller
application information from existing source code. The tool generates an abstract
representation of the program in the form of dependency trees and cross-
references, to help you to understand the controller application even if you are
unfamiliar with the system.

Because the documentation is generated from the source code, it is coherent with
the given version of the controller application. Therefore, the tool can provide
access to up-to-date program information even if the original paper documentation
is out of date.

The documentation generated automatically by the tool includes two dynamic
representations of the control program in the form of flow diagrams:

» A control flow for the procedures (call tree)
+ A data flow for the variables
These representations support you in, among others, the following tasks:

* Re-documentation: Create a representation of the structure of the controller
application.

« Design recovery: Support the understanding of the functionality of the
controller application.

EcoStruxure Control Engineering - Documentation is a Software as a Service
(SaaS) tool accessible using a web browser. It is an agnostic tool and supports
controller applications written for a variety of controller types and models such as
EcoStruxure™ Control Expert (formerly Unity Pro), EcoStruxure™ Machine Expert,
PL7-PRO, Siemens TIA Portal, Siemens Simatic Step 7, Rockwell Automation®
RSLogix 50009.

EI00000004426.05
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Registration, Login, My Account, Licenses and Sessions

Registration, Login, My Account, Licenses and

Sessions

Registration

Overview

The EcoStruxure Control Engineering tools are accessible using the cloud version
or using a dedicated server for your organization.

The URL of the cloud version is https://ecostruxure-control-engineering.se.app/.

If a dedicated server has been set up for your organization, the URL is available
from your system administrator.

In both cases, you must create a user account to use the tools.

Browser Compatibility

The following web browsers are supported:

Login Options

Mozilla Firefox from version 11

Google Chrome from version 16

Microsoft Edge from version 12

Microsoft Internet Explorer from version 10
Apple Safari from version 7

You can login to the EcoStruxure Control Engineering platform by using the
following options:

Schneider Electric Account
Legacy EcoStruxure Control Engineering

Step Action

1 Go to https://ecostruxure-control-engineering.se.app/.

Result: The following window appears:

EcodPtruxure Sign in with your unique Schneider Electric account
Control Engineering Use A Schneider Electric Account

Or use the legacy EcoStruxure Control Engineering login method

Use An EcoStruxure Control Engineering Account

English v

NOTE: You can choose either the legacy web platform accounts management
or Schneider Electric account. However, eventually the Legacy option will be
transistioned to the Schneider Electric option. You can create a Schneider
Electric account by clicking the Use A Schneider Electric Account button
wherein you can create a new account. In order to preserve the data you have
from the legacy account, use the same email address you used to create the
legacy. See Login using Schneider Electric Account, page 16.

14
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Registration

Registration procedure for the cloud version of EcoStruxure Control Engineering

tools:

Step

Action

1

Click on any one login options.

2

Click Sign up or Register Here.

Fill in the form with your first and last names, your phone number, your e-mail address
(which is used as your identifier) and select a password. Password requirements:

« Atleast one uppercase character

« Atleast one lowercase character

»  Atleast one numerical character

» Atleast one special character (such as "{”, ’/", “$”)
« Password length between 8 and 32 characters

Read the Terms and Conditions and, if you agree, select | agree to the Terms and
Conditions.

Click Sign Up.

Result: A verification e-mail is sent to you.

The verification e-mail sent to you contains a link that you need to follow.

Result: Your account is activated within a period of 48 working hours.

NOTE: If a dedicated server is set up for your organization, contact your
system administrator for details on the registration procedure.

EI00000004426.05
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Login

Login using Schneider Electric Account

This is the new method to login to the EcoStruxure Control Engineering platform.
Legacy accounts for the EcoStruxure Control Engineering platform will be
migrated to Schneider Electric accounts (SE accounts). If you are using the legacy
login method but want to migrate to the account login method, use or create a
Schneider Electric user account that uses the same email address as your legacy
account. After the first login with a Schneider Electric user account, subsequent
logins must be completed using your Schneider Electric user account.

Step

Action

1

When your registration on the Schneider Electric account is completed and your
account is ready, go to https://ecostruxure-control-engineering.se.app/.

Select Use a Schneider Electric Account, the following window appears:

»
(1) .
Comrol Engineering ECOSTruxure COI’IEI:0| Engineeriti’g
. 3

EcodZ truxure

Login or Register here

Welcome to the EcoStruxure Control Engineering

platform, where you can find industrial software

O Remember Me @

engineering tools to help better manage your

. Or continue with
control software lifecycle.

&g

Don't have a user account? R;

Enter your email address, click Next and then enter your password.

Result: After validation, you are redirected to the dashboard in EcoStruxure Control
Engineering platform.

Ecoll truure fuglin v st~ SChNeider
Control Engineering - Electric
COSTRUXURE CONTROL ENGINEERING  DASHBOARD ~ PROJECTS ~ TOOLS + SUPPORT LICENSES & ORDERS  GIVE FEEDBACK
Welcome Harshvarahan Sudha, this is your dashboard, start by creating a first application, thi flect your last work and help you to find the functionalities you will need
m Quick tour of EcoStruxure Control Engineering
The dashboard
Programs PR roiccts E
N The dashboard is the place where you can start all the operations you need to do.
Once you have created a program and started to work on it, then the dashboard will help you to resume what
Projects Personal Licenses manager  you were doing. It also contains a ot of useful links such as the links to the user manuals, to your licenses

. . manager, to your projects.
information s o yourprol

NOTE: For more information on Schneider Electric accounts, contact your
local Schneider Electric service representative.

16
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Login using Legacy EcoStruxure Control Engineering

Step

Action

1

Select Use An EcoStruxure Control Engineering Account, the following dialog box
appears:

Important notes about legacy login

In a future version of EcoStruxure Control Engineering, the legacy login method will no
loenger be possible meaning that the legacy accounts will stay available during some
time, and will then be migrated to a Schneider Electric account.

If you already have accounts on both the EcoStruxure Control Engineering platform and
through the unique Schneider Electric account using the same email address, you can
connect with your SE login to merge the accounts. Once the accounts are merged, your
personal data will come from your Schneider Electric account. Please note that once you
use the SE Login once, future logins must always use this method to connect to the
EcoStruxure Control Engineering platform.

We advise you to prefer connecting with your unigue Schneider Electric account.

Click Close to close the dialog box.

Enter your email address and password in the respective fields.

Click Login.

Result: The Dashboard window appears.

.
EcoPtrucure Frlish v sammmnareren « SChNeider
Control Engineering = LElectric
[ECOSTRUXURE CONTROL ENGINEERING -~ DASHBOARD ~ PROJECTS  TOOLS + SUPPORT v LICENSES & ORDERS  GIVE FEEDBACK
Welcome Harshvardhan Sudha, this is your dashboard, start by creating a first application, this view will reflect your last work and help you to find the functionalities you will need
Quick tour of EcoStruxure Control Engineering ey
The dashboard
Programs (A Foiecs
The dashboard is the place where you can start all the operations you need to do.
Once you have created a program and started to work on it, then the dashboard will help you to resume what
Projects Personal Licenses manager  you were doing. It also contains a Lot of useful links such as the links to the user manuals, to your licenses

information manager, to your projects

EI00000004426.05
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My account Page

My account Page When Using a Schneider Electric Account

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.

Step Action

1
In Dashboard window, click

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Schneider Electric Profile Tab

The Schneider Electric Profile tab lists the user personal information such as the
identity, phone number, country. To update this information, you need to edit your
Schneider Electric profile, which is accessible with the link provided in the
Schneider Electric Profile tab.

Third-Party Apps Settings Tab

The Third-Party Apps Settings tab allows you to generate an applicative
password to connect your application to EcoStruxure Control Engineering when
your application does not support the Schneider Electric account authentication.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between the different views available
on the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:

* you are using dedicated server and the server is configured to send the
emails.

» you are using cloud version (Not applicable for Monitoring)
My account Page When Using a Legacy EcoStruxure Control
Engineering

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.
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Step Action

1
In Dashboard window, click

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Profile Tab

The Profile tab lists the user personal information such as the identity, phone
number, country, etc. You can update this information at any time.

Password Tab

The Password tab provides the password change form. You can change your
password at any time.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between different views available on
the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:

* you are using dedicated server and the server is configured to send the
emails.

+ you are using cloud version (Not applicable for Monitoring)

EIO0000004426.05
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Licenses

Overview

Schneider Electric offers various license plans for EcoStruxure Control
Engineering tools.

Paid License Plans

Contact your local Schneider Electric representative for details on the available
license plans for EcoStruxure Control Engineering tools. A selection of licenses is
also directly available from Schneider Electric Exchange at https://exchange.se.
com/shop.

Free Trial Licenses

As of version 22.1 of EcoStruxure Control Engineering, free trial licenses are
available to help you evaluate the EcoStruxure Control Engineering tools after you
have created a user account. A trial license allows you to work with many of the
functions of the EcoStruxure Control Engineering tool. The number of results
provided by the tools and the available functions are limited if you use a trial
license. You can upgrade a trial license to a paid license.
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Sessions

Automatic Log-Out (Session Time-Out)

After 10 minutes of inactivity in an EcoStruxure Control Engineering session, you
are automatically logged out. If you work with multiple browser tabs, the most
recent activity in any of the tabs applies. For example, if you work in tab 1, but not
in tab 2, tab 2 does not disconnect you because there is activity in tab 1.

You are about to be logged out

There has been no activity on your account for the last 10 minute(s). With no action on

your side, we will log you out in 1 minute(s).
Stay Logged In

Multiple Sessions

If your credentials are used in multiple sessions, you receive a notification. For
example, if you are logged in and another session is established with the same
credentials, you receive the following message:

You are authenticated several times

Your credentials have been used to open several sessions of the EcoStruxure Control Engineering web platform.

As this may be unintended, here is the list of open sessions with your credentials. You may choose to close any
simultaneous sessions.

If you did not authenticate several times, then this situation may be due to your account being compromised. You
should close all other sessions and change your password. If the problem persists, then you need to contact your
local Schneider Electric representative for support.

D Date IP Address Qperating System Web Browser
\:‘ 2022-08-19 14:18:47 10.0.2.2 Llinux Mozilla Firefox
\:| 2022-08-19 16:19:54 10.0.2.2 linux Mozilla Firefox

‘ Close

The information on the connection date and time, the IP address, the operating
system and browser help you to determine whether or not a sessions is legitimate.
You can select and close a session with Close Session(s).
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Creating Projects and Programs

Introduction to Projects and Programs

Overview

Example

EcoStruxure Control Engineering provides projects and programs for you to
organize your work.

A project is a type of container that can hold programs. A project is not specific to
an EcoStruxure Control Engineering tool.

When you register with EcoStruxure Control Engineering, the platform provides
one default project for you.

A program is assigned to a project. A program is created in conjunction with one of
the tools provided by EcoStruxure Control Engineering. A program typically
comprises metadata you entered during its creation, the uploaded source code of
a controller application, and the results generated with the EcoStruxure Control
Engineering tools.

The EcoStruxure Control Engineering tools are launched from within a program.
Whether or not a specific EcoStruxure Control Engineering tool is available for a
program depends on the source controller/development environment you select
during the creation of the program (PLC Brand or PLC source brand).

Programs can be shared with other users.

Assume you have been assigned the task of improving a machine ABC with two
controllers X and Y. In a first step, you want to better understand the code of the
two controller applications. You create a project “Machine ABC”. Then you add
two programs to this project: “Controller X” and “Controller Y”.

In both of these programs, you run EcoStruxure Control Engineering -
Documentation to visualize the data flow and the control flow.

In a subsequent step, your task is extended to managing the creation of a new
version of the controller applications. You start by running EcoStruxure Control
Engineering - Verification in your programs to verify the existing code. You share
the two programs with the developers so they can access the results of the code
verification for assistance in updating the code.

In subsequent steps, you can upload intermediate versions of the updated code
into your program and re-run EcoStruxure Control Engineering - Documentation
and EcoStruxure Control Engineering - Verification to document the progress and
verify that your coding rules have been properly implemented.
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Creating Projects and Programs

Creating Projects

Procedure for creating a project:

Step

Action

1

Select PROJECTS in the top menu to display the Projects page.

2

Select Actions > New project.

Ecuﬂtruxurn
Control Engineering

ECOSTRUXURE CONTROL ENGINEERING = DASHBOARD PROIECTS

PROJECTS

Open projects Closed projects Shared applications

Open projects

MNew proj

Change owner

Delete

Provide a unique name for your project. Lowercase and uppercase are ignored which
means that, for example, the name of a project to be created cannot be “Controller xyz”
if you already have a project with the name “Controller XYZ”. Click Add to create it.

Click Add to create the project.

Result: The project is added to your list of projects on the Open projects tab.

Clicking a project in the list displays two tabs. The Overview tab provides general
information on the project. The Programs tab contains the list of programs
assigned to this project.

Creating Programs

There are three ways to start the creation of a program:

From outside of a project select TOOLS on the main menu
From the dashboard click New ...

From inside a project on its Programs tab select Actions > New program

EI00000004426.05
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Creating a program from outside of a project:

Step Action

1 From the main menu, select TOOLS.

2 Select the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from the dashboard:

Step Action

1 From the main menu, select DASHBOARD.

2 Click the New ... button for the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from inside a project:

Step Action

1 From the main menu, select PROJECTS.
2 Select the required project from the list.

3 Display the Programs tab of the project.
4 Select Actions > New program.

Owverview Programs

Programs

| Mew program
Change project
Change program owner
Launch “erification
Launch Documentation

Delete

Result: EcoStruxure Control Engineering prompts you for the tool to be used for the
program and starts the program creation wizard.
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Program Creation Wizard

Overview

A wizard guides you through the different steps required to create your program
and launch the execution of the selected EcoStruxure Control Engineering tool.

The project to which the new program is assigned depends on how the wizard is
started. If the wizard is started from outside of a project or from the dashboard, the
program is assigned to your default project. If the wizard started from inside a
project, the program is assigned to this project. In both cases, the project
assignment can be adjusted in step 1 of the wizard.

Refer to Creating Programs, page 23 for details.

Step 1 - Start

The first step consists of providing setup information on the program.

(1) Start 5 ) Parameters

3 License 4 Source file 5 Summary
Setup program i i Do

Assodate license Upload source files Summary of your program

x.
Application name documentation-app

x.
Customer name Schneider Electric

PLC site address :
PLC site city :
PLC reference :
PLC function :

Project: | default - Default project!

Validate And Next Step

Provide the following information:

+ The fields Application name and Customer name are mandatory. The
defined Application name is used to identify the program in the different
views of EcoStruxure Control Engineering.

+ Add additional information in the other fields so that you can identify this
program in your project.

Continue with the next step by clicking Validate And Next Step.

Step 2 - Parameters

The second step consists of selecting the development environment that was
used to develop the controller application.

;) Start 2 Parameters 5 ) License Source file Summary

Setup program information “ ) Documentation parameters Associate license # ) Uplood source fies 5 ) Summary of your program

PLC brand*:

Schneider-Electric EcoStruxure Control Expert ~

Previous Step Validate And Next Step

Select the PLC Brand and continue with the next step by clicking Validate And
Next Step.
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Step 3 - License

The third step consists of selecting the EcoStruxure Control Engineering license to
be used with your new program.

;) Start 5 | Parameters 3 ) License

4 Source file 5 Summary
Setup program information Documentation parameters Assodate license

Upload source files Summary of your program
ach of them to get more

Licensing possibilities for this program

Do not assign a license now
@ Do not assign a license now

Without selecting a license now, you won't be able to run a new
Documentation analyse. It is possible to assign a license later, and
continue with the program creation process.

Use a license ID

Use 3 free trial license

Previous Step

Chose one of the Licensing possibilities for this program:

Validate And Next Step

Licensing possibilities Description

Do not assign a license now Select this option when you will not run the analysis

immediately.

Use alicense ID Select this option when you have a license code. If you have
a license, but the license has not yet been assigned to your
user account, you can still use it by entering its identifier in

the License #id field.

Use a free trial license Select this option to launch a trial version of the tool. This is
not possible if you have already used all trial licenses that

have been associated with your user account.

Use a contract license This option appears when you have a contract for
EcoStruxure Control Engineering. This allows you to
automatically generate a license, as part of your contract, to

run the analysis.

Use an account license This option appears when licenses are available in your
account. In this case, you can select the license from a

dropdown list.

Click Validate And Next Step to continue.

If no license is available, you can still continue creating the program by clicking
Validate And Next Step. In this case, a license can be added to the program after
you have created the program. Without a valid license, the EcoStruxure Control
Engineering tool selected for this program cannot be executed.

Step 4 - Source file

The fourth step consists of uploading the file with the source code of the controller
application that you have exported from the development environment (refer to
Manufacturer-Specific File Export Procedures, page 45 for details). This source
code is the input material for EcoStruxure Control Engineering. Depending on the
EcoStruxure Control Engineering tool used for the program, you may be prompted
to upload additional files.
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1 5 | Parameters 3 ) License (4 Source file 5 ) Summary
Setup i D. parameters Associate license Upload source fles Summary of your program

pis optional, you ¢; ter.
DRAG YOUR FILES HERE
OR
Select Files...
Supported files
= XEF
Please provide a complete, up-to-date code export of your PLC code. If some code is missing in your program, this code will ;ng

not be analyzed.

More about the allowed files for your PLC brand

How to get supported files?

Previous Step Validate And Next Step

Drag and drop the files to the location indicated or click Select Files... to import
the files. Then click Validate And Next Step to continue.

If the input files are not yet available when you create the program, you can skip
the upload with Validate And Next Step and provide the files at a later point in
time. Without the uploaded input files, the EcoStruxure Control Engineering tool
selected for this program cannot be executed.

Step 5 - Summary

The fifth step displays a summary of the information you have provided in creating
your program.

Start Parameters 3 License 4 Source file 5 Summary

2

Setup program information Documentation parameters Assodate license Upload source files N Summary of your program
A name documentation-app Custol Schneider Electric
L N/A PLCr NIA
PLC site address NiA PLC function NiA
PLC brand Schneider-Electric EcoStruxure Control Expert
License N/A

In order to help you to understand the EcoStruxure Control Engineering - Documentation usages and limitations, the important Safety
information about the product is available through the Link below. You are able to retrieve them in the dashboard and in your programs
tabs. These messages are also available in the product documentation.

Read the safety information summary
Download the user guide (English)

Frevious Sisp m

Review the information. If you want to make modifications, click Previous Step to
return to the step you want to modify.

If the information is correct, click Create to create the program or click Launch to
create the program and to start the EcoStruxure Control Engineering tool selected
for this program (this is possible if you have selected a valid license and if you
have uploaded the required files).
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Accessing a Shared Program

If a program is shared with you, or if access to the program is not restricted (refer
to Sharing a Program, page 29), you can add it to your list of programs by
providing its unique 6-digit key. The unique 6-digit key can be found in the
program overview under Application key.

Procedure for adding a program to your list of programs using its unique 6-digit

key:

Step

Action

1

From the menu, select PROJECTS to access the Projects page.

Eco&truxuru .
Control Engineering

ECOSTRUXURE CONTROL ENGINEERING | DASHBOARD PROJECTS TOOLS SUPPORT

Click Shared applications to display the corresponding tab.

Opened projects Closed projects Shared applications

Enter the unique 6-digit key of the program in the field below User personal accesses
or in the field below One time access, depending on whether you want to add this
program to your personal records for access at a later point in time, or whether you
want to access it only once without adding it to your list of programs.

Open projects Closed projects Shared applications

Shared applications

User personal accesses

Here is the list of the applications shared explicitely with you by someane else or that you have decided to add for the applications shared with everyone

Your personal accesses is currently empty because no application have been shared with you yet. or you do not have added an application shared with everyone to this list

You can add any application shared with everyone in your list of applications by providing its application key below

One time access

You can access any application shared with you without saving it in your personal accesses by providing the application key below.

Click Add To My Applications or One Time Access.
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Sharing Programs with Other Users

Overview

You can share your programs with other users so that a team can work on the
same project. As the owner, you can share your program. Selected users with
whom you share your program cannot delegate their access rights, that is, they
cannot share this shared program with further users.

There are two ways of sharing a program:

+ Share with selected users: You choose who can access your program. By
default, other users cannot share this program because you are the owner.

» Share with everyone: Everyone can access your program.

Sharing with a Specific User

Procedure for sharing a program with selected users:

Step Action

1 Navigate to the Program page.

2 Select Admin > Collaboration > Users access rights to display the User
management.

3 Below Invited collaborators, select Actions > Add .

Overview

User management

Owner details

Invited collaborators.

4 Enter the name and the e-mail address of the user to be invited. You can enter the e-
mail address the user specified for registration with EcoStruxure Control Engineering,
or you can use any other e-mail address. You can also send an invitation notification to
the user. On a dedicated server, the invitation notification function requires a mail
server.

Users added to the list of invited users can perform the same actions as you, except for
sharing the program and modifying its settings. If you do not want invited users to
perform any further actions, deactivate the program with the Active application
checkbox in Admin > Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can revoke sharing by selecting the user(s) you want to remove from your
program and selecting Actions > Remove access.

Sharing with Everyone

Procedure for sharing a program with everyone:
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Step Action
1 Navigate to the Program page.
2 Select Admin > Settings.
3 Enable the checkbox Private application.

Users accessing your program can perform the same actions as you, except for sharing
the program and modifying its settings. If you do not want invited users to perform any
further actions, deactivate the program with the Active application checkbox in Admin

> Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function.

You can disable sharing with everybody by deactivating the checkbox Private
application. With this setting, only users explicitly invited can access your

program.
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Documenting Controller Applications

Creating a Documentation of a Controller Application

Procedure

No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be

semantically invalid, but syntactically correct. The tool may not be able to detect

such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

» Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

» After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Step

Action

1

Click Launch Documentation on the Program page.

Launch Verification Launch Documentation

Upload the source files of the controller application exported from your software
development environment as described in Program Creation Wizard, page 25.

Specify the files to be analyzed. If you do not want to generate the documentation for
each file, you can remove unwanted files by unselecting them in the list.

Start the documentation process by clicking Launch.

NOTE: The time required to generate your documentation depends on the size
and complexity of the source code of the controller application. Progress
information is displayed on the Program page.
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Displaying Documentation Code Results

Overview

Dashboard

After you run EcoStruxure Control Engineering - Documentation for the first time,
the Documentation tab provides access to the dashboard and to the
documentation details.

The dashboard provides a summary of the documentation results. To display the
dashboard, click Documentation > Dashboard.

The dashboard provides various elements, for example, amount of Programmable
Organization Units (POUs), variables and communication in your controller
application.

Example of a dashboard:
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Last analysis details

Current analysis date:

Amount of analyzes performed 1

Last analysis high-level overview

September 20,2021 16:29:21

First analysis date:

Here is an overview of your program's last analysis. For 3 more detailed result, have a look at the specific sections in this page, or consult the correspanding tabs in the Documentation menu entry.

6955

Variables

0

Communications

Amount of components found in the program

POU

Here are some statistics about the POU (Function blocks, Tasks, Functions..) in your PLC program. You an get more information using the interactive graph in the tab "Documentation”, entry "Control flow"

14

Mast_section.loop

The more a POU is doing calls to others,
the more it depends from others. ftis
usual to have the tasks calling more
other POUS than any other types of
POUS.

The metrics provided here can help you
to diagnose an issue with your program,
you can get deeper insights on your
program quality using EcoStruxure
Control Engineering - Verification if itis
available for your PLC programming

Most dependant POU environment.
Amount of call operations done by
your program in its POUs
O]
Searehs :
Halstead metrics
Amount of dependencies
Name Language oo ted Cyclomatic Statistical amountof L
Complexity bugs ty
adjust_steps fod [ 2 00326997 05
alarming list 0 1 0 0
ALRM_DIA ltteral O 1 0 0
chart_start_robot grafeet 0 3 00576257 2
control ladder 1 1 00393427 15
demo_controlexpert_m580init
lteral 1 1 [ 0
demao_controlexpert m5801oop
lteral 1 1 0 0
diag_system literal 0 1 00177169 08
diagnostic ladder 2 2 00728697 2
feeder literal 0 14 0118953 35
Overview of the program’s POUs
Variables

Here are some statistics about the variables in your PLC program. You ean get more information using the interactive graph in the tab "Documentation”, entry "Data flow"

Dsta type vanies
2150 s :
anl_in 7
Reads Andlor Writes ot B
any 172
any_array_ebool 3
Amount of read and/or write any_array_uint 28
operations done by your program
with its variables area_type g
arm_1_type 1
arm_2_type 1
array of int 1

92

Conveying_motor

Most used variable

POUs

Examples

Feeder_monitoring, Temperature_monitoring_2, Valve_selection, Temperature_monitoring_1
i_raw.channel, i_rawsim.channel, i_scale channel, i_filter.ch_in, i_norm.channel, i_phys.channel, i_filterch_out

o_norm channel, o_phys.channel, o_filter.ch_out, o_raw.channel, o_scale.channel, o_filterch_in

September 20, 2021 16:29:21

EcoStruxure Control Engineering - Documentation helps you to understand your PLC
application by he rel between thy inside it. It can show
how the Functions are called by the Tasks for instance, or which variable is used to
compute the value of another.

Documentation has been designed to be as easy-to-use as possible, s0 one can navigate
the program using graphs, switching from a variable to another with a simple click
Documentation is also aimed to serve as a backup of your program documentation as you
can download a standalone version of the results, or create screenshots to re-use
somewhere else of the graphs that matters for you.

Program’s POU relations

St |:|

ge_ref_anyin29, ge_ref_anyin13, eq_ref_anyin29, eq_ref_any.in13, gt_ref_anyin29, gt_ref_anyin13, lt_ref_any.in29, tt_ref_anyin13, le_ref_any.in29, le_ref_any.in13

U_blkm_bi SOURCE, U_comp_bi SOURCE, lL_blkm_ib DEST

U_dv16 RESULT, IL_and_ii SOURCE, L_mul RESULT, IL_blkm_bi DEST, ll_fin_i QUEUE, Il_comp_ii SOURCE, L_sens_ic SOURCE, LL_cmpr_i SOURCE, (_blkm_ib. SOURCE, Ul_cmpr_i DEST

regdfbarea
arm_1
arm_2

Table

Overview of the datatypes usage in the program’s variables

The term Program Organizational Unit (POU) is used for all programming objects
(programs, function blocks, functions, etc.) which are used to create a controller
application.

The dashboard displays the total count of programmable entity calls (for instance,
if POU1 calls POU3 and POU2 calls POU3, then this counter displays 2) in your
controller program.

EI00000004426.05
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Variables

Communication

You can get more information using interactive graphic in the Documentation >
Control flow. The metrics help you to detect the issue in your program.

The dashboard displays the total count of variables read and/or write operations
detected in your controller application.

You can get more information using interactive graphic in the Documentation >
Data flow. The metrics help you to detect the issue with your program.

A table is displayed listing the variables by datatype, the amount of variables
tagged with this datatype and examples.

The dashboard displays the total count of the communication (data exchanges
between other controller systems) detected in the program.
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The Data Flow View

General

The Data Flow view displays the relationships between variables of a controller
application from input to output, or vice versa.

This view displays how the values of the variables of the controller application are
read or written.

Displaying the Data Flow View

If you work with the EcoStruxure Control Engineering platform, select
Documentation > Data flow.

Documentation

Dashboard
Confrol flow
Data flow
Communication
Download (zip)

User Awareness »

NOTE: If you have downloaded a copy of the online results and want to work
with the downloaded copy, open the file index.html and click the button
Display Data Flow. Refer to Downloading an Offline Version of the
Documentation, page 43

Overview of the Data Flow View

The Data Flow view consists of four parts:
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riable o.
what depends on the:
List OF Variables
Read

Variable Location Type Comment ©

Robot_one Rotation_Lef

Q @ g
sweview 200w z00mour [l roos

00GLE
s Packaging Robot-Left_Rota

» List of variables to explore and settings for variables (top left, green frame)
» Dependency tree (bottom left, purple frame)

+ Language settings (top right, blue frame)

» Cross references snippets (bottom right, yellow frame)

List of Variables

The list of variables to explore lets you select a variable whose dependencies you
want to display. Click List Of Variables to select a variable.

| veaw | vviile | VoAU A VYUY

10 ~
y Mnemonic Memory reference Comment m
d Machine_running %Q0.3.3 - -

inst_watchpoint_3_out - -
inst_transportation_belt_3_out - -
inst_transportation_belt_1_out - -
inst_forming_6_out - -
inst_forming_3_out - -
inst_forming_5_out - -
inst_forming_2_out - -
inst_forming_1_out - -

inst_mixer_1_out - -

|< < Page| 1 ~ |/29 > >|

Functions for finding a variable:

* You can scroll through the list using the page buttons at the bottom of the
view. You can specify the number of variables to be displayed on a single
page using the dropdown list at the top left part of the table.

* You can filter the variables using the search field at the top right part of the
list. You can search by full or partial name, address and comment of a
variable.

Click the name of a variable to display it in the dependency tree and in the cross
references snippets parts of the page.
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Dependency Tree

The Data flow direction let you specify the way the dependencies are listed and
displayed. Write displays only the dependencies that write the value of the
variable. Read displays only the variables that are used to write to other variables
that are using the selected variable. Read and write displays both. This selection
also affects the way the Dependency tree, page 37 is displayed.

The list of variables is not exhaustive in the sense that if a selected variable does
not form a dependency (not written to or not used to write to other variables), it will
not appear in the list depending on the data flow direction you have chosen.

The Dependency tree is a graphical representation of the dependencies between
the variables. If a variable is used to compute or to determine another value, this
variable is displayed with a link to that other variable.

In the example above, the following is true of the selected (blue) variable (Data
flow direction is set to Read and write):

* The variable needs the values of the two linked variables displayed to its left
in order to calculate its own value.

+ The variable is used to calculate the values of the linked variables displayed
to its right.

You can explore the relationships between variables by clicking their names.
This view is helpful to locate the variables affected if code is modified in the

controller application, or to determine an unwanted value of a variable in the
running controller application.

Language Settings

The language settings let you select Ladder or Literal as the language for the
cross reference snippets.

Depending on the different types of variables, a representation of the code in
Ladder may not be available. In such a case, the cross references are displayed in
Literal.

Creating a flow chart from a controller application is a complex operation.
Depending on the complexity of the code and the different types of objects,
EcoStruxure Control Engineering - Documentation may not be able to generate a
precise flow if a variable is indexed and/or if its address is accessed indirectly
using a variable in the controller application.

Cross References Snippets

The cross references snippets part of the page displays how the variables are
used in the calculations of one another.

It consists of a code extract, displayed in Ladder or Literal language, that
highlights the relations. The code extract is not displayed in the same way it is
written in the original code in order to provide a synthetic view. Its logic still
remains the same as in the original code. The logic can be retrieved using the
location displayed behind each snippet.
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For instance, if you access a variable inside several nested conditional
instructions, the snippet compresses these instructions into a single one.

Section-MAST-Packaging_Robot-Left_Rotation-L-5-C:5

Robot_one Robot_one
robot Belt .Rotation
_running _running _left
| | I/I\I Sy
| | 111 \J
glaa]

The cross references snippets view is updated each time you select a variable
either in the list of variables or in the dependency tree.
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The Control Flow View

General

The Control Flow view displays the order in which the function or procedure calls

are executed or evaluated.

This view displays the way the logic of the controller application is called.

Displaying the Control Flow View

Select Documentation > Control flow.

Documentation ~

Dashboard

Control flow

Data flow

Communication

Download (zip)

User Awareness  »

NOTE: If you have downloaded a copy of the online results and want to work

with the downloaded copy, open the file index.html and click the button
Display Control Flow. Refer to Downloading an Offline Version of the
Documentation, page 43

Overview of the Control Flow View

The Control flow view consists of four parts:
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Name Full name Language Comment ©

ga H H
¢

DATTRATRATRATE

[@]e]la]

+ List of procedures to explore (top left, green frame)

» Dependency tree (bottom left, purple frame)

» Language settings (top right, blue frame)

» Cross references snippets (bottom right, yellow frame)

List of Procedures

The list of procedures lets you select a procedure whose call tree you want to
display. Click List Of Procedures to select a function, function block or task
(which are generally referred to as called “procedure” in the EcoStruxure Control
Engineering tools).

— | Laaager Literat
10 v Search :
b Procedure name Nb Dep references m
q demo_controlexpert_m580.loop 1
demo_controlexpert_mb80.init 1
MotorTwoDirections 3 I
Heating 1
control 1 I
m580.loop 1 I
mast_section.loop 14 I
weighing_material_a 1 I
mixer 2
heating 1 I
K < Page| 1 v /2 > >| :

Functions for finding a procedure:

* You can scroll through the list using the page buttons at the bottom of the
view. You can specify the number of procedures to be displayed on a single
page using the dropdown list at the top left part of the table.

* You can filter the procedures using the search field at the top right part of the
list. You can search by full or partial name of the procedure.
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Click the name of a procedure to display it in the dependency tree and in the cross
references snippets parts of the page.

Dependency Tree

The Dependency tree is a graphical representation of the dependencies between
the procedures.

p

p

transporta

.
packaging_...

The selected procedure is highlighted in blue. Each linked procedure displayed to
its left is a procedure that calls it. Each linked procedure displayed to its right is a
procedure that is called by it.

You can explore the relationships between procedures by clicking their names.

This view is helpful to determine how the procedures call each other.

Language Settings

The language settings let you select Ladder or Literal as the language for the
cross reference snippets.

Depending on the different types of procedures, a representation of the code in
Ladder may not be available. In such a case, the cross references are displayed in
Literal.

Cross References Snippets

The cross references snippets part of the page displays how the different
procedures call each other.

It consists of a code extract, displayed in Ladder or Literal language, that
highlights the relations. The code extract is not displayed in the same way it is
written in the original code in order to provide a synthetic view. Its logic still
remains the same as in the original code. The logic can be retrieved using the
location displayed behind each snippet.

For instance, if you call a procedure inside several nested conditional instructions,
the snippet compresses these instructions into a single one.
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Section-MAST-Mixer-L-:25-C:27

refill_feeder

Mixing
_daone

_II_

T#10s —

L EM

ton

ENC

Et

Fill
_feeder

Refill
[~ _feederEt

EIEYEY

The cross references snippets view is updated each time you select a procedure
either in the list of procedures or in the dependency tree.
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Downloading an Offline Version of the Documentation

You can download a copy of the EcoStruxure Control Engineering -
Documentation online results from the server to your local PC.

Download procedure:

Step

Action

1

Navigate to the Program page.

2

Select Documentation > Download (zip).

Documentation

Control flow

Data flow

Download (zip)

A ZIP file with the documentation in HTML format is downloaded to your PC.

Extract the contents of the downloaded ZIP file and open the file index.html if you want
to work with the downloaded documentation.

NOTE: Security policies in your organization may keep your browser from
displaying certain or all HTML content stored on your PC. In such cases, contact
your administrator to resolve this condition.
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Limitations of the Free Trial Version

If the documentation has been created with a free trial license of EcoStruxure
Control Engineering - Documentation, the results are limited as shown in the
following list.

Functionality Trial version Paid license

Control Flow

List of procedures Included Included

Number of dependencies per | Limited to 3 No license limitations
procedure

Number of cross-references Limited to 2 No license limitations

per procedure

Data Flow

List of variables Included Included

Number of dependencies/ Limited to 3 No license limitations
influences per variable

Number of cross references Limited to 2 No license limitations

per variable

Flow direction Unidirectional Unidirectional and bidirectional

Communications

Number of communications Limited to 2 No license limitations
Other features

Save tree view Unavailable Included

Download offline version Unavailable Included

NOTE: Free license does not allow to download the cross-references.

The functions that are not available or limited are highlighted on the
Documentation tab of your program:

e Trial: Limited results
* Unavailable: Function is not accessible
* No indication: No license limitations

Documentation ~

J Control flow

Data flow QLG

Communication

Licensed version features

User Awareness >

You can upgrade to a paid license to get the full functionality of your program.
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Manufacturer-Specific File Export Procedures

EcoStruxure Control Engineering tools use the source code files of controller
applications as input files. These files are exported from the corresponding
software development environments. The following sections provide information
on generating these export files in various software development environments.

EcoStruxure Control Expert (.XEF / .ZEF File Export)

Export the EcoStruxure Control Expert (formerly Unity Pro) controller application
to an XEF or a ZEF export file in order to be processed with EcoStruxure Control
Engineering tools.

To export the file, you can use the EcoStruxure Control Engineering Import/Export
tool. Select SUPPORT > DOWNLOADS.

It is also possible to export the files using the EcoStruxure Control Expert menu:

Step Action
1 From the menu, select File > Export application....
2 In the Export application... dialog box, provide a name for the XEF or ZEF file.
3 If required, modify the storage location for the XEF or ZEF file.
4 Click Save.
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EcoStruxure Machine Expert (.EXPORT File Export)

Export the EcoStruxure Machine Expert controller application to an XML export
file (with the extension .export) in order to be processed with EcoStruxure Control
Engineering tools.

Procedure:
Step Action
1 From the menu, select Project > Export....

'Project FBD/LD/IL  ETEST Build  Online

o -

& @

Add Object

Add Folder.

Scan For Devices...
Update Device...
Online Config Mede...
Edit Object

Edit Object With..
Add Module...

Set Active Application

Project Information...
Project Settings...
Open “Update Project” dialog...

Project Localization

Document...
Compare...
Commit accepted changes

Compare with device..,

13

Export...

Import...

Export PLCopenXML...
Import PLCopenXML...
Import of motion profiles

User Management

Mass Storage (USB or SDCard)...

You can export particular objects or a full tree. From the tabs in the Export dialog,

select the objects to be included in the export file.
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Step

Action

Export

Please select the objects which are to be exported:
Devices  PQUs
=3 Untibled?
- M Controller (TM241C24R)
=-[¥] Bl PLC Logic
= £} Application
= ) DOORS
iH DOOR (FB)
AF] DOORS_CTRL (FUN)
4¥] LS_SENSOR (FB)
= ) VALVES
@] vALVE (FB)
HF] VALVES_CTRL (FUN)
4] wL_sensoR (FB)
@ o
ﬂi] Library Manager v

[ One file per subtree

Storage version:
vV19.2.3.0

[ o

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
EcoStruxure Machine Expert version that you select from the dropdown list
Storage version. To re-import the file, this EcoStruxure Machine Expert version is

used.

Click OK and provide a file name and a folder name as prompted.

Click Save.
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PL7 Pro (.FEF File Export)

Export the PL7 Pro controller application to an FEF export file in order to be
processed with EcoStruxure Control Engineering tools.

Procedure:
Step Action
1 From the menu, select File > Export application....
2 In the Export application... dialog box, provide a name for the FEF file.
3 If required, modify the storage location for the FEF file.
4 Click Save.
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3S CODESYS V3 (.EXPORT File Export)

Export the CODESYS V3 controller application to an XML export file (with the

extension .export) in order to be processed with EcoStruxure Control Engineering

tools.

Procedure:

Step

Action

1

i1 Add Object D
) Add Folder...

Scan For Devices...

Update Device...

Edit Object

Edit Object With...

Online Config Mode...

Set Active Application

H Project Information...

@ Project Settings...

Project Environment...
Project Localization ’

& Document...
¥ Compare...

Commit accepted changes

From the menu, select Project > Export....

File Edit View | Project | Build Or

1

nit
r (1

2}

Export...

Import...

Export PLCopenXML...
Import PLCopenXML...

User Management 4

You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.

Export

Please select the objects which are to be exported:
Devices POls  Modules

=l Compressor

=[4 B0 PLC Logic
= £ Application

= 2 Generic Units
¥ Compression_Unit (FB)
{9 Pressure_Sensor (FB)
@ Compression_Units
i Library Manager
{1 Compressor_State_Manager (FUN)

= @ [ CODESYS_Control_RTE_V3 (CODESYS Control RTE V3)

["]0ne file per subtree

Storage version:

7| CODESYS V3.5 SP12 Patch 1
[

Cancel

L T —— T — S ——

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific

CODESYS version that you select from the dropdown list Storage version. This
version is then used to re-import the file in CODESYS. If you work on CODESYS
V3 code, select a version from the version 3 family (CODESYS V3 ...).
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Step Action
3 Click OK.
4 Provide a file name and a folder name as prompted and click Save.
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3S CODESYS V2 (.EXP File Export)

Export the CODESYS V2 controller application to an EXP export file in order to be
processed with EcoStruxure Control Engineering tools.

(with the default settings, a selected item has a blue background), then click OK.

Step Action
1 From the menu, select Project > Export....
File Edit Project Insert Extras Online Window HEE
2= Build F11
———  Rebuildall
m Clean all
Ej[ll: Load download infermation...
~[g] Object
o E Project database
B Wa
----- B Options...
_____ 'E:ﬂ Translate into other languages
g] Wl Document...
Export...
Import...
Siemens Import
Merge...
Compare...
Project Info...
Global Search...
fRlahal Bamlara
2 In the Export Project dialog box, select the objects to be included in the export file
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Step Action
Export Project X
Cancel |
I” Ore file for each object
3 Click OK and provide a file name and a folder name as prompted.
4 Click Save.
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BECKHOFF TwinCAT V3 (.XML File Export)

Export the Beckhoff TwinCAT controller application to an XML export file
(PLCopen) in order to be processed with EcoStruxure Control Engineering tools.

Step

Action

Gre-Sdd 4B

Fle Fdit View Project Buld FSDADAL Debug TWnCAT PIC Tools Scope Window telp

PR —

BB reiase

~ || TwinCAT RT (x64) -|l
n gl

[Solution Explorer

o
2 Cause (ENUM)
22 Direction (ENUM)
¢ STATE (eNUM)

#2.cp pLCane
B PicTask (PIcTask)
MAN
8 Visualzation Manager

TART
MANAGMENT (BRG)
M

In the Solution Explorer window, select the project.

jep_project - Microsoft Visual Studio

fobjectindex

O]

azlelesi @

Scope: PUP_MANAGHENT

ZoEm

Variable Access Type Sope  Address  Location Comment
PUMP MARAGUENT  ipump_stote Decaraion 2001 el Lo 30ec)
PUMPMARAGUENT it e 2001 el Networc 2| Operand .
2 PROGRAM PUMP_MANAGHENT
T scope  Name Address  Datatype  itialization Comment  Attributes ~O
SRl pump state a0
@ VAR THM G pump_started s00L v
non_bool2 na_sortia_bool
P £
]
M[+[a) [100% @

4l 1340

w
Fle Edit View Project Buid FBOADAL

Bl 1o

Debug TWINGAT PLC Tools Scope Window Help

Release -1 TwinGAT RT (50)

o g

= glox

Login

sura
e
%20 Creckallabiecs
S Gen
- mou
@g M

& Import PLCopenXL.
' Export PLCopenXML

Save as orary

|12 liovjectndex

Right-click the project and select Export PLCopenXML..

jep_project - Microsoft Visual Studio

SRS E RE

O & e FEENE

-

=oEm

Remore

G propertes

+ 9 Super PUMP F5)
i 1S RUNNING

B PicTask PIcTask)
AN

@ Visualzation Manager

oel

AltsEner

PROGRAM PUMP_MANAGHENT

-~ casle es Scope: PUMP_MANAGHENT - an
~frov Variable Access Type Scope  Addes  Locaton Comment

PUMP MARAGUENT i, state Decaraion 200 el Lo 30ec)

PUMP MANAGUENT  iL_pump.stae e 200 el Netwotc 2 Oparnd it

S AR _pump_state
S AR THM_f_pump_started

200

Adoress Datatype nitalization Comment

[

PRS-

Bureau » T

A (100 6V

=
- 3 0

| icp_project - Microsoft Visual Studio - f
= Export PLCopenXML File
h o cercs V[ | Rechacherdasicerc »
Oganser - ) Bx Bx
8 Microsoft Visual Studio 2010 4 Dossiers (6) Al @] scope: punp_masacuenT - an
e Scope Acwess Locaon Conment
oo e Luen 000 s L3001
[ so01 s Moot 2 O .
41l Bureau 15
R ooamens
2 jparzni
T cer ] L
223 Bibioteques N
 Documents
mages
4 Musique ]ds Musique
Nom du e JCP LGl N
Type: PLCoperdOL e o o
PROGU PP MANAGHENT
= Ve s cossers seve ] [ Amier | Bos e witaizaion Comment  Aiutes ~[a]
ot
E""‘U N 22 AR IO pump_started 0oL v
Rstaar it 1)
) PUMP_MANAGMENT (PRG) A N
4 1 Super PUMP (FB) N S

ErE—
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PHOENIX CONTACT Multiprog v5.5 (.XML File Export)

Export the MULTIPROG controller application to an XML export file in order to be
processed with EcoStruxure Control Engineering tools.

Step

Action

1

From the menu, select File > Export....

File| Edit View Project Build Online Extras ?

D| New Project...

5

;-,m Close Project
':}:| Delete Project...

Save As Template...

Delete Template...

-

(47

AS NEeTWOrK 1em

3 @j| Open Project / Unzip Project.. CTRL+0O
: Save Project As / Zip Project As...

o

z
CTRL+N T

-

!

Export...

Import...

Enter password...

(47

LA

'l-'4|

ave All

I

o |

Print Setup...
Print Project...

r“].l

[ye]

Exit

Select Export PLCopen xml file.

Import / Export

Extended IEC61131-3 Export

OK. |

Cancel

Description:

Export in PLCopen xml format.

Provide a name for the export file.

Click Save.

As MULTIPROG can export the controller application in different versions of
PLCopen, there may be differences in the way your EcoStruxure Control
Engineering tool processes the export file, depending on the PLCopen version.
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Rockwell Automation® RSLogix 5000® or Studio 5000 (.
L5K File Export)

Export the Rockwell Automation® RSLogix 5000® controller application to a L5K
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Save as....

2 In the Save as... dialog box, provide a name for the L5K file.

3 If required, modify the storage location.

4 Select the file type: RSLogix 5000 Import/Export File (*.L5K).

5 Click Save.
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Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File

Export)

Overview

The following steps are required to process a Siemens SIMATIC STEP 7
controller application with EcoStruxure Control Engineering tools:

Set your SIMATIC STEP 7 workshop to German abbreviations (mnemonics).
Create and export the symbols of the controller application to an .ASC file.
Create and export the contact code (CONT) to an .AWL file.

Create and export the graph blocks (GRAPH) to a .GRY files.

Compile the CFC code (if any) to create the corresponding SCL sources.
Export structural codes (SCL) to .SCL files.

Setting German Mnemonics

Before creating the export files, set your SIMATIC STEP 7 workshop to German
abbreviations (mnemonics):
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Step Action
1 From the menu, select Options > Customize....
z  Change Log L
L TextLibraries v L
E Language for Display Dewvices.., Et
ili 3
u Manage Multilingual Texts ol
L Rewire.. Cl
B Run-Time Properties... Cl
T Cl
T Carnpare Blocks.. TL
£  Reference Data FTL
#d  Define Global Data Tl
€ Configure Metwark T
T Cl
T Simulate Modules E
£ Configure Process Diagnostics B
T ] B
g  FEditsafety program B
Chx Data 3
Set PGSPC Interface...
2 Display the Language tab.
Sabune I Meszage numbers I Archiving
| I Language | I General I Date and Time of Day I Wig
i — Mational Language — Mremonics
! english
deutzch a & Geman JE1.D 5 A4.0
frangais  Engish  Al1.0 5040
ezpafiol
italiano
Cancel Help
3 Select German mnemonics.
4 Click OK.
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Creating an ASC File

Step Action

1 Right-click the symbols table in your program folder and select Open object.
% Ecluzel Obiject name | Symbalic name | Type
E‘" SIMATIC 300(1) (B Sources Source Folder
El-{z0 Programme S7(1]
-@ Blacs

Cut Ctrl+3X
Copy Ctrl+
Paste Ctrl 4
Delete Del
PLC 3
Print 3
Renatre F2
Ohject Properties.., Alt+Return
Special Object Properties 3

2 From the menu of the symbols editor, select Symbol Table > Export....

dit  Insert ‘iew Options  ‘Window Help

Ctrl +0 j_

Close Ctrl+F4

Sawe Ctrl+3 Prm

5[0 i > || [~
=)

r
r
FHIT.., CTHi+F er
Print Preview... ver
Page Setup... e
e
3 Select ASCII Format (*.ASC).

ISymboIs.asc

it Drata Interchangé Farmat [* DIF]
Syztem Data Format [* 5DF)
254l [A5C," . SEQ." DIF.".S5DF)

4 Provide a name and select a directory for the .ASC export file.

5 Click Save.

Creating an AWL File

To create an .AWL file, first generate the LIST source for the code blocks
developed in the languages CONT, LIST and LOG.
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Step Action
1 Right-click a CONT, LIST or LOG source and select Open Object to open the CONT/
LIST/LOG code editor.
E--% Ecluzel Object name | Symbalic name | Created in
=l SIMATIC 300(1) :
=[] CPU 31402 DP
E-+{7] Programme 57(1] Chrl + A+
= AR
il Cut Chrl +3 S0l
oF Copy Ctrl +C -
oOF Paste Crl +4 arL
4F Delete Del st
iF STL
3 F Ihsert Mew Object F | STL
OF PLC » | STL
ik ] STL
O F Rewvire... 5CL
0l CompareEBlocks.. DE
Em gy Reference Data » | DB
oD Print . DB
oo " DE
Rename F2
Ohject Properties.. Alt+Return
Special Object Properties 4
2 From the menu, select File > Close to close all open objects.
Edit Insert PLC Debug View Options ‘Window Help
Mew.., Ctrl+M
| Open. Ctrl+0
- ('l kL TRIC i
r Ctrl+F4
£ Sawve Ctrl+3 1
£ Sawve A,
B Store Read-Only ...
£
Properties...
E Check and Update Accesses
Check Consistency Crl +8E+E
Compile Ctrl+B
Generate Source.., Chrl+T =
Print... Chrl+F T
Print Presview..,
Page Setup...
3 From the menu, select File > Generate source... to generate the program source.
iewy  Options  Help
Ctrl+[
Ctrl+0
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Step Action

4 Provide an object name and click OK.

Entry paitit: Wiga

IF‘roiect LI IEomponent wigw LI = Online @ Oifline
MHame: Storage path:

IEcIuse1 LI I | Browse... |
E--@ Eclusel code_ladder section_laddder

E-E] SIMATIC 30001)
=-[§ crustaczoP

. | |
I Obiect name:  [CONT_LIST_LOG] |
Ubiject type: ISTL Source ;I
5 Click All to select all program blocks and select the options Sort according to

program structure and Symbolic addresses.

Mate: Automatic generation of single sources per block:
Menu "Options’ » "Cugtomize’ in the "Sources' tab

Fath: Eclugel SIMATIC 30001 \NCPU 314C-2 DPY..
Blocks Mat Selectad: Blocks Selected:

M arne/F anily:
[ User created F-FBs, F-FCs and F-DEs —Addreszes
v Include reference blocks [

¥ Sort according to program structure {* Sumbalic

I 0K | Cancel Help

6 Click OK to confirm.

If your controller application contains safety-related blocks, export those blocks in
a separate AWL file. Refer to Safety-Related Applications, page 63 for details.

Creating a GRY File

The .GR7 sources have to be created for each GRAPH blocks separately. Repeat
the following procedure for each GRAPH block to be exported.
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Step Action
1 Right-click a GRAPH object and select Open Object.
_ommande
Ctrl + soL
Copy Ctrl+C oL
Paste Crl -+ L
Delete Del 5TL
STL
Insert Mew Object » STL
PLC 3 STL
) SCL
Rewvire.., OB
2 From the menu, select File > Generate Source File.
Edit Insert PLC Debug “iew Options ‘Window Help
MNews,. Ctrl+M |
Open... Ctrl+0
Clase
Sawe Ctrl+5
Sawe fs,.,
Properties...
Cansistency Check Ctrl + 21t +K
Carnpile Ctrl+B
Modify/Sdapt Instance DB Mumber...
Ctrl+T
e
Print... Ctrl+P
Primt Presview..,
Page Setup...
3 Provide a name for the GRAPH object.
Entry paint: Wiga:
IProiect LI IComponent wiEw LI  Orline & Offline
Mame: Storage path:
[Echset = [eoe ||
- Eclusel
=l SIMATIC 300[1]
&-[@ cPusaczoP
El-{z2] Frogramme 57[1]
Sources
Blocs
| |
Obiject name: |GrapH I
Object type: lmce ;I
Cancel Help |
4 Click OK to confirm.
5 Repeat the procedure for each GRAPH object to be exported.
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Creating a CFG File

The CFG file is required for analyzing the communication and the hardware
configuration of the station.

Step Action
1 Double-click your CPU's links in the main window to open NetPro.
2 In the NetPro window, double-click the CPU of the station to be exported open the HW
Config utility.
3 From the Station menu, select Export... to export your station configuration (leave the
default settings in the dialog).
4 If the controller application contains CFC code, compile the code to generate the

corresponding SCL source files which are the files processed with EcoStruxure Control
Engineering tools. To do so, open the CFC code editor by clicking its icon in the toolbar
of the main window .

ioix]
[ Chart Edit Insert CPU Debug View Options Wwindow Help =&l x|
DEs|iee@mEE=s a8 ex=s=xEEkD e 2E0]

T New chart
New Text

]

l— i)
I Find initial letier 4 AhafE 7] [ ——

Press F1 for help = [A/Sheste |08

szl
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Step

Action

5

Compile the code with the options Entire program and Generate SCL sources and
click OK.

Compile program il

Compile Chartz az Program |

CPL: CPU 313-3 PM/DF
Pragram name: MP34NCPU 313-3 PHADPAST Program
—Srnone

| &' Entire program

|f" Changes anly

¥ Generate module divers Block Driver Settings. ..

¥ Generate SCL source

Cancel Help |

The generated SCL source file can then be exported like other source files (refer to
Exporting Files, page 67).

Ohject name | Symbalic name | Type

DE11_Alam_DE STL Sourc
MP34_Comple
FileEm

te: STL Sourc

Zipen Object Chrl+Al+0
Cut Chrl+

Copy Chrl+C

Paste el

Delete Del

Insert Mew Object 4
PLC ’

p= T Lo

Print +
Rename F2

Ohject Properties. .. Alk-+Return
Special Cbject Properties 4

Safety-Related Applications

A safety-re

lated controller application contains two code parts:

» The non-safety-related code part

» The safety-related code part

Procedure

for exporting controller applications that contain safety-related code:

Step

Action

1

Export the .ASC file that contains the database for the safety-related code and for the
non-safety-related code (refer to Creating an ASC File, page 58).

Generate the sources for the non-safety-related code parts (refer to Creating an AWL
File, page 58 and Creating a GRY7 File, page 60).
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Step

Action

Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

Mate:

Automatic generation of single sources per block:
Menu "Options’ » "Cugtomize’ in the "Sources' tab

Fath: Eclugel SIMATIC 30001 \NCPU 314C-2 DPY..
Blocks Mat Selectad: Blocks Selected:

M arne/F anily:

[ User created F-FBs, F-FCs and F-DEs —Addreszes
v Include reference blocks [
¥ Sort according to program structure {* Sumbalic

I ak | Cancel

Help

Click OK to confirm.

Follow the procedure for Creating an AWL File, page 58 until the dialog Generate
source Safety is displayed.
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Manufacturer-Specific File Export Procedures

Step

Action

6

Select the option User-created F-FBs, F-FCs and F-DBs and click OK to confirm.

Generate source Safety

Mate: Automatic generation of single sources per block:
Menu "Options’ » "Cugtomize’ in the "Sources' tab

Fath: Eclugel SIMATIC 30001 \NCPU 314C-2 DPY..
Blocks Mat Selectad:

@ Bl

M arne/F anily:

Blocks Selected:

Salety Block

v User created F-FEs, F-FCz and F-DBs Addresses
I " Absolute
= * Symbalic
™ Source contains checksum of the blocks

ak Cancel

x|

Help

Create a .dif file (refer to Creating a dif File, page 65). The .dif file is used to determine

whether code is safety-related.

Creating a dif File

A .dif file is created in the SIMATIC Manager of SIMATIC STEP 7 in the following

way:
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Manufacturer-Specific File Export Procedures

Step Action
1 From the menu, select Options > Reference Data > Display.
LT Window Help
ustomize... Ctrl+Alt+E ;I Ny | B8 &
S0 aiEis i’ reated in language | Size in th
Change Log 2
Text Libraries v iTL
Language far Display Devices.., EHLAF'H
Manage Multilingual Texts 4
Rewvire... CL
Rur-Tirme Properties...
{ Ctrl +2]t+R,
Define Global Data
Confi Metwork
onfigure Metwor Generate
Simulate bModules
) . ) Delete
Configure Process Diagnostics
) =
Edit safety program B
Cioc Data v 1B
B
Set PG/PC Interface..,
2 In the Display S7 reference data dialog, select the option regenerated? and click Yes.
& Should the reference data be ...
" ypdated?
Yes I Mo | Cancel Help
3 In the Customize dialog, select the option Program Structure and click OK to display

the program structure.

" Crosseferences

& Program Stucture
Uruzed Symbols
" Addreszes withaut Symbal

—Wiew to Be Opened

tput, Bit Memory, Timers, Counters)

¥ Display this message every ime a project is opened,

Help |
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Manufacturer-Specific File Export Procedures

Step

Action

4

From the menu, select View > Export to open the Save dialog box.

Reference Data  Edi

| &| %|H)

indows  Help

" Cro:

Assignment

3 References

v Prograrm Structure
Unused Symbaols
Addresses without Syrmbol

Cross References for Address

Block{syrmbol),

=-1 S7 Prograd

=20 oe1 {1y

O FC1l  Filter...
® DBLCI <. )
® DB2(C 0]
® DB3 (| v Toolbar 0]
® DB4 (Tl w Status Bar o]
® FC2 (A 2]
B8 FC3 (M  Update F5 2]
[ I = B e T el =1

Provide a name for the .dif and click Save.

Exporting Files

After you have created the files, export them from SIMATIC STEP 7:

Step

Action

1

Select the LIST, GRAPH (or .AWL and .GRY7 files) and SCL sources that you have
generated.

Right-click the sources and select Export source....

%File Edit Insert PLC ‘“iew Options Window Help
D |29a | 4 B |olm o 5% i
E--% Ecluse

= SIMATIC 300(1)
=-[f cPU 34C2 DR
B s

| & || < NoFiter >

Surbolic name

Object name Type

Open Chject Ctrl+Alt+0

Cut Chrl +X

o1 Copy Ctrl+C
Paste Chrl +4
Delete Del
Insert MNew Object 3
PLC 3

Print 3

Special Object Praperties »

Select a file name and a storage location and click Save.
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Manufacturer-Specific File Export Procedures

Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export)

Export the Siemens TIA Portal SIMATIC STEP 7 controller application to a ZIP
export file in order to be processed with EcoStruxure Control Engineering tools.

The export can be performed automatically with the EcoStruxure Control
Engineering - Import/Export tool. Select SUPPORT > DOWNLOADS.

Refer to the EcoStruxure Control Engineering - Import/Export user guide for
details on the export procedure.
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