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Safety Information

Safety Information

Important Information

Please Note

Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an
electrical hazard exists which will result in personal injury if the instructions are not
followed.

hazards. Obey all safety messages that follow this symbol to avoid possible injury or
death.

A DANGER

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious
injury.

2 This is the safety alert symbol. It is used to alert you to potential personal injury

A WARNING

WARNING indicates a hazardous situation which, if not avoided, could result in death or
serious injury.

A CAUTION

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or
moderate injury.

NOTICE

NOTICE is used to address practices not related to physical injury.

Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

Before You Begin

Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.

EIO0000004427.03



Safety Information

AWARNING

UNGUARDED EQUIPMENT

» Do not use this software and related automation equipment on equipment
which does not have point-of-operation protection.

* Do not reach into machinery during operation.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only you, the user, machine builder or system integrator can be aware of all the
conditions and factors present during setup, operation, and maintenance of the
machine and, therefore, can determine the automation equipment and the related
safeties and interlocks which can be properly used. When selecting automation
and control equipment and related software for a particular application, you should
refer to the applicable local and national standards and regulations. The National
Safety Council's Accident Prevention Manual (nationally recognized in the United
States of America) also provides much useful information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch points or
other hazardous areas and serious injury can occur. Software products alone
cannot protect an operator from injury. For this reason the software cannot be
substituted for or take the place of point-of-operation protection.

Ensure that appropriate safeties and mechanical/electrical interlocks related to
point-of-operation protection have been installed and are operational before
placing the equipment into service. All interlocks and safeties related to point-of-
operation protection must be coordinated with the related automation equipment
and software programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.

Start-up and Test

Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start-up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check are made and that enough time is allowed to perform complete and
satisfactory testing.

AWARNING

EQUIPMENT OPERATION HAZARD
» Verify that all installation and set up procedures have been completed.

» Before operational tests are performed, remove all blocks or other temporary
holding means used for shipment from all component devices.

* Remove tools, meters, and debris from equipment.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Safety Information

Follow all start-up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and temporary
grounds that are not installed according to local regulations (according to the
National Electrical Code in the U.S.A, for instance). If high-potential voltage
testing is necessary, follow recommendations in equipment documentation to
prevent accidental equipment damage.

Before energizing equipment:
* Remove tools, meters, and debris from equipment.
* Close the equipment enclosure door.
* Remove all temporary grounds from incoming power lines.
» Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments

The following precautions are from the NEMA Standards Publication ICS 7.1-
1995:

(In case of divergence or contradiction between any translation and the English
original, the original text in the English language will prevail.)

+ Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

* Itis sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

+ Only those operational adjustments required by the operator should be
accessible to the operator. Access to other controls should be restricted to
prevent unauthorized changes in operating characteristics.

EIO0000004427.03



About the Book

About the Book

Document Scope

Validity Note

Related Documents

The present user guide describes the functionality provided by EcoStruxure
Control Engineering - Monitoring.

This document has been updated for the release of EcoStruxure Control
Engineering V23.1.

The characteristics that are described in the present document, as well as those
described in the documents included in the Related Documents section below,
can be found online. To access the information online, go to the Schneider Electric
home page www.se.com/ww/en/download/.

The characteristics that are described in the present document should be the
same as those characteristics that appear online. In line with our policy of constant
improvement, we may revise content over time to improve clarity and accuracy. If
you see a difference between the document and online information, use the online
information as your reference.

Title of documentation Reference number

EcoStruxure Control Engineering - Monitoring - EI00000004427 (eng)
User Guide (this user guide)

EcoStruxure Control Engineering - EI00000004426 (eng)
Documentation - User Guide

EcoStruxure Control Engineering - Converter - EI00000004425 (eng)

User Guide

EcoStruxure Control Engineering - Verification - EI00000004424 (eng)

User Guide

Cybersecurity Best Practices CS-Best-Practices-2019-340
EcoStruxure Control Engineering, Hardening EIO0000004982 (eng)
Guide
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https://www.se.com/ww/en/download/
https://www.se.com/ww/en/download/document/EIO0000004427/
https://www.se.com/ww/en/download/document/EIO0000004426/
https://www.se.com/ww/en/download/document/EIO0000004425/
https://www.se.com/ww/en/download/document/EIO0000004424/
https://www.se.com/ww/en/download/document/CS-Best-Practices-2019-340/
https://www.se.com/ww/en/download/document/EIO0000004982/

About the Book

Product Related Information

AWARNING

LOSS OF CONTROL

» Perform a Failure Mode and Effects Analysis (FMEA), or equivalent risk
analysis, of your application, and apply preventive and detective controls
before implementation.

» Provide a fallback state for undesired control events or sequences.
* Provide separate or redundant control paths wherever required.
» Supply appropriate parameters, particularly for limits.

» Review the implications of transmission delays and take actions to mitigate
them.

* Review the implications of communication link interruptions and take actions
to mitigate them.

» Provide independent paths for control functions (for example, emergency
stop, over-limit conditions, and error conditions) according to your risk
assessment, and applicable codes and regulations.

* Apply local accident prevention and safety regulations and guidelines.!

» Test each implementation of a system for proper operation before placing it
into service.

Failure to follow these instructions can result in death, serious injury, or

equipment damage.

1 For additional information, refer to NEMA ICS 1.1 (latest edition), Safety
Guidelines for the Application, Installation, and Maintenance of Solid State Control
and to NEMA ICS 7.1 (latest edition), Safety Standards for Construction and
Guide for Selection, Installation and Operation of Adjustable-Speed Drive
Systems or their equivalent governing your particular location.

AWARNING

UNINTENDED EQUIPMENT OPERATION

* Perform a risk assessment as per ISO 12100 and/or other equivalent
assessment in view of your use of EcoStruxure Control Engineering.

* Inyour risk assessment, consider all applicable regulations and standards
that apply to your development process and to your machine/process.

» Verify that your use of EcoStruxure Control Engineering is fully covered in
the definition of your software development process and that your software
development process meets all applicable regulations and standards.

» After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
commission or recommission the machine/process in compliance with all
regulations, standards, and process definitions applicable to your machine/
process.

» During commissioning or recommissioning of the machine/process, verify
the correct operation and effectiveness of all safety-related functions and
non-safety-related functions by performing comprehensive tests for all
operating states, for the defined safe state of your machine/process, and for
all potential error situations.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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About the Book

EcoStruxure Control Engineering - Monitoring generates a representation of the
source code of your controller application and uses the representation as a basis
for providing information on your controller application. You must, therefore,
ensure that the source code used for your application on the controller is the same
as the source code used for EcoStruxure Control Engineering. You can do so by,
for example, implementing automated version control routines, or by setting up
appropriate organizational measures to meet the corresponding requirements.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

+ Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is the
identical to the source code used for the application running on your
controller.

» Do not rely on the data provided by EcoStruxure Control Engineering -
Monitoring as the sole source of information in monitoring, verifying,
validating or otherwise assessing the operation of your machine/process.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Machines, controllers, and related equipment are usually integrated into networks.
Unauthorized persons and malware may gain access to the machine as well as to
other devices on the network/fieldbus of the machine and connected networks
because of insufficiently secure access to software and networks.

10
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About the Book

Schneider Electric adheres to industry best practices in the development and
implementation of control systems. This includes a "Defense-in-Depth" approach
to secure an Industrial Control System. This approach places the controllers
behind one or more firewalls to restrict access to authorized personnel and
protocols only.

AWARNING

UNAUTHENTICATED ACCESS AND SUBSEQUENT UNAUTHORIZED
MACHINE OPERATION

» Evaluate whether your environment or your machines are connected to your
critical infrastructure and, if so, take appropriate steps in terms of prevention,
based on Defense-in-Depth, before connecting the automation system to
any network.

« Limit the number of devices connected to a network to the minimum
necessary.

» Isolate your industrial network from other networks inside your company.

* Protect any network against unintended access by using firewalls, VPN, or
other, proven security measures.

* Monitor activities within your systems.

* Prevent subject devices from direct access or direct link by unauthorized
parties or unauthenticated actions.

* Prepare a recovery plan including backup of your system and process
information.

Failure to follow these instructions can result in death, serious injury, or

equipment damage.

For more information on organizational measures and rules covering access to
infrastructures, refer to ISO/IEC 27000 series, Common Criteria for Information
Technology Security Evaluation, ISO/IEC 15408, IEC 62351, ISA/IEC 62443,
NIST Cybersecurity Framework, Information Security Forum - Standard of Good
Practice for Information Security, and refer to Cybersecurity Guidelines for
EcoStruxure Machine Expert, Modicon and PacDrive Controllers and Associated
Equipment.

For reasons of Internet security, for those devices that have a native Ethernet
connection, TCP/IP forwarding is disabled by default. Therefore, you must
manually enable TCP/IP forwarding. However, doing so may expose your network
to possible cyberattacks if you do not take additional measures to protect your
enterprise. In addition, you may be subject to laws and regulations concerning
cybersecurity.

AWARNING

UNAUTHENTICATED ACCESS AND SUBSEQUENT NETWORK INTRUSION

» Observe and respect any and all pertinent national, regional and local
cybersecurity and/or personal data laws and regulations when enabling
TCP/IP forwarding on an industrial network.

* Isolate your industrial network from other networks inside your company.

» Protect any network against unintended access by using firewalls, VPN, or
other, proven security measures.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Consult the Schneider Electric Cybersecurity Best Practices for additional
information.

EIO0000004427.03
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About the Book

Terminology Derived from Standards

The technical terms, terminology, symbols and the corresponding descriptions in
this manual, or that appear in or on the products themselves, are generally
derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, faulf,
fault reset, malfunction, failure, error, error message, dangerous, etc.

Among others, these standards include:

Standard

Description

IEC 61131-2:2007

Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2015

Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013

Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010

Safety of machinery - General principles for design - Risk assessment
and risk reduction

EN 60204-1:2006

Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013

Safety of machinery - Interlocking devices associated with guards -
Principles for design and selection

ISO 13850:2015

Safety of machinery - Emergency stop - Principles for design

IEC 62061:2015

Safety of machinery - Functional safety of safety-related electrical,
electronic, and electronic programmable control systems

IEC 61508-1:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: General requirements.

IEC 61508-2:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: Requirements for electrical/electronic/programmable
electronic safety-related systems.

IEC 61508-3:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: Software requirements.

IEC 61784-3:2016

Industrial communication networks - Profiles - Part 3: Functional safety
fieldbuses - General rules and profile definitions.

2006/42/EC Machinery Directive
2014/30/EU Electromagnetic Compatibility Directive
2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control — Fieldbus for

use in industrial control systems

Finally, the term zone of operation may be used in conjunction with the description

of specific hazards, and is defined as it is for a hazard zone or danger zone in the

Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.

12
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Introduction to EcoStruxure Control Engineering - Monitoring

Introduction to EcoStruxure Control Engineering -
Monitoring

Overview

EcoStruxure Control Engineering - Monitoring is a diagnostics solution that
provides live views of your running controller application to help reduce the
downtime of controller-based systems by supporting operators and maintenance
teams in diagnosing an issue.

It provides a representation of the structure of your controller application in the
form of a data flow dependence tree with the corresponding cross references (in
Ladder or Structured Text) that show the different equations relating to a selected
variable. Based on these dependence tree and cross reference representations,
EcoStruxure Control Engineering - Monitoring displays the values of the variables
of the running controller application. Views are available that show only those
inputs that are instrumental in determining the values of a selected output, or only
the outputs whose values depend on a selected input.

EcoStruxure Control Engineering - Monitoring is installed on a dedicated server in
your industrial production network. It is a Software as a Service (SaaS) tool
accessible using a web browser. This allows, for example, for access from
distributed locations, enabling on-site maintenance staff to be supported by
engineers who are not on site.

Use Cases

EcoStruxure Control Engineering - Monitoring meets the requirements of different
profiles in various use cases:

* Operators:
o Assistance in determining potential causes for machine downtime
o Support in securing the system before a restart
* Maintenance teams:
o Diagnostics of hardware issues
o Diagnostics of software issues
o |dentification of missing criteria
» Automation experts/developers:
o Familiarization with complex systems

o Reduction of the time required to develop the monitoring system by
removing the need to create diagnostic synoptics (EcoStruxure Control
Engineering - Monitoring can substitute corresponding panels).

o Reduction of the time required for code instrumentation since EcoStruxure
Control Engineering - Monitoring does not require any.

For each of these profiles, EcoStruxure Control Engineering - Monitoring is also
useful for training people.

EI00000004427.03 13



Registration, Login, My Account, Licenses and Sessions

Registration, Login, My Account, Licenses and

Sessions

Registration

Overview

EcoStruxure Control Engineering - Monitoring is accessible using a dedicated
server for your organization.

The URL of the dedicated server is available from your system administrator.

Browser Compatibility

The following web browsers are supported:

* Mozilla Firefox from version 11

* Google Chrome from version 16

» Microsoft Edge from version 12

* Microsoft Internet Explorer from version 10

* Apple Safari from version 7

Registration

Registration procedure:

Step

Action

1

In your browser, go to the URL of the dedicated server.

2

Click Sign up.

3

Fill in the form with your first and last names, your phone number, your e-mail address
(which is used as your identifier) and select a password. Password requirements:

* Atleast one uppercase character

* Atleast one lowercase character

* Atleast one numerical character

« Atleast one special character (such as "{", "/", “$" )
» Password length between 8 and 32 characters

Read the Terms and Conditions and, if you agree, select | agree to the Terms and
Conditions.

Click Sign Up.

Result: Your account is created and activated.

Contact your system administrator for further details on the registration procedure.

14
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Login

Login using EcoStruxure Control Engineering Account

Step Action

1 Enter your email address and password in the respective fields.

2 Click Login.

Result: The Dashboard window appears.

Ecotruxure tgisn v A s« OCHNEIdEr
Control Engineering ‘ LElectric
JECOSTRUXURE CONTROL ENGINEERING DASHBOARD PROJECTS TOOLS ~ SUPPORT LICENSES & ORDERS GIVE FEEDBACK

DASHBOARD

Welcome Harshvardhan Sudhe, this is your dashboard, start by creating a first application, this view will reflect your last work and help you to find the functionalities you will need

Quick tour of EcoStruxure Control Engineering Next

wallable The dashboard
Programs RN Froiccts ! .
[ The dashboard is the place where you can start all the operations you need to do,

Once you have created a program and started to work on it, then the dashboard will help you to resume what
Projects Personal Licenses manager  you were doing. It also contains a lot of useful links such as the links to the user manuals, to your licenses

. 3 manager, to your projects...

information

EI00000004427.03 15
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My account Page

My account Page When Using a Schneider Electric Account

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.

Step Action

1
In Dashboard window, click

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Schneider Electric Profile Tab

The Schneider Electric Profile tab lists the user personal information such as the
identity, phone number, country. To update this information, you need to edit your
Schneider Electric profile, which is accessible with the link provided in the
Schneider Electric Profile tab.

Third-Party Apps Settings Tab

The Third-Party Apps Settings tab allows you to generate an applicative
password to connect your application to EcoStruxure Control Engineering when
your application does not support the Schneider Electric account authentication.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between the different views available
on the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:

* you are using dedicated server and the server is configured to send the
emails.

» you are using cloud version (Not applicable for Monitoring)
My account Page When Using a Legacy EcoStruxure Control
Engineering

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.

16 EIO0000004427.03
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Step Action

1
In Dashboard window, click

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Profile Tab

The Profile tab lists the user personal information such as the identity, phone
number, country, etc. You can update this information at any time.

Password Tab

The Password tab provides the password change form. You can change your
password at any time.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between different views available on
the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:

* you are using dedicated server and the server is configured to send the
emails.

+ you are using cloud version (Not applicable for Monitoring)

EIO0000004427.03
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Licenses

Overview

Schneider Electric offers various license plans for EcoStruxure Control
Engineering tools.

Paid License Plans

Contact your local Schneider Electric representative for details on the available
license plans for EcoStruxure Control Engineering tools. A selection of licenses is
also directly available from Schneider Electric Exchange at https://exchange.se.
com/shop.

18 EIO0000004427.03
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Sessions

Automatic Log-Out (Session Time-Out)

After 10 minutes of inactivity in an EcoStruxure Control Engineering session, you
are automatically logged out. If you work with multiple browser tabs, the most
recent activity in any of the tabs applies. For example, if you work in tab 1, but not
in tab 2, tab 2 does not disconnect you because there is activity in tab 1.

You are about to be logged out

There has been no activity on your account for the last 10 minute(s). With no action on

your side, we will log you out in 1 minute(s).
Stay Logged In

Multiple Sessions

If your credentials are used in multiple sessions, you receive a notification. For
example, if you are logged in and another session is established with the same
credentials, you receive the following message:

You are authenticated several times

Your credentials have been used to open several sessions of the EcoStruxure Control Engineering web platform.

As this may be unintended, here is the list of open sessions with your credentials. You may choose to close any
simultaneous sessions.

If you did not authenticate several times, then this situation may be due to your account being compromised. You
should close all other sessions and change your password. If the problem persists, then you need to contact your
local Schneider Electric representative for support.

D Date IP Address Qperating System Web Browser
\:‘ 2022-08-19 14:18:47 10.0.2.2 Llinux Mozilla Firefox
\:| 2022-08-19 16:19:54 10.0.2.2 linux Mozilla Firefox

‘ Close

The information on the connection date and time, the IP address, the operating
system and browser help you to determine whether or not a sessions is legitimate.
You can select and close a session with Close Session(s).

EI00000004427.03 19
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Creating Projects and Programs

Introduction to Projects and Programs

Overview

Example

EcoStruxure Control Engineering provides projects and programs for you to
organize your work.

A project is a type of container that can hold programs. A project is not specific to
an EcoStruxure Control Engineering tool.

When you register with EcoStruxure Control Engineering, the platform provides
one default project for you.

A program is assigned to a project. A program is created in conjunction with one of
the tools provided by EcoStruxure Control Engineering. A program typically
comprises metadata you entered during its creation, the uploaded source code of
a controller application, and the results generated with the EcoStruxure Control
Engineering tools.

The EcoStruxure Control Engineering tools are launched from within a program.
Whether or not a specific EcoStruxure Control Engineering tool is available for a
program depends on the source controller/development environment you select
during the creation of the program (PLC Brand or PLC source brand).

Programs can be shared with other users.

Assume you have been assigned the task of improving a machine ABC with two
controllers X and Y. In a first step, you want to better understand the code of the
two controller applications. You create a project “Machine ABC”. Then you add
two programs to this project: “Controller X” and “Controller Y”.

In both of these programs, you run EcoStruxure Control Engineering -
Documentation to visualize the data flow and the control flow.

In a subsequent step, your task is extended to managing the creation of a new
version of the controller applications. You start by running EcoStruxure Control
Engineering - Verification in your programs to verify the existing code. You share
the two programs with the developers so they can access the results of the code
verification for assistance in updating the code.

In subsequent steps, you can upload intermediate versions of the updated code
into your program and re-run EcoStruxure Control Engineering - Documentation
and EcoStruxure Control Engineering - Verification to document the progress and
verify that your coding rules have been properly implemented.
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Creating Projects and Programs

Creating Projects

Procedure for creating a project:

Step

Action

1

Select PROJECTS in the top menu to display the Projects page.

2

Select Actions > New project.

Ecuﬂtruxurn
Control Engineering

ECOSTRUXURE CONTROL ENGINEERING = DASHBOARD PROIECTS

PROJECTS

Open projects Closed projects Shared applications

Open projects

MNew proj

Change owner

Delete

Provide a unique name for your project. Lowercase and uppercase are ignored which
means that, for example, the name of a project to be created cannot be “Controller xyz”
if you already have a project with the name “Controller XYZ”. Click Add to create it.

Click Add to create the project.

Result: The project is added to your list of projects on the Open projects tab.

Clicking a project in the list displays two tabs. The Overview tab provides general
information on the project. The Programs tab contains the list of programs
assigned to this project.

Creating Programs

There are three ways to start the creation of a program:

From outside of a project select TOOLS on the main menu
From the dashboard click New ...

From inside a project on its Programs tab select Actions > New program

EI00000004427.03
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Creating a program from outside of a project:

Step Action

1 From the main menu, select TOOLS.

2 Select the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from the dashboard:

Step Action

1 From the main menu, select DASHBOARD.

2 Click the New ... button for the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from inside a project:

Step Action

1 From the main menu, select PROJECTS.
2 Select the required project from the list.

3 Display the Programs tab of the project.
4 Select Actions > New program.

Owverview Programs

Programs

| Mew program
Change project
Change program owner
Launch “erification
Launch Documentation

Delete

Result: EcoStruxure Control Engineering prompts you for the tool to be used for the
program and starts the program creation wizard.
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Program Creation Wizard

Overview

A wizard guides you through the different steps required to create your program
and launch the execution of the selected EcoStruxure Control Engineering tool.

The project to which the new program is assigned depends on how the wizard is
started. If the wizard is started from outside of a project or from the dashboard, the
program is assigned to your default project. If the wizard started from inside a
project, the program is assigned to this project. In both cases, the project
assignment can be adjusted in step 1 of the wizard.

Refer to Creating Programs, page 21 for details.

Step 1 - Start

The first step consists of providing setup information on the program.

1 Start 2 Parameters 3 License 4 Source file 5 Summary
Setup program i C Assodiate license Upload source files Summary of your program

.
Application name™: | oqt_monitoring

Customer name Schneider Electric

PLC site address :
PLC site ity :

PLC reference®: | [ o

PLC function :

Project: | gefault - Default project! v

Validate And Next Step

Provide the following information:

* The fields Application name and Customer name are mandatory. The
defined Application name is used to identify the program in the different
views of EcoStruxure Control Engineering.

» For Monitoring, the PLC reference field is required to configure the
connection with the OPC server.

+ Add additional information in the other fields so that you can identify this
program in your project.

Continue with the next step by clicking Validate And Next Step.

Step 2 - Parameters

The second step consists of selecting the development environment that was
used to develop the controller application.

1) Start ("3 ) Parameters 3 ) License 4 ) Source file 5 ) Summary
Setup program information Monitoring parameters Associate license Upload source files Summary of your program

PLCbrand™ | g eider-Electric EcoStruxure Control Expert v

Previous Step Validate And Next Step
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Step 3 - License

Select the PLC brand and continue with the next step by clicking Validate And

Next Step.

The third step consists of selecting the EcoStruxure Control Engineering license to

be used with your new program.

Start Parameters

2

3 License 4 Source file 5 Summary

Setup program information Monitoring parameters Assodiate license Upload source files Summary of your program

Licensing possibilities for this program

® Do not assign a license now
O Use a license ID

O Use a free trial license

Previous Step

Do not assign a license now

Without selecting a license now, you won't be able to run a new
Monitoring analyse. It is possible to assign a license Later, and continue
with the program creation process

Validate And Next Step

Chose one of the Licensing possibilities for this program:

Licensing possibilities

Description

Do not assign a license now

Select this option when you will not run the analysis
immediately.

Use alicense ID

Select this option when you have a license code. If you have
a license, but the license has not yet been assigned to your
user account, you can still use it by entering its identifier in
the License #id field.

Use a free trial license

Select this option to launch a trial version of the tool. This is
not possible if you have already used all trial licenses that
have been associated with your user account.

Use a contract license

This option appears when you have a contract for
EcoStruxure Control Engineering. This allows you to
automatically generate a license, as part of your contract, to
run the analysis.

Use an account license

This option appears when licenses are available in your
account. In this case, you can select the license from a
dropdown list.

Click Validate And Next Step to continue.

If no license is available, you can still continue creating the program by clicking

Validate And Next Step. In this

case, a license can be added to the program after

you have created the program. Without a valid license, the EcoStruxure Control
Engineering tool selected for this program cannot be executed.

Step 4 - Source file

The fourth step consists of uploading the file with the source code of the controller
application that you have exported from the development environment (refer to
Manufacturer-Specific File Export Procedures, page 48 for details). This source
code is the input material for EcoStruxure Control Engineering. Depending on the
EcoStruxure Control Engineering tool used for the program, you may be prompted

to upload additional files.

24
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Step 5 - Summary

Summary

License
4
Summary of your program

Associate license

Source file 5

Start
L 2 Upload source files

Setup program information

Parameters 3
Monitoring parameters

DRAG YOUR FILES HERE

OR
Select Files..
Supported files
*XEF
Please provide a complete, up-to-date code export of your PLC code. If some code is missing in your program, this code will * ZEF

not be analyzed.

More about the allowed files for your PLC brand

How to get supported files?

Previous Step Validate And Next Step

Drag and drop the files to the location indicated or click Select Files... to import
the files. Then click Validate And Next Step to continue.

If the input files are not yet available when you create the program, you can skip
the upload with Validate And Next Step and provide the files at a later point in
time. Without the uploaded input files, the EcoStruxure Control Engineering tool
selected for this program cannot be executed.

The fifth step displays a summary of the information you have provided in creating
your program.

Summary

Source file 5
Summary of your program

License 4
Upload source files

Start 5 ) Parameters 3
Associate license:

Setup program information Monitoring parameters

name ‘test-monitoring Customer name Schneider Electric
N/A PLC my-ref
L N/A PLC function N/A

Schneider-Electric EcoStruxure Control Expert

N/A

In order to help you to understand the EcoStruxure Contral Engineering - Monitoring usages and limitations, the important Safety
information about the product is available through the link below. You are able to retrieve them in the dashboard and in your pragrams

tabs. These messages are also available in the product documentation.
f— m

Review the information. If you want to make modifications, click Previous Step to
return to the step you want to modify.

Read the safety information summary
Download the user guide (English)

If the information is correct, click Create to create the program or click Launch to
create the program and to start the EcoStruxure Control Engineering tool selected
for this program (this is possible if you have selected a valid license and if you
have uploaded the required files).
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Accessing a Shared Program

If a program is shared with you, or if access to the program is not restricted (refer
to Sharing a Program, page 27), you can add it to your list of programs by
providing its unique 6-digit key. The unique 6-digit key can be found in the
program overview under Application key.

Procedure for adding a program to your list of programs using its unique 6-digit

key:

Step

Action

1

From the menu, select PROJECTS to access the Projects page.

Eco&truxuru .
Control Engineering

ECOSTRUXURE CONTROL ENGINEERING | DASHBOARD PROJECTS TOOLS SUPPORT

Click Shared applications to display the corresponding tab.

Opened projects Closed projects Shared applications

Enter the unique 6-digit key of the program in the field below User personal accesses
or in the field below One time access, depending on whether you want to add this
program to your personal records for access at a later point in time, or whether you
want to access it only once without adding it to your list of programs.

Open projects Closed projects Shared applications

Shared applications

User personal accesses

Here is the list of the applications shared explicitely with you by someane else or that you have decided to add for the applications shared with everyone

Your personal accesses is currently empty because no application have been shared with you yet. or you do not have added an application shared with everyone to this list

You can add any application shared with everyone in your list of applications by providing its application key below

One time access

You can access any application shared with you without saving it in your personal accesses by providing the application key below.

Click Add To My Applications or One Time Access.

26
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Sharing Programs with Other Users

Overview

You can share your programs with other users so that a team can work on the
same project. As the owner, you can share your program. Selected users with
whom you share your program cannot delegate their access rights, that is, they
cannot share this shared program with further users.

There are two ways of sharing a program:

+ Share with selected users: You choose who can access your program. By
default, other users cannot share this program because you are the owner.

» Share with everyone: Everyone can access your program.

Sharing with a Specific User

Procedure for sharing a program with selected users:

Step Action

1 Navigate to the Program page.

2 Select Admin > Collaboration > Users access rights to display the User
management.

3 Below Invited collaborators, select Actions > Add .

Overview

User management

Owner details

Invited collaborators.

4 Enter the name and the e-mail address of the user to be invited. You can enter the e-
mail address the user specified for registration with EcoStruxure Control Engineering,
or you can use any other e-mail address. You can also send an invitation notification to
the user. On a dedicated server, the invitation notification function requires a mail
server.

Users added to the list of invited users can perform the same actions as you, except for
sharing the program and modifying its settings. If you do not want invited users to
perform any further actions, deactivate the program with the Active application
checkbox in Admin > Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can revoke sharing by selecting the user(s) you want to remove from your
program and selecting Actions > Remove access.

Sharing with Everyone

Procedure for sharing a program with everyone:
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Step Action
1 Navigate to the Program page.
2 Select Admin > Settings.
3 Enable the checkbox Private application.

Users accessing your program can perform the same actions as you, except for sharing
the program and modifying its settings. If you do not want invited users to perform any
further actions, deactivate the program with the Active application checkbox in Admin

> Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function.

You can disable sharing with everybody by deactivating the checkbox Private
application. With this setting, only users explicitly invited can access your

program.

28
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Monitoring a Controller Application

Pre-Deployment Considerations

Overview

EcoStruxure Control Engineering - Monitoring complements the controller
commands for diagnostics.

EcoStruxure Control Engineering - Monitoring does not affect the commands of
the controller application for your production process, but provides information on
the status of such commands to support you in, for example, resolving issues that
may cause machine downtime.

Pre-Requisites Regarding the Controller Application

The quality of the analysis of the source code of controller applications largely
depends on the quality of such code. Using consistent coding rules and standards
enables a better comprehension of what the source code does or is intended to
do. Analyzing tools that respect a set of coding rules facilitates and improves the
quality of diagnostics. For example, if the names of variables are explicit and have
a clear comment, it is much easier to understand the role of the variables.

The architecture of a controller application also plays an important role in the
analysis of the code. A controller application containing many pointers is more
difficult to diagnose than a controller application without pointers.

If you are unsure about the quality or suitability of your controller application for
use with EcoStruxure Control Engineering - Monitoring, verify the source code
with EcoStruxure Control Engineering - Verification to identify optimization
potential before using EcoStruxure Control Engineering - Monitoring.

EI00000004427.03
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Architecture

Overview

Web Platform

The following descriptions provide a generic overview of the architecture of an
EcoStruxure Control Engineering - Monitoring solution. The actual architecture
and configuration depend on your specific hardware and software environment
and the corresponding requirements.

Graphical User Interface (web browser)

COM Server
Communication Module

Inter-connected dataflow
information

EcodPtruxure” ‘ _ OPC Server
Control Engineering

Documentation

EcodPtruxure
Control Engineering
Monitoring

PLC Development
Environment #1

Version Control System

PLC Development
Environment #2

PLC Development
Environment #3

The web platform manages the analysis of the controller application in order to
generate the data flow information. It is also from the web platform that
EcoStruxure Control Engineering - Monitoring can be launched and the results
can be visualized.

The web platform is available using a client workstation with a web browser.

Communication Server (COM Server)

The communication server is a Web Socket server allowing for communication of
process data (that is, direct communication with the controller systems or with an
OPC server). This component can be installed on a virtual machine (VM) or on a
separate server. The data is obtained from the controller system either with the
Modbus TCP protocol or with the OPC-DA protocol (using an OPC server). The
possible configurations for the installation of these components are described
below.

Your IT department needs to open certain ports and provide the appropriate
permissions in your network to allow for communication with the controller
systems or the OPC server.

Communication using OPC Server

The communication server is installed on the same virtual machine as the web
platform and uses an OPC-DA connection to communicate with the OPC server.

30
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EcodPtruxure-
Control Engineering

Monitoring

COM Server

OPC-DA Protocol

OPC Server

Native Protocol
of the PLC

In order to provide you with valid data, the communication server requires a valid
configuration of the OPC-DA server, especially if the requests use names of

variables instead of addresses.

Communication using OPC Server and Communication Server

To account for certain configuration constraints, the communication server can be
installed on the same computer as the OPC server you use.

EcodPtruxure-
Control Engineering

Monitoring

Communication
via websocket

COM Server
OPC Server

Native Protocol
of the PLC

Direct Communication using Modbus TCP

The communication server uses the Modbus TCP protocol for direct
communication with the controller system.

EcodPtruxure-
Control Engineering

Monitoring
COM Server

Modbus TCP Protocol
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Installation and

Package

Configuration

EcoStruxure Control Engineering - Monitoring is provided in a virtual machine
(VM) that contains the environment required for its operation. It includes the
communication server in charge of the communication between EcoStruxure
Control Engineering - Monitoring and your controller application (if you enable
OPC communication from the virtual machine). The communication server can
also be installed on your server (physical machine) that hosts the OPC server
(according to your cybersecurity policies).

Installation of the Virtual Machine

Installation of the

Configuration

EcoStruxure Control Engineering - Monitoring is delivered in the form of a virtual
machine that virtualizes a Linux Debian operating system.
This virtual machine can be delivered on different architectures and hypervisors:
* VMware that can be used on its OS ESX server, or on Windows
» Hyper-V (Microsoft)
» Oracle VM VirtualBox (Oracle)

Contact your Schneider Electric representative for other hypervisors and
architectures.

For more information on cybersecurity guidelines, refer to EcoStruxure Control
Engineering Cybersecurity, Hardening Guide.

Communication Server

The communication server component is installed like a Windows service. The
installation procedure is explained below for Microsoft Windows. The following
operating systems are supported:

* Microsoft Windows 10
* Debian Linux 9 and 10

The configuration is adapted in the file config.properties which is located in the
root of the folder containing the service wrapper:

lib
windows-x86-32
.gitignore
| config.properties
| ICSMenitoring jar
LICENSE.md
README.md

32
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Property

Example

Description

dataProviderType

1 (for Modbus TCP)

Defines the protocol to be used
for the installation. OPC DA
and Modbus TCP are
supported.

dataProviderADDR

127.0.0.1 when it is installed
on the same computer as the
communication server.

Primarily used for OPC DA
communication. This is the IP
address of the computer on
which the OPC server is
installed.

dataProviderPort

103 for OPC Server and 502
for Modbus TCP

The port used by the OPC
Server or by Modbus TCP.

dataProviderUser

Only for OPC DA. This is the
name of the system user who
has access to the computer on
which the OPC server is
installed.

dataProviderPassword

Only for OPC DA. This is the
password of the system user
who has access to the
computer on which the OPC
server is installed.

dataProviderDomain

WORKGROUP

Only for OPC DA. This is the
domain name of the computer
on which the OPC server is
installed.

dataProviderProgld

Only for OPC DA. This is the
program ID of the OPC server.

dataProviderClsld

Only for OPC DA. This is the
CLS ID of the OPC server.

updateRate

5000 ms (default value)

The time interval to refresh the
values of variable. With OPC
DA communication, the
communication server
refreshes the values of the
variables every five seconds.

NOTE: Verify that your
infrastructure supports the
value specified.

NOTE: Restart the server service after each modification to the configuration
(for example, using the Windows services management console).

Installation of the EcoStruxure Control Engineering - Monitoring
Service of the Communication Server

The service wrapper can be installed by executing the script for the corresponding

Windows version:

«  Windows 32 bit: windows-x86-32\installService.bat

*  Windows 64 bit: windows-64/installService.bat

After the installation procedure, a command prompt with the installation status
message is displayed (successful or not successful). The service is enabled
following a successful installation.
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N C:AWINDOWS\system32\cmd.exe - a x

It is possible to verify the status of the service by executing the file windows-x86-
32\ICSMonitoring.exe. A window is displayed that allows you to stop or launch
the service and to view the logs and service properties. It is advisable to keep
automatic startup.

NOTE: The storage location of the installation package is used as the
installation location, that is, the program is not installed in the Windows
\Program Files tree, but in the directory in which the installation package is
contained.

Integration With a Supervision System

Supervision software capable of opening a web browser directly within the window
or as an external software can integrate EcoStruxure Control Engineering -
Monitoring. You can integrate EcoStruxure Control Engineering - Monitoring into
your supervision system either by automating the generation of the opening action
from a variable or an alarm, or by adding an action button to launch it for the
corresponding software (for example, in Visual Studio, the WebBrowser class
defined in System.Windows.Forms can be used to open a web browser window).

Integration With a Version Control System

EcoStruxure Control Engineering - Monitoring generates a representation of the
source code of your controller application and uses the representation as a basis
for providing information on your controller application. You must, therefore,
ensure that the source code used for your application on the controller is the same
as the source code used for EcoStruxure Control Engineering. You can do so by,
for example, implementing automated version control routines, or by setting up
appropriate organizational measures to meet the corresponding requirements.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

+ Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is the
identical to the source code used for the application running on your
controller.

» Do not rely on the data provided by EcoStruxure Control Engineering -
Monitoring as the sole source of information in monitoring, verifying,
validating or otherwise assessing the operation of your machine/process.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Integrating EcoStruxure Control Engineering - Monitoring and a version control
system facilitates keeping the controller application used for EcoStruxure Control
Engineering - Monitoring and the controller application used to run your system
synchronized. After each modification to your controller application and the
deployment of this controller application in your system, the following steps are
required:

Step Action

1 Exporting the code of the controller application in the corresponding format with the
help of the EcoStruxure Control Engineering - Import/Export tool.

2 Launching the EcoStruxure Control Engineering - Monitoring program on the newly
uploaded version of the code of the controller application.

These two steps can be executed automatically without user intervention. This is
managed by script mechanisms (such as hooks) that are available in version
control tools.

NOTE: Verify that EcoStruxure Control Engineering - Monitoring has access to
both the archived controller applications and the data from the production
systems.
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Creating a Representation of an Controller Application

Procedure

No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

+ Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

+ After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Step Action

1 Select Documentation | Monitoring > Launch Monitoring on the Program page.

Launch Verification Documentation | Monitoring ~

Launch Documentation

Launch Monitoring

2 Upload the source files of the controller application exported from your software
development environment as described in Program Creation Wizard, page 23.

3 Specify the files to be analyzed. If you do not want to generate the representation for
each file, you can remove unwanted files by unselecting them in the list.

4 Start the representation process by clicking Launch.

NOTE: The time required to generate your representation depends on the size and
complexity of the source code of the controller application. Progress information is
displayed on the Program page.
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The Data Flow View

General

The Data Flow view displays the relationships between variables of a controller
application from input to output, or vice versa.

This view displays how the values of the variables of the controller application are
read or written.

Displaying the Data Flow View

To display the Data Flow view, select Monitoring > Data flow.

Monitoring - Con
Control flow
W
Data flow
E
W Communication
Download (zip)
[
User Awareness >
it

NOTE: If you have downloaded a copy of the online results and want to work
with the downloaded copy, open the file index.html and click the button
Display Data Flow. Refer to Downloading an Offline Version of the
Representation, page 47.

Overview of the Data Flow View

The Data Flow view consists of four parts:

Test Connection

Data flow direction Cross-references language
The - and the.
what depends on the selected varizble Litral, or vice versa

Variable Location Type Comment ©

Y i

(&llale)

« List of variables to explore and settings for variables (top left, green frame)
» Dependency tree (bottom left, purple frame)
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» Language settings (top right, blue frame)
» Cross references snippets (bottom right, yellow frame)

List of Variables

The list of variables to explore lets you select a variable whose dependencies you
want to display. Click List Of Variables to select a variable.

10 A

y Mnemonic Memory reference Comment

Machine_running %Q0.3.3 -
inst_watchpoint_3_out - -
inst_transportation_belt_3_out - -
inst_transportation_belt_1_out - -
inst_forming_6_out - -
inst_forming_3_out - -
inst_forming_5_out - -
inst_forming_2_out - -
inst_forming_1_out - - !

inst_mixer_1_out - -

|< < Page| 1 ~ /29 > >|

Functions for finding a variable:

* You can scroll through the list using the page buttons at the bottom of the
view. You can specify the number of variables to be displayed on a single
page using the dropdown list at the top left part of the table.

* You can filter the variables using the search field at the top right part of the
list. You can search by full or partial name, address and comment of a
variable.

Click the name of a variable to display it in the dependency tree and in the cross
references snippets parts of the page.

The Data flow direction let you specify the way the dependencies are listed and
displayed. Write displays only the dependencies that write the value of the
variable. Read displays only the variables that are used to write to other variables
that are using the selected variable. Read and write displays both. This selection
also affects the way the Dependency tree is displayed.

Dependency Tree

The Dependency tree is a graphical representation of the dependencies between
the variables. If a variable is used to compute or to determine another value, this
variable is displayed with a link to that other variable.

38 EIO0000004427.03



Monitoring a Controller Application

[
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In the example above, the following is true of the selected (blue) variable (Data
flow direction is set to Read and write):

» The variable needs the values of the two linked variables displayed to its left
in order to calculate its own value.

» The variable is used to calculate the values of the linked variables displayed
to its right.

You can explore the relationships between variables by clicking their names.
This view is helpful to locate the variables affected if code is modified in the

controller application, or to determine an unwanted value of a variable in the
running controller application.

Language Settings

The language settings let you select Ladder or Literal as the language for the
cross reference snippets.

Depending on the different types of variables, a representation of the code in
Ladder may not be available. In such a case, the cross references are displayed in
Literal.

Creating a flow chart from an controller application is a complex operation.
Depending on the complexity of the code and the different types of objects,
EcoStruxure Control Engineering - Monitoring may not be able to generate a
precise flow if a variable is indexed and/or if its address is accessed indirectly
using a variable in the controller application.

Cross References Snippets

The cross references snippets part of the page displays how the variables are
used in the calculations of one another.

It consists of a code extract, displayed in Ladder or Literal language, that
highlights the relations. The code extract is not displayed in the same way it is
written in the original code in order to provide a synthetic view. Its logic still
remains the same as in the original code. The logic can be retrieved using the
location displayed behind each snippet.

For instance, if you access a variable inside several nested conditional
instructions, the snippet compresses these instructions into a single one.
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Live Visualization

Section-MAST-5tart_process-L:2-C:10

Start
Start Stop _process
] | Ijrl [
| | 171 L
Tmp_0
_start
_process
]l 1
1 T

@jlaja]

The cross references snippets view is updated each time you select a variable
either in the list of variables or in the dependency tree.

EcoStruxure Control Engineering - Monitoring provides a live visualization of the
values of the variables of the running controller application. The transmission
latency between the running controller application and the visualization in
EcoStruxure Control Engineering - Monitoring depends on, among other things,
the communication infrastructure, the server settings (refer to updateRate in
Configuration), and the controller application itself.

To start the live visualization, click Start under Monitoring.

— MONITORING

NOTE: The button Test Connection allows you to test the connection, for
example, in order to test whether the view is frozen or the communication
server is running.

The states of a variable are displayed depending on the type and the value:

» Boolean value: If the value is TRUE, the node is green. If the value is FALSE,
the node is red.

* Non-boolean value: The value is displayed in a label associated with the
node.

* Indeterminable: The “?” symbol is displayed next to the node if the value
cannot be retrieved because it does not have an address or is not accessible.

In the following example, the boolean values are highlighted with an orange frame.
The non-boolean values are highlighted with a blue frame:

| Fedo_ferm_vr

Fde_ferm_vv . \
N

410129347 -F

1849065888

In the following example, the value of the variable A_ferm_vv depends on the
variables Niv_sas, Niv_aval, Mode_manu and Mode_auto. The value of the
variable A_ferm_vv determines the values of the variables Dde _ouv_vv and Dde _
ferm_v.

40
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Representation in the dependency view:

Rotation_L__

Start_proc_.

Representation in Ladder language:

Section-MAST-Start_process-L-2-C:10

Ctart
Start Stop _process
] 1| Ijrl [
L | 151 L
Tmp_0
_start
_process
]
Ejleje]

Representation in Literal language:
Section-MAST-Start_process-L-2-C:10 @

Start_prucess = (Start or Tmp_la_star"t_prncess:

L4 >
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The Control Flow View

General

The Control Flow view displays the order in which the function or procedure calls
are executed or evaluated.

This view displays the way the logic of the controller application is called.

Displaying the Control Flow View

Select Monitoring > Control flow.

Meonitoring Col

J‘ Control flow

Data flow

Communication

Download (zip)

User Awareness 3

NOTE: If you have downloaded a copy of the online results and want to work
with the downloaded copy, open the file index.html and click the button
Display Control Flow. Refer to Downloading an Offline Version of the
Representation, page 47.
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Overview of the Control Flow View

The Control flow view consists of four parts:

Procedures to explore

Use this lis o select the procedure to explore o ange from a view in Ladder to 2 view in
Lie

Name Full name Language Comment ©

SAVEVIEW

a o la

zoomin zoomour [l ToocLe

I i
§

+ List of procedures to explore (top left, green frame)

+ Dependency tree (bottom left, purple frame)

» Language settings (top right, blue frame)

» Cross references snippets (bottom right, yellow frame)

List of Procedures

(eale)

The list of procedures lets you select a procedure whose call tree you want to
display. Click List Of Procedures to select a function, function block or task
(which are generally referred to as called “procedure” in the EcoStruxure Control

Engineering tools).

10 v

y Procedure name

4 demao_controlexpert_m580.loop
demo_controlexpert_m580.init
MotorTwoDirections
Heating
control
m580.loop
mast_section.loop
weighing_material_a

mixer

heating

| Laaaer

| Lierac |

Search :

|< < Page

Nb Dep references
1

1

Vv
N

EI00000004427.03

43



Monitoring a Controller Application

Dependency Tree

Functions for finding a procedure:

* You can scroll through the list using the page buttons at the bottom of the
view. You can specify the number of procedures to be displayed on a single
page using the dropdown list at the top left part of the table.

* You can filter the procedures using the search field at the top right part of the
list. You can search by full or partial name of the procedure.

Click the name of a procedure to display it in the dependency tree and in the cross
references snippets parts of the page.

The Dependency tree is a graphical representation of the dependencies between
the procedures.

packaging_..

The selected procedure is highlighted in blue. Each linked procedure displayed to
its left is a procedure that calls it. Each linked procedure displayed to its right is a
procedure that is called by it.

You can explore the relationships between procedures by clicking their names.

This view is helpful to determine how the procedures call each other.

Language Settings

The language settings let you select Ladder or Literal as the language for the
cross reference snippets.

Depending on the different types of procedures, a representation of the code in
Ladder may not be available. In such a case, the cross references are displayed in
Literal.

Cross References Snippets

The cross references snippets part of the page displays how the different
procedures call each other.

It consists of a code extract, displayed in Ladder or Literal language, that
highlights the relations. The code extract is not displayed in the same way it is
written in the original code in order to provide a synthetic view. Its logic still
remains the same as in the original code. The logic can be retrieved using the
location displayed behind each snippet.

For instance, if you call a procedure inside several nested conditional instructions,
the snippet compresses these instructions into a single one.
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Section-MAST-Mixer-L:25-C:27

refill_feeder

ton
| EN ENOD L
Mixing Fill
_done _feeder
— ]
Refill
T#10s L Pt Bt — feederkt

8 ajal

The cross references snippets view is updated each time you select a procedure
either in the list of procedures or in the dependency tree.
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Integration with SCADA

EcoStruxure Control Engineering - Monitoring provides a view that supplies only
the information relevant to a given variable. This view can be called from another
tool or displayed in a pop-up, since it is accessible via a URL. This URL comes in
the following format:

http://<@IP>/programs/view/<ABCDEF>/?entityname=
<entityname>&startmonitor=true

or

http://<@IP>/programs/view/<ABCDEF>/?entityaddress=%
<entityaddress>&startmonitor=true

The parameters found in the URL are:

*  <@IP> - IP address of the server hosting EcoStruxure Control Engineering -
Monitoring tool

* <ABCDEF> is a program key that refers one program inside EcoStruxure
Control Engineering

* <entityname> or <entityaddress> corresponds to the name of the variable or
its address.

» startmonitor=true enables the automatic launch of the diagnostics and real-
time communication with the target (for example, the control system, the OPC
Server, etc.).

This view provides either the list of input variables that influence the output

variable passed as the parameter, or the list of output variables that may be
impacted by the input variable passed as the parameter.
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Downloading an Offline Version of the Representation

You can download a copy of the EcoStruxure Control Engineering - Monitoring
online results from the server to your local PC.

Download procedure:

Step

Action

1

Navigate to the Program page.

2

Select Monitoring > Download (zip).

Monitoring -~ Caol

Control flow

Data flow

Communication

Download (zip) |

User Awareness  »

A ZIP file with the representation in HTML format is downloaded to your PC.

Extract the contents of the downloaded ZIP file and open the file index.html if you want
to work with the downloaded representation.

NOTE: Security policies in your organization may keep your browser from
displaying certain or all HTML content stored on your PC. In such cases, contact
your administrator to resolve this condition.
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Manufacturer-Specific File Export Procedures

EcoStruxure Control Engineering tools use the source code files of controller
applications as input files. These files are exported from the corresponding
software development environments. The following sections provide information
on generating these export files in various software development environments.

EcoStruxure Control Expert (.XEF / .ZEF File Export)

Export the EcoStruxure Control Expert (formerly Unity Pro) controller application
to an XEF or a ZEF export file in order to be processed with EcoStruxure Control
Engineering tools.

To export the file, you can use the EcoStruxure Control Engineering Import/Export
tool. Select SUPPORT > DOWNLOADS.

It is also possible to export the files using the EcoStruxure Control Expert menu:

Step Action
1 From the menu, select File > Export application....
2 In the Export application... dialog box, provide a name for the XEF or ZEF file.
3 If required, modify the storage location for the XEF or ZEF file.
4 Click Save.

48

EI00000004427.03
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EcoStruxure Machine Expert (.EXPORT File Export)

Export the EcoStruxure Machine Expert controller application to an XML export
file (with the extension .export) in order to be processed with EcoStruxure Control
Engineering tools.

Procedure:
Step Action
1 From the menu, select Project > Export....

| Project | FBD/LD/IL  ETEST  Build

-'_::I

o -

5 @

Add Object

Add Folder.

Scan For Devices...
Update Device...
Online Config Mode...
Edit Object

Edit Object With..
Add Module...

Set Active Application

Project Information...

Project Settings...

Open “Update Project” dialog..,

Project Localization

Document...
Compare...
Commit accepted changes

Compare with device...

»

1

Export...

Import...

Export PLCopenXML...
Import PLCopenxXML...
Import of motion profiles

User Management

Mass Storage (USB or SDCard)...

You can export particular objects or a full tree. From the tabs in the Export dialog,

select the objects to be included in the export file.
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Step

Action

Export X

Please select the objects which are to be exported:
Devices POUs
=3 Untitled? v A
- @ Controller (TM241C24R)
= [ PLC Logic
= £ Application
= ) DOCRS
iH poor (F8)
] poors_cTrL (FUN)
B Ls_sensor (B)
= ) VALVES
[@) vaLve (Fe)
B vaLvEs_cTRL (FUN)
] w_sensor (F8)
@ on
m Library Manager v

[[] One file per subtree

Storage version:
V18.2.3.0 ~

5] o

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
EcoStruxure Machine Expert version that you select from the dropdown list
Storage version. To re-import the file, this EcoStruxure Machine Expert version is
used.

Click OK and provide a file name and a folder name as prompted.

Click Save.

50

EI00000004427.03



Manufacturer-Specific File Export Procedures

PL7 Pro (.FEF File Export)

Export the PL7 Pro controller application to an FEF export file in order to be
processed with EcoStruxure Control Engineering tools.

Procedure:
Step Action
1 From the menu, select File > Export application....
2 In the Export application... dialog box, provide a name for the FEF file.
3 If required, modify the storage location for the FEF file.
4 Click Save.
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3S CODESYS V3 (.EXPORT File Export)

Export the CODESY'S V3 controller application to an XML export file (with the
extension .export) in order to be processed with EcoStruxure Control Engineering

tools.

Procedure:

Step

Action

1

From the menu, select Project > Export....

File Edit View | Project | Build Or
21 Add Object Y
) Add Folder...

Scan For Devices...

Update Device... L
Edit Object
Edit Object With... 3 (¢
Online Config Mode...
Set Active Application
H Project Information...
¢ Project Settings... nit
Project Environment... r(f
Project Localization r

uT

& Document...
1 Compare... M
Commit accepted changes
| Export...
Import...
Expart PLCopenXML...
Import PLCopenXML...
User Management 4

You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.

Export X

Please select the objects which are to be exported:
Devices POls  Modules
=& Compressor
= [ (@ CODESYS_Control_RTE_V3 (CODESYS Control RTE V3)
=-[v] B PLC Logic
= [ € Application

=  Generic Units
Compression_Unit (FB)
Pressure_Sensor (FB)
@ Compression_Units
i Library Manager
Compressor_State_Manager (FUN)

[]one file per subtree

Storage version:
;| | CODESYS V3.5 SP12 Patch 1 >
g

e

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
CODESYS version that you select from the dropdown list Storage version. This
version is then used to re-import the file in CODESYS. If you work on CODESYS
V3 code, select a version from the version 3 family (CODESYS V3 ...).
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Step Action
3 Click OK.
4 Provide a file name and a folder name as prompted and click Save.
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3S CODESYS V2 (.EXP File Export)

Export the CODESY'S V2 controller application to an EXP export file in order to be
processed with EcoStruxure Control Engineering tools.

(with the default settings, a selected item has a blue background), then click OK.

Step Action
1 From the menu, select Project > Export....
_File Edit Project Insett Extras Online Window Helg
Blz|E  Buid =
———  Rebuildall 1
jm Clean all
E:‘ EE Load download information...
=[] Object ’
o B Project database 4
B3 vVa
..... = Options...
_____ E:'-' Translate into other languages ’
£] wil Document...
Export...
Import...
Siemens Import ?
Merge...
Compare...
Project Info...
Global Search...
flahal Danlara
2 In the Export Project dialog box, select the objects to be included in the export file

54

EI00000004427.03
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Step Action
Export Project X
Cancel |
DOOR [FB]
DOOR_ACTIONS_CTRL (FUN)
CTION_CTRL (FUN)
TRL (PRG)
{SOR [FB)
™ One file for each object
3 Click OK and provide a file name and a folder name as prompted.
4 Click Save.
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BECKHOFF TwinCAT V3 (.XML File Export)

Export the Beckhoff TwinCAT controller application to an XML export file
(PLCopen) in order to be processed with EcoStruxure Control Engineering tools.

Step Action

In the Solution Explorer window, select the project.

Fie Edit View Project Buld FDAD/L Debug TwnCAT PIC Tools Scope Window Help

jep_project - Microsoft Visual Studio

T PUMP MANAGMENT (PRG)
) Super PUMP 55

1S RUNNING
W voiture (58

- SIENE
D819 0 L] ) [reeme -|[twincaTRT 060 -1\ uobjecinder
a8 g RE|e |- -l xeeic | =g
Souion ot e
= e .sump.stie asieien 5 an
L mnc varitle A e Swpe  Address Loation Comment
pYs PR SNAGHENT  ALpae_ste Decaen 000L Leat sy
. PP MANAGUENT  Lpup_ste e oot Leal [iyE—
= el Types
= References
25 Cause (ENUMD)
2 Direcion ENUM)
% STATE ENUM)

o e X PROGRAM PUMP_MANAGNENT
7 scope Name Address Datatype Initalization Comment Atributes ~0
2 v pump state eooL
2 VA THM L pump_started so0L M
mon_bool1 ma_sortie_bool

N Ci00% v

Fle Edit View Project Buld

FBDADAI

Right-click the project and select Export PLCopenXML....

L Detug TWnCAT PLC Tools Sope Window Hielp
D

QS Dk BIE -
)-ionc 3 =dl ED) u
X

jep_project - Microsoft Visual Studio

S -

|| ToincaT AT 66y -8 |uobjecingex

TR Scope: PUMP_MANAGHENT g
~ Variabie ccess Type Swope  Addies  Location Comment
POV ANAGHENT L. st Dsiewen  BOOL Lasa Line3 pse)
PUMP JANAGUENT  l_pomo.stte e BooL Laso -
SRS 5 gy
& our
e Rebuid
o0 Checkal objects .
S dean
s mow
oq A ,
+ 2 p0U [ Import PLCopenthL
06 g
B ExportPLCopenL.
5
d  smeastiay,
b sseastirayns ———— =
X [Remors el i PROGRAM PUMP_MANAGMENT
@ Properies AvEre | scope Address Datatype Intalzation Comment  Atrbutes Y=l
5y e ViR _pump_state eooL
001 FUN) 2 VAR THM_f_pump_started so0L .
+ T S 5
AT -
& ERROR R B
B GeroTaTe =oe pooty PR —
i STAKT t )
B PUMP MANAGMENT (PRG) -
+ 0 Super PUMP FB) i
5415 RUNNING =

Click Save.

0 Microsoft Visua Studio 2010

E jcp_project

Py Export PLCopenXML File

@ o - 1 M cercr v C|  Rechercher dans: CepC 2
Organiser -

- Microsoft Visual Studio

hdtess Locaton Comment
oo sy
s —
T
IR docmens
R iporan f
[ & cerc
473 Bibliothéques. b images
Dacuments ~
< mages
& Musiaue u} Musique
Nom uicir: X PGt E
Type: PLCopenXML s (i) > PUMPERROR  PUMP  PUMPGETSTATE  POL1  jcp  Super PUMPISFUNNING  MOTO
= Masuerts dossiers e | e s comnen v -0
3
o0 v M _punp_sanea w00t v
P . >
Bac =
(5 ERROR
Sicersia ae_sertic_bost
I ]
@ PP MANAGUENT 0% .
+ 3] Super PUMP 8) i Iﬁ 11 pump state | | 4
TE o
y— Shm_£113 s dicecrion
N[+ T100% &V

Bureau
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PHOENIX CONTACT Multiprog v5.5 (.XML File Export)

Export the MULTIPROG controller application to an XML export file in order to be

processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Export....

File| Edit View Project Build Online Extras

D| New Project... CTRL+N
3 @j| Open Project / Unzip Project.. CTRL+0O
5 Save Project As / Zip Project As...

o o2 [

-

;-\m Close Project
S<| Delete Project...

Save As Template...
Delete Template...

As Network Ter

53

m
;]J

Export...
Import...

Enter password...

m
}
’

1oL
[¥5)

i

ave All

i}

Print Setup...
Print Project...

2 Select Export PLCopen xml file.

Import / Export X

Extended [ECB1131-3 Export | Ok |

Cancel

Description:

Export in PLCopen xml format.

3 Provide a name for the export file.

4 Click Save.

As MULTIPROG can export the controller application in different versions of
PLCopen, there may be differences in the way your EcoStruxure Control
Engineering tool processes the export file, depending on the PLCopen version.
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Rockwell Automation® RSLogix 5000® or Studio 5000 (.
L5K File Export)

Export the Rockwell Automation® RSLogix 5000® controller application to a L5K
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Save as....

2 In the Save as... dialog box, provide a name for the L5K file.

3 If required, modify the storage location.

4 Select the file type: RSLogix 5000 Import/Export File (*.L5K).

5 Click Save.
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Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File

Export)

Overview

The following steps are required to process a Siemens SIMATIC STEP 7
controller application with EcoStruxure Control Engineering tools:

Set your SIMATIC STEP 7 workshop to German abbreviations (mnemonics).

Create and export the symbols of the controller application to an .ASC file.
Create and export the contact code (CONT) to an .AWL file.

Create and export the graph blocks (GRAPH) to a .GRY files.

Compile the CFC code (if any) to create the corresponding SCL sources.
Export structural codes (SCL) to .SCL files.

Setting German Mnemonics

Before creating the export files, set your SIMATIC STEP 7 workshop to German
abbreviations (mnemonics):
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Step Action
1 From the menu, select Options > Customize....
B o A e S S el P T e 1
s Changelog L
L Text Libraries v (L
E Language far Display Devices.., E{
- 5
u Manage Multilingual Texts o
L Rewvire.., Cl
B Run-Time Froperties.., Cl
T Cl
E Compare Blocks.., Tl
T Reference Data kTl
d  Define Global Data Tl
T Configure MNetwork Tl
T Cl
En Simulate Modules E
£  Configure Process Diagnostics B
T ) B
g  Editsafety program B
Chy Data 3
Set PG/PC Interface...
2 Display the Language tab.
Custormize il
Gntm I teszage numbers I Archiving
| Language | General I Date and Time of Day I Wig
i — Mational Language —Mremaonics
I englizh
deutzch - % Geman JE1.D 5 A4.0
frangais  Engish  Al1.0 5040
espafiol
italiana
Cancel Help
3 Select German mnemonics.
4 Click OK.

60

EI00000004427.03



Manufacturer-Specific File Export Procedures

Creating an ASC File

Step

Action

1

Right-click the symbols table in your program folder and select Open object.

% Ecluzel Object name I Symbolic name I Type
E‘" M“: DD[” (B Sources Source Folder
&
----- {£H Blocs
Cut Chrl+X
Copy Ctrl+C
Paste Crl+4
Delete Del
PLC »
Print 3
Renarne F2
Object Properties.., Aft+Return
Special Object Properties ]

From the menu of the symbols editor, select Symbol Table > Export....

Window  Help

Insert  Wiew Options

Ctrl +0 j_

Close Ctrl+F4

EN Sawve Ctrl+5 Prm
2 |

EN

4

_I: "

El

Exmmmiiom CH+F war
|8 | Print Preview... wer
|9 | Page Setup... it
1 rtir

Select ASCII Format (*.ASC).

IS_l,lmbols. azc

|ASCIl Format [~45C)
| !

* Data Interchangé Farmat [*.DIF)
Swyztem D ata Format [ SDF)
2940 [".A5C," SEQ,".DIF,". SDF)

Provide a name and select a directory for the .ASC export file.

Click Save.

Creating an AWL File

To create an .AWL file, first generate the LIST source for the code blocks
developed in the languages CONT, LIST and LOG.
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Step Action
1 Right-click a CONT, LIST or LOG source and select Open Object to open the CONT/
LIST/LOG code editor.
E--% Ecluzel Object name | Sembolic name | Created in
E-ER SIMATIC 300(1) : i
=-[@ cPuI4c2oP
El{z5] Programme 57(1] |, £ Ctrl +8lt+0
F = =S
B F Cut Ctrl+X S0l
oF Copy Ctrl+C .
oOF Paste Chr+1f oL
OF Delete Dl sCL
i F S5TL
A Insert Mew Object | STL
3F FLC b | STL
i F ) S5TL
o F Rewvire... 5oL
o0l Compare Blocks.. DE
0D Reference Data » | DB
oD Print R LB
@ M DB
Rename F2
Object Properties.., Alt+Return
Special Object Properties 4
2 From the menu, select File > Close to close all open objects.
Edit Insert PLC Debug View Options ‘Window Help
T e, Ctrl+M
| Open.. Ctrl+0
- i kL TRIC i
B Ctrl+F4
£ Save Ctrl+5 1
£ Sawe A,
B Store Read-Only ...
£
Properties...
b Check and Update Accesses
Check Consistency Ctrl +AlE+k
Compile Ctrl+E
Generate Source.., Ctrl+T -
Print... Ctrl+P -
Print Presiew..,
Page Setup...
3 From the menu, select File > Generate source... to generate the program source.

jewy  Options  Help

Ctrl+M
Ctrl+0

Chrl+T
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Step Action

4 Provide an object name and click OK.

Entry pairt: Wigt:

IProiect ;I IEomponent wiew LI  Online & Offline

Mame: Storage path:

IEcIuse1 ;I I | Browse... | I?
E--% Eclusel code_ladder zection_laddder

E-EJ SIMATIC 300(1)
=-§ crustac2oP
E@ Programme 57(1]

{B] Sources
% Blocs
. | |
I Obiect name:  [CONT_LIST_LOG] 1
Dbiect type: ISTL Source ;I
5 Click All to select all program blocks and select the options Sort according to

program structure and Symbolic addresses.

MHate: Autornatic generation of single sources per block:
tenu 'Options' » "Customize’ in the "Sources' tab

Path: EcluselSIMATIC 30001 NCPU 314C-2 DP...
Blocks Mot Selected: Blocks Selected:

I arne/F amily:
[ User created F-FBs, F-FCs and F-DEs —Addreszes
v |nclude reference blocks [

W Sart according to program structure {* Sumbalic

Source containg checksum of the blocks

QK. | Cancel Help

6 Click OK to confirm.

If your controller application contains safety-related blocks, export those blocks in
a separate AWL file. Refer to Safety-Related Applications, page 66 for details.

Creating a GR7 File

The .GRY7 sources have to be created for each GRAPH blocks separately. Repeat
the following procedure for each GRAPH block to be exported.
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Manufacturer-Specific File Export Procedures

Step Action
1 Right-click a GRAPH object and select Open Object.
Lommande
SCL
Copy Ctrl+C -
Paste Chrl +4 0L
Delete Del STL
STL
Insert Mew Object » STL
PLC 3 5TL
] SCL
Rewvire.., OB
2 From the menu, select File > Generate Source File.
Edit Insert PLC Debug View Options ‘Window Help
M e, Ctrl+M |
Open... Ctrl+0
Claose
Sawve Ctrl+5
Sawve D,
Properties...
Consistency Check Ctrl + 21t +K
Cormpile Ctrl+B
MuodifyfAdapt Instance DB Mumber...
Ctrl+T
ML e et o
Print... Ctrl+P
Print Prewviews..,
Page Setup...
3 Provide a name for the GRAPH object.
Entry paint: Wigw:
IF‘miect j IComponent wiEw j  Orline & Offline
Mame: Starage path:
IEcIuse1 j I Browse... | L_ =
- Eclusel
E-E# SIMATIC 300(1)
= cPU 31aC2 0P
=8 Programme S7(1]
| |
Object name: |GrapH I
Object type: Imce j
Cancel Help I
4 Click OK to confirm.
5 Repeat the procedure for each GRAPH object to be exported.
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Creating a CFG File

The CFG file is required for analyzing the communication and the hardware
configuration of the station.

Step Action

1 Double-click your CPU's links in the main window to open NetPro.

2 In the NetPro window, double-click the CPU of the station to be exported open the HW
Config utility.

3 From the Station menu, select Export... to export your station configuration (leave the

default settings in the dialog).

4 If the controller application contains CFC code, compile the code to generate the
corresponding SCL source files which are the files processed with EcoStruxure Control

Engineering tools. To do so, open the CFC code editor by clicking its icon in the toolbar
of the main window .

SHcrc [ ] _[al x|

[ chart Edt Insert CPU Debug View Options Window Help -1

DEs s e mEEe| s a8 w2 g B0k esBEm N

) New Chart =
New Text
& All blocks
its.. i

I~ Find iniialletter

£l WY g KN —

Press F1 for help =
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[&/5hest 6 [OB1
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Step Action

click OK.

CPL:

Proaram narne:

— Srane

Compile the code with the options Entire program and Generate SCL sources and

Compile program

Carpile Chartz az Program |

CPU 313-3 PN/DP
MP345CPU 319-3 PMADPYS Y Programm

x|

| %' Entire program
‘ {~ Changes only

¥ Generate module drivers

¥ Generate SCL source

Black Driver Settings. ..

Cancel Help |

Object name

The generated SCL source file can then be exported like other source files (refer to
Exporting Files, page 70).

| Symbalic name

| Type

DET1_Alam_DE
MP34_C

ample

be

STL Sourc
STL Sourc

Zipen Object Chrl+Al+0
Cut Chrl+
Copy Chrl+C
Paste el
Delete Del

Insert Mew Object
PLC

p= T

Lo

Rename
Ohject Properties. ..
Special Cbject Properties

F2
Ale+Return

Safety-Related Applications

A safety-related controller application contains two code parts:

* The non-safety
* The safety-rela

-related code part
ted code part

Procedure for exporting controller applications that contain safety-related code:

Step Action
1 Export the .ASC file that contains the database for the safety-related code and for the
non-safety-related code (refer to Creating an ASC File, page 61).
2 Generate the sources for the non-safety-related code parts (refer to Creating an AWL
File, page 61 and Creating a GR7 File, page 63).
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Step Action

3 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

MHate: Autornatic generation of single sources per block:
tenu 'Options' » "Customize’ in the "Sources' tab

Path: EcluselSIMATIC 30001 NCPU 314C-2 DP...
Blocks Mot Selected: Blocks Selected:

I arne/F amily:
[ User created F-FBs, F-FCs and F-DEs —Addreszes
v |nclude reference blocks [

W Sart according to program structure {* Sumbalic

Source containg checksum of the blocks

QK. | Cancel Help

4 Click OK to confirm.

5 Follow the procedure for Creating an AWL File, page 61 until the dialog Generate
source Safety is displayed.
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Creating a dif File

Step Action
6 Select the option User-created F-FBs, F-FCs and F-DBs and click OK to confirm.
Generate source Safety ﬂ
MHate: Autoratic generation of single sources per block:
tenu 'Options' > 'Cugtomize’ in the 'Sources' tab
Path: Eclusel“SIMATIC 300(1MCPU 314C-2 DPA...
Blocks Mot Selected: Blocks Selected:
Safety Block
<...
I arne/F amily:
Iv User created F-FBe, F-FCs and F-DEBs Addresses
| " Absolute
[# * Symbolic
[~ Source containg checksum of the blocks
QK. Cancel Help
7 Create a .dif file (refer to Creating a dif File, page 68). The .dif file is used to determine
whether code is safety-related.

A .dif file is created in the SIMATIC Manager of SIMATIC STEP 7 in the following

way:
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Step Action
1 From the menu, select Options > Reference Data > Display.
B find oy Help
ustomize... Ctrl+Alt+E ;I Wy | BE EH
#ieesg Medeebio i’ reated in language | Size in the
Change Log 2
Text Libraries v iTL
Language far Display Dewvices.., EHLAF'H
Manage Multilingual Texts 4
Rewvire... CL
Run-Tirme Properties...
Reference Data Ctrl +8/t+R
Define Global Data
Confi Metwork
onfigure Metwor Generate
Sirmulate bModules
. . ) Delete
Caonfigure Process Diagnostics
=
Edit safety program B
Chu Data v 1B
B
Set PG/PC Interface..,
2 In the Display S7 reference data dialog, select the option regenerated? and click Yes.
& Should the reference data be ..
" ypdated?
Yes Mo | Cancel Help
3 In the Customize dialog, select the option Program Structure and click OK to display

the program structure.

—*iew to Be Opened

 Cross-references

fesignment oot Clutput, Bit Memnary, Timers, Counters)

& Program Stucture

Unuszed Symbols

" Addreszes without Symbal

v Display this message every time a project is opened,

oo |
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Exporting Files

Step Action
4 From the menu, select View > Export to open the Save dialog box.
Reference Data  Edi indows  Help
34 rass References 5
= & © ]
Assignment —
v Prograrm Structure
Unused Symbaols
Addresses without Syrmbol
Block (symbol) Cross References for Address ocal
=-1 S7 Prograd
= D DRl |::'| )
FC1 Filter...
® DBL(CI <. ]
® DB2(C ]|
® DB3 (Tl v Toolbar 0]
® DB4 (Cl v Status Bar o]
™ FC2 (A 2]
B FCa (M Update Fa 2]
L = T e T T2
5 Provide a name for the .dif and click Save.

After you have created the files, export them from SIMATIC STEP 7:

Step Action
1 Select the LIST, GRAPH (or .AWL and .GRY7 files) and SCL sources that you have
generated.
2 Right-click the sources and select Export source....
% File  Edit Insert PLC View Options Window Help
D 276 | 4 R |da|o %20
EI--% Eclusel Object name Symbalic harne Type
= SIMATIC 30001) P
EI CPU 31402 DP Open Chject Ctrl+21t+0
T2 'k Cut Ctrl+X
Copy Ctrl+C
Paste Chrl +4
Delete Del
Insert MNew Object 3
PLC 3
Print 3
Special Object Properties »
3 Select a file name and a storage location and click Save.
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Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export)

Export the Siemens TIA Portal SIMATIC STEP 7 controller application to a ZIP

export file in order to be processed with EcoStruxure Control Engineering tools.

The export can be performed automatically with the EcoStruxure Control
Engineering - Import/Export tool. Select SUPPORT > DOWNLOADS.

Refer to the EcoStruxure Control Engineering - Import/Export user guide for
details on the export procedure.
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