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Legal Information
The Schneider Electric brand and any trademarks of Schneider Electric SE and its
subsidiaries referred to in this guide are the property of Schneider Electric SE or its
subsidiaries. All other brands may be trademarks of their respective owners.

This guide and its content are protected under applicable copyright laws and
furnished for informational use only. No part of this guide may be reproduced or
transmitted in any form or by any means (electronic, mechanical, photocopying,
recording, or otherwise), for any purpose, without the prior written permission of
Schneider Electric.

Schneider Electric does not grant any right or license for commercial use of the guide
or its content, except for a non-exclusive and personal license to consult it on an "as
is" basis. Schneider Electric products and equipment should be installed, operated,
serviced, and maintained only by qualified personnel.

As standards, specifications, and designs change from time to time, information
contained in this guide may be subject to change without notice.

To the extent permitted by applicable law, no responsibility or liability is assumed by
Schneider Electric and its subsidiaries for any errors or omissions in the informational
content of this material or consequences arising out of or resulting from the use of the
information contained herein.

As part of a group of responsible, inclusive companies, we are updating our
communications that contain non-inclusive terminology. Until we complete this
process, however, our content may still contain standardized industry terms that may
be deemed inappropriate by our customers.
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Safety Information

Safety Information
Important Information

Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

Please Note
Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

Before You Begin
Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an 
electrical hazard exists which will result in personal injury if the instructions are not 
followed.

This is the safety alert symbol. It is used to alert you to potential personal injury 
hazards. Obey all safety messages that follow this symbol to avoid possible injury or 
death.

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious 
injury.

! DANGER

WARNING indicates a hazardous situation which, if not avoided, could result in death or 
serious injury.

WARNING!

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or 
moderate injury.

CAUTION!

NOTICE is used to address practices not related to physical injury.

NOTICE
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Safety Information

WARNING
UNGUARDED EQUIPMENT
• Do not use this software and related automation equipment on equipment

which does not have point-of-operation protection.
• Do not reach into machinery during operation.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only you, the user, machine builder or system integrator can be aware of all the
conditions and factors present during setup, operation, and maintenance of the
machine and, therefore, can determine the automation equipment and the related
safeties and interlocks which can be properly used. When selecting automation
and control equipment and related software for a particular application, you should
refer to the applicable local and national standards and regulations. The National
Safety Council's Accident Prevention Manual (nationally recognized in the United
States of America) also provides much useful information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch points or
other hazardous areas and serious injury can occur. Software products alone
cannot protect an operator from injury. For this reason the software cannot be
substituted for or take the place of point-of-operation protection.

Ensure that appropriate safeties and mechanical/electrical interlocks related to
point-of-operation protection have been installed and are operational before
placing the equipment into service. All interlocks and safeties related to point-of-
operation protection must be coordinated with the related automation equipment
and software programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.

Start-up and Test
Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start-up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check are made and that enough time is allowed to perform complete and
satisfactory testing.

WARNING
EQUIPMENT OPERATION HAZARD
• Verify that all installation and set up procedures have been completed.
• Before operational tests are performed, remove all blocks or other temporary

holding means used for shipment from all component devices.
• Remove tools, meters, and debris from equipment.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Safety Information

Follow all start-up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and temporary
grounds that are not installed according to local regulations (according to the
National Electrical Code in the U.S.A, for instance). If high-potential voltage
testing is necessary, follow recommendations in equipment documentation to
prevent accidental equipment damage.

Before energizing equipment:
• Remove tools, meters, and debris from equipment.
• Close the equipment enclosure door.
• Remove all temporary grounds from incoming power lines.
• Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments
The following precautions are from the NEMA Standards Publication ICS 7.1-
1995:

(In case of divergence or contradiction between any translation and the English
original, the original text in the English language will prevail.)

• Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

• It is sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

• Only those operational adjustments required by the operator should be
accessible to the operator. Access to other controls should be restricted to
prevent unauthorized changes in operating characteristics.
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About the Book

About the Book
Document Scope

The present user guide describes the functionality provided by EcoStruxure
Control Engineering - Converter.

Validity Note
This document has been updated for the release of EcoStruxure Control
Engineering V23.1.

The characteristics that are described in the present document, as well as those
described in the documents included in the Related Documents section below,
can be found online. To access the information online, go to the Schneider Electric
home page www.se.com/ww/en/download/.

The characteristics that are described in the present document should be the
same as those characteristics that appear online. In line with our policy of constant
improvement, we may revise content over time to improve clarity and accuracy. If
you see a difference between the document and online information, use the online
information as your reference.

Related Documents
Title of documentation Reference number

EcoStruxure Control Engineering - Converter -
User Guide (this user guide)

EIO0000004425 (eng)

EcoStruxure Control Engineering -
Documentation - User Guide

EIO0000004426 (eng)

EcoStruxure Control Engineering - Verification -
User Guide

EIO0000004424 (eng)

EcoStruxure Control Engineering - Monitoring -
User Guide

EIO0000004427 (eng)

Cybersecurity Best Practices CS-Best-Practices-2019-340

EDI2200, Manuel de référence 1590595K01000 (fre)

EcoStruxure Control Engineering, Hardening
Guide

EIO0000004982 (eng)
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About the Book

Product Related Information

WARNING
LOSS OF CONTROL
• Perform a Failure Mode and Effects Analysis (FMEA), or equivalent risk

analysis, of your application, and apply preventive and detective controls
before implementation.

• Provide a fallback state for undesired control events or sequences.
• Provide separate or redundant control paths wherever required.
• Supply appropriate parameters, particularly for limits.
• Review the implications of transmission delays and take actions to mitigate

them.
• Review the implications of communication link interruptions and take actions

to mitigate them.
• Provide independent paths for control functions (for example, emergency

stop, over-limit conditions, and error conditions) according to your risk
assessment, and applicable codes and regulations.

• Apply local accident prevention and safety regulations and guidelines.1

• Test each implementation of a system for proper operation before placing it
into service.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

1 For additional information, refer to NEMA ICS 1.1 (latest edition), Safety
Guidelines for the Application, Installation, and Maintenance of Solid State Control
and to NEMA ICS 7.1 (latest edition), Safety Standards for Construction and
Guide for Selection, Installation and Operation of Adjustable-Speed Drive
Systems or their equivalent governing your particular location.

WARNING
UNINTENDED EQUIPMENT OPERATION
• Perform a risk assessment as per ISO 12100 and/or other equivalent

assessment in view of your use of EcoStruxure Control Engineering.
• In your risk assessment, consider all applicable regulations and standards

that apply to your development process and to your machine/process.
• Verify that your use of EcoStruxure Control Engineering is fully covered in

the definition of your software development process and that your software
development process meets all applicable regulations and standards.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
commission or recommission the machine/process in compliance with all
regulations, standards, and process definitions applicable to your machine/
process.

• During commissioning or recommissioning of the machine/process, verify
the correct operation and effectiveness of all safety-related functions and
non-safety-related functions by performing comprehensive tests for all
operating states, for the defined safe state of your machine/process, and for
all potential error situations.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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EcoStruxure Control Engineering - Converter converts the application logic,
database, structure, and behavior of controller applications. Infrastructure-specific
code (for example, code relating to hardware, communication infrastructure,
configuration, axes, counters) is not converted or may only be partially converted,
for example, because the tool cannot be aware of the configuration and
requirements of your target system. Therefore, certain code parts will miss from
the converted code, or have only been partially converted.

You must subject the entire code converted by EcoStruxure Control Engineering -
Converter to a full review, verification and validation.

In this process, you must, among other things, adapt the code to your target
infrastructure. The information on post-conversion steps provided in the present
user guide is not exhaustive, because only you, the user of EcoStruxure Control
Engineering - Converter, can be aware of all requirements relating to your target
controller application.

WARNING
UNINTENDED EQUIPMENT OPERATION
• In your risk assessment, consider all potential effects of using EcoStruxure

Control Engineering - Converter, including, but not limited to, inappropriate,
incorrect or incomplete input code as well as inappropriate, incorrect or
incomplete converted output code.

• Verify that the converted code is properly adapted to all requirements of your
target system.

• Subject the converted code to a full review, verification and validation by
appropriately qualified personnel; and according to all applicable regulations,
standards, and process definitions.

• Do not rely on the conversion report provided by EcoStruxure Control
Engineering - Converter as the sole source of information in reviewing,
verifying, validating, or otherwise assessing or using the converted code.

• Ensure that your overall machine/process for which EcoStruxure Control
Engineering - Converter has been used is properly certified and/or approved
according to all standards, regulations, and directives applicable at the
installation site of the machine/process.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

EcoStruxure Control Engineering - Converter is neither certified nor intended for
conversion of safety-related code.

WARNING
INSUFFICIENT AND/OR INEFFECTIVE SAFETY-RELATED FUNCTIONS
• Do not convert safety-related code with EcoStruxure Control Engineering -

Converter.
• Re-design any and all converted code in compliance with all applicable

safety-related regulations, standards, and certification requirements if, after
the conversion, you decide to use any part of such converted code for
safety-related purposes.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

WARNING
INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS
• In your risk assessment, consider all potential effects of inappropriate,

incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

• Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

• After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Machines, controllers, and related equipment are usually integrated into networks.
Unauthorized persons and malware may gain access to the machine as well as to
other devices on the network/fieldbus of the machine and connected networks
because of insufficiently secure access to software and networks.
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Schneider Electric adheres to industry best practices in the development and
implementation of control systems. This includes a "Defense-in-Depth" approach
to secure an Industrial Control System. This approach places the controllers
behind one or more firewalls to restrict access to authorized personnel and
protocols only.

WARNING
UNAUTHENTICATED ACCESS AND SUBSEQUENT UNAUTHORIZED
MACHINE OPERATION
• Evaluate whether your environment or your machines are connected to your

critical infrastructure and, if so, take appropriate steps in terms of prevention,
based on Defense-in-Depth, before connecting the automation system to
any network.

• Limit the number of devices connected to a network to the minimum
necessary.

• Isolate your industrial network from other networks inside your company.
• Protect any network against unintended access by using firewalls, VPN, or

other, proven security measures.
• Monitor activities within your systems.
• Prevent subject devices from direct access or direct link by unauthorized

parties or unauthenticated actions.
• Prepare a recovery plan including backup of your system and process

information.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

For more information on organizational measures and rules covering access to
infrastructures, refer to ISO/IEC 27000 series, Common Criteria for Information
Technology Security Evaluation, ISO/IEC 15408, IEC 62351, ISA/IEC 62443,
NIST Cybersecurity Framework, Information Security Forum - Standard of Good
Practice for Information Security, and refer to Cybersecurity Guidelines for
EcoStruxure Machine Expert, Modicon and PacDrive Controllers and Associated
Equipment.

For reasons of Internet security, for those devices that have a native Ethernet
connection, TCP/IP forwarding is disabled by default. Therefore, you must
manually enable TCP/IP forwarding. However, doing so may expose your network
to possible cyberattacks if you do not take additional measures to protect your
enterprise. In addition, you may be subject to laws and regulations concerning
cybersecurity.

WARNING
UNAUTHENTICATED ACCESS AND SUBSEQUENT NETWORK INTRUSION
• Observe and respect any and all pertinent national, regional and local

cybersecurity and/or personal data laws and regulations when enabling
TCP/IP forwarding on an industrial network.

• Isolate your industrial network from other networks inside your company.
• Protect any network against unintended access by using firewalls, VPN, or

other, proven security measures.
Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Consult the Schneider Electric Cybersecurity Best Practices for additional
information.
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About the Book

Terminology Derived from Standards
The technical terms, terminology, symbols and the corresponding descriptions in
this manual, or that appear in or on the products themselves, are generally
derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, fault,
fault reset, malfunction, failure, error, error message, dangerous, etc.

Among others, these standards include:

Standard Description

IEC 61131-2:2007 Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2015 Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013 Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010 Safety of machinery - General principles for design - Risk assessment
and risk reduction

EN 60204-1:2006 Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013 Safety of machinery - Interlocking devices associated with guards -
Principles for design and selection

ISO 13850:2015 Safety of machinery - Emergency stop - Principles for design

IEC 62061:2015 Safety of machinery - Functional safety of safety-related electrical,
electronic, and electronic programmable control systems

IEC 61508-1:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: General requirements.

IEC 61508-2:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: Requirements for electrical/electronic/programmable
electronic safety-related systems.

IEC 61508-3:2010 Functional safety of electrical/electronic/programmable electronic safety-
related systems: Software requirements.

IEC 61784-3:2016 Industrial communication networks - Profiles - Part 3: Functional safety
fieldbuses - General rules and profile definitions.

2006/42/EC Machinery Directive

2014/30/EU Electromagnetic Compatibility Directive

2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control – Fieldbus for
use in industrial control systems

Finally, the term zone of operation may be used in conjunction with the description
of specific hazards, and is defined as it is for a hazard zone or danger zone in the
Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.

EIO0000004425.05 13



Introduction to EcoStruxure Control Engineering - Converter

Introduction to EcoStruxure Control Engineering -
Converter

EcoStruxure Control Engineering - Converter is a code conversion and re-
engineering tool for controller applications. The tool supports modernization and
migration projects by converting a controller application to a different controller
brand, model, and/or programming language, maintaining the behavior and
semantics of the source controller application.

EcoStruxure Control Engineering - Converter focuses on the conversion of the
application logic, database, structure, and behavior. Infrastructure-specific code
(for example, code relating to hardware, communication infrastructure and
configuration) is not converted, for example, because the tool cannot be aware of
the configuration and requirements of your target system.

EcoStruxure Control Engineering - Converter is a Software as a Service (SaaS)
tool accessible using a web browser.

The number of source and target systems that EcoStruxure Control Engineering -
Converter supports is increased on an ongoing basis. The supported systems are
available at https://ecostruxure-control-engineering.se.app/.

14 EIO0000004425.05
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Registration, Login, My Account, Licenses and
Sessions

Registration

Overview
The EcoStruxure Control Engineering tools are accessible using the cloud version
or using a dedicated server for your organization.

The URL of the cloud version is https://ecostruxure-control-engineering.se.app/.

If a dedicated server has been set up for your organization, the URL is available
from your system administrator.

In both cases, you must create a user account to use the tools.

Browser Compatibility
The following web browsers are supported:

• Mozilla Firefox from version 11
• Google Chrome from version 16
• Microsoft Edge from version 12
• Microsoft Internet Explorer from version 10
• Apple Safari from version 7

Login Options
You can login to the EcoStruxure Control Engineering platform by using the
following options:

• Schneider Electric Account
• Legacy EcoStruxure Control Engineering

Step Action

1 Go to https://ecostruxure-control-engineering.se.app/.

Result: The following window appears:

NOTE: You can choose either the legacy web platform accounts management
or Schneider Electric account. However, eventually the Legacy option will be
transistioned to the Schneider Electric option. You can create a Schneider
Electric account by clicking the Use A Schneider Electric Account button
wherein you can create a new account. In order to preserve the data you have
from the legacy account, use the same email address you used to create the
legacy. See Login using Schneider Electric Account, page 17.

EIO0000004425.05 15
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Registration
Registration procedure for the cloud version of EcoStruxure Control Engineering
tools:

Step Action

1 Click on any one login options.

2 Click Sign up or Register Here.

3 Fill in the form with your first and last names, your phone number, your e-mail address
(which is used as your identifier) and select a password. Password requirements:

• At least one uppercase character
• At least one lowercase character
• At least one numerical character
• At least one special character (such as ”{”, ”/”, “$” )
• Password length between 8 and 32 characters

4 Read the Terms and Conditions and, if you agree, select I agree to the Terms and
Conditions.

5 Click Sign Up.

Result: A verification e-mail is sent to you.

6 The verification e-mail sent to you contains a link that you need to follow.

Result: Your account is activated within a period of 48 working hours.

NOTE: If a dedicated server is set up for your organization, contact your
system administrator for details on the registration procedure.

16 EIO0000004425.05
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Login

Login using Schneider Electric Account
This is the new method to login to the EcoStruxure Control Engineering platform.
Legacy accounts for the EcoStruxure Control Engineering platform will be
migrated to Schneider Electric accounts (SE accounts). If you are using the legacy
login method but want to migrate to the account login method, use or create a
Schneider Electric user account that uses the same email address as your legacy
account. After the first login with a Schneider Electric user account, subsequent
logins must be completed using your Schneider Electric user account.

Step Action

1 When your registration on the Schneider Electric account is completed and your
account is ready, go to https://ecostruxure-control-engineering.se.app/.

2 Select Use a Schneider Electric Account, the following window appears:

3 Enter your email address, click Next and then enter your password.

Result: After validation, you are redirected to the dashboard in EcoStruxure Control
Engineering platform.

NOTE: For more information on Schneider Electric accounts, contact your
local Schneider Electric service representative.

EIO0000004425.05 17
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Login using Legacy EcoStruxure Control Engineering

Step Action

1 Select Use An EcoStruxure Control Engineering Account, the following dialog box
appears:

2 Click Close to close the dialog box.

3 Enter your email address and password in the respective fields.

4 Click Login.

Result: The Dashboard window appears.

18 EIO0000004425.05
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My account Page

My account Page When Using a Schneider Electric Account
The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.

Step Action

1

In Dashboard window, click .

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Schneider Electric Profile Tab

The Schneider Electric Profile tab lists the user personal information such as the
identity, phone number, country. To update this information, you need to edit your
Schneider Electric profile, which is accessible with the link provided in the
Schneider Electric Profile tab.

Third-Party Apps Settings Tab

The Third-Party Apps Settings tab allows you to generate an applicative
password to connect your application to EcoStruxure Control Engineering when
your application does not support the Schneider Electric account authentication.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between the different views available
on the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:
• you are using dedicated server and the server is configured to send the

emails.
• you are using cloud version (Not applicable for Monitoring)

My account Page When Using a Legacy EcoStruxure Control
Engineering

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.
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Step Action

1

In Dashboard window, click .

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Profile Tab

The Profile tab lists the user personal information such as the identity, phone
number, country, etc. You can update this information at any time.

Password Tab

The Password tab provides the password change form. You can change your
password at any time.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between different views available on
the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:
• you are using dedicated server and the server is configured to send the

emails.
• you are using cloud version (Not applicable for Monitoring)
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Licenses

Overview
Schneider Electric offers various license plans for EcoStruxure Control
Engineering tools.

Paid License Plans
Contact your local Schneider Electric representative for details on the available
license plans for EcoStruxure Control Engineering tools. A selection of licenses is
also directly available from Schneider Electric Exchange at https://exchange.se.
com/shop.

EIO0000004425.05 21
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Sessions

Automatic Log-Out (Session Time-Out)
After 10 minutes of inactivity in an EcoStruxure Control Engineering session, you
are automatically logged out. If you work with multiple browser tabs, the most
recent activity in any of the tabs applies. For example, if you work in tab 1, but not
in tab 2, tab 2 does not disconnect you because there is activity in tab 1.

Multiple Sessions
If your credentials are used in multiple sessions, you receive a notification. For
example, if you are logged in and another session is established with the same
credentials, you receive the following message:

The information on the connection date and time, the IP address, the operating
system and browser help you to determine whether or not a sessions is legitimate.
You can select and close a session with Close Session(s).
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Creating Projects and Programs

Introduction to Projects and Programs

Overview
EcoStruxure Control Engineering provides projects and programs for you to
organize your work.

A project is a type of container that can hold programs. A project is not specific to
an EcoStruxure Control Engineering tool.

When you register with EcoStruxure Control Engineering, the platform provides
one default project for you.

A program is assigned to a project. A program is created in conjunction with one of
the tools provided by EcoStruxure Control Engineering. A program typically
comprises metadata you entered during its creation, the uploaded source code of
a controller application, and the results generated with the EcoStruxure Control
Engineering tools.

The EcoStruxure Control Engineering tools are launched from within a program.
Whether or not a specific EcoStruxure Control Engineering tool is available for a
program depends on the source controller/development environment you select
during the creation of the program (PLC Brand or PLC source brand).

Programs can be shared with other users.

Example
Assume you have been assigned the task of improving a machine ABC with two
controllers X and Y. In a first step, you want to better understand the code of the
two controller applications. You create a project “Machine ABC”. Then you add
two programs to this project: “Controller X” and “Controller Y”.

In both of these programs, you run EcoStruxure Control Engineering -
Documentation to visualize the data flow and the control flow.

In a subsequent step, your task is extended to managing the creation of a new
version of the controller applications. You start by running EcoStruxure Control
Engineering - Verification in your programs to verify the existing code. You share
the two programs with the developers so they can access the results of the code
verification for assistance in updating the code.

In subsequent steps, you can upload intermediate versions of the updated code
into your program and re-run EcoStruxure Control Engineering - Documentation
and EcoStruxure Control Engineering - Verification to document the progress and
verify that your coding rules have been properly implemented.
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Creating Projects and Programs

Creating Projects
Procedure for creating a project:

Step Action

1 Select PROJECTS in the top menu to display the Projects page.

2 Select Actions > New project.

3 Provide a unique name for your project. Lowercase and uppercase are ignored which
means that, for example, the name of a project to be created cannot be “Controller xyz”
if you already have a project with the name “Controller XYZ”. Click Add to create it.

4 Click Add to create the project.

Result: The project is added to your list of projects on the Open projects tab.

Clicking a project in the list displays two tabs. The Overview tab provides general
information on the project. The Programs tab contains the list of programs
assigned to this project.

Creating Programs
There are three ways to start the creation of a program:

• From outside of a project select TOOLS on the main menu
• From the dashboard click New ...
• From inside a project on its Programs tab select Actions > New program
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Creating a program from outside of a project:

Step Action

1 From the main menu, select TOOLS.

2 Select the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from the dashboard:

Step Action

1 From the main menu, select DASHBOARD.

2 Click the New ... button for the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from inside a project:

Step Action

1 From the main menu, select PROJECTS.

2 Select the required project from the list.

3 Display the Programs tab of the project.

4 Select Actions > New program.

Result: EcoStruxure Control Engineering prompts you for the tool to be used for the
program and starts the program creation wizard.
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Program Creation Wizard

Overview
A wizard guides you through the different steps required to create your program
and launch the execution of the selected EcoStruxure Control Engineering tool.

The project to which the new program is assigned depends on how the wizard is
started. If the wizard is started from outside of a project or from the dashboard, the
program is assigned to your default project. If the wizard started from inside a
project, the program is assigned to this project. In both cases, the project
assignment can be adjusted in step 1 of the wizard.

Refer to Creating Programs, page 24 for details.

Step 1 - Start
The first step consists of providing setup information on the program.

Provide the following information:
• The fields Application name and Customer name are mandatory. The

defined Application name is used to identify the program in the different
views of EcoStruxure Control Engineering.

• Add additional information in the other fields so that you can identify this
program in your project.

Continue with the next step by clicking Validate And Next Step.

Step 2 - Parameters
The second step consists of selecting the source development environment that
was used to develop the controller application and the required target
development environment for the converted code.
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Select the source development environment from the dropdown listbox PLC
source brand. Then select the target development environment from the
dropdown listbox PLC destination brand (the available options depend on your
selection for the source development environment).

You can optionally specify the kind of controller used with your target development
environment.

Continue with the next step by clicking Validate And Next Step.

Step 3 - License
The third step in creating an EcoStruxure Control Engineering program typically
consists of selecting the EcoStruxure Control Engineering license to be used with
your new program.

An EcoStruxure Control Engineering - Converter program consists of the two main
phases of estimation and actual conversion. The estimation is based on a code
analysis that is started when you finish the wizard. It provides key metrics on the
convertibility of your source code (refer to Estimation, page 32 for details). The
estimation can be launched without a license. Based on the results of the
estimation, you can decide whether you want to convert your code. If you opt for
an actual conversion after the estimation, EcoStruxure Control Engineering -
Converter prompts you for a license.

Click Validate And Next Step to continue.

Step 4 - Source file
The fourth step consists of uploading the file with the source code of the controller
application that you have exported from the development environment (refer to
Manufacturer-Specific File Export Procedures, page 40 for details). This source
code is the input material for EcoStruxure Control Engineering. Depending on the
EcoStruxure Control Engineering tool used for the program, you may be prompted
to upload additional files.
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Drag and drop the files to the location indicated or click Select Files… to import
the files. Then click Validate And Next Step to continue.

If the input files are not yet available when you create the program, you can skip
the upload with Validate And Next Step and provide the files at a later point in
time. Without the uploaded input files, the EcoStruxure Control Engineering tool
selected for this program cannot be executed.

Step 5 - Summary
The fifth step displays a summary of the information you have provided in creating
your program.

Review the information. If you want to make modifications, click Previous Step to
return to the step you want to modify.

If the information is correct, click Create to create the program or click Launch to
create the program and to start the EcoStruxure Control Engineering tool selected
for this program (this is possible if you have uploaded the required files).
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Accessing a Shared Program
If a program is shared with you, or if access to the program is not restricted (refer
to Sharing a Program, page 30), you can add it to your list of programs by
providing its unique 6-digit key. The unique 6-digit key can be found in the
program overview under Application key.

Procedure for adding a program to your list of programs using its unique 6-digit
key:

Step Action

1 From the menu, select PROJECTS to access the Projects page.

2 Click Shared applications to display the corresponding tab.

3 Enter the unique 6-digit key of the program in the field below User personal accesses
or in the field below One time access, depending on whether you want to add this
program to your personal records for access at a later point in time, or whether you
want to access it only once without adding it to your list of programs.

4 Click Add To My Applications or One Time Access.
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Sharing Programs with Other Users

Overview
You can share your programs with other users so that a team can work on the
same project. As the owner, you can share your program. Selected users with
whom you share your program cannot delegate their access rights, that is, they
cannot share this shared program with further users.

There are two ways of sharing a program:
• Share with selected users: You choose who can access your program. By

default, other users cannot share this program because you are the owner.
• Share with everyone: Everyone can access your program.

Sharing with a Specific User
Procedure for sharing a program with selected users:

Step Action

1 Navigate to the Program page.

2 Select Admin > Collaboration > Users access rights to display the User
management.

3 Below Invited collaborators, select Actions > Add .

4 Enter the name and the e-mail address of the user to be invited. You can enter the e-
mail address the user specified for registration with EcoStruxure Control Engineering,
or you can use any other e-mail address. You can also send an invitation notification to
the user. On a dedicated server, the invitation notification function requires a mail
server.

Users added to the list of invited users can perform the same actions as you, except for
sharing the program and modifying its settings. If you do not want invited users to
perform any further actions, deactivate the program with the Active application
checkbox in Admin > Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can revoke sharing by selecting the user(s) you want to remove from your
program and selecting Actions > Remove access.

Sharing with Everyone
Procedure for sharing a program with everyone:
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Step Action

1 Navigate to the Program page.

2 Select Admin > Settings.

3 Enable the checkbox Private application.

Users accessing your program can perform the same actions as you, except for sharing
the program and modifying its settings. If you do not want invited users to perform any
further actions, deactivate the program with the Active application checkbox in Admin
> Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function.

You can disable sharing with everybody by deactivating the checkbox Private
application. With this setting, only users explicitly invited can access your
program.
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Converting Controller Applications

Estimation

General Information
The estimation process is the first phase of a conversion. The objective is to
collect information on the potential result of the conversion without actually
carrying out the conversion. This provides an overview of the potential quantity
and quality of converted code and lets you assess the remaining post-conversion
effort.

This estimation is available after the program wizard has been run for the first
time. It is possible to run several estimation processes for a given program, even
with several target controller/development environments so you can assess
different scenarios with your program.

The estimation report provides a summary, page 32 and details, page 33. You can
also start the actual conversion from here, page 33.

Accessing the estimation report:

Step Action

1 Click Converter in the program.

2 From the list, select the target controller/development environment.

3 Select Estimation Report.

Estimation Report - Summary
The Summary of the estimation report provides an overview of the key metrics
concerning the convertibility of your source code.

The upper part of the summary contains a table with information on the source
and the destination controllers/development environments.
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The lower part of the summary provides percentage information on the amount of
code that can be converted and the percentage of detected issues in the code to
be converted. The corresponding messages are listed in the Details of the
Estimation Report, page 33.

Estimation Report - Details
The Details of the estimation report provide information on the elements found
during the analysis of your code performed with the estimation process.

The information is provided on four tabs:
• The tab Conversion impediment contains a list of detected blocking issues

for the code conversion. Conversion impediment conditions must be resolved
in the original source code before EcoStruxure Control Engineering -
Converter can start the code conversion. The list provides information on the
causes that keep the code from being converted.
Correct detected conversion impediments in your source code. Then, re-
upload your corrected source code and run a new estimation with the updated
program.

• The tab Conversion issues contains a list of detected issues that do not
prevent the code from being converted, but that can affect the quality of the
converted code in such a way that it is advisable to resolve them in the
original code before starting the code conversion.

• The tab Manual operations contains a list of detected issues you need to
resolve in the converted code before the code can be used.

• The tab Specific features contains an list of specific elements found in the
source code which are to be reviewed by you.
NOTE: If the Knowledge Base contains an article on an item in a list, you can
display the article with the link in the appropriate column.

Starting the Actual Conversion
The actual conversion is started by clicking Proceed. This step requires a valid
license.

If the estimation contains detected conversion impediments in your source code,
you cannot start the actual conversion. Correct detected conversion impediments
in your source code. Then, re-upload your corrected source code and run a new
estimation with the updated program.

You must confirm the disclaimer before you can start the actual conversion.
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After the conversion is complete, you can access the summary, page 35 and the
details, page 36 of conversion report as well as the download function for the
converted code, page 36 using the menu of the program.
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Conversion

General Information
The conversion process takes place in a second phase, after the estimation
process.

A conversion report is available after the conversion process has been completed.

The conversion report provides a summary, page 35 and details, page 36. You
can also download the conversion results from here, page 36.

Accessing the conversion report:

Step Action

1 Click Converter in the program.

2 From the list, select the target controller/development environment.

3 Select Conversion Report.

Conversion Report - Summary
The Summary of the conversion report provides an overview of the key metrics
concerning your converted source code.

The upper part of the summary contains a table with information on the source
and the destination controllers/development environments.

The lower part of the summary provides percentage information on the amount of
code that has been converted and the percentage of detected issues in the
converted code. The corresponding messages are listed in the Details of the
Conversion Report, page 36.
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Conversion Report - Details
The Details of the conversion report provide information on the elements found
during the conversion of your source code.

The information is provided on four tabs:
• The tab Manual operations contains a list of detected issues you need to

resolve in the converted code before the code can be used.
• The tab Specific features contains a list of specific elements found in the

source code which need to be reviewed by you.
• The tab Details contains information on the conversion process intended to

support you in resolving detected issues in the converted code.
• The tab Appendix contains a knowledge base article detailing the conversion

process and various steps you need to take after having downloaded the
converted code.
NOTE: If the Knowledge Base contains an article on an item in a list, you can
display the article with the link in the appropriate column.

Downloading the Conversion Result
The converted code can be downloaded by clicking Result.

You must confirm that you have read and understood the safety information
associated with the conversion using the corresponding checkboxes before you
can download the conversion result.

36 EIO0000004425.05



Converting Controller Applications

NOTE: The download can also be started from the program menu by clicking
Download conversion result.
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Post-Conversion Steps

General Information
EcoStruxure Control Engineering - Converter converts the application logic,
database, structure, and behavior of controller applications. Infrastructure-specific
code (for example, code relating to hardware, communication infrastructure,
configuration, axes, counters) is not converted or may only be partially converted,
for example, because the tool cannot be aware of the configuration and
requirements of your target system. Therefore, certain code parts will miss from
the converted code, or have only been partially converted.

You must subject the entire code converted by EcoStruxure Control Engineering -
Converter to a full review, verification and validation.

In this process, you must, among other things, adapt the code to your target
infrastructure. The information on post-conversion steps provided in the present
user guide is not exhaustive, because only you, the user of EcoStruxure Control
Engineering - Converter, can be aware of all requirements relating to your target
controller application.

WARNING
UNINTENDED EQUIPMENT OPERATION
• In your risk assessment, consider all potential effects of using EcoStruxure

Control Engineering - Converter, including, but not limited to, inappropriate,
incorrect or incomplete input code as well as inappropriate, incorrect or
incomplete converted output code.

• Verify that the converted code is properly adapted to all requirements of your
target system.

• Subject the converted code to a full review, verification and validation by
appropriately qualified personnel; and according to all applicable regulations,
standards, and process definitions.

• Do not rely on the conversion report provided by EcoStruxure Control
Engineering - Converter as the sole source of information in reviewing,
verifying, validating, or otherwise assessing or using the converted code.

• Ensure that your overall machine/process for which EcoStruxure Control
Engineering - Converter has been used is properly certified and/or approved
according to all standards, regulations, and directives applicable at the
installation site of the machine/process.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

EcoStruxure Control Engineering - Converter is neither certified nor intended for
conversion of safety-related code.

WARNING
INSUFFICIENT AND/OR INEFFECTIVE SAFETY-RELATED FUNCTIONS
• Do not convert safety-related code with EcoStruxure Control Engineering -

Converter.
• Re-design any and all converted code in compliance with all applicable

safety-related regulations, standards, and certification requirements if, after
the conversion, you decide to use any part of such converted code for
safety-related purposes.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

The conversion report generated by EcoStruxure Control Engineering - Converter
can be used as a starting point for the post-conversion activities to be performed.
It contains various types of messages:
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• Feature detection from source controller
• Unsupported feature on the target controller for each unsupported system

block
• One message for each instance/usage of an unsupported system block

Hardware-Related Logic
The following section provides information on some of the steps to perform on the
hardware-related logic of the converted code. Only you, the user of EcoStruxure
Control Engineering - Converter can determine the entirety of measures to be
taken because they depend on your target controller application which
EcoStruxure Control Engineering - Converter cannot be aware of.

• Configuration of racks/modules:
◦ Select the modules (depending on the controller application, you may also

be able to use tools such as EcoStruxure Migration Expert).
◦ Define the appropriate mapping of status bits.

• Communication infrastructure (such as fieldbus, SCADA, interPLCs), control,
high-speed counters, motion (typically, this is skipped by the conversion):
◦ Assign variables to the right memory location, if required
◦ Configure the hardware
◦ Replace the empty system blocks that were generated for the target

controller with the appropriate code
• Information specific to the controller (system bits/words) related to hardware
• Task mapping on the target controller

Manual Conversion
EcoStruxure Control Engineering - Converter may not have converted certain
system blocks from the source controller application to the target controller
application, for example, because the code has an unresolvable complexity or is
insufficiently documented. Instances and usage of such blocks are documented
by messages in the details of the conversion report, page 36.

In such cases, EcoStruxure Control Engineering - Converter may also have
included an invalid instruction in the generated code. Such an invalid instruction is
intended to be detected as an error by the target software development
environment to keep the corresponding code from being used without further
processing.

Manually adapt the code blocks to the target controller.
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Manufacturer-Specific File Export Procedures
EcoStruxure Control Engineering tools use the source code files of controller
applications as input files. These files are exported from the corresponding
software development environments. The following sections provide information
on generating these export files in various software development environments.

Allen Bradley PLC5 (.PC5, .SY6 Export Files)
Export the Allen Bradley PLC5 controller application to a PC5 and a SYS6 export
file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 Open the project in RSLogix500.

2 From the menu, select File > Save As > Type.

3 Select Library Files (*.PC5).

Result: RSLogix500 generates the following files:
• PC5 file
• SY5 file
• SY6 file
• FIX file
• FIX2 file

Only the PC5 and SY6 files are required for conversion.

The PC5 file contains the controller application:
• Hardware configuration
• Code
• Code comments
• Last values of variables

The SY6 files contains:
• Names of variables and comments
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Allen Bradley SLC 500 (.SLC and .SY6 Export Files)
Export the Allen Bradley SLC500 controller application to a SCL and a SYS6
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 Open the project in RSLogix500.

2 From the menu, select File > Save As > Type.

3 Select Library Files (*.SLC)).

Result: RSLogix500 generates the following files:
• SCL file
• SY5 file
• SY6 file
• FIX file
• FIX2 file

Only the SCL and SY6 files are required for conversion.

The SCL file contains the controller application:
• Hardware configuration
• Code
• Code comments
• Last values of variables

The SY6 files contains:
• Names of variables and comments
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April SMC80, SMC600 (Native Application Files)
Controller applications for April SMC80 and April SMC600 are developed with
VPeSOFT and EDIDOS.

The EcoStruxure Control Engineering tools that support April SMC use the native
controller application files under MS-DOS. The name of the controller application
corresponds to the name of the directory. This directory contains the required files.
Depending on the SDT, the exact file names may be different.

VPeSOFT files:
• BOOL.DAT: Sequential code section
• CALC.DAT: Calcul code section
• MNEMO.DAT: Variables mnemonics and comments
• MNEMO.CLE : MNEMO.DAT index file
• PIPC.DAT: Sequential section mnemonics and comments
• PIPC.IDX: PIPC.DAT index file

Note: VPeSOFT did not support comments in the Calcul section.

EDIDOS files
• BOOL.SAV: Sequential code section
• CALC.SAV : Calcul code section
• MNEMO.SAV : Variables mnemonics and comments
• COMCAL.SAV: Mnemonics and calcul comments
• PIPC.SAV: Sequential section mnemonics and comments
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April Orphee 1000 Series (FTA Export File)
Controller applications for the April Orphée 1000 controller series are developed
with April Orphée. The native Orphée application files are contained in the
directory C:\ORPHEE\SERVROOT\ of the hard drive. Each subdirectory contains
a different controller application. EcoStruxure Control Engineering supports the
exported format.

Use the tool ORPHEE-EDI2200 to export the controller application to an FTA text
file. The tool is available on the ORPHEE installation disk. Download the
corresponding user guide (EDI2200, Manuel de référence) or contact your
Schneider Electric representative for details.
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Mitsubishi GX Works3 (PLCopen .XML File Export)
Export the Mitsubishi GX Works3 controller application to an XML export file
(PLCopen) in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select Project > Save Other Format File > XML Format….

2 Provide a file name and a folder name as prompted.

3 Click Save.
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Rockwell Automation® RSLogix 5000® or Studio 5000 (.
L5K File Export)

Export the Rockwell Automation® RSLogix 5000® controller application to a L5K
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Save as….

2 In the Save as… dialog box, provide a name for the L5K file.

3 If required, modify the storage location.

4 Select the file type: RSLogix 5000 Import/Export File (*.L5K).

5 Click Save.
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Siemens SIMATIC STEP 5 (.S5D, Z0.INI Native Files)
EcoStruxure Control Engineering - Converter can process controller applications
developed with Siemens STEP 5 for SIMATIC controllers. The following files are
used as input for EcoStruxure Control Engineering - Converter:

1. S5D: Contains the logic and memory information. This file is required. More
than one S5D file can be provided to EcoStruxure Control Engineering -
Converter.

2. Z0.INI : Contains mnemonics used in the controller application. This file is
optional. If the file is not provided, there are no mnemonics in the analyzed
controller application.
NOTE: Verify that the version of the files S5D and Z0.INI .
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Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File
Export)

Overview
The following steps are required to process a Siemens SIMATIC STEP 7
controller application with EcoStruxure Control Engineering tools:

• Set your SIMATIC STEP 7 workshop to German abbreviations (mnemonics).
• Create and export the symbols of the controller application to an .ASC file.
• Create and export the contact code (CONT) to an .AWL file.
• Create and export the graph blocks (GRAPH) to a .GR7 files.
• Compile the CFC code (if any) to create the corresponding SCL sources.
• Export structural codes (SCL) to .SCL files.

Setting German Mnemonics
Before creating the export files, set your SIMATIC STEP 7 workshop to German
abbreviations (mnemonics):
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Step Action

1 From the menu, select Options > Customize….

2 Display the Language tab.

3 Select German mnemonics.

4 Click OK.
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Creating an ASC File

Step Action

1 Right-click the symbols table in your program folder and select Open object.

2 From the menu of the symbols editor, select Symbol Table > Export….

3 Select ASCII Format (*.ASC).

4 Provide a name and select a directory for the .ASC export file.

5 Click Save.

Creating an AWL File
To create an .AWL file, first generate the LIST source for the code blocks
developed in the languages CONT, LIST and LOG.
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Step Action

1 Right-click a CONT, LIST or LOG source and select Open Object to open the CONT/
LIST/LOG code editor.

2 From the menu, select File > Close to close all open objects.

3 From the menu, select File > Generate source… to generate the program source.
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Step Action

4 Provide an object name and click OK.

5 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

6 Click OK to confirm.

If your controller application contains safety-related blocks, export those blocks in
a separate AWL file. Refer to Safety-Related Applications, page 54 for details.

Creating a GR7 File
The .GR7 sources have to be created for each GRAPH blocks separately. Repeat
the following procedure for each GRAPH block to be exported.

EIO0000004425.05 51



Manufacturer-Specific File Export Procedures

Step Action

1 Right-click a GRAPH object and select Open Object.

2 From the menu, select File > Generate Source File.

3 Provide a name for the GRAPH object.

4 Click OK to confirm.

5 Repeat the procedure for each GRAPH object to be exported.
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Creating a CFG File
The CFG file is required for analyzing the communication and the hardware
configuration of the station.

Step Action

1 Double-click your CPU's links in the main window to open NetPro.

2 In the NetPro window, double-click the CPU of the station to be exported open the HW
Config utility.

3 From the Station menu, select Export… to export your station configuration (leave the
default settings in the dialog).

4 If the controller application contains CFC code, compile the code to generate the
corresponding SCL source files which are the files processed with EcoStruxure Control
Engineering tools. To do so, open the CFC code editor by clicking its icon in the toolbar
of the main window .
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Step Action

5 Compile the code with the options Entire program and Generate SCL sources and
click OK.

6 The generated SCL source file can then be exported like other source files (refer to
Exporting Files, page 58).

Safety-Related Applications
A safety-related controller application contains two code parts:

• The non-safety-related code part
• The safety-related code part

Procedure for exporting controller applications that contain safety-related code:

Step Action

1 Export the .ASC file that contains the database for the safety-related code and for the
non-safety-related code (refer to Creating an ASC File, page 49).

2 Generate the sources for the non-safety-related code parts (refer to Creating an AWL
File, page 49 and Creating a GR7 File, page 51).
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Step Action

3 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

4 Click OK to confirm.

5 Follow the procedure for Creating an AWL File, page 49 until the dialog Generate
source Safety is displayed.
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Step Action

6 Select the option User-created F-FBs, F-FCs and F-DBs and click OK to confirm.

7 Create a .dif file (refer to Creating a dif File, page 56). The .dif file is used to determine
whether code is safety-related.

Creating a dif File
A .dif file is created in the SIMATIC Manager of SIMATIC STEP 7 in the following
way:
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Step Action

1 From the menu, select Options > Reference Data > Display.

2 In the Display S7 reference data dialog, select the option regenerated? and click Yes.

3 In the Customize dialog, select the option Program Structure and click OK to display
the program structure.

EIO0000004425.05 57



Manufacturer-Specific File Export Procedures

Step Action

4 From the menu, select View > Export to open the Save dialog box.

5 Provide a name for the .dif and click Save.

Exporting Files
After you have created the files, export them from SIMATIC STEP 7:

Step Action

1 Select the LIST, GRAPH (or .AWL and .GR7 files) and SCL sources that you have
generated.

2 Right-click the sources and select Export source….

3 Select a file name and a storage location and click Save.
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Telemecanique TSX 7 Series (.BIN, .CDB Native Files)
To work with controller applications of the Telemecanique TSX 7 series developed
with XTEL versions 4 and 5, three types of files are required:

1. BIN
This file is mandatory. It contains the controller application with the hardware
configuration, the database, the code, comments and further items.
The file is available in the subdirectory ...\XPROPJ\PL7_3/APPLI\ (“appli”
being the name of the controller application directory). The file name is PL7_
3.BIN or appli.BIN (“appli” being the name of the controller application
directory).
If the BIN file has the same name as the TSX task, rename the BIN file before
uploading it.

2. CDB
This file is optional. It contains the names of the variables, comments and
topological addresses of variables in the controller application.
The file is available in the subdirectory ...\XPROPJ\SDBASE\APP\. The file
name is PL7_3.CBD or appli.CBD (“appli” being the name of the controller
application directory).
If the file is not provided, the generated code does not have mnemonics and
comments.

3. CNIORACK.BIN
This file is optional. It contains a more detailed hardware configuration than
that contained in the file BIN file. The file is only available in versions higher
than V4 of XTEL.
The file is available in the subdirectory ...\\/CONF\IORACK\ CONFIO.
If the file is not provided, the generated code does not have mnemonics and
comments.
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Manufacturer-Specific File Import Procedures

Unity Pro (XEF Import Format)
EcoStruxure Control Engineering - Converter provides an export of a Unity Pro
project in XEF format that can be imported into Unity Pro.

Step Action

1 From the menu, select File > Open.

2 Select Application Exchange File (*.XEF).

3 Select the XEF file in the appropriate folder and click Open.

Result: The import process starts and progress information is displayed. When the
import is finished, the project is available in Unity Pro.
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3S CODESYS V3 (EXPORT Import Format)
EcoStruxure Control Engineering - Converter provides an export of a CODESYS
project that can be imported into CODESYS.

Step Action

1 In CODESYS, create a project by selecting Start page > Basic Operations > New
project….

2 Select Empty project and provide a name and storage location for the new project.

Result: CODESYS opens the new project.

3 Select the root of the new project under Devices.

4 Select Project > Import….
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Step Action

5 Select the EXPORT file in the appropriate folder and click Open.

Result: CODESYS reads the file and provides a tree of the insertable items. By default,
all items are selected.

6 Select the required items and click OK to import the items.

7 CODESYS may notify you that a device contained in the project needs to be removed.
This can occur because the code export contains another device. To continue, confirm
with OK to overwrite the existing device.

Result: CODESYS notifies you when the import is complete.

By default, the EXPORT file generated by EcoStruxure Control Engineering -
Converter is compatible with version 3.5 SP10, patch 10 of CODESYS. If you
want to use the files with a different CODESYS version, import it into CODESYS
version 3.5 SP10, patch 10 to create a project, and then open the project with the
CODESYS version that you want to use. Contact your Schneider Electric
representative for additional information.
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Siemens TIA Portal SIMATIC STEP 7 (.ZIP Import Format)
EcoStruxure Control Engineering - Converter provides the generated code for
Siemens TIA Portal SIMATIC STEP 7 in a ZIP file to be imported into a Siemens
TIA Portal SIMATIC STEP 7 project.

The file can be imported automatically with the EcoStruxure Control Engineering
Import/Export tool. Select SUPPORT > DOWNLOADS.

Refer to the user guide of the EcoStruxure Control Engineering Import/Export tool
for details.
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