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Safety Information

Safety Information

Important Information

Please Note

Read these instructions carefully, and look at the equipment to become familiar
with the device before trying to install, operate, service, or maintain it. The
following special messages may appear throughout this documentation or on the
equipment to warn of potential hazards or to call attention to information that
clarifies or simplifies a procedure.

The addition of this symbol to a “Danger” or “Warning” safety label indicates that an
electrical hazard exists which will result in personal injury if the instructions are not
followed.

hazards. Obey all safety messages that follow this symbol to avoid possible injury or
death.

A DANGER

DANGER indicates a hazardous situation which, if not avoided, will result in death or serious
injury.

2 This is the safety alert symbol. It is used to alert you to potential personal injury

A WARNING

WARNING indicates a hazardous situation which, if not avoided, could result in death or
serious injury.

A CAUTION

CAUTION indicates a hazardous situation which, if not avoided, could result in minor or
moderate injury.

NOTICE

NOTICE is used to address practices not related to physical injury.

Electrical equipment should be installed, operated, serviced, and maintained only
by qualified personnel. No responsibility is assumed by Schneider Electric for any
consequences arising out of the use of this material.

A qualified person is one who has skills and knowledge related to the construction
and operation of electrical equipment and its installation, and has received safety
training to recognize and avoid the hazards involved.

Before You Begin

Do not use this product on machinery lacking effective point-of-operation
guarding. Lack of effective point-of-operation guarding on a machine can result in
serious injury to the operator of that machine.
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Safety Information

AWARNING

UNGUARDED EQUIPMENT

» Do not use this software and related automation equipment on equipment
which does not have point-of-operation protection.

* Do not reach into machinery during operation.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

This automation equipment and related software is used to control a variety of
industrial processes. The type or model of automation equipment suitable for each
application will vary depending on factors such as the control function required,
degree of protection required, production methods, unusual conditions,
government regulations, etc. In some applications, more than one processor may
be required, as when backup redundancy is needed.

Only you, the user, machine builder or system integrator can be aware of all the
conditions and factors present during setup, operation, and maintenance of the
machine and, therefore, can determine the automation equipment and the related
safeties and interlocks which can be properly used. When selecting automation
and control equipment and related software for a particular application, you should
refer to the applicable local and national standards and regulations. The National
Safety Council's Accident Prevention Manual (nationally recognized in the United
States of America) also provides much useful information.

In some applications, such as packaging machinery, additional operator protection
such as point-of-operation guarding must be provided. This is necessary if the
operator's hands and other parts of the body are free to enter the pinch points or
other hazardous areas and serious injury can occur. Software products alone
cannot protect an operator from injury. For this reason the software cannot be
substituted for or take the place of point-of-operation protection.

Ensure that appropriate safeties and mechanical/electrical interlocks related to
point-of-operation protection have been installed and are operational before
placing the equipment into service. All interlocks and safeties related to point-of-
operation protection must be coordinated with the related automation equipment
and software programming.

NOTE: Coordination of safeties and mechanical/electrical interlocks for point-
of-operation protection is outside the scope of the Function Block Library,
System User Guide, or other implementation referenced in this
documentation.

Start-up and Test

Before using electrical control and automation equipment for regular operation
after installation, the system should be given a start-up test by qualified personnel
to verify correct operation of the equipment. It is important that arrangements for
such a check are made and that enough time is allowed to perform complete and
satisfactory testing.

AWARNING

EQUIPMENT OPERATION HAZARD
» Verify that all installation and set up procedures have been completed.

» Before operational tests are performed, remove all blocks or other temporary
holding means used for shipment from all component devices.

* Remove tools, meters, and debris from equipment.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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Safety Information

Follow all start-up tests recommended in the equipment documentation. Store all
equipment documentation for future references.

Software testing must be done in both simulated and real environments.

Verify that the completed system is free from all short circuits and temporary
grounds that are not installed according to local regulations (according to the
National Electrical Code in the U.S.A, for instance). If high-potential voltage
testing is necessary, follow recommendations in equipment documentation to
prevent accidental equipment damage.

Before energizing equipment:
* Remove tools, meters, and debris from equipment.
* Close the equipment enclosure door.
* Remove all temporary grounds from incoming power lines.
» Perform all start-up tests recommended by the manufacturer.

Operation and Adjustments

The following precautions are from the NEMA Standards Publication ICS 7.1-
1995:

(In case of divergence or contradiction between any translation and the English
original, the original text in the English language will prevail.)

+ Regardless of the care exercised in the design and manufacture of equipment
or in the selection and ratings of components, there are hazards that can be
encountered if such equipment is improperly operated.

* Itis sometimes possible to misadjust the equipment and thus produce
unsatisfactory or unsafe operation. Always use the manufacturer’s
instructions as a guide for functional adjustments. Personnel who have
access to these adjustments should be familiar with the equipment
manufacturer’s instructions and the machinery used with the electrical
equipment.

+ Only those operational adjustments required by the operator should be
accessible to the operator. Access to other controls should be restricted to
prevent unauthorized changes in operating characteristics.

EIO0000004424.04



About the Book

About the Book

Document Scope

Validity Note

Related Documents

The present user guide describes the functionality provided by EcoStruxure
Control Engineering - Verification.

This document has been updated for the release of EcoStruxure Control
Engineering V23.1.

The characteristics that are described in the present document, as well as those
described in the documents included in the Related Documents section below,
can be found online. To access the information online, go to the Schneider Electric
home page www.se.com/ww/en/download/.

The characteristics that are described in the present document should be the
same as those characteristics that appear online. In line with our policy of constant
improvement, we may revise content over time to improve clarity and accuracy. If
you see a difference between the document and online information, use the online
information as your reference.

Title of documentation Reference number

EcoStruxure Control Engineering - Verification - EIO0000004424 (eng)
User Guide (this user guide)

EcoStruxure Control Engineering - Converter - EI00000004425 (eng)
User Guide
EcoStruxure Control Engineering - EI00000004426 (eng)

Documentation - User Guide

EcoStruxure Control Engineering - Monitoring - EI00000004427 (eng)

User Guide

Cybersecurity Best Practices CS-Best-Practices-2019-340
EcoStruxure Control Engineering, Hardening EI00000004982 (eng)
Guide
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Product Related Information

AWARNING

LOSS OF CONTROL

» Perform a Failure Mode and Effects Analysis (FMEA), or equivalent risk
analysis, of your application, and apply preventive and detective controls
before implementation.

» Provide a fallback state for undesired control events or sequences.
* Provide separate or redundant control paths wherever required.
» Supply appropriate parameters, particularly for limits.

» Review the implications of transmission delays and take actions to mitigate
them.

* Review the implications of communication link interruptions and take actions
to mitigate them.

» Provide independent paths for control functions (for example, emergency
stop, over-limit conditions, and error conditions) according to your risk
assessment, and applicable codes and regulations.

* Apply local accident prevention and safety regulations and guidelines.!

» Test each implementation of a system for proper operation before placing it
into service.

Failure to follow these instructions can result in death, serious injury, or

equipment damage.

1 For additional information, refer to NEMA ICS 1.1 (latest edition), Safety
Guidelines for the Application, Installation, and Maintenance of Solid State Control
and to NEMA ICS 7.1 (latest edition), Safety Standards for Construction and
Guide for Selection, Installation and Operation of Adjustable-Speed Drive
Systems or their equivalent governing your particular location.

AWARNING

UNINTENDED EQUIPMENT OPERATION

* Perform a risk assessment as per ISO 12100 and/or other equivalent
assessment in view of your use of EcoStruxure Control Engineering.

* Inyour risk assessment, consider all applicable regulations and standards
that apply to your development process and to your machine/process.

» Verify that your use of EcoStruxure Control Engineering is fully covered in
the definition of your software development process and that your software
development process meets all applicable regulations and standards.

» After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
commission or recommission the machine/process in compliance with all
regulations, standards, and process definitions applicable to your machine/
process.

» During commissioning or recommissioning of the machine/process, verify
the correct operation and effectiveness of all safety-related functions and
non-safety-related functions by performing comprehensive tests for all
operating states, for the defined safe state of your machine/process, and for
all potential error situations.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.
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About the Book

No tool can provide analysis procedures for all potential types of code and
methods of creating code. For example, a code block in your source code may be
semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such
protected code blocks in your software development environment before creating
export files to be used with EcoStruxure Control Engineering.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

+ Verify that the source code exported from your software development
environment and to be used by EcoStruxure Control Engineering is complete
and up to date.

« After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

EcoStruxure Control Engineering - Verification may not be able to detect incorrect
or incomplete source code, depending on, for example, the analysis rules used.
The Schneider Electric default rules files are provided as are.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

Do not use the Schneider Electric default rules files, or rules files created or
modified by you in EcoStruxure Control Engineering without verifying their
appropriateness and completeness for the task at hand by appropriate
measures such as test cases.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Machines, controllers, and related equipment are usually integrated into networks.
Unauthorized persons and malware may gain access to the machine as well as to
other devices on the network/fieldbus of the machine and connected networks
because of insufficiently secure access to software and networks.

10
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About the Book

Schneider Electric adheres to industry best practices in the development and
implementation of control systems. This includes a "Defense-in-Depth" approach
to secure an Industrial Control System. This approach places the controllers
behind one or more firewalls to restrict access to authorized personnel and
protocols only.

AWARNING

UNAUTHENTICATED ACCESS AND SUBSEQUENT UNAUTHORIZED
MACHINE OPERATION

» Evaluate whether your environment or your machines are connected to your
critical infrastructure and, if so, take appropriate steps in terms of prevention,
based on Defense-in-Depth, before connecting the automation system to
any network.

« Limit the number of devices connected to a network to the minimum
necessary.

» Isolate your industrial network from other networks inside your company.

* Protect any network against unintended access by using firewalls, VPN, or
other, proven security measures.

* Monitor activities within your systems.

* Prevent subject devices from direct access or direct link by unauthorized
parties or unauthenticated actions.

* Prepare a recovery plan including backup of your system and process
information.

Failure to follow these instructions can result in death, serious injury, or

equipment damage.

For more information on organizational measures and rules covering access to
infrastructures, refer to ISO/IEC 27000 series, Common Criteria for Information
Technology Security Evaluation, ISO/IEC 15408, IEC 62351, ISA/IEC 62443,
NIST Cybersecurity Framework, Information Security Forum - Standard of Good
Practice for Information Security, and refer to Cybersecurity Guidelines for
EcoStruxure Machine Expert, Modicon and PacDrive Controllers and Associated
Equipment.

For reasons of Internet security, for those devices that have a native Ethernet
connection, TCP/IP forwarding is disabled by default. Therefore, you must
manually enable TCP/IP forwarding. However, doing so may expose your network
to possible cyberattacks if you do not take additional measures to protect your
enterprise. In addition, you may be subject to laws and regulations concerning
cybersecurity.

AWARNING

UNAUTHENTICATED ACCESS AND SUBSEQUENT NETWORK INTRUSION

» Observe and respect any and all pertinent national, regional and local
cybersecurity and/or personal data laws and regulations when enabling
TCP/IP forwarding on an industrial network.

* Isolate your industrial network from other networks inside your company.

» Protect any network against unintended access by using firewalls, VPN, or
other, proven security measures.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

Consult the Schneider Electric Cybersecurity Best Practices for additional
information.

EIO0000004424.04
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About the Book

Terminology Derived from Standards

The technical terms, terminology, symbols and the corresponding descriptions in
this manual, or that appear in or on the products themselves, are generally
derived from the terms or definitions of international standards.

In the area of functional safety systems, drives and general automation, this may
include, but is not limited to, terms such as safety, safety function, safe state, faulf,
fault reset, malfunction, failure, error, error message, dangerous, etc.

Among others, these standards include:

Standard

Description

IEC 61131-2:2007

Programmable controllers, part 2: Equipment requirements and tests.

ISO 13849-1:2015

Safety of machinery: Safety related parts of control systems.

General principles for design.

EN 61496-1:2013

Safety of machinery: Electro-sensitive protective equipment.

Part 1: General requirements and tests.

ISO 12100:2010

Safety of machinery - General principles for design - Risk assessment
and risk reduction

EN 60204-1:2006

Safety of machinery - Electrical equipment of machines - Part 1: General
requirements

ISO 14119:2013

Safety of machinery - Interlocking devices associated with guards -
Principles for design and selection

ISO 13850:2015

Safety of machinery - Emergency stop - Principles for design

IEC 62061:2015

Safety of machinery - Functional safety of safety-related electrical,
electronic, and electronic programmable control systems

IEC 61508-1:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: General requirements.

IEC 61508-2:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: Requirements for electrical/electronic/programmable
electronic safety-related systems.

IEC 61508-3:2010

Functional safety of electrical/electronic/programmable electronic safety-
related systems: Software requirements.

IEC 61784-3:2016

Industrial communication networks - Profiles - Part 3: Functional safety
fieldbuses - General rules and profile definitions.

2006/42/EC Machinery Directive
2014/30/EU Electromagnetic Compatibility Directive
2014/35/EU Low Voltage Directive

In addition, terms used in the present document may tangentially be used as they
are derived from other standards such as:

Standard Description

IEC 60034 series Rotating electrical machines

IEC 61800 series Adjustable speed electrical power drive systems

IEC 61158 series Digital data communications for measurement and control — Fieldbus for

use in industrial control systems

Finally, the term zone of operation may be used in conjunction with the description

of specific hazards, and is defined as it is for a hazard zone or danger zone in the

Machinery Directive (2006/42/EC) and ISO 12100:2010.

NOTE: The aforementioned standards may or may not apply to the specific
products cited in the present documentation. For more information concerning
the individual standards applicable to the products described herein, see the
characteristics tables for those product references.

12
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Introduction to EcoStruxure Control Engineering - Verification

Introduction to EcoStruxure Control Engineering -

Verification

Overview

Workflow

EcoStruxure Control Engineering - Verification (formerly known as PLC Checker)
is a static code analysis tool that analyzes PLC (programmable logic controller)
and PAC (programmable automation controller) code. The tool helps to verify that
the code respects the specified design and programming rules. In addition, the
tool provides information on key metrics. You can use default rules or create your
own rules for the verification.

EcoStruxure Control Engineering - Verification supports, for example, code
development or code migration processes by providing methods of determining
the quality of a controller application, as well as monitoring the development
progress and helping ensure process quality with consistent, automated code
reviews and code audits.

The code verification results are available in two views:
» Dashboard view: Graphical overview as a summary

* Result Details view: List of the non-conformity messages generated by the
code verification

EcoStruxure Control Engineering - Verification is a Software as a Service (SaaS)
tool accessible using a web browser. It is an agnostic tool and supports controller
applications written for a variety of controller types and models such as
EcoStruxure™ Control Expert (formerly Unity Pro), EcoStruxure™ Machine Expert,
PL7-PRO, Siemens TIA Portal, Siemens Simatic Step 7, Rockwell Automation®
RSLogix 50009.

The following steps are typical parts of the EcoStruxure Control Engineering -
Verification workflow:

* Registration with EcoStruxure Control Engineering - Verification, either to the
cloud version or to a dedicated server for your organization.

* Procurements of license for working with EcoStruxure Control Engineering -
Verification. You can start with a free trial license to evaluate the functionality
and upgrade to license plans adapted to the requirements of your
organization.

+ Creation of the work structure with one or multiple projects.

» Creation of one or multiple programs that are used to execute the code
verification functionality of EcoStruxure Control Engineering - Verification.
This includes:

o Exporting the code of your controller application and uploading the code
to EcoStruxure Control Engineering - Verification.

o Preparing a rules file which contains the rules used to analyze your
controller application. Default rules files are available that can be used as
is or adapted to your requirements.

* Analysis of the results provided by EcoStruxure Control Engineering -
Verification.

EIO0000004424.04

13



Registration, Login, My Account, Licenses and Sessions

Registration, Login, My Account, Licenses and

Sessions

Registration

Overview

The EcoStruxure Control Engineering tools are accessible using the cloud version
or using a dedicated server for your organization.

The URL of the cloud version is https://ecostruxure-control-engineering.se.app/.

If a dedicated server has been set up for your organization, the URL is available
from your system administrator.

In both cases, you must create a user account to use the tools.

Browser Compatibility

The following web browsers are supported:

Login Options

Mozilla Firefox from version 11

Google Chrome from version 16

Microsoft Edge from version 12

Microsoft Internet Explorer from version 10
Apple Safari from version 7

You can login to the EcoStruxure Control Engineering platform by using the
following options:

Schneider Electric Account
Legacy EcoStruxure Control Engineering

Step Action

1 Go to https://ecostruxure-control-engineering.se.app/.

Result: The following window appears:

EcodPtruxure Sign in with your unique Schneider Electric account
Control Engineering Use A Schneider Electric Account

Or use the legacy EcoStruxure Control Engineering login method

Use An EcoStruxure Control Engineering Account

English v

NOTE: You can choose either the legacy web platform accounts management
or Schneider Electric account. However, eventually the Legacy option will be
transistioned to the Schneider Electric option. You can create a Schneider
Electric account by clicking the Use A Schneider Electric Account button
wherein you can create a new account. In order to preserve the data you have
from the legacy account, use the same email address you used to create the
legacy. See Login using Schneider Electric Account, page 16.

14
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Registration

Registration procedure for the cloud version of EcoStruxure Control Engineering

tools:

Step

Action

1

Click on any one login options.

2

Click Sign up or Register Here.

Fill in the form with your first and last names, your phone number, your e-mail address
(which is used as your identifier) and select a password. Password requirements:

« Atleast one uppercase character

« Atleast one lowercase character

»  Atleast one numerical character

» Atleast one special character (such as "{”, ’/", “$”)
« Password length between 8 and 32 characters

Read the Terms and Conditions and, if you agree, select | agree to the Terms and
Conditions.

Click Sign Up.

Result: A verification e-mail is sent to you.

The verification e-mail sent to you contains a link that you need to follow.

Result: Your account is activated within a period of 48 working hours.

NOTE: If a dedicated server is set up for your organization, contact your
system administrator for details on the registration procedure.

EIO0000004424.04
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Login

Login using Schneider Electric Account

This is the new method to login to the EcoStruxure Control Engineering platform.
Legacy accounts for the EcoStruxure Control Engineering platform will be
migrated to Schneider Electric accounts (SE accounts). If you are using the legacy
login method but want to migrate to the account login method, use or create a
Schneider Electric user account that uses the same email address as your legacy
account. After the first login with a Schneider Electric user account, subsequent
logins must be completed using your Schneider Electric user account.

Step

Action

1

When your registration on the Schneider Electric account is completed and your
account is ready, go to https://ecostruxure-control-engineering.se.app/.

Select Use a Schneider Electric Account, the following window appears:

»
(1) .
Comrol Engineering ECOSTruxure COI’IEI:0| Engineeriti’g
. 3

EcodZ truxure

Login or Register here

Welcome to the EcoStruxure Control Engineering

platform, where you can find industrial software

O Remember Me @

engineering tools to help better manage your

. Or continue with
control software lifecycle.

&g

Don't have a user account? R;

Enter your email address, click Next and then enter your password.

Result: After validation, you are redirected to the dashboard in EcoStruxure Control
Engineering platform.

Ecoll truure fuglin v st~ SChNeider
Control Engineering - Electric
COSTRUXURE CONTROL ENGINEERING  DASHBOARD ~ PROJECTS ~ TOOLS + SUPPORT LICENSES & ORDERS  GIVE FEEDBACK
Welcome Harshvarahan Sudha, this is your dashboard, start by creating a first application, thi flect your last work and help you to find the functionalities you will need
m Quick tour of EcoStruxure Control Engineering
The dashboard
Programs PR roiccts E
N The dashboard is the place where you can start all the operations you need to do.
Once you have created a program and started to work on it, then the dashboard will help you to resume what
Projects Personal Licenses manager  you were doing. It also contains a ot of useful links such as the links to the user manuals, to your licenses

. . manager, to your projects.
information s o yourprol

NOTE: For more information on Schneider Electric accounts, contact your
local Schneider Electric service representative.

16
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Login using Legacy EcoStruxure Control Engineering

Step

Action

1

Select Use An EcoStruxure Control Engineering Account, the following dialog box
appears:

Important notes about legacy login

In a future version of EcoStruxure Control Engineering, the legacy login method will no
loenger be possible meaning that the legacy accounts will stay available during some
time, and will then be migrated to a Schneider Electric account.

If you already have accounts on both the EcoStruxure Control Engineering platform and
through the unique Schneider Electric account using the same email address, you can
connect with your SE login to merge the accounts. Once the accounts are merged, your
personal data will come from your Schneider Electric account. Please note that once you
use the SE Login once, future logins must always use this method to connect to the
EcoStruxure Control Engineering platform.

We advise you to prefer connecting with your unigue Schneider Electric account.

Click Close to close the dialog box.

Enter your email address and password in the respective fields.

Click Login.

Result: The Dashboard window appears.

.
EcoPtrucure Frlish v sammmnareren « SChNeider
Control Engineering = LElectric
[ECOSTRUXURE CONTROL ENGINEERING -~ DASHBOARD ~ PROJECTS  TOOLS + SUPPORT v LICENSES & ORDERS  GIVE FEEDBACK
Welcome Harshvardhan Sudha, this is your dashboard, start by creating a first application, this view will reflect your last work and help you to find the functionalities you will need
Quick tour of EcoStruxure Control Engineering ey
The dashboard
Programs (A Foiecs
The dashboard is the place where you can start all the operations you need to do.
Once you have created a program and started to work on it, then the dashboard will help you to resume what
Projects Personal Licenses manager  you were doing. It also contains a Lot of useful links such as the links to the user manuals, to your licenses

information manager, to your projects

EIO0000004424.04
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My account Page

My account Page When Using a Schneider Electric Account

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.

Step Action

1
In Dashboard window, click

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Schneider Electric Profile Tab

The Schneider Electric Profile tab lists the user personal information such as the
identity, phone number, country. To update this information, you need to edit your
Schneider Electric profile, which is accessible with the link provided in the
Schneider Electric Profile tab.

Third-Party Apps Settings Tab

The Third-Party Apps Settings tab allows you to generate an applicative
password to connect your application to EcoStruxure Control Engineering when
your application does not support the Schneider Electric account authentication.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between the different views available
on the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:

* you are using dedicated server and the server is configured to send the
emails.

» you are using cloud version (Not applicable for Monitoring)
My account Page When Using a Legacy EcoStruxure Control
Engineering

The My account page helps you to access the personal information of the
account and the global EcoStruxure Control Engineering platform settings.
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Step Action

1
In Dashboard window, click

Result: A context menu appears.

2 Click My account.

Result: My account window appears.

Profile Tab

The Profile tab lists the user personal information such as the identity, phone
number, country, etc. You can update this information at any time.

Password Tab

The Password tab provides the password change form. You can change your
password at any time.

Notifications Tab

From the Notifications tab, you can configure the type of email notifications sent
to you by the web platform. For example, you can choose to receive a
confirmation email at the end of a controller code analysis.

View Settings Tab

The View Settings tab allows you to choose between different views available on
the web platform.

Privacy Tab

The Privacy tab provides general information, actions and instructions about
privacy practices and cookies policy. It enables you to understand how private
data are used, what are the services that can access it and for which purpose, and
to exercise your rights toward the retention and information on your private data.

You can delete the personal information if:

* you are using dedicated server and the server is configured to send the
emails.

+ you are using cloud version (Not applicable for Monitoring)

EIO0000004424.04
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Licenses

Overview

Schneider Electric offers various license plans for EcoStruxure Control
Engineering tools.

Paid License Plans

Contact your local Schneider Electric representative for details on the available
license plans for EcoStruxure Control Engineering tools. A selection of licenses is
also directly available from Schneider Electric Exchange at https://exchange.se.
com/shop.

Free Trial Licenses

As of version 22.1 of EcoStruxure Control Engineering, free trial licenses are
available to help you evaluate the EcoStruxure Control Engineering tools after you
have created a user account. A trial license allows you to work with many of the
functions of the EcoStruxure Control Engineering tool. The number of results
provided by the tools and the available functions are limited if you use a trial
license. You can upgrade a trial license to a paid license.
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Sessions

Automatic Log-Out (Session Time-Out)

After 10 minutes of inactivity in an EcoStruxure Control Engineering session, you
are automatically logged out. If you work with multiple browser tabs, the most
recent activity in any of the tabs applies. For example, if you work in tab 1, but not
in tab 2, tab 2 does not disconnect you because there is activity in tab 1.

You are about to be logged out

There has been no activity on your account for the last 10 minute(s). With no action on

your side, we will log you out in 1 minute(s).
Stay Logged In

Multiple Sessions

If your credentials are used in multiple sessions, you receive a notification. For
example, if you are logged in and another session is established with the same
credentials, you receive the following message:

You are authenticated several times

Your credentials have been used to open several sessions of the EcoStruxure Control Engineering web platform.

As this may be unintended, here is the list of open sessions with your credentials. You may choose to close any
simultaneous sessions.

If you did not authenticate several times, then this situation may be due to your account being compromised. You
should close all other sessions and change your password. If the problem persists, then you need to contact your
local Schneider Electric representative for support.

D Date IP Address Qperating System Web Browser
\:‘ 2022-08-19 14:18:47 10.0.2.2 Llinux Mozilla Firefox
\:| 2022-08-19 16:19:54 10.0.2.2 linux Mozilla Firefox

‘ Close

The information on the connection date and time, the IP address, the operating
system and browser help you to determine whether or not a sessions is legitimate.
You can select and close a session with Close Session(s).
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Creating Projects and Programs

Introduction to Projects and Programs

Overview

Example

EcoStruxure Control Engineering provides projects and programs for you to
organize your work.

A project is a type of container that can hold programs. A project is not specific to
an EcoStruxure Control Engineering tool.

When you register with EcoStruxure Control Engineering, the platform provides
one default project for you.

A program is assigned to a project. A program is created in conjunction with one of
the tools provided by EcoStruxure Control Engineering. A program typically
comprises metadata you entered during its creation, the uploaded source code of
a controller application, and the results generated with the EcoStruxure Control
Engineering tools.

The EcoStruxure Control Engineering tools are launched from within a program.
Whether or not a specific EcoStruxure Control Engineering tool is available for a
program depends on the source controller/development environment you select
during the creation of the program (PLC Brand or PLC source brand).

Programs can be shared with other users.

Assume you have been assigned the task of improving a machine ABC with two
controllers X and Y. In a first step, you want to better understand the code of the
two controller applications. You create a project “Machine ABC”. Then you add
two programs to this project: “Controller X” and “Controller Y”.

In both of these programs, you run EcoStruxure Control Engineering -
Documentation to visualize the data flow and the control flow.

In a subsequent step, your task is extended to managing the creation of a new
version of the controller applications. You start by running EcoStruxure Control
Engineering - Verification in your programs to verify the existing code. You share
the two programs with the developers so they can access the results of the code
verification for assistance in updating the code.

In subsequent steps, you can upload intermediate versions of the updated code
into your program and re-run EcoStruxure Control Engineering - Documentation
and EcoStruxure Control Engineering - Verification to document the progress and
verify that your coding rules have been properly implemented.

22
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Creating Projects and Programs

Creating Projects

Procedure for creating a project:

Step

Action

1

Select PROJECTS in the top menu to display the Projects page.

2

Select Actions > New project.

Ecuﬂtruxurn
Control Engineering

ECOSTRUXURE CONTROL ENGINEERING = DASHBOARD PROIECTS

PROJECTS

Open projects Closed projects Shared applications

Open projects

MNew proj

Change owner

Delete

Provide a unique name for your project. Lowercase and uppercase are ignored which
means that, for example, the name of a project to be created cannot be “Controller xyz”
if you already have a project with the name “Controller XYZ”. Click Add to create it.

Click Add to create the project.

Result: The project is added to your list of projects on the Open projects tab.

Clicking a project in the list displays two tabs. The Overview tab provides general
information on the project. The Programs tab contains the list of programs
assigned to this project.

Creating Programs

There are three ways to start the creation of a program:

From outside of a project select TOOLS on the main menu
From the dashboard click New ...

From inside a project on its Programs tab select Actions > New program

EIO0000004424.04
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Creating a program from outside of a project:

Step Action

1 From the main menu, select TOOLS.

2 Select the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from the dashboard:

Step Action

1 From the main menu, select DASHBOARD.

2 Click the New ... button for the tool you want to use for the program.

Result: EcoStruxure Control Engineering starts the program creation wizard.

Creating a program from inside a project:

Step Action

1 From the main menu, select PROJECTS.
2 Select the required project from the list.

3 Display the Programs tab of the project.
4 Select Actions > New program.

Owverview Programs

Programs

| Mew program
Change project
Change program owner
Launch “erification
Launch Documentation

Delete

Result: EcoStruxure Control Engineering prompts you for the tool to be used for the
program and starts the program creation wizard.
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Program Creation Wizard

Overview

A wizard guides you through the different steps required to create your program
and launch the execution of the selected EcoStruxure Control Engineering tool.

The project to which the new program is assigned depends on how the wizard is
started. If the wizard is started from outside of a project or from the dashboard, the
program is assigned to your default project. If the wizard started from inside a
project, the program is assigned to this project. In both cases, the project
assignment can be adjusted in step 1 of the wizard.

Refer to Creating Programs, page 23 for details.

Step 1 - Start

The first step consists of providing setup information on the program.

1 Start B Parameters 3 License a Source file 5 Summary
Setup program information Verification parameters Associate license Upload source files Summary of your program

Application name* ;

my-application

Custemer name™: | gopnaiger Electric
PLC site address :
PLC site city :
PLC reference :

PLC function :

Project: | gefault - Default project!

Validate And Next Step

I <

Provide the following information:

+ The fields Application name and Customer name are mandatory. The
defined Application name is used to identify the program in the different
views of EcoStruxure Control Engineering.

+ Add additional information in the other fields so that you can identify this
program in your project.

Continue with the next step by clicking Validate And Next Step.

Step 2 - Parameters

The second step consists of selecting the development environment that was
used to develop the controller application.

In addition, you select the rules file to be used for the analysis of the source code.
You may use one of the default rules files, or upload your own rules file in step 4,
page 26.
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Step 3 - License

1 Start Z Parameters 3 License 4 Source file 5 Summary
Setup program information “ /) Verification parameters Associate license Upload source files Summary of your program
PLCbrand™ | g yncider-Electric EcoStruxure Control Expert v
Rules set™ | p| CChecker-standard-en.gqr v

Previous Step Validate And Next Step

Select the PLC Brand and the Rules set and continue with the next step by
clicking Validate And Next Step.

The third step consists of selecting the EcoStruxure Control Engineering license to
be used with your new program.

Start P Parameters 3 License 4 Source file 5 Summary
Setup program information Verification parameters =/ Associate license Upload source files Summary of your program

Licensing possibilities for this program

Do not assign a li

@ Do not assign a license now D = T

O Use 3 license ID Without salacting a license now, you won't b able torun anew
Verification analyse. it is possible to assign a license later, and continue

O Use a free trial license with the program creation process.

Previous Step Validate And Next Step

Chose one of the Licensing possibilities for this program:

Licensing possibilities Description

Do not assign a license now Select this option when you will not run the analysis
immediately.

Use alicense ID Select this option when you have a license code. If you have

a license, but the license has not yet been assigned to your
user account, you can still use it by entering its identifier in
the License #id field.

Use a free trial license Select this option to launch a trial version of the tool. This is
not possible if you have already used all trial licenses that
have been associated with your user account.

Use a contract license This option appears when you have a contract for
EcoStruxure Control Engineering. This allows you to
automatically generate a license, as part of your contract, to
run the analysis.

Use an account license This option appears when licenses are available in your
account. In this case, you can select the license from a
dropdown list.

Click Validate And Next Step to continue.

If no license is available, you can still continue creating the program by clicking
Validate And Next Step. In this case, a license can be added to the program after
you have created the program. Without a valid license, the EcoStruxure Control
Engineering tool selected for this program cannot be executed.

Step 4 - Source file

The fourth step consists of uploading the file with the source code of the controller
application that you have exported from the development environment (refer to
Manufacturer-Specific File Export Procedures, page 46 for details). This source
code is the input material for EcoStruxure Control Engineering. Depending on the

26
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EcoStruxure Control Engineering tool used for the program, you may be prompted
to upload additional files.

Start 5 ) Parameters 3 ) License (4 ) Source file 5 ) Summary
Setup program information Verification parameters Associate license Upload source files Summary of your program

DRAG YOUR FILES HERE

OR
Select Files...
e
* XEF
Please provide a complete, up-to-date code export of your PLC code. If some code = ZEF

is missing in your program, this code will not be analyzed

More about the allowed files for your PLC brand

How to get supported files?

Validate And Next Step

Drag and drop the files to the location indicated or click Select Files... to import
the files. Also specify the rules file to be used if you have not selected a default file
in step 2, page 25. Then click Validate And Next Step to continue.

If the input files are not yet available when you create the program, you can skip
the upload with Validate And Next Step and provide the files at a later point in
time. Without the uploaded input files, the EcoStruxure Control Engineering tool
selected for this program cannot be executed.

Step 5 - Summary

The fifth step displays a summary of the information you have provided in creating
your program.

1) Start 5 ) Parameters 3 ) License 4 ) Source file I 5 | Summary
Setup program information Verification parameters Associate license Upload source files 7/ Summary of your program
Application name my-application Customer name Schneider Electric
N/A N/A
N/A N/A

Schneider-Electric EcoStruxure Control Expert

Do not affect a license now

Rules set PLCChecker-standard-en.gqr

In order to help you to understand the EcoStruxure Control Engineering - Verification usages and limitations, the important Safety
information about the product is available through the link below. You are able to retrieve them in the dashboard and in your programs
tabs. These messages are also available in the product documentation.

Read the safety information summary
Download the user guide (English)

—— m

Review the information. If you want to make modifications, click Previous Step to
return to the step you want to modify.

If the information is correct, click Create to create the program or click Launch to
create the program and to start the EcoStruxure Control Engineering tool selected
for this program (this is possible if you have selected a valid license and if you
have uploaded the required files).
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Accessing a Shared Program

If a program is shared with you, or if access to the program is not restricted (refer
to Sharing a Program, page 29), you can add it to your list of programs by
providing its unique 6-digit key. The unique 6-digit key can be found in the
program overview under Application key.

Procedure for adding a program to your list of programs using its unique 6-digit

key:

Step

Action

1

From the menu, select PROJECTS to access the Projects page.

Eco&truxuru .
Control Engineering

ECOSTRUXURE CONTROL ENGINEERING | DASHBOARD PROJECTS TOOLS SUPPORT

Click Shared applications to display the corresponding tab.

Opened projects Closed projects Shared applications

Enter the unique 6-digit key of the program in the field below User personal accesses
or in the field below One time access, depending on whether you want to add this
program to your personal records for access at a later point in time, or whether you
want to access it only once without adding it to your list of programs.

Open projects Closed projects Shared applications

Shared applications

User personal accesses

Here is the list of the applications shared explicitely with you by someane else or that you have decided to add for the applications shared with everyone

Your personal accesses is currently empty because no application have been shared with you yet. or you do not have added an application shared with everyone to this list

You can add any application shared with everyone in your list of applications by providing its application key below

One time access

You can access any application shared with you without saving it in your personal accesses by providing the application key below.

Click Add To My Applications or One Time Access.

28
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Sharing Programs with Other Users

Overview

You can share your programs with other users so that a team can work on the
same project. As the owner, you can share your program. Selected users with
whom you share your program cannot delegate their access rights, that is, they
cannot share this shared program with further users.

There are two ways of sharing a program:

+ Share with selected users: You choose who can access your program. By
default, other users cannot share this program because you are the owner.

» Share with everyone: Everyone can access your program.

Sharing with a Specific User

Procedure for sharing a program with selected users:

Step Action

1 Navigate to the Program page.

2 Select Admin > Collaboration > Users access rights to display the User
management.

3 Below Invited collaborators, select Actions > Add .

Overview

User management

Owner details

Invited collaborators.

4 Enter the name and the e-mail address of the user to be invited. You can enter the e-
mail address the user specified for registration with EcoStruxure Control Engineering,
or you can use any other e-mail address. You can also send an invitation notification to
the user. On a dedicated server, the invitation notification function requires a mail
server.

Users added to the list of invited users can perform the same actions as you, except for
sharing the program and modifying its settings. If you do not want invited users to
perform any further actions, deactivate the program with the Active application
checkbox in Admin > Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function. Refer to the EcoStruxure
Control Engineering - Verification user guide for details.

You can revoke sharing by selecting the user(s) you want to remove from your
program and selecting Actions > Remove access.

Sharing with Everyone

Procedure for sharing a program with everyone:
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Step Action
1 Navigate to the Program page.
2 Select Admin > Settings.
3 Enable the checkbox Private application.

Users accessing your program can perform the same actions as you, except for sharing
the program and modifying its settings. If you do not want invited users to perform any
further actions, deactivate the program with the Active application checkbox in Admin

> Settings. This sets your program to read-only.

NOTE: If your program uses the EcoStruxure Control Engineering -
Verification tool, invited users may not be able to update the rules file and may
not be able to work with the Justifications function.

You can disable sharing with everybody by deactivating the checkbox Private
application. With this setting, only users explicitly invited can access your

program.
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Verifying the Code of Controller Applications

Running a Verification of a Controller Application

Procedure

No tool can provide analysis procedures for all potential types of code and

methods of creating code. For example, a code block in your source code may be

semantically invalid, but syntactically correct. The tool may not be able to detect
such a condition.

Software development environments may provide code protection features
intended to, for example, block access to intellectual property. Unlock such

protected code blocks in your software development environment before creating

export files to be used with EcoStruxure Control Engineering.

AWARNING

INCORRECT OR INCOMPLETE SOURCE CODE ANALYSIS

* In your risk assessment, consider all potential effects of inappropriate,
incorrect, or incomplete input files used with EcoStruxure Control
Engineering.

» Verify that the source code exported from your software development

and up to date.

« After modifications of any type whatsoever to the source code of your
application resulting from your use of EcoStruxure Control Engineering,
verify the correctness of the modified source code.

Failure to follow these instructions can result in death, serious injury, or
equipment damage.

environment and to be used by EcoStruxure Control Engineering is complete

Step Action

1 Click Launch Verification on the Program page.

Launch Verification Launch Documentation

Result: EcoStruxure Control Engineering - Verification prompts you to upload new files
for the verification. If you do not have new files to upload, click Launch to run the
verification. If you have new files to upload, continue with step 2.

2 Upload the source files of the controller application exported from your software
development environment, as well as the rules file, if applicable, as described in
Program creation wizard, page 25.

4 Start the verification process by clicking Launch.

EIO0000004424.04

31



Verifying the Code of Controller Applications

Displaying Code Verification Results

Overview

Dashboard

After you run EcoStruxure Control Engineering - Verification for the first time, the
Verification tab provides access to the dashboard and to the verification details.

Overview ‘erification « Admin v

The dashboard provides a summary of the verification results. To display the
dashboard, click Verification > Dashboard.

The dashboard provides various metrics, for example, percentage values for non-
conformity to specific rules types and an overall score of the verification result
from A to E. The scoring is based on the severity assigned to the five individual
messages types.

Verification dashboard

Last analysis details

Current analysis date: September 5. 2022 16:07:53 First analysis date September 5, 2022 16:07:53

Amount of analyzes performed 2
Last analysis high-level overview
Here is an overview of your program Last analysis [perfarmed on September 5, 2022 16:07:53). For a more detailed result, have 3 look to the specific sec

tians in this page, or consult the tab "Results details".

362 0

es—

Amount of messages

Last analysis overall score

Adapt Severities and Thresholds

In the project configuration, you can adapt the scoring by setting your own values

for the severities of the message types and for the thresholds for the individual
scores.

The severity and threshold values are set per project.

Verification weights and thresholds

The Verification results you will get in the programs contained in this project are classified with a high-Level nate, frem A to E. In order to compute that note, each severity of your Verification results are weighted, the relative sum of the
weights are used to affect a note to the programe.

Weights Classes thresholds
The severities are hierarchized. meaning that an information is. by convention, less important than a warning. The

Once the relative sum of weights have been computed, the result is matched with the following thresholds. which
weights you choose should take in consideration the severities meanings and the probatility to find them in your gives the program its overall note,
rules files.
Info severity weight N Class A (better note) .
From 0% -
Warning severity weight | N Class B o
Error severity weight - Class €
5 15
Fatal severity weight Class D
o 20 g 50
lustified messages weight N . Class E (worse note) From class D to 100%

Save Thresholds And Classes

32
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To get a simulated result of you modified values click Simulate. On the next
screen enter the amount of messages for the various severities and click
Simulate to visualize the result. Click Close to close the simulation screen.

Click Save Thresholds And Classes to save the modified severity and threshold
values.

Result Details

To display the details of the verification results, click Verification > Result details.

Compare Mode
Result details

s page contain thels of non-conformities and iformation that have been ontrol Enginesring -

Rules Set Messages for the rule(s) "Structure”

CED A Warming

P ol CXEDD (A3

5 Coding Rules XD ‘A3 ass%
5 Naming @)
Severiy Amount of messages Percent of al non-confimities Percent of al analyzed
Q eror 52 9455% 176%
Warning sas 1%
rbidden @)
£ 52- Avarabl s sorsted ont Search
[ 3 - Avariable should be written from o
5 4~ Aphysical o = Rule #ID Variable Locatior ‘Severity
5 56 DFBVFBS instances shou
~ d variables should be used {
Mode_auto Inititisation (FC1139) Qo
Descents n FC1L25)
£ 510 - SCADA Limitations @) Varible Mot_g_d (MWS) is writen from dferent rutines Mot.g.d Cycte_avatan (83)
5 Information @D
Varible Mot_g_m (MW4) s witen from different routnes  Mot_g.m Cyele_montant (F52) Qo

Selecting a rule to the left displays the corresponding messages to the right.

Search functions allow you to search for, for example, variables, locations in the
code or severity categories within messages generated by a selected rule.
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Verification Settings

Select Verification > Settings to open the verification settings for the selected
program.

For each program you can set the following:

+ Select a default rules file to be used with the EcoStruxure Control Expert
Plug-In for EcoStruxure Control Engineering - Verification, page 41.

» Forinvited users of a shared program, page 29:
o Enable and disable the possibility to update the rules files.
o Enable and disable the possibility to justify the results.

Overview Verification v Admin
Verification settings

Default rules file

Defining a default rules file allows you to pre-select the rules file to use when you run an analysis, or which file to use when running an analysis using the EcoStruxure Control Engineering - Verification plugin for EcoStruxure Control Expert

@ PLCChecker-standard-frgqr

Allow invited users of this application to edit or upload rules file (*gqr)
By defaul, the invited users can update the rules file, you can prevent them to do so with this setting
Allow invited users of this application to justify the results

By default, the invited users can justify the Verification messages, you can prevent them to do so with this setting =]
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Rules and Rules Files

Introduction

Rules Editor

The rules file is the file containing the rules used in the verification procedure. Only
the rules configured in the rules file specified for a given verification procedure are
applied.

A program can contain one or more rules files. However, only one of these rules
files is used in a given verification procedure.

A rule consists of two elements:

+ A type which defines the verification operation of the rule. For example, the
rule can focus on comments, or on computing certain statistics.

» Configuration attributes which configure the behavior of the rule. For
example, the attributes are used to select the elements to which the rule is
applied, to specify the type of message to be displayed when an error is
detected, or to set the number of messages to be generated.

The rules editor lets you customize attributes of rules.

The rules in a rules file can be updated using the rules editor.

In your program, select Verification > Rules set > Rules editor to open the rules
editor.

Select the rules file you want to edit by clicking Edit in the Action column of the
corresponding row.

Select the rules file to edit

Here is the list of the rules file in your program, please select the one that you want to edit.

Name Last change Last unsaved change Action
PLCChecker-standard-en-draftggr 2022-06-17 03:06:03 Mever edited m
PLCChecker-standard-en.ggr 2022-06-17 03:06:02 Mever edited m

The rules editor provides the following buttons:

— RULESFLE ———————————— — RULES

E\X@ﬁ'

PROPERTIES

SAVE PROJECT SAVE AS DROP UPDATES ADD RULE DELETE RULE

Buttons for the rules file:

+ PROPERTIES: Allows you to display the properties of the rules file currently
being edited.

+ SAVE PROJECT: Allows you to save the modifications to the rules file. Until
the modifications are saved, they are stored in a temporary location.

« SAVE AS: Saves the rules file under a different name.

+ DROP UPDATES: Discards the modifications stored in the temporary
location.

Buttons for the rules of the rules file:
+ ADD RULE: Adds a new rule from a list of pre-defined rules.
« DELETE RULE: Deletes a rule from the rules file.

The tree view to the left contains the rules hierarchy. You can expand the tree to
navigate in the hierarchy.

EIO0000004424.04
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5 PLCChecker-standard-en.gqr
4 £ 1AS Generic rules file version 1.4

[ Hris Automation Square SVN ID:
i

P PLC

£ 1-PL7-Pro

o B

P 3-STEP7

5 4 - RSLogix 5000

7 5- CODESYS

77 6-STEPS

[ 7 - PLCOPEN

[
5 Sets definitions (invisible)
5 Dictionary
5 Coding Rules

Current GQR file informations
Author
Date

Version
Configuration attributes

2 - Unity Pro
Rule parameter
Enabled

Name

Variables

Treatments

developer@automationsquare.com
2021-09-15 14:08:00

25

Help

Parameter value Edition actions.

2 - Unity Pro

This attribute is empty

This attribute is empty

Selecting a rule displays the configuration attributes that can be modified.
Additional information on the rule is available in the Help tab.

Example of rule attributes that you can configure:

Cla - All program variables must be commented

Rule parameter Parameter value Edition actions
Enabled

Error Message Variable {VARIABLE} has no comment

Min Length 1

Name Cla - All program variables must be commented

Severity error v

-#PARAM_COPY-#EN_ENO-#ROCKWELL_MODULES_ELMT-#PARAM_IN_FB_S7
GRAPH-#PARAM_OUT_FB_S7GRAPH-#PARAM_STATE_FB_S7GRAPH

Variables

Treatments This attribute is empty

Max Length

No Match Message

After you have modified an attribute, the following buttons are displayed in the
Edition actions column of the attribute:

Clicking the button saves the modification to a temporary storage location, not to the
rules file. This means that the rules file itself is not yet modified and code verifications
v are still performed with the unmodified rules file.

value.

Clicking the button discards the modifications and resets the attributes to their original

Click SAVE PROJECT to save the modifications to the rules file. Then,
succeeding code verifications will be performed with the modified rules file.

NOTE: If you confirm a modification, this may imply that attributes of a
different rule are also updated. For example, enabling a rule may require
another rule to be activated as well. In such a case, a summary of the
modifications is displayed.

List of the Configuration Attributes

The rules editor allows you to configure the attributes described below. The
meaning of the attributes can vary depending on the rule type. Click the Help tab
to display additional information on an attribute.
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Attribute

Meaning

Special behavior

Enabled

Enables/disables a rule.

An enabled rule is only taken
into account if the parent rule is
also enabled.

The activation of certain rules
depends on the activation state
of other rules. In such a case,
the rule cannot be enabled
individually.

Name

Name of the rule, visible in the
rules trees, in the rules editor
and in the verification results.

Error Message

Message displayed when the
rule detects an error.

No Match Message

Message displayed when the
rule does not detect an error.

This message is displayed only
if no element in the program
can be selected by the rule for
analysis (for instance, if the
rule checks for the variables in
the program but no variable is
available in the program).

Severity Importance of resolving the The severity “nolog” allow you
errors reported by the rule. to suppress the generation of
an error message. However,
the match is still counted in the
statistics.
Min Length Minimum length of a verified The behavior depends on the
element in the program. rule type.
Max Length Maximum length of a verified The behavior depends on the

element in the program.

rule type.

In addition to these modifiable attributes, two non-modifiable configuration
attributes are displayed: variables and treatments. These two attributes explain
which set of elements in the program the rules are applied to.

Configuration of the Default Rules Files

The default rules files are organized in three main parts (their names depend on
the rules file language and may be different from the names in the present user

guide):

* |IAS Generic rules file version X.Y.Z: Contains the controller configuration
(the version number depends on the rules file that you are using)

« Sets definition: Contains several lists of the elements in the controller
application that can be matched by the rules

+ Coding rules: Contains the list of rules to be executed

If the objective of the configuration is to modify the controller to be verified with

EcoStruxure Control Engineering - Verification using this rules file, customize the
first part of the rules file (IAS Generic rules file version X.Y.Z). Modifications to
these elements may result in several modifications in the rest of the rules file
because certain rules depend on the controller type and cause the corresponding
rules to be enabled or disabled as well.

If the objective of the configuration is to update the messages, the severity or the
activation state of a particular rule, modify the last part of the rules file containing
the coding rules.

No action is required in the Sets definition part of the rules file.

EIO0000004424.04
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Adding a Rule

You can add a rule from a pre-defined list of rules and customize this rule. A rule is
added to the location in the rules hierarchy that is selected when you click ADD

RULE.

Procedure for adding a rule:

Step Action
1 Select a location in the rules hierarchy to specify where the new rule is to be added.
2 Click ADD RULE.
Result: EcoStruxure Control Engineering - Verification displays step 1 of the Rule
Creation Wizard.
3 Select the required rule.
A
Rule Parameter(s) Summary
Select the rule Customize the rule Summary of your rule
Name
4 [ Qther rules
[ The code written in Structured Text sl Variables should not be localized
S SFC steps do not contain programmes NS
A ‘Variable memory mapping should be reserved to variables whose
Fl Copy/Paste detection ratio elaboration or consumption is done outside the program :
Fl Define name prefixes for user defined communication tags, WO variables, spedal function variables, All
I Code of [DB] code class must be pres internal variables should not be localized.
I CPU configuration Detailed explanation : Using lacalized variables leads to constraints in
1 Identifiers: Using the standard {IEC) cl the ability of program evolution due to a strong ry organization. "
Validate And Next Step Close
4 Click Validate And Next Step.
Result: EcoStruxure Control Engineering - Verification displays step 2 of the Rule
Creation Wizard.
Rule Parameter(s) Summary
Select the nule Customize the rule Summary of your rule
This rule needs to be parametrized in order to be used in the rules file. These parameters are required for the rule to be instancied
correctly. Some of them may not be updatable once the rule is inserted inside the Rules file.
id* rule identifier eg: C1
5 Configure the customizable elements of the rule displayed in step 2 of the Rule
Creation Wizard.
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Step Action

6 Click Validate And Next Step.

Result: EcoStruxure Control Engineering - Verification displays step 3 of the Rule
Creation Wizard.

Rule creation

Rule Parameter(s) Summary
Select the rule Customize the rule Summary of your rule

Name Rule parameter(s)

id tost-
id

Variables should not be localized
Documentation

Variable memory mapping should be reserved to variables whose elaboration or
consumption is done outside the program : communication tags, /O variables,
special function variables, Allinternal variables should net be localized,

Detailed explanation : Using localized variables leads to constraints in the ability
of program evolution due to a stronger memory organization. It reduces
portability as memory organization is varying from one PLC to another. So the

v

S R S ST SO [ E S TR O

e Close

7 Review the summary and confirm with Add Rule or click Previous Step if you want to
make modifications.

NOTE: You can modify the order of your rules with the "Drag and Drop"
function, if needed.
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Justifications for Exceptions

EcoStruxure Control Engineering - Verification generates a message for each
non-conformity with a rule it detects. However, there may be conditions in which
the choice of code was made for a valid reason and is not to be flagged for
improvement, for example, code on which the developer has no impact or code
relating to specific technology that cannot be implemented in a different way. In
such cases, you want to define a justified exception.

EcoStruxure Control Engineering - Verification provides a mechanism referred to
as Justification that allows you to ignore the corresponding message.

Procedure for removing a message from the list and entering a justification for the

exception:
Step Action
1 In your program, select Verification > Results details.
2 Select the checkbox of the message.
3 Select Actions > Justify.
4 Enter the reason for the justification.
5 Click Send to confirm the justification.

NOTE: To display a list of the justifications, their reasons and their authors,
select Verification > Justification in your program. You can remove an
exception and the justification by selecting Actions > Delete in this list view.
As a result, the corresponding message is generated again the next time you
run EcoStruxure Control Engineering - Verification.
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EcoStruxure Control Expert Plug-In for EcoStruxure
Control Engineering - Verification

General Information

The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification is designed for use with the software development environments
EcoStruxure Control Expert and Unity Pro.

The plug-in allows you to launch a verification procedure from within the software
development environment. The code is automatically exported and uploaded for
verification. The verification results are displayed in a special view in the plug-in. A
“back-to-source” feature in the plug-in allows you to navigate directly to the
corresponding location in the code highlighted by the message.

Compatibility and System Requirements

The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification is compatible with the following versions of EcoStruxure Control
Expert and Unity Pro:

* Unity Pro: From version 8.2 to version 13.1
» EcoStruxure Control Expert: From version 14 to latest supported version

The EcoStruxure Control Expert plug-in requires access to EcoStruxure Control
Engineering - Verification, either in the cloud or on the dedicated server of your
organization.

Download and Installation

The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification is available by clicking SUPPORT > DOWNLOADS.

Follow the instructions during the installation. Compatibility with your software
development environment is verified during the installation.

After the installation, the menu item EcoStruxure Control Engineering -
Verification for EcoStruxure Control Expert is available on the Tools menu:

iew  Tools PLC  Help

4

F [@ Types Library Manager... (=

— | Dtm Audit Tool... =

Customize...

Cintinne

EcoStruxure Control Engineering - Verification for EcoStruxure Control Expert..,

Program Configuration

The EcoStruxure Control Expert plug-in for EcoStruxure Control Engineering -
Verification requires a program to execute the code verification and return the
results to the plug-in.

The program contains the information on the controller/development environment
that is used to develop the controller application, on the rules file to be used for the
verification, and on the licences used with EcoStruxure Control Engineering -
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Verification. Refer to Program Creation Wizard, page 25 for details on creating
and configuring a program.

Certain licenses for unlimited usage do not require the configuration of a license. If
you do not have an unlimited licence, specify your license in step 3 of the program
creation wizard or thereafter select Admin > Licenses > Actions > Associate
new license in the program view.

Refer to Verification Setting, page 34 for details on setting the default rules file and
setting the sharing options.

Share the 6-digit program key with the collaborators who are to use EcoStruxure
Control Engineering - Verification through the plug-in.

Working with the Plug-In

In EcoStruxure Control Expert, compile your controller application and select
Tools > EcoStruxure Control Engineering - Verification for EcoStruxure
Control Expert.

If you have not assigned the EcoStruxure Control Expert controller application to a
program in EcoStruxure Control Engineering - Verification you are prompted for
the 6-digit program key:

Set Program Key Pt

Program Key : ‘

Each program analyzed by PLC Checker shall be associated with a unique & characters
key. This key comesponds to a designated PLC CPU usage right. It is associated with the
Control Expert or Unity project. i you are starting a new project from an existing one that
had previously been associated with a 6 character key, please enter a new one.

horer

After you have entered the 6-digit key, the plug-in attempts to contact EcoStruxure
Control Engineering - Verification. If you are not authenticated, a new screen is
displayed that allows you to provide a custom proxy configuration. Use this screen
if your organization uses a proxy for outgoing Internet traffic (the required
information to be provided is available from your administrator). After that, you are
prompted for your credentials. You can modify these settings by selecting ? >
Preferences.

The first time you are authenticated, a verification is started. The progress bar at
the bottom of the screen provides details:

Glips semantic check - Analyze entity unity_lib.max_word

The next time you log in, you can start the verification manually by selecting
Actions > Launch analysis.

When the verification is complete, the results are downloaded from EcoStruxure
Control Engineering - Verification and displayed on the plug-in screen.

You can also display the latest results on the EcoStruxure Control Engineering -
Verification server by selecting Actions > Get remote last results. If the results
have already been downloaded to your local PC, you can display them by
selecting Actions > Display local results. The local results may not reflect the
latest results available on the EcoStruxure Control Engineering - Verification
server, for example, because another member of your team has performed a
verification after you have downloaded your results to your local PC.
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The results are displayed in a table:

Results Rules Set  Justfications  History

<

id
113a
Cla
S7a
Cla
S7a
Cb
N2e
Cib
N2e
Cib
Cla
S57a
Cla
S7a
Cib
Cla

s message | severity

The POU MAST _section main is called 1times

Variable ECPU_HSBY_1 has no comment

Variable ECPU_HSBY_1is not used

Variable BMEP58_ECPU_EXT has no comment

Variable BMEP58_ECPU_EXT is not used

Type at unity_hardware BusRIODIO has no comment

Type unity_hardware XBusM580_BMEXBP0800_BMEHS584040 name is longer than required
Type at unity_hardware XBusM580_BMEXBP0800_BMEH584040 has no comment

Type unity_hardware XBusM580_BMEXBP0800_BMXCPS4002 name is longer than required
Type at unity_hardware XBusM580_BMEXBP0800_BMXCPS4002 has no comment

Variable XBusM580_BMEXBP0800.BMXCPS4002_has no comment

Variable XBusM580_BMEXBP0800. BMXCPS4002_is not used

Variable XBusM580_BMEXBP0800 BMEH584040_ has no comment

Variable XBusM580_BMEXBP0800 BMEHS584040_is not used

Type at unity_handware XBusM580_BMEXBP0B0D has no comment

Vanable XBusM580 BMEXBP0800_ has no comment.

Columns in this table:

waming
efmor

waming

variable

ECPU_HSBY_1
ECPU_HSBY_1
BMEPS8_ECPU_EXT
BMEP38_ECPU_EXT

XBusM580_BMEXBP0800.BMXCPS4002_
XBusM580_BMEXBP0800.BMXCPS4002_

XBusM580_BMEXBP 0800 BMEH584040_
XBusM580_BMEXBP0800.BMEH584040_

XBusM580 BMEXBP0300_

id: Identifier of the rule that generated the message

message: Generated message

location

Database-ECPU_HSBY_1
Database-ECPU_HSBY_1
Database-BMEP58_ECPL
Database-BMEPS8_ECPL_

severity: Severity of the message (for example, “error” or “info”) as defined in
the rules file

variable: Name of the variable that matched the applied coding rule

location: Location in the code where the coding rule is not respected

address: Topological address of the variable that matched the applied coding
rule

You can jump to the location in your code where the highlighted elements are by
right-clicking a message and selecting Display Data Editor or Display Code
Editor, depending to the kind of the element.

You can set non-conformities as exception and create an appropriate justification
by selecting Justify exceptions.... Refer to Exceptions and Justifications, page
40 for details. You can select multiple messages to be justified in a single step.
However, this is only possible for messages triggered by the same rule.

From within the corresponding tabs in the plug-in, you can also display the rules
file, the program history and list the justifications of the program in EcoStruxure
Control Engineering - Verification.
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Limitations of the Free Trial Version

If the verification has been performed with a free trial license of EcoStruxure
Control Engineering - Verification, the results are limited as shown in the following

list.
Functionality Trial version Paid license
Result details summary Limited No license limitations
Number of messages per Limited to 2 No license limitations
rule
Rules set visualizer Included Included
Message justifications Included Included
Comparison of results Unavailable Included
between program versions
Download results list (for Unavailable Included
import into Microsoft Excel)
Download result details as Unavailable Included
PDF
Download rules set Unavailable Included
documentation as PDF
Program versions Unavailable Included
comparison as PDF
Online rules editor Unavailable Included

The functions that are not available or limited are highlighted on the Verification
tab of your program:

Verification v

Dashboard @I

Result details

Justification

Rules set LT

Settings

Report (5 E

Licensed version features

User Awareness »

e Trial: Limited results

« Unavailable: Function is not accessible

* No indication: No license limitations
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You can upgrade to a paid license to get the full functionality of your program.

EIO0000004424.04

45



Manufacturer-Specific File Export Procedures

Manufacturer-Specific File Export Procedures

EcoStruxure Control Engineering tools use the source code files of controller
applications as input files. These files are exported from the corresponding
software development environments. The following sections provide information
on generating these export files in various software development environments.

EcoStruxure Control Expert (.XEF / .ZEF File Export)

Export the EcoStruxure Control Expert (formerly Unity Pro) controller application
to an XEF or a ZEF export file in order to be processed with EcoStruxure Control
Engineering tools.

To export the file, you can use the EcoStruxure Control Engineering Import/Export
tool. Select SUPPORT > DOWNLOADS.

It is also possible to export the files using the EcoStruxure Control Expert menu:

Step Action
1 From the menu, select File > Export application....
2 In the Export application... dialog box, provide a name for the XEF or ZEF file.
3 If required, modify the storage location for the XEF or ZEF file.
4 Click Save.
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EcoStruxure Machine Expert (.EXPORT File Export)

Export the EcoStruxure Machine Expert controller application to an XML export
file (with the extension .export) in order to be processed with EcoStruxure Control
Engineering tools.

Procedure:
Step Action
1 From the menu, select Project > Export....

| Project | FBD/LD/IL  ETEST  Build

-'_::I

o -

5 @

Add Object

Add Folder.

Scan For Devices...
Update Device...
Online Config Mode...
Edit Object

Edit Object With..
Add Module...

Set Active Application

Project Information...

Project Settings...

Open “Update Project” dialog..,

Project Localization

Document...
Compare...
Commit accepted changes

Compare with device...

»

1

Export...

Import...

Export PLCopenXML...
Import PLCopenxXML...
Import of motion profiles

User Management

Mass Storage (USB or SDCard)...

You can export particular objects or a full tree. From the tabs in the Export dialog,

select the objects to be included in the export file.

EIO0000004424.04
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Step

Action

Export X

Please select the objects which are to be exported:
Devices POUs
=3 Untitled? v A
- @ Controller (TM241C24R)
= [ PLC Logic
= £ Application
= ) DOCRS
iH poor (F8)
] poors_cTrL (FUN)
B Ls_sensor (B)
= ) VALVES
[@) vaLve (Fe)
B vaLvEs_cTRL (FUN)
] w_sensor (F8)
@ on
m Library Manager v

[[] One file per subtree

Storage version:
V18.2.3.0 ~

5] o

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
EcoStruxure Machine Expert version that you select from the dropdown list
Storage version. To re-import the file, this EcoStruxure Machine Expert version is
used.

Click OK and provide a file name and a folder name as prompted.

Click Save.
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PL7 Pro (.FEF File Export)

Export the PL7 Pro controller application to an FEF export file in order to be
processed with EcoStruxure Control Engineering tools.

Procedure:
Step Action
1 From the menu, select File > Export application....
2 In the Export application... dialog box, provide a name for the FEF file.
3 If required, modify the storage location for the FEF file.
4 Click Save.

EIO0000004424.04
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3S CODESYS V3 (.EXPORT File Export)

Export the CODESY'S V3 controller application to an XML export file (with the
extension .export) in order to be processed with EcoStruxure Control Engineering

tools.

Procedure:

Step

Action

1

From the menu, select Project > Export....

File Edit View | Project | Build Or
21 Add Object Y
) Add Folder...

Scan For Devices...

Update Device... L
Edit Object
Edit Object With... 3 (¢
Online Config Mode...
Set Active Application
H Project Information...
¢ Project Settings... nit
Project Environment... r(f
Project Localization r

uT

& Document...
1 Compare... M
Commit accepted changes
| Export...
Import...
Expart PLCopenXML...
Import PLCopenXML...
User Management 4

You can export particular objects or a full tree. From the tabs in the Export dialog,
select the objects to be included in the export file.

Export X

Please select the objects which are to be exported:
Devices POls  Modules
=& Compressor
= [ (@ CODESYS_Control_RTE_V3 (CODESYS Control RTE V3)
=-[v] B PLC Logic
= [ € Application

=  Generic Units
Compression_Unit (FB)
Pressure_Sensor (FB)
@ Compression_Units
i Library Manager
Compressor_State_Manager (FUN)

[]one file per subtree

Storage version:
;| | CODESYS V3.5 SP12 Patch 1 >
g

e

NOTE: The checkbox One file per subtree allows you to generate separate
export files for the selected subtrees. You can export the file with a specific
CODESYS version that you select from the dropdown list Storage version. This
version is then used to re-import the file in CODESYS. If you work on CODESYS
V3 code, select a version from the version 3 family (CODESYS V3 ...).
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Step Action
3 Click OK.
4 Provide a file name and a folder name as prompted and click Save.
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3S CODESYS V2 (.EXP File Export)

Export the CODESY'S V2 controller application to an EXP export file in order to be
processed with EcoStruxure Control Engineering tools.

(with the default settings, a selected item has a blue background), then click OK.

Step Action
1 From the menu, select Project > Export....
_File Edit Project Insett Extras Online Window Helg
Blz|E  Buid =
———  Rebuildall 1
jm Clean all
E:‘ EE Load download information...
=[] Object ’
o B Project database 4
B3 vVa
..... = Options...
_____ E:'-' Translate into other languages ’
£] wil Document...
Export...
Import...
Siemens Import ?
Merge...
Compare...
Project Info...
Global Search...
flahal Danlara
2 In the Export Project dialog box, select the objects to be included in the export file
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Step Action
Export Project X
Cancel |
DOOR [FB]
DOOR_ACTIONS_CTRL (FUN)
CTION_CTRL (FUN)
TRL (PRG)
{SOR [FB)
™ One file for each object
3 Click OK and provide a file name and a folder name as prompted.
4 Click Save.

EIO0000004424.04

53



Manufacturer-Specific File Export Procedures

BECKHOFF TwinCAT V3 (.XML File Export)

Export the Beckhoff TwinCAT controller application to an XML export file
(PLCopen) in order to be processed with EcoStruxure Control Engineering tools.

Step Action

In the Solution Explorer window, select the project.

Fie Edit View Project Buld FDAD/L Debug TwnCAT PIC Tools Scope Window Help

jep_project - Microsoft Visual Studio

T PUMP MANAGMENT (PRG)
) Super PUMP 55

1S RUNNING
W voiture (58

- SIENE
D819 0 L] ) [reeme -|[twincaTRT 060 -1\ uobjecinder
a8 g RE|e |- -l xeeic | =g
Souion ot e
= e .sump.stie asieien 5 an
L mnc varitle A e Swpe  Address Loation Comment
pYs PR SNAGHENT  ALpae_ste Decaen 000L Leat sy
. PP MANAGUENT  Lpup_ste e oot Leal [iyE—
= el Types
= References
25 Cause (ENUMD)
2 Direcion ENUM)
% STATE ENUM)

o e X PROGRAM PUMP_MANAGNENT
7 scope Name Address Datatype Initalization Comment Atributes ~0
2 v pump state eooL
2 VA THM L pump_started so0L M
mon_bool1 ma_sortie_bool

N Ci00% v

Fle Edit View Project Buld

FBDADAI

Right-click the project and select Export PLCopenXML....

L Detug TWnCAT PLC Tools Sope Window Hielp
D

QS Dk BIE -
)-ionc 3 =dl ED) u
X

jep_project - Microsoft Visual Studio

S -

|| ToincaT AT 66y -8 |uobjecingex

TR Scope: PUMP_MANAGHENT g
~ Variabie ccess Type Swope  Addies  Location Comment
POV ANAGHENT L. st Dsiewen  BOOL Lasa Line3 pse)
PUMP JANAGUENT  l_pomo.stte e BooL Laso -
SRS 5 gy
& our
e Rebuid
o0 Checkal objects .
S dean
s mow
oq A ,
+ 2 p0U [ Import PLCopenthL
06 g
B ExportPLCopenL.
5
d  smeastiay,
b sseastirayns ———— =
X [Remors el i PROGRAM PUMP_MANAGMENT
@ Properies AvEre | scope Address Datatype Intalzation Comment  Atrbutes Y=l
5y e ViR _pump_state eooL
001 FUN) 2 VAR THM_f_pump_started so0L .
+ T S 5
AT -
& ERROR R B
B GeroTaTe =oe pooty PR —
i STAKT t )
B PUMP MANAGMENT (PRG) -
+ 0 Super PUMP FB) i
5415 RUNNING =

Click Save.

0 Microsoft Visua Studio 2010

E jcp_project

Py Export PLCopenXML File

@ o - 1 M cercr v C|  Rechercher dans: CepC 2
Organiser -

- Microsoft Visual Studio

hdtess Locaton Comment
oo sy
s —
T
IR docmens
R iporan f
[ & cerc
473 Bibliothéques. b images
Dacuments ~
< mages
& Musiaue u} Musique
Nom uicir: X PGt E
Type: PLCopenXML s (i) > PUMPERROR  PUMP  PUMPGETSTATE  POL1  jcp  Super PUMPISFUNNING  MOTO
= Masuerts dossiers e | e s comnen v -0
3
o0 v M _punp_sanea w00t v
P . >
Bac =
(5 ERROR
Sicersia ae_sertic_bost
I ]
@ PP MANAGUENT 0% .
+ 3] Super PUMP 8) i Iﬁ 11 pump state | | 4
TE o
y— Shm_£113 s dicecrion
N[+ T100% &V

Bureau
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PHOENIX CONTACT Multiprog v5.5 (.XML File Export)

Export the MULTIPROG controller application to an XML export file in order to be

processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Export....

File| Edit View Project Build Online Extras

D| New Project... CTRL+N
3 @j| Open Project / Unzip Project.. CTRL+0O
5 Save Project As / Zip Project As...

o o2 [

-

;-\m Close Project
S<| Delete Project...

Save As Template...
Delete Template...

As Network Ter

53

m
;]J

Export...
Import...

Enter password...

m
}
’

1oL
[¥5)

i

ave All

i}

Print Setup...
Print Project...

2 Select Export PLCopen xml file.

Import / Export X

Extended [ECB1131-3 Export | Ok |

Cancel

Description:

Export in PLCopen xml format.

3 Provide a name for the export file.

4 Click Save.

As MULTIPROG can export the controller application in different versions of
PLCopen, there may be differences in the way your EcoStruxure Control
Engineering tool processes the export file, depending on the PLCopen version.

EIO0000004424.04

55




Manufacturer-Specific File Export Procedures

Rockwell Automation® RSLogix 5000® or Studio 5000 (.
L5K File Export)

Export the Rockwell Automation® RSLogix 5000® controller application to a L5K
export file in order to be processed with EcoStruxure Control Engineering tools.

Step Action

1 From the menu, select File > Save as....

2 In the Save as... dialog box, provide a name for the L5K file.

3 If required, modify the storage location.

4 Select the file type: RSLogix 5000 Import/Export File (*.L5K).

5 Click Save.
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Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File

Export)

Overview

The following steps are required to process a Siemens SIMATIC STEP 7
controller application with EcoStruxure Control Engineering tools:

Set your SIMATIC STEP 7 workshop to German abbreviations (mnemonics).

Create and export the symbols of the controller application to an .ASC file.
Create and export the contact code (CONT) to an .AWL file.

Create and export the graph blocks (GRAPH) to a .GRY files.

Compile the CFC code (if any) to create the corresponding SCL sources.
Export structural codes (SCL) to .SCL files.

Setting German Mnemonics

Before creating the export files, set your SIMATIC STEP 7 workshop to German
abbreviations (mnemonics):
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Manufacturer-Specific File Export Procedures

Step Action
1 From the menu, select Options > Customize....
B o A e S S el P T e 1
s Changelog L
L Text Libraries v (L
E Language far Display Devices.., E{
- 5
u Manage Multilingual Texts o
L Rewvire.., Cl
B Run-Time Froperties.., Cl
T Cl
E Compare Blocks.., Tl
T Reference Data kTl
d  Define Global Data Tl
T Configure MNetwork Tl
T Cl
En Simulate Modules E
£  Configure Process Diagnostics B
T ) B
g  Editsafety program B
Chy Data 3
Set PG/PC Interface...
2 Display the Language tab.
Custormize il
Gntm I teszage numbers I Archiving
| Language | General I Date and Time of Day I Wig
i — Mational Language —Mremaonics
I englizh
deutzch - % Geman JE1.D 5 A4.0
frangais  Engish  Al1.0 5040
espafiol
italiana
Cancel Help
3 Select German mnemonics.
4 Click OK.
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Creating an ASC File

Step Action

Insert  Wiew Options  Window Help

1 Right-click the symbols table in your program folder and select Open object.
% Ecluzel Object name | Symbalic name | Tupe
E‘" M“: DD[” (B Sources Source Folder
i
----- {£H Blocs

Cut Chrl+X
Copy Ctrl+C
Paste Crl+4
Delete Del
PLC »
Print 3
Renarne F2
Object Properties.., Aft+Return
Special Object Properties ]

2 From the menu of the symbols editor, select Symbol Table > Export....

ar Ctrl +0 j_
Close Ctrl+F4

EN Sawve Ctrl+5 Prm
£ |
3 |

4

—
El

Exmmmiiom CH+F war

|8 | Print Preview... wer

|9 | Page Setup... it

1 rtir

3 Select ASCII Format (*.ASC).

IS_l,lmbols. azc

|ASCIl Format [~45C)
| !

* Data Interchangé Farmat [*.DIF)
Swyztem D ata Format [ SDF)
2940 [".A5C," SEQ,".DIF,". SDF)

4 Provide a name and select a directory for the .ASC export file.

5 Click Save.

Creating an AWL File

To create an .AWL file, first generate the LIST source for the code blocks
developed in the languages CONT, LIST and LOG.
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Step Action
1 Right-click a CONT, LIST or LOG source and select Open Object to open the CONT/
LIST/LOG code editor.
E--% Ecluzel Object name | Sembolic name | Created in
E-ER SIMATIC 300(1) : i
=-[@ cPuI4c2oP
El{z5] Programme 57(1] |, £ Ctrl +8lt+0
F = =S
B F Cut Ctrl+X S0l
oF Copy Ctrl+C .
oOF Paste Chr+1f oL
OF Delete Dl sCL
i F S5TL
A Insert Mew Object | STL
3F FLC b | STL
i F ) S5TL
o F Rewvire... 5oL
o0l Compare Blocks.. DE
0D Reference Data » | DB
oD Print R LB
@ M DB
Rename F2
Object Properties.., Alt+Return
Special Object Properties 4
2 From the menu, select File > Close to close all open objects.
Edit Insert PLC Debug View Options ‘Window Help
T e, Ctrl+M
| Open.. Ctrl+0
- i kL TRIC i
B Ctrl+F4
£ Save Ctrl+5 1
£ Sawe A,
B Store Read-Only ...
£
Properties...
b Check and Update Accesses
Check Consistency Ctrl +AlE+k
Compile Ctrl+E
Generate Source.., Ctrl+T -
Print... Ctrl+P -
Print Presiew..,
Page Setup...
3 From the menu, select File > Generate source... to generate the program source.

jewy  Options  Help

Ctrl+M
Ctrl+0

Chrl+T
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Step Action

4 Provide an object name and click OK.

Entry pairt: Wigt:

IProiect ;I IEomponent wiew LI  Online & Offline

Mame: Storage path:

IEcIuse1 ;I I | Browse... | I?
E--% Eclusel code_ladder zection_laddder

E-EJ SIMATIC 300(1)
=-§ crustac2oP
E@ Programme 57(1]

{B] Sources
% Blocs
. | |
I Obiect name:  [CONT_LIST_LOG] 1
Dbiect type: ISTL Source ;I
5 Click All to select all program blocks and select the options Sort according to

program structure and Symbolic addresses.

MHate: Autornatic generation of single sources per block:
tenu 'Options' » "Customize’ in the "Sources' tab

Path: EcluselSIMATIC 30001 NCPU 314C-2 DP...
Blocks Mot Selected: Blocks Selected:

I arne/F amily:
[ User created F-FBs, F-FCs and F-DEs —Addreszes
v |nclude reference blocks [

W Sart according to program structure {* Sumbalic

Source containg checksum of the blocks

QK. | Cancel Help

6 Click OK to confirm.

If your controller application contains safety-related blocks, export those blocks in
a separate AWL file. Refer to Safety-Related Applications, page 64 for details.

Creating a GR7 File

The .GRY7 sources have to be created for each GRAPH blocks separately. Repeat
the following procedure for each GRAPH block to be exported.
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Step Action
1 Right-click a GRAPH object and select Open Object.
Lommande
SCL
Copy Ctrl+C -
Paste Chrl +4 0L
Delete Del STL
STL
Insert Mew Object » STL
PLC 3 5TL
] SCL
Rewvire.., OB
2 From the menu, select File > Generate Source File.
Edit Insert PLC Debug View Options ‘Window Help
M e, Ctrl+M |
Open... Ctrl+0
Claose
Sawve Ctrl+5
Sawve D,
Properties...
Consistency Check Ctrl + 21t +K
Cormpile Ctrl+B
MuodifyfAdapt Instance DB Mumber...
Ctrl+T
ML e et o
Print... Ctrl+P
Print Prewviews..,
Page Setup...
3 Provide a name for the GRAPH object.
Entry paint: Wigw:
IF‘miect j IComponent wiEw j  Orline & Offline
Mame: Starage path:
IEcIuse1 j I Browse... | L_ =
- Eclusel
E-E# SIMATIC 300(1)
= cPU 31aC2 0P
=8 Programme S7(1]
| |
Object name: |GrapH I
Object type: Imce j
Cancel Help I
4 Click OK to confirm.
5 Repeat the procedure for each GRAPH object to be exported.
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Creating a CFG File

The CFG file is required for analyzing the communication and the hardware
configuration of the station.

Step Action

1 Double-click your CPU's links in the main window to open NetPro.

2 In the NetPro window, double-click the CPU of the station to be exported open the HW
Config utility.

3 From the Station menu, select Export... to export your station configuration (leave the

default settings in the dialog).

4 If the controller application contains CFC code, compile the code to generate the
corresponding SCL source files which are the files processed with EcoStruxure Control

Engineering tools. To do so, open the CFC code editor by clicking its icon in the toolbar
of the main window .

SHcrc [ ] _[al x|

[ chart Edt Insert CPU Debug View Options Window Help -1

DEs s e mEEe| s a8 w2 g B0k esBEm N

) New Chart =
New Text
& All blocks
its.. i

I~ Find iniialletter

£l WY g KN —

Press F1 for help =

szl

[&/5hest 6 [OB1
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Step Action

click OK.

CPL:

Proaram narne:

— Srane

Compile the code with the options Entire program and Generate SCL sources and

Compile program

Carpile Chartz az Program |

CPU 313-3 PN/DP
MP345CPU 319-3 PMADPYS Y Programm

x|

| %' Entire program
‘ {~ Changes only

¥ Generate module drivers

¥ Generate SCL source

Black Driver Settings. ..

Cancel Help |

Object name

The generated SCL source file can then be exported like other source files (refer to
Exporting Files, page 68).

| Symbalic name

| Type

DET1_Alam_DE
MP34_C

ample

be

STL Sourc
STL Sourc

Zipen Object Chrl+Al+0
Cut Chrl+
Copy Chrl+C
Paste el
Delete Del

Insert Mew Object
PLC

p= T

Lo

Rename
Ohject Properties. ..
Special Cbject Properties

F2
Ale+Return

Safety-Related Applications

A safety-related controller application contains two code parts:

* The non-safety
* The safety-rela

-related code part
ted code part

Procedure for exporting controller applications that contain safety-related code:

Step Action
1 Export the .ASC file that contains the database for the safety-related code and for the
non-safety-related code (refer to Creating an ASC File, page 59).
2 Generate the sources for the non-safety-related code parts (refer to Creating an AWL
File, page 59 and Creating a GR7 File, page 61).
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Step Action

3 Click All to select all program blocks and select the options Sort according to
program structure and Symbolic addresses.

MHate: Autornatic generation of single sources per block:
tenu 'Options' » "Customize’ in the "Sources' tab

Path: EcluselSIMATIC 30001 NCPU 314C-2 DP...
Blocks Mot Selected: Blocks Selected:

I arne/F amily:
[ User created F-FBs, F-FCs and F-DEs —Addreszes
v |nclude reference blocks [

W Sart according to program structure {* Sumbalic

Source containg checksum of the blocks

QK. | Cancel Help

4 Click OK to confirm.

5 Follow the procedure for Creating an AWL File, page 59 until the dialog Generate
source Safety is displayed.
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Creating a dif File

Step Action
6 Select the option User-created F-FBs, F-FCs and F-DBs and click OK to confirm.
Generate source Safety ﬂ
MHate: Autoratic generation of single sources per block:
tenu 'Options' > 'Cugtomize’ in the 'Sources' tab
Path: Eclusel“SIMATIC 300(1MCPU 314C-2 DPA...
Blocks Mot Selected: Blocks Selected:
Safety Block
<...
I arne/F amily:
Iv User created F-FBe, F-FCs and F-DEBs Addresses
| " Absolute
[# * Symbolic
[~ Source containg checksum of the blocks
QK. Cancel Help
7 Create a .dif file (refer to Creating a dif File, page 66). The .dif file is used to determine
whether code is safety-related.

A .dif file is created in the SIMATIC Manager of SIMATIC STEP 7 in the following

way:
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Step Action
1 From the menu, select Options > Reference Data > Display.
B find oy Help
ustomize... Ctrl+Alt+E ;I Wy | BE EH
#ieesg Medeebio i’ reated in language | Size in the
Change Log 2
Text Libraries v iTL
Language far Display Dewvices.., EHLAF'H
Manage Multilingual Texts 4
Rewvire... CL
Run-Tirme Properties...
Reference Data Ctrl +8/t+R
Define Global Data
Confi Metwork
onfigure Metwor Generate
Sirmulate bModules
. . ) Delete
Caonfigure Process Diagnostics
=
Edit safety program B
Chu Data v 1B
B
Set PG/PC Interface..,
2 In the Display S7 reference data dialog, select the option regenerated? and click Yes.
& Should the reference data be ..
" ypdated?
Yes Mo | Cancel Help
3 In the Customize dialog, select the option Program Structure and click OK to display

the program structure.

—*iew to Be Opened

 Cross-references

fesignment oot Clutput, Bit Memnary, Timers, Counters)

& Program Stucture

Unuszed Symbols

" Addreszes without Symbal

v Display this message every time a project is opened,

oo |

EIO0000004424.04

67
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Exporting Files

Step Action
4 From the menu, select View > Export to open the Save dialog box.
Reference Data  Edi indows  Help
34 rass References 5
= & © ]
Assignment —
v Prograrm Structure
Unused Symbaols
Addresses without Syrmbol
Block (symbol) Cross References for Address ocal
=-1 S7 Prograd
= D DRl |::'| )
FC1 Filter...
® DBL(CI <. ]
® DB2(C ]|
® DB3 (Tl v Toolbar 0]
® DB4 (Cl v Status Bar o]
™ FC2 (A 2]
B FCa (M Update Fa 2]
L = T e T T2
5 Provide a name for the .dif and click Save.

After you have created the files, export them from SIMATIC STEP 7:

Step Action
1 Select the LIST, GRAPH (or .AWL and .GRY7 files) and SCL sources that you have
generated.
2 Right-click the sources and select Export source....
% File  Edit Insert PLC View Options Window Help
D 276 | 4 R |da|o %20
EI--% Eclusel Object name Symbalic harne Type
= SIMATIC 30001) P
EI CPU 31402 DP Open Chject Ctrl+21t+0
T2 'k Cut Ctrl+X
Copy Ctrl+C
Paste Chrl +4
Delete Del
Insert MNew Object 3
PLC 3
Print 3
Special Object Properties »
3 Select a file name and a storage location and click Save.
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Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export)

Export the Siemens TIA Portal SIMATIC STEP 7 controller application to a ZIP

export file in order to be processed with EcoStruxure Control Engineering tools.

The export can be performed automatically with the EcoStruxure Control
Engineering - Import/Export tool. Select SUPPORT > DOWNLOADS.

Refer to the EcoStruxure Control Engineering - Import/Export user guide for
details on the export procedure.

EIO0000004424.04

69



Schneider Electric

35 rue Joseph Monier
92500 Rueil Malmaison
France

+33(0) 141297000

www.se.com

As standards, specifications, and design change from time to time,
please ask for confirmation of the information given in this publication.

© 2023 Schneider Electric. All rights reserved.
EI00000004424.04



	EcoStruxure™ Control Engineering Verification 
	Safety Information 
	Before You Begin 
	Start-up and Test 
	Operation and Adjustments 

	About the Book 
	Introduction to EcoStruxure Control Engineering - Verification 
	Registration, Login, My Account, Licenses and Sessions 
	Registration 
	Login 
	My account Page 
	Licenses 
	Sessions 

	Creating Projects and Programs 
	Introduction to Projects and Programs 
	Creating Projects and Programs 
	Program Creation Wizard 
	Accessing a Shared Program 
	Sharing Programs with Other Users 

	Verifying the Code of Controller Applications 
	Running a Verification of a Controller Application 
	Displaying Code Verification Results 
	Verification Settings 
	Rules and Rules Files 
	Justifications for Exceptions 
	EcoStruxure Control Expert Plug-In for EcoStruxure Control Engineering - Verification 
	Limitations of the Free Trial Version 

	Manufacturer-Specific File Export Procedures 
	EcoStruxure Control Expert (.XEF / .ZEF File Export) 
	EcoStruxure Machine Expert (.EXPORT File Export) 
	PL7 Pro (.FEF File Export) 
	3S CODESYS V3 (.EXPORT File Export) 
	3S CODESYS V2 (.EXP File Export) 
	BECKHOFF TwinCAT V3 (.XML File Export) 
	PHOENIX CONTACT Multiprog v5.5 (.XML File Export) 
	Rockwell Automation® RSLogix 5000® or Studio 5000 (.L5K File Export) 
	Siemens SIMATIC STEP 7 (.ASC, .AWL, .GR7 and .SCL File Export) 
	Siemens TIA Portal SIMATIC STEP 7 (.ZIP File Export) 



